
PART IV
Working with  
Data
In this part, you’ll find tips related to working with data of all types. There’s an 
excellent chance that the tips here will improve your overall efficiency.
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Selecting Cells Efficiently
Many Excel users think that the only way to select a range of cells is to drag over the cells with the 
mouse. Although selecting cells with a mouse works, it’s rarely the most efficient way to accomplish 
the task. A better way is to use your keyboard to select ranges.

Selecting a range by using the Shift and arrow keys
The simplest way to select a range is to press (and hold) Shift and then use the arrow keys to high-
light the cells. For larger selections, you can use PgDn or PgUp while pressing Shift to move in larger 
increments.

You can also use the End key to quickly extend a selection to the last non-empty cell in a row or col-
umn. To select the range B3:B8 (see Figure 53-1) by using the keyboard, move the cell pointer to B3 
and then press the Shift key while you press End followed by the down-arrow key. Similarly, to select 
B3:D3, press the Shift key while you press End, followed by the right-arrow key.

Figure 53-1: A range of cells.
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Selecting the current region
Often, you need to select a large rectangular selection of cells — the current region. To select the 
entire block of cells, move the cell pointer anywhere within the range and press Ctrl+A.

Note 	

If the cell pointer is within a table (created by using Insert➜Tables➜Table), pressing 
Ctrl+A selects only the data. Press Ctrl+A a second time to select the table’s Header row 
and Total row.

Selecting a range by Shift+clicking
When you’re selecting a very large range, using the mouse may be the most efficient method — but 
dragging is not required. Select the upper-left cell in the range. Then scroll to the lower-right corner 
of the range, press Shift, and click the lower-right cell.

Selecting noncontiguous ranges
Most of the time, your range selections are probably simple rectangular ranges. In some cases, you 
may need to make a multiple selection — a selection that includes nonadjacent cells or ranges. For 
example, you may want to apply formatting to cells in different areas of your worksheet. If you make 
a multiple selection, you can apply the formatting in one step to all selected ranges. Figure 53-2 
shows an example of a multiple selection.

Figure 53-2: A multiple selection that consists of noncontiguous ranges.

You can select a noncontiguous range by using either the mouse or the keyboard.

Press Ctrl as you click and drag the mouse to highlight individual cells or ranges.

From the keyboard, select a range as described previously (by using the Shift key). Then press Shift+F8 
to select another range without canceling the previous range selection. Repeat this action as many 
times as needed. When you’re finished, press Shift+F8 again to return to normal selecting mode.
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Selecting entire rows
To select a single row, click a row number along the left of the worksheet. Or select any cell in the 
row and press Shift+spacebar.

To select multiple adjacent rows, click and drag in the row number area. Or select any cell in the first 
(or last) row and press Shift+spacebar to select the row. Then press Shift and use the arrow keys to 
extend the row selection down (or up).

To select multiple nonadjacent rows, press Ctrl while you click the row numbers for the rows you 
want to include.

Selecting entire columns
To select a single column, click a column letter along the top of the worksheet. Or select any cell in 
the column and press Ctrl+spacebar.

To select multiple adjacent columns, click and drag in the column letter section. Or select any cell in 
the first (or last) column and press Ctrl+spacebar to select the column. Then press Shift and use the 
arrow keys to extend the selection to the right (or left).

To select multiple nonadjacent columns, press Ctrl while you click the column letters for the columns 
you want to include.

Selecting multisheet ranges
In addition to two-dimensional ranges on a single worksheet, ranges can extend across multiple 
worksheets to be three-dimensional ranges.

Figure 53-3 shows a simple example of a multisheet workbook. The workbook has four sheets, 
named Totals, Operations, Marketing, and Manufacturing. The sheets are laid out identically.

Figure 53-3: Each worksheet in this workbook is laid out identically.
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Assume that you want to apply the same formatting to all sheets — for example, you want to 
make the column headings bold with background shading. Selecting a multisheet range is the 
best approach. When the ranges are selected, the formatting is applied to all sheets.

In general, selecting a multisheet range is a simple two-step process:

	 1.	 Select the range in one sheet.

	 2.	 Select the worksheets to include in the range.

	

To select a group of contiguous worksheets, press Shift and click the sheet tab of the 
last worksheet that you want to include in the selection. To select individual worksheets, 
press Ctrl and click the sheet tab of each worksheet that you want to select. When you 
make the selection, the sheet tabs of the selected sheets appear with a white back-
ground, and Excel displays [Group] on the title bar. When you finish working with the 
multisheet range, click any sheet tab to leave Group mode.

Note
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Automatically Filling a Range with a Series
If you need to fill a range with a series of values, one approach is to enter the first value, write a for-
mula to calculate the next value, and copy the formula. For example, Figure 54-1 shows a series of 
consecutive numbers in column A. Cell A1 contains the value 1, and cell A2 contains this formula, 
which was copied down the column:

=A1+1

Figure 54-1: Excel offers an easy way to generate a series of values like these.

Another approach is to let Excel do the work by using the handy AutoFill feature:

	 1.	 Enter 1 into cell A1.

	 2.	 Enter 2 into cell A2.

	 3.	 Select A1:A2.

	 4.	 Move the mouse cursor to the lower-right corner of cell A2 (the cell’s fill handle), and when 
the mouse pointer turns into a black plus sign, drag down the column to fill in the cells.

Note 	

You can turn this behavior on and off. If cells don’t have a fill handle, choose File➜ 

Options and click the Advanced tab in the Excel Options dialog box. Select the check 
box labeled Enable Fill Handle and Cell Drag-And-Drop.

The data entered in Steps 1 and 2 provide Excel with the information it needs to determine which type 
of series to use. If you entered 3 in cell A2, the series will consist of odd integers: 1, 3, 5, 7, and so on.

When you release the mouse button after dragging, Excel displays an Auto Fill Options drop-down 
list. Click to select other options. The list of options is particular helpful with dates. Figure 54-2 shows 
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the Auto Fill Options when working with a date series. You can quickly create a series of weekdays, 
months, or years.

Figure 54-2: Use the Auto Fill Options drop-down list to change the type of fill.

Here’s another AutoFill trick: If the data you start with is irregular, Excel completes the AutoFill action 
by doing a linear regression and fills in the predicted values. Figure 54-3 shows a worksheet with 
monthly sales values for January through July. If you use AutoFill after selecting C2:C8, Excel extends 
the best-fit linear sales trend and fills in the missing values. Figure 54-4 shows the predicted values, 
along with a chart.

Figure 54-3: Use AutoFill to perform a linear regression and predict sales values for August through December.
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Figure 54-4: The sales figures, after using AutoFill to predict the next five months.

AutoFill also works with dates and even a few text items — day names and month names. The fol-
lowing table lists a few examples of the types of data that can be autofilled.

First Value Autofilled Values

Sunday Monday, Tuesday, Wednesday, and so on

Quarter-1 Quarter-2, Quarter-3, Quarter-4, Quarter-1, and so on

Jan Feb, Mar, Apr, and so on

January February, March, April, and so on

Month 1 Month 2, Month 3, Month 4, and so on

You can also create your own lists of items to be autofilled. To do so, open the Excel Options dialog box 
and click the Advanced tab. Then scroll down and click the Edit Custom Lists button to display the 
Custom Lists dialog box. Enter your items in the List Entries box (each on a new line). Then click the Add 
button to create the list. Figure 54-5 shows a custom list of region names that use Roman numerals.

Figure 54-5: These region names work with the Excel AutoFill feature.
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Fixing Trailing Minus Signs
Imported data sometimes displays negative values with a trailing minus sign. For example, a nega-
tive value may appear as 3,498- rather than the more common -3,498. Excel doesn’t convert these 
values. In fact, it considers them to be non-numeric text.

The solution is so simple it may surprise you:

	 1.	 Select the data that has the trailing minus signs. The selection can also include positive values.

	 2.	 Choose Data➜Data Tools➜Text to Columns.

	 3.	 When the Text to Columns dialog box appears, click Finish.

This procedure works because of a default setting in the Advanced Text Import Settings dialog box 
(which you don’t even see, normally). To display this dialog box, shown in Figure 55-1, go to Step 3 in 
the Text to Columns Wizard dialog box and click Advanced.

Or you can use Flash Fill to fix the trailing minus signs. If the range contains any positive values, you 
may need to provide several examples. See Tip 64 for information about the Flash Fill feature.

Figure 55-1: The Trailing Minus for Negative Numbers option makes it very easy to fix trailing minus signs in a 
range of data.
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Restricting Cursor Movement to Input Cells
A common type of worksheet uses two types of cells: input cells and formula cells. The user enters 
data into the input cells, and the formulas calculate and display the results.

Figure 56-1 shows a simple example. The input cells are in the range C4:C7. These cells are used by 
the formulas in C10:C13. To prevent the user from accidentally typing over formula cells, it’s useful to 
limit the cursor movement so that the formula cells can’t even be selected.

Figure 56-1: This worksheet has input cells at the top and formula cells below.

Setting up this sort of arrangement is a two-step process: Unlock the input cells and then protect the 
sheet. The following specific instructions are for the example shown in Figure 56-1:

	 1.	 Select C4:C7.

	 2.	 Press Ctrl+1 to display the Format Cells dialog box.

	 3.	 In the Format Cells dialog box, click the Protection tab, deselect the Locked check box, and 
click OK.

		  By default, all cells are locked.

	 4.	 Choose Review➜Changes➜Protect Sheet.

		  The Protect Sheet dialog box appears.

	 5.	 Deselect the Select Locked Cells check box and make sure that the Select Unlocked Cells 
check box is selected.

	 6.	 (Optional) Specify a password that will be required to unprotect the sheet.

	 7.	 Click OK.
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After you perform these steps, only the unlocked cells can be selected. If you need to make any 
changes to your worksheet, you need to unprotect the sheet first, by choosing Review➜Changes➜ 

Unprotect Sheet.

Although this example used a contiguous range of cells for the input, that isn’t necessary for the 
steps to work. The input cells can be scattered throughout your worksheet.

Note 	

Protecting a worksheet with a password isn’t a security feature. This type of password is 
easily cracked.

www.it-ebooks.info

http://www.it-ebooks.info/


Tip 57: Transforming Data with and Without Using Formulas 157

Transforming Data with and Without 
Using Formulas
Often, you have a range of cells containing data that must be transformed in some way. For example, 
you might want to increase all values by five percent. Or you might need to divide each value by two. 
This tip describes two ways to perform these types of transformations.

Transforming data without formulas
The following steps assume that you have values in a range and you want to increase all values by five 
percent. For example, the range can contain a price list and you’re raising all prices by five percent:

	 1.	 Activate any empty cell and enter 1.05.

		  You will multiply the values by this number, which results in an increase of five percent.

	 2.	 Press Ctrl+C to copy that cell.

	 3.	 Select the range to be transformed.

		  The range can include values, formulas, or text.

	 4.	 Choose Home➜Clipboard➜Paste➜Paste Special to display the Paste Special dialog box (see 
Figure 57-1).

	 5.	 In the Paste Special dialog box, click the Multiply option.

	 6.	 Click OK.

	 7.	 Press Esc to cancel Copy mode.

Figure 57-1: Using the Paste Special dialog box to multiply a range by a value.
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The values in the range are multiplied by the copied value (1.05), and cells that contain text are 
ignored. Formulas in the range are modified accordingly. Assume that the range originally contained 
this formula:

=SUM(B18:B22)

After you perform the Paste Special operation, the formula is converted to

=(SUM(B18:B22))*1.05

This technique is limited to the four basic math operations: add, subtract, multiply, and divide.

For more versatility, keep reading to learn how to use formulas to transform values.

Transforming data by using temporary formulas
The previous section describes how to perform simple mathematical transformations on a range of 
numeric data. This tip describes the much more versatile method of transforming data (numerical or 
text) by using temporary formulas.

Figure 57-2 shows a worksheet with names in column A. These names are in all uppercase letters, 
and the goal is to convert them to proper case (only the first letter of each name is uppercase).

Figure 57-2: The goal is to transform the names in column A to proper case.
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Follow these steps to transform the data in column A:

	 1.	 Create a temporary formula in an unused column.

		  For this example, enter this formula in cell C2:

=PROPER(A2)

	 2.	 Copy the formula down the column to accommodate all cells to be transformed.

	 3.	 Select the formula cells (in column C).

	 4.	 Press Ctrl+C.

	 5.	 Select the original data cells (in column A).

	 6.	 Choose Home➜Clipboard➜Paste➜Paste Values (V).

		  The original data is replaced with the transformed data (see Figure 57-3).

	 7.	 Press Esc to cancel Copy mode.

	 8.	 When you’re satisfied that the transformation happened as you intended, you can delete the 
temporary formulas in column C.

Figure 57-3: The formula results from column C replace the original data in column A.

You can adapt this technique for just about any type of data transformation you need. The key, of 
course, is constructing the proper transformation formula in Step 1.
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Creating a Drop-Down List in a Cell
Most Excel users probably assume that some advanced feature (such as a VBA macro) is required to 
display a drop-down list in a cell. But it’s not. You can easily display a drop-down list in a cell — no 
macros required.

Figure 58-1 shows an example. Cell B2, when selected, displays a down arrow. Click the arrow, and 
you get a list of items (in this case, month names). Click an item, and it appears in the cell. The drop-
down list can contain text, numeric values, or dates. Your formulas, of course, can refer to cells that 
contain a drop-down list. The formulas always use the value that’s currently displayed.

Figure 58-1: Creating a drop-down list in a cell is easy and doesn’t require macros.

The trick to setting up a drop-down list is to use the data validation feature. The following steps 
describe how to create a drop-down list of items in a cell:

	 1.	 Enter the list of items in a range.

		  In this example, the month names are in the range F1:F12.

	 2.	 Select the cell that will contain the drop-down list (cell B2, in this example).

	 3.	 Choose Data➜Data Tools➜Data Validation.

	 4.	 In the Data Validation dialog box, click the Settings tab.

	 5.	 In the Allow drop-down list, select List.

	 6.	 In the Source box, specify the range that contains the items.

		  In this example, the range is E1:E12.

	 7.	 Make sure that the In-Cell Dropdown option is checked (see Figure 58-2) and click OK.
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If your list is short, you can avoid Step 1. Rather, just type your list items (separated by commas) in 
the Source box in the Data Validation dialog box.

If you plan to share your workbook with others who use Excel 2007 or earlier, make sure that the list 
is on the same sheet as the drop-down list. Alternatively, you can put the list on any sheet, as long as 
it’s a named range. For example, you can choose Formulas➜Defined Names➜Define Name to define 
the name MonthNames for E1:E12. Then, in the Data Validation dialog box, enter =MonthNames in 
the Source box.

Figure 58-2: Using the Data Validation dialog box to create a drop-down list.
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Comparing Two Ranges by Using 
Conditional Formatting
A common task is comparing two lists of items to identify differences between the two lists. Doing it 
manually is far too tedious and error-prone, but Excel can make it easy. This tip describes a method 
that uses conditional formatting.

Figure 59-1 shows an example of two multicolumn lists of names. Applying conditional formatting 
can make the differences in the lists become immediately apparent. These list examples contain text, 
but this technique also works with numeric data.

Figure 59-1: You can use conditional formatting to highlight the differences in these two ranges.

The first list is in A2:A20, and this range is named OldList. The second list is in C2:C20, and the range is 
named NewList. The ranges were named by using the Formulas➜Defined Names➜Define Name 
command. Naming the ranges isn’t necessary, but it makes them easier to work with.

Start by adding conditional formatting to the old list:

	 1.	 Select the cells in the OldList range.

	 2.	 Choose Home➜Conditional Formatting➜New Rule to display the New Formatting Rule  
dialog box.

	 3.	 In the New Formatting Rule dialog box, click the option labeled Use a Formula to Determine 
Which Cells to Format.
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	 4.	 Enter this formula in the dialog box (see Figure 59-2):

=COUNTIF(NewList,A2)=0

		  When using this technique with your own data, substitute the actual range address (or 
name) for NewList, and substitute the address of the top left selected cell for A2.

	 5.	 Click the Format button and specify the formatting to apply when the condition is true.

		  A different fill color is a good choice.

	 6.	 Click OK.

Figure 59-2: Applying conditional formatting.

The cells in the NewList range use a similar conditional formatting formula.

	 1.	 Select the cells in the NewList range.

	 2.	 Choose Home➜Conditional Formatting➜New Rule to display the New Formatting Rule dia-
log box.

	 3.	 In the New Formatting Rule dialog box, click the option labeled Use a Formula to Determine 
Which Cells to Format.

	 4.	 Enter this formula in the dialog box:

=COUNTIF(OldList,C2)=0

		  When using this technique with your own data, substitute the actual range address (or 
name) for OldList, and substitute the address of the top left selected cell for C2.
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	 5.	 Click the Format button and specify the formatting to apply when the condition is true (a dif-
ferent fill color).

	 6.	 Click OK.

Figure 59-3 shows the result. Names that are in the old list but not in the new list are highlighted. In 
addition, names in the new list that aren’t in the old list are highlighted in a different color. Names 
that aren’t highlighted appear in both lists.

Figure 59-3: Conditional formatting causes differences in the two lists to be highlighted.

Both of these conditional-formatting formulas use the COUNTIF function. This function counts the 
number of times a particular value appears in a range. If the formula returns 0, it means that the item 
doesn’t appear in the range. Therefore, the conditional formatting kicks in and the cell’s background 
color is changed.
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Finding Duplicates by Using Conditional 
Formatting
You might find it helpful to identify duplicate values within a range of cells. For example, take a look 
at Figure 60-1. Are any of the values duplicated?

One approach to identifying duplicate values is to use conditional formatting. After applying a condi-
tional formatting rule, you can quickly spot duplicated cell values.

Figure 60-1: You can use conditional formatting to quickly identify duplicate values in a range.

Here’s how to set up the conditional formatting:

	 1.	 Select the cells in the range (in this example, A1:G22).

	 2.	 Choose Home➜Conditional Formatting➜New Rule to display the Conditional Formatting 
dialog box.

	 3.	 In the Conditional Formatting dialog box, select the option labeled Use a Formula to 
Determine Which Cells to Format.
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	 4.	 For this example, enter this formula (change the range references to correspond to your own 
data):

=COUNTIF($A$1:$G$22,A1)>1

	 5.	 Click the Format button and specify the formatting to apply when the condition is true.

		  Changing the fill color is a good choice.

	 6.	 Click OK.

Figure 60-2 shows the result. The seven highlighted cells are the duplicated values in the range.

Figure 60-2: Conditional formatting causes the duplicated cells to be highlighted.

You can extend this technique to identify entire rows within a list that are identical. The trick is to add 
a new column and use a formula that concatenates the data in each row. For example, if your list is in 
A2:G500, enter this formula in cell H2:

=A2&B2&C2&D2&E2&F2&G2
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Copy the formula down the column and then apply the conditional formatting to the formulas in col-
umn H. In this case, the conditional formatting formula is

=COUNTIF($H$2:$H$500,H2)>1

Highlighted cells in column H indicate duplicated rows.

Note 	

You can use Data➜Data Tools➜Remove Duplicates to remove duplicate rows. That 
command, however, doesn’t identify the duplicates before deleting them.
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Working with Credit Card Numbers
If you’ve ever tried to enter a 16-digit credit card number into a cell, you may have discovered that 
Excel always changes the last digit to a zero. Even worse, maybe you didn’t discover the changed 
credit card number until it was too late.

Why does Excel change your numbers? The reason is that Excel can handle only 15 digits of numeri-
cal accuracy.

Entering credit card numbers manually
If you need to store credit card numbers in a worksheet, you have three options:

➤	 Precede the credit card number with an apostrophe. Excel then interprets the data as a 
text string rather than as a number.

➤	 Preformat the cell or range by using the Text number format. Select the range, choose 
Home➜Number and then select Text from the Number Format drop-down control.

➤	 Enter the card number with dashes or spaces. Embedding a dash character (or any other 
non-numeric character) forces Excel to interpret the entry as text.

This tip, of course, also applies to other long numbers (such as part numbers) that aren’t used in 
numeric calculations.
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Importing credit card numbers
If you’re importing credit card numbers from a CSV text file, Excel will import the credit card numbers 
as values — and erroneously change the last digit to zero. To avoid this, don’t use File➜Open to 
import the text. Rather, use Data➜Connections➜Get External Data➜From Text. When you use this 
command, Excel displays the TextImport Wizard. In Step 3 of the wizard, make sure that you specify 
Text as the column data format for the credit card numbers. See Figure 61-1.

Figure 61-1: Using the TextImport Wizard to ensure that credit card numbers are imported as text.
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Identifying Excess Spaces
A common type of spreadsheet error involves something that you can’t even see: a space character. 
Consider the example shown in Figure 62-1. Cell B2 contains a formula that looks up the color name 
in cell B1 and returns the corresponding code from a table. The formula is

=VLOOKUP(B1,D2:E9,2,FALSE)

Figure 62-1: A simple lookup formula returns the code for a color entered in cell B1.

In Figure 62-2, the formula in cell B2 returns an error — indicating that Red wasn’t found in the table. 
Hundreds of thousands of Excel users have spent far too much time trying to figure out why this sort 
of thing doesn’t work. In this case, the answer is simple: Cell D7 doesn’t contain the word Red. Rather, 
it contains the word Red followed by a space. To Excel, these text strings are completely different.

Figure 62-2: The lookup formula can’t find the word Red in the table.

www.it-ebooks.info

http://www.it-ebooks.info/


Tip 62: Identifying Excess Spaces 171

If your worksheet contains thousands of text entries — and you need to perform comparisons using 
that text — you may want to identify the cells that contain excess spaces and then fix those cells. The 
term excess spaces means a text entry that contains any of the following: 

➤	 One or more leading spaces

➤	 One or more trailing spaces

➤	 Two or more consecutive spaces within the text

One way to identify this type of cell is to use conditional formatting. To set up conditional formatting 
to identify excess spaces, follow these steps:

	 1.	 Select all text cells to which you want to apply conditional formatting.

	 2.	 Choose Home➜Conditional Formatting➜New Rule to display the New Formatting Rule dia-
log box.

	 3.	 In the top part of the dialog box, select the option labeled Use a Formula to Determine 
Which Cells to Format.

	 4.	 Enter a formula like the following in the bottom part of the dialog box (see Figure 62-3):

=A1<>TRIM(A1)

		  Note: This formula assumes that cell A1 is the upper-left cell in the selection. If that’s not the 
case, substitute the address of the upper-left cell in the selection you made in Step 1.

	 5.	 Click the Format button to display the Format Cells dialog box and select the type of format-
ting you want for the cells that contain excess spaces — for example, a yellow fill color.

	 6.	 Click OK to close the Format Cells dialog box, and click OK again to close the New Formatting 
Rule dialog box.

After you complete these steps, each cell that contains excess spaces and is within the range you 
selected in Step 1 is highlighted with the formatting of your choice. You can then easily spot these 
cells and remove the spaces.
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Figure 62-3: Using conditional formatting to identify cells that contain excess spaces.

Note 	

Because of the way the TRIM function works, the formula in Step 4 also applies the con-
ditional formatting to all numeric cells. A slightly more complex formula that doesn’t 
apply the formatting to numeric cells is

=IF(NOT(ISNONTEXT(A1)),A1<>TRIM(A1))
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Transposing a Range
You may have a range of data that should be transposed. Transposing a range is essentially making 
the rows columns, and the columns rows. Figure 63-1 shows an example. The original data is in 
A1:H9, and the transposed data is in A12:I19.

This tip describes two methods to transpose a range of data.

Figure 63-1: Data before and after being transposed.

Using Paste Special
To transpose a range of data by copying and pasting, follow these steps:

	 1.	 Select the range to be transposed.

	 2.	 Press Ctrl+C to copy the range.

	 3.	 Select the cell that will be the upper-left cell for the transposed range.

	 4.	 Choose Home➜Clipboard➜Paste➜Paste Special to display the Paste Special dialog box.

	 5.	 Choose the Transpose option.

	 6.	 Click OK.

Excel pastes the copied data, but reoriented.
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If the original range contains formulas, the formulas will be adjusted so they continue to refer to the 
correct cells.

Note 	

If the original range is in a table (created with Insert➜Tables➜Table), this technique has 
a few caveats. The original selection cannot include the Total Row or columns that con-
tain a formula. You can still paste the transposed data, but you must choose the Values 
option in the Paste Special dialog box. The transposed range will include the values (but 
not the formulas).

Using the TRANSPOSE function
In some cases, you may want the transposed range to be linked to the original range. In such a situa-
tion, changes made to the original range also appear in the transposed range. Here’s how to set up a 
transposed range that’s linked to the original source. Refer to Figure 63-2.

Figure 63-2: A13:J17 contains a multicell array formula, linked to the source range.

	 1.	 Make a note of the number of rows and columns in the source range.

		  In this example, the source range (A1:E10) has 10 rows and 5 columns.

	 2.	 Select a range of blank cells that has the same number of rows as source range columns, and 
the same number of column as source range rows.

		  In this example, the selection should be 5 rows and 10 columns. For example, you can put 
the transposed range in A13:J17.
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	 3.	 Type a formula that uses the TRANSPOSE function, with the source range address as its argu-
ment.

		  In this example, the formula is

=TRANSPOSE(A1:E10)

	 4.	 Press Ctrl+Shift+Enter (not just Enter) to create a multicell array formula in all of the selected 
cells.

Any changes made in the source range also appear in the transposed range.
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Using Flash Fill to Extract Data
When you import data, it’s often necessary to clean up some of the text. For example, names may 
appear in uppercase that they should be in proper case. One approach is to use formulas to modify 
the text (see Tip 57). Another approach uses a feature introduced in Excel 2013: Flash Fill.

Flash Fill uses pattern recognition to extract data (and also concatenate data) from adjoining col-
umns. Just enter a few examples in a column that’s adjacent to the data, and then choose Data➜Data 
Tools➜Flash Fill (or press Ctrl+E). Excel analyzes the examples you typed and attempts to fill in the 
remaining cells. If Excel didn’t recognize the pattern you had in mind, press Ctrl+Z, add another 
example or two, and try again.

Changing the case of text
Figure 64-1 shows a list of U.S. presidents in column A. Column B shows the result of using Flash Fill 
to convert the text to proper case.

Start by providing a few examples: Type George Washington in cell B1 and John Adams in cell B2. 
You’ll notice that Excel kicks in as soon as you start typing John Adams. It recognizes your pattern 
(which is “make all text proper case”) and fills the column with the transformed text (in a light gray 
color). You can press Enter to keep Excel’s suggestion, or continue typing more examples. At any 
time, you can press Ctrl+E to have Excel fill the column.

Figure 64-1: Flash Fill quickly converted the names in Column A to proper case.
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Extracting last names
In this example, we want to extract the last name of each president, so the list can be sorted by last 
name. This is a simple job for Flash Fill. It takes only two examples, and the pattern is recognized.

Figure 64-2 shows the worksheet after Excel extracted the last names. Now, you can sort the list by 
column C, so the name will be in alphabetical order, by last name.

Figure 64-2: Flash Fill extracted the last names.

Extracting first names
You’ll find that Flash Fill is equally adept at extracting first names. Figure 64-3 shows the list of presi-
dents after using Flash Fill to extract the first names in Column D. Again, it took only two examples 
before Excel identified the pattern.

Figure 64-3: Flash Fill extracted the first names.
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Extracting middle names
Some (but not all) of the presidents on the list have a middle name. Can Flash Fill extract the middle 
names?

The answer: Sort of. I provided several examples of middle names, and Flash Fill successfully 
extracted the other middle names. But for names without a middle name, it extracted the first name. 
No matter what I tried, I could not get Flash Fill to ignore names that had no middle name.

Extracting domain names from URLs
Here’s another example of using Flash Fill. Say you have a list of URLs and need to extract the file-
name (the text that follows the last slash character).

Figure 64-4 shows a list of URLs. Flash Fill required just one example of a filename entered in column 
B. I pressed Ctrl+E, and Excel filled in the remaining rows. Flash fill worked equally well removing the 
filename from the URL, in column C.

Figure 64-4: Flash Fill extracted the filenames from URLs.

Potential problems
Flash Fill is a great feature, but if you use it for important data, you should be aware of some poten-
tial problems:

➤	 Sometimes it just doesn’t work. Extracting middle names seems like a simple pattern, but 
Flash Fill was not capable of recognizing the pattern.

➤	 It’s not always accurate. With a small set of data, it’s usually easy to check to ensure that 
Flash Fill worked as you intended it to work. But if you use Flash Fill on thousands of rows of 
data, you can’t be assured that it worked perfectly unless you examine every row. Flash Fill 
works best with data that is very consistent.

➤	 It’s not dynamic. If you change any of the information that Flash Fill used, the changes are 
not reflected in the filled column.

➤	 There is no “audit trail.” If you use formulas to extract data, the formulas provide documen-
tation so anyone can figure out how the data was extracted. Using Flash Fill, on the other 
hand, provides no such audit trail. There is no way to see which rules Excel used to extract 
the data.
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Using Flash Fill to Combine Data
Tip 64 described how to extract data using the Excel 2013 Flash Fill feature. This tip looks at the other 
side of Flash Fill: combing data.

If you need to combine the data in two or more columns, you can write a formula that uses the con-
catenation operator (&). For example, this formula combines the contents of cells A1, B1, and C1:

=A1&B1&C1

For more complicated types of combinations, Flash Fill might be able to do the job and save you the 
trouble of creating (and debugging) a formula.

Figure 65-1 shows a worksheet with first names in column A and last names in column B. I used Flash 
Fill to create e-mail addresses (in Column C) for the domain example.com. The e-mail addresses con-
sist of the first initial, an underscore, and the last name — all lowercase.

Figure 65-1: Flash Fill can quickly convert these names into e-mail addresses.

It took only two examples before Flash Fill recognized the pattern and filled in the rest of the column.

Flash Fill is simpler than composing this equivalent formula:

=LOWER(LEFT(A1,1)&”_”&B1&”@example.com”)
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Figure 65-2 shows another example. Column A:D hold the original data, and the text in column E was 
filled in using Flash Fill, after providing two examples. The equivalent formula to generate the text in 
column E is

=A4&” “&B4&”: “&TEXT(D4,”$0”)&” due on 10/”&C4&”/2013”

Figure 65-2: Flash Fill generated the text in column E.
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Inserting Stock Information
This tip describes how to insert refreshable stock data into a worksheet. For some reason, Microsoft 
makes this feature rather difficult to find.

Here’s how to do it:

	 1.	 Make sure that you’re connected to the Internet.

	 2.	 Type a stock symbol into a cell — for example, MSFT for Microsoft. Make sure the characters 
are all uppercase.

	 3.	 Right-click the cell and choose Addition Cell Actions➜Insert Refreshable Stock Price from the 
shortcut menu.

		  The Insert Stock Price dialog box appears.

	 4.	 Specify the location for the information (on a new sheet, or starting at a particular cell).

	 5.	 Click OK.

Excel retrieves current information about the stock and inserts data that occupies 18 rows and 16 col-
umns (see Figure 66-1).

Figure 66-1: Refreshable stock information inserted into a worksheet.

You can refresh the information at any time. Select any cell in the table, right-click, and choose 
Refresh from the shortcut menu. If your worksheet has information for multiple stocks, you can 
refresh them all by choosing Data➜Connections➜Refresh All.
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Hiding irrelevant rows and columns
Notice that, of the 18 rows, only one of them contains actual data. The other rows are links and dis-
claimers. Unfortunately, there is no direct way to retrieve the information without all of the extrane-
ous information. But you can hide the irrelevant rows and columns — and the hidden rows and 
columns remain hidden when you refresh the information.

Figure 66-2 shows a worksheet that has information for four stocks. I hid the irrelevant rows and col-
umns, for a concise display.

Figure 66-2: Information for four stocks, after hiding irrelevant rows and columns.

Behind the scenes
Using the Addition Cell Actions➜Insert Refreshable Stock Price shortcut menu item is just a quick 
way of performing a web query and retrieving data from Microsoft’s MSN Money site. You can 
retrieve the same information by performing a web query. Choose Data➜Get External Data➜From 
Web and use this URL:

http://moneycentral.msn.com/investor/external/excel/quotes.asp?symbol=MSFT

The URL retrieves information for Microsoft. You can replace MSFT with a different stock symbol. 
Figure 66-3 shows the New Web Query dialog box before the information is inserted into a worksheet.

www.it-ebooks.info

http://www.it-ebooks.info/


Tip 66: Inserting Stock Information 183

Figure 66-3: Using the New Web Query dialog box to retrieve stock information.

Cross-Ref	
See Tip 67 for more information about web queries.
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Getting Data from a Web Page
This tip describes three ways to capture data contained on a web page:

➤	 Paste a static copy of the information.

➤	 Create a refreshable link to the site.

➤	 Open the page directly in Excel.

Pasting static information
One way to get data from a web page into a worksheet is to simply highlight the text in your 
browser, press Ctrl+C to copy it to the Clipboard, and then paste it into a worksheet. The results will 
vary, depending on what browser you use and how the web page is coded.

If pasting doesn’t yield the results you want, choose Home➜Clipboard➜Paste➜Paste Special and 
then try various paste options.

Figure 67-1 shows some currency exchange rates, pasted from a web page at msn.com. As you can 
see, even the hyperlinks are pasted.

Figure 67-1: A table of exchange rates copied from a website and pasted to a worksheet.
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Pasting refreshable information
If you need to regularly access updated data from a web page, create a web query. Figure 67-1 shows 
a website that contains currency exchange rates in a three-column table.

Note 	

The term web query is a bit misleading because this operation is not limited to the web. 
You can perform a web query on a local HTML file, a file stored on a network server, or a 
file stored on a web server on the Internet. To retrieve information from a web server, 
you must be connected to the Internet. After the information is retrieved, an Internet 
connection is not required to work with the information (unless you need to refresh the 
query).

These steps create a web query that allows this information to be retrieved and then refreshed at any 
time with a single mouse click:

	 1.	 Choose Data➜Get External Data➜From Web to display the New Web Query dialog box.

	 2.	 In the Address field, enter the URL of the website and click Go.

		  For this example, the URL for the web page shown in Figure 67-2 is

http://investing.money.msn.com/investments/exchange-rates

		  Notice that the New Web Query dialog box contains a web browser (Internet Explorer). You 
can click links and navigate the website until you locate the data you’re interested in.

		  When a web page is displayed in the New Web Query dialog box, you see one or more yel-
low boxes with an arrow, which correspond to tables defined in the web page — plus 
another yellow box that will retrieve the entire page.

	 3.	 Click a yellow box, and it turns into a green check box, which indicates that the data in that 
table will be imported.

		  Unfortunately, the table in the example is not selectable, so the only choice is to retrieve the 
entire page.

	 4.	 Click the Import button to display the Import Data dialog box.

	 5.	 In the Import Data dialog box, specify the location for the imported data.

		  It can be a cell in an existing worksheet or a new worksheet.

	 6.	 Click OK, and Excel imports the data.
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Figure 67-2: Using the New Web Query dialog box to specify the data to be imported.

Part of the results is shown in Figure 67-3. Although I was interested only in the 17-row and 3-column 
currency table, this web query retrieved 145 rows of mostly irrelevant information.

By default, the imported data is a web query. To refresh the information, right-click any cell in the 
imported range and choose Refresh from the shortcut menu.

If you don’t want to create a refreshable query, specify this choice in Step 5 of the preceding step list. 
In the Import Data dialog box, click the Properties button and deselect the Save Query Definition 
check box.

Note 	

Excel’s Web query feature works by identifying tables (specified using the HTML 
<TABLE> tag) in the document. Increasingly, website designers use cascading style 
sheets (CSS) to display tabular information. As demonstrated in this example, Excel 
doesn’t recognize these as tables and, therefore, doesn’t display a yellow arrow so you 
can retrieve only the table. Therefore, you may have to retrieve the entire document 
and then delete (or hide) everything except the table that you want.
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Figure 67-3: Information retrieved from a web query.

Opening the web page directly
Another way to get web page data into a worksheet is to open the URL directly, by using Excel’s 
File➜Open command. Just enter the complete URL into the File Name field and click Open. 

The results will vary, depending on how the web page is laid out. Most of the time, you’ll get satisfac-
tory results. In some cases, you’ll retrieve quite a bit of extraneous information. Also, note that the 
information is not refreshable. If the data on the web page changes, you’ll need to close the work-
book and use the File➜Open command again.
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Importing a Text File into a Worksheet 
Range
If you need to insert a text file into a specific range in a worksheet, you may think that your only choice 
is to import the text into a new workbook (by choosing Office➜Open) and then to copy the data and 
paste it to the range where you want it to appear. However, you can do it in a more direct way.

Figure 68-1 shows a small CSV (comma separated value) file. The following instructions describe how 
to import this file, named monthly.csv, beginning at cell C3.

Figure 68-1: This CSV file will be imported into a range.

	 1.	 Choose Data➜Get External Data➜From Text to display the Import Text File dialog box.

	 2.	 Navigate to the folder that contains the text file.

	 3.	 Select the file from the list and then click the Import button to display the Text Import 
Wizard.

	 4.	 Use the Text Import Wizard to specify how the data will be imported.

		  For a CSV file, specify Delimited, with a Comma Delimiter.

	 5.	 Click the Finish button.

		  The Import Data dialog box appears.

	 6.	 Click the Properties button, and the External Data Range Properties dialog box appears.

	 7.	 Deselect the Save Query Definition check box and click OK to return to the Import Data dia-
log box.
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	 8.	 Here, specify the location for the imported data.

		  It can be a cell in an existing worksheet or a new worksheet.

	 9.	 Click OK, and Excel imports the data (see Figure 68-2).

Note 	

You can ignore Step 7 if the data you’re importing will be changing. By saving the query 
definition, you can quickly update the imported data by right-clicking any cell in the 
range and choosing Refresh.

Figure 68-2: This range contains data imported directly from a CSV file.
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Using the Quick Analysis Feature
One of the new features in Excel 2013 is Quick Analysis. When you select a range of data, Excel dis-
plays a Quick Analysis button in the lower-right corner of the range. Click the button to view some 
options, shown in Figure 69-1. You can also press Ctrl+Q on the keyboard to display the Quick 
Analysis options.

Figure 69-1: Quick Analysis options for the selected range.

The words along the top (Formatting, Charts, Totals, Tables, and Sparklines) are menu items. Click an 
item and a different set of icons appears. When you hover your mouse over an icon, Excel sometimes 
displays a preview of how the option will appear.

The options available depend on the type of data in the selected range. For example, if the range 
contains only text, the Sparklines option will not be available.

Figure 69-2 shows an example of a range of numbers in column C, with a preview of the Quick 
Analysis option to create running totals in column D.
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Figure 69-2: A preview of Quick Analysis running totals.

Figure 69-3 shows another example. The range A2:G7 is selected, and Quick Analysis is previewing 
the Line Sparklines option in column H.

Figure 69-3: A preview of Quick Analysis Sparklines.

Note 	

The Quick Analysis options don’t enable you to do anything that you can’t do using 
Excel’s normal commands. But sometimes it can you save a bit of time. If you find the 
Quick Analysis button annoying, turn if off in the General tab of the Excel Options dialog 
box. Deselect the check box labeled Show Quick Analysis Options on Selection.
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Filling the Gaps in a Report
When you import data, you can sometimes end up with a worksheet that looks something like the 
one shown in Figure 70-1. This type of report formatting is common. As you can see, an entry in col-
umn A applies to several rows of data. If you sort this type of list, the missing data messes things up, 
and you can no longer tell who sold what when.

Figure 70-1: This report contains gaps in the Sales Rep column.

If your list is small, you can enter the missing cell values manually or by using a series of Home➜ 

Editing➜Fill➜Down commands (or its Ctrl+D shortcut). But if you have a large list that’s in this for-
mat, you need a better way of filling in those cell values. Here’s how:

	 1.	 Select the range that has the gaps (A3:A14, in this example).

	 2.	 Choose Home➜Editing➜Find & Select➜Go To Special.

		  The Go To Special dialog box appears.

	 3.	 Select the Blanks option and click OK.

		  This action selects the blank cells in the original selection.

	 4.	 On the Formula bar, type an equal sign (=) followed by the address of the first cell with an 
entry in the column (=A3, in this example) and press Ctrl+Enter.

	 5.	 Reselect the original range and press Ctrl+C to copy the selection.

	 6.	 Choose Home➜Clipboard➜Paste➜Paste Values to convert the formulas to values.
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After you complete these steps, the gaps are filled in with the correct information, and your work-
sheet looks similar to the one shown in Figure 70-2. Now it’s a normal list, and you can do whatever 
you like with it — including sorting.

Figure 70-2: The gaps are gone, and this list can now be sorted.
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Performing Inexact Searches
If you have a large worksheet with lots of data, locating what you’re looking for can be difficult. The 
Excel Find and Replace dialog box is a useful tool for locating information, and it has a few features 
that many users overlook.

Access the Find and Replace dialog box by choosing Home➜Editing➜Find & Select➜Find (or by 
pressing Ctrl+F). If you’re replacing information, you can use Home➜Editing➜Find & Select➜Replace 
(or Ctrl+H). The only difference is which of the two tabs is displayed in the dialog box. Figure 71-1 
shows the Find and Replace dialog box after clicking the Options button, which expands the dialog 
box to show additional options.

Figure 71-1: The Find and Replace dialog box with the Find tab selected.

In many cases, you want to locate “approximate” text. For example, you may be trying to find data for 
a customer named Stephen R. Rosencrantz. You can, of course, search for the exact text: Stephen R. 
Rosencrantz. However, there’s a reasonably good chance that the search will fail. The name may have 
been entered differently, as Steve Rosencrantz or S.R. Rosencrantz, for example. It may have even 
been misspelled as Rosentcrantz.

The most efficient search for this name is to use a wildcard character and search for st*rosen* and 
then click the Find All button. In addition to reducing the amount of text that you enter, this search is 
practically guaranteed to locate the customer, if the record is in your worksheet. The search may also 
find some records that you aren’t looking for, but that’s better than not finding anything.

The Find and Replace dialog box supports two wildcard characters:

➤	 ? matches any single character.

➤	 * matches any number of characters.
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Wildcard characters also work with values. For example, searching for 3* locates all cells that contain 
an entry that begins with 3. Searching for 1?9 locates all three-digit entries that begin with 1 and end 
with 9.

Note 	

To search for a question mark or an asterisk, precede the character with a tilde character 
(~). For example, the following search string finds the text *NONE*:

~*NONE~*

If you need to search for the tilde character, use two tildes.

If your searches don’t seem to be working correctly, double-check these three options (which some-
times have a way of changing on their own):

➤	 Match Case: If this check box is selected, the case of the text must match exactly. For exam-
ple, searching for smith does not locate Smith.

➤	 Match Entire Cell Contents: If this check box is selected, a match occurs if the cell contains 
only the search string (and nothing else). For example, searching for Excel doesn’t locate a 
cell that contains Microsoft Excel.

➤	 Look In: This drop-down list has three options: Values, Formulas, and Comments. If, for 
example, Values is selected, searching for 900 doesn’t find a cell that contains 900 if that 
value is generated by a formula.

Remember that searching operates on the selected range of cells. If you want to search the entire 
worksheet, select only one cell before you begin your search.

Also, remember that searches do not include numeric formatting. For example, if you have a value 
that uses currency formatting so that it appears as $54.00, searching for $5* doesn’t locate that value.

Working with dates can be a bit tricky because Excel offers many ways to format dates. If you search 
for a date by using the default date format, Excel locates the dates even if they’re formatted differ-
ently. For example, if your system uses the m/d/y date format, the search string 10/*/2013 finds all 
dates in October 2013, regardless of how the dates are formatted.

You can also use an empty Replace With field. For example, to quickly delete all asterisks from your 
worksheet, enter ~* in the Find What field and leave the Replace With field blank. When you click the 
Replace All button, Excel finds all the asterisks and replaces them with nothing.
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Proofing Your Data with Audio
Excel 2002 introduced a handy feature: text-to-speech. In other words, Excel is capable of speaking to 
you. You can have this feature read back a specific range of cells, or you can set it up so that it reads 
the data as you enter it.

For some reason, this feature appears to be missing in action, beginning with Excel 2007. You can 
search the Ribbon all day and not find a trace of the text-to-speech feature. But the feature is still 
available — you just need to spend a few minutes to make it accessible.

Adding speech commands to the Ribbon
Following are instructions to add these commands to a new group in the Review tab of the Ribbon:

	 1.	 Right-click the Ribbon and then choose Customize the Ribbon from the shortcut menu.

		  The Customize Ribbon tab of the Excel Options dialog box appears.

	 2.	 In the list box on the right, select Review and click New Group.

	 3.	 Click Rename and overwrite the default name with a more descriptive name, such as Text To 
Speech.

	 4.	 Click the drop-down list on the left and choose Commands Not in the Ribbon.

	 5.	 Scroll down the list, and you find five items that begin with the word Speak; select each one 
and then click Add.

		  They’re added to the newly created group (see Figure 72-1).

	 6.	 Click OK to close the Excel Options dialog box.

After you perform these steps, the Review tab displays a new group with five new icons (see  
Figure 72-2).

Using the speech commands
To read a range of cells, select the range first and then click the Speak Cells button. You can also 
specify the orientation (By Rows or By Columns). To read the data as it’s entered, click the Speak On 
Enter button.
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Some people (myself included) find the voice in this “love it or hate it” feature much too annoying to 
use for any extended period. And, if you enter the data at a relatively rapid clip, the voice simply can-
not keep up with you.

You have a small bit of control over the voice used in the Excel Text To Speech feature. To adjust the 
voice, open the Windows Control Panel and display the Text to Speech tab of the Speech Properties 
dialog box. You can adjust the speed and select a different voice (if other voices are installed). Click 
the Preview Voice button to help make your choices.

Figure 72-1: Adding the speech commands to the Ribbon.

Figure 72-2: Speech commands added to the Ribbon.
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Getting Data from a PDF File
A PDF file is a document format that displays text or graphics in a way that’s independent of the 
hardware and operating system used to create the document. PDF files are very common, and just 
about everyone has software that can read PDF files.

Excel can export a worksheet (or workbook) as a PDF file, but it cannot open PDF files. This tip 
describes two ways to get data from a PDF file into an Excel worksheet.

Using copy and paste
Figure 73-1 shows a PDF file displayed in Adobe Reader. I selected the table of data and pressed 
Ctrl+C to copy it to the Clipboard. Then I activated Excel and pressed Ctrl+V to copy the Clipboard 
contents. The result is shown in Figure 73-2.

Figure 73-1: Data in a PDF file that needs to be transferred to a worksheet.
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Figure 73-2: Using copy and paste doesn’t work very well.

The data is copied, but it’s all in a single column. I could spend some time and rearrange the data, but 
there’s a more efficient way to transfer the PDF file data to Excel.

Note 	

When coping from a PDF file and pasting to a worksheet, the actual results will vary, 
depending on the layout of the PDF file. In some cases, the pasted text is usable. But in 
most cases, it’s not.
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Using Word 2013 as an intermediary
Excel can’t open PDF files, but Word 2013 can. Figure 73-3 shows a Word document after importing 
the PDF file. The information can be copied and pasted to an Excel worksheet — and the result will 
require minimal reformatting (see Figure 73-4).

After making a few minor edits, the table looks perfect.

Figure 73-3: A PDF file, imported into World 2013.
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Figure 73-4: A Word 2013 document pasted into an Excel worksheet.

Note 	

The ability to open PDF files is new to Word 2013, so this method won’t work with other 
previous versions of Word.
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PART V
Tables and  
Pivot Tables
This part contains tips that deal with two of Excel’s most useful features: tables and 
pivot tables. If you work with large amounts of structured data, you owe it to 
yourself to understand these features. 
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Understanding Tables
An important but often underutilized feature in Excel is tables. This tip describes when to use a table 
and also lists the advantages and disadvantages.

Understanding what a table is
A table is a rectangular range of structured data. Each row in the table corresponds to a single entity. 
For example, a row can contain information about a customer, a bank transaction, an employee, or a 
product. Each column contains a specific piece of information. For example, if each row contains 
information about an employee, the columns can contain data, such as name, employee number, 
hire date, salary, or department. Tables have a header row at the top that describes the information 
contained in each column.

You’ve probably created ranges that meet this description. The magic happens when you tell Excel 
to convert a range of data into an “official” table. You do so by selecting any cell within the range and 
then choosing Insert➜Tables➜Table.

When you explicitly identify a range as a table, Excel can respond more intelligently to the actions 
you perform with that range. For example, if you create a chart from a table, the chart expands auto-
matically as you add new rows to the table. If you create a pivot table from a table, refreshing the 
pivot table will include any new data that you added to the table.

Figure 74-1 shows a range before it was converted to a table, and Figure 74-2 shows the range after it 
was converted to a table.
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Figure 74-1: A range of data that’s not an official table.

Figure 74-2: A range of data that has been designated a table.

Range versus table
What’s the difference between a standard range and a range that has been converted to a table?
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➤	 Activating any cell in the table gives you access to a new Table Tools context tab on the 
Ribbon.

➤	 You can quickly apply background color and text color formatting by choosing from a gal-
lery. This type of formatting is optional.

➤	 Each column header contains a filter button that, when clicked, lets you easily sort the rows 
or filter the data by hiding rows that don’t meet your criteria.

➤	 A table can have “slicers,” which makes it easy for novices to quickly apply filters to a table.

➤	 If you scroll down the sheet so that the header row disappears, the table headers replace the 
column letters in the worksheet header. In other words, you don’t need to freeze the top row 
to keep the column labels visible.

➤	 If you create a chart from data in a table, the chart automatically expands if you add new 
rows to the end of the table.

➤	 If you create a name for a column in a table, the “refers to” range for the name adjusts as you 
add new rows to the table.

➤	 Tables support calculated columns. A single formula entered in a cell is automatically propa-
gated to all cells in the column (see Tip 75).

➤	 Tables support structured references in formulas outside of the table. Rather than use cell 
references, formulas can use table names and column headers.

➤	 When you move your mouse pointer to the lower-right corner of the lower-right cell, you can 
click and drag to extend the table’s size, either horizontally (add more columns) or vertically 
(add more rows).

➤	 Selecting rows and columns within the table is simplified.

Limitations of using a table
If a workbook contains at least one table, a few Excel features are not available:

➤	 For some reason, when a workbook contains at least one table, Excel doesn’t allow you to 
use the Custom Views feature (choose View➜Workbook Views➜Custom Views).

➤	 You cannot share a workbook (using Review➜Changes➜Share) if the workbook contains a 
table.

➤	 You can’t insert automatic subtotals within a table (by choosing Data➜Outline➜Subtotal).

➤	 You cannot use array formulas within a table.
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Using Formulas with a Table
This tip describes some ways to use formulas with a table. The example uses a simple sales summary 
table with three columns: Month, Projected, and Actual, as shown in Figure 75-1. I entered the data 
and then converted the range to a table by using the Insert➜Tables➜Table command. Note that I 
didn’t define any names, but the data area of the table is named Table1 by default.

Figure 75-1: A simple table with three columns.

Working with the Total row
If you want to calculate the total projected and total actual sales, you don’t even need to write a for-
mula. Just click a button to add a row of summary formulas to the table:

	 1.	 Activate any cell in the table.

	 2.	 Select the Table Tools➜Design➜Table Style Options➜Total Row command and check the 
Total Row check box.

	 3.	 Activate a cell in the Total row and select a summary formula from the drop-down list (see 
Figure 75-2).

		  For example, to calculate the sum of the Actual column, select SUM from the drop-down list 
in cell D15. Excel creates this formula:

=SUBTOTAL(109,[Actual])

For the SUBTOTAL function, 109 is an enumerated argument that represents SUM. The second argu-
ment for the SUBTOTAL function is the column name, in square brackets. Using the column name 
within brackets is a way to create structured references within a table.
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Figure 75-2: A drop-down list enables you to select a summary formula for a table column.

Note 	

You can toggle the Total row display on and off by choosing Table Tools➜Design➜ 

Table Style Options➜Total Row. If you turn it off, the summary options you selected are 
remembered when you turn it back on.

Using formulas within a table
In many cases, you want to use formulas within a table. For example, in the table shown in Figure 
75-1, you may want a column that shows the difference between the actual and projected amounts 
for each month. As you can see, Excel makes this process very easy:

	 1.	 Activate cell E2 and type Difference for the column header.

		  Excel automatically expands the table for you.

	 2.	 Move to cell E3 and type an equal sign (=) to signal the beginning of a formula.

	 3.	 Press the left-arrow key to point to the corresponding value in the Actual column.

	 4.	 Type a minus sign (–) and then press the left-arrow key twice to point to the corresponding 
value in the Projected column.
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	 5.	 Press Enter to end the formula.

		  The formula is entered into the other cells in the column, and the Formula bar displays this 
formula:

=[@Actual]-[@Projected]

Figure 75-3 shows the table with the new column.

Figure 75-3: The Difference column contains a formula.

Although the formula was entered into the first row of the table, that’s not necessary. Anytime a for-
mula is entered into an empty table column, it propagates to the other cells in the column. If you 
need to edit the formula, edit any formula in the column, and the change is applied to the other cells 
in the column.

Note 	

Propagating a formula to other cells in a table column is actually one of Excel’s 
AutoCorrect options. To turn off this feature, click the icon that appears when you enter 
a formula and choose Stop Automatically Creating Calculated Columns.

The preceding set of steps uses the column names to create the formula. Alternatively, you can enter 
the formula by using standard cell references. For example, you can enter the following formula in 
cell E3:

=D3-C3

If you type the cell references, Excel still automatically copies the formula to other cells in the column.
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Referencing data in a table
Formulas that are outside of a table can refer to data within a table by using the table name and col-
umn headers. You don’t need to create names for these items. The table itself has a name (for exam-
ple, Table1), and you can refer to data within the table by using column headers.

You can, of course, use standard cell references to refer to data in a table, but using table references 
has a distinct advantage: The names adjust automatically if the table size changes by adding or delet-
ing rows.

Refer to the table shown earlier in Figure 75-1. This table was given the name Table1 when it was cre-
ated. To calculate the sum of all data in the table, use this formula:

=SUM(Table1)

This formula always returns the sum of all the data, even if rows or columns are added or deleted. 
And, if you change the name of Table1, Excel automatically adjusts formulas that refer to that table. 
For example, if you rename Table1 as AnnualData (by using the Name Manager), the preceding for-
mula changes to

=SUM(AnnualData)

Most of the time, you want to refer to a specific column in the table. The following formula returns 
the sum of the data in the Actual column (but ignores the total row):

=SUM(Table1[Actual])

Notice that the column name is enclosed in square brackets. Again, the formula adjusts automatically 
if you change the text in the column heading.

Even better, Excel provides some helpful assistance when you create a formula that refers to data 
within a table. Figure 75-4 shows the Formula AutoComplete feature helping to create a formula by 
showing a list of the elements in the table.

Figure 75-4: The Formula AutoComplete feature is useful when creating a formula that refers to data in a table.
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Numbering Table Rows Automatically
In some situations, you may want a table to include sequential row numbers. This tip describes how 
to take advantage of the calculated column feature (explained in Tip 75) and create a formula that 
numbers table rows automatically.

Figure 76-1 shows a table (named Table1) with information about job applicants. The first column of 
the table, labeled Num, displays sequential numbers.

Figure 76-1: The numbers in column B are generated with a formula.

The calculated column formula, which you can enter into any cell in the Num column, is

=ROW()-ROW(Table1)+1

When you enter the formula, it’s automatically propagated to all other cells in the Num column.

The ROW function, when used without an argument, returns the row that contains the formula. 
When the ROW function has an argument that consists of a multirow range, it returns the first row of 
the range.

Note 	

A table’s name does not include the header row of the table. So, in this example, the first 
row of Table1 is row 5.

The numbers are table row numbers, not numbers that correspond to a particular row of data. For 
example, if you sort the table, the numbers will remain consecutive — and they will no longer be 
associated with the same row of data.
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If you filter the table, rows that don’t meet the filter criteria will be hidden. In such a case, some table 
row numbers will not be visible. Figure 76-2 shows the table after filtering to display only the Clerk 
positions.

Figure 76-2: When the table is filtered, the row numbers are no longer consecutive.

If you want the table row numbers to remain consecutive when the table is filtered, a different for-
mula is required. Referring to the example in Figure 76-1, enter this formula in cell B5, and it will be 
propagated to the other rows:

=SUBTOTAL(3,C$5:C5)

This formula uses the SUBTOTAL function, with a first argument of 3 (which corresponds to COUNTA). 
The SUBTOTAL function ignores hidden rows, so only visible rows are counted. Notice that the for-
mula refers to a different column — which is necessary to avoid a circular reference error.

Figure 76-3 shows the filtered table using the SUBTOTAL formula in column B.

Figure 76-3: When the table is filtered, the row numbers remain consecutive.
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Identifying Data Appropriate for a Pivot 
Table
A pivot table requires that your data is in the form of a rectangular database table. You can store the 
database in either a worksheet range (which can be a table or just a normal range) or an external data-
base file. And although Excel can generate a pivot table from any database, not all databases benefit.

Figure 77-1 shows part of a simple database table that has five columns and 3,144 rows (one row for 
each county). This data is appropriate for a pivot table. For example, a pivot table can instantly calcu-
late the total population by state or by region and display the values in a nicely formatted table.

Figure 77-1: This data is appropriate for a pivot table.

Generally speaking, fields in a database table consist of two types of information:

➤	 Data: Contains a value or data to be summarized. For this example, the 1990 Population and 
the 2000 Population fields are data fields.

➤	 Category: Describes the data. For this example, the Country, State, and Region fields are cat-
egory fields because they describe the two data fields.

The data versus category distinction can be blurry at times. Often a pivot table will display counts of 
items within a category. In such a case, a category is serving as a data field.

Note 	

A database table that’s appropriate for a pivot table is said to be normalized. In other 
words, each row contains information that describes the data in the row.
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A single database table can have any number of data fields and category fields. When you create a 
pivot table, you usually want to summarize one or more of the data fields. Conversely, the values in 
the category fields appear in the pivot table as rows, columns, or filters.

Figure 77-2 shows a pivot table created from the example. This pivot table displays the 2000 
Population values, totaled by state.

Figure 77-2: A pivot table created from the data.

Figure 77-3 shows an example of an Excel range that is not appropriate for a pivot table. Although 
the range contains descriptive information about each value, it does not consist of normalized data, 
and you cannot create a useful pivot table from it. In fact, this range actually resembles a pivot table 
summary, but it’s much less flexible.

Figure 77-3: This range is not appropriate for a pivot table.
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Figure 77-4 shows the same data, but normalized. This range contains 78 rows of data — one for 
each of the six monthly sales values for the 13 states. Notice that each row contains category infor-
mation for the sales value. This table is an ideal candidate for a pivot table and contains all informa-
tion necessary to summarize the information by region or quarter.

Figure 77-5 shows a pivot table created from the normalized data. As you can see, it’s virtually identi-
cal to the non-normalized data shown in Figure 77-3. Working with normalized data provides ulti-
mate flexibility in designing reports.

Figure 77-4: This range contains normalized data and is appropriate for a pivot table.
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Figure 77-5: A pivot table created from normalized data.
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Using a Pivot Table Instead of Formulas
The Excel PivotTable feature is incredibly powerful, and you can often create pivot tables in lieu of 
creating formulas. This tip describes a specific problem and provides three different solutions.

Figure 78-1 shows a range of data that contains student test scores. The goal is to calculate the aver-
age score for all students plus the average score for each gender.

Figure 78-1: What’s the best way to calculate the average test score for males versus females?

Inserting subtotals
The first solution involves automatically inserting subtotals. To use this method, the data must be 
sorted by the column that will trigger the subtotaling. In this case, you need to sort by the Gender 
column. Follow these steps:

	 1.	 Select any cell in column C.

	 2.	 Right-click and choose Sort➜Sort A to Z from the shortcut menu.

	 3.	 Choose Data➜Outline➜Subtotal.

		  The Subtotal dialog box appears.

www.it-ebooks.info

http://www.it-ebooks.info/


Tip 78: Using a Pivot Table Instead of Formulas 219

	 4.	 Specify At Each Change in Gender, Use Function Average, and Add Subtotal to Score.

The result of adding subtotals is shown in Figure 78-2. Notice that Excel also creates an outline, so 
you can hide the details and view just the summary.

The formulas inserted by Excel use the SUBTOTAL function, with 1 as the first argument (1 represents 
average). Here are the formulas:

=SUBTOTAL(1,B2:B13)
=SUBTOTAL(1,B15:B28)
=SUBTOTAL(1,B2:B28)

The formula in cell B30 calculates the Grand Average and uses a range that includes the other  
two SUBTOTAL formulas in cells B14 and B29. The SUBTOTAL function ignores cells that contain 
other SUBTOTAL formulas.

Figure 78-2: Excel adds subtotals automatically.
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Using formulas
Another method of creating averages is to use formulas. The formula to calculate the average of all 
students is simple:

=AVERAGE(B2:B27)

To calculate the average of the genders, you can use the AVERAGEIF function and create these  
formulas:

=AVERAGEIF(C2:C27,”Female”,B2:B27)
=AVERAGEIF(C2:C27,”Male”,B2:B27)

Using Excel’s PivotTable feature
A third method of averaging the scores is to create a pivot table. Many users avoid creating pivot 
tables because they consider this feature too complicated. As you can see, it’s simple to use:

	 1.	 Select any cell in the data range and choose Insert➜Tables➜PivotTable.

		  The Create PivotTable dialog box appears.

	 2.	 Verify that Excel selected the correct data range and specify a cell on the existing worksheet 
as the location.

		  Cell E1 is a good choice.

	 3.	 Click OK.

		  Excel displays the PivotTable Fields task pane.

	 4.	 Drag the Gender item to the Rows section, at the bottom.

	 5.	 Drag the Score item to the Values section.

		  Excel creates the pivot table but calculates the sum of the scores rather than the average.

	 6.	 To change the summary function that’s used, right-click any of the values in the pivot table 
and choose Summarize Data By➜Average from the shortcut menu.

Figure 78-3 shows the pivot table and the PivotTable Fields task pane.
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Figure 78-3: This pivot table calculates the averages without using formulas.

Note 	

Unlike a formula-based solution, a pivot table doesn’t update itself automatically if the 
data changes. If the data changes, you must refresh the pivot table. Just right-click any 
cell in the pivot table and choose Refresh from the shortcut menu.

The pivot table in this example is extremely simple, but it’s also very easy to create. Pivot tables can 
be much more complex, and they can summarize massive amounts of data in just about any way you 
can think of — without using any formulas.
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Controlling References to Cells Within a 
Pivot Table
In some cases, you may want to create a formula that references one or more cells within a pivot 
table. Figure 79–1 shows a simple pivot table that displays income and expense information for three 
years. In this pivot table, the Month field is hidden, so the pivot table shows the year totals.

Figure 79-1: The formulas in column F reference cells in the pivot table.

Column F contains formulas, and this column is not part of the pivot table. These formulas calculate 
the expense-to-income ratio for each year. I created these formulas by pointing to the cells. You may 
expect to see this formula in cell F3:

=D3/C3

In fact, the formula in cell F3 is

=GETPIVOTDATA(“Sum of Expenses”,$B$2,”Year”,2010)
/GETPIVOTDATA(“Sum of Income”,$B$2,”Year”,2010)

When you use the pointing technique to create a formula that references a cell in a pivot table, 
Excel replaces those simple cell references with a much more complicated GETPIVOTDATA function. 
If you type the cell references manually (rather than pointing to them), Excel does not use the 
GETPIVOTDATA function.

The reason? Using the GETPIVOTDATA function helps ensure that the formula will continue to refer-
ence the intended cells if the pivot table layout is changed.
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Figure 79-2 shows the pivot table after expanding the years to show the month detail. As you can 
see, the formulas in column F still show the correct result even though the referenced cells are in a 
different location. For example, the summary row for 2011 was originally row 4. After expanding the 
years, the summary row for 2011 is row 16. Had I used simple cell references, the formula would have 
returned incorrect results after expanding the years.

Figure 79-2: After expanding the pivot table, formulas that used the GETPIVOTDATA function continue to dis-
play the correct result.

Using the GETPIVOTDATA function has one caveat: The data that it retrieves must be visible in the 
pivot table. If you modify the pivot table so that the value used by GETPIVOTDATA is no longer visi-
ble, the formula returns an error.

Note 	

You may want to prevent Excel from using the GETPIVOTDATA function when you point 
to pivot table cells when creating a formula. If so, choose PivotTable Tools➜Analyze➜ 

PivotTable➜Options➜Generate GetPivot Data (this command is a toggle).
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Creating a Quick Frequency Tabulation
This tip describes a quick method for creating a frequency tabulation for a single column of data. 
Figure 80-1 shows a small part of a range that contains more than 20,000 rows of city and state data. 
The goal is to tally the number of times each state appears in the list.

Although you can tally the states in a number of ways, a pivot table is the easiest choice for this task.

Figure 80-1: You can use a pivot table to generate a frequency tabulation for these state abbreviations.

Before you get started on this task, make sure that your data column has a heading. In this example, 
it’s in cell B1.

Activate any cell in the column A or B and then follow these steps:

	 1.	 Choose Insert➜Tables➜PivotTable.

		  The Create PivotTable dialog box appears.
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	 2.	 If Excel doesn’t correctly identify the range, change the Table/Range setting.

	 3.	 Specify a location for the PivotTable.

	 4.	 Click OK.

		  Excel creates an empty pivot table and displays the PivotTable Fields task pane.

	 5.	 Drag the State field into the Rows section.

	 6.	 Drag the State field into the Values section.

Excel creates the pivot table, which shows the frequency of each state (see Figure 80-2).

Figure 80-2: A quick pivot table shows the frequency of each state abbreviation.
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This pivot table can be sorted, by using the Home➜Editing➜Sort & Filter command. In addition (as 
shown in Figure 80-3), you can even create a pivot chart to display the counts graphically. Just select 
any cell in the pivot table and choose PivotTable Tools➜Analyze➜Tools➜PivotChart.

Figure 80-3: A few mouse clicks creates a chart from the pivot table.
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Grouping Items by Date in a Pivot Table
One of the more useful features of a pivot table is the ability to combine items into groups. Grouping 
items is simple: Select them and choose PivotTable Tools➜Options➜Group➜Group Selection.

You can go a step further, though. When a field contains dates, Excel can create groups automati-
cally. Many users overlook this helpful feature. Figure 81-1 shows a portion of a table that has two 
columns of data: Date and Sales. This table has 731 rows and covers dates between January 1, 2012, 
and December 31, 2013. The goal is to summarize the sales information by month.

Figure 81-1: You can use the PivotTable feature to summarize the sales data by month.

Figure 81-2 shows part of a pivot table (in columns D:E) created from the data. Not surprisingly, it 
looks exactly like the input data because the dates haven’t been grouped.

To group the items by month, right-click any cell in the Date column of the pivot table and select 
Group from the shortcut menu. You see the Grouping dialog box, shown in Figure 81-3. In the By list 
box, select Months and Years and verify that the starting and ending dates are correct. Click OK.

The Date items in the pivot table are grouped by years and by months (as shown in Figure 81-4).

Note 	

The Group command is available only if every item in the field is a date (or a time). Even 
a single blank cell will make it impossible to group by date.
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Figure 81-2: The pivot table, before grouping by months and years.

Figure 81-3: Use the Grouping dialog box to group items in a pivot table.

Note 	

If you select only Months in the Grouping list box, months in different years are com-
bined. For example, the June item would display sales for both 2012 and 2013.

www.it-ebooks.info

http://www.it-ebooks.info/


Tip 81: Grouping Items by Date in a Pivot Table 229

Figure 81-4: The pivot table, after grouping by months and years.

Notice that the Grouping dialog box contains other time-based units. For example, you can group 
the data into quarters. Figure 81-5 shows the data grouped by quarters and years.

Figure 81-5: The pivot table, after grouping by quarters and years.
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Creating Pivot Tables with Multiple 
Groupings
If you’ve created multiple pivot tables from the same data source, you may have noticed that group-
ing a field in one pivot table affects the other pivot tables. Specifically, all the other pivot tables auto-
matically use the same grouping. Sometimes, this is exactly what you want. Other times, it’s not at all 
what you want. For example, you may want to see two pivot table reports: one that summarizes data 
by month and year, and another that summarizes the data by quarter and year.

The reason grouping affects other pivot tables is because all the pivot tables are using the same pivot 
table cache. Unfortunately, there’s no direct way to force a pivot table to use a new cache. But there is 
a way to trick Excel into using a new cache. The trick involves assigning multiple range names to the 
source data.

For example, if your source range is named Table1, give the same range a second name: Table2. The 
easiest way to name a range is to use the Name box, to the left of the Formula bar. Select the range, 
type a name in the Name box, and press Enter. Then, with the range still selected, type a different 
name, and press Enter. Excel will display only the first name, but you can verify that both names exist 
by choosing Formulas➜Define Names➜Name Manager (see Figure 82-1).

Figure 82-1: A range has two names.

When you create the first pivot table, specify Table1 as the Table/Range in the Create PivotTable dia-
log box (see Figure 82-2). When you create the second pivot table, specify Table2 as the Table/Range. 
Each pivot table will use a separate cache, and you can create groups in one pivot table, independent 
of the other pivot table.
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Figure 82-2: Using a named range as the Table/Range.

You can use this trick with existing pivot tables. Make sure that you give the data source a different 
name. Then select the pivot table and choose PivotTable Tools➜Analyze➜Data➜Change Data 
Source. In the Change PivotTable Data Source dialog box, type the new name that you gave to the 
range. This will cause Excel to create a new pivot cache for the pivot table.

Figure 82-3 shows two pivot tables (with different groupings) created from the same data source. 
One pivot table is grouped by quarters and years, and the other is grouped by months and years.

Figure 82-3: These pivot tables were created from the same data source, but use different groupings.
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Using Pivot Table Slicers and Timelines
If you’ve worked with pivot tables, filtering data in a pivot table is fairly easy. Just click the filter but-
ton for a field, and remove the check mark from items that you don’t want to see. This tip describes 
two ways to simplify pivot table filtering: slicers and timelines. These methods are most useful when 
the worksheet will be viewed by novices, or for those who prefer things very simple.

Using slicers
Figure 83-1 shows an unfiltered pivot table that summarizes bank account information by three 
fields: Customer Type (either New or Existing), Branch (either Central, North County, or Westside), 
and OpenedBy (either New Accts or Teller).

Figure 83-1: The normal way to filter items in a pivot table.

A slicer is an interactive control that makes it easy to apply simple filters to data in a pivot table. 
Figure 83-2 shows a pivot table with three slicers. Each slicer represents a particular field in the pivot 
table. In this case, the pivot table is displaying data for existing customers, opened by tellers at the 
Central branch.

The same type of filtering can be accomplished by using the field labels in the pivot table, but slicers 
are intended for those who might not understand how to filter data in a pivot table. Slicers can also 
be used to create an attractive and easy-to-use interactive dashboard.

www.it-ebooks.info

http://www.it-ebooks.info/


Tip 83: Using Pivot Table Slicers and Timelines 233

Figure 83-2: Using slicers to filter the data displayed in a pivot table.

To add one or more slicers to a worksheet, start by selecting any cell in a pivot table. Then choose 
Insert➜Filter➜Slicer. The Insert Slicers dialog box appears, with a list of all fields in the pivot table. 
Place a check mark next to the slicers you want, and then click OK.

Note 	

In Excel 2013, slicers aren’t limited to pivot tables. You can also use slicers with a table 
(created with Insert➜Tables➜Table).

Slicers float on the worksheet’s drawing layer, and they can be moved and resized. You can change 
the look and also specify multiple columns of buttons.

To use a slicer to filter data in a pivot table, just click a button in the slicer. To display multiple values, 
press Ctrl while you click the buttons. Press Shift and click to select a series of consecutive buttons.

To remove the effects of filtering by a particular slicer, click the icon in the slicer’s upper-right corner.

Figure 83-3 shows a pivot table with two slicers to enable filtering the data (by State and by Month). 
In this case, the pivot table and pivot chart show only the data for California, Oregon, and 
Washington for the months of January through March. Slicers provide a quick-and-easy way to create 
an interactive chart.
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Figure 83-3: Using slicers to filter a pivot table by state and by month.

Using a timeline
A timeline is conceptually similar to a slicer, but this control is designed to simplify time-based filter-
ing in a pivot table. Timelines are new to Excel 2013, and (unlike slicers) this feature is for pivot 
tables only.

A timeline is relevant only if your pivot table has a field that’s formatted as a date. This feature does 
not work with times. To add a timeline, select a cell in a pivot table and choose Insert➜Filter➜ 

Timeline. A dialog box appears listing all date-based fields. If your pivot table doesn’t have a field for-
matted as a date, Excel displays an error.

Figure 83-4 shows a pivot table created from the data in columns A:E. This pivot table uses a timeline, 
set to allow date filtering by quarters. Click a button that corresponds to the quarter you want to view, 
and the pivot table is updated immediately. To select a range of quarters, press Shift while you click 
the buttons. Other filtering options (selectable from the drop-down in the upper-right corner) are 
Year, Month, and Day. In the figure, the pivot table displays data from the first two quarters of 2012.

You can, of course, use both slicers and a timeline for a pivot table. A timeline has the same type of 
formatting options as slicers, so you can create an attractive interactive dashboard that simplifies 
pivot table filtering.
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Figure 83-4: Using a timeline to filter a pivot table by date.
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PART VI
Charts and  
Graphics
A well-conceived chart can make a range of incomprehensible numbers make sense. 
The tips in this part deal with various aspects of chart making, and also covers topics 
related to other types of graphics.
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Understanding Recommended Charts
One of the new features in Excel 2013 is Recommended Charts. Select your data, choose Insert➜ 

Charts➜Recommended Charts, and Excel responds by displaying the Recommended Charts of the 
Insert Chart dialog box (see Figure 84-1). This dialog box displays a preview of your data using several 
chart type options.

Figure 84-1: The Recommended Charts feature displays your data using several different chart types.
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How does it work? According to the Excel Help:

Want us to recommend a good chart to showcase your data? Select data in your worksheet and click this 
button to get a customized set of charts that we think will fit best with your data.

Don’t believe it. Excel uses some simple algorithms to make its suggestions, but don’t expect any 
advanced artificial intelligence. In other words, you will probably never see a recommended chart 
that will make you say, “Why didn’t I think of that!”

The recommended charts seem to be limited to the basic chart types: column charts, line charts, area 
charts, bar charts, pie charts, and scatter charts.

The recommendations don’t seem to take the magnitude of the data into account. For example, if 
you select two data series that vary drastically in scale, a combination chart would be a good recom-
mendation. But I’ve never seen Excel recommend a combination chart. Rather, it recommends a col-
umn or line chart in which one of the data series is so close to the axis that it may not even be visible.

Even when data is perfectly suited (and labeled) for a stock market chart, that chart is never recom-
mended. But it does offer some recommendations that are clearly inappropriate.

But the recommended charts feature is not completely useless. For example, if a data series has more 
than eight data points, Excel will not recommend a pie chart. That’s certainly good advice because 
pie charts are often used inappropriately to display too much data. Also, Excel will never recommend 
a 3D chart. That’s also good advice because a 3D chart is almost never the best choice.

Excel’s Recommended Charts feature is certainly a good idea, but the current implementation leaves 
much to be desired. The main problem is this feature is intended for novice users — and many of 
them will actually believe that a recommended chart is an appropriate way to present their data.

Bottom line: Don’t trust Excel’s chart recommendations, except for very simple data sets. Instead, 
take some time and become familiar with Excel’s chart types. Strive for simplicity and clarity, and you 
won’t be tempted to take bad advice from a computer program.
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Customizing Charts
If you’ve ever been frustrated when trying to customize a chart, here’s some good news: Excel 2013 
makes this task easier than ever.

When you click on a chart in Excel 2013, you see three buttons at the upper-right of the chart. These 
buttons are the key to quick and easy chart customization.

Adding or removing chart elements
Figure 85-1 shows the options available when you click the Chart Elements button. Note that each 
item can be expanded to show additional options. To expand an item in the Chart Elements list, 
hover your mouse over the item and click the arrow that appears.

When you display the options for a button, hover the mouse over the item to get a preview of how 
the chart will look if you select (or deselect) an item.

Figure 85-1: Options available from the Chart Elements button.

Modifying a chart style or colors
Figure 85-2 shows the options available when you click the Chart Styles button.

Notice that there’s a two-item menu at the top: Style and Color. Click the Color item, and you can 
choose a different color palette for your chart.
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Figure 85-2: Options available from the Chart Styles button.

Filtering chart data
Options for the third button, Chart Filters, are shown in Figure 85-3. These options enable you to 
quickly hide one or more charts series or even data points within a chart series.

Note that previewing works differently for these options, and you must click the Apply button to see 
the effect of filtering.

Figure 85-3: Options available from the Chart Filters button.
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Making Charts the Same Size
If you have several embedded charts on a worksheet, you might want to make them all exactly the 
same size. Figure 86-1 shows a worksheet with four charts that would look better if they were all the 
same size and aligned.

Figure 86-1: These charts would look better if they were all the same size.

To make all the charts the same size, first identify the chart that is already the size you want. In this 
case, you want to make all the charts the same size as the Subject 2 chart in the upper-right area.

	 1.	 Click the chart to select it.

	 2.	 Choose Chart Tools➜Format.

		  You see the Height and Width settings in the Size group.

	 3.	 Make a note of the Height and Width settings.

	 4.	 Press Ctrl while you click the other three charts (so that all four are selected).

	 5.	 Choose Drawing Tools➜Format, enter the Height and Width settings that you noted in  
Step 3 and then click OK.

		  The charts are now exactly the same size.
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You can align the charts manually, or you can use the Chart Tools➜Format➜Arrange➜Align commands. 
Figure 86-2 shows the result.

Note that if you Ctrl+click a chart, you select it as a graphic object so that you can use the arrow keys 
to move the chart. Using the arrow keys moves the chart one pixel at a time and allows more control 
than dragging it with your mouse.

Figure 86-2: Four charts, resized and aligned.
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Creating a Chart Template
If you find that you’re continually making the same types of customizations to your charts, you can 
probably save some time by creating a template. Many users avoid this feature because they think 
that it’s too complicated. Creating a chart template is actually very simple.

Figure 87-1 shows a highly customized chart that will be saved as a template so it can be used for 
future charts. This chart includes a shape and a text box, and both of these added elements are 
included in the template.

Figure 87-1: This chart will be saved as a template.

Creating a template
To create a chart template, follow these steps:

	 1.	 Create a chart to serve as the basis for your template.

		  The data you use for this chart isn’t critical, but for best results, it should be typical of the 
data that you will eventually plot with your custom chart type.

	 2.	 Apply any formatting and customizations that you like.

		  This step determines the appearance of the charts created from the template.

	 3.	 Activate the chart; then right-click and choose Save as Template from the shortcut menu. 
(The Excel 2013 Ribbon doesn’t have a command to create a chart template.)

		  The Save Chart Template dialog box appears.

	 4.	 Provide a name for the template and click Save.

Chart templates are stored as *.ctrx files. You can create as many chart templates as you need.
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Using a template
To create a chart based on a template you’ve created, follow these steps:

	 1.	 Select the data to be used in the chart.

	 2.	 Choose Insert➜Charts➜Recommended Charts.

		  The Insert Chart dialog box appears.

	 3.	 At the top of the Insert Chart dialog box, choose the All Charts tab.

	 4.	 Choose Templates from the list on the left.

		  Excel displays a preview image (using the selected data) for each custom template that has 
been created (see Figure 87-2).

	 5.	 Click the image that represents the template you want to use and click OK.

		  Excel creates the chart based on the template you selected.

You can also apply a template to an existing chart. Select the chart and choose Chart Tools➜ 

Design➜Change Chart Type. That command displays a dialog box that’s exactly the same as the Insert 
Chart dialog box. Choose the All Charts tab and then choose Templates from the list on the left.

Figure 87-2: Choosing a chart template.
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Creating a Combination Chart
A combination chart combines two chart types in a single chart. A combination chart may use a sec-
ondary vertical axis. In the past, creating a combination chart in Excel was relatively complicated and 
required some non-intuitive steps. Excel 2013 finally gets it right: creating a combination chart is easy.

Figure 88-1 shows a column chart with two data series: Temperature and Precipitation. Because 
these two measures have drastically different scales, the columns for the precipitation data are hardly 
visible. This is a good candidate for a combination chart.

Figure 88-1: The two data series in this chart use drastically different scales.

Inserting a preconfigured combination chart
The following steps describe how to create a combination chart from the data in range A2:M4. The 
chart will display temperature as columns, and precipitation as a line. In addition, the precipitation 
series will use a secondary vertical axis.

	 1.	 Select the range A2:M4.

	 2.	 Choose Insert➜Charts➜Combo.

		  This command expands to display three icons (see Figure 88-2). Hover your mouse over the 
icons, and you’ll see a preview.
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	 3.	 Choose the second icon: Clustered Column — Line on Secondary Axis.

		  Excel creates the chart shown on Figure 88-3.

Figure 88-2: Excel proposes three preconfigured combination charts.

Figure 88-3: Excel created this combination chart with just a few mouse clicks.

The chart clearly shows both data series. The primary axis (on the left) is for the Avg Temperature 
series (columns). The secondary axis (on the right) is for the Avg Precipitation series (the line). You 
may want to add axis labels to make it easier to distinguish the two axes.

Customizing a combination chart
In some cases, none of the preconfigured combination charts will be exactly what you want. But cre-
ating a customized combination chart is a simple matter.

Choose Insert➜Charts➜Combo➜Create Custom Combo Chart, and the Insert Chart dialog box 
appears with the Combo section displayed (see Figure 88-4). Use the controls at the bottom of the All 
Charts tab of the Insert Chart dialog box to specify the chart type for each data series. Use the check 
boxes to indicate which (if any) of the series will use a secondary axis.
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Figure 88-4: Use the controls at the bottom of this dialog box to customize a combination chart.

You have a great deal of control in customizing combination charts. But just because Excel allows 
you to create a certain combination chart doesn’t mean it’s a good idea. Figure 88-5 shows a custom 
combination chart that uses bars and columns — and it’s not a good example of an effective chart.

Figure 88-5: An example of a poorly conceived custom combination chart.
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Handling Missing Data in a Chart
Sometimes, data that you’re charting may be missing one or more data points. As shown in Figure 89-1, 
Excel offers three ways to handle the missing data:

➤	 Gaps: Missing data is simply ignored, and the data series will have a gap. This is the default 
way missing data is handled in a chart.

➤	 Zero: Missing data is treated as zero.

➤	 Connect Data Points with Line: Missing data is interpolated, calculated by using data on 
either side of the missing point(s). This option is available for line charts, area charts, and XY 
charts only.

Figure 89-1: Three options for dealing with missing data.

To specify how to deal with missing data for a chart, choose Chart Tools➜Design➜Data➜Select 
Data. In the Select Data Source dialog box, click the Hidden and Empty Cells button. The Hidden and 
Empty Cell Settings dialog box appears, as shown in Figure 89-2. Make your choice in the dialog box.
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The option that you choose applies to the entire chart, and you can’t set a different option for differ-
ent series in the same chart.

Figure 89-2: The Hidden and Empty Cell Settings dialog box.

Note 	

Normally, a chart doesn’t display data that’s in a hidden row or column. You can use the 
Hidden and Empty Cell Settings dialog box to force a chart to use hidden data, though.
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Using High-Low Lines in a Chart
Excel supports a number of stock market charts, which are normally used to display stock market 
data. For example, you can create a chart that shows a stock’s daily high, low, and closing prices. That 
particular chart type requires three data series.

But stock market charts aren’t just for stock prices. Figure 90-1 shows a chart that depicts daily tempera-
tures for a month. The vertical lines (called high-low lines) show the temperature range for the day.

This chart was created with a single command. I selected the range A3:D34, chose Insert➜Charts➜ 

Other Charts, and selected the High-Low-Close option. You can, of course, format the high-low lines 
any way you like. And you may prefer to have the average temperatures connected with a line.

Figure 90-1: Using a stock market chart to plot temperature data.

When creating stock market charts, the order of the data for the chart series is critical. Because I 
chose the High-Low-Close chart type, the series must be arranged in that order. In this case, the 
“Close” data corresponds to Average temperatures.
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Using Multi-Level Category Labels
Most users don’t realize it, but when you create a chart, you can display multi-level category labels. 
You don’t have to do anything special. Just select all of the data before you create the chart. Excel 
takes care of the details for you.

Figure 91-1 shows an example of a chart that uses two columns for the category labels. Here, the first 
level is the region, and the second level is the state. Notice that the Region labels in column A aren’t 
repeated for each state. The blank regions cause the region name to appear once in the chart.

Figure 91-1: A chart that uses two columns for category labels.

Figure 91-2 shows another example, which uses three columns for the category axis labels. In this exam-
ple, the additional lines of text are used to provide more information about each of the four branches.

Figure 91-2: A chart that uses three columns for category labels.
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You can apply formatting to the category axis labels, but the formatting is applied to all of the text. In 
other words, you can’t apply different formatting for each level.

Figure 91-3 shows a variation of the previous example. After creating the chart with a multi-level 
category axis, I selected the category axis and pressed Ctrl+1 to display the Format Axis task pane. 
In the Axis Options➜Labels section, I specified the Label Position to be High. I also deselected the 
Multi-level Category Labels option, which has the effect of making the lines closer together.

Figure 91-3: A chart that displays category labels at the top.
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Linking Chart Text to Cells
When you create a chart, you may want to have some of the chart’s text elements linked to cells. That 
way, when you change the text in the cell, the corresponding chart element is updated. You can even 
link chart text elements to cells that contain a formula. For example, you might link the chart title to a 
cell that contains a formula that returns the current date.

You can create a link to a cell for the chart title, the axis titles, and individual data labels.

	 1.	 Select the chart element that will contain the cell link.

	 2.	 Click the Formula bar.

	 3.	 Type an equal sign (=).

	 4.	 Click the cell that will be linked to the chart element.

	 5.	 Press Enter.

Figure 92-1 shows a chart title being linked to cell A1.

Figure 92-1: Adding a cell link to a chart title.
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Oddly, this technique doesn’t work if the cell has a name. Excel displays an error claim-
ing that the formula contains an error. If you must link the chart element to a named 
cell, override the name with the sheet name and cell address. For example:

=Sheet1!A12

In addition, you can add a linked text box (or a linked shape) to a chart:

	 1.	 Select the chart.

	 2.	 Choose Insert➜Text➜Text Box. Or choose Insert➜Illustrations➜Shapes and choose a shape 
that supports text.

	 3.	 Click inside the chart to add an empty text box (or shape).

	 4.	 Click the Formula bar.

	 5.	 Type an equal sign (=).

	 6.	 Click the cell that will be linked to the object.

	 7.	 Press Enter.

Note

www.it-ebooks.info

http://www.it-ebooks.info/


Tip 93: Freezing a Chart 257

Freezing a Chart
Normally, an Excel chart uses data stored in a range. Change the data, and the chart is updated auto-
matically. Usually, that’s a good thing. But sometimes you want to “unlink” the chart from its data 
range to produce a static chart — a snapshot of a chart that never changes. For example, if you plot 
data generated by various what-if scenarios, you may want to save a chart that represents a baseline 
so that you can compare it with other scenarios. You can freeze a chart in two ways:

➤	 Convert the chart to a picture.

➤	 Convert the range references to arrays.

Converting a chart into a picture
To convert a chart to a static picture, follow these steps:

	 1.	 Create the chart as usual and format it the way you want.

	 2.	 Click the chart to activate it.

	 3.	 Choose Home➜Clipboard➜Copy➜Copy As Picture.

		  The Copy Picture dialog box appears.

	 4.	 Accept the default settings and click OK.

	 5.	 Click any cell to deselect the chart.

	 6.	 Press Ctrl+V to paste the picture at the cell you selected in Step 5.

The result is a picture of the original chart. This chart can be edited as a picture, but not as a chart. In 
other words, you can no longer modify properties such as chart type and data labels. It’s a dead 
chart — just what you wanted.

When you select the picture, Excel displays its Picture Tools contextual menu. You can use all of the 
tools in Picture Tools➜Format, plus those available in the Format Picture dialog box (displayed when 
you press Ctrl+1). Figure 93-1 shows a few examples of picture styles applied to a chart that was cop-
ied as a picture.
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Figure 93-1: Applying picture styles to a chart that was copied as a picture.

Converting range references into arrays
The other way to unlink a chart from its data is to convert the SERIES formula range references to 
arrays. Follow these steps:

	 1.	 Activate your chart.

	 2.	 Click a chart series.

		  The Formula bar displays the SERIES formula for the selected data series.

	 3.	 Click the Formula bar.

	 4.	 Press F9 and then press Enter.

Repeat these steps for each series in the chart.

Figure 93-2 shows a pie chart that has been unlinked from its data range. Notice that the Formula bar 
displays arrays, not range references. The original data SERIES formula was

=SERIES(,Sheet3!$A$1:$A$6,Sheet3!$B$1:$B$6,1)
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The converted SERIES formula is

=SERIES(,{“Work”,”Sleep”,”Commute”,”Eat”,
“Play Banjo”,”Other”},{8,7,2,1,3,3},1)

Note 	

Excel places a limit on the length of a SERIES formula. Therefore, this method may not 
work if the series consists of a large number of data points.

Figure 93-2: This chart is no longer linked to a data range.
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Creating a Chart Directly in a Range
This tip describes two ways to display a bar chart directly in a range of cells:

➤	 Using conditional formatting data bars

➤	 Using formulas that display repeating characters

These “non-chart” charts often serve as a quick way to display lots of data graphically, without creat-
ing actual charts.

Using conditional formatting data bars
Using the data bars conditional formatting option can sometimes serve as a quick alternative to cre-
ating a chart. The data bars conditional format displays horizontal bars directly in the cell. The length 
of the bar is based on the value of the cell, relative to the other values in the range. When you adjust 
the column width, the bar lengths adjust accordingly. The differences among the bar lengths are 
more prominent when the column is wider. 

Figure 94-1 shows results from a survey, using data bars to visualize the distribution for each survey 
item.

Figure 94-1: These tables use data bars conditional formatting.
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To add data bars to a range, select the range and choose Home➜Conditional Formatting➜Data Bars 
and select one of the fill options.

Excel provides quick access to 12 data bar styles via Home➜Styles➜Conditional Formatting➜Data 
Bars. For additional choices, click the More Rules option, which displays the New Formatting Rule dia-
log box. Use this dialog box to do the following:

➤	 Show the bar only (hide the numbers).

➤	 Specify Minimum and Maximum values for the scaling.

➤	 Change the appearance of the bars.

➤	 Specify how negative values and the axis are handled.

➤	 Specify the direction of the bars.

Using formulas to display repeating characters
Figure 94-2 shows an example of a chart created by using formulas.

Figure 94-2: A histogram created directly in a range of cells.

Column D contains formulas that incorporate the rarely used REPT function, which repeats a text 
string a specified number of times. For example, the following formula displays five asterisks:

=REPT(“*”,5)

In the example shown in Figure 94-2, cell D3 contains this formula, which was copied down the column:

=REPT(“*”,C3/2)
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Notice that the formula divides the value in column B by 2. This is a way to scale the chart. Instead of 
displaying 60 asterisks, the cell displays 30 asterisks. For improved accuracy, you can use the ROUND 
function:

=REPT(“*”,ROUND(C3/2,0))

Without the ROUND function, the formula truncates the result of the division (disregards the decimal 
part of the argument). For example, the value 67 in column B displays 33 characters in column D. 
Using ROUND rounds up the result to 34 characters.

You can use this type of graphical display in place of a column chart. As long as you don’t require 
strict accuracy (because of rounding errors), this type of nonchart might fit the bill.

Figure 94-3 shows some other examples that use different characters and fonts. The chart that dis-
plays the solid bars (beginning in row 39) uses the pipe character of the Script font. On most key-
boards, the pipe character is generated when you press Shift+backslash. The formula in cell D39 is

=REPT(“|”,C39/2000)

Figure 94-3: Examples of in-cell charting using the REPT function.
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The example in Figure 94-4 uses formulas in columns F and H to graphically depict monthly budget 
variances by displaying a series of characters. You can then easily see which budget items are under 
or over budget. This pseudo bar chart uses the character n, which appears as a small square in the 
Wingdings font.

The key formulas are

F3: =IF(D3<0,REPT(“n”,-ROUND(D3*100,0)),””)
G3: =A3
H3: =IF(D3>0,REPT(“n”,-ROUND(D3*-100,0)),””)

Figure 94-4: Displaying monthly budget variances by using the REPT function.

For this example, follow these steps to set up the bar chart after entering the preceding formulas:

	 1.	 Assign the Wingdings font to cells F3 and H3.

	 2.	 Copy the formulas down columns F, G, and H to accommodate all the data.

	 3.	 Right-align the text in column E and adjust any other formatting.

Depending on the numerical range of your data, you may need to change the scaling. Experiment by 
replacing the 100 value in the formulas. You can substitute any character you like for the n in the for-
mulas to produce a different character in the chart.
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Creating Minimalistic Charts
Effective charts don’t always have to be complicated. In fact, simpler charts that convey a clear mes-
sage are almost always preferable to more complex charts.

This tip presents some simple charts that demonstrate various ways to provide a different visual 
experience, compared to the standard chart types. The point is to help you realize that, with a bit of 
creativity, you can create charts that don’t look like everyone else’s charts.

Simple column charts
Figure 95-1 shows four charts, each of which uses only one data point. This data could be displayed 
in a single chart, but using four charts provides a different, cleaner look.

These are very minimalistic charts. The only chart elements displayed are the single data point series, 
the data label for that data point, and the chart tile (displayed on the left, and rotated). The single 
column fills the entire width of the plot area.

Figure 95-1: Four minimalistic column charts.

Simple pie charts
Figure 95-2 shows the same data, plotted as four pie charts. These charts were adjusted such that the 
angle of the first slice is 0 degrees. That step makes it easy to make comparisons across the four 
charts.

The chart titles are linked to the cells in column E (see Tip 92). Each title is generated with a formula 
that uses the original data. For example, the formula in cell E2 is

=A2&” (“&TEXT(B2,”0%”)&”)”
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Figure 95-2: Four pie charts.

Simple line charts
Figure 95-3 shows four line charts, with all chart elements removed except for the series and the data 
labels. Importantly, all four charts use the same vertical scale values (0 through 50). If you allowed 
Excel to calculate the scale bounds, comparisons among the charts would be difficult.

Figure 95-3: Four line charts.

Using four charts makes it very easy to spot trends. The alternative, four series in a single chart, is 
shown in Figure 95-4.

www.it-ebooks.info

http://www.it-ebooks.info/


Tip 95: Creating Minimalistic Charts266

Figure 95-4: A line chart with four series.

Note 	

Another option is to use Sparkline graphics — perhaps the ultimate in minimal charts. 
Sparklines are small graphics that display directly in a cell.

A gauge chart
Figure 95-5 shows a chart based on a single cell. It’s a pie chart set up to resemble a gauge. Although 
this chart displays only one value (entered in cell B1), it actually uses three data points (in A4:A6).

Figure 95-5: This chart resembles a speedometer gauge and displays a value between 0 and 100 percent.
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One slice of the pie — the slice at the bottom — always consists of 50 percent. I rotated the pie so 
that the 50-percent slice was at the bottom. Then I hid that slice by specifying No Fill and No Border 
for the data point. The other two slices are apportioned based on the value in cell B1. The formula in 
cell B4 is

=MIN(B1,100%)/2

This formula uses the MIN function to display the smaller of two values: either the value in cell B1 or 
100 percent. It then divides this value by 2 because only the top half of the pie is relevant. Using the 
MIN function prevents the chart from displaying more than 100 percent.

The formula in cell A5 simply calculates the remaining part of the pie — the part to the right of the 
gauge’s needle:

=50%-A4

The chart’s title (Percent Completed) was moved below the half-pie. A linked text box displays the 
percent completed value in cell B1.
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Applying Chart Data Labels from a Range
Excel 2013 introduced a feature that’s been on the wish lists of many users for at least 15 years: the 
ability to specify an arbitrary range to be used as data labels for a series.

Figure 96-1 shows an XY scatter chart that uses data labels stored in a range to identify the data 
points. In previous versions of Excel, adding these data labels had to be done manually, or with the 
assistance of a macro.

Figure 96-1: Excel 2013 can add data labels from an arbitrary range.

To specify data labels from a range:

	 1.	 Activate the chart and select the series that will contain data labels.

	 2.	 Click the Chart Elements icon (to the right of the chart) and add data labels.

		  Excel displays default data labels for the series.

	 3.	 Select the data labels and press Alt+1 to display the Format Data Labels task pane.

	 4.	 In the Label Options section of Format Data Labels task pane, deselect any check boxes that 
are selected and select the Values from Cells check box.

		  The Data Label Range dialog box appears, as shown in Figure 96-2.

	 5.	 Specify the range that contains the labels and click OK.
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Figure 96-2: Specifying a range to be used as data labels.

Note 	

When the data labels are placed on the chart, you can fine-tune the location of each one, 
if necessary. Click one data label to select them all; then click a single data label and 
drag it to its new position.
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Grouping Charts and Other Objects
If you create a number of charts, you may want to be able to work with them all as a group. For 
example, move them all, or resize them all. The solution is to group the charts into a single object.

Grouping charts
Start by creating the charts that you’d like to group and then arrange and size them as you like. Then 
press Shift and click each chart. When the charts are selected, right-click any one of them and choose 
Group➜Group.

Figure 97-1 shows six charts that have been grouped. The group name (Group 14) appears in the 
Name box.

Figure 97-1: Six charts, combined into a group.

To move the entire group, click anywhere in the group and drag.

Note 	

If the group is already selected when you click and drag, you will select a particular chart 
in the group and change its position. Most of the time, this is not what you want. Press 
Ctrl+Z to undo.

To resize the entire group, click anywhere in the group to select the group. Then drag any of the 
resizing handles that appear in the group’s outline.
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Figure 97-2 shows the grouped charts after I resized the entire group.

Figure 97-2: Grouped charts, after resizing the group.

Even though charts are grouped, you can still work with a particular chart in a group — and charts 
that are in a group can still be moved and resized individually. To work with a single chart in a group, 
click anywhere in the group to select the group; then click the chart you want to work on.

To ungroup the objects in the group, right-click anywhere in the group and choose Group➜ 

Ungroup.

Grouping other objects
You can combine various types of objects into a group. Figure 97-3 shows a group that consists of a 
shape (which serves as the background), a text box, and a chart. Figure 97-4 shows the group after I 
resized it to change the proportions. Resizing a group is much easier than resizing three separate 
objects.

Note 	

When combining objects that overlap, you’ll often need to adjust the stack order. Right-
click an object and use the Bring to Front or Send to Back commands.
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Figure 97-3: Three objects in a group.

Figure 97-4: The object group, after resizing.
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Taking Pictures of Ranges
Excel makes it easy to convert a range of cells into a picture. The picture can either be a static image 
(it doesn’t change if the original range changes) or a live picture (which reflects changes in the origi-
nal range). The range can even contain objects, such as charts or shapes.

Creating a static image of a range
To create a snapshot of a range, start by selecting a range of cells and then press Ctrl+C to copy the 
range to the Clipboard. Then choose Home➜Clipboard➜Paste➜Other Paste Options➜Picture (U). 
The result is a graphic image of the original range, pasted on top of the original range. Just click and 
drag to move the picture to another location. When you select this image, Excel displays its Picture 
Tools context menu — which means that you can apply some additional formatting to the picture.

Figure 98-1 shows a range of cells (B2:E9), along with a picture of the range after I applied one of the 
built-in styles from the Picture Tools➜Format➜Picture Styles gallery. It’s a static picture, so changes 
made within the range B2:E9 aren’t shown in the picture.

Note 	

If you want to include a graphic that shows information from another (non-Excel) win-
dow, choose Insert➜Illustrations➜Screenshot. You can capture an entire window or 
just a portion of a window (by choosing Screen Clipping). The copied information is 
pasted as a picture in the active worksheet.

Figure 98-1: A picture of a range, after applying some picture formatting.
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Creating a live image of a range
To create an image that’s linked to the original range of cells, select the cells and press Ctrl+C to copy 
the range to the Clipboard. Then choose Home➜Clipboard➜Paste➜Other Paste Options➜Linked 
Picture (I). Excel pastes a picture of the original range, and the picture is linked — if you make 
changes to the original, those changes are shown in the linked picture.

Notice that when you select the linked picture, the Formula bar displays the address of the original 
range. You can edit this range reference to change the cells that are displayed in the picture. To 
unlink the picture, just delete the formula on the Formula bar.

As with an unlinked picture, you can use Excel’s Picture Tools context menu to modify the appear-
ance of the linked picture.

You can also cut and paste this picture to a different worksheet, if you like. Doing so makes it easy to 
refer to information on a different sheet.

Figure 98-2 shows a linked picture of a range placed on top of a shape, which has lots of interesting 
formatting capabilities. Placing a linked picture on top of a shape is a good way to make a particular 
range stand out.

Figure 98-2: A linked picture of a range, placed on top of a shape.
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Saving a range as a graphic image
If you need to save a range as a graphic image, the best approach is to use one of several screen cap-
ture programs that are available. This type of software makes it easy to capture complete windows or 
just a portion of a window. After you capture the screen, click a button to save it as a graphics image 
in the format you choose (GIF, PNT, TIF, and so on).

If you don’t have a screen capture program, you probably have some other type of graphics software. 
When you copy a range of cells, that range is stored on the Windows Clipboard in several different 
formats. One of those formats is a graphic image. Therefore, you can copy a range, activate your 
graphics software, and press Ctrl+V to paste the range as a graphic. Then save the graphics file in 
your desired format.

Figure 98-3 shows a range after it was copied and pasted into a freeware program named IrfanView.

Figure 98-3: A range of data, ready to be saved as a graphic image.

Copying a range is a what-you-see-is-what-you-get thing. For example, if the selected range contains 
a chart, the chart will also appear in the image.

Cross-Ref	
For another method to save a range as a graphic image, see Tip 101.
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Changing the Look of Cell Comments
Cell comments are useful for a variety of purposes. But sometimes you just get tired of looking at the 
same old yellow rectangle. This tip describes three tricks that you can use to make your comments 
stand out:

➤	 Format a comment.

➤	 Change the shape of a comment.

➤	 Add an image to a comment.

Note 	

All of these changes require that the cell comment is visible. If the comment isn’t visible, 
right-click the cell and choose Show/Hide Comments from the shortcut menu.

Setting up your Quick Access toolbar
The operations described in this tip require commands that aren’t normally available in the Ribbon 
when a comment is selected. So the first step is to add three commands to your Quick Access toolbar:

	 1.	 Right-click the Quick Access toolbar and choose Customize Quick Access Toolbar.

		  The Customization section of the Excel Options dialog box appears.

	 2.	 From the Choose Commands From drop-down list, select All Commands.

	 3.	 In the list on the left, select Format Shape and then click the Add button.

	 4.	 In the list on the left, select Change Shape and then click the Add button.

	 5.	 In the list on the left, select Picture Fill and then click the Add button.

	 6.	 Click OK to close the Excel Options dialog box.

After you complete these steps, your Quick Access toolbar has three new icons.

Formatting a comment
To change the formatting of a comment, Ctrl+click the comment (to select it as a shape) and then 
click the Format Shape icon in your Quick Access toolbar, or you can press Ctrl+1. Either of these 
actions displays the Format Comment dialog box. This dialog box has eight tabs that enable you to 
change just about any aspect of the comment.
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Figure 99-1 shows a normal cell comment, and the same comment after changing the font, align-
ment, fill color, text color, and border width and style.

Figure 99-1: A normal cell comment and a comment with different formatting.

Changing the shape of a comment
Comments don’t have to display as a rectangular box. Figure 99-2 shows a cell comment, after apply-
ing a different shape.

To change the shape of a comment, Ctrl+click the comment (to select it as a shape). Click the Change 
Shape button on the Quick Access toolbar and choose a new shape for the comment from the Shape 
gallery.

Figure 99-2: A cell comment that uses a nonstandard shape.
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Adding an image to a cell comment
Most users don’t realize it, but a cell comment can display an image. The image can reside in a file or 
can come from the Office.com Clip Art collection. You can’t use shapes or clip art images that are 
copied to the Clipboard.

To add an image to a comment, Ctrl+click the comment to select it as a shape and then click the 
Picture Fill icon in the Quick Access toolbar. Excel displays the Insert Pictures dialog box, in which you 
can select or search for an image.

Figure 99-3 shows a comment that contains a clip art image. Using an image in a comment increases 
the size of your workbook, so keep that in mind before you go overboard with images.

Figure 99-3: Displaying an image in a cell comment.
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Enhancing Images
A set of features that you might overlook is image enhancement. These tools allow you to modify 
and enhance images that you insert on a worksheet. This doesn’t mean you can uninstall your favor-
ite image editing software, but you may be surprised at the type of enhancements you can perform 
without even leaving Excel.

To embed an image on a worksheet, choose Insert➜Illustrations➜Pictures (for an image stored on 
your hard drive) or Insert➜Illustrations➜Online Pictures (to search for and retrieve an image from an 
online source).

When you select an embedded image, use the tools in the Picture Tools➜Format➜Adjust group to 
work it. The tools include the following:

➤	 Remove Background: Makes it very easy to remove an extraneous background from a 
photo.

➤	 Corrections: Sharpen or soften the image or adjust the brightness and contrast.

➤	 Color: Adjust the color saturation and color tone or convert the image to use just a few colors.

➤	 Artistic Effects: Apply some Photoshop-like filters to the image.

➤	 Compress Pictures: Make your images smaller.

➤	 Change Picture: Substitute a different image for the selected image.

➤	 Reset Picture: Undo all modifications you’ve made.

In most cases, you get a live preview of the effect when you move your mouse pointer over the icon. 
Just click to apply it. For more control over the enhancements, right-click the image and choose 
Format Picture. Then use the controls in the Format Picture task pane to adjust the parameters.

Figure 100-1 shows a photo before and after I removed the background. The parts of the image that 
are removed become transparent. This feature works surprisingly well.
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Figure 100-1: The result of using the Remove Background command.

Figure 100-2 shows a clipart image before and after I applied the Pencil Grayscale effect.

Figure 100-2: Applying an artistic effect to a photo.

Even if you have no need to adjust images, you might enjoy playing around with these features 
when you need a break from number crunching.
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Saving Shapes, Charts, and Ranges as 
Images
Excel supports quite a few types of graphics, but it doesn’t provide a way to save the graphic as a 
separate file for use in another program. For example, you may want a separate PNG or GIF file cre-
ated from a chart, a shape, SmartArt, or even a range pasted as a picture (see Tip 98).

Although Excel doesn’t provide a direct way to export a graphic, here’s a useful trick you can use. 
First, a bit of set-up work is required:

	 1.	 Right-click the Quick Access toolbar and choose Customize the Quick Access Toolbar.

		  The Quick Access Toolbar tab of the Excel Options dialog box appears.

	 2.	 In the upper-left drop-down control, choose Commands Not in the Ribbon.

	 3.	 In the list box, scroll down and select Web Options and then click the Add button.

	 4.	 In the list box, select Web Page Preview and click the Add button.

	 5.	 Click OK to close the Excel Options dialog box.

		  Your Quick Access toolbar now has two new buttons.

Here’s how to use these tools to export graphic objects (including charts) from a worksheet.

	 1.	 Make sure that your graphics appear the way you want.

	 2.	 Click the Web Page Preview button in the Quick Access toolbar.

		  A copy of your workbook is converted to an HTML file and is displayed in your default 
browser.

	 3.	 In the browser, right-click a graphic object, choose Save Image As, and specify a location for 
the file.

		  Your browser may have a different, but equivalent, command. Or you can just drag the 
graphic image to your desktop.

If the quality of the images in your browser is lacking, click the Web Options button in your Quick 
Access toolbar. The Web Options dialog box is shown in Figure 101-1.
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Figure 101-1: The Web Options dialog box.

In the Web Options dialog box, click the Browsers tab and make sure Allow PNG as a Graphics Format 
is enabled. If graphics don’t appear in your browser at all, remove the check mark from Rely on VML 
for Displaying Graphics in Browser. Next, click the Pictures tab and choose the 120 Pixels Per Inch 
option. Click OK and do the web preview again. You should see higher-quality graphics (transparent 
PNG files).
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Index

formulas, entering properly, 114, 123
IFERROR function, using with, 124
limitations of, 207
lists, generating with, 27–28
multicell formulas, creating, 174–175
nonblank cells, finding with, 117
range references, converting into, 258–259

asterisk (*) wildcard character, 194
audio

proofing data with, 196
text-to-speech feature, enabling, 196
voice qualities, adjusting with, 197

AutoComplete, 211
AutoCorrect, propagating formulas with, 210
AutoFill

date series, creating with, 152
filling range with, 151
lists, creating for, 153
predicting values with, 152–153
table of data types, 153

autofit, issues with merged cells, 45
AutoRecover

autosave intervals, setting, 21
recovering unsaved workbooks with, 20–21
saved versions of current workbooks, using, 20

autosave
AutoRecover, using with, 20
intervals, setting, 21

AutoSum button (alt+=), 85–86
AVERAGE function, inserting with AutoSum button, 85
AVERAGEIF function, 220

B
bar charts, creating directly in ranges

condition formatting data bars, 260–261
formulas, using to display, 261–263
with repeating characters, 261

bullet lists
additional columns, creating with, 60–61
characters for, creating, 60
numbered lists, using for, 60–61
SmartArt, creating with, 61
wrap-text formatting, using with, 60

Symbols
#DIV/0! error message, 130
#REF! error message

avoiding display of, 90–91
displaying in name lists, 28, 30

* wildcard character, 194
? wildcard character, 195
~ search character, 195

A
absolute references. See also formulas

identifying with dollar signs, 87
in mixed references, 88–89
relative versus, 87
usefulness of, 88

add-ins
file format for, 37
Inquire, 132–134
XDATE, 111–112

Add-Watch dialog box, 83
Advanced Text Import Settings dialog box, 154
age calculations, 108–109
AGGREGATE function, 125–127
alignment

adjusting by indenting, 48–49
defaults for text and numbers, 48
font substitution, avoiding, 72–74

analysis tools, 132
apostrophes

including in worksheet names, 93
preceding credit card numbers with, 168

appearance. See also formatting
fonts, adjusting with, 75
ranges, converting into tables, 205–206
shading, adjusting with, 62–64

array formulas
curly braces, using with, 2
lookups, using with, 103

arrays
AGGREGATE function, replacing with, 125
concatenation, using with, 103
curly braces, using with, 2
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Chart Tools
aligning charts, 243–244
Hidden and Empty Cell Settings dialog box

dealing with missing data, 250
forcing hidden data use, 251

managing as graphic objects, 244
managing missing chart data with, 250
templates, applying with, 246

charts
aligning multiples of, 243–244
combination, 247–249
customization of

combination charts, 248–249
size alignment of multiples, 243–244
styles and colors, modifying, 241

data labels from ranges, applying, 268–269
dialog boxes for

Change Chart Type, 246
Hidden and Empty Cell Settings, 250–251
Insert Chart, 239, 246–250
Recommended Charts, 239
Save Chart Template, 245

filtering data in, 242
freezing

by converting into arrays, 258–259
by converting into static pictures, 257–258

graphic objects, managing as, 244
hidden data management, 251
high-low lines, uses for, 252
interactive, creating, 233
linking to cells, 255–256
missing data management, 250
multi-level category labels, using, 253–254
Quick Analysis feature, 190
saving as images, 281–282
slicers, creating with, 233
stock market, 240, 252
tables, creating from

advantages of, 207
overview, 205
pivot tables, 226
Recommended Charts, 239–240

templates, using with
applying to existing charts, 246
creating, 245
Insert Chart dialog box, 246
saving, 245

themes, using with, 32
types of, 240

cloud computing
advantages of, 22
disadvantages of, 22–23

C
calculated columns

numbering rows automatically with, 212–213
supported by tables, 207

calendars, 114–115
cascading style sheets (CSS), 186
case sensitivity, 3
CEILING.MATH function

overview, 118
rounding values up with, 119

cell comments
appearance of, adjusting, 276–277
commands, adding to toolbar, 276
images, adding to, 278
shape of, changing, 277

cells
cleaning formatting from, 134
copying formatting to ranges of, 67
diagramming relationships between, 133
dialog boxes for

Format Cells, 47–49, 52, 54–58, 62–63, 65
Hidden and Empty Cell Settings, 250–251

drop-down lists, creating in, 160–161
error identification in, 130
fonts in formatted, changing, 76
formatting individual characters in, 65
formatting with Format Painter, 66–67
hiding, 135–137
importing CSV files into, 188–189
last nonblank, finding, 116–118
linking to charts, 255–256
locating all merged types, 45
locking, 135–137
merging, 43–47
mixing text and values in, 70–71
mouse versus keyboard selection, 147
pivot tables, controlling within, 222–223
Protection option, using with, 53
references, making unchangeable, 140
restricting formula entries, 155–156
restrictions on protected worksheets, 137
selecting current region, 148
selecting noncontiguous, 148
shading rows and columns of, 62–64
text length limitations in HYPERLINK functions, 98
themes, using with, 32
unchangeable references, creating, 140
Watch Window, monitoring with, 83–84

Change Chart Type dialog box, 246
Change PivotTable Data Source dialog box, 231
chart sheets, 30
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comma separated values (CSV) files
importing text with, 188–189
issues with credit card numbers, 169

commands
listing of, 11–12
Quick Access toolbar, 10–12

comparing files, 133–134
compatibility

DATEIF function for Lotus 1-2-3, 109
IFERROR versus ISERROR functions in, 91
limitations of, 38
sharing issues, 161, 207
updating fonts on old worksheets, 75–77
zip and XML files, 37

Compatibility Checker, 38
concatenation

Flash Fill, using instead of, 179
for HYPERLINK function, 98
lookup tables, creating with, 104
text and numbers, displaying with, 70

conditional formatting
alternate row shading, creating with, 62–63
checkerboard shading, creating with, 63
comparing ranges with, 162–164
Conditional Formatting dialog box, 163, 165–167
duplicates, finding with, 165–167
excess spaces, identifying with, 171–172
shading groups of rows with, 64
themes, using with, 32

Conditional Formatting dialog box, 163, 165–167
CONVERT function

arguments required for, 121–122
measurement systems converted, 121

Convert Text to Columns Wizard dialog box, 129
converting measurements

overview, 121–122
table of functions, 122

Copy Picture dialog box, 257
copying data

importing from PDF files, 198–201
ranges of formulas, 128–129

COUNT function, inserting with AutoSum button, 85
COUNTA function, 116
COUNTIF function, 164
Create Names from Selection dialog box, 102
Create New Theme Fonts dialog box, 35
Create PDF/XPS button, 24
Create PivotTable dialog box

frequency tabulations, creating, 224–225
multiple groupings, 230–231
overview, 220

Excel Web App versus desktop version, 22
synching files with, 22

colors
in charts, modifying, 241–242
custom themes, selecting for, 35
customizing for themes, 36
highlighting list changes with, 163–164, 166
identifying errors with, 171

column charts, 264–265
COLUMN function, using for column shading, 62–64
column names

in formulas, 208
formulas, creating with, 210
naming with dialog box, 102
structured references, creating with, 208

columns
automatically adjusting with tables, 207
averaging with pivot tables, 230–231
calculated, 207, 212–213
centering text across, 47
concatenating for lookups, 103–104
copying and pasting data into, 128
credit cards, specifying Text number format for, 168–169
dialog boxes for

Convert Text to Columns Wizard, 129
Text to Columns, 154

duplicates of, identifying, 167
filters, creating in tables, 207
Format Painter, copying formatting with, 67
frequency tabulations, creating for, 224–226
hidden data management, 251
last value in, finding, 116–117
missing data management, 250
naming, 102, 207
propagating formulas automatically in, 210, 212
running totals, creating in, 190–191
selecting entire, 149
shading options for, 62–64
sorting contents in, 84
subtotals, inserting with pivot tables, 220–221
transposing with rows, 173–175
vertical ranges, converting to tables, 142–143
width of, changing

with autofit, 45
manually, 84

COM Add-Ins dialog box, 132
combination charts

creating, 247
customizing, 248–249
inserting preconfigured charts, 247–248
unavailable from Recommended Charts, 240
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Flash Fill
using to combine, 179–180
using to extract, 176–178

hidden data management, 251
importing from web pages, 184–185
indenting in cells, 48–49
keyboard selection of, 148
lists, comparing, 162–164
merged cells, issues with, 45
missing data management, 250
pivot table requirements, 214
proofing with audio, 196
quick queries for, 185–186
referencing in pivot tables with outside formulas, 222
SUBTOTAL versus TOTAL functions, 86
table references, using to access, 211
Text to Columns Wizard, managing with, 129
trailing minus signs, fixing, 154
transforming

with temporary formulas, 158–159
vertical records into tables, 142–143
without formulas, 157–158

unchangeable cell references, creating, 140
Data Label Range dialog box, 268
data labels

adjusting location of, 269
applying in charts from ranges, 268–269
Format Data Labels, using with, 268
linking to cells, 255

Data Validation dialog box, 160–161
database tables

normalized versus non-normalized, 214–216
overview, 214

DATEIF function
calculating ages with, 108–109
code list for, 109
overview, 109

dates
AutoFill

creating series with, 152
predicting values with, 152–153

CONVERT function, using with, 121–122
custom formats of, codes for, 57
holidays, calculating, 105–107
live calendars, displaying, 114–115
pre-1900

Google Spreadsheet, using for, 113
issues with, 110–111
XDATE functions, using for, 111–112

searching options, 195
diagram tools, 133

credit card numbers
importing as text for accuracy, 169
importing with CSV files, 169, 189
manual entry of, 168
storing accurately, 168

CSS (cascading style sheets), 186
CSV (comma separated values) files

importing text with, 188–189
issues with credit card numbers, 169

curly braces, 2
cursor movement, restricting to Input cells, 155–156
custom number formats

codes for, 55–56
data testing format strings, 55
dates and times, codes for, 57
displaying text and numbers with, 71
Format Cells dialog box, creating with, 54, 58
overview, 54
scale values, 58–59
specifying codes for, 55

Custom Views
forbidden within tables, 207
named worksheet views, creating with, 8

Customize Ribbon tab
accessing by right-click, 15
expanding lists on, 15
hiding built-in tabs with, 16
renaming tabs and groups with, 16

D
dashboards

slicers, creating with, 232
timelines, using with, 234–235

data. See also cells; filters; formulas; lookups
AutoFill, predicting values with, 152–153
concatenation of, 70, 103–104, 179
copying and pasting, 128
copying from Protected View documents, 18
custom number formats, testing with, 55
default alignment of, 48
dialog boxes for

Change PivotTable Data Source, 231
Data Validation, 160–161
External Data Range, 188–189
Hidden and Empty Cell Settings, 250–251
Import Data, 185–186
Select Data Source, 250

displaying in pivot table charts, 226
filtering

with Chart Filters, 242
with labels, 232
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EVEN function, 118
exact values, finding

with implicit intersections, 102
with intersection formulas, 101–102
with VLOOKUP and HLOOKUP, 99–100

Excel Options dialog box
AutoRecover, controlling with, 21
commands on, 11
Customize Ribbon tab, accessing, 14–15
enabling error-checking in, 130–131
hiding display elements with, 9
limitations of, 12
overview, 11–12
Quick Access toolbar, customizing with, 10–13
Ribbon, customizing with, 14–15

Excel Web App, 22–23
External Data Range dialog box, 188–189

F
filenames

available formats, 37
creating list with macro, 27–28
macro-enabled file extensions, 28, 31

files
Compare Files command, 133–134
Compatibility Checker use, 38
compatibility issues with, 37–38
copying data from Protected View, 18
Import Text file dialog box, 188–189
macro-enabled extensions, 31
MHTML format

advantages of, 26
saving in, 25

Office Compatibility Pack, installing, 37–38
Page Layout view, using before saving, 24
PDF format, saving in, 24–25
printing from Protected View, 18
Protected View management, 17–19
protecting integrity of, 24–26
read-only, sending as, 26
web browsers, creating in, 22
XML, reading with zip utilities, 37
XPS format, saving in, 24

FILES function, 27
fill handles, enabling, 151
filling

autofill, 151–153
cells with color, 166, 171
Flash Fill, 176–180
reporting gaps with, 192–193
shading, 62–64
styles for, 50

dialog boxes. See also specific dialog boxes by name
formulas, editing in, 141
modeless, advantages of, 131
toggling point mode and edit mode, 141

display, changing
alternative themes, 7
hiding elements from view, 9
hiding Ribbon display, 8
hiding status bar, 9
View tab options, 8

#DIV/0! error message, 130
dollar signs, identifying absolute references with, 87
DOLLARDE function, 118
DOLLARFR function, 118
Drawing Tools

modifying text boxes with, 47
sizing charts with, 243

drop-down lists
Data Validation dialog box, creating with, 160
in named range for sharing, 161

duplicates
COUNTIF function, using to find, 164–167
finding in ranges with conditional formatting, 165
identifying entire columns, 167
identifying entire rows, 166
removing, 167

E
Edit DWORD dialog box, 73
Edit Name dialog box, 95
e-mail

creating address lists with Flash Fill, 179
sending from Excel, 96–98

ENCODEURL function
encoding non-alphanumeric characters with, 96
examples of, 97–98

Error Checking dialog box, 131
error messages

#DIV/0!, 130
#REF!, 28, 30
AGGREGATE function, handling with, 125–127
avoiding displays of, 90–91
overriding with named cells, 256

error-checking
cautions regarding, 131
cells, identifying errors in, 130
dialog boxes for

Error Checking, 131
Ignore Error option, 131
New Formatting Rule, 171

excess spaces, identifying, 171
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style attributes, setting, 50
superscript and subscript, applying, 65

Format Comment dialog box, 276
Format Painter

basics, 66
copying from range of cells, 67
removing all formatting with, 67

Format Picture dialog box, 257
formatting. See also custom number formats

combining four series, 254
dialog boxes for

Find Format, 45
Format Cells, 47–49, 52, 54–58, 62–65
Format Comment, 276
Format Picture, 257

fonts on old worksheets, updating, 75–77
Format Painter, 66–67
individual text characters in cells, 65
inexact searches, issues with, 195
of numbers, 54
Quick Analysis feature, 190
ranges versus tables, 206–207
superscript and subscript, applying, 65

Formatting (R) command, 67
Formula AutoComplete feature, 211
formula bar, resizing to edit worksheets, 81–82
Formula view mode, toggling, 128
formulas. See also absolute references; mixed references

accidental overwrites of, preventing, 155–156
automatically adjusting through tables, 211
AutoSum button, inserting with, 85–86
bar charts, creating with, 261–263
column names, creating with, 210
editing in dialog boxes, 141
enabling error-checking for, 130–131
exactly copying ranges of, 128–129
filenames, generating list of, 27–28
hiding, 135–137
INDIRECT function, building flexibility with, 138–140
intellisense drop-down list for, 95
locking, 135–137
named, 27–31
versus pivot tables, 218–221
in pivot tables, 222–223
propagating automatically in tables, 207, 210, 212
ranges, converting to tables with, 142–143
referencing cells in pivot tables, 222–223
restrictions on protected worksheets, 137
sheet names, generating list of, 28–31
table references with, 211
tables, adding to, 209–210
transforming data with, 157–158
updating by linking cells to charts, 255–256

filters
chart, 242
displaying multiple values with, 233
filter buttons for, 207
hiding rows

using AGGREGATE function, 126
using SUBTOTAL function, 126, 213

with images, 279
labels for, 232
merged cell issues, 45
overview, 213
pivot tables, sorting with, 226
with Quick Access Toolbar, 11
with slicers, 207, 232–233
SUBTOTAL versus SUM functions with, 86
in tables versus ranges, 206–207
timelines with, 234–235

Find and Replace dialog box
inexact searches with, 194–195
merged cells, finding, 45–46
searching for values with, 195
unwanted characters, removing with, 195
updating fonts in formatted cells with, 76
wildcard characters, 194–195

Find Format dialog box, 45
FIND function, 28–29
Flash Fill

case of text, changing with, 176
combining data with, 179–180
domain names, extracting from URLs with, 178
extracting names with, 177–178
overview, 176
potential problems with, 178
training pattern recognition in, 176–180

FLOOR.MATH function, 118–119
fonts

Create New Theme Fonts dialog box, 35
for custom themes, 35
legibility, adjusting with, 75
substitution with registry editing, disabling, 72–74
updating in formatted cells, 76
updating on old worksheets, 75–77

footers
inserting images into, 68
printer options for, specifying, 40
watermarks, creating with, 68–69

Format Cells dialog box
alternate row shading, displaying, 62–63
centering text across columns, 47
codes for, specifying, 55
custom number formats, creating, 54–58
formatting new styles, 52
indentation, 48–49
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I
icons

displaying names of, 10
finding hidden on toolbar, 10
rearranging on Quick Access toolbar, 12–13

IF function, using with ISERROR function, 91
IFERROR function

for error message substitutions, 100
hiding error values with, 90–91
ISERROR versus, 91

images
capturing from windows, 273
comments, adding to, 278
dialog boxes for

Copy Picture, 257
Format Picture, 257
Insert Picture, 68, 278

enhancing within Excel, 279–280
exporting from worksheets, 281–282
Format Picture dialog box, adjusting with, 68
modifying linked, 274
modifying on worksheets, 279
for Office Background, 7
Picture Tools, using with, 274
ranges, converting into

live images, 274
static images, 273

saving as graphics, 275
saving shapes, charts and ranges as, 281–282
watermarks, creating with, 68–69

Import Data dialog box
refreshable links, 185
static links, 186

Import Text File dialog box
importing CSV files with, 188
static or refreshable content, choosing, 189

importing
data

pasting refreshable information, 185–186
trailing minus sign issues, 154

dialog boxes for
Advanced Text Import Settings, 154, 246
Import Data, 185–186
Import Text file, 188–189
New Web Query, 185–187

indenting, 48–49
INDEX function, 27–28, 102, 116
INDIRECT function

making cell references unchangeable with, 140
specifying rows with, 138–139
specifying worksheet names with, 139

volatile for automatic updates, making, 30
XLM functions in, 27–31

frequency tabulations, using pivot tables for, 224–226
fx button, 85

G
gauge charts, 266–267
GETPIVOTDATA function, 222–223
GET.WORKBOOK function, 29
global (workbook-level) names, 92
Go To dialog box (F5), 95
Go To Special dialog box

filling report gaps with, 192–193
hiding and locking cells with, 135

Google Spreadsheet, 113
Group mode, 150
Grouping dialog box, 227–229
groups

creating automatically, 228–229
creating with pivot tables, 227
grouping charts, 270–272
grouping dissimilar objects, 271–272
ungrouping charts, 271

H
headers

column widths, changing with, 84
inserting images into, 68
keyboard selection of, 148
with merged cells, 45
printer options for, specifying, 40
sorting columns with, 84
themes, customizing with, 35
unmerging cells with, 46
watermarks, creating with, 68–69

Hidden and Empty Cell Settings dialog box, 250–251
hiding

cells
formula, 135
security, 137
unhiding nonformula, 136

filtering chart data, 242
slices of pie charts, 267

HLOOKUP function, 99
holiday calculations, 105–107
HYPERLINK function

chart sheets, limitation with, 30
navigating to web pages with, 96
sending e-mail with, 96–98
subject line, including in, 96
text length, limitation on, 98
URLs, including in, 96

www.it-ebooks.info

http://www.it-ebooks.info/


Index290

tying transposed formulas to source ranges, 174
unlinking data ranges, 257–259

local (worksheet-level) names
apostrophes with, 93
in formulas, 93
Name box, creating with, 92–93
Name Manager dialog box, 93
spaces in, 93

locking cells
formula, 135
restricting cursor movement, 155–156
security, 137
unlocking nonformula, 136

lookups
concatenation with, 104
implicit intersections for, 102
INDEX function for, 102
intersection formulas for, 101–102
MATCH function for, 101
two columns for, 103–104

M
macros

enabling in Protected View, 17
Excel 4 XLM functions, in formulas, 27–31
filenames list, creating with, 27–28
on Quick Access Toolbar, 12
saving with proper file extensions, 28, 31

malware. See also Protected View
avoiding, 17
concerns about, 17
opening safe files, 18

MATCH function, 101
MAX function, inserting with AutoSum button, 85
Merge and Center button

available commands, 44
merging cells with, 43
unmerging cells

selecting all worksheet cells, 46
selecting individual cells, 44

Merge Styles dialog box
sharing styles between workbooks, 53
updating fonts on old worksheets, 76–77

merging cells
alternatives to, 47
combining cells, 43
issues with, 45
limitations of, 44–45
locating with Find and Replace, 45–46
with Merge and Center button, 43–44
unmerging actions, 43

Inquire add-in
comparing files with, 133–134
diagram tools, 133
workbook analysis with, 132

Insert Chart dialog box
combination charts

creating, 247–248
customizing, 248–249

Recommended Charts, using in, 239
stock market charts, using, 252
templates, applying with, 246

Insert Function dialog box, 85
Insert Picture dialog box, 68
Insert Pictures dialog box, 278
Insert Refreshable Stock Price shortcut menu, 181–182
Insert Slicers dialog box, 233
Insert Timeline dialog box, 234
INT function

converting values to integers with, 119–120
definition of, 118
TRUNC function versus, 119
YEARFRAC function versus, 108

intellisense drop-down list, 95
interactive charts, creating, 233
intersections

definition of, 101
implicit, 102
for look-ups, 101–102

ISERROR function, 91

L
labels

axis, adding to charts, 248
chart data, applying from ranges, 268–269
filtering data with, 232
multi-level category, 253–254

layout choices
affected by themes, 34
centering text, 43–44, 47
indenting text and numbers, 48–49
named styles, 50–53

legibility, adjusting with fonts, 75
line charts

combining four series in, 266
using four charts together, 265

linking
to charts, 255–256
with HYPERLINK function, 30, 35, 96–98
live pictures to charts, 274
refreshable links, 184
text boxes to charts, 256
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managing for worksheets, 93
for named constants, 94–95
workbook-level, 92
worksheet-level, 92–93

New Formatting Rule dialog box
bar charts, modifying with, 261
for conditional formatting, 163
excess spaces, identifying with, 171
ranges, comparing with, 163
shading, applying with, 62

New Name dialog box, 94
New Web Query dialog box

HTML files, accessing with, 185
limitations of, 185–186
refreshable links, creating, 185
refreshing information with, 181, 186
servers, accessing with, 185
specifying data to retrieve, 186–187
stock market reports, retrieving with, 182–183
web browsers, accessing with, 185

Normal style
changing fonts for, 52
displaying settings in Style dialog box, 51

Normal view
forcing from Protected View, 18–19
in workbooks, 8

number format codes
code categories, 55
displaying in scale values, 58
managing with Format Cells dialog box, 54–58
tables of

custom formats for, 56
formats for dates and times, 57
scale values, 58–59

numbers. See also custom number formats; rounding
converting measurements, 121–122
counting nonduplicated entries, 123–124
credit cards, working with, 168–169
digit changes with long, avoiding, 167
displaying with text, 70–71
font substitution, avoiding, 72–74
inexact searches for, 195
row

automatic, 212
consecutive, maintaining when filtering, 213
sequential, 212–213

TRIM function, identifying excess spaces with, 172

O
ODD function, 118
Office Compatibility Pack, 37–38
Open dialog box, 18

unmerging all worksheet cells, 46
wrapping text in, 44

MHTML file format
advantages of using, 26
saving workbooks in, 25

MIN function
comparing values with, 267
inserting with AutoSum button, 85

mixed references, 88–89
MOD function, 62–64
modifications

of chart pictures, 257
of chart styles and colors, 241–242
of images on worksheets, 279
of linked pictures, 274
of named styles, 51
of pivot table data, 223
protecting against

passwords, 136–137
Styles dialog box, 53

of Quick Access toolbar, 12
of Ribbon, 14
of speech qualities, 197
Style gallery for, 50
of text with formulas, 176
of themes, 35
transforming data

temporary formulas, 158–159
without formulas, 157–158

MROUND function, 118
multi-level category labels, 253–254

N
Name Manager dialog box, 93
named constants

controlling scope of, 94
creating with New Name dialog box, 94–95
for formulas, 94
simplifying formulas with, 95
for text shortcuts, 95

named ranges
comparing ranges with, 162–164
creating drop-down lists in, 161
in formulas, 101

names
apostrophes with, 93
dialog boxes for

Create Names from Selection, 102
Edit Name, 95
Name Manager, 93
New Name, 94
Paste Name (F3), 93, 95
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formulas versus, 218–221
frequency tabulations, creating with, 224–226
grouping items

avoiding blank cells, 227
by dates, 227–228
optional time-based units, 229

multiple groupings, creating
by assigning multiple range names, 229
with existing tables, 230

output, controlling with hidden fields, 222
purpose of, 215
ranges versus, 215
references to cells within, controlling, 222–223
referencing with outside formulas, 222
refreshing with new table data, 205
requirements for, 214
slicers, using with

advantages of, 232
applying simple filters, 232
creating interactive charts, 233
creating interactive dashboards, 232
displaying multiple values, 233
Insert Slicers dialog box, 233

themes, using with, 32
timelines, using with, 234–235

Power Utility Pak, 4
predicting values, 152–153
printers

adjusting settings for, 39–40
Page Setup dialog box, 40

printing
chart of printer settings, 39–40
Page Setup dialog box, 40
printer settings, adjusting, 39
from Protected View, 18
Quick Print option, 39

propagating formulas, 210
properties

of cells
locking and hiding formula cells, 135
unlocking nonformula cells, 136

dialog boxes for
Import Data, 186
Properties, 18–19
Speech Properties, 197

forcing Protected View files open, 18
modifications

of chart pictures, 257
of speech qualities, 197

of PDF documents, 24
web queries, controlling with, 186

P
page displays, changing with Workbook Views, 8
Page Layout view, 24
Page Setup dialog box, 39–40
passwords

bypassing with Inquire add-in, 134
limitations of, 137, 156
Protect Sheet dialog box, 136–137

Paste Name dialog box (F3)
finding named constants in, 95
for worksheet-level names, 93

Paste Special dialog box, 157–158, 173–174
pasting data

from autosaved workbook copies, 20
copies of range formulas, 128–129
dialog boxes for

Paste Name (F3), 93, 95
Paste Special, 157–158, 173–174

filling gaps in reports by, 192–193
into graphics files, 273–275
Import Text file dialog box, 188–189
mixed cell references, 88–89
from PDF files, 198–199
pictures of charts, managing, 257–258
from Protected View documents, 18
refreshable information, creating, 185–187
from web pages, 184
from Word 2013 into Excel, 257–258

pattern recognition, 176–180
PDF files

importing data by copying, 198–199
importing data using Word 2013, 200–201
opening with Word 2013, 200
sending files as, 24–25

Picture Tools menu, 274
pictures. See images
pie charts

creating simple, 264–265
gauge charts, creating from, 266–267

pivot tables
advantages of using, 216, 221
charts, creating from, 226
complicated formulas, creating with, 222
dialog boxes for

Change PivotTable Data Source, 231
Create PivotTable, 220, 224–225, 230–231
Insert Slicers, 233

document themes, incorporating in, 32
ease of use, 220
flexibility of, 216
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with AutoSum function, 85–86
conditional formatting, comparing with, 162–164
conditional formatting for shading, 62–64
counting nonduplicated entries in, 123–124
data labels from, using, 268–269
document themes, controlling with, 32
duplicate values, identifying in, 165–167
exact copies of, making, 128–129
with Format Painter, 66–67
in formulas, 92–93
importing text into, 188–189
live calendars, displaying in, 114–115
lookup tables, naming for, 103
Merge functions, using with, 43–47
in mixed references, 88–89
mouse plus keyboard selections, 148
mouse versus keyboard selection, 147
names for, creating, 101–102
normalized versus non-normalized, 214–216
official tables, converting into, 205–206
PDFs, saving as, 24
pictures, converting into

live images, 273–274
saving as graphic images, 275, 281–282
static images, 273

pivot table usage of, 215
pivot tables versus, 215
searches, performing on, 195
selecting

across multiple worksheets, 149–150
current region, 148
noncontiguous ranges, 148

spaces, using for intersection operators, 102
styles, applying to, 50
tables versus, 205–207
transforming data in, 157–158
transposing columns and rows, 173–175
vertical, converting into tables, 142–143
VLOOKUP and HLOOKUP with, 101–102
in Watch Window, 83

read-only file sharing, 26
Recommended Charts

with Insert Charts dialog box
advantages of, 240
previewing data in, 239

limitations of, 240
trust issues with, 240

#REF! error message
avoiding display of, 90–91
displaying in name lists, 28, 30

Properties dialog box, 18–19
Protect Sheet dialog box, 136–137
Protected View. See also security

copying data from, 18
disabling to edit files in, 17
forcing Normal view with Properties dialog box, 18–19
macros, working with in, 17
opening by choice, 18
overview, 17
printing documents from, 18
printing issues with cloud computing, 22
saving workbooks into Normal view, 18–19
triggering situations for, 17
Trust Center, controlling with, 17–18
warning messages displayed for, 17

protecting formula cells, 155–156
Publish as PDF or XPS dialog box, 24

Q
question mark (?) wildcard character, 195
Quick Access toolbar

comments, setting up for, 276
copying Ribbon commands to, 10
default location of, 10
displaying below Ribbon, 13
displaying icon names on, 10
filters, using with, 11
finding

additional icons on, 10
all Excel commands on, 12
macros on, 12

icons
adding, 10–12
changing, 12
rearranging, 13
removing, 13

resetting to default, 13
Ribbon use versus, 10
sharing with others, 13
work-specific macros, adding, 12

Quick Analysis
overview, 190–191
preventing display of, 191

Quick Print, 39

R
ranges

in absolute versus relative references, 87–88
AGGREGATE function, using with, 126
AutoFill, generating with, 151
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Hidden and Empty Cell Settings dialog box
dealing with missing data, 250
forcing hidden data use, 251

hiding
AGGREGATE function, 126
filter buttons, 207
SUBTOTAL function, 126

last value in, finding, 116–117
naming

with Create Names from Selection dialog box, 102
for implicit intersection lookups, 102

numbering sequentially, 212–213
row numbers versus data numbers, 212
selecting entire, 149
shading options for, 62–64
Total Row command, 208
transposing with columns, 173–175

ruler display, changing with Show group, 8

S
sandbox environment, 17
Save As dialog box, 25
Save Chart Template dialog box, 245
scope

identifying names by, 93
limiting workbook names with, 94
Scope drop-down list, 92

searching
Find and Replace dialog box, 195
question marks and asterisks, looking for, 195
wildcard characters, 194–195

security
limitations of

in hiding and locking cells, 137
for passwords, 156

precautions with macros, 17
role of Protected View in, 17–18

Select Data Source dialog box, 250
selecting

across noncontiguous worksheets, 150
choosing current region, 148
entire column, 149
entire row, 149
mouse plus keyboard selections, 148
mouse versus keyboard selections, 147
multisheet ranges, 149–150
noncontiguous cells and ranges, 148

shading
alternate rows with, 62–63
checkerboard patterns, 63
groups of rows with, 64

refreshing
CSV files in worksheet ranges, 188–189
manually

for pivot tables, 221
for static pages, 187

updating pivot tables, 221
web page data, 185–186

Registry Editor
disabling font substitution with, 72–74
Edit DWORD dialog box in, 73

relative references
absolute versus, 87
in mixed references, 88–89

Replace Format dialog box, 76
REPLACE function, 28–29
REPT function, 261–262
Reset Ignored Errors button, 131
Ribbon display

built-in tabs, hiding, 14, 16
customizing

with Excel Options dialog box, 14–15
overview, 14–16
Quick Access toolbar, 10

hiding, 8
Quick Access Toolbar versus, 10
renaming tabs and groups on, 16

ROUND function
rounding currency values with, 119
rounding to significant digits, 120
scaling bar charts with, 262

ROUNDDOWN function
definition of, 118
rounding to significant digits with, 120

rounding
currency values, 119
formatting versus, 118
INT versus TRUNC functions, 119–120
MROUND function, 118
to nearest multiple, 118–119
ROUND function, 119–120, 262
to significant digits, 120
table of functions, 118

ROUNDUP function, 118
ROW function

generating integers with, 28
numbering table rows automatically with, 212
with row shading, 62–64

rows
consecutive numbers, maintaining when filtering, 213
duplicates of, identifying, 166
Format Painter, copying formatting with, 67
height of, changing, 45
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Sort & Filter command, sorting pivot tables with, 226
sorting

contents of columns, 84
issues with gaps, 192–193
issues with merged cells, 45

spaces
encoding with ENCODEURL function, 96
issues with excess, 170–172
as range intersection operators, 102
in worksheet names, 93

sparklines
with Quick Analysis, 190–191
themes with, 32

speech
enabling text-to-speech feature, 196
proofing data with, 196
reading data with, 196
Ribbon, customizing for, 16
voice qualities, adjusting, 197

Speech Properties dialog box, 197
status bar

Custom Views with, 8
hiding with VBA command, 9

stock market charts
unavailable from Recommended Charts, 240
uses for high-low lines, 252

stock market reports
automatically inserting into spreadsheets, 181
entering symbols correctly, 181
hiding irrelevant information, 182
Insert Refreshable Stock Price shortcut menu, 181–182
plotting with, 252
refreshing data in, 181
retrieving with New Web Query dialog box, 182–183
retrieving with web queries, 182

structured references
creating with column names, 208
supported by tables, 207
with Total Row display, 208–209

Style dialog box
creating new styles with, 52–53
modifying existing styles with, 51–52

Style gallery
creating and naming new styles with, 52–53
merging styles between workbooks with, 53
modifying styles with, 50–52
protecting styles from modification, 53
sharing styles in master workbooks, 53

styles
additional formatting with, 50
attributes affected by, 50

shapes
Format Painter, copying formatting with, 67
linked, adding to charts, 256
saving as images, 281–282
themes, using with, 32, 36

SharePoint, 22
sharing

Compatibility Checker, 38
compatibility issues with, 161
file format choices for, 24–26
IFERROR versus ISERROR functions, 207
Ribbon customizations, 13
tabled workbooks, 207

sheet names
combining with HYPERLINK function, 30
creating list with macro, 29–31
updating list, 30

Show group, 8
sizing

Chart Tools, 244
charts, 243–244
copying ranges, 67
dragging cells for, 207
Drawing Tools, 243
font substitution issues, 72–73
Formula bar appearance, changing, 82
of indentation values, changing, 49
referencing data when, 211
of shading values, changing, 64
of slicers, 233
SmartArt, 61
Styles for, 52
with themes, 34
Watch Window display, customizing, 84

SkyDrive
advantages of using with Excel, 22
disadvantages of, 22–23
synching files with, 22
working using workbooks in, 22

slicers
appearance of, adjusting, 233
compatibility issues with, 38
definition of, 232
Insert Slicers dialog box, 233
interactive dashboards, creating with, 232
multiple values, displaying with, 233
pivot tables, using with, 234
removing from filters, 233
simple filters, applying with, 232
themes, using with, 32

SmartArt dialog box
creating bullet lists with, 61
using themes with, 32, 36
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size of, adjusting, 207
slicers with, 207
structured references with, 207
SUM versus SUBTOTAL functions in, 86
themes with, 32
values at intersections, finding, 101–102
workbook sharing issues with, 207

templates
applying to existing charts, 246
creating for charts, 245
file formats for workbooks, 37
with new charts, 246
text boxes, adding to, 245

temporary formulas, 158–159
text

centering without merging, 47
chart

adding with multi-level category labels, 253
linking to cells, 255–256

converting arguments to range references, 138–139
dialog boxes for

Advanced Text Import Settings, 154, 246
Convert Text to Columns Wizard, 129
Import Text file, 188–189
Text to columns, 154

displaying
with numbers, 70–71
in text boxes, 47
in vertical format, 47

encoding for e-mail, 96
excess spaces, 170–172
font substitution, avoiding, 72–74
formatting individual characters in cells, 65
in HYPERLINK functions, 96, 98
importing into worksheet ranges, 188–189
in merged cells, 43
modifying

with Flash Fill, 176–178
with styles, 50–53
with temporary formulas, 158–159

searching with wildcards, 194
shortcuts using named constants, 95
superscript and subscript, applying, 65
wrapping in merged cells, 44

text boxes
adding to charts with multi-level category labels, 256
including in groups, 271
including in templates, 245
linking to pie-charts, 267

TEXT function, displaying text and numbers with, 71
Text to Columns dialog box, 154
TextImport Wizard, 169

styles (continued)
chart modification with

changing chart elements, 241
modifying styles and colors, 241–242

creating from existing formats, 52–53
custom sets, limitations of, 53
dialog boxes for

Merge Styles, 53, 76–77
Style, 51–53

master workbooks for sharing, creating, 53
modifications

of Normal style, 52
protecting from, 53
with Style gallery, 51–52

multiple cells, adjusting with, 50
sizing, adjusting with, 50–52
updating fonts on old worksheets, 76–77

subscript, applying to text, 65
Subtotal dialog box, 218–219
SUBTOTAL function

automatically inserting subtotals with, 218–219
sequential numbers, maintaining when filtering, 213
sorting data with, 218–219
SUM function versus, 86
with Total Row command, 208

SUM function
AutoSum button for, 85
SUBTOTAL function versus, 86

superscript, applying to text, 65

T
table references, 211
tables. See also pivot tables

AutoSum button with, 86
calculated columns supported by, 207
charts, creating from, 205
converting from vertical ranges, 142–143
copying from web pages, 185–187
CSS displays, issues with, 186
exact values in, finding, 99–100
filters with, 207
formatting options, 207
formulas with, 208
limitations of, 207
merged cell issues, 45
normalized, definition of, 214
numbering rows automatically, 212
official, creating, 205
overview, 205–207
pivot tables, creating from, 205
propagating formulas automatically in, 210, 212
Quick Analysis feature, creating with, 190
ranges versus, 206–207
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U
unlocking cells

nonformula, 136
restricting cursor movement, 155–156

updating
CSV files in worksheet ranges, 188–189
manually for static pages, 187
refreshing pivot tables, 221
web page data, 185–186

URLs
for e-mail, 96–98
extracting domain names from with Flash Fill, 178
with HYPERLINK, 96
retrieving stock market reports with, 181–183
for web queries, 182

V
values

displaying with text, 70–71
finding at intersections, 101–102
looking up exact values, 99–100
searching with wildcards, 195

VBA code
hiding status bar with, 9
problems with merged cells, 45
XDATE add-ins, 111–112

VLOOKUP function, 99

W
Watch Window

customizing display of, 84
monitoring cells and ranges with, 83
navigating between worksheets with, 84
overview, 83
sorting contents in, 84

watermarks
example of, 69
Format Picture dialog box, 68
in headers and footers, creating, 68
Insert Picture dialog box, 68

Web Options dialog box, 281–282
web pages

accessing directly by URL command, 187
copying static information from, 184, 186
CSS displays, issues with, 186
dialog boxes for

New Web Query, 118, 182–183, 185–187
Web Options, 281

Excel Web App, 22–23
HYPERLINK function, navigating to with, 96
importing data from, 184

text-to-speech feature, 196
themes

colors for, choosing, 35
creating, 35–36
custom colors for, creating, 36
custom sets in Office applications, 36
default Office, new fonts for, 75
gallery, choosing from, 34
limitations of using, 34
modifying, 35–36
overview, 32
saving customized sets, 36

tilde (~) character, using in searches, 195
timelines

filters with, 234–235
Insert Timeline dialog box, 234
themes with, 32

times
AutoFill

creating series with, 152
predicting values with, 152–153

CONVERT function, using with, 121–122
custom formats of, codes for, 57
holidays, calculating, 105–107
live calendars, displaying, 114–115
pre-1900

Google Spreadsheet, using for, 113
issues with, 110–111
XDATE functions, using for, 111–112

searching options, 195
Total Row command

with tables, 208
toggling display on and off, 209

totals
AutoSum button, creating with, 86
ignoring with formulas, 211
pivot tables, calculating with, 214
running, creating, 190–191
SUBTOTAL versus SUM functions, 190–191

transforming data
with temporary formulas, 158–159
without formulas, 157–158

TRANSPOSE function, 174–175
transposing ranges

linking to source ranges, 174
Paste Special dialog box, 173–174
TRANSPOSE function, 174–175

TRIM function, 172
TRUNC function

converting values to integers with, 119–120
definition of, 118
INT function versus, 119

Trust Center, controlling Protected View with, 17–18
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exporting graphics from, 281–282
filling gaps for sorting, 192–193
Format Painter, removing formatting with, 67
names, identifying by scope, 93
password limitations with, 156
pivot tables, using with, 214
protecting with Protect Sheet dialog box, 136–137
refreshable data, creating in, 188–189
resizing formula bar for editing, 81–82
selecting multisheet ranges, 149–150
selecting noncontiguous worksheets, 150
spaces, including in names, 93
themes, adjusting for different, 34

Wrap Text
using with bullet lists, 60
using with merged cells, 44

X
XDATE custom functions

issues with pre-1583 dates, 112
list of extended date functions, 111–112
for pre-1900 dates, 111

XLM-style macros
FILES function, 27
GET.WORKBOOK function, 29

.xls file extensions, 28, 31

.xlsm file extensions, 28, 31
XPS file format, 24

Y
YEARFRAC function, 108

Z
zip files, compatibility with XML files, 37
Zoom group, 8
zooming

avoiding font substitution during, 72–74
Zoom group versus Zoom slider for, 8

web pages (continued)
pasting methods for inserting, 184
quick queries for, creating, 185–186
refreshable links to, creating, 185
specifying data to retrieve, 186–187
web queries, making

New Web Query dialog box, 182–183
URLs, 182

workbooks, using in browsers
with Microsoft SkyDrive account, 22
with SharePoint, 22

wildcard search characters
searching for question marks or asterisks, 195
searching for text, 194–195
searching for values, 195

Word 2013
copying formula ranges with, 128–129
copying PDF data with, 200–201
opening PDF files with, 200
sharing themes with Excel, 36

Workbook Analysis Report dialog box, 132
Workbook Views

adding watermarks with, 68
overview, 8
restriction of tables from, 207

workbook-level (global) names, 92
workbooks

analyzing with Workbook Analysis Report dialog box, 132
bypassing passwords with Inquire, 134
diagramming relationships between, 133
sharing prohibitions with tables, 207

worksheet-level (local) names
apostrophes with, 93
in formulas, 93
Name box, creating with, 92–93
Name Manager dialog box, 93
spaces in, 93

worksheets. See also pivot tables
apostrophes, using with names, 93
common themes, using with, 34
diagramming relationships between, 133
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PUP v7 is a handy collection of 60 general pur-
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