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Introducing Microsoft Excel 2010
For those of you who are upgrading to Microsoft Excel 2010 from an earlier version  
of the program, this introduction summarizes the new features in Excel 2010. One of 
the first things you’ll notice about Excel 2010 is that the program incorporates the 
ribbon, which was introduced in Excel 2007. If you used Excel 2003 or an earlier ver-
sion of Excel, you’ll need to spend only a little bit of time working with the new user 
interface to bring yourself back up to your usual proficiency.

Managing Excel Files and Settings  
in the Backstage View

If you used Excel 2007, you’ll immediately notice one significant change: the Microsoft 
Office button, located at the top left corner of the program window in Excel 2007, has 
been replaced by the File tab. After releasing the 2007 Microsoft Office System, the Office 
User Experience team re-examined the programs’ user interfaces to determine how they 
could be improved. During this process, they discovered that it was possible to divide user 
tasks into two categories: “in” tasks, such as formatting and formula creation, which affect 
the contents of the workbook directly, and “out” tasks, such as saving and printing, which 
could be considered workbook management tasks.

When the User Experience and Excel teams focused on the Excel 2007 user interface, they 
discovered that several workbook management tasks were sprinkled among the ribbon 
tabs that contained content-related tasks. The Excel team moved all of the workbook 
management tasks to the File tab, which users can click to display these commands in 
the new Backstage view.
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Previewing Data by Using Paste Preview
One of the most common tasks undertaken by Excel users involves cutting or copying 
a worksheet’s contents, such as text or numbers, and pasting that data into either the 
same workbook or a separate Office document. Users have always been able to paste 
data from the Microsoft Office Clipboard and control which formatting elements were 
pasted into the destination; however, in versions prior to Excel 2010, you had to select 
a paste option, observe the results, and (often) undo the paste and try another option 
until you found the option that produced the desired result.
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In Excel 2010, you can take advantage of the new Paste Preview capability to see how 
your data will appear in the worksheet before you commit to the paste. By pointing to 
any of the icons in the Paste Options palette, you can switch between options to discover 
the one that makes your pasted data appear the way you want it to.

Troubleshooting The appearance of buttons and groups on the ribbon changes depending 
on the width of the program window. For information about changing the appearance of 
the ribbon to match our screen images, see “Modifying the Display of the Ribbon” at the 
beginning of this book.

Customizing the Excel 2010 User Interface
When the Office User Experience team designed the ribbon interface for Excel 2007, they 
allowed users to modify the program window by adding and removing commands on the 
Quick Access Toolbar. In Excel 2010, you can still modify the Quick Access Toolbar, but you 
also have many more options for changing the ribbon interface. You can hide or display 
built-in ribbon tabs, change the order of built-in ribbon tabs, add custom groups to a 
ribbon tab, and create custom ribbon tabs which, in turn, can contain custom groups. 
These custom groups provide easy access to existing ribbon commands as well as  
custom commands that run macros stored in the workbook.
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Summarizing Data by Using More Accurate 
Functions

In earlier versions of Excel, the program contained statistical, scientific, engineering, 
and financial functions that would return inaccurate results in some relatively rare  
circumstances. For Excel 2010, the Excel programming team identified the functions 
that returned inaccurate results and collaborated with academic and industry analysts 
to improve the functions’ accuracy.

The Excel team also changed the naming conventions used to identify the program’s 
functions. This change is most noticeable with regard to the program’s statistical func-
tions. The table below lists the statistical distribution functions that have been improved 
in Excel 2010.

Distribution Functions
Beta BETA.DIST, BETA.INV
Binomial BINOM.DIST, BINOM.INV

Chi squared CHISQ.DIST, CHISQ.DIST.RT, CHISQ.INV, CHISQ.INV.RT

Exponential EXPON.DIST

F F.DIST, F.DIST.RT, F.INV, F.INV.RT
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Distribution Functions
Gamma GAMMA.DIST, GAMMA.INV

Hypergeometric HYPGEOM.DIST

Lognormal LOGNORM.DIST, LOGNORM.INV

Negative Binomial NEGBINOM.DIST

Normal NORM.DIST, NORM.INV

Standard Normal NORM.S.DIST, NORMS.INV

Poisson POISSON.DIST

Student’s t T.DIST, T.DIST.RT, T.DIST.2T, T.INV, T.INV.2T

Weibull WEIBULL.DIST

Excel 2010 also contains more accurate statistical summary and test functions. The following 
table lists those functions, as well as the new naming convention that distinguishes between 
new and old functions. The Excel programming team chose to retain the older functions to 
ensure that workbooks created in Excel 2010 would be compatible with workbooks created 
in previous versions of the program.

Function name Description
CEILING.PRECISE Consistent with mathematical definition; rounds up towards positive 

infinity regardless of sign of number being rounded
FLOOR.PRECISE Consistent with mathematical definition; rounds down towards 

negative infinity regardless of sign of number being rounded
CONFIDENCE.NORM Name for existing CONFIDENCE function that is internally consistent 

with naming of other confidence function
CONFIDENCE.T Consistent definition with industry best practice;. confidence function 

assuming a Student’s t distribution
COVARIANCE.P Name for existing COVAR function that is internally consistent with 

naming of other covariance function
COVARIANCE.S Internally consistent name with other functions that act on a 

population or a sample
MODE.MULT Consistent with user expectations; returns multiple modes for a range

MODE.SNGL Name for existing MODE function that is internally consistent with 
naming of other mode function

PERCENTILE.EXC Consistent with industry best practices, assuming percentile is a 
value between 0 and 1, exclusive

PERCENTILE.INC Name for existing PERCENTILE function that is internally consistent 
with naming of other percentile function
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Function name Description
PERCENTRANK.EXC Consistent with industry best practices; assuming percentile is a 

value between 0 and 1, exclusive
PERCENTRANK.INC Name for existing PERCENTRANK function that is internally consistent 

with naming of other PERCENTRANK function
QUARTILE.EXC Consistent with industry best practices, assuming percentile is a 

value between 0 and 1, exclusive
QUARTILE.INC Name for existing QUARTILE function that is internally consistent 

with naming of other quartile function
RANK.AVG Consistent with industry best practices, returning the average rank 

when there is a tie
RANK.EQ Name for existing RANK function that is internally consistent with 

naming of other rank function
STDEV.P Name for existing STDEVP function that is internally consistent with 

naming of other standard deviation function
STDEV.S Name for existing STDEV function that is internally consistent with 

naming of other standard deviation function
VAR.P Name for existing VARP function that is internally consistent with 

naming of other variance function
VAR.S Name for existing VAR function that is internally consistent with 

naming of other variance function
CHISQ.TEST Name for existing CHITEST function that is internally consistent with 

naming of other hypothesis test functions
F.TEST Name for existing FTEST function that is internally consistent with 

naming of other hypothesis functions
T.TEST Name for existing TTEST function that is internally consistent with 

naming of other hypothesis functions
Z.TEST Name for existing ZTEST function that is internally consistent with 

naming of other hypothesis functions

It is possible in Excel 2010 to create formulas by using the older functions. The Excel 
team assigned these functions to a new group called Compatibility Functions. These 
older functions appear at the bottom of the Formula AutoComplete list, but they are 
marked with a different icon than the newer functions. Additionally, the tooltip that 
appears when you point to the older function’s name indicates that the function is 
included for backward compatibility only.
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When a user saves a workbook that contains functions that are new in Excel 2010 to an 
older format, the Compatibility Checker flags the functions and indicates that they will 
return a #NAME? error when the workbook is opened in Excel 2007 or earlier versions.

Summarizing Data by Using Sparklines
In his book Beautiful Evidence, Edward Tufte describes sparklines as “intense, simple, 
wordlike graphics.” In Excel 2010, sparklines take the form of small charts that summarize 
data in a single cell. These small but powerful additions to Excel 2010 enhance the 
program’s reporting and summary capabilities.

Adding a sparkline to a summary worksheet provides context for a single value, such 
as an average or total, displayed in the worksheet. Excel 2010 includes three types of 
sparklines: line, column, and win/loss. A line sparkline is a line chart that displays a data 
trend over time. A column sparkline summarizes data by category, such as sales by 
product type or by month. Finally, a win/loss sparkline indicates whether the points 
in a data series are positive, zero, or negative.
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Filtering PivotTable Data by Using Slicers
With PivotTables, users can summarize large data sets efficiently, such as by rearranging 
values dynamically to emphasize different aspects of the data. It’s often useful to be able 
to limit the data that appears in a PivotTable, so the Excel team included the functionality 
for users to filter PivotTables. The PivotTable indicates that a filter is present for a particular 
data column, but it doesn’t indicate which items are currently displayed or hidden by 
the filter. 

Slicers, which are new in Excel 2010, visually indicate which values appear in a PivotTable 
and which are hidden. They are particularly useful when presenting data to an audience 
that contains visual thinkers who might not be skilled at working with numerical values. 
For example, a corporate analyst could use a Slicer to indicate which months are displayed 
in a PivotTable that summarizes monthly package volumes. 
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Filtering PivotTable Data by Using Search Filters
Excel 2007 introduced several new ways to filter PivotTables. Excel 2010 extends these 
filtering capabilities by introducing search filters. With a search filter, you begin typing 
a sequence of characters that occur in the term (or terms) by which you want to filter. 
As you type in these characters, the PivotTable field’s filter list displays only those terms 
that reflect the values entered into the search filter box.
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Visualizing Data by Using Improved Conditional 
Formats

In Excel 2007, the Excel programming team greatly improved the user’s ability to change a 
cell’s format based on the cell’s contents. One new conditional format, data bars, indicated 
a cell’s relative value by the length of the bar within the cell that contained the value. The 
cell in the range that contained the smallest value displayed a zero-length bar, and the cell 
that contained the largest value displayed a bar that spanned the entire cell width. 

The default behavior of the Excel 2010 data bars has been changed so that bar length is 
calculated in comparison to a baseline value, such as zero. If you prefer, you can display 
values based on the Excel 2007 method or change the comparison value to something 
other than zero. Data bars in Excel 2010 also differ from those in Excel 2007 in that they 
display negative values in a different color than the positive values. In addition, data bars  
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representing negative values extend to the left of the baseline, not to the right. In Excel 2007,  
the conditional formatting engine placed the zero-length data bar in the cell that con-
tained the smallest value, regardless of whether that value was positive or negative.

You have much more control over your data bars’ formatting in Excel 2010 than in Excel 
2007. When you create a data bar in Excel 2010, it has a solid color fill, not a gradient fill 
like the bars in Excel 2007. The gradient fill meant that the color of the Excel 2007 data 
bars faded as the bar extended to the right, making the cells’ relative values harder to 
discern. In Excel 2010 you can select a solid or gradient fill style, apply borders to data 
bars, and change the fill and border colors for both positive and negative values.

Another conditional format introduced in Excel 2007, icon sets, displayed an icon selected 
from a set of three, four, or five icons based on a cell’s value. In Excel 2007, users were 
limited to using the icons within each set and had no ability to create their own sets. In 
Excel 2010, you can create custom icon sets from the icons included in the program and, 
if you prefer, define conditions that, when met, display no icon in the cell.
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Finally, with Excel 2010 you can create conditional formats that refer to values on 
worksheets other than the sheet that contains the cell you’re formatting. In previous 
versions of Excel, users had to create conditional formats that referred to values on the 
same worksheet. 
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Creating and Displaying Math Equations
Scientists and engineers who use Microsoft Excel to support their work often want to 
include equations in their workbooks to help explain how they arrived at their results. 
Excel 2010 includes an updated equation designer with which you can create any 
equation you require. The new editor has several common equations built in, such as 
the quadratic formula and the Pythagorean theorem, but it also contains numerous 
templates that you can use to create custom equations quickly.

Editing Pictures within Excel 2010
When you present data in an Excel workbook, you can insert images into your work-
sheets to illustrate aspects of your data. For example, a shipping company could display 
a scanned image of a tracking label or a properly prepared package. Rather than having 
to edit your images in a separate program and then insert them into your Excel 2010 
workbook, you can insert the image and then modify it by using the editing tools built 
into Excel 2010.

One very helpful capability that is new in Excel 2010 is the ability to remove the back-
ground elements of an image. Removing an image’s background enables you to create 
a composite image in which the foreground elements are placed in front of another 
background. For example, you could focus on a flower’s bloom and remove most of the 
leaves and stem from the photo. After you isolate the foreground image, you can place 
the bloom in front of another background.
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Managing Large Worksheets by Using the 64-bit 
Version of Excel 2010

Some Excel 2010 users, such as business analysts and scientists, will need to manipulate 
extremely large data sets. In some cases, these data sets won’t fit into the more than one 
million rows available in a standard Excel 2010 worksheet. To meet the needs of these 
users, the Excel product team developed the 64-bit version of Excel 2010. The 64-bit 
version takes advantage of the greater amount of random access memory (RAM) avail-
able in newer computers. As a result of its ability to use more RAM than the standard 
32-bit version of Excel 2010, users of the 64-bit version can store hundreds of millions 
of rows of data in a worksheet. In addition, the 64-bit version takes advantage of multi-
core processors to manage its larger data collections efficiently.

All of the techniques described in Microsoft Excel 2010 Step by Step apply to both the 
32-bit and 64-bit versions of the program.

Summarizing Large Data Sets by Using the 
PowerPivot (Project Gemini) Add-In

As businesses collect and maintain increasingly large data sets, the need to analyze that 
data efficiently grows in importance. More powerful computers offer some performance 
improvements, but even the fastest computer takes a long time to process huge data sets 
when using traditional data-handling procedures. A new add-in, PowerPivot for Excel 2010, 
uses enhanced data management techniques to store the data in a computer’s memory, 
rather than forcing the Excel program to read the data from a hard disk. Reading data 
from a computer’s memory instead of a hard disk speeds up the data analysis and display 
operations substantially. Tasks that might have taken minutes to complete in Excel 2010 
without the PowerPivot add-in now take seconds.

PowerPivot relies on the Microsoft SQL Server Analysis Services engine to produce its 
results, so discussion of it is outside the scope of this book. If you would like to learn 
more about PowerPivot, you can visit the team’s blog at blogs.msdn.com/powerpivot/.
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Accessing Your Data from Almost Anywhere by 
Using the Excel Web App and Excel Mobile 2010

As the workforce becomes increasingly mobile, information workers need to access their 
Excel 2010 data as they move around the world. To enable these mobile use scenarios, 
the Excel product team developed the Excel Web App and Excel Mobile 2010. The Excel 
Web App provides a high-fidelity experience that is very similar to the experience of using 
the Excel 2010 desktop application. In addition, you can collaborate with other users in 
real time. The Excel Web App identifies which changes were made by which users and 
enables you to decide which changes to keep and which to reject.

You can use the Excel Web App in Windows Internet Explorer 7 or 8, Safari 4, and 
Firefox 3.5. 

With Excel Mobile 2010, you can access and, in some cases, manipulate your data by 
using a Windows Phone or other mobile device. If you have a Windows Phone running 
Windows Mobile 6.5, you can use Excel Mobile 2010 to view and edit your Excel 2010 
workbooks. If you have another mobile device that provides access to the Web, you can 
use your device’s built-in Web browser to view your files.

A full discussion of the Excel Web App and Excel Mobile 2010 are beyond the scope of 
this book.
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Modifying the Display of the Ribbon
The goal of the Microsoft Office working environment is to make working with Office docu-
ments, including Microsoft Word documents, Excel workbooks, PowerPoint presentations, 
Outlook e-mail messages, and Access database tables, as intuitive as possible. You work 
with an Office document and its contents by giving commands to the program in which 
the document is open. All Office 2010 programs organize commands on a horizontal bar 
called the ribbon, which appears across the top of each program window whether or not 
there is an active document.

Ribbon tabs Ribbon groups

Commands are organized on task-specific tabs of the ribbon, and in feature-specific 
groups on each tab. Commands generally take the form of buttons and lists. Some 
appear in galleries. Some groups have related dialog boxes or task panes that contain 
additional commands. 

Throughout this book, we discuss the commands and ribbon elements associated with 
the program feature being discussed. In this topic, we discuss the general appearance 
of the ribbon, things that affect its appearance, and ways of locating commands that 
aren’t visible on compact views of the ribbon.

Tip Some older commands no longer appear on the ribbon, but are still available in the 
program. You can make these commands available by adding them to the Quick Access 
Toolbar. For more information, see “Customizing the Excel 2010 Program Window” in 
Chapter 1, “Setting Up a Workbook.”

Dynamic Ribbon Elements
The ribbon is dynamic, meaning that the appearance of commands on the ribbon 
changes as the width of the ribbon changes. A command might be displayed on the 
ribbon in the form of a large button, a small button, a small labeled button, or a list 
entry. As the width of the ribbon decreases, the size, shape, and presence of buttons 
on the ribbon adapt to the available space.

 Contents
Modifying the Display of the Ribbon . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xxv

Dynamic Ribbon Elements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xxv
Changing the Width of the Ribbon . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xxvi
Adapting Exercise Steps . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .xxix

www.it-ebooks.info

http://www.it-ebooks.info/


xxvi  Modifying the Display of the Ribbon

For example, when sufficient horizontal space is available, the buttons on the Review tab of 
the Word program window are spread out and you’re able to see more of the commands 
available in each group.

Drop-down list
Small labeled button

Large button

If you decrease the width of the ribbon, small button labels disappear and entire groups 
of buttons hide under one button that represents the group. Click the group button to 
display a list of the commands available in that group.

Group button Small unlabeled buttons

When the window becomes too narrow to display all the groups, a scroll arrow appears 
at its right end. Click the scroll arrow to display hidden groups.

Scroll arrow

Changing the Width of the Ribbon
The width of the ribbon is dependent on the horizontal space available to it, which 
depends on these three factors:

● The width of the program window Maximizing the program window provides the most 
space for ribbon elements. You can resize the program window by clicking the button in 
its upper-right corner or by dragging the border of a non-maximized window.
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Tip On a computer running Windows 7, you can maximize the program window by 
dragging its title bar to the top of the screen.

● Your screen resolution Screen resolution is the size of your screen display expressed 
as pixels wide × pixels high. The greater the screen resolution, the greater the amount 
of information that will fit on one screen. Your screen resolution options are depen-
dent on your monitor. At the time of writing, possible screen resolutions range from 
800 × 600 to 2048 × 1152. In the case of the ribbon, the greater the number of pixels 
wide (the first number), the greater the number of buttons that can be shown on the 
ribbon, and the larger those buttons can be.

On a computer running Windows 7, you can change your screen resolution from 
the Screen Resolution window of Control Panel. You set the resolution by dragging 
the pointer on the slider.

● The density of your screen display You might not be aware that you can change the 
magnification of everything that appears on your screen by changing the screen mag-
nification setting in Windows. Setting your screen magnification to 125% makes text 
and user interface elements larger on screen. This increases the legibility of informa-
tion, but means that less fits onto each screen.
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On a computer running Windows 7, you can change the screen magnification from 
the Display window of Control Panel. You can choose one of the standard display 
magnification options, or create another by setting a custom text size.

The screen magnification is directly related to the density of the text elements on 
screen, which is expressed in dots per inch (dpi) or points per inch (ppi). (The terms 
are interchangeable, and in fact are both used in the Windows dialog box in which 
you change the setting.) The greater the dpi, the larger the text and user interface 
elements appear on screen. By default, Windows displays text and screen elements 
at 96 dpi. Choosing the Medium - 125% display setting changes the dpi of text and 
screen elements to 120 dpi. You can choose a custom setting of up to 500% mag-
nification, or 480 dpi, in the Custom DPI Setting dialog box. The list allows you to 
choose a magnification of up to 200%.You can choose a greater magnification by 
dragging across the ruler from left to right.
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See Also  For more information about display settings, refer to Windows 7 Step by Step 
(Microsoft Press, 2009), Windows Vista Step by Step (Microsoft Press, 2006), or Windows XP 
Step by Step (Microsoft Press, 2002) by Joan Lambert Preppernau and Joyce Cox.

Adapting Exercise Steps
The screen images shown in the exercises in this book were captured at a screen resolution 
of 1024 × 768, at 100% magnification, and the default text size (96 dpi). If any of your set-
tings are different, the ribbon on your screen might not look the same as the one shown 
in the book. For example, you might see more or fewer buttons in each of the groups, the 
buttons you see might be represented by larger or smaller icons than those shown, or the 
group might be represented by a button that you click to display the group’s commands.

When we instruct you to give a command from the ribbon in an exercise, we do it in this 
format:

● On the Insert tab, in the Illustrations group, click the Chart button.

If the command is in a list, we give the instruction in this format:

● On the Page Layout tab, in the Page Setup group, click the Breaks button and 
then, in the list, click Page.

The first time we instruct you to click a specific button in each exercise, we display an 
image of the button in the page margin to the left of the exercise step.

If differences between your display settings and ours cause a button on your screen to 
look different from the one shown in the book, you can easily adapt the steps to locate 
the command. First, click the specified tab. Then locate the specified group. If a group 
has been collapsed into a group list or group button, click the list or button to display 
the group’s commands. Finally, look for a button that features the same icon in a larger 
or smaller size than that shown in the book. If necessary, point to buttons in the group 
to display their names in ScreenTips.

If you prefer not to have to adapt the steps, set up your screen to match ours while you 
read and work through the exercises in the book.
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Features and Conventions  
of This Book

This book has been designed to lead you step by step through all the tasks you’re most 
likely to want to perform in Microsoft Excel 2010. If you start at the beginning and work 
your way through all the exercises, you’ll gain enough proficiency to be able to create 
and work with all the common types of Excel workbooks. However, each topic is self 
contained. If you’ve worked with a previous version of Excel, or if you completed all the 
exercises and later need help remembering how to perform a procedure, the following 
features of this book will help you locate specific information:

● Detailed table of contents Search the listing of the topics and sidebars within 
each chapter.

● Chapter thumb tabs Easily locate the beginning of the chapter you want.

● Topic-specific running heads Within a chapter, quickly locate the topic you 
want by looking at the running heads at the top of odd-numbered pages.

● Glossary Look up the meaning of a word or the definition of a concept.

● Detailed index Look up specific tasks and features in the index, which has been 
carefully crafted with the reader in mind.

You can save time when reading this book by understanding how the Step by Step series 
shows exercise instructions, keys to press, buttons to click, and other information.
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Convention Meaning
SET UP This paragraph preceding a step-by-step exercise indicates the 

practice files that you will use when working through the exercise. It 
also indicates any requirements you should attend to or actions you 
should take before beginning the exercise.

CLEAN UP This paragraph following a step-by-step exercise provides instructions 
for saving and closing open files or programs before moving on to 
another topic. It also suggests ways to reverse any changes you made 
to your computer while working through the exercise.

1
2

Blue numbered steps guide you through hands-on exercises in each 
topic.

1

2

Black numbered steps guide you through procedures in sidebars and 
expository text.

See Also This paragraph directs you to more information about a topic in this 
book or elsewhere.

Troubleshooting This paragraph alerts you to a common problem and provides 
guidance for fixing it.

Tip This paragraph provides a helpful hint or shortcut that makes working 
through a task easier.

Important This paragraph points out information that you need to know to 
complete a procedure.

Keyboard Shortcut This paragraph provides information about an available keyboard 
shortcut for the preceding task.

Ctrl+B A plus sign (+) between two keys means that you must press those 
keys at the same time. For example, “Press Ctrl+B” means that you 
should hold down the Ctrl key while you press the B key.
Pictures of buttons appear in the margin the first time the button is 
used in a chapter.

Black bold In exercises that begin with SET UP information, the names of program 
elements, such as buttons, commands, windows, and dialog boxes, 
as well as files, folders, or text that you interact with in the steps, are 
shown in black, bold type.

Blue bold In exercises that begin with SET UP information, text that you should 
type is shown in blue bold type.

www.it-ebooks.info

http://www.it-ebooks.info/


  xxxiii

Using the Practice Files
Before you can complete the exercises in this book, you need to copy the book’s practice 
files to your computer. These practice files, and other information, can be downloaded 
from the book’s detail page, located at:

go.microsoft.com/fwlink/?LinkId=191751

Display the detail page in your Web browser and follow the instructions for downloading 
the files.

Important The Microsoft Excel 2010 program is not available from this Web site. You should 
purchase and install that program before using this book.

The following table lists the practice files for this book.

Chapter File
Chapter 1:  
Setting Up a Workbook

ExceptionSummary_start.xlsx
ExceptionTracking_start.xlsx
MisroutedPackages_start.xlsx
PackageCounts_start.xlsx
RouteVolume_start.xlsx

Chapter 2:  
Working with Data and Excel Tables

2010Q1ShipmentsByCategory_start.xlsx
AverageDeliveries_start.xlsx
DriverSortTimes_start.xlsx
Series_start.xlsx
ServiceLevels_start.xlsx

Chapter 3:  
Performing Calculations on Data

ConveyerBid_start.xlsx 
ITExpenses_start.xlsx
PackagingCosts_start.xlsx
VehicleMiles_start.xlsx

(continued)
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Chapter File
Chapter 4:  
Changing Workbook Appearance

CallCenter_start.xlsx
Dashboard_start.xlsx
ExecutiveSearch_start.xlsx
HourlyExceptions_start.xlsx
HourlyTracking_start.xlsx
phone.jpg
texture.jpg
VehicleMileSummary_start.xlsx

Chapter 5:  
Focusing on Specific Data by Using Filters

Credit_start.xlsx
ForFollowUp_start.xlsx
PackageExceptions_start.xlsx

Chapter 6:  
Reordering and Summarizing Data

GroupByQuarter_start.xlsx
ShipmentLog_start.xlsx
ShippingSummary_start.xlsx

Chapter 7:  
Combining Data from Multiple Sources

Consolidate_start.xlsx
DailyCallSummary_start.xlsx
FebruaryCalls_start.xlsx
FleetOperatingCosts_start.xlsx
JanuaryCalls_start.xlsx
OperatingExpenseDashboard_start.xlsx

Chapter 8:  
Analyzing Alternative Data Sets

2DayScenario_start.xlsx
AdBuy_start.xlsx
DriverSortTimes_start.xlsx
MultipleScenarios_start.xlsx
TargetValues_start.xlsx

Chapter 9:  
Creating Dynamic Lists by Using PivotTables

Creating_start.txt
Creating_start.xlsx
Editing_start.xlsx
Focusing_start.xlsx
Formatting_start.xlsx
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Chapter File
Chapter 10:  
Creating Charts and Graphics

FutureVolumes_start.xlsx
OrgChart_start.xlsx
RevenueAnalysis_start.xlsx
RevenueSummary_start.xlsx
Shapes_start.xlsx
VolumebyCenter_start.xlsx
YearlyPackageVolume_start.xlsx

Chapter 11:  
Printing

ConsolidatedMessenger.png
CorporateRevenue_start.xlsx
HourlyPickups_start.xlsx
PickupsByHour_start.xlsx
RevenueByCustomer_start.xlsx
SummaryByCustomer_start.xlsx
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Getting Help
Every effort has been made to ensure the accuracy of this book. If you do run into 
problems, please contact the sources listed in the following topics.

Getting Help with This Book
If your question or issue concerns the content of this book or its practice files, please 
first consult the book’s errata page, which can be accessed at:

go.microsoft.com/fwlink/?LinkId=191751

This page provides information about known errors and corrections to the book. If 
you do not find your answer on the errata page, send your question or comment to 
Microsoft Press Technical Support at:

mspinput@microsoft.com

Getting Help with Excel 2010
If your question is about Microsoft Excel 2010, and not about the content of this book, 
your first recourse is the Excel Help system. This system is a combination of tools and files 
stored on your computer when you installed Excel and, if your computer is connected to 
the Internet, information available from Office.com. You can find general or specific Help 
information in the following ways:

● To find out about an item on the screen, you can display a ScreenTip. For example, to 
display a ScreenTip for a button, point to the button without clicking it. The ScreenTip 
gives the button’s name, the associated keyboard shortcut if there is one, and unless 
you specify otherwise, a description of what the button does when you click it.

● In the Excel program window, you can click the Microsoft Excel Help button (a 
question mark in a blue circle) at the right end of the ribbon to display the Excel 
Help window. 

● After opening a dialog box, you can click the Help button (also a question mark) at 
the right end of the dialog box title bar to display the Excel Help window. Sometimes, 
topics related to the functions of that dialog box are already identified in the window.
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xxxviii  Getting Help

To practice getting help, you can work through the following exercise.

SET UP You don’t need any practice files to complete this exercise. Start Excel, and 
then follow the steps.

1. At the right end of the ribbon, click the Microsoft Excel Help button.

The Excel Help window opens.

If you are connected to the Internet, clicking any of the buttons below the Microsoft 
Office banner (Downloads, Images, and Templates) takes you to a corresponding 
page of the Office Web site.

Tip You can maximize the window or adjust its size by dragging the handle in the 
lower-right corner. You can change the size of the font by clicking the Change Font 
Size button on the toolbar.

2. Below the bulleted list under Browse Excel 2010 support, click see all.

The window changes to display a list of help topics.

www.it-ebooks.info

http://www.it-ebooks.info/


Getting Help  xxxix

3. In the list of topics, click Activating Excel.

Excel Help displays a list of topics related to activating Microsoft Office programs. 
You can click any topic to display the corresponding information.

4. On the toolbar, click the Show Table of Contents button.

The window expands to accommodate two panes. The Table Of Contents task 
pane appears on the left, organized by category, like the table of contents in a 
book. If you’re connected to the Internet, Excel displays categories, topics, and 
training available from the Office Online Web site as well as those stored on 
your computer. Clicking any category (represented by a book icon) displays that 
category’s topics (represented by help icons).

5. In the Table of Contents task pane, click a few categories and topics. Then click the 
Back and Forward buttons to move among the topics you have already viewed.

6. At the right end of the Table of Contents title bar, click the Close button.

7. At the top of the Excel Help window, click the Type words to search for box, 
type saving, and then press the Enter key.

The Excel Help window displays topics related to the word you typed. Next and 
Back buttons appear to make it easier to search for the topic you want.
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8. In the results list, click the Recover earlier versions of a file in Office 2010 topic.

The selected topic appears in the Excel Help window.

9. Below the title at the top of the topic, click Show All.

Excel displays any hidden auxiliary information available in the topic and changes 
the Show All button to Hide All. You can jump to related information by clicking 
hyperlinks identified by blue text.

Tip You can click the Print button on the toolbar to print a topic. Only the displayed 
information is printed.

CLEAN UP Click the Close button at the right end of the Excel Help window.
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More Information
If your question is about Microsoft Excel 2010 or another Microsoft software product 
and you cannot find the answer in the product’s Help system, please search the  
appropriate product solution center or the Microsoft Knowledge Base at:

support.microsoft.com

In the United States, Microsoft software product support issues not covered by the 
Microsoft Knowledge Base are addressed by Microsoft Product Support Services. 
Location-specific software support options are available from:

support.microsoft.com/gp/selfoverview/
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1 Setting Up a 
Workbook

In this chapter, you will learn how to
✔ Create workbooks.
✔ Modify workbooks.
✔ Modify worksheets.
✔ Customize the Excel 2010 program window.

When you start Microsoft Excel 2010, the program presents a blank workbook that con-
tains three worksheets. You can add or delete worksheets, hide worksheets within the 
workbook without deleting them, and change the order of your worksheets within 
the workbook. You can also copy a worksheet to another workbook or move the work-
sheet without leaving a copy of the worksheet in the first workbook. If you and your 
colleagues work with a large number of documents, you can define property values to 
make your workbooks easier to find when you and your colleagues attempt to locate 
them by using the Windows search facility.

Another way to make Excel easier to use is by customizing the Excel program window to 
fit your work style. If you have several workbooks open at the same time, you can move 
between the workbook windows quickly. However, if you switch between workbooks 
frequently, you might find it easier to resize the workbooks so they don’t take up the 
entire Excel window. If you do this, you just need to click the title bar of the workbook 
you want to modify to switch to it.

The Microsoft Office User Experience team has enhanced your ability to customize the 
Excel user interface. If you find that you use a command frequently, you can add it to  
the Quick Access Toolbar so it’s never more than one click away. If you use a set of 
commands frequently, you can create a custom ribbon tab so they appear in one  
place. You can also hide, display, or change the order of the tabs on the ribbon.
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2  Chapter 1 Setting Up a Workbook

In this chapter, you’ll learn how to create and modify workbooks, create and modify 
worksheets, make your workbooks easier to find, and customize the Excel 2010 
program window.

Practice Files Before you can complete the exercises in this chapter, you need to copy 
the book’s practice files to your computer. The practice files you’ll use to complete the 
exercises in this chapter are in the Chapter01 practice file folder. A complete list of 
practice files is provided in “Using the Practice Files” at the beginning of this book.

Creating Workbooks
Every time you want to gather and store data that isn’t closely related to any of your 
other existing data, you should create a new workbook. The default new workbook in 
Excel has three worksheets, although you can add more worksheets or delete existing 
worksheets if you want. Creating a new workbook is a straightforward process—you 
just click the File tab, click New, identify the type of workbook you want, and click the 
Create button.
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When you start Excel, the program displays a new, blank workbook; you can begin 
to type data into the worksheet’s cells or open an existing workbook. In this book’s 
exercises, you’ll work with workbooks created for Consolidated Messenger, a fictional 
global shipping company. After you make changes to a workbook, you should save it 
to preserve your work.

Tip Readers frequently ask, “How often should I save my files?” It is good practice to save 
your changes every half hour or even every five minutes, but the best time to save a file is 
whenever you make a change that you would hate to have to make again. 

When you save a file, you overwrite the previous copy of the file. If you have made 
changes that you want to save, but you also want to keep a copy of the file as it was 
when you saved it previously, you can use the Save As command to specify a name for 
the new file. 

You also can use the controls in the Save As dialog box to specify a different format for the 
new file and a different location in which to save the new version of the file. For example, 
Lori Penor, the chief operating officer of Consolidated Messenger, might want to save an 
Excel file that tracks consulting expenses as an Excel 2003 file if she needs to share the file 
with a consulting firm that uses Excel 2003. 

After you create a file, you can add information to make the file easier to find when 
you use the Windows search facility to search for it. Each category of information, or 
property, stores specific information about your file. In Windows, you can search for 
files based on the file’s author or title, or by keywords associated with the file. A file 
tracking the postal code destinations of all packages sent from a vendor might have 
the keywords postal, destination, and origin associated with it.

To set values for your workbook’s built-in properties, you can click the File tab, click Info, 
click Properties, and then click Show Document Panel to display the Document Properties 
panel just below the ribbon. The standard version of the Document Properties panel has 
fields for the file’s author, title, subject, keywords, category, and status, and any comments 
about the file. You can also create custom properties by clicking the arrow located just to 
the right of the Document Properties label, and clicking Advanced Properties to display the 
Properties dialog box.

Creating Workbooks  3
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4  Chapter 1 Setting Up a Workbook

On the Custom page of the Properties dialog box, you can click one of the existing custom 
categories or create your own by typing a new property name in the Name field, clicking 
the Type arrow and selecting a data type (for example, Text, Date, Number, or Yes/No), 
selecting or typing a value in the Value field, and then clicking Add. If you want to delete 
an existing custom property, point to the Properties list, click the property you want to 
get rid of, and click Delete. After you finish making your changes, click the OK button. To 
hide the Document Properties panel, click the Close button in the upper-right corner of 
the panel.

In this exercise, you’ll create a new workbook, save the workbook with a new name, 
assign values to the workbook’s standard properties, and create a custom property.

SET UP You need the ExceptionSummary_start workbook located in your 
Chapter01 practice file folder to complete this exercise. Start Excel, and open  
the ExceptionSummary_start workbook. Then follow the steps.

1. Click the File tab, and then click Close.

The ExceptionSummary_start workbook closes.

2. Click the File tab, and then click New.

The New Workbook page of the Backstage view appears.
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3. Click Blank Workbook, and then click Create.

A new, blank workbook opens.

4. Click the File tab, and then click Save As.

The Save As dialog box opens.

5. Use the navigation controls to display the Chapter01 folder. In the File name field, 
type Exceptions 2010.

6. Click the Save button.

Excel 2010 saves your work, and the Save As dialog box closes.

7. Click the File tab, click Info, click Properties, and then click Show Document 
Panel.

The Document Properties panel opens.

8. In the Keywords field, type exceptions, regional, percentage.

9. In the Category field, type performance.

10. Click the arrow at the right end of the Document Properties button, and then click 
Advanced Properties.

The Exceptions 2010 Properties dialog box opens.

Creating Workbooks  5

www.it-ebooks.info

http://www.it-ebooks.info/


6  Chapter 1 Setting Up a Workbook

11. Click the Custom tab.

The Custom page is displayed.

12. In the Name field, type Performance.

13. In the Value field, type Exceptions.

14. Click the Add button, and then click OK.

The Exceptions 2010 Properties dialog box closes.

15. On the Quick Access Toolbar, click the Save button to save your work.

Keyboard Shortcut Press Ctrl+S to save a workbook.

See Also To see a complete list of keyboard shortcuts, see “Keyboard Shortcuts” at the 
end of this book.

CLEAN UP Close the Exceptions 2010 workbook.
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Modifying Workbooks
Most of the time, you create a workbook to record information about a particular activity, 
such as the number of packages that a regional distribution center handles or the average 
time a driver takes to complete all deliveries on a route. Each worksheet within that work-
book should represent a subdivision of that activity. To display a particular worksheet, just 
click the worksheet’s tab on the tab bar (just below the grid of cells).

In the case of Consolidated Messenger, the workbook used to track daily package 
volumes could have a separate worksheet for each regional distribution center. New 
Excel workbooks contain three worksheets; because Consolidated Messenger uses nine 
regional distribution centers, you would need to create six new ones. To create a new 
worksheet, click the Insert Worksheet button at the right edge of the tab bar.

Insert Worksheet

When you create a worksheet, Excel assigns it a generic name such as Sheet4, Sheet5, 
or Sheet6. After you decide what type of data you want to store on a worksheet, you 
should change the default worksheet name to something more descriptive. For example, 
you could change the name of Sheet1 in the regional distribution center tracking work-
book to Northeast. When you want to change a worksheet’s name, double-click the 
worksheet’s tab on the tab bar to highlight the worksheet name, type the new name, 
and press Enter.

Another way to work with more than one worksheet is to copy a worksheet from another 
workbook to the current workbook. One circumstance in which you might consider copying 
worksheets to the current workbook is if you have a list of your current employees in  
another workbook. You can copy worksheets from another workbook by right-clicking 
the tab of the sheet you want to copy and, on the shortcut menu, clicking Move Or Copy 
to display the Move Or Copy dialog box.

Modifying Workbooks  7
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8  Chapter 1 Setting Up a Workbook

Tip Selecting the Create A Copy check box leaves the copied worksheet in its original 
workbook, whereas clearing the check box causes Excel to delete the worksheet from its 
original workbook.

After the worksheet is in the target workbook, you can change the worksheets’ order to 
make the data easier to locate within the workbook. To change a worksheet’s location in 
the workbook, you drag its sheet tab to the desired location on the tab bar. If you want 
to remove a worksheet from the tab bar without deleting the worksheet, you can do 
so by right-clicking the worksheet’s tab on the tab bar and clicking Hide on the context 
menu. When you want Excel to redisplay the worksheet, right-click any visible sheet tab 
and then click Unhide. In the Unhide dialog box, click the name of the sheet you want to 
display, and click OK.

To differentiate a worksheet from others, or to visually indicate groups or categories of work-
sheets in a multiple-worksheet workbook, you can easily change the color of a worksheet 
tab. To do so, right-click the tab, point to Tab Color, and then click the color you want.

Tip If you copy a worksheet to another workbook, and the destination workbook has the 
same Office Theme applied as the active workbook, the worksheet retains its tab color. If 
the destination workbook has another theme applied, the worksheet’s tab color changes 
to reflect that theme. For more information on Office themes, see Chapter 4, “Changing 
Workbook Appearance.”

If you determine that you no longer need a particular worksheet, such as one you created 
to store some figures temporarily, you can delete the worksheet quickly. To do so, right-
click its sheet tab, and then click Delete. 

In this exercise, you’ll insert and rename a worksheet, change a worksheet’s position in a 
workbook, hide and unhide a worksheet, copy a worksheet to another workbook, change 
a worksheet’s tab color, and delete a worksheet.
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SET UP You need the ExceptionTracking_start workbook located in your Chapter01 
practice file folder to complete this exercise. Open the ExceptionTracking_start file, 
and save it as ExceptionTracking. Then follow the steps.

1. On the tab bar, click the Insert Worksheet button.

A new worksheet is displayed.

2. Right-click the new worksheet’s sheet tab, and then click Rename.

Excel highlights the new worksheet’s name.

3. Type 2010, and then press Enter.

4. On the tab bar, double-click the Sheet1 sheet tab.

Excel highlights the worksheet’s name.

5. Type 2009, and then press Enter.

6. Right-click the 2009 sheet tab, point to Tab Color, and then, in the Standard 
Colors area of the color palette, click the green square.

Excel changes the 2009 sheet tab to green.

7. On the tab bar, drag the 2010 sheet tab to the left of the Scratch Pad sheet tab.

 8. Right-click the 2010 sheet tab, and then click Hide.

Excel hides the 2010 worksheet.

 9. Right-click the 2009 sheet tab, and then click Move or Copy.

The Move Or Copy dialog box opens.

 10. Click the To book arrow, and then in the list, click (new book).

 11. Select the Create a copy check box.

Modifying Workbooks  9
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12. Click OK.

A new workbook opens, containing only the worksheet you copied into it.

13. On the Quick Access Toolbar, click Save.

The Save As dialog box opens.

14. In the File name field, type 2009 Archive, and then press Enter.

Excel saves the workbook, and the Save As dialog box closes.

15. On the View tab, click the Switch Windows button, and then click 
ExceptionTracking.

The ExceptionTracking workbook is displayed.

16. On the tab bar, right-click the Scratch Pad sheet tab, and then click Delete. 
In the dialog box that opens, click Delete to confirm the operation. 

The Scratch Pad worksheet is deleted.

17. Right-click the 2009 sheet tab, and then click Unhide.

The Unhide dialog box opens.

18. Click 2010, and then click OK.

The Unhide dialog box closes, and the 2010 worksheet is displayed in the 
workbook.

CLEAN UP Save and close the ExceptionTracking workbook and the 2009 Archive 
workbook.
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Modifying Worksheets
After you put up the signposts that make your data easy to find, you can take other 
steps to make the data in your workbooks easier to work with. For example, you can 
change the width of a column or the height of a row in a worksheet by dragging the 
column’s right border or the row’s bottom border to the desired position. Increasing 
a column’s width or a row’s height increases the space between cell contents, making 
your data easier to read and work with.

Tip You can apply the same change to more than one row or column by selecting the rows 
or columns you want to change and then dragging the border of one of the selected rows or 
columns to the desired location. When you release the mouse button, all the selected rows 
or columns change to the new height or width.

Modifying column width and row height can make a workbook’s contents easier to work 
with, but you can also insert a row or column between cells that contain data to make 
your data easier to read. Adding space between the edge of a worksheet and cells that 
contain data, or perhaps between a label and the data to which it refers, makes the work-
book’s contents less crowded. You insert rows by clicking a cell and clicking the Home 
tab on the ribbon. Then, in the Cells group, in the Insert list, click Insert Sheet Rows. Excel 
inserts a row above the row that contains the active cell. You insert a column in much the 
same way, by choosing Insert Sheet Columns from the Insert list. When you do this, Excel 
inserts a column to the left of the active cell.

When you insert a row, column, or cell in a worksheet that has had formatting applied, 
the Insert Options button appears. Clicking the Insert Options button displays a list of 
choices you can make about how the inserted row or column should be formatted. The 
following table summarizes your options.

Option Action
Format Same As Above Applies the formatting of the row above the inserted row to the 

new row
Format Same As Below Applies the formatting of the row below the inserted row to the 

new row
Format Same As Left Applies the formatting of the column to the left of the inserted 

column to the new column
Format Same As Right Applies the formatting of the column to the right of the inserted 

column to the new column
Clear Formatting Applies the default format to the new row or column

Modifying Worksheets  11
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If you want to delete a row or column, right-click the row or column head and then, on 
the shortcut menu that appears, click Delete. You can temporarily hide rows or columns 
by selecting those rows or columns and then, on the Home tab, in the Cells group, clicking 
the Format button, pointing to Hide & Unhide, and then clicking either Hide Rows or Hide 
Columns. The rows or columns you selected disappear, but they aren’t gone for good, as 
they would be if you’d used Delete. Instead, they have just been removed from the display 
until you call them back. To return the hidden rows to the display, select the row or column 
headers on either side of the hidden rows or columns. Then, on the Home tab, in the Cells 
group, click the Format button, point to Hide & Unhide, and then click either Unhide Rows 
or Unhide Columns.

Important If you hide the first row or column in a worksheet, you must click the Select All 
button in the upper-left corner of the worksheet (above the first row header and to the left 
of the first column header) or press Ctrl+A to select the entire worksheet. Then, on the Home 
tab, in the Cells group, click Format, point to Hide & Unhide, and then click either Unhide 
Rows or Unhide Columns to make the hidden data visible again.

Just as you can insert rows or columns, you can insert individual cells into a worksheet. To 
insert a cell, click the cell that is currently in the position where you want the new cell to 
appear. On the Home tab, in the Cells group, in the Insert list, click Insert Cells to display 
the Insert dialog box. In the Insert dialog box, you can choose whether to shift the cells 
surrounding the inserted cell down (if your data is arranged as a column) or to the right (if 
your data is arranged as a row). When you click OK, the new cell appears, and the contents 
of affected cells shift down or to the right, as appropriate. In a similar vein, if you want 
to delete a block of cells, select the cells, and on the Home tab, in the Cells group, in the 
Delete list, click Delete Cells to display the Delete dialog box—complete with options that 
enable you to choose how to shift the position of the cells around the deleted cells.

Tip The Insert dialog box also includes options you can click to insert a new row or column; 
the Delete dialog box has similar options for deleting an entire row or column.

If you want to move the data in a group of cells to another location in your worksheet, 
select the cells you want to move and use the mouse pointer to point to the selection’s 
border. When the pointer changes to a four-pointed arrow, you can drag the selected cells 
to the desired location on the worksheet. If the destination cells contain data, Excel displays 
a dialog box asking whether you want to overwrite the destination cells’ contents. If you 
want to replace the existing values, click OK. If you don’t want to overwrite the existing 
values, click Cancel and insert the required number of cells to accommodate the data 
you want to move.

In this exercise, you’ll insert a column and row into a worksheet, specify insert options, 
hide a column, insert a cell into a worksheet, delete a cell from a worksheet, and move a 
group of cells within the worksheet.
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SET UP You need the RouteVolume_start workbook located in your Chapter01 
practice file folder to complete this exercise. Open the RouteVolume_start workbook, 
and save it as RouteVolume. Then follow the steps.

1. On the May 12 worksheet, select cell A1.

2. On the Home tab, in the Cells group, click the Insert arrow, and then in the list, 
click Insert Sheet Columns.

A new column A appears.

3. In the Insert list, click Insert Sheet Rows.

A new row 1 appears.

4. Click the Insert Options button that appears below the lower-right corner of the 
selected cell, and then click Clear Formatting.

Excel removes the formatting from the new row 1.

5. Right-click the column header of column E, and then click Hide.

Column E disappears.
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6. On the tab bar, click the May 13 sheet tab.

The worksheet named May 13 appears.

7. Click cell B6.

8. On the Home tab, in the Cells group, click the Delete arrow, and then in the list, 
click Delete Cells.

The Delete dialog box opens.

9. If necessary, click Shift cells up, and then click OK.

The Delete dialog box closes and Excel deletes cell B6, moving the cells below it up 
to fill in the gap.

10. Click cell C6.

11. In the Cells group, in the Insert list, click Insert Cells.

The Insert dialog box opens.

12. If necessary, click Shift cells down, and then click OK.

The Insert dialog box closes, and Excel creates a new cell C6, moving cells C6:C11 
down to accommodate the inserted cell.

13. In cell C6, type 4499, and then press Enter.

14. Select cells E13:F13.

15. Point to the border of the selected cells. When your mouse pointer changes to a 
four-pointed arrow, drag the selected cells to cells B13:C13.

The dragged cells replace cells B13:C13.
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CLEAN UP Save the RouteVolume workbook, and then close it.

Customizing the Excel 2010 Program Window
How you use Excel 2010 depends on your personal working style and the type of data 
collections you manage. The Excel product team interviews customers, observes how 
differing organizations use the program, and sets up the user interface so that many 
users won’t need to change it to work effectively. If you do want to change the Excel 
program window, including the user interface, you can. You can change how Excel dis-
plays your worksheets; zoom in on worksheet data; add frequently used commands 
to the Quick Access Toolbar; hide, display, and reorder ribbon tabs; and create custom 
tabs to make groups of commands readily accessible.

Customizing the Excel 2010 Program Window  15
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16  Chapter 1 Setting Up a Workbook

Zooming In on a Worksheet
One way to make Excel easier to work with is to change the program’s zoom level. Just 
as you can “zoom in” with a camera to increase the size of an object in the camera’s 
viewer, you can use the zoom setting to change the size of objects within the Excel 2010 
program window. For example, if Peter Villadsen, the Consolidated Messenger European 
Distribution Center Manager, displayed a worksheet that summarized his distribution 
center’s package volume by month, he could click the View tab and then, in the Zoom 
group, click the Zoom button to display the Zoom dialog box. The Zoom dialog box 
contains controls that he can use to select a preset magnification level or to type in 
a custom magnification level. He could also use the Zoom control in the lower-right 
corner of the Excel 2010 window.

Zoom Out

Zoom In

Clicking the Zoom In control increases the size of items in the program window by 
10 percent, whereas clicking the Zoom Out control decreases the size of items in the 
program window by 10 percent. If you want more fine-grained control of your zoom 
level, you can use the slider control to select a specific zoom level or click the magnifi-
cation level indicator, which indicates the zoom percentage, and use the Zoom dialog 
box to set a custom magnification level.

The Zoom group on the View tab also contains the Zoom To Selection button, which 
fills the program window with the contents of any selected cells, up to the program’s 
maximum zoom level of 400 percent.

Tip The minimum zoom level in Excel 2010 is 10 percent.
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Arranging Multiple Workbook Windows
As you work with Excel, you will probably need to have more than one workbook open 
at a time. For example, you could open a workbook that contains customer contact 
information and copy it into another workbook to be used as the source data for a mass 
mailing you create in Microsoft Word 2010. When you have multiple workbooks open 
simultaneously, you can switch between them by clicking the View tab and then, in the 
Window group, clicking the Switch Windows button and clicking the name of the work-
book you want to view. 

You can arrange your workbooks within the Excel window so that most of the active 
workbook is shown but the others are easily accessible. To do so, click the View tab and 
then, in the Window group, click the Arrange All button. Then, in the Arrange Windows 
dialog box, click Cascade. 

Many Excel 2010 workbooks contain formulas on one worksheet that derive their value 
from data on another worksheet, which means you need to change between two work-
sheets every time you want to see how modifying your data changes the formula’s result. 
However, an easier way to approach this is to display two copies of the same workbook 
simultaneously, displaying the worksheet that contains the data in the original window 
and displaying the worksheet with the formula in the new window. When you change 
the data in either copy of the workbook, Excel updates the other copy. To display two 
copies of the same workbook, open the desired workbook and then, in the View tab’s 
Window group, click New Window. Excel opens a second copy of the workbook. To display 
the workbooks side by side, on the View tab, in the Window group, click Arrange All. 
Then, in the Arrange Windows dialog box, click Vertical and then click OK.

If the original workbook’s name is Exception Summary, Excel 2010 displays the name 
Exception Summary:1 on the original workbook’s title bar and Exception Summary:2 
on the second workbook’s title bar.
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www.it-ebooks.info

http://www.it-ebooks.info/


18  Chapter 1 Setting Up a Workbook

Troubleshooting The appearance of buttons and groups on the ribbon changes depending on 
the width of the program window. For information about changing the appearance of the ribbon 
to match our images, see “Modifying the Display of the Ribbon” at the beginning of this book.

Adding Buttons to the Quick Access Toolbar
As you continue to work with Excel 2010, you might discover that you use certain com-
mands much more frequently than others. If your workbooks draw data from external 
sources, for example, you might find yourself displaying the Data tab and then, in the 
Connections group, clicking the Refresh All button much more often than the program’s 
designers might have expected. You can make any button accessible with one click by 
adding the button to the Quick Access Toolbar, located just above the ribbon in the 
upper-left corner of the Excel program window. 

To add a button to the Quick Access Toolbar, click the File tab, and then click Options. In 
the Excel Options dialog box, display the Customize The Quick Access Toolbar page. This 
Options page contains two panes. The pane on the left lists all of the controls that are 
available within a given category, and the pane on the right lists the controls currently 
displayed on the Quick Access Toolbar. To add a command to the Quick Access Toolbar, 
display the Customize The Quick Access Toolbar page of the Options dialog box. Then, 
in the Choose Commands From list, click the category that contains the control you 
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want to add. Excel 2010 displays the available commands in the box below the Choose 
Commands From field. Click the control you want, and then click the Add button. 

You can change a button’s position on the Quick Access Toolbar by clicking its name 
in the right pane and then clicking either the Move Up or Move Down button at the 
right edge of the dialog box. To remove a button from the Quick Access Toolbar, click 
the button’s name in the right pane, and then click the Remove button. When you’re 
done making your changes, click the OK button. If you prefer not to save your changes, 
click the Cancel button. If you saved your changes but want to return the Quick Access 
Toolbar to its original state, click the Reset button and then click either Reset Only Quick 
Access Toolbar, which removes any changes you made to the Quick Access Toolbar, or 
Reset All Customizations, which returns the entire ribbon interface to its original state.

You can also choose whether your Quick Access Toolbar changes affect all your work-
books or just the active workbook. To control how Excel applies your change, in the 
Customize Quick Access Toolbar list, click either For All Documents to apply the change to 
all of your workbooks or For Workbook to apply the change to the active workbook only.

If you’d like to export your Quick Access Toolbar customizations to a file that can be 
used to apply those changes to another Excel 2010 installation, click the Import/Export 
button and then click Export All Customizations. Use the controls in the dialog box that 
opens to save your file. When you’re ready to apply saved customizations to Excel, click 
the Import/Export button, click Import Customization File, select the file in the File Open 
dialog box, and click Open.
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Customizing the Ribbon
Excel 2010 enhances your ability to customize the entire ribbon by enabling you to hide and 
display ribbon tabs, reorder tabs displayed on the ribbon, customize existing tabs (including 
tool tabs, which appear when specific items are selected), and to create custom tabs.

To begin customizing the ribbon, click the File tab and then click Options. In the Excel 
Options dialog box, click Customize Ribbon to display the Customize The Ribbon page. 

To select which tabs appear in the tabs pane on the right side of the screen, click the 
Customize The Ribbon field’s arrow and then click either Main Tabs, which displays the 
tabs that can appear on the standard ribbon; Tool Tabs, which displays the tabs that 
appear when you click an item such as a drawing object or PivotTable; or All Tabs.

Tip The procedures taught in this section apply to both the main tabs and the tool tabs.

Each ribbon tab’s name has a check box next to it. If a tab’s box is selected, then that tab 
appears on the ribbon. You can hide a tab by clearing the check box and bring it back by 
selecting the check box. You can also change the order in which the tabs are displayed 
on the ribbon. To do so, click the name of the tab you want to move and then click the 
Move Up or Move Down arrows to reposition the selected tab.
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Just as you can change the order of the tabs on the ribbon, with Excel 2010, you can change 
the order in which groups of commands appear on a tab. For example, the Page Layout tab 
contains five groups: Themes, Page Setup, Scale To Fit, Sheet Options, and Arrange. If you 
use the Themes group less frequently than the other groups, you could move the group to 
the right end of the tab by clicking the group’s name and then clicking the Move Down 
arrow button until the group appears in the desired position.

To remove a group from a built-in ribbon tab, click the name of the group in the right 
pane and click the Remove button. If you remove a group from a built-in tab and later 
decide you want to put it back on the tab, display the tab in the right pane. Then, click the 
Choose Commands From field’s arrow and click Main Tabs. With the tab displayed, in the left 
pane, click the expand control (which looks like a plus sign) next to the name of the tab that 
contains the group you want to add back. You can now click the name of the group in the 
left pane and click the Add button to put the group back on the selected ribbon tab.

The built-in ribbon tabs are designed efficiently, so adding new command groups might 
crowd the other items on the tab and make those controls harder to find. Rather than 
adding controls to an existing ribbon tab, you can create a custom tab and then add 
groups and commands to it. To create a custom ribbon tab, click the New Tab button  
on the Customize The Ribbon page of the Excel Options dialog box. When you do, 
a new tab named New Tab (Custom), which contains a group named New Group 
(Custom), appears in the tab list. 
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You can add an existing group to your new ribbon tab by clicking the Choose Commands 
From field’s arrow, selecting a collection of commands, clicking the group you want to 
add, and then clicking the Add button. You can also add individual commands to your 
ribbon tab by clicking a command in the command list and clicking the Add button. To 
add a command to your tab’s custom group, click the new group in the right tab list, 
click the command in the left list, and then click the Add button. If you want to add 
another custom group to your new tab, click the new tab, or any of the groups within 
that tab, and then click New Group.

Tip You can change the order of the groups and commands on your custom ribbon tabs by 
using the techniques described earlier in this section.

The New Tab (Custom) name doesn’t tell you anything about the commands on your new 
ribbon tab, so you can rename it to reflect its contents. To rename any tab on the ribbon,  
display the Customize The Ribbon page of the Excel Options dialog box, click the tab 
you want to modify, and then click the Rename button. Type the tab’s new name in the 
Rename dialog box, and click OK. To rename any group on the ribbon, click the name of 
the group, and then click Rename. When you do, a different version of the Rename dialog 
box appears. Click the symbol that you want to use to represent the group on the ribbon, 
type a new name for the group in the Display Name box, and click OK.

If you’d like to export your ribbon customizations to a file that can be used to apply those 
changes to another Excel 2010 installation, click the Import/Export button and then click 
Export All Customizations. Use the controls in the dialog box that opens to save your file. 
When you’re ready to apply saved customizations to Excel, click the Import/Export button, 
click Import Customization File, select the file in the File Open dialog box, and click Open.
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When you’re done customizing the ribbon, click the OK button to save your changes 
or click Cancel to keep the user interface as it was before you started this round of 
changes. You can also change a ribbon tab, or the entire ribbon, back to the state it 
was in when you installed Excel. To restore a single ribbon tab, click the tab you want 
to restore, click the Reset button, and then click Reset Only Selected Ribbon Tab. To 
restore the entire ribbon, including the Quick Access Toolbar, click the Reset button 
and then click Reset All Customizations.

Maximizing Usable Space in the Program Window
You can increase the amount of space available inside the program window by hiding 
the ribbon, the formula bar, or the row and column labels.

To hide the ribbon, double-click the active tab label. The tab labels remain visible at the top 
of the program window, but the tab content is hidden. To temporarily redisplay the ribbon, 
click the tab label you want. Then click any button on the tab, or click away from the tab, to 
rehide it. To permanently redisplay the ribbon, double-click any tab label.

Keyboard Shortcut Press Ctrl+F1 to hide and unhide the ribbon.

To hide the formula bar, clear the Formula Bar check box in the Show/Hide group on 
the View tab. To hide the row and column labels, clear the Headings check box in the 
Show/Hide group on the View tab.

In this exercise, you’ll change your worksheet’s zoom level, zoom in to emphasize a 
selected cell range, switch between multiple open workbooks, cascade multiple open 
workbooks within the Excel program window, add a button to the Quick Access Toolbar, 
and customize the ribbon.

SET UP You need the PackageCounts_start and MisroutedPackages_start workbooks 
located in your Chapter01 practice file folder to complete this exercise. Open the 
PackageCounts_start and MisroutedPackages_start workbooks, and name them as 
PackageCounts and MisroutedPackages, respectively. Then follow the steps.

1. In the MisroutedPackages workbook, in the lower-right corner of the Excel 2010 
window, click the Zoom In control five times.

The worksheet’s zoom level changes to 150%.

2. Select cells B2:C11.

3. On the View tab, in the Zoom group, click the Zoom to Selection button.

Excel displays the selected cells so they fill the program window.
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24  Chapter 1 Setting Up a Workbook

4. On the View tab, in the Zoom group, click the Zoom button.

The Zoom dialog box opens.

5. Click 100%, and then click OK.

The worksheet returns to its default zoom level.

6. On the View tab, in the Window group, click the Switch Windows button, and 
then click PackageCounts.

The PackageCounts workbook opens.
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7. On the View tab, in the Window group, click the Arrange All button.

The Arrange Windows dialog box opens.

8. Click Cascade, and then click OK.

Excel cascades the open workbook windows within the program window.

9. Click the File tab, and then click Options.

The Excel Options dialog box opens.

10. Click Quick Access Toolbar.

The Customize The Quick Access Toolbar page opens.

11. Click the Choose commands from arrow, and then in the list, click Review Tab.

The commands in the Review Tab category appear in the command list.

12. Click the Spelling command, and then click Add.

Excel adds the Spelling command to the Quick Access Toolbar.
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26  Chapter 1 Setting Up a Workbook

13. Click Customize Ribbon. 

The Customize The Ribbon page of the Excel Options dialog box appears.

14. If necessary, click the Customize the Ribbon box’s arrow and click Main Tabs. In the 
right tab list, click the Review tab and then click the Move Up button three times.

Excel moves the Review tab between the Insert and Page Layout tabs.

15. Click the New Tab button.

A tab named New Tab (Custom) appears below the most recently active tab in the 
Main Tabs list.

16. Click the New Tab (Custom) tab name, click the Rename button, type My 
Commands in the Display Name box, and click OK.

The new tab’s name changes to My Commands.

17. Click the New Group (Custom) group’s name and then click the Rename button. 
In the Rename dialog box, click the icon that looks like a paint palette (second 
row, fourth from the right). Then, in the Display name box, type Formatting, 
and click OK.

The new group’s name changes to Formatting. 

18. In the right tab list, click the My Commands tab name. Then, on the left side of the 
dialog box, click the Choose Commands From box’s arrow and click Main Tabs.

The Main Tabs group of ribbon tabs appears in the left tab list.
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19. In the left tab list, click the Home tab’s expand control, click the Styles group’s 
name, and then click the Add button.

The Styles group is added to the My Commands tab.

20. In the left tab list, under the Home tab, click the Number group’s expand control.

The commands in the Number group appear.

21. In the right tab list, click the Formatting group you created earlier. Then, in the left 
tab list, click the Number Format item and click the Add button.

Excel 2010 adds the Number Format item to the Formatting custom group.

22. Click OK to save your ribbon customizations, and then click the My Commands 
tab on the ribbon.

Important The remaining exercises in this book assume you are using Excel 2010 as it 
was installed on your computer. After you complete this exercise, you should reset the 
ribbon to its original configuration so the instructions in the remaining exercises in the 
book are consistent with your copy of Excel.

CLEAN UP Save and close all open workbooks. If you are not continuing directly to 
the next chapter, exit Excel.

Key Points
● Save your work whenever you do something you’d hate to have to do again.

● Assigning values to a workbook’s properties makes it easier to find your workbook 
using the Windows search facility.

● Be sure to give your worksheets descriptive names.

● If you want to use a worksheet’s data in another workbook, you can send a copy of 
the worksheet to that other workbook without deleting the original worksheet.

● You can delete a worksheet you no longer need, but you can also hide a worksheet 
in the workbook. When you need the data on the worksheet, you can unhide it.

● You can save yourself a lot of bothersome cutting and pasting by inserting and 
deleting worksheet cells, columns, and rows.

● Customize your Excel 2010 program window by changing how it displays your 
workbooks, zooming in on data, adding frequently used buttons to the Quick 
Access Toolbar, and rearranging or customizing the ribbon to meet your needs.

Key Points  27
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2 Working with Data 
and Excel Tables

In this chapter, you will learn how to
✔ Enter and revise data.
✔ Move data within a workbook.
✔ Find and replace data.
✔ Correct and expand upon worksheet data.
✔ Define Excel tables.

With Microsoft Excel 2010, you can visualize and present information effectively by 
using charts, graphics, and formatting, but the data is the most important part of any 
workbook. By learning to enter data efficiently, you will make fewer data entry errors 
and give yourself more time to analyze your data so you can make decisions about 
your organization’s performance and direction.

Excel provides a wide variety of tools you can use to enter and manage worksheet data 
effectively. For example, you can organize your data into Excel tables, which enables you 
to store and analyze your data quickly and efficiently. Also, you can enter a data series 
quickly, repeat one or more values, and control how Excel formats cells, columns, and 
rows moved from one part of a worksheet to another with a minimum of effort. With 
Excel, you can check the spelling of worksheet text, look up alternative words by using 
the Thesaurus, and translate words to foreign languages.

In this chapter, you’ll learn how to enter and revise Excel data, move data within a work-
book, find and replace existing data, use proofing and reference tools to enhance your 
data, and organize your data by using Excel tables.

Practice Files Before you can complete the exercises in this chapter, you need to copy 
the book’s practice files to your computer. The practice files you’ll use to complete the 
exercises in this chapter are in the Chapter02 practice file folder. A complete list of 
practice files is provided in “Using the Practice Files” at the beginning of this book.

 Contents

 2 Working with Data 
  
and Excel Tables 29

Entering and Revising Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30
Moving Data Within a Workbook. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .34
Finding and Replacing Data. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 38
Correcting and Expanding Upon Worksheet Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43
Defining Excel Tables . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .48
Key Points . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53

www.it-ebooks.info

http://www.it-ebooks.info/
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Entering and Revising Data
After you create a workbook, you can begin entering data. The simplest way to enter data 
is to click a cell and type a value. This method works very well when you’re entering a few 
pieces of data, but it is less than ideal when you’re entering long sequences or series of 
values. For example, Craig Dewar, the VP of Marketing for Consolidated Messenger, might 
want to create a worksheet listing the monthly program savings that large customers can 
realize if they sign exclusive delivery contracts with Consolidated Messenger. To record 
those numbers, he would need to create a worksheet tracking each customer’s monthly 
program savings.

Repeatedly entering the sequence January, February, March, and so on can be handled 
by copying and pasting the first occurrence of the sequence, but there’s an easier way to 
do it: use AutoFill. With AutoFill, you enter the first element in a recognized series, click 
and hold the mouse button down on the fill handle at the lower-right corner of the cell, 
and drag the fill handle until the series extends far enough to accommodate your data. 
Using a similar tool, FillSeries, you can enter two values in a series and use the fill handle 
to extend the series in your worksheet. For example, if you want to create a series starting 
at 2 and increasing by 2, you can put 2 in the first cell and 4 in the second cell, select 
both cells, and then use the fill handle to extend the series to your desired end value.
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You do have some control over how Excel extends the values in a series when you drag 
the fill handle. For example, if you drag the fill handle up (or to the left), Excel extends the 
series to include previous values. If you type January in a cell and then drag that cell’s fill 
handle up (or to the left), Excel places December in the first cell, November in the second 
cell, and so on.

Another way to control how Excel extends a data series is by holding down the Ctrl key 
while you drag the fill handle. For example, if you select a cell that contains the value 
January and then drag the fill handle down, Excel extends the series by placing February 
in the next cell, March in the cell after that, and so on. If you hold down the Ctrl key while 
you drag the fill handle, however, Excel repeats the value January in each cell you add to 
the series. 

Tip Be sure to experiment with how the fill handle extends your series and how pressing the 
Ctrl key changes that behavior. Using the fill handle can save you a lot of time entering data.

Other data entry techniques you’ll use in this section are AutoComplete, which detects 
when a value you’re entering is similar to previously entered values; Pick From Drop-Down 
List, from which you can choose a value from among the existing values in a column; and 
Ctrl+Enter, which you can use to enter a value in multiple cells simultaneously.

Troubleshooting If an AutoComplete suggestion doesn’t appear as you begin typing a cell 
value, the option might be turned off. To turn on AutoComplete, click the File tab, and then click 
Options. In the Excel Options dialog box, display the Advanced page. In the Editing Options area 
of the page, select the Enable AutoComplete For Cell Values check box, and then click OK.

The following table summarizes these data entry techniques.

Method Action
AutoFill Enter the first value in a recognized series and use the fill handle to extend 

the series.
FillSeries Enter the first two values in a series and use the fill handle to extend the 

series.
AutoComplete Type the first few letters in a cell, and if a similar value exists in the same 

column, Excel suggests the existing value.
Pick From  
Drop-Down  
List

Right-click a cell, and then click Pick From Drop-Down List. A list of existing 
values in the cell’s column is displayed. Click the value you want to enter 
into the cell.

Ctrl+Enter Select a range of cells, each of which you want to contain the same data, 
type the data in the active cell, and press Ctrl+Enter.
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Another handy feature in Excel is the AutoFill Options button that appears next to data 
you add to a worksheet by using the fill handle.

Clicking the AutoFill Options button displays a list of actions Excel can take regarding 
the cells affected by your fill operation. The options in the list are summarized in the 
following table.

Option Action
Copy Cells This copies the contents of the selected cells to the cells indicated by the 

fill operation.
Fill Series This action fills the cells indicated by the fill operation with the next items 

in the series.
Fill Formatting 
Only

This copies the format of the selected cell to the cells indicated by the fill 
operation, but does not place any values in the target cells.

Fill Without 
Formatting

This action fills the cells indicated by the fill operation with the next items 
in the series, but ignores any formatting applied to the source cells.

Fill Days, 
Weekdays, and 
so on

The appearance of this option changes according to the series you extend. 
For example, if you extend the values Wed, Thu, and Fri, Excel presents two 
options, Fill Days and Fill Weekdays, and you can select which one you 
intended. If you do not use a recognized sequence, this option does not 
appear.
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In this exercise, you’ll enter data by using multiple methods and control how Excel for-
mats an extended data series.

SET UP You need the Series_start workbook located in your Chapter02 practice file 
folder to complete this exercise. Start Excel, open the Series_start workbook, and 
save it as Series. Then follow the steps.

1. On the Monthly worksheet, select cell B3, and then drag the fill handle down until 
it covers cells B3:B7.

Excel repeats the value Fabrikam in cells B4:B7.

2. Select cell C3, hold down the Ctrl key, and drag the fill handle down until it covers 
cells C3:C7.

Excel repeats the value January in cells C4:C7.

3. Select cell B8, and then type the letter F.

Excel displays the characters abrikam in reverse colors.

 4. Press Tab to accept the value Fabrikam for the cell.

 5. In cell C8, type February.

6. Right-click cell D8, and then click Pick From Drop-down List.

A list of values in column D appears below cell D8.
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7. From the list, click 2Day.

The value 2Day appears in cell D8.

8. In cell E8, type 11802.14, and then press Tab or Enter.

The value $11,802.14 appears in cell E8.

9. Select cell B2, and then drag the fill handle so that it covers cells C2:E2.

Excel replaces the values in cells C2:E2 with the value Customer.

10. Click the AutoFill Options button, and then click Fill Formatting Only.

Excel restores the original values in cells C2:E2 but applies the formatting of cell B2 
to those cells.

CLEAN UP Save the Series workbook, and then close it.

Moving Data Within a Workbook
You can move to a specific cell in lots of ways, but the most direct method is to click the 
desired cell. The cell you click will be outlined in black, and its contents, if any, will appear 
in the formula bar. When a cell is outlined, it is the active cell, meaning that you can 
modify its contents. You use a similar method to select multiple cells (referred to as a 
cell range)—just click the first cell in the range, hold down the left mouse button, and 
drag the mouse pointer over the remaining cells you want to select. After you select the 
cell or cells you want to work with, you can cut, copy, delete, or change the format of 
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the contents of the cell or cells. For instance, Gregory Weber, the Northwest Distribution 
Center Manager for Consolidated Messenger, might want to copy the cells that contain a 
set of column labels to a new page that summarizes similar data.

Important If you select a group of cells, the first cell you click is designated as the active cell.

You’re not limited to selecting cells individually or as part of a range. For example, you 
might need to move a column of price data one column to the right to make room 
for a column of headings that indicate to which service category (ground, three-day 
express, two-day express, overnight, or priority overnight) a set of numbers belongs. 
To move an entire column (or entire columns) of data at a time, you click the column’s 
header, located at the top of the worksheet. Clicking a column header highlights every 
cell in that column and enables you to copy or cut the column and paste it elsewhere 
in the workbook. Similarly, clicking a row’s header highlights every cell in that row, 
enabling you to copy or cut the row and paste it elsewhere in the workbook.

When you copy a cell, cell range, row, or column, Excel copies the cells’ contents and 
formatting. In previous versions of Excel, you would paste the cut or copied items and 
then click the Paste Options button to select which aspects of the cut or copied cells to 
paste into the target cells. The problem with using the Paste Options button was that 
there was no way to tell what your pasted data would look like until you completed the 
paste operation. If you didn’t like the way the pasted data looked, you had to click  
the Paste Options button again and try another option. 

With the new Paste Live Preview capability in Excel, you can see what your pasted data 
will look like without forcing you to commit to the paste operation. To preview your 
data using Paste Live Preview, cut or copy worksheet data and then, on the Home tab 
of the ribbon, in the Clipboard group, click the Paste button’s arrow to display the Paste 
gallery, and point to one of the icons. When you do, Excel displays a preview of how 
your data will appear if you click that paste option.
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If you position your mouse pointer over one icon in the Paste gallery and then move 
it over another icon without clicking, Excel will update the preview to reflect the new 
option. Depending on the cells’ contents, two or more of the paste options might lead 
to the same result.

Troubleshooting If pointing to an icon in the Paste gallery doesn’t result in a live preview, 
that option might be turned off. To turn Paste Live Preview on, click the File tab and click 
Options to display the Excel Options dialog box. Click General, select the Enable Live Preview 
check box, and click OK.

After you click an icon to complete the paste operation, Excel displays the Paste Options 
button next to the pasted cells. Clicking the Paste Options button displays the Paste 
Options palette as well, but pointing to one of those icons doesn’t generate a preview. 
If you want to display Paste Live Preview again, you will need to press Ctrl+Z to undo 
the paste operation and, if necessary, cut or copy the data again to use the icons in the 
Home tab’s Clipboard group.

Troubleshooting If the Paste Options button doesn’t appear, you can turn the feature on by 
clicking the File tab and then clicking Options to display the Excel Options dialog box. In the 
Excel Options dialog box, display the Advanced page and then, in the Cut, Copy, And Paste 
area, select the Show Paste Options Buttons When Content Is Pasted check box. Click OK to 
close the dialog box and save your setting.

After cutting or copying data to the Clipboard, you can access additional paste options 
from the Paste gallery and from the Paste Special dialog box, which you display by clicking 
Paste Special at the bottom of the Paste gallery. 
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In the Paste Special dialog box, you can specify the aspect of the Clipboard contents 
you want to paste, restricting the pasted data to values, formats, comments, or one of  
several other options. You can perform mathematical operations involving the cut 
or copied data and the existing data in the cells you paste the content into. You can 
transpose data—change rows to columns and columns to rows—when you paste it, 
by clicking Transpose in the Paste gallery or by selecting the Transpose check box in 
the Paste Special dialog box.

In this exercise, you’ll copy a set of data headers to another worksheet, move a column 
of data within a worksheet, and use Paste Live Preview to control the appearance of 
copied data.

SET UP You need the 2010Q1ShipmentsByCategory_start workbook located 
in your Chapter02 practice file folder to complete this exercise. Open 
the 2010Q1ShipmentsByCategory_start workbook, and save it as 
2010Q1ShipmentsByCategory. Then follow the steps.

1. On the Count worksheet, select cells B2:D2.

2. On the Home tab, in the Clipboard group, click the Copy button.

Excel copies the contents of cells B2:D2 to the Clipboard.

Keyboard Shortcut Press Ctrl+C to copy worksheet contents to the Clipboard.

See Also To see a complete list of keyboard shortcuts, see “Keyboard Shortcuts” at the 
end of this book.

3. On the tab bar, click the Sales tab to display that worksheet.

4. Select cell B2.

5. On the Home tab, in the Clipboard group, click the Paste button’s arrow, point to 
the first icon in the Paste group, and then click the Keep Source Formatting icon 
(the final icon in the first row of the Paste gallery.)

Excel displays how the data would look if you pasted the copied values without for-
matting, and then pastes the header values into cells B2:D2, retaining the original 
cells’ formatting.

6. Right-click the column header of column I, and then click Cut.

Excel outlines column I with a marquee.

7. Right-click the header of column E, and then, under Paste Options, click Paste.
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Excel pastes the contents of column I into column E.

Keyboard Shortcut Press Ctrl+V to paste worksheet contents exactly as they appear in 
the original cell.

Troubleshooting The appearance of buttons and groups on the ribbon changes depending 
on the width of the program window. For information about changing the appearance of 
the ribbon to match our screen images, see “Modifying the Display of the Ribbon” at the 
beginning of this book.

CLEAN UP Save the 2010Q1ShipmentsByCategory workbook, and then close it.

Finding and Replacing Data
Excel worksheets can hold more than one million rows of data, so in large data collections 
it’s unlikely that you would have the time to move through a worksheet one row at a time 
to locate the data you want to find. You can locate specific data in an Excel worksheet by 
using the Find And Replace dialog box, which has two pages (one named Find, the other 
named Replace) that you can use to search for cells that contain particular values. Using 
the controls on the Find page identifies cells that contain the data you specify; using the 
controls on the Replace page, you can substitute one value for another. For example, if one 
of Consolidated Messenger’s customers changes its company name, you can change every 
instance of the old name to the new name by using the Replace functionality.

When you need more control over the data that you find and replace, for instance, if 
you want to find cells in which the entire cell value matches the value you’re searching 
for, you can click the Options button to expand the Find And Replace dialog box.
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One way you can use the extra options in the Find And Replace dialog box is to use 
a specific format to identify data that requires review. As an example, Consolidated 
Messenger VP of Marketing Craig Dewar could make corporate sales plans based on 
a projected budget for the next year and mark his trial figures using a specific format. 
After the executive board finalizes the numbers, he could use the Find Format capability 
in the Find And Replace dialog box to locate the old values and change them by hand. 

The following table summarizes the Find And Replace dialog box controls’ functions.

Control Function
Find What field Contains the value you want to find or replace
Find All button Selects every cell that contains the value in the Find What field
Find Next  
button

Selects the next cell that contains the value in the Find What field

Replace With 
field

Contains the value to overwrite the value in the Find What field

Replace All 
button

Replaces every instance of the value in the Find What field with the value 
in the Replace With field

Replace button Replaces the highlighted occurrence of the value in the Find What field 
and highlights the next cell that contains that value

Options button Expands the Find And Replace dialog box to display additional capabilities
Format button Displays the Find Format dialog box, which you can use to specify the 

format of values to be found or values to be replaced
Within box Enables you to select whether to search the active worksheet or the entire 

workbook
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Control Function
Search box Enables you to select whether to search by rows or by columns
Look In box Enables you to select whether to search cell formulas or values
Match Case 
check box

When checked, requires that all matches have the same capitalization as 
the text in the Find What field (for example, cat doesn’t match Cat)

Match Entire 
Cell Contents 
check box

Requires that the cell contain exactly the same value as in the Find What 
field (for example, Cat doesn’t match Catherine)

Close button Closes the Find And Replace dialog box

To change a value by hand, select the cell, and then either type a new value in the cell or, 
in the formula bar, select the value you want to replace and type the new value. You can 
also double-click a cell and edit its contents within the cell.

In this exercise, you’ll find a specific value in a worksheet, replace every occurrence of a 
company name in a worksheet, and find a cell with a particular formatting.

SET UP You need the AverageDeliveries_start workbook located in your Chapter02 
practice file folder to complete this exercise. Open the AverageDeliveries_start 
workbook, and save it as AverageDeliveries. Then follow the steps.

1. If necessary, click the Time Summary sheet tab.

The Time Summary worksheet is displayed.

2. On the Home tab, in the Editing group, click Find & Select, and then click Find.

The Find And Replace dialog box opens with the Find tab displayed.

Keyboard Shortcut Press Ctrl+F to display the Find tab of the Find And Replace 
dialog box.

 3. In the Find what field, type 114.

 4. Click Find Next.
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Excel highlights cell B16, which contains the value 114.

5. Delete the value in the Find what field, and then click the Options button.

The Find And Replace dialog box expands to display additional search options.

6. Click Format.

The Find Format dialog box opens.

7. Click the Font tab.

The Font page is displayed.
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8. In the Font style list, click Italic.

9. Click OK.

The Find Format dialog box closes.

10. Click Find Next.

Excel highlights cell D25.

11. Click Close.

The Find And Replace dialog box closes.

12. On the tab bar, click the Customer Summary sheet tab.

The Customer Summary worksheet is displayed.

13. On the Home tab, in the Editing group, click Find & Select, and then click 
Replace.

The Find And Replace dialog box opens with the Replace tab displayed.

Keyboard Shortcut Press Ctrl+H to display the Replace tab of the Find And Replace 
dialog box.
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14. Click the Format arrow to the right of the Find what field, and then in the 
list, click Clear Find Format.

The format displayed next to the Find What field disappears.

15. In the Find what field, type Contoso.

16. In the Replace with field, type Northwind Traders.

17. Click Replace All.

A message box appears, indicating that Excel made three replacements.

18. Click OK to close the message box.

 19. Click Close.

The Find And Replace dialog box closes.

CLEAN UP Save the AverageDeliveries workbook, and then close it.

Correcting and Expanding Upon Worksheet Data
After you enter your data, you should take the time to check and correct it. You do need 
to verify visually that each piece of numeric data is correct, but you can make sure that 
your worksheet’s text is spelled correctly by using the Excel spelling checker. When the 
spelling checker encounters a word it doesn’t recognize, it highlights the word and offers 
suggestions representing its best guess of the correct word. You can then edit the word 
directly, pick the proper word from the list of suggestions, or have the spelling checker 
ignore the misspelling. You can also use the spelling checker to add new words to a cus-
tom dictionary so that Excel will recognize them later, saving you time by not requiring 
you to identify the words as correct every time they occur in your worksheets. 
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Tip After you make a change in a workbook, you can usually remove the change as long as 
you haven’t closed the workbook. To undo a change, click the Undo button on the Quick 
Access Toolbar. If you decide you want to keep a change, you can use the Redo command to 
restore it.

If you’re not sure of your word choice, or if you use a word that is almost but not 
quite right for your intended meaning, you can check for alternative words by using 
the Thesaurus. Several other research tools are also available, such as the Bing search 
engine and the Microsoft Encarta dictionary, to which you can refer as you create 
your workbooks. To display those tools, on the Review tab, in the Proofing group, 
click Research to display the Research task pane.
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Finally, if you want to translate a word from one language to another, you can do so by 
selecting the cell that contains the value you want to translate, displaying the Review tab, 
and then, in the Language group, clicking Translate. The Research task pane opens (or 
changes if it’s already open) and displays controls you can use to select the original and 
destination languages.

Important Excel translates a sentence by using word substitutions, which means that the 
translation routine doesn’t always pick the best word for a given context. The translated 
sentence might not capture your exact meaning.
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In this exercise, you’ll check a worksheet’s spelling, add two new terms to a dictionary, 
search for an alternative word by using the Thesaurus, and translate a word from English 
into French.

SET UP You need the ServiceLevels_start workbook located in your Chapter02 practice 
file folder to complete this exercise. Open the ServiceLevels_start workbook, and save 
it as ServiceLevels. Then follow the steps.

1. On the Review tab, in the Proofing group, click Spelling.

The Spelling dialog box opens with the first misspelled word in the worksheet 
displayed in the Not In Dictionary field.

2. Verify that the word shipped is highlighted in the Suggestions pane, and then 
click Change.

Excel corrects the word and displays the next questioned word: withn.

3. Click Change.

Excel corrects the word and displays the next questioned word: TwoDay.

4. Click Add to Dictionary.

Excel adds the word to the dictionary and displays the next questioned word: 
ThreeDay.

5. Click Add to Dictionary.

Excel adds the word to the dictionary.

6. If necessary, click Close to close the Spelling dialog box.

The Spelling dialog box closes, and a message box appears, indicating that the 
spelling check is complete for the worksheet.
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7. Click OK to close the message box.

8. Click cell B6.

9. On the Review tab, in the Proofing group, click Thesaurus.

The Research task pane opens and displays a list of synonyms for the word 
Overnight.

10. On the Review tab, in the Language group, click Translate.

The Research task pane displays the translation tools.

11. If necessary, in the From list, click English (U.S.).

12. In the To list, click French (France).

The Research task pane displays French words that mean overnight.
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CLEAN UP Save the ServiceLevels workbook, and then close it.

Defining Excel Tables
With Exel, you’ve always been able to manage lists of data effectively, enabling you to 
sort your worksheet data based on the values in one or more columns, limit the data 
displayed by using criteria (for example, show only those routes with fewer than 100 
stops), and create formulas that summarize the values in visible (that is, unfiltered) cells. 
In Excel 2007, the Excel product team extended your ability to manage your data by 
introducing Excel tables. Excel 2010 offers you the same capability.
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To create an Excel table, type a series of column headers in adjacent cells, and then type 
a row of data below the headers. Click any header or data cell into which you just typed, 
and then, on the Home tab, in the Styles group, click Format As Table. Then, from the 
gallery that opens, click the style you want to apply to the table. When the Format As 
Table dialog box opens, verify that the cells in the Where Is The Data For Your Table? 
field reflect your current selection and that the My Table Has Headers check box is 
selected, and then click OK.

Excel can also create an Excel table from an existing cell range as long as the range has 
no blank rows or columns within the data and there is no extraneous data in cells imme-
diately below or next to the list. To create the Excel table, click any cell in the range and 
then, on the Home tab, in the Styles group, click the Format As Table button and select 
a table style. If your existing data has formatting applied to it, that formatting remains 
applied to those cells when you create the Excel table. If you want Excel to replace the 
existing formatting with the Excel table’s formatting, right-click the table style you want 
to apply and then click Apply And Clear Formatting.

When you want to add data to an Excel table, click the rightmost cell in the bottom row 
of the Excel table and press the Tab key to create a new row. You can also select a cell in 
the row immediately below the last row in the table or a cell in the column immediately 
to the right of the table and type a value into the cell. After you enter the value and move 
out of the cell, the AutoCorrect Options action button appears. If you didn’t mean to 
include the data in the Excel table, you can click Undo Table AutoExpansion to exclude 
the cells from the Excel table. If you never want Excel to include adjacent data in an Excel 
table again, click Stop Automatically Expanding Tables.

Tip To stop Table AutoExpansion before it starts, click the File tab, and then click Options. In 
the Excel Options dialog box, click Proofing, and then click the AutoCorrect Options button to 
display the AutoCorrect dialog box. Click the AutoFormat As You Type tab, clear the Include 
New Rows And Columns In Table check box, and then click OK twice.
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You can add rows and columns to an Excel table, or remove them from an Excel table 
without deleting the cells’ contents, by dragging the resize handle at the Excel table’s 
lower-right corner. If your Excel table’s headers contain a recognizable series of values 
(such as Region1, Region2, and Region3), and you drag the resize handle to create a fourth 
column, Excel creates the column with the label Region4—the next value in the series. 

Excel tables often contain data you can summarize by calculating a sum or average, or 
by finding the maximum or minimum value in a column. To summarize one or more 
columns of data, you can add a Total row to your Excel table. 

When you add the Total row, Excel creates a formula that summarizes the values in the 
rightmost Excel table column. To change that summary operation, or to add a summary 
operation to any other cell in the Total row, click the cell, click the arrow that appears, 
and then click the summary operation you want to apply. Clicking the More Functions 
menu item displays the Insert Function dialog box, from which you can select any of the 
functions available in Excel.

Much as it does when you create a new worksheet, Excel gives your Excel tables 
generic names such as Table1 and Table2. You can change an Excel table’s name to 
something easier to recognize by clicking any cell in the table, clicking the Design 
contextual tab, and then, in the Properties group, editing the value in the Table Name 
box. Changing an Excel table name might not seem important, but it helps make for-
mulas that summarize Excel table data much easier to understand. You should make  
a habit of renaming your Excel tables so you can recognize the data they contain.

See Also For more information about using the Insert Function dialog box and about 
referring to tables in formulas, see “Creating Formulas to Calculate Values” in Chapter 3, 
“Performing Calculations on Data.”
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If for any reason you want to convert your Excel table back to a normal range of cells, 
click any cell in the Excel table and then, on the Design contextual tab, in the Tools 
group, click Convert To Range. When Excel displays a message box asking if you’re sure 
you want to convert the table to a range, click OK.

In this exercise, you’ll create an Excel table from existing data, add data to an Excel 
table, add a Total row, change the Total row’s summary operation, and rename the 
Excel table.

SET UP You need the DriverSortTimes_start workbook located in your Chapter02 
practice file folder to complete this exercise. Open the DriverSortTimes_start 
workbook, and save it as DriverSortTimes. Then follow the steps.

1. Select cell B2.

2. On the Home tab, in the Styles group, click Format as Table, and then select a 
table style.

The Format As Table dialog box opens.

3. Verify that the range =$B$2:$C$17 is displayed in the Where is the data for your 
table? field and that the My table has headers check box is selected, and then 
click OK.

Excel creates an Excel table from your data and displays the Design contextual tab.

4. In cell B18, type D116, press Tab, type 100 in cell C18, and then press Enter.

Excel includes the data in your Excel table.

5. Select a cell in the table. Then on the Design contextual tab, in the Table Style 
Options group, select the Total Row check box.

A Total row appears at the bottom of your Excel table.

6. Select cell C19, click the arrow that appears at the right edge of the cell, and then 
click Average.

Excel changes the summary operation to Average.
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7. On the Design contextual tab, in the Properties group, type the value SortTimes 
in the Table Name field, and then press Enter.

Excel renames your Excel table.

8. On the Quick Access Toolbar, click the Save button to save your work.

CLEAN UP Close the DriverSortTimes workbook. If you are not continuing directly to 
the next chapter, exit Excel.
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Key Points
● You can enter a series of data quickly by typing one or more values in adjacent 

cells, selecting the cells, and then dragging the fill handle. To change how dragging 
the fill handle extends a data series, hold down the Ctrl key.

● Dragging a fill handle displays the Auto Fill Options button, which you can use to 
specify whether to copy the selected cells’ values, extend a recognized series, or 
apply the selected cells’ formatting to the new cells.

● With Excel, you can enter data by using a list, AutoComplete, or Ctrl+Enter. You 
should experiment with these techniques and use the one that best fits your 
circumstances.

● When you copy (or cut) and paste cells, columns, or rows, you can use the new 
Paste Live Preview capability to preview how your data will appear before you 
commit to the paste operation.

● After you paste cells, rows, or columns into your worksheet, Excel displays the 
Paste Options action button. You can use its controls to change which aspects  
of the cut or copied elements Excel applies to the pasted elements.

● By using the options in the Paste Special dialog box, you can paste only specific 
aspects of cut or copied data, perform mathematical operations, transpose data, 
or delete blank cells when pasting.

● You can find and replace data within a worksheet by searching for specific values 
or by searching for cells that have a particular format applied.

● Excel provides a variety of powerful proofing and research tools, enabling you to 
check your workbook’s spelling, find alternative words by using the Thesaurus, and 
translate words between languages.

● With Excel tables, you can organize and summarize your data effectively.
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3 Performing 
Calculations  
on Data

In this chapter, you will learn how to
✔ Name groups of data.
✔ Create formulas to calculate values.
✔ Summarize data that meets specific conditions.
✔ Find and correct errors in calculations.

Microsoft Excel 2010 workbooks give you a handy place to store and organize your 
data, but you can also do a lot more with your data in Excel. One important task you 
can perform is to calculate totals for the values in a series of related cells. You can also 
use Excel to discover other information about the data you select, such as the maximum 
or minimum value in a group of cells. By finding the maximum or minimum value in a 
group, you can identify your best salesperson, product categories you might need to 
pay more attention to, or suppliers that consistently give you the best deal. Regardless 
of your bookkeeping needs, Excel gives you the ability to find the information you want. 
And if you make an error, you can find the cause and correct it quickly.

Many times, you can’t access the information you want without referencing more than 
one cell, and it’s also often true that you’ll use the data in the same group of cells for 
more than one calculation. Excel makes it easy to reference a number of cells at once, 
enabling you to define your calculations quickly.

In this chapter, you’ll learn how to streamline references to groups of data on your 
worksheets and how to create and correct formulas that summarize an organization’s 
business operations.
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Practice Files Before you can complete the exercises in this chapter, you need to copy 
the book’s practice files to your computer. The practice files you’ll use to complete the 
exercises in this chapter are in the Chapter03 practice file folder. A complete list of 
practice files is provided in “Using the Practice Files” at the beginning of this book.

Naming Groups of Data
When you work with large amounts of data, it’s often useful to identify groups of cells 
that contain related data. For example, you can create a worksheet in which cells C4:I4 
hold the number of packages Consolidated Messenger’s Northeast processing facility 
handled from 5:00 P.M. to 12:00 A.M. on the previous day.

Instead of specifying the cells individually every time you want to use the data they contain, 
you can define those cells as a range (also called a named range). For example, you can 
group the items from the cells described in the preceding paragraph into a range named 
NortheastPreviousDay. Whenever you want to use the contents of that range in a calcula-
tion, you can simply use the name of the range instead of specifying each cell individually.

Tip Yes, you could just name the range Northeast, but if you use the range’s values in a formula 
in another worksheet, the more descriptive range name tells you and your colleagues exactly 
what data is used in the calculation.

To create a named range, select the cells you want to include in your range, click the 
Formulas tab, and then, in the Defined Names group, click Define Name to display the New 
Name dialog box. In the New Name dialog box, type a name in the Name field, verify that 
the cells you selected appear in the Refers To field, and then click OK. You can also add a 
comment about the range in the Comment field and select whether you want to make the 
name available for formulas in the entire workbook or just on an individual worksheet.
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If the cells you want to define as a named range have labels in a row or column that’s 
part of the cell group, you can use those labels as the names of the named ranges. For 
example, if your data appears in worksheet cells B4:I12 and the values in column B are 
the row labels, you can make each row its own named range. To create a series of named 
ranges from a group of cells, select all of the data cells, including the labels, display the 
Formulas tab and then, in the Defined Names group, click Create From Selection to dis-
play the Create Names From Selection dialog box. In the Create Names From Selection 
dialog box, select the check box that represents the labels’ position in the selected 
range, and then click OK. 

A final way to create a named range is to select the cells you want in the range, click in 
the Name box next to the formula box, and then type the name for the range. You can 
display the ranges available in a workbook by clicking the Name arrow.

Name box
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To manage the named ranges in a workbook, display the Formulas tab, and then, in the 
Defined Names group, click Name Manager to display the Name Manager dialog box.

When you click a named range, Excel displays the cells it encompasses in the Refers To 
field. Clicking the Edit button displays the Edit Name dialog box, which is a version of the 
New Name dialog box, enabling you to change a named range’s definition; for example, 
by adding a column. You can also use the controls in the Name Manager dialog box to 
delete a named range (the range, not the data) by clicking it, clicking the Delete button, 
and then clicking OK in the confirmation dialog box that opens.

Tip If your workbook contains a lot of named ranges, you can click the Filter button in the 
Name Manager dialog box and select a criterion to limit the names displayed in the Name 
Manager dialog box.

In this exercise, you’ll create named ranges to streamline references to groups of cells.

SET UP You need the VehicleMiles_start workbook located in your Chapter03 practice 
file folder to complete this exercise. Start Excel, open the VehicleMiles_start workbook, 
and save it as VehicleMiles. Then follow the steps. 

1. Select cells C4:G4.

You are intentionally leaving cell H4 out of this selection. You will edit the named 
range later in this exercise.
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2. In the Name box at the left end of the formula bar, type V101LastWeek, and then 
press Enter.

Excel creates a named range named V101LastWeek.

3. On the Formulas tab, in the Defined Names group, click Name Manager.

The Name Manager dialog box opens.

4. Click the V101LastWeek name.

The cell range to which the V101LastWeek name refers appears in the Refers To 
box at the bottom of the Name Manager dialog box.

5. Edit the cell range in the Refers to box to =MilesLastWeek!$C$4:$H$4 (change 
the G to an H), and then click the check mark button to the left of the box to final-
ize the update.

Excel changes the named range’s definition.

6. Click Close.

The Name Manager dialog box closes.

7. Select the cell range C5:H5.
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8. On the Formulas tab, in the Defined Names group, click Define Name.

The New Name dialog box opens.

9. In the Name field, type V102LastWeek.

10. Verify that the definition in the Refers to field is =MilesLastWeek!$C$5:$H$5.

11. Click OK.

Excel creates the name and closes the New Name dialog box.

CLEAN UP Save the VehicleMiles workbook, and then close it.

Creating Formulas to Calculate Values
After you add your data to a worksheet and define ranges to simplify data references, 
you can create a formula, which is an expression that performs calculations on your data. 
For example, you can calculate the total cost of a customer’s shipments, figure the  
average number of packages for all Wednesdays in the month of January, or find  
the highest and lowest daily package volumes for a week, month, or year.

To write an Excel formula, you begin the cell’s contents with an equal (=) sign; when Excel 
sees it, it knows that the expression following it should be interpreted as a calculation, 
not text. After the equal sign, type the formula. For example, you can find the sum of 
the numbers in cells C2 and C3 by using the formula =C2+C3. After you have entered a 
formula into a cell, you can revise it by clicking the cell and then editing the formula in 
the formula box. For example, you can change the preceding formula to =C3-C2, which 
calculates the difference between the contents of cells C2 and C3.

Troubleshooting If Excel treats your formula as text, make sure that you haven’t accidentally 
put a space before the equal sign. Remember, the equal sign must be the first character!

Typing the cell references for 15 or 20 cells in a calculation would be tedious, but 
Excel makes it easy to enter complex calculations. To create a new calculation, click 
the Formulas tab, and then in the Function Library group, click Insert Function. The 
Insert Function dialog box opens, with a list of functions, or predefined formulas, 
from which you can choose.
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The following table describes some of the most useful functions in the list.

Function Description
SUM Finds the sum of the numbers in the specified cells
AVERAGE Finds the average of the numbers in the specified cells
COUNT Finds the number of entries in the specified cells

MAX Finds the largest value in the specified cells

MIN Finds the smallest value in the specified cells

Two other functions you might use are the NOW and PMT functions. The NOW func-
tion displays the time Excel updated the workbook’s formulas, so the value will change 
every time the workbook recalculates. The proper form for this function is =NOW(). 
To update the value to the current date and time, just press the F9 key or display the 
Formulas tab and then, in the Calculation group, click the Calculate Now button. You 
could, for example, use the NOW function to calculate the elapsed time from when 
you started a process to the present time.
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The PMT function is a bit more complex. It calculates payments due on a loan, assuming a 
constant interest rate and constant payments. To perform its calculations, the PMT function 
requires an interest rate, the number of payments, and the starting balance. The elements 
to be entered into the function are called arguments and must be entered in a certain order. 
That order is written as PMT(rate, nper, pv, fv, type). The following table summarizes the 
arguments in the PMT function.

Argument Description
rate The interest rate, to be divided by 12 for a loan with monthly payments, 

by 4 for quarterly payments, and so on
nper The total number of payments for the loan
pv The amount loaned (pv is short for present value, or principal)

fv The amount to be left over at the end of the payment cycle (usually left 
blank, which indicates 0)

type 0 or 1, indicating whether payments are made at the beginning or at the 
end of the month (usually left blank, which indicates 0, or the end of  
the month)

If Consolidated Messenger wanted to borrow $2,000,000 at a 6 percent interest rate 
and pay the loan back over 24 months, you could use the PMT function to figure out 
the monthly payments. In this case, the function would be written =PMT(6%/12, 24, 
2000000), which calculates a monthly payment of $88,641.22.

You can also use the names of any ranges you defined to supply values for a formula. For 
example, if the named range NortheastLastDay refers to cells C4:I4, you can calculate the 
average of cells C4:I4 with the formula =AVERAGE(NortheastLastDay). With Excel, you 
can add functions, named ranges, and table references to your formulas more efficiently 
by using the Formula AutoComplete capability. Just as AutoComplete offers to fill in a 
cell’s text value when Excel recognizes that the value you’re typing matches a previous 
entry, Formula AutoComplete offers to help you fill in a function, named range, or table 
reference while you create a formula.
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As an example, consider a worksheet that contains a two-column Excel table named 
Exceptions. The first column is labeled Route; the second is labeled Count. 

You refer to a table by typing the table name, followed by the column or row name in 
square brackets. For example, the table reference Exceptions[Count] would refer to the 
Count column in the Exceptions table.

To create a formula that finds the total number of exceptions by using the SUM function, 
you begin by typing =SU. When you type the letter S, Formula AutoComplete lists 
functions that begin with the letter S; when you type the letter U, Excel narrows the 
list down to the functions that start with the letters SU.
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To add the SUM function (followed by an opening parenthesis) to the formula, click SUM 
and then press Tab. To begin adding the table reference, type the letter E. Excel displays a list 
of available functions, tables, and named ranges that start with the letter E. Click Exceptions, 
and press Tab to add the table reference to the formula. Then, because you want to summa-
rize the values in the table’s Count column, type a left square bracket and then, in the list of 
available table items, click Count. To finish creating the formula, type a right square bracket 
followed by a right parenthesis to create the formula =SUM(Exceptions[Count]).

If you want to include a series of contiguous cells in a formula, but you haven’t defined 
the cells as a named range, you can click the first cell in the range and drag to the last 
cell. If the cells aren’t contiguous, hold down the Ctrl key and select all of the cells to be 
included. In both cases, when you release the mouse button, the references of the cells 
you selected appear in the formula.
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Troubleshooting The appearance of buttons and groups on the ribbon changes depending 
on the width of the program window. For information about changing the appearance of 
the ribbon to match our screen images, see “Modifying the Display of the Ribbon” at the 
beginning of this book.

After you create a formula, you can copy it and paste it into another cell. When you do, 
Excel tries to change the formula so that it works in the new cells. For instance, suppose  
you have a worksheet where cell D8 contains the formula =SUM(C2:C6). Clicking 
cell D8, copying the cell’s contents, and then pasting the result into cell D16 writes 
=SUM(C10:C14) into cell D16. Excel has reinterpreted the formula so that it fits the 
surrounding cells! Excel knows it can reinterpret the cells used in the formula because 
the formula uses a relative reference, or a reference that can change if the formula is 
copied to another cell. Relative references are written with just the cell row and column 
(for example, C14). 
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Relative references are useful when you summarize rows of data and want to use the same 
formula for each row. As an example, suppose you have a worksheet with two columns of 
data, labeled SalePrice and Rate, and you want to calculate your sales representative’s com-
mission by multiplying the two values in a row. To calculate the commission for the first 
sale, you would type the formula =B4*C4 in cell D4.

Selecting cell D4 and dragging the fill handle until it covers cells D4:D9 copies the for-
mula from cell D4 into each of the other cells. Because you created the formula using 
relative references, Excel updates each cell’s formula to reflect its position relative to the 
starting cell (in this case, cell D4.) The formula in cell D9, for example, is =B9*C9.
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You can use a similar technique when you add a formula to an Excel table column. If the 
sale price and rate data were in an Excel table and you created the formula =B4*C4 in 
cell D4, Excel would apply the formula to every other cell in the column. Because you 
used relative references in the formula, the formulas would change to reflect each cell’s 
distance from the original cell.
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If you want a cell reference to remain constant when the formula using it is copied to 
another cell, you can use an absolute reference. To write a cell reference as an absolute 
reference, type $ before the row letter and the column number. For example, if you want 
the formula in cell D16 to show the sum of values in cells C10 through C14 regardless of 
the cell into which it is pasted, you can write the formula as =SUM($C$10:$C$14).

Tip Another way to ensure your cell references don’t change when you copy the formula 
to another cell is to click the cell that contains the formula, copy the formula’s text in the 
formula bar, press the Esc key to exit cut-and-copy mode, click the cell where you want to 
paste the formula, and press Ctrl+V. Excel doesn’t change the cell references when you copy 
your formula to another cell in this manner.

One quick way to change a cell reference from relative to absolute is to select the cell 
reference in the formula box and then press F4. Pressing F4 cycles a cell reference 
through the four possible types of references:

● Relative columns and rows (for example, C4)

● Absolute columns and rows (for example, $C$4)

● Relative columns and absolute rows (for example, C$4)

● Absolute columns and relative rows (for example, $C4)
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In this exercise, you’ll create a formula manually, revise it to include additional cells, 
create a formula that contains an Excel table reference, create a formula with relative 
references, and change the formula so it contains absolute references.

SET UP You need the ITExpenses_start workbook located in your Chapter03 practice 
file folder to complete this exercise. Open the ITExpenses_start workbook, and save it 
as ITExpenses. Then follow the steps.

1. If necessary, display the Summary worksheet. Then, in cell F9, type =C4, and 
press Enter.

The value $385,671.00 appears in cell F9.

2. Select cell F9 and type =SU.

Excel erases the existing formula, and Formula AutoComplete displays a list of 
possible functions to use in the formula.

3. In the Formula AutoComplete list, click SUM, and then press Tab.

Excel changes the contents of the formula bar to =SUM(.

4. Select the cell range C3:C8, type a right parenthesis (  )  ) to make the formula 
bar’s contents =SUM(C3:C8), and then press Enter.

The value $2,562,966.00 appears in cell F9.

5. In cell F10, type =SUM(C4:C5), and then press Enter.

6. Select cell F10, and then in the formula box, select the cell reference C4, and 
press F4.

Excel changes the cell reference to $C$4.

7. In the formula box, select the cell reference C5, press F4, and then press Enter.

Excel changes the cell reference to $C$5.

8. On the tab bar, click the JuneLabor sheet tab.

The JuneLabor worksheet opens.

9. In cell F13, type =SUM(J.

Excel displays JuneSummary, the name of the table in the JuneLabor worksheet.

10. Press Tab.

Excel extends the formula to read =SUM(JuneSummary.
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11. Type [, and then in the Formula AutoComplete list, click Labor Expense, and 
press Tab.

Excel extends the formula to read =SUM(JuneSummary[Labor Expense.

12. Type ]) to complete the formula, and then press Enter.

The value $637,051.00 appears in cell F13.

CLEAN UP Save the ITExpenses workbook, and then close it.

Summarizing Data That Meets Specific Conditions
Another use for formulas is to display messages when certain conditions are met. For 
instance, Consolidated Messenger’s VP of Marketing, Craig Dewar, might have agreed 
to examine the rates charged to corporate customers who were billed for more than 
$100,000 during a calendar year. This kind of formula is called a conditional formula; 
one way to create a conditional formula in Excel is to use the IF function. To create a 
conditional formula, you click the cell to hold the formula and open the Insert Function 
dialog box. From within the dialog box, click IF in the list of available functions, and 
then click OK. When you do, the Function Arguments dialog box opens.
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When you work with an IF function, the Function Arguments dialog box has three boxes: 
Logical_test, Value_if_true, and Value_if_false. The Logical_test box holds the condition 
you want to check. If the customer’s year-to-date shipping bill appears in cell G8, the 
expression would be G8>100000.

Now you need to have Excel display messages that indicate whether Craig Dewar should 
evaluate the account for a possible rate adjustment. To have Excel print a message from 
an IF function, you enclose the message in quotes in the Value_if_true or Value_if_false 
box. In this case, you would type “High-volume shipper—evaluate for rate decrease.” in 
the Value_if_true box and “Does not qualify at this time.” in the Value_if_false box.

Excel also includes several other conditional functions you can use to summarize your data, 
shown in the following table.

Function Description
AVERAGEIF Finds the average of values within a cell range that meet a given criterion
AVERAGEIFS Finds the average of values within a cell range that meet multiple criteria
COUNT Counts the number of cells in a range that contain a numerical value
COUNTA Counts the number of cells in a range that are not empty
COUNTBLANK Counts the number of cells in a range that are empty
COUNTIF Counts the number of cells in a range that meet a given criterion
COUNTIFS Counts the number of cells in a range that meet multiple criteria
IFERROR Displays one value if a formula results in an error and another if it doesn’t

SUMIF Finds the sum of values in a range that meet a single criterion

SUMIFS Finds the sum of values in a range that meet multiple criteria
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You can use the IFERROR function to display a custom error message, instead of relying 
on the default Excel error messages to explain what happened. For example, you could 
use an IFERROR formula when looking up the CustomerID value from cell G8 in the 
Customers table by using the VLOOKUP function. One way to create such a formula is 
=IFERROR(VLOOKUP(G8,Customers,2,false),”Customer not found”). If the function finds 
a match for the CustomerID in cell G8, it displays the customer’s name; if it doesn’t 
find a match, it displays the text Customer not found.

See Also For more information about the VLOOKUP function, see “Looking Up Information in 
a Worksheet” in Chapter 6, “Reordering and Summarizing Data.”

Just as the COUNTIF function counts the number of cells that meet a criterion and the 
SUMIF function finds the total of values in cells that meet a criterion, the AVERAGEIF 
function finds the average of values in cells that meet a criterion. To create a formula 
using the AVERAGEIF function, you define the range to be examined for the criterion, 
the criterion, and, if required, the range from which to draw the values. As an example, 
consider a worksheet that lists each customer’s ID number, name, state, and total 
monthly shipping bill.

If you want to find the average order of customers from the state of Washington  
(abbreviated in the worksheet as WA), you can create the formula =AVERAGEIF(D3:D6, 
”WA”, E3:E6). 
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The AVERAGEIFS, SUMIFS, and COUNTIFS functions extend the capabilities of the 
AVERAGEIF, SUMIF, and COUNTIF functions to allow for multiple criteria. If you want to 
find the sum of all orders of at least $100,000 placed by companies in Washington, you 
can create the formula =SUMIFS(E3:E6, D3:D6, “=WA”, E3:E6, “>=100000”).

The AVERAGEIFS and SUMIFS functions start with a data range that contains values 
that the formula summarizes; you then list the data ranges and the criteria to apply  
to that range. In generic terms, the syntax runs =AVERAGEIFS(data_range, criteria_
range1, criteria1[,criteria_range2, criteria2…]). The part of the syntax in square brackets 
(which aren’t used when you create the formula) is optional, so an AVERAGEIFS 
or SUMIFS formula that contains a single criterion will work. The COUNTIFS func-
tion, which doesn’t perform any calculations, doesn’t need a data range—you just 
provide the criteria ranges and criteria. For example, you could find the number of 
customers from Washington who were billed at least $100,000 by using the formula 
=COUNTIFS(D3:D6, “=WA”, E3:E6, “>=100000”).

In this exercise, you’ll create a conditional formula that displays a message if a condition 
is true, find the average of worksheet values that meet one criterion, and find the sum of 
worksheet values that meet two criteria.

SET UP You need the PackagingCosts_start workbook located in your Chapter03 
practice file folder to complete this exercise. Open the PackagingCosts_start 
workbook, and save it as PackagingCosts. Then follow the steps.

1. In cell G3, type the formula =IF(F3>=35000, ”Request discount”, ”No discount 
available”), and press Enter.

Excel accepts the formula, which displays Request discount if the value in cell F3 is 
at least 35,000 and displays No discount available if not. The value Request discount 
appears in cell G3.

2. Click cell G3, and drag the fill handle down until it covers cell G14.

Excel copies the formula in cell G3 to cells G4:G14, adjusting the formula to reflect 
the cells’ addresses. The results of the copied formulas appear in cells G4:G14.
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3. In cell I3, type the formula =AVERAGEIF(C3:C14, “=Box”, F3:F14), and press Enter.

The value $46,102.50, which represents the average cost per category of boxes, 
appears in cell I3.

4. In cell I6, type =SUMIFS(F3:F14, C3:C14, “=Envelope”, E3:E14, 
“=International”).

The value $45,753.00, which represents the total cost of all envelopes used for in-
ternational shipments, appears in cell I6.

CLEAN UP Save the PackagingCosts workbook, and then close it.

Finding and Correcting Errors in Calculations
Including calculations in a worksheet gives you valuable answers to questions about your 
data. As is always true, however, it is possible for errors to creep into your formulas. With 
Excel, you can find the source of errors in your formulas by identifying the cells used in a 
given calculation and describing any errors that have occurred. The process of examining 
a worksheet for errors is referred to as auditing.

Excel identifies errors in several ways. The first way is to display an error code in the cell 
holding the formula generating the error. 
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When a cell with an erroneous formula is the active cell, an Error button is displayed 
next to it. Pointing to the Error button causes it to display an arrow on the button’s right 
edge. Clicking the arrow displays a menu with options that provide information about 
the error and offer to help you fix it. 

The following table lists the most common error codes and what they mean.

Error code Description
##### The column isn’t wide enough to display the value.
#VALUE! The formula has the wrong type of argument (such as text in a cell where 

a numerical value is required).
#NAME? The formula contains text that Excel doesn’t recognize (such as an unknown 

named range).
#REF! The formula refers to a cell that doesn’t exist (which can happen whenever 

cells are deleted).
#DIV/0! The formula attempts to divide by zero.

Another technique you can use to find the source of formula errors is to ensure that 
the appropriate cells are providing values for the formula. For example, you might 
want to calculate the total number of deliveries for a service level, but you could 
accidentally create a formula referring to the service levels’ names instead of their 
package quantities. You can identify the source of an error by having Excel trace a 
cell’s precedents, which are the cells with values used in the active cell’s formula. To 
do so, click the Formulas tab, and then in the Formula Auditing group, click Trace 
Precedents. When you do, Excel identifies those cells by drawing a blue tracer arrow 
from the precedents to the active cell.
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You can also audit your worksheet by identifying cells with formulas that use a value from 
a given cell. For example, you might use one region’s daily package total in a formula 
that calculates the average number of packages delivered for all regions on a given day. 
Cells that use another cell’s value in their calculations are known as dependents, meaning 
that they depend on the value in the other cell to derive their own value. As with tracing 
precedents, you can click the Formulas tab, and then in the Formula Auditing group, click 
Trace Dependents to have Excel draw blue arrows from the active cell to those cells that 
have calculations based on that value.

If the cells identified by the tracer arrows aren’t the correct cells, you can hide the arrows 
and correct the formula. To hide the tracer arrows on a worksheet, display the Formulas 
tab, and then in the Formula Auditing group, click Remove Arrows.

If you prefer to have the elements of a formula error presented as text in a dialog box, 
you can use the Error Checking dialog box to view the error and the formula in the cell in 
which the error occurs. To display the Error Checking dialog box, display the Formulas tab, 
and then in the Formula Auditing group, click the Error Checking button. You can use the 
controls in the Error Checking dialog box to move through the formula one step at a time, 
to choose to ignore the error, or to move to the next or the previous error. If you click the 
Options button in the dialog box, you can also use the controls in the Excel Options dialog 
box to change how Excel determines what is an error and what isn’t.
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Tip You can have the Error Checking tool ignore formulas that don’t use every cell in a region 
(such as a row or column). If you clear the Formulas That Omit Cells In A Region check box, 
you can create formulas that don’t add up every value in a row or column (or rectangle) 
without Excel marking them as an error.

For times when you just want to display the results of each step of a formula and don’t need 
the full power of the Error Checking tool, you can use the Evaluate Formula dialog box to 
move through each element of the formula. To display the Evaluate Formula dialog box, 
you display the Formulas tab and then, in the Formula Auditing group, click the Evaluate 
Formula button. The Evaluate Formula dialog box is much more useful for examining for-
mulas that don’t produce an error but aren’t generating the result you expect.

Finally, you can monitor the value in a cell regardless of where in your workbook you are 
by opening a Watch Window that displays the value in the cell. For example, if one of 
your formulas uses values from cells in other worksheets or even other workbooks, you 
can set a watch on the cell that contains the formula and then change the values in the 
other cells. To set a watch, click the cell you want to monitor, and then on the Formulas 
tab, in the Formula Auditing group, click Watch Window. Click Add Watch to have Excel 
monitor the selected cell. 

As soon as you type in the new value, the Watch Window displays the new result of the 
formula. When you’re done watching the formula, select the watch, click Delete Watch, 
and close the Watch Window.
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In this exercise, you’ll use the formula-auditing capabilities in Excel to identify and cor-
rect errors in a formula.

SET UP You need the ConveyerBid_start workbook located in your Chapter03 practice 
file folder to complete this exercise. Open the ConveyerBid_start workbook, and save 
it as ConveyerBid. Then follow the steps.

1. Click cell D20.

2. On the Formulas tab, in the Formula Auditing group, click Watch Window.

The Watch Window opens.

3. Click Add Watch, and then in the Add Watch dialog box, click Add.

Cell D20 appears in the Watch Window.

4. Click cell D8.

=SUM(C3:C7) appears in the formula bar.

5. On the Formulas tab, in the Formula Auditing group, click the Trace Precedents 
button.

A blue arrow begins at the cell range C3:C7 and points to cell D8, indicating that 
the cells in the range C3:C7 provide the values for the formula in cell D8.
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6. On the Formulas tab, in the Formula Auditing group, click the Remove Arrows 
button.

The arrow disappears.

7. Click cell A1.

8. On the Formulas tab, in the Formula Auditing group, click the Error Checking 
button.

The Error Checking dialog box opens, displaying the error found in cell D1.
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9. Click Next.

Excel displays a message box indicating that there are no more errors in the 
worksheet.

10. Click OK.

The message box and the Error Checking dialog box close.

11. On the Formulas tab, in the Formula Auditing group, click the Error Checking 
arrow, and then in the list, click Trace Error.

Blue arrows appear, pointing to cell D21 from cells C12 and D19. These arrows 
indicate that using the values (or lack of values, in this case) in the indicated cells 
generates the error in cell D21.

12. On the Formulas tab, in the Formula Auditing group, click Remove Arrows.

The arrows disappear.

13. In the formula box, delete the existing formula, type =C12/D20, and press Enter.

The value 14% appears in cell D21.

14. Click cell D21.

15. On the Formulas tab, in the Formula Auditing group, click the Evaluate Formula 
button.

The Evaluate Formula dialog box opens, with the formula from cell D21 displayed.

16. Click Evaluate three times to step through the formula’s elements, and 
then click Close.

The Evaluate Formula dialog box closes.
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17. In the Watch Window, click the watch in the list.

18. Click Delete Watch.

The watch disappears.

19. On the Formulas tab, in the Formula Auditing group, click Watch Window.

The Watch Window closes.

CLEAN UP Save the ConveyerBid workbook, and then close it. If you are not 
continuing directly to the next chapter, exit Excel.

Key Points
● You can add a group of cells to a formula by typing the formula, and then at the spot 

in the formula in which you want to name the cells, selecting the cells by using the 
mouse.

● By creating named ranges, you can refer to entire blocks of cells with a single term, 
saving you lots of time and effort. You can use a similar technique with table data, 
referring to an entire table or one or more table columns.

● When you write a formula, be sure you use absolute referencing ($A$1) if you 
want the formula to remain the same when it’s copied from one cell to another, 
or use relative referencing (A1) if you want the formula to change to reflect its 
new position in the worksheet.

● Instead of typing a formula from scratch, you can use the Insert Function dialog 
box to help you on your way.

● You can monitor how the value in a cell changes by adding a watch to the Watch 
Window.

● To see which formulas refer to the values in the selected cell, use Trace Dependents; 
if you want to see which cells provide values for the formula in the active cell, use 
Trace Precedents.

● You can step through the calculations of a formula in the Evaluate Formula dialog 
box or go through a more rigorous error-checking procedure by using the Error 
Checking tool.
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4 Changing Workbook 
Appearance

In this chapter, you will learn how to
✔ Format cells.
✔ Define styles.
✔ Apply workbook themes and Excel table styles.
✔ Make numbers easier to read.
✔ Change the appearance of data based on its value.
✔ Add images to worksheets.

Entering data into a workbook efficiently saves you time, but you must also ensure  
that your data is easy to read. Microsoft Excel 2010 gives you a wide variety of ways  
to make your data easier to understand; for example, you can change the font, character 
size, or color used to present a cell’s contents. Changing how data appears on a work-
sheet helps set the contents of a cell apart from the contents of surrounding cells. The 
simplest example of that concept is a data label. If a column on your worksheet contains 
a list of days, you can easily set apart a label (for example, Day) by presenting it in bold 
type that’s noticeably larger than the type used to present the data to which it refers. To 
save time, you can define a number of custom formats and then apply them quickly 
to the desired cells.

You might also want to specially format a cell’s contents to reflect the value in that cell. 
For example, Lori Penor, the chief operating officer of Consolidated Messenger, might 
want to create a worksheet that displays the percentage of improperly delivered packages 
from each regional distribution center. If that percentage exceeds a threshold, she could 
have Excel display a red traffic light icon, indicating that the center’s performance is out 
of tolerance and requires attention. 
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In this chapter, you’ll learn how to change the appearance of data, apply existing formats 
to data, make numbers easier to read, change data’s appearance based on its value, and 
add images to worksheets.

Practice Files Before you can complete the exercises in this chapter, you need to copy 
the book’s practice files to your computer. The practice files you’ll use to complete the 
exercises in this chapter are in the Chapter04 practice file folder. A complete list of 
practice files is provided in “Using the Practice Files” at the beginning of this book.

Formatting Cells
Excel spreadsheets can hold and process lots of data, but when you manage numerous 
spreadsheets it can be hard to remember from a worksheet’s title exactly what data is 
kept in that worksheet. Data labels give you and your colleagues information about data 
in a worksheet, but it’s important to format the labels so that they stand out visually. To 
make your data labels or any other data stand out, you can change the format of the 
cells that hold your data.
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Most of the tools you need to change a cell’s format can be found on the Home tab. You 
can apply the formatting represented on a button by selecting the cells you want to apply 
the style to and then clicking that button. If you want to set your data labels apart by 
making them appear bold, click the Bold button. If you have already made a cell’s con-
tents bold, selecting the cell and clicking the Bold button will remove the formatting.

Tip Deleting a cell’s contents doesn’t delete the cell’s formatting. To delete a selected cell’s 
formatting, on the Home tab, in the Editing group, click the Clear button (which looks like an 
eraser), and then click Clear Formats. Clicking Clear All from the same list will remove the cell’s 
contents and formatting.

Buttons in the Home tab’s Font group that give you choices, such as Font Color, have 
an arrow at the right edge of the button. Clicking the arrow displays a list of options 
accessible for that button, such as the fonts available on your system or the colors you 
can assign to a cell.
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Another way you can make a cell stand apart from its neighbors is to add a border around 
the cell. To place a border around one or more cells, select the cells, and then choose the 
border type you want by selecting from the Border list in the Font group. Excel does 
provide more options: To display the full range of border types and styles, in the Border 
list, click More Borders. The Border page of the Format Cells dialog box contains the full 
range of tools you can use to define your cells’ borders.

You can also make a group of cells stand apart from its neighbors by changing its shading, 
which is the color that fills the cells. On a worksheet that tracks total package volume for 
the past month, Lori Penor could change the fill color of the cells holding her data labels 
to make the labels stand out even more than by changing the labels’ text formatting.

Tip You can display the most commonly used formatting controls by right-clicking a selected 
range. When you do, a Mini Toolbar containing a subset of the Home tab formatting tools 
appears above the shortcut menu.

If you want to change the attributes of every cell in a row or column, you can click the 
header of the row or column you want to modify and then select your desired format.
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One task you can’t perform by using the tools on the Home tab is to change the stan-
dard font for a workbook, which is used in the Name box and on the formula bar. The 
standard font when you install Excel is Calibri, a simple font that is easy to read on a 
computer screen and on the printed page. If you want to choose another font, click the  
File tab, and then click Options. On the General page of the Excel Options dialog box, set 
the values in the Use This Font and Font Size list boxes to pick your new display font.

Important The new standard font doesn’t take effect until you exit Excel and restart the 
program.

In this exercise, you’ll emphasize a worksheet’s title by changing the format of cell data, 
adding a border to a cell range, and then changing a cell range’s fill color. After those 
tasks are complete, you’ll change the default font for the workbook.

SET UP You need the VehicleMileSummary_start workbook located in your 
Chapter04 practice file folder to complete this exercise. Start Excel, open the 
VehicleMileSummary_start workbook, and save it as VehicleMileSummary. Then 
follow the steps. 

1. Click cell D2.

2. On the Home tab, in the Font group, click the Bold button.

Excel displays the cell’s contents in bold type.

3. In the Font group, click the Font Size arrow, and then in the list, click 18.

Excel increases the size of the text in cell D2.
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4. Click cell B5, hold down the Ctrl key, and click cell C4 to select the non-contiguous 
cells.

5. On the Home tab, in the Font group, click the Bold button.

Excel displays the cells’ contents in bold type.

6. Select the cell ranges B6:B15 and C5:H5.

7. In the Font group, click the Italic button.

Excel displays the cells’ contents in italic type.

8. Select the cell range C6:H15.

9. In the Font group, click the Border arrow, and then in the list, click Outside 
Borders.

Excel places a border around the outside edge of the selected cells.

10. Select the cell range B4:H15.

11. In the Border list, click Thick Box Border.

Excel places a thick border around the outside edge of the selected cells.

12. Select the cell ranges B4:B15 and C4:H5.

13. In the Font group, click the Fill Color arrow, and then in the Standard Colors area 
of the color palette, click the yellow button.

Excel changes the selected cells’ background color to yellow.
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Troubleshooting The appearance of buttons and groups on the ribbon changes depending 
on the width of the program window. For information about changing the appearance of 
the ribbon to match our screen images, see “Modifying the Display of the Ribbon” at the 
beginning of this book.

14. Click the File tab, and then click Options.

The Excel Options dialog box opens.

15. If necessary, click General to display the General page.

16. In the When creating new workbooks area, in the Use this font list, click Verdana.

Verdana appears in the Use This Font field.

17. Click Cancel.

The Excel Options dialog box closes without saving your change.

CLEAN UP Save the VehicleMileSummary workbook, and then close it.
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Defining Styles
As you work with Excel, you will probably develop preferred formats for data labels, 
titles, and other worksheet elements. Instead of adding a format’s characteristics one 
element at a time to the target cells, you can have Excel store the format and recall it 
as needed. You can find the predefined formats by displaying the Home tab, and then  
in the Styles group, clicking Cell Styles.

Clicking a style from the Cell Styles gallery applies the style to the selected cells, 
but Excel also displays a live preview of a format when you point to it. If none of the 
existing styles is what you want, you can create your own style by clicking New Cell 
Style at the bottom of the gallery to display the Style dialog box. In the Style dialog 
box, type the name of your new style in the Style Name field, and then click Format. 
The Format Cells dialog box opens.
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After you set the characteristics of your new style, click OK to make your style available 
in the Cell Styles gallery. If you ever want to delete a custom style, display the Cell Styles 
gallery, right-click the style, and then click Delete.

The Style dialog box is quite versatile, but it’s overkill if all you want to do is apply for-
matting changes you made to a cell to the contents of another cell. To do so, use the 
Format Painter button, found in the Home tab’s Clipboard group. Just click the cell that 
has the format you want to copy, click the Format Painter button, and select the target 
cells to have Excel apply the copied format to the target range.

Tip If you want to apply the same formatting to multiple cells by using the Format Painter 
button, double-click the Format Painter button and then click the cells to which you want to 
apply the formatting. When you’re done applying the formatting, press the Esc key.

In this exercise, you’ll create a style and apply the new style to a data label. 

SET UP You need the HourlyExceptions_start workbook located in your Chapter04 
practice file folder to complete this exercise. Open the HourlyExceptions_start 
workbook, and save it as HourlyExceptions. Then follow the steps. 

1. On the Home tab, in the Styles group, click Cell Styles, and then click New Cell Style.

The Style dialog box opens.
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2. In the Style name field, type Crosstab Column Heading.

3. Click the Format button.

The Format Cells dialog box opens.

4. Click the Alignment tab.
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5. In the Horizontal list, click Center.

Center appears in the Horizontal field.

6. Click the Font tab.

7. In the Font style list, click Italic.

The text in the Preview pane appears in italicized text.

8. Click the Number tab.

The Number page of the Format Cells dialog box is displayed.

9. In the Category list, click Time.

The available time formats appear.

10. In the Type pane, click 1:30 PM.

11. Click OK to save your changes.

The Format Cells dialog box closes, and your new style’s definition appears in the 
Style dialog box.

12. Click OK.

The Style dialog box closes.

13. Select cells C4:N4.
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14. On the Home tab, in the Styles group, click Cell Styles.

Your new style appears at the top of the gallery, in the Custom group.

15. Click the Crosstab Column Heading style.

Excel applies your new style to the selected cells.

CLEAN UP Save the HourlyExceptions workbook, and then close it.

Applying Workbook Themes and Excel Table Styles
Microsoft Office 2010 includes powerful design tools that enable you to create attractive, 
professional documents quickly. The Excel product team implemented the new design 
capabilities by defining workbook themes and Excel table styles. A theme is a way to 
specify the fonts, colors, and graphic effects that appear in a workbook. Excel comes 
with many themes installed.

To apply an existing workbook theme, display the Page Layout tab. Then, in the Themes 
group, click Themes, and click the theme you want to apply to your workbook. By default, 
Excel applies the Office theme to your workbooks. 
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When you want to format a workbook element, Excel displays colors that are available 
within the active theme. For example, selecting a worksheet cell and then clicking the Font 
Color button’s arrow displays a palette of colors you can use. The theme colors appear in 
the top segment of the color palette—the standard colors and the More Colors link, which 
displays the Colors dialog box, appear at the bottom of the palette. If you format workbook 
elements using colors from the Theme Colors area of the color palette, applying a different 
theme changes that object’s colors.
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You can change a theme’s colors, fonts, and graphic effects by displaying the Page Layout 
tab and then, in the Themes group, selecting new values from the Colors, Fonts, and 
Effects lists. To save your changes as a new theme, display the Page Layout tab, and in the 
Themes group, click Themes, and then click Save Current Theme. Use the controls in the 
Save Current Theme dialog box that opens to record your theme for later use. Later, when 
you click the Themes button, your custom theme will appear at the top of the gallery.

Tip When you save a theme, you save it as an Office Theme file. You can apply the theme to 
other Office 2010 documents as well.

Just as you can define and apply themes to entire workbooks, you can apply and 
define Excel table styles. You select an Excel table’s initial style when you create it; 
to create a new style, display the Home tab, and in the Styles group, click Format As 
Table. In the Format As Table gallery, click New Table Style to display the New Table 
Quick Style dialog box.
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Type a name for the new style, select the first table element you want to format, and 
then click Format to display the Format Cells dialog box. Define the element’s formatting, 
and then click OK. When the New Table Quick Style dialog box reopens, its Preview pane 
displays the overall table style and the Element Formatting area describes the selected 
element’s appearance. Also, in the Table Element list, Excel displays the element’s name 
in bold to indicate it has been changed. To make the new style the default for new Excel 
tables created in the current workbook, select the Set As Default Table Quick Style For 
This Document check box. When you click OK, Excel saves the new table style.

Tip To remove formatting from a table element, click the name of the table element and then 
click the Clear button.

In this exercise, you’ll create a new workbook theme, change a workbook’s theme, create 
a new table style, and apply the new style to an Excel table.

SET UP You need the HourlyTracking_start workbook located in your Chapter04 
practice file folder to complete this exercise. Open the HourlyTracking_start 
workbook, and save it as HourlyTracking. Then follow the steps. 

1. If necessary, click any cell in the Excel table.

2. On the Home tab, in the Styles group, click Format as Table, and then click the 
style at the upper-left corner of the Table Styles gallery.

Excel applies the style to the table.

3. On the Home tab, in the Styles group, click Format as Table, and then click New 
Table Style.

The New Table Quick Style dialog box opens.

 4. In the Name field, type Exception Default.

 5. In the Table Element list, click Header Row.

 6. Click Format.

The Format Cells dialog box opens.

Applying Workbook Themes and Excel Table Styles  97

www.it-ebooks.info

http://www.it-ebooks.info/


98  Chapter 4 Changing Workbook Appearance

7. Click the Fill tab.

The Fill page is displayed.

8. In the first row of color squares, just below the No Color button, click the third 
square from the left.

The new background color appears in the Sample pane of the dialog box.

9. Click OK.
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The Format Cells dialog box closes. When the New Table Quick Style dialog box 
reopens, the Header Row table element appears in bold, and the Preview pane’s 
header row is shaded.

10. In the Table Element list, click Second Row Stripe, and then click Format.

The Format Cells dialog box opens.

11. Just below the No Color button, click the third square from the left again.

The new background color appears in the Sample pane of the dialog box.

12. Click OK.

The Format Cells dialog box closes. When the New Table Quick Style dialog box 
reopens, the Second Row Stripe table element appears in bold, and every second 
row is shaded in the Preview pane.
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13. Click OK.

The New Table Quick Style dialog box closes.

14. On the Home tab, in the Styles group, click Format as Table. In the gallery, in the 
Custom area, click the new format.

Excel applies the new format.

15. On the Page Layout tab, in the Themes group, click the Fonts arrow, and then in 
the list, click Verdana.

Excel changes the theme’s font to Verdana (which is part of the Aspect font set).

 16. In the Themes group, click the Themes button, and then click Save Current 
Theme.

The Save Current Theme dialog box opens.
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17. In the File name field, type Verdana Office, and then click Save.

Excel saves your theme.

18. In the Themes group, click the Themes button, and then click Origin.

Excel applies the new theme to your workbook.

CLEAN UP Save the HourlyTracking workbook, and then close it.

Making Numbers Easier to Read
Changing the format of the cells in your worksheet can make your data much easier to read, 
both by setting data labels apart from the actual data and by adding borders to define the 
boundaries between labels and data even more clearly. Of course, using formatting options 
to change the font and appearance of a cell’s contents doesn’t help with idiosyncratic data 
types such as dates, phone numbers, or currency values.
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As an example, consider U.S. phone numbers. These numbers are 10 digits long and have 
a 3-digit area code, a 3-digit exchange, and a 4-digit line number written in the form (###) 
###-####. Although it’s certainly possible to type a phone number with the expected for-
matting in a cell, it’s much simpler to type a sequence of 10 digits and have Excel change 
the data’s appearance.

You can tell Excel to expect a phone number in a cell by opening the Format Cells 
dialog box to the Number page and displaying the formats available for the Special 
category.

Clicking Phone Number in the Type list tells Excel to format 10-digit numbers in the 
standard phone number format. You can see this in operation if you compare the con-
tents of the active cell and the contents of the formula box for a cell with the Phone 
Number formatting.
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Troubleshooting If you type a 9-digit number in a field that expects a phone number, you 
won’t see an error message; instead, you’ll see a 2-digit area code. For example, the number 
425550012 would be displayed as (42) 555-0012. An 11-digit number would be displayed with 
a 4-digit area code. If the phone number doesn’t look right, you probably left out a digit or 
included an extra one, so you should make sure your entry is correct.

Just as you can instruct Excel to expect a phone number in a cell, you can also have it 
expect a date or a currency amount. You can make those changes from the Format Cells 
dialog box by choosing either the Date category or the Currency category. The Date 
category enables you to pick the format for the date (and determine whether the date’s 
appearance changes due to the Locale setting of the operating system on the computer 
viewing the workbook). In a similar vein, selecting the Currency category displays controls 
to set the number of places after the decimal point, the currency symbol to use, and the 
way in which Excel should display negative numbers.

Tip The Excel user interface enables you to make the most common format changes by 
displaying the Home tab of the ribbon and then, in the Number group, either clicking a 
button representing a built-in format or selecting a format from the Number Format list.

You can also create a custom numeric format to add a word or phrase to a number 
in a cell. For example, you can add the phrase per month to a cell with a formula that 
calculates average monthly sales for a year to ensure that you and your colleagues will 
recognize the figure as a monthly average. To create a custom number format, click the 
Home tab, and then click the Number dialog box launcher (found at the bottom right 
corner of the Number group on the ribbon) to display the Format Cells dialog box. 
Then, if necessary, click the Number tab.

In the Category list, click Custom to display the available custom number formats in the 
Type list. You can then click the base format you want and modify it in the Type box. For 
example, clicking the 0.00 format causes Excel to format any number in a cell with two 
digits to the right of the decimal point.

Tip The zeros in the format indicate that the position in the format can accept any number as 
a valid value.
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To customize the format, click in the Type box and add any symbols or text you want to 
the format. For example, typing a dollar ($) sign to the left of the existing format and then 
typing “per month” (including quote marks) to the right of the existing format causes the 
number 1500 to be displayed as $1500.00 per month.

Important You need to enclose any text to be displayed as part of the format in quotes so 
that Excel recognizes the text as a string to be displayed in the cell.

In this exercise, you’ll assign date, phone number, and currency formats to ranges of cells. 

SET UP You need the ExecutiveSearch_start workbook located in your Chapter04 
practice file folder to complete this exercise. Open the ExecutiveSearch_start 
workbook, and save it as ExecutiveSearch. Then follow the steps. 

1. Click cell A3.

2. On the Home tab, click the Font dialog box launcher.

The Format Cells dialog box opens.

3. If necessary, click the Number tab.

4. In the Category list, click Date.

The Type list appears with a list of date formats.

5. In the Type list, click 3/14/01.
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6. Click OK to assign the chosen format to the cell.

Excel displays the contents of cell A3 to reflect the new format.

7. Click cell G3.

8. On the Home tab, in the Number group, click the Number Format button’s down 
arrow and then click More Number Formats.

9. If necessary, click the Number tab in the Format Cells dialog box.

10. In the Category list, click Special.

The Type list appears with a list of special formats.

11. In the Type list, click Phone Number, and then click OK.

Excel displays the contents of the cell as (425) 555-0102, matching the format you 
selected, and the Format Cells dialog box closes.

12. Click cell H3.

13. Click the Font dialog box launcher.

14. If necessary, click the Number tab in the Format Cells dialog box.

15. In the Category list, click Custom.

The contents of the Type list are updated to reflect your choice.
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16. In the Type list, click the #,##0 item.

#,##0 appears in the Type box.

17. In the Type box, click to the left of the existing format, and type $. Then click to 
the right of the format, and type “ before bonuses” (note the space after the 
opening quote).

18. Click OK to close the dialog box.

CLEAN UP Save the ExecutiveSearch workbook, and then close it.

Changing the Appearance of Data  
Based on Its Value

Recording package volumes, vehicle miles, and other business data in a worksheet enables 
you to make important decisions about your operations. And as you saw earlier in this 
chapter, you can change the appearance of data labels and the worksheet itself to make 
interpreting your data easier.

Another way you can make your data easier to interpret is to have Excel change the 
appearance of your data based on its value. These formats are called conditional for-
mats because the data must meet certain conditions, defined in conditional formatting 
rules, to have a format applied to it. For example, if chief operating officer Lori Penor 
wanted to highlight any Thursdays with higher-than-average weekday package volumes, 
she could define a conditional format that tests the value in the cell recording total sales 
and changes the format of the cell’s contents when the condition is met.

To create a conditional format, you select the cells to which you want to apply the format, 
display the Home tab, and then in the Styles group, click Conditional Formatting to display 
a menu of possible conditional formats. In Excel, you can define conditional formats that 
change how the program displays data in cells that contain values above or below the aver-
age values of the related cells, that contain values near the top or bottom of the value range, 
or that contain values duplicated elsewhere in the selected range.
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When you select which kind of condition to create, Excel displays a dialog box that contains 
fields and controls you can use to define your rule. To display all of the rules for the selected 
cells, display the Home tab, and then in the Styles group, click Conditional Formatting. On 
the menu, click Manage Rules to display the Conditional Formatting Rules Manager.

The Conditional Formatting Rules Manager enables you to control your conditional formats 
in the following ways:

● Create a new rule by clicking the New Rule button.

● Change a rule by clicking the rule and then clicking the Edit Rule button.

● Remove a rule by clicking the rule and then clicking the Delete Rule button.

● Move a rule up or down in the order by clicking the rule and then clicking the 
Move Up button or Move Down button.

● Control whether Excel continues evaluating conditional formats after it finds a rule 
to apply by selecting or clearing a rule’s Stop If True check box.

● Save any new rules and close the Conditional Formatting Rules Manager by 
clicking OK.

● Save any new rules without closing the Conditional Formatting Rules Manager by 
clicking Apply.

● Discard any unsaved changes by clicking Cancel.

Tip Clicking the New Rule button in the Conditional Formatting Rules Manager opens the 
New Formatting Rule dialog box. The commands in the New Formatting Rule dialog box 
duplicate the options displayed when you click the Conditional Formatting button in the 
Styles group on the Home tab.
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After you create a rule, you can change the format applied if the rule is true by clicking 
the rule and then clicking the Edit Rule button to display the Edit Formatting Rule dialog 
box. In that dialog box, click the Format button to display the Format Cells dialog box. 
After you define your format, click OK to display the rule.

Important Excel doesn’t check to make sure that your conditions are logically consistent, so 
you need to be sure that you plan and enter your conditions correctly.

Excel also enables you to create three other types of conditional formats: data bars, 
color scales, and icon sets. Data bars summarize the relative magnitude of values in a 
cell range by extending a band of color across the cell.

You can create two types of data bars in Excel 2010: solid fill and gradient fill. When  
data bars were introduced in Excel 2007, they filled cells with a color band that decreased  
in intensity as it moved across the cell. This gradient fill pattern made it a bit difficult to 
determine the relative length of two data bars because the end points weren’t as distinct 
as they would have been if the bars were a solid color. Excel 2010 enables you to choose 
between a solid fill pattern, which makes the right edge of the bars easier to discern, 
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and a gradient fill, which you can use if you share your workbook with colleagues who 
use Excel 2007.

Excel also draws data bars differently than was done in Excel 2007. Excel 2007 drew a very 
short data bar for the lowest value in a range and a very long data bar for the highest 
value. The problem was that similar values could be represented by data bars of very 
different lengths if there wasn’t much variance among the values in the conditionally 
formatted range. In Excel 2010, data bars compare values based on their distance from 
zero, so similar values are summarized using data bars of similar lengths.

Tip Excel 2010 data bars summarize negative values by using bars that extend to the left of 
a baseline that the program draws in a cell. You can control how your data bars summarize 
negative values by clicking the Negative Value And Axis button, which can be accessed from 
either the New Formatting Rule dialog box or the Edit Formatting Rule dialog box.

Color scales compare the relative magnitude of values in a cell range by applying colors 
from a two-color or three-color set to your cells. The intensity of a cell’s color reflects the 
value’s tendency toward the top or bottom of the values in the range.

Icon sets are collections of three, four, or five images that Excel displays when certain 
rules are met. 

When icon sets were introduced in Excel 2007, you could apply an icon set as a whole, 
but you couldn’t create custom icon sets or choose to have Excel 2007 display no icon if 
the value in a cell met a criterion. In Excel 2010, you can display any icon from any set for 
any criterion or display no icon.

When you click a color scale or icon set in the Conditional Formatting Rules Manager 
and then click the Edit Rule button, you can control when Excel applies a color or icon 
to your data.
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Important Be sure to not include cells that contain summary formulas in your conditionally 
formatted ranges. The values, which could be much higher or lower than your regular cell 
data, could throw off your comparisons.

In this exercise, you’ll create a series of conditional formats to change the appearance of 
data in worksheet cells displaying the package volume and delivery exception rates of a 
regional distribution center.

SET UP You need the Dashboard_start workbook located in your Chapter04 practice 
file folder to complete this exercise. Open the Dashboard_start workbook, and save it 
as Dashboard. Then follow the steps. 

1. Select cells C4:C12.

2. On the Home tab, in the Styles group, click Conditional Formatting. On the menu, 
point to Color Scales, and then in the top row of the palette, click the second pattern 
from the left.

Excel formats the selected range.

3. Select cells F4:F12.
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4. On the Home tab, in the Styles group, click Conditional Formatting. On the 
menu, point to Data Bars, and then, in the Solid Fill group, click the orange data 
bar format.

Excel formats the selected range.

5. Select cells I4:I12.

6. On the Home tab, in the Styles group, click Conditional Formatting. On the 
menu, point to Icon Sets, and then in the left column of the list of formats, click 
the three traffic lights with black borders.

Excel formats the selected cells.

7. With the range I4:I12 still selected, on the Home tab, in the Styles group, click 
Conditional Formatting, and then click Manage Rules.

The Conditional Formatting Rules Manager opens.

8. Click the Icon Set rule, and then click Edit Rule.

The Edit Formatting Rule dialog box opens.
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9. Click the Reverse Icon Order button.

Excel reconfigures the rules so the red light icon is at the top and the green light 
icon is at the bottom.

10. In the red light icon’s row, in the Type list, click Number.

11. In the red light icon’s Value field, type 0.7.

12. In the yellow light icon’s row, in the Type list, click Number.

13. In the yellow light icon Value field, type 0.5.

14. Click OK twice to close the Edit Formatting Rule dialog box and the Conditional 
Formatting Rules Manager.

Excel formats the selected cell range.

15. Click cell C15.

16. On the Home tab, in the Styles group, click Conditional Formatting. On the 
menu, point to Highlight Cells Rules, and then click Less Than.

The Less Than dialog box opens.

17. In the left field, type 96%.

18. In the With list, click Red text.
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19. Click OK.

The Less Than dialog box closes, and Excel displays the text in cell C15 in red.

CLEAN UP Save the Dashboard workbook, and then close it.

Adding Images to Worksheets
Establishing a strong corporate identity helps customers remember your organization  
as well as the products and services you offer. Setting aside the obvious need for sound 
management, two important physical attributes of a strong retail business are a well-
conceived shop space and an eye-catching, easy-to-remember logo. After you or your 
graphic artist has created a logo, you should add the logo to all your documents, especially 
any that might be seen by your customers. Not only does the logo mark the documents 
as coming from your company but it also serves as an advertisement, encouraging anyone 
who sees your worksheets to call or visit your company.

One way to add a picture to a worksheet is to display the Insert tab, and then in the 
Illustrations group, click Picture. Clicking Picture displays the Insert Picture dialog box, 
from which you can locate the picture you want to add from your hard disk. When you 
insert a picture, the Picture Tools Format contextual tab appears on the ribbon. You can 
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use the tools on the Format contextual tab to change the picture’s contrast, brightness, 
and other attributes. With the controls in the Picture Styles group, you can place a bor-
der around the picture, change the picture’s shape, or change a picture’s effects (such as 
shadow, reflection, or three-dimensional effects). Other tools, found in the Arrange and 
Size groups, enable you to rotate, reposition, and resize the picture. 

You can also resize a picture by clicking it and then dragging one of the handles that 
appears on the graphic. If you accidentally resize a graphic by dragging a handle, just 
click the Undo button to remove your change. 

Excel 2010 includes a new built-in capability that you can use to remove the background 
of an image you insert into a workbook. To do so, click the image and then, on the Format 
contextual tab of the ribbon, in the Adjust group, click Remove Background. When you do, 
Excel attempts to identify the foreground and background of the image. 
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You can drag the handles on the inner square of the background removal tool to change  
how the tool analyzes the image. When you have adjusted the outline to identify 
the elements of the image you want to keep, click the Keep Changes button on the 
Background Removal contextual tab of the ribbon to complete the operation.

If you want to generate a repeating image in the background of a worksheet to form a 
tiled pattern behind your worksheet’s data, you can display the Page Layout tab, and 
then in the Page Setup group, click Background. In the Sheet Background dialog box, 
click the image that you want to serve as the background pattern for your worksheet, 
and click OK.

Tip To remove a background image from a worksheet, display the Page Layout tab, and then 
in the Page Setup group, click Delete Background.

To achieve a watermark-type effect with words displayed behind the worksheet data, save 
the watermark information as an image, and then use the image as the sheet background; 
you could also insert the image in the header or footer, and then resize or scale it to  
position the watermark information where you want it.

In this exercise, you’ll add an image to an existing worksheet, change its location on 
the worksheet, reduce the size of the image, and then set another image as a repeating 
background for the worksheet.
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SET UP You need the CallCenter_start workbook and the phone and texture images 
located in your Chapter04 practice file folder to complete this exercise. Open the 
CallCenter_start workbook, and save it as CallCenter. Then follow the steps. 

1. On the Insert tab, in the Illustrations group, click Picture.

The Insert Picture dialog box opens.

2. Navigate to the Chapter04 practice file folder, and then double-click the phone 
image file.

The image appears on your worksheet.

3. On the Format contextual tab, in the Adjust group, click Remove Background.

Excel attempts to separate the image’s foreground from its background.

4. Drag the handles at the upper-left and bottom-right corners of the outline until 
the entire phone, including the cord, is within the frame.

5. On the Background Removal tab, click Keep Changes.

Excel removes the highlighted image elements.
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6. Move the image to the upper-left corner of the worksheet, click and hold the handle 
at the lower-right corner of the image, and drag it up and to the left until the image 
no longer obscures the Call Volume label.

7. On the Page Layout tab, in the Page Setup group, click Background.

The Sheet Background dialog box opens.

8. Navigate to the Chapter04 practice file folder, and then double-click the texture 
image file.

Excel repeats the image to form a background pattern.
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9. On the Page Layout tab, in the Page Setup group, click Delete Background.

Excel removes the background image.

CLEAN UP Save the CallCenter workbook, and then close it. If you are not continuing 
directly to the next chapter, exit Excel.
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Key Points
● If you don’t like the default font in which Excel displays your data, you can change it.

● You can use cell formatting, including borders, alignment, and fill colors, to 
emphasize certain cells in your worksheets. This emphasis is particularly useful 
for making column and row labels stand out from the data.

● Excel comes with a number of existing styles that enable you to change the 
appearance of individual cells. You can also create new styles to make format-
ting your workbooks easier.

● If you want to apply the formatting from one cell to another cell, use the Format 
Painter to copy the format quickly.

● There are quite a few built-in document themes and Excel table formats you can 
apply to groups of cells. If you see one you like, use it and save yourself lots of 
formatting time.

● Conditional formats enable you to set rules so that Excel changes the appearance 
of a cell’s contents based on its value.

● Adding images can make your worksheets more visually appealing and make your 
data easier to understand. Excel 2010 greatly enhances your ability to manage 
your images without leaving Excel.
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5 Focusing on Specific 
Data by Using Filters

In this chapter, you will learn how to
✔ Limit data that appears on your screen.
✔ Manipulate worksheet data.
✔ Define valid sets of values for ranges of cells.

With Microsoft Excel 2010, you can manage huge data collections, but storing more than 
1 million rows of data doesn’t help you make business decisions unless you have the ability 
to focus on the most important data in a worksheet. Focusing on the most relevant data in 
a worksheet facilitates decision making, whether that data represents the 10 busiest days 
in a month or revenue streams that you might need to reevaluate. Excel offers a number of 
powerful and flexible tools with which you can limit the data displayed in your worksheet. 
When your worksheet displays the subset of data you need to make a decision, you can 
perform calculations on that data. You can discover what percentage of monthly revenue 
was earned in the 10 best days in the month, find your total revenue for particular days of 
the week, or locate the slowest business day of the month.

Just as you can limit the data displayed by your worksheets, you can create validation rules 
that limit the data entered into them as well. Setting rules for data entered into cells enables 
you to catch many of the most common data entry errors, such as entering values that are 
too small or too large, or attempting to enter a word in a cell that requires a number. If you 
add a validation rule to worksheet cells after data has been entered into them, you can 
circle any invalid data so that you know what to correct.

In this chapter, you’ll learn how to limit the data that appears on your screen, manipulate 
list data, and create validation rules that limit data entry to appropriate values.

Practice Files Before you can complete the exercises in this chapter, you need to copy 
the book’s practice files to your computer. The practice files you’ll use to complete the 
exercises in this chapter are in the Chapter05 practice file folder. A complete list of 
practice files is provided in “Using the Practice Files” at the beginning of this book.
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Limiting Data That Appears on Your Screen
Excel spreadsheets can hold as much data as you need them to, but you might not want 
to work with all the data in a worksheet at the same time. For example, you might want to 
see the revenue figures for your company during the first third, second third, and final 
third of a month. You can limit the data shown on a worksheet by creating a filter, which 
is a rule that selects rows to be shown in a worksheet.

To create a filter, you click the cell in the data you want to filter and then, on the Home tab, 
in the Editing group, click Sort & Filter and then click Filter. When you do, Excel displays a 
filter arrow at the right edge of the top cell in each column of the data. The arrow indicates 
that the Excel AutoFilter capability is active.

Important When you turn on filtering, Excel treats the cells in the active cell’s column as a 
range. To ensure that the filtering works properly, you should always have a label at the top 
of the column you want to filter. If you don’t, Excel treats the first value in the list as the label 
and doesn’t include it in the list of values by which you can filter the data.

Clicking the filter arrow displays a menu of filtering options and a list of the unique values 
in the column. The first few commands in the list are sorting commands, followed by the 
Clear Filter command and then the Filter By Color command. The next command that 
appears on the list depends on the type of data in the column. For example, if the col-
umn contains a set of dates, the command will be Date Filters. Clicking the command 
displays a list of commands specific to that data type.
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Troubleshooting The appearance of buttons and groups on the ribbon changes depending 
on the width of the program window. For information about changing the appearance of 
the ribbon to match our screen images, see “Modifying the Display of the Ribbon” at the 
beginning of this book.

Tip When a column contains several types of data, the filter command becomes Number 
Filters.

When you click a filtering option, Excel displays a dialog box in which you can define 
the filter’s criteria. As an example, you could create a filter that displays only dates 
after 3/31/2010.

If you want to see the highest or lowest values in a data column, you can create a Top 10 
filter. Choosing the Top 10 command from the menu doesn’t just limit the display to 
the top 10 values. Instead, it opens the Top 10 AutoFilter dialog box. From within this 
dialog box, you can choose whether to show values from the top or bottom of the 
list, define the number of items you want to see, and choose whether the number in 
the middle box indicates the number of items or the percentage of items to be shown 
when the filter is applied. Using the Top 10 AutoFilter dialog box, you can find your 
top 10 salespeople or identify the top 5 percent of your customers.

Excel 2010 includes a new capability called the search filter, which you can use to type a 
search string that Excel uses to identify which items to display in an Excel table or a data 
list. To use a search filter, click a column’s filter arrow and start typing a character string 
in the Search box. As you type the character string, Excel limits the items displayed at 
the bottom of the filter panel to those that contain the character or characters you’ve 
entered. When the filter list’s items represent the values you want to display, click OK.
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When you point to Text Filters and then click Custom Filter, you can define a rule that Excel 
uses to decide which rows to show after the filter is applied. For instance, you can create a 
rule that determines that only days with package volumes of less than 100,000 should be 
shown in your worksheet. With those results in front of you, you might be able to deter-
mine whether the weather or another factor resulted in slower business on those days.

Excel indicates that a column has a filter applied by changing the appearance of the 
column’s filter arrow to include an icon that looks like a funnel. After you finish examining 
your data by using a filter, you can remove the filter by clicking the column’s filter arrow 
and then clicking Clear Filter. To turn off filtering entirely and remove the filter arrows, dis-
play the Home tab and then, in the Editing group, click Sort & Filter and then click Filter.

In this exercise, you’ll filter worksheet data by using a series of AutoFilter commands, 
create a filter showing the five days with the highest delivery exception counts in a 
month, create a search filter, and create a custom filter.

SET UP You need the PackageExceptions_start workbook located in your 
Chapter05 practice file folder to complete this exercise. Start Excel, open the 
PackageExceptions_start workbook, and save it as PackageExceptions. Then follow 
the steps. 

1. On the ByRoute worksheet, click any cell in the cell range B2:F27.
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2. On the Home tab, in the Editing group, click Sort & Filter, and then click Filter.

A filter arrow appears in each column’s header cell.

3. Click the Date column filter arrow and then, from the menu that appears, clear the 
March check box.

Excel removes the check from the March check box and changes the state of the 
Select All and 2010 check boxes to indicate that some items within those categories 
have been filtered.

4. Click OK.

Excel hides all rows that contain a date from the month of March.

5. Click the Center column filter arrow and then, from the menu that appears, clear 
the Select All check box.

Excel clears all the check boxes in the list.

6. Select the Midwest check box, and then click OK.

Excel displays only those exceptions that occurred in the Midwest distribution 
center during the month of April.
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7. On the Home tab, in the Editing group, click Sort & Filter, and then click Clear.

Excel clears all active filters but leaves the filter arrows in place.

8. Click the Route column header’s filter arrow, and then type RT9 in the Search box.

The filter list displays only those routes with an identifier that includes the characters 
RT9.

9. Click OK.

Excel applies the filter, displaying exceptions that occurred on routes with identifiers 
that contain the string RT9.

10. Click the MarchDailyCount sheet tab.

The MarchDailyCount worksheet appears.

11. Click any cell in the Excel table.

12. Click the Exceptions column filter arrow, point to Number Filters, and then click 
Top 10.

The Top 10 AutoFilter dialog box opens.

13. In the middle field, type 5.

14. Click OK.

Excel displays the table rows that contain the five highest values in the Exceptions 
column.
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15. Click the Exceptions column filter arrow, and then click Clear Filter from “Exceptions”.

Excel removes the filter.

16. Click the Date column filter arrow, point to Date Filters, and then click Custom Filter.

The Custom AutoFilter dialog box opens.

17. In the upper-left list, click is after or equal to.

18. In the upper-right list, click 3/8/2010.

19. In the lower-left list, click is before or equal to.

20. In the lower-right list, click 3/14/2010.

21. Click OK.

Because you left the And option selected, Excel displays all table rows that contain 
a date from 3/8/2010 to 3/14/2010, inclusive.

22. On the Quick Access Toolbar, click the Undo button to remove your filter.

Excel restores the table to its unfiltered state.

CLEAN UP Save the PackageExceptions workbook, and then close it.
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Manipulating Worksheet Data
Excel offers a wide range of tools you can use to summarize worksheet data. This section 
shows you how to select rows at random using the RAND and RANDBETWEEN functions, 
how to summarize worksheet data using the SUBTOTAL and AGGREGATE functions, and how 
to display a list of unique values within a data set.

Selecting List Rows at Random
In addition to filtering the data that is stored in your Excel worksheets, you can choose rows 
at random from a list. Selecting rows randomly is useful for choosing which customers will 
receive a special offer, deciding which days of the month to audit, or picking prize winners 
at an employee party. 

To choose rows randomly, you can use the RAND function, which generates a random 
value between 0 and 1, and compare the value it returns with a test value included in the 
formula. As an example, suppose Consolidated Messenger wanted to offer approximately 
30 percent of its customers a discount on their next shipment. A formula that returns a 
TRUE value 30 percent of the time would be RAND<=0.3; that is, whenever the random 
value was between 0 and 0.3, the result would be TRUE. You could use this formula to 
select each row in a list with a probability of 30 percent. A formula that displayed TRUE 
when the value was equal to or less than 30 percent, and FALSE otherwise, would be 
=IF(RAND()<=0.3,”True”,”False”).

If you recalculate this formula 10 times, it’s very unlikely that you would see exactly three 
TRUE results and seven FALSE results. Just as flipping a coin can result in the same result 
10 times in a row by chance, so can the RAND function’s results appear to be off if you 
only recalculate it a few times. However, if you were to recalculate the function 10 
thousand times, it is extremely likely that the number of TRUE results would be very 
close to 30 percent.

Tip Because the RAND function is a volatile function (it recalculates its results every time 
you update the worksheet), you should copy the cells that contain the RAND function in a 
formula and paste the formulas’ values back into their original cells. To do so, select the cells 
that contain the RAND formulas and press Ctrl+C to copy the cell’s contents. Then, on the 
Home tab, in the Clipboard group, in the Paste list, click Paste Values to replace the formula 
with its current result. If you don’t replace the formulas with their results, you will never have 
a permanent record of which rows were selected.

The RANDBETWEEN function generates a random whole number within a defined 
range. For example, the formula =RANDBETWEEN(1,100) would generate a random 
integer value from 1 to 100, inclusive. The RANDBETWEEN function is very useful for 
creating sample data collections for presentations. Before the RANDBETWEEN function 
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was introduced, you had to create formulas that added, subtracted, multiplied, and 
divided the results of the RAND function, which are always decimal values between 0 
and 1, to create your data.

Summarizing Worksheets with Hidden and Filtered Rows
The ability to analyze the data that’s most vital to your current needs is important, but 
there are some limitations to how you can summarize your filtered data by using functions 
such as SUM and AVERAGE. One limitation is that any formulas you create that include the 
SUM and AVERAGE functions don’t change their calculations if some of the rows used in 
the formula are hidden by the filter. 

Excel provides two ways to summarize just the visible cells in a filtered data list. The first 
method is to use AutoCalculate. To use AutoCalculate, you select the cells you want to 
summarize. When you do, Excel displays the average of values in the cells, the sum of the 
values in the cells, and the number of visible cells (the count) in the selection. You’ll find 
the display on the status bar at the lower edge of the Excel window.

When you use AutoCalculate, you aren’t limited to finding the sum, average, and count 
of the selected cells. To display the other functions you can use, right-click the status bar 
and select the function you want from the shortcut menu. If a check mark appears next 
to a function’s name, that function’s result appears on the status bar. Clicking a checked 
function name removes that function from the status bar.

AutoCalculate is great for finding a quick total or average for filtered cells, but it doesn’t 
make the result available in the worksheet. Formulas such as =SUM(C3:C26) always 
consider every cell in the range, regardless of whether you hide a cell’s row by right-
clicking the row’s header and then clicking Hide, so you need to create a formula by 
using either the SUBTOTAL function or the AGGREGATE function (which is new in Excel 
2010) to summarize just those values that are visible in your worksheet. The SUBTOTAL 
function enables you to summarize every value in a range or summarize only those 
values in rows you haven’t manually hidden. The SUBTOTAL function has this syntax: 
SUBTOTAL(function_num, ref1, ref2, ...). The function_num argument holds the number 
of the operation you want to use to summarize your data. (The operation numbers are 
summarized in a table later in this section.) The ref1, ref2, and further arguments repre-
sent up to 29 ranges to include in the calculation. 

As an example, assume you have a worksheet where you hid rows 20-26 manually. In this 
case, the formula =SUBTOTAL(9, C3:C26, E3:E26, G3:G26) would find the sum of all values 
in the ranges C3:C26, E3:E26, and G3:G26, regardless of whether that range contained 
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any hidden rows. The formula =SUBTOTAL(109, C3:C26, E3:E26, G3:G26) would find the 
sum of all values in cells C3:C19, E3:E19, and G3:G19, ignoring the values in the manually 
hidden rows.

Important Be sure to place your SUBTOTAL formula in a row that is even with or above the 
headers in the range you’re filtering. If you don’t, your filter might hide the formula’s result!

The following table lists the summary operations available for the SUBTOTAL formula. Excel 
displays the available summary operations as part of the Formula AutoComplete functionality, 
so you don’t need to remember the operation numbers or look them up in the Help system.

Operation
number 
(includes 
hidden  
values)

Operation
number  
(ignores values 
in manually 
hidden rows) Function Description

1 101 AVERAGE Returns the average of the values in the 
range

2 102 COUNT Counts the cells in the range that contain a 
number

3 103 COUNTA Counts the nonblank cells in the range

4 104 MAX Returns the largest (maximum) value in the 
range

5 105 MIN Returns the smallest (minimum) value in 
the range

6 106 PRODUCT Returns the result of multiplying all numbers 
in the range

7 107 STDEV.S Calculates the standard deviation of values 
in the range by examining a sample of the 
values

8 108 STDEV.P Calculates the standard deviation of the 
values in the range by using all the values

9 109 SUM Returns the result of adding all numbers in 
the range together

10 110 VAR.S Calculates the variance of values in the 
range by examining a sample of the values

11 111 VAR.P Calculates the variance of the values in the 
range by using all of the values

As the previous table shows, the SUBTOTAL function has two sets of operations. The first 
set (operations 1-11) represents operations that include hidden values in their summary, 
and the second set (operations 101-111) represents operations that summarize only values  
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visible in the worksheet. Operations 1-11 summarize all cells in a range, regardless of 
whether the range contains any manually hidden rows. By contrast, the operations 
101-111 ignore any values in manually hidden rows. What the SUBTOTAL function 
doesn’t do, however, is change its result to reflect rows hidden by using a filter.

The new AGGREGATE function extends the capabilities of the SUBTOTAL function. With it, 
you can select from a broader range of functions and use another argument to determine 
which, if any, values to ignore in the calculation. AGGREGATE has two possible syntaxes, 
depending on the summary operation you select. The first syntax is =AGGREGATE(function_
num, options, ref1…), which is similar to the syntax of the SUBTOTAL function. The other 
possible syntax, =AGGREGATE(function_num, options, array, [k]), is used to create 
AGGREGATE functions that use the LARGE, SMALL, PERCENTILE.INC, QUARTILE.INC, 
PERCENTILE.EXC, and QUARTILE.EXC operations.

The following table summarizes the summary operations available for use in the 
AGGREGATE function.

Number Function Description
1 AVERAGE Returns the average of the values in the range.
2 COUNT Counts the cells in the range that contain a number.
3 COUNTA Counts the nonblank cells in the range.

4 MAX Returns the largest (maximum) value in the range.

5 MIN Returns the smallest (minimum) value in the range.

6 PRODUCT Returns the result of multiplying all numbers in the range.

7 STDEV.S Calculates the standard deviation of values in the range by 
examining a sample of the values.

8 STDEV.P Calculates the standard deviation of the values in the range 
by using all the values.

9 SUM Returns the result of adding all numbers in the range  
together.

10 VAR.S Calculates the variance of values in the range by examining 
a sample of the values.

11 VAR.P Calculates the variance of the values in the range by using 
all of the values.

12 MEDIAN Returns the value in the middle of a group of values.

13 MODE.SNGL Returns the most frequently occurring number from a 
group of numbers.

14 LARGE Returns the k-th largest value in a data set; k is specified 
using the last function argument. If k is left blank, Excel 
returns the largest value.
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Number Function Description
15 SMALL Returns the k-th smallest value in a data set; k is specified 

using the last function argument. If k is left blank, Excel 
returns the smallest value.

16 PERCENTILE.INC Returns the k-th percentile of values in a range, where k is a 
value from 0 to 1, inclusive.

17 QUARTILE.INC Returns the quartile value of a data set, based on a  
percentage from 0 to 1, inclusive.

18 PERCENTILE.EXC Returns the k-th percentile of values in a range, where k is a 
value from 0 to 1, exclusive.

19 QUARTILE.EXC Returns the quartile value of a data set, based on a  
percentage from 0 to 1, exclusive.

The second argument, options, enables you to select which items the AGGREGATE 
function should ignore. These items can include hidden rows, errors, and SUBTOTAL 
and AGGREGATE functions. The following table summarizes the values available for the 
options argument and the effect they have on the function’s results.

Number Description
0 Ignore nested SUBTOTAL and AGGREGATE functions
1 Ignore hidden rows and nested SUBTOTAL and AGGREGATE functions
2 Ignore error values and nested SUBTOTAL and AGGREGATE functions

3 Ignore hidden rows, error values, and nested SUBTOTAL and AGGREGATE 
functions

4 Ignore nothing

5 Ignore hidden rows

6 Ignore error values

7 Ignore hidden rows and error values

Finding Unique Values Within a Data Set
Summarizing numerical values can provide valuable information that helps you run your 
business. It can also be helpful to know how many different values appear within a col-
umn. For example, you might want to display all of the countries in which Consolidated 
Messenger has customers. If you want to display a list of the unique values in a column, 
click any cell in the data set, display the Data tab and then, in the Sort & Filter group, 
click Advanced to display the Advanced Filter dialog box.
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In the List Range field, type the reference of the cell range you want to examine for 
unique values, select the Unique Records Only check box, and then click OK to have 
Excel display the row that contains the first occurrence of each value in the column. 

Important Excel treats the first cell in the data range as a header cell, so it doesn’t consider the 
cell as it builds the list of unique values. Be sure to include the header cell in your data range!

In this exercise, you’ll select random rows from a list of exceptions to identify package 
delivery misadventures to investigate, create an AGGREGATE formula to summarize the 
visible cells in a filtered worksheet, and find the unique values in one column of data.

SET UP You need the ForFollowUp_start workbook located in your Chapter05 practice 
file folder to complete this exercise. Open the ForFollowUp_start workbook, and save it 
as ForFollowUp. Then follow the steps. 

1. Select cells G3:G27.

The average of the values in the selected cells, the number of cells selected, and 
the total of the values in the selected cells appear in the AutoCalculate area of the 
status bar.

2. In cell J3, enter the formula =AGGREGATE(1,1,G3:G27).

The value $15.76 appears in cell J3.

3. On the Data tab, in the Sort & Filter group, click Advanced.

The Advanced Filter dialog box opens.

4. In the List range field, type E2:E27.

5. Select the Unique records only check box, and then click OK.

Excel displays the rows that contain the first occurrence of each different value in 
the selected range.
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Tip Remember that you must include cell E2, the header cell, in the List Range field so 
that the filter doesn’t display two occurrences of Northeast in the unique values list. 
To see what happens when you don’t include the header cell, try changing the range 
in the List Range field to E3:E27, selecting the Unique Records Only check box, and 
clicking OK.

6. On the Data tab, in the Sort & Filter group, click Clear.

Excel removes the filter.

7. In cell H3, type the formula =IF(RAND()<0.15,”Yes”,”No”), and press Enter.

A value of Yes or No appears in cell H3, depending on the RAND function result.

8. Select cell H3, and then drag the fill handle down until it covers cell H27.

Excel copies the formula into every cell in the range H3:H27.

9. With the range H3:H27 still selected, on the Home tab, in the Clipboard group, 
click the Copy button.

Excel copies the cell range’s contents to the Microsoft Office Clipboard.

10. Click the Paste arrow, and then in the Paste gallery that appears, click the first icon 
in the Paste Values group.

Excel replaces the cells’ formulas with the formulas’ current results. 
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CLEAN UP Save the ForFollowUp workbook, and then close it.

Defining Valid Sets of Values for Ranges of Cells
Part of creating efficient and easy-to-use worksheets is to do what you can to ensure the 
data entered into your worksheets is as accurate as possible. Although it isn’t possible to 
catch every typographical or transcription error, you can set up a validation rule to make 
sure that the data entered into a cell meets certain standards.

To create a validation rule, display the Data tab on the ribbon and then, in the Data Tools 
group, click the Data Validation button to open the Data Validation dialog box. You can 
use the controls in the Data Validation dialog box to define the type of data that Excel 
should allow in the cell and then, depending on the data type you choose, to set the 
conditions data must meet to be accepted in the cell. For example, you can set the con-
ditions so that Excel knows to look for a whole number value between 1000 and 2000.
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Setting accurate validation rules can help you and your colleagues avoid entering a cus-
tomer’s name in the cell designated to hold the phone number or setting a credit limit 
above a certain level. To require a user to enter a numeric value in a cell, display the 
Settings page of the Data Validation dialog box, and, depending on your needs, choose 
either Whole Number or Decimal from the Allow list.

If you want to set the same validation rule for a group of cells, you can do so by selecting 
the cells to which you want to apply the rule (such as a column in which you enter the 
credit limit of customers of Consolidated Messenger) and setting the rule by using the Data 
Validation dialog box. One important fact you should keep in mind is that, with Excel, you 
can create validation rules for cells in which you have already entered data. Excel doesn’t 
tell you whether any of those cells contain data that violates your rule at the moment 
you create the rule, but you can find out by having Excel circle any worksheet cells con-
taining data that violates the cell’s validation rule. To do so, display the Data tab and 
then, in the Data Tools group, click the Data Validation arrow. On the menu, click the 
Circle Invalid Data button to circle cells with invalid data.
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When you’re ready to hide the circles, in the Data Validation list, click Clear Validation 
Circles. 

Of course, it’s frustrating if you want to enter data into a cell and, when a message box 
appears that tells you the data you tried to enter isn’t acceptable, you aren’t given the 
rules you need to follow. With Excel, you can create a message that tells the user which 
values are expected before the data is entered and then, if the conditions aren’t met, 
reiterate the conditions in a custom error message.

You can turn off data validation in a cell by displaying the Settings page of the Data 
Validation dialog box and clicking the Clear All button in the lower-left corner of the 
dialog box.
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In this exercise, you’ll create a data validation rule limiting the credit line of Consolidated 
Messenger customers to $25,000, add an input message mentioning the limitation, and 
then create an error message if someone enters a value greater than $25,000. After you 
create your rule and messages, you’ll test them.

SET UP You need the Credit_start workbook located in your Chapter05 practice file 
folder to complete this exercise. Open the Credit_start workbook, and save it as Credit. 
Then follow the steps. 

1. Select the cell range J4:J7.

Cell J7 is currently blank, but you will add a value to it later in this exercise.

2. On the Data tab, in the Data Tools group, click Data Validation.

The Data Validation dialog box opens and displays the Settings page.

3. In the Allow list, click Whole Number.

Boxes labeled Minimum and Maximum appear below the Data box.

4. In the Data list, click less than or equal to.

The Minimum box disappears.

5. In the Maximum box, type 25000.

6. Clear the Ignore blank check box.

7. Click the Input Message tab.

The Input Message page is displayed.
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8. In the Title box, type Enter Limit.

9. In the Input Message box, type Please enter the customer’s credit limit, 
omitting the dollar sign and any commas.

10. Click the Error Alert tab.

The Error Alert page is displayed.

11. In the Style list, click Stop.

The icon that appears on your message box changes to the Stop icon.

12. In the Title box, type Error, and then click OK.

13. Click cell J7.

A ScreenTip with the title Enter Limit and the text Please enter the customer’s credit 
limit, omitting the dollar sign and any commas appears near cell J7.
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14. Type 25001, and press Enter.

A stop box with the title Error opens. Leaving the Error Message box blank in step 
12 causes Excel to use its default message.

15. Click Cancel.

The error box closes.

Important Clicking Retry enables you to edit the bad value, whereas clicking Cancel 
deletes the entry.

16. Click cell J7.

Cell J7 becomes the active cell, and the ScreenTip reappears.

17. Type 25000, and press Enter.

Excel accepts your input.

18. On the Data tab, in the Data Tools group, click the Data Validation arrow and 
then, in the list, click Circle Invalid Data.

A red circle appears around the value in cell J4.

19. In the Data Validation list, click Clear Validation Circles.

The red circle around the value in cell K4 disappears.

CLEAN UP Save the Credit workbook, and then close it. If you are not continuing 
directly to the next chapter, exit Excel.
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Key Points
● A number of filters are defined in Excel. (You might find the one you want is already 

available.)

● Filtering an Excel worksheet based on values in a single column is easy to do, but 
you can create a custom filter to limit your data based on the values in more than 
one column as well.

● With the new search filter capability in Excel 2010, you can limit the data in 
your worksheets based on characters the terms contain.

● Don’t forget that you can get a running total (or an average, or any one of several 
other summary operations) for the values in a group of cells. Just select the cells 
and look on the status bar: the result will be there.

● Use data validation techniques to improve the accuracy of data entered into your 
worksheets and to identify data that doesn’t meet the guidelines you set.
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6 Reordering and 
Summarizing Data

In this chapter, you will learn how to
✔ Sort worksheet data.
✔ Organize data into levels.
✔ Look up information in a worksheet.

Most of the time, when you enter data in a Microsoft Excel worksheet, you will enter it in 
chronological order. For example, you could enter hourly shipment data in a worksheet, 
starting with the first hour of the day and ending with the last hour. The data would 
naturally be displayed in the order you entered it, but that might not always be the best 
arrangement to answer your questions. For instance, you might want to sort your data 
so that the top row in your worksheet shows the day of the month with the highest 
package volume, with subsequent rows displaying the remaining days in decreasing 
order of package volumes handled. You can also sort based on the contents of more 
than one column. A good example is sorting package handling data by week, day, 
and then hour of the day.

After you have sorted your data into the desired order with Excel, you can find partial totals, 
or subtotals, for groups of cells within a given range. Yes, you can create formulas to 
find the sum, average, or standard deviation of data in a cell range, but you can do the 
same thing much more quickly by having Excel calculate the total for rows that have 
the same value in one of their columns. For example, if your worksheet holds sales data 
for a list of services, you can calculate subtotals for each product category.

 Contents

 6 Reordering and 
  
Summarizing Data 143

Sorting Worksheet Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .144
Organizing Data into Levels. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .153
Looking Up Information in a Worksheet . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .160
Key Points . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 165

www.it-ebooks.info

http://www.it-ebooks.info/


144  Chapter 6 Reordering and Summarizing Data

When you calculate subtotals in a worksheet, Excel creates an outline that marks the 
cell ranges used in each subtotal. For example, if the first 10 rows of a worksheet con-
tain overnight shipping data, and the second 10 rows contain second-day shipping 
data, Excel divides the rows into two units. You can use the markers on the worksheet 
to hide or display the rows used to calculate a subtotal; in this case, you can hide all 
the rows that contain overnight shipping data, hide all the rows that contain second-
day shipping data, hide both, or show both.

Excel also has a capability you might expect to find only in a database program—in Excel,  
you can type a value in a cell and have Excel look in a named range to find a corre-
sponding value. For instance, you can have a two-column named range with one column 
displaying customer identification numbers and the second column displaying the name 
of the company assigned each number. By using a VLOOKUP formula that references 
the named range, you can let colleagues using your workbook type a customer identi-
fication number in a cell and have the name of the corresponding company appear in 
the cell with the formula.

In this chapter, you’ll learn how to sort your data using one or more criteria, calculate 
subtotals, organize your data into levels, and look up information in a worksheet.

Practice Files Before you can complete the exercises in this chapter, you need to copy 
the book’s practice files to your computer. The practice files you’ll use to complete the 
exercises in this chapter are in the Chapter06 practice file folder. A complete list of 
practice files is provided in “Using the Practice Files” at the beginning of this book.

Sorting Worksheet Data
Although Excel makes it easy to enter your business data and to manage it after you’ve 
saved it in a worksheet, unsorted data will rarely answer every question you want to ask 
it. For example, you might want to discover which of your services generates the most 
profits, which service costs the most for you to provide, and so on. You can discover that 
information by sorting your data.

When you sort data in a worksheet, you rearrange the worksheet rows based on the 
contents of cells in a particular column or set of columns. For instance, you can sort a 
worksheet to find your highest-revenue services.

You can sort a group of rows in a worksheet in a number of ways, but the first step is to 
identify the column that will provide the values by which the rows should be sorted. In 
the revenue example, you could find the highest revenue totals by sorting on the cells 
in the Revenue column. First you would select the cells in the Revenue column and dis-
play the Home tab. Then, in the Editing group, in the Sort & Filter list, click Sort Largest 
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To Smallest. Clicking Sort Largest To Smallest makes Excel put the row with the highest 
value in the Revenue column at the top of the worksheet and continue down to the 
lowest value.

If you want to sort the rows in the opposite order, from the lowest revenue to the high-
est, select the cells in the Revenue column and then, in the Sort & Filter list, click Sort 
Smallest To Largest.

Tip The exact set of values that appears in the Sort & Filter list changes to reflect the data in 
your column. If your column contains numerical values, you’ll see the options Sort Largest To 
Smallest, Sort Smallest To Largest, and Custom List. If your column contains text values, the 
options will be Sort A To Z (ascending order), Sort Z To A (descending order), and Custom List. 
And if your column contains dates, you’ll see Sort Newest To Oldest, Sort Oldest To Newest, 
and Custom List.
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The Sort Smallest To Largest and Sort Largest To Smallest options enable you to sort 
rows in a worksheet quickly, but you can use them only to sort the worksheet based on 
the contents of one column, even though you might want to sort by two columns. For 
example, you might want to order the worksheet rows by service category and then by 
total so that you can see the customers that use each service category most frequently. 
You can sort rows in a worksheet by the contents of more than one column by using the 
Sort dialog box, in which you can pick any number of columns to use as sort criteria and 
choose whether to sort the rows in ascending or descending order.

To display the Sort dialog box, click Custom Sort in the Sort & Filter list.

If your data has a header row, select the My Data Has Headers check box so the column 
headers will appear in the Sort By list. After you identify the column by which you want to 
sort, the Sort On list enables you to select whether you want to sort by a cell’s value (the 
default), a cell’s fill color, a cell’s font color, or an icon displayed in the cell.

See Also For more information about creating conditional formats that change a cell’s 
formatting or display icon to reflect the cell’s value, see “Changing the Appearance of Data 
Based on Its Value” in Chapter 4, “Changing Workbook Appearance.”

Finally, from the Order list, you can select how you want Excel to sort the column values. 
As with the Sort & Filter button’s list, the exact values that appear in the Order list change 
to reflect the data you want to sort.

Adding, moving, copying, and deleting sorting levels are a matter of clicking the appropri-
ate button in the Sort dialog box. To add a second level to your sort, click the Add Level 
button. 

Tip In Excel 2003 and earlier versions of the program, you could define a maximum of three 
sorting levels. You can create up to 64 sorting levels in Excel 2010.
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To delete a level, click the level in the list, and then click Delete Level. Clicking the Copy 
Level button enables you to put all the settings from one rule into another, saving you 
some work if you need to change only one item. The Move Up and Move Down buttons, 
which display an upward-pointing arrow and a downward-pointing arrow, respectively, 
enable you to change a sorting level’s position in the order. Finally, clicking the Options 
button displays the Sort Options dialog box, which you can use to make a sorting level 
case sensitive and to change the orientation of the sort.

The default setting for Excel is to sort numbers according to their values and to sort 
words in alphabetical order, but that pattern doesn’t work for some sets of values. One 
example in which sorting a list of values in alphabetical order would yield incorrect 
results is the months of the year. In an “alphabetical” calendar, April is the first month 
and September is the last! Fortunately, Excel recognizes a number of special lists, such 
as days of the week and months of the year. You can have Excel sort the contents of a 
worksheet based on values in a known list; if needed, you can create your own list of 
values. For example, the default lists of weekdays in Excel start with Sunday. If you keep 
your business records based on a Monday–Sunday week, you can create a new list with 
Monday as the first day and Sunday as the last. 

To create a new list, type the list of values you want to use as your list into a contiguous 
cell range, select the cells, click the File tab, and then click Options. On the Advanced 
page of the Excel Options dialog box, in the General group near the bottom of the page, 
click the Edit Custom Lists button to display the Custom Lists dialog box.
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The selected cell range’s reference appears in the Import List From Cells field. To record 
your list, click the Import button. 

If you prefer, you can type the list in the List Entries box, to the right of the Custom 
Lists box.

Tip Another benefit of creating a custom list is that dragging the fill handle of a list cell that 
contains a value causes Excel to extend the series for you. For example, if you create the list 
Spring, Summer, Fall, Winter, then type Summer in a cell and drag the cell’s fill handle, Excel 
extends the series as Fall, Winter, Spring, Summer, Fall, and so on.

To use a custom list as a sorting criterion, display the Sort dialog box, click the rule’s 
Order arrow, click Custom List, and select your list from the dialog box that opens.

Tip In Excel 2003 and earlier, your custom list had to be the primary sorting criterion. In Excel 
2010 and Excel 2007, you can use your custom list as any criterion.

In this exercise, you’ll sort worksheet data, sort by multiple criteria, change the order in 
which sorting criteria are applied, sort data by using a custom list, and sort data by color.

SET UP You need the ShippingSummary_start workbook located in your 
Chapter06 practice file folder to complete this exercise. Start Excel, open  
the ShippingSummary_start workbook, and save it as ShippingSummary. 
Then follow the steps.

1. Click cell C3.

2. On the Home tab, in the Editing group, click the Sort & Filter button and 
then, in the list, click Sort A to Z.

Excel sorts the data by season, with the seasons listed in alphabetical order.

3. In the Sort & Filter list, click Custom Sort.

The Sort dialog box opens and displays the parameters of the sort you just 
applied.

4. If it’s not already selected, select the My data has headers check box.

5. In the Column list, click Customer. If necessary, in the Sort On list, click Values; 
then in the Order list, click A to Z.

6. Click Add Level.

A new Then By sorting level appears.
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7. In the new Column list, click Revenue.

8. In the new Order list, click Largest to Smallest.

9. Click OK.

Excel closes the Sort dialog box and sorts the data list.
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10. In the Sort & Filter list, click Custom Sort.

The Sort dialog box opens.

11. Click Then by.

Excel highlights the Revenue sorting rule.

12. Click the Move Up button.

Excel moves the Revenue sorting rule above the Customer sorting rule.

13. Click OK.

Excel closes the Sort dialog box and sorts the data list.

14. Select cells G4:G7, click the File tab, and then click Options.

The Excel Options dialog box opens.

15. On the Advanced page, in the General group toward the bottom of the page, 
click Edit Custom Lists.

The Custom Lists dialog box opens.

16. Verify that the cell range $G$4:$G$7 appears in the Import list from cells field, 
and then click Import.

The new list appears in the Custom Lists pane.
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17. Click OK twice to close the Custom Lists dialog box and the Excel Options 
dialog box.

18. Click cell C3.

19. On the Home tab, in the Editing group, click Sort & Filter, and then click 
Custom Sort.

The Sort dialog box opens, displaying the sorting operation you defined earlier.

20. Click the rule in the Sort by row, and then click Delete Level.

The sorting rule disappears.

21. If necessary, in the new Sort by row, in the Column list, click Season.

22. In the same row, in the Order list, click Custom List.

The Custom Lists dialog box opens.

23. In the Custom lists pane, click the sequence Spring, Summer, Fall, Winter.

24. Click OK twice to close the Custom Lists dialog box and the Sort dialog box.

Excel sorts the data list.
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25. Click cell C3. Then on the Home tab, in the Editing group, click Sort & Filter, 
and click Custom Sort.

The Sort dialog box opens.

26. In the Sort by row, in the Column list, click Revenue.

27. In the Sort on list, click Cell Color.

28. In the new list control that appears in the Sort by row, click On Bottom to have 
Excel put the Revenue cells that have no cell color on the bottom.

29. Click OK.

Excel sorts the data list.

CLEAN UP Save the ShippingSummary workbook, and then close it.
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Organizing Data into Levels
After you have sorted the rows in an Excel worksheet or entered the data so that it 
doesn’t need to be sorted, you can have Excel calculate subtotals or totals for a portion 
of the data. In a worksheet with sales data for three different product categories, for 
example, you can sort the products by category, select all the cells that contain data, 
and then open the Subtotal dialog box. To open the Subtotal dialog box, display the 
Data tab and then, in the Outline group, click Subtotal.

In the Subtotal dialog box, you can choose the column on which to base your subtotals 
(such as every change of value in the Week column), the summary calculation you want 
to perform, and the column or columns with values to be summarized. After you define 
your subtotals, they appear in your worksheet.
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Troubleshooting The appearance of buttons and groups on the ribbon changes depending 
on the width of the program window. For information about changing the appearance of 
the ribbon to match our screen images, see “Modifying the Display of the Ribbon” at the 
beginning of this book.

When you add subtotals to a worksheet, Excel also defines groups based on the rows 
used to calculate a subtotal. The groupings form an outline of your worksheet based 
on the criteria you used to create the subtotals. For example, all the rows representing 
months in the year 2009 could be in one group, rows representing months in 2010 in  
another, and so on. The outline area at the left of your worksheet holds controls you 
can use to hide or display groups of rows in your worksheet.
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Three types of controls can appear in the outline area: Hide Detail buttons, Show Detail 
buttons, and level buttons. The Hide Detail button beside a group can be clicked to 
hide the rows in that group. In a worksheet that has a subtotal group consisting of 
rows 2 through 13, clicking the Hide Detail button next to row 14 would hide rows 2 
through 13 but leave the row holding the subtotal for that group, row 14, visible.

Show detail

Hide detail

When you hide a group of rows, the button displayed next to the group changes to 
a Show Detail button. Clicking a group’s Show Detail button restores the rows in the 
group to the worksheet.
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The level buttons are the other buttons in the outline area of a worksheet with subtotals. 
Each button represents a level of organization in a worksheet; clicking a level button hides 
all levels of detail below that of the button you clicked. The following table describes the 
data contained at each level of a worksheet with three levels of organization.

Level Description
1 Grand total
2 Subtotals for each group

3 Individual rows in the worksheet

Clicking the Level 2 button in the worksheet would hide the rows with data on, for  
example, each month’s revenue but would leave the row that contains the grand total  
(Level 1) and all rows that contain the subtotal for each year (Level 2) visible in the 
worksheet.

If you like, you can add levels of detail to the outline that Excel creates. For example, 
you might want to be able to hide revenues from January and February, which you 
know are traditionally strong months. To create a new outline group within an existing 
group, select the rows you want to group; on the Data tab, in the Outline group, point 
to Group, and then click Group. 
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You can remove a group by selecting the rows in the group and then, in the Outline 
group, clicking Ungroup.

Tip If you want to remove all subtotals from a worksheet, open the Subtotal dialog box, and 
click the Remove All button.

In this exercise, you’ll add subtotals to a worksheet and then use the outline that appears 
to show and hide different groups of data in your worksheet.

SET UP You need the GroupByQuarter_start workbook located in your Chapter06 
practice file folder to complete this exercise. Open the GroupByQuarter_start 
workbook, and save it as GroupByQuarter. Then follow the steps. 

1. Click any cell in the data list.

2. On the Data tab, in the Outline group, click Subtotal.

The Subtotal dialog box opens with the default options to add a subtotal at every 
change in the Year column, to return the sum of the values in the subtotaled rows, 
and to add a row with the subtotal of values in the Package Volume column below 
the final selected row.
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3. Click OK.

The Subtotal dialog box closes. New rows appear with subtotals for package volume 
during each year represented in the worksheet. The new rows are numbered 14 and 
27. A row with the grand total of all rows also appears; that row is row 28. A new area 
with outline bars and group-level indicators appears to the left of column A.

4. Click the row heading of row 5, and drag to the row heading of row 7.

Rows 5 through 7 are selected.

5. On the Data tab, in the Outline group, click Group.

Rows 5 through 7 are made into a new group. An outline bar appears on a new 
level in the outline area, and a corresponding Level 4 button appears at the top of 
the outline area.

6. In the outline area, click the Hide Detail button next to row 8.

Rows 5 through 7 are hidden, and the Hide Detail button you clicked changes to a 
Show Detail button.
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7. In the outline area, click the Show Detail button next to row 8.

Rows 5 through 7 reappear.

8. In the outline area, click the Level 1 button.

All rows except row 1 with the column headings and row 28 with the grand total 
are hidden.

9. In the outline area, click the Level 2 button.

The rows with the subtotal for each year appear.

10. In the outline area, click the Level 3 button.

All rows except rows 5 through 7 appear.

11. In the outline area, click the Level 4 button.

Rows 5 through 7 reappear.

CLEAN UP Save the GroupByQuarter workbook, and then close it.
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Looking Up Information in a Worksheet
Whenever you create a worksheet that holds information about a list of distinct items, 
such as products offered for sale by a company, you should ensure that at least one 
column in the list contains a unique value that distinguishes that row (and the item the 
row represents) from every other row in the list. Assigning each row a column that con-
tains a unique value means that you can associate data in one list with data in another 
list. For example, if you assign every customer a unique identification number, you can 
store a customer’s contact information in one worksheet and all orders for that customer 
in another worksheet. You can then associate the customer’s orders and contact infor-
mation without writing the contact information in a worksheet every time the customer 
places an order.

In the case of shipments handled by Consolidated Messenger, the column that contains 
those unique values, also known as the primary key column, is the ShipmentID column.
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If you know a shipment’s ShipmentID, it’s no trouble to look through a list of 20 or 30 
items to find a particular shipment. If, however, you have a list of many thousands of 
shipments, looking through the list to find one would take quite a bit of time. Instead, 
you can use the VLOOKUP function to let your colleagues type a ShipmentID in a cell 
and have the corresponding details appear in another cell.

The VLOOKUP function finds a value in the leftmost column of a named range, such as 
a table, and then returns the value from the specified cell to the right of the cell with 
the found value. A properly formed VLOOKUP function has four arguments (data that is 
passed to the function), as shown in the following definition: =VLOOKUP(lookup_value, 
table_array, col_index_num, range_lookup). 

The following table summarizes the values Excel expects for each of these arguments.

Argument Expected value
lookup_value The value to be found in the first column of the named range specified by 

the table_array argument. The lookup_value argument can be a value, a 
cell reference, or a text string.

table_array The multicolumn range or name of the range or data table to be searched.

col_index_num The number of the column in the named range with the value to be  
returned.

range_lookup A TRUE or FALSE value, indicating whether the function should find an 
approximate match (TRUE) or an exact match (FALSE) for the lookup_value. 
If left blank, the default value for this argument is TRUE.

Important When range_lookup is left blank or set to TRUE, for VLOOKUP to work properly the 
rows in the named range specified in the table_array argument must be sorted in ascending 
order based on the values in the leftmost column of the named range.

The VLOOKUP function works a bit differently depending on whether the range_lookup 
argument is set to TRUE or FALSE. The following list summarizes how the function works 
based on the value of range_lookup:

● If the range_lookup argument is left blank or set to TRUE, and VLOOKUP doesn’t 
find an exact match for lookup_value, the function returns the largest value that is 
less than lookup_value.

● If the range_lookup argument is left blank or set to TRUE, and lookup_value is 
smaller than the smallest value in the named range, an #N/A error is returned.
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● If the range_lookup argument is left blank or set to TRUE, and lookup_value is larger 
than all values in the named range, the largest value in the named range is returned.

● If the range_lookup argument is set to FALSE, and VLOOKUP doesn’t find an exact 
match for lookup_value, the function returns an #N/A error.

As an example of a VLOOKUP function, consider the following data, which shows 
an Excel table with its headers in row 2 and the first column in column B of the 
worksheet. 

CustomerID Customer
CI01 Fabrikam
CI02 Northwind Traders

CI03 Tailspin Toys

CI04 Contoso

If the =VLOOKUP (E3, Table1, 2, TRUE) formula is used, when you type CI02 in cell E3 
and press Enter, the VLOOKUP function searches the first column of the table, finds an 
exact match, and returns the value Northwind Traders to cell F3.
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Tip The relatedHLOOKUP function matches a value in a column of the first row of a table 
and returns the value in the specified row number of the same column. The letter “H” in  
the HLOOKUP function name refers to the horizontal layout of the data, just as the “V” in the 
VLOOKUP function name refers to the data’s vertical layout. For more information on using 
the HLOOKUP function, click the Excel Help button, type HLOOKUP in the search terms box, 
and then click Search.

Important Be sure to give the cell in which you type the VLOOKUP formula the same format 
as the data you want the formula to display. For example, if you create a VLOOKUP formula 
in cell G14 that finds a date, you must apply a date cell format to cell G14 for the result of the 
formula to display properly.

In this exercise, you’ll create a VLOOKUP function to return the destination postal code 
of deliveries with ShipmentIDs typed in a specific cell.

SET UP You need the ShipmentLog_start workbook located in your Chapter06 practice 
file folder to complete this exercise. Open the ShipmentLog_start workbook, and save 
it as ShipmentLog. Then follow the steps. 

1. In cell C3, type the formula =VLOOKUP(B3, Shipments, 5, FALSE).

Cell B3, which the formula uses to look up values in the Shipments table, is blank, 
so the #N/A error code appears in cell C3.

2. In cell B3, type SI3049224, and press Enter.

The value 51102 appears in cell C3.

3. In cell C3, edit the formula so that it reads =VLOOKUP(B3, Shipments, 2, FALSE).

The formula now finds its target value in table column 2 (the CustomerID column), 
so the value CI512191 appears in cell C3.

4. In cell C3, edit the formula so that it reads =VLOOKUP(B3, Shipments, 4, TRUE). 

Changing the last argument to TRUE enables the VLOOKUP formula to find an approx-
imate match for the ShipmentID in cell B3, whereas changing the column to 4 means 
the formula gets its result from the OriginationPostalCode column. The value 14020 
appears in cell C3.
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5. In cell B3, type SI3049209.

The value in cell B3 is smaller than the smallest value in the Shipments table’s first 
column, so the VLOOKUP formula displays the #N/A error code in cell C3.

6. In cell B3, type SI3049245.

The ShipmentID typed into cell B3 is greater than the last value in the table’s first 
column, so the VLOOKUP formula displays the last value in the target column (in 
this case, the fourth column). Therefore, the value 44493 appears in cell C3.

CLEAN UP Save the ShipmentLog workbook, and then close it. If you are not 
continuing directly to the next chapter, exit Excel.
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Key Points
● You can rearrange the data in a worksheet quickly by clicking either the Sort 

Ascending or Sort Descending button in the Sort & Filter group on the Data tab.

● Don’t forget that you can sort the rows in a worksheet by using orders other than 
alphabetical or numerical. For example, you can sort a series of days based on their 
order in the week or by cell color.

● If none of the existing sort orders (days, weekdays, and so on) meets your needs, 
you can create your own custom sort order.

● You can divide the data in your worksheet into levels and find a subtotal for each 
level.

● Creating subtotals enables you to show or hide groups of data in your worksheets.

● Use the VLOOKUP function to look up a value in one column of data and return a 
value from another column in the same row.
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7 Combining Data 
from Multiple  
Sources

In this chapter, you will learn how to
✔ Use workbooks as templates for other workbooks.
✔ Link to data in other worksheets and workbooks.
✔ Consolidate multiple sets of data into a single workbook.
✔ Group multiple sets of data.

Microsoft Excel 2010 gives you a wide range of tools with which to format, summarize, 
and present your data. After you have created a workbook to hold data about a particu-
lar subject, you can create as many worksheets as you need to make that data easier to 
find within your workbook. For example, you can create a workbook to store sales data 
for a year, with each worksheet representing a month in that year. To ensure that every 
year’s workbook has a similar appearance, you can create a workbook with the desired 
characteristics (such as more than the standard number of worksheets, custom worksheet 
formatting, or a particular color for the workbook’s sheet tabs) and save it as a pattern, 
or template, for similar workbooks you will create in the future. The benefit of ensuring 
that all your sales data worksheets have the same layout is that you and your colleagues 
immediately know where to look for specific totals. You can use that knowledge to sum-
marize, or consolidate, that data into a single worksheet.

If you work with the same set of workbooks repeatedly, you can group those workbooks 
in a special type of Excel file called a workspace. When you open the workspace, Excel 
knows to open the files you included in that workspace.
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A consequence of organizing your data into different workbooks and worksheets is that 
you need ways to manage, combine, and summarize data from more than one Excel 
document. You can always copy data from one worksheet to another, but if the original 
value were to change, that change would not be reflected in the cell range to which you 
copied the data. Rather than remembering which cells you need to update when a value 
changes, you can create a link to the original cell. That way, Excel will update the value for 
you whenever you open the workbook. If multiple worksheets hold related values, you can 
use links to summarize those values in a single worksheet.

In this chapter, you’ll learn how to use a workbook as a template for other workbooks, 
work with more than one set of data, link to data in other workbooks, summarize 
multiple sets of data, and group multiple workbooks.

Practice Files Before you can complete the exercises in this chapter, you need to copy 
the book’s practice files to your computer. The practice files you’ll use to complete the 
exercises in this chapter are in the Chapter07 practice file folder. A complete list of 
practice files is provided in “Using the Practice Files” at the beginning of this book.

Using Workbooks as Templates for Other 
Workbooks

After you decide on the type of data you want to store in a workbook and what that work-
book should look like, you probably want to be able to create similar workbooks without 
adding all of the formatting and formulas again. For example, you might have established 
a design for your monthly sales-tracking workbook.

When you have settled on a design for your workbooks, you can save one of the work-
books as a template for similar workbooks you will create in the future. You can leave 
the workbook’s labels to aid data entry, but you should remove any existing data from 
a workbook that you save as a template, both to avoid data entry errors and to remove 
any confusion as to whether the workbook is a template. You can also remove any work-
sheets you and your colleagues won’t need by right-clicking the tab of an unneeded 
worksheet and, on the shortcut menu that appears, clicking Delete.

If you want your template workbook to have more than the standard number of work-
sheets (such as 12 worksheets to track shipments for a year, by month), you can add 
worksheets by clicking the Insert Worksheet button that appears to the right of the 
existing worksheet tabs.
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To create a template from an existing workbook, save the model workbook as an Excel 
template file (a file with an .xltx extension), which is a file format you can choose from the 
Save As Type list in the Save As dialog box. If you ever want to change the template, you 
can open it like a standard workbook and make your changes. When you have completed 
your work, save the file by clicking the Save button on the Quick Access Toolbar—it will 
still be a template.

Tip You can also save your Excel 2010 workbook either as an Excel 97–2003 template (.xlt) or 
as a macro-enabled Excel 2010 workbook template (.xltm). For information on using macros in 
Excel 2010 workbooks, see “Introducing Macros” in Chapter 12, “Automating Repetitive Tasks 
by Using Macros.”

After you save a workbook as a template, you can use it as a model for new workbooks. 
To create a workbook from a template in Excel, click the File tab to display the Backstage 
view, and then click New.

When you click New in the Backstage view, the top of the middle pane displays the blank 
workbook template, templates you have used recently, sample templates, and templates 
you created. Below that list is a set of template categories available through the Office.com 
Web site and a search box you can use to locate helpful templates on Office.com.
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Tip When you display the New page of the Backstage view, you can also find templates and 
other tools related to your job functions by clicking the More Templates folder at the bottom 
of the Office.com Templates area of the page.

From the list of available templates, you can double-click the template you want to use 
as the model for your workbook. Excel creates a new workbook (an .xlsx workbook file, 
not an .xlst template file) with the template’s formatting and contents in place.

In addition to creating a workbook template, you can create a template to add as a work-
sheet within an existing workbook. To create a worksheet template, design the worksheet 
you want to use as a template, delete all the other worksheets in that workbook, and save 
the single-sheet workbook as a template. You can then add a worksheet based on that 
template to your workbook by right-clicking a sheet tab and then clicking Insert to display 
the Insert dialog box.

The Insert dialog box splits its contents into two pages. The General page contains icons 
you can click to insert a blank worksheet, a chart sheet, and any worksheet templates you 
have created. 

Tip The other two options on the General page, MS Excel 4.0 Macro and MS Excel 5.0 Dialog, 
are there to help users integrate older Excel spreadsheet solutions into Excel 2010.

The Spreadsheet Solutions page contains a set of useful templates for a variety of financial 
and personal tasks.
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To add a spreadsheet from the Insert dialog box to your workbook, click the desired 
template, and then click OK. When you click a template, a preview of that template’s 
contents appears in the preview pane, so you can verify you’ve selected the template 
you want.

In this exercise, you’ll create a workbook from an existing template, save a template 
to track hourly call volumes to each regional center, save another version of the file 
as a worksheet template, and insert a worksheet based on that template into a new 
workbook.

SET UP You need the DailyCallSummary_start workbook located in your 
Chapter07 practice file folder to complete this exercise. Start Excel, open  
the DailyCallSummary_start workbook, and save it as DailyCallSummary. 
Then follow the steps. 

1. Click the File tab, and then click Save As.

The Save As dialog box opens.

2. In the Save as type list, click Excel Template.

Excel displays the default Microsoft Office template folder.
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3. Click Save.

Excel saves the workbook as a template and closes the Save As dialog box.

4. Click the File tab, and then click Close.

Excel closes the DailyCallSummary workbook.

5. Click the File tab, and then click New.

The New Workbook dialog box opens.

6. In the Available Templates list, click Sample Templates.

The Sample Templates gallery appears.

7. Click Expense Report, and then click Create.

Excel creates a workbook based on the selected template.
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Troubleshooting The appearance of buttons and groups on the ribbon changes depending 
on the width of the program window. For information about changing the appearance of 
the ribbon to match our screen images, see “Modifying the Display of the Ribbon” at the 
beginning of this book.

8. On the Quick Access Toolbar, click the Save button.

The Save As dialog box opens.

9. In the File name box, type ExpenseReport. Use the dialog box controls to browse 
to the Chapter07 folder, and then click Save.

Excel saves your workbook.

10. Click the File tab to display the Backstage view, click Recent, and then, in the Recent 
Workbooks list, click the DailyCallSummary workbook file (not the template).

The DailyCallSummary file is displayed.
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11. Right-click the Sheet2 sheet tab, and then click Delete.

Excel deletes the worksheet, leaving one worksheet in the workbook.

12. Click the File tab, and then click Save As.

The Save As dialog box opens.

13. In the File name box, type DailyCallWorksheet.

14. If necessary, in the Save as type list, click Excel Template.

15. Click Save.

Excel saves your template.

16. Click the File tab, and then click Close.

Excel closes the template.

17. Click the File tab, and then click New.

The New Workbook dialog box opens.

18. Click Blank Workbook, and then click Create.

A blank workbook is displayed.

19. Right-click any sheet tab, and then click Insert.

The Insert dialog box opens.
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20. On the General page, click DailyCallWorksheet, and then click OK.

Excel creates a new worksheet based on the template.

21. On the Quick Access Toolbar, click the Save button.

The Save As dialog box opens.

22. In the File name box, type CurrentCallSummary. Use the dialog box controls to 
browse to the Chapter07 folder, and then click Save.

Excel saves your workbook.

CLEAN UP Close the CurrentCallSummary workbook.

Linking to Data in Other Worksheets and 
Workbooks

Copying and pasting data from one workbook to another is a quick and easy way to gather 
related data in one place, but there is a substantial limitation: If the data from the original 
cell changes, the change is not reflected in the cell to which the data was copied. In other 
words, copying and pasting a cell’s contents doesn’t create a relationship between the 
original cell and the target cell.
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You can ensure that the data in the target cell reflects any changes in the original cell by 
creating a link between the two cells. Instead of entering a value into the target cell by 
typing or pasting, you create a formula that identifies the source from which Excel will 
derive the target cell’s value and updates the value when it changes in the source cell.

To create a link between cells, open both the workbook that contains the cell from which 
you want to pull the value and the workbook with the target cell. Then click the target 
cell and type an equal sign, signifying that you want to create a formula. After you type 
the equal sign, activate the workbook with the cell from which you want to derive the 
value, click that cell, and then press the Enter key.

When you switch back to the workbook with the target cell, you see that Excel has filled 
in the formula with a reference to the cell you clicked.

For example, the reference =’[FleetOperatingCosts.xlsx]Truck Fuel’!$C$15 gives three 
pieces of information: the workbook, the worksheet, and the cell you clicked in the 
worksheet. The first element of the reference, the name of the workbook, is enclosed 
in square brackets; the end of the second element (the worksheet) is marked with an 
exclamation point; and the third element, the cell reference, has a dollar sign before 
both the row and the column identifier. The single quotes around the workbook name 
and worksheet name are there to account for the space in the Truck Fuel worksheet’s 
name. This type of reference is known as a 3-D reference, reflecting the three dimen-
sions (workbook, worksheet, and cell range) that you need to point to a group of cells 
in another workbook.
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Tip For references to cells in the same workbook, the workbook information is omitted. 
Likewise, references to cells in the same worksheet don’t use a worksheet identifier.

You can also link to cells in an Excel table. Such links include the workbook name, work-
sheet name, name of the Excel table, and row and column references of the cell to which 
you’ve linked. Creating a link to the Cost column’s cell in a table’s Totals row, for example, 
results in a reference such as =’FleetOperatingCosts.xlsx’!Truck Maintenance[[#Totals],[Cost]]. 

Important Hiding or displaying a table’s Totals row affects any links to a cell in that row. 
Hiding the Totals row causes references to that row to display a #REF! error message.

Whenever you open a workbook containing a link to another document, Excel tries to 
update the information in linked cells. If the program can’t find the source, as would 
happen if a workbook or worksheet is deleted or renamed, an alert box appears to 
indicate that there is a broken link. At that point, you can click the Update button 
and then the Edit Links button to open the Edit Links dialog box and find which link 
is broken. After you identify the broken link, you can close the Edit Links dialog box, 
click the cell containing the broken link, and create a new link to the desired data.

If you type a link and you make an error, a #REF! error message appears in the cell that 
contains the link. To fix the link, click the cell, delete its contents, and then either retype 
the link or create it with the point-and-click method described earlier in this section.

Tip Excel tracks workbook changes, such as when you change a workbook’s name, very well. 
Unless you delete a worksheet or workbook, or move a workbook to a new folder, odds are 
good that Excel can update your link references automatically to reflect the change.

In this exercise, you’ll create a link to another workbook, make the link’s reference invalid, 
use the Edit Links dialog box to break the link, and then re-create the link correctly.

SET UP You need the OperatingExpenseDashboard_start and FleetOperatingCosts_start 
workbooks located in your Chapter07 practice file folder to complete this exercise. 
Open the OperatingExpenseDashboard_start and FleetOperatingCosts_start workbooks, 
and save them as OperatingExpenseDashboard and FleetOperatingCosts, respectively. 
Then follow the steps.

1. In the OperatingExpenseDashboard workbook, in cell I6, type =, but do not 
press Enter.

2. On the View tab, in the Window group, click Switch Windows and then, in the 
list, click FleetOperatingCosts.

The FleetOperatingCosts workbook is displayed.
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3. If necessary, click the Plane Repair sheet tab to display the Plane Repair worksheet, 
and then click cell C15.

Excel sets the cell’s formula to =’[FleetOperatingCosts.xlsx]Plane Repair’!$C$15.

4. Press Enter.

Excel displays the OperatingExpenseDashboard workbook; the value $2,410,871 
appears in cell I6.

Tip Yes, cell C15 on the Plane Repair worksheet contains the wrong total for the 
Airplane Fuel category; that’s why you replace it later in this exercise.

5. In the Switch Windows list, click FleetOperatingCosts.

The FleetOperatingCosts workbook is displayed.

6. Right-click the Plane Repair sheet tab, and then click Delete. In the message box 
that appears, click Delete to confirm that you want to delete the worksheet.

Excel deletes the Plane Repair worksheet.

7. In the Switch Windows list, click OperatingExpenseDashboard.

The OperatingExpenseDashboard workbook is displayed, showing a #REF! error in 
cell I6.
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8. On the Data tab, in the Connections group, click Edit Links.

The Edit Links dialog box opens.

9. Click Break Link.

Excel displays a warning box asking if you’re sure you want to break the link.

10. Click Break Links.

The warning box closes, and Excel removes the link from the workbook.

11. Click Close.

The Edit Links dialog box closes.
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12. In cell I6, type =, but do not press Enter.

13. In the Switch Windows list, click FleetOperatingCosts.

The FleetOperatingCosts workbook is displayed.

14. Click the Plane Fuel sheet tab.

The Plane Fuel worksheet is displayed.

15. Click cell C15, and then press Enter.

Excel displays the OperatingExpenseDashboard workbook with the value 
$52,466,303 in cell I6.

CLEAN UP Save the OperatingExpenseDashboard and FleetOperatingCosts 
workbooks, and then close them.

Consolidating Multiple Sets of Data into a Single 
Workbook

When you create a series of worksheets that contain similar data, perhaps by using  
a template, you build a consistent set of workbooks in which data is stored in a pre-
dictable place. For example, consider a workbook template that uses cell C5 to record 
the number of calls received from 9:00 A.M. to 10:00 P.M. by the Northeast distribu-
tion center.
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Using links to bring data from one worksheet to another gives you a great deal of power 
to combine data from several sources into a single resource. For example, you can create a 
worksheet that lists the total revenue just for certain months of a year, use links to draw 
the values from the worksheets in which the sales were recorded, and then create a for-
mula to perform calculations on the data. However, for large worksheets with hundreds 
of cells filled with data, creating links from every cell is a time-consuming process. Also, 
to calculate a sum or an average for the data, you would need to include links to cells in 
every workbook.

Fortunately, there is an easier way to combine data from multiple worksheets in a single 
worksheet. This process, called data consolidation, enables you to define ranges of cells 
from multiple worksheets and have Excel summarize the data. You define these ranges 
in the Consolidate dialog box.
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After you open the dialog box, you move to the worksheet that contains the first cell range 
you want to include in your summary. When you select the cells, the 3-D reference for 
the range appears in the Consolidate dialog box. Clicking Add stores the reference. You 
can then choose the other cell ranges that contain data you want to include in the sum-
mary, or you can remove a range from the calculation by clicking the range and then 
clicking Delete. 

Cells that are in the same relative position in the ranges have their contents summarized 
together. When you consolidate the ranges, the cell in the upper-left corner of one range 
is added to the cell in the upper-left corner of every other range, even if those ranges are in  
different areas of the worksheet. After you choose the ranges to be used in your sum-
mary, you can choose the calculation to perform on the data (sum, average, and so on). 
When you’re done selecting ranges to use in the calculation, click OK to have Excel sum-
marize the data on your target worksheet.

Important You can define only one data consolidation summary per workbook.

In this exercise, you’ll define a data consolidation range consisting of ranges from two 
other workbooks. You’ll then add the contents of the ranges and show the results in a 
worksheet.

SET UP You need the Consolidate_start, JanuaryCalls_start, and FebruaryCalls_start 
workbooks located in your Chapter07 practice file folder to complete this exercise. 
Open the Consolidate_start, JanuaryCalls_start, and FebruaryCalls_start workbooks, 
and save them as Consolidate, JanuaryCalls, and FebruaryCalls, respectively. Then 
follow the steps. 

1. In the Consolidate workbook, on the Data tab, in the Data Tools group, click 
Consolidate.

The Consolidate dialog box opens.

2. Click the Collapse Dialog button at the right edge of the Reference field.

The Consolidate dialog box contracts.
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3. On the View tab, in the Window group, click Switch Windows and then, in the 
list, click JanuaryCalls.

The JanuaryCalls workbook is displayed.

4. Select the cell range C5:O13, and then click the Expand Dialog button.

The Consolidate dialog box is restored to its full size.

5. Click Add.

The range you selected appears in the All References pane.

6. Click the Collapse Dialog button at the right edge of the Reference field.

The Consolidate dialog box contracts.

7. In the Switch Windows list, click FebruaryCalls.

The FebruaryCalls workbook is displayed.

8. Select the cell range C5:O13, and then click the Expand Dialog button.

The Consolidate dialog box is restored to its full size.

9. Click Add.

The range ‘[FebruaryCalls.xlsx]February’!$C$5:$O$13 appears in the All References 
pane.
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10. Click OK.

Excel consolidates the JanuaryCalls and FebruaryCalls workbook data into the range 
C5:O13 in the Consolidate workbook. You didn’t change the SUM operation in the 
Function box, so the values in the Consolidate workbook are the sum of the other 
workbooks’ values.

CLEAN UP Save the Consolidate, JanuaryCalls, and FebruaryCalls workbooks, and 
then close them.

Grouping Multiple Sets of Data
When you work with Excel for a while, you’ll find that you often open a number of the 
same workbooks at the same time. For instance, Lori Penor, the chief operating officer of 
Consolidated Messenger, might always pull up a workbook that tracks labor costs at the 
same time she opens the package volume summary workbook. She can open the work-
books individually through the Open dialog box, but she can also group the files so that 
she has the option of opening them all simultaneously.

If you want to open a set of files simultaneously, you can define them as part of a work-
space, which uses one file name to reference several workbooks. To define a workspace, 
you open the files you want to include and then open the Save Workspace dialog box.
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Clicking Save in the Save Workspace dialog box saves references to all the Excel files that 
are currently open. Whenever you open the workspace you create, all the files that were 
open when you defined the workspace are displayed. Including a file in a workspace 
doesn’t remove it from general circulation; you can still open it by itself.

In this exercise, you’ll save a workspace that consists of two workbooks, close the included 
files, and then test the workspace by opening it from the Open dialog box.

SET UP You need the OperatingExpenseDashboard and FleetOperatingCosts 
workbooks you created in the second exercise in this chapter to complete this  
exercise. If you did not complete that exercise, you should do so now. Open the  
OperatingExpenseDashboard and FleetOperatingCosts workbooks. Then follow  
the steps. 

1. In either workbook, on the View tab, in the Window group, click Save 
Workspace.

The Save Workspace dialog box opens.

Grouping Multiple Sets of Data  185

www.it-ebooks.info

http://www.it-ebooks.info/


186  Chapter 7 Combining Data from Multiple Sources

2. In the File name field, type Expenses.

3. Click Save.

Excel saves your workspace and closes the Save Workspace dialog box.

4. Click the File tab, and then click Close.

Excel closes the active workbook.

5. Click the File tab, and then click Close.

Excel closes the second workbook.

6. Click the File tab and (if necessary), click Recent. In the Recent Workbooks 
list, click Expenses.xlw.

Excel opens the OperatingExpenseDashboard and FleetOperatingCosts 
workbooks.

CLEAN UP Close the OperatingExpenseDashboard and FleetOperatingCosts 
workbooks. If you are not continuing directly to the next chapter, exit Excel.
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Key Points
● If you create a lot of workbooks with the same layout and design, saving a workbook 

with the common elements (and no data) will save you time when you create similar 
workbooks in the future.

● You can use data in other worksheets or workbooks in your formulas. You make the 
link by clicking the cell, which creates a 3-D reference to that cell.

● When you create a link to a cell in a table’s Totals row, hiding the Totals row causes 
Excel to display a #REF! error in the cell where you created the link.

● If you always work on a group of workbooks at the same time, create a workspace 
so that you can open them all at once.
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8 Analyzing 
Alternative  
Data Sets

In this chapter, you will learn how to
✔ Define an alternative data set.
✔ Define multiple alternative data sets.
✔ Vary your data to get a desired result by using Goal Seek.
✔ Find optimal solutions by using Solver.
✔ Analyze data by using descriptive statistics.

When you store data in a Microsoft Excel 2010 workbook, you can use that data, either  
by itself or as part of a calculation, to discover important information about your organi- 
zation. When you track total sales on a time basis, you can find your best and worst sales 
periods and correlate them with outside events. For businesses such as Consolidated 
Messenger, package volume increases dramatically during the holidays as customers 
ship gifts to friends and family members.

The data in your orksheets is great for answering the question, “What happened?” The data 
is less useful for answering “what-if” questions, such as, “How much money would we save 
if we reduced our labor to 20 percent of our total costs?” You can always save an alternative 
version of a workbook and create formulas that calculate the effects of your changes, but 
you can do the same thing in your existing workbooks by defining one or more alternative 
data sets and switching between the original data and the new sets you create.

Excel also provides the tools to determine the input values that would be required for a 
formula to produce a given result. For example, the chief operating officer of Consolidated 
Messenger, Lori Penor, could find out to what level the revenues from three-day shipping 
would need to rise for that category to account for 25 percent of total revenue.

In this chapter, you’ll learn how to define alternative data sets and determine the necessary 
inputs to make a calculation produce a particular result.
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Practice Files Before you can complete the exercises in this chapter, you need to copy 
the book’s practice files to your computer. The practice files you’ll use to complete the 
exercises in this chapter are in the Chapter08 practice file folder. A complete list of 
practice files is provided in “Using the Practice Files” at the beginning of this book.

Defining an Alternative Data Set
When you save data in an Excel worksheet, you create a record that reflects the character-
istics of an event or object. That data could represent the number of deliveries in an hour 
on a particular day, the price of a new delivery option, or the percentage of total revenue 
accounted for by a delivery option. After the data is in place, you can create formulas to 
generate totals, find averages, and sort the rows in a worksheet based on the contents of 
one or more columns. However, if you want to perform a what-if analysis or explore the 
impact that changes in your data would have on any of the calculations in your workbooks, 
you need to change your data.

The problem with manipulating data that reflects an event or item is that when you change 
any data to affect a calculation you run the risk of destroying the original data if you acci-
dentally save your changes. You can avoid ruining your original data by creating a duplicate 
workbook and making your changes to it, but you can also create alternative data sets, or 
scenarios, within an existing workbook.

When you create a scenario, you give Excel alternative values for a list of cells in a 
worksheet. You can use the Scenario Manager to add, delete, and edit scenarios.
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Clicking the Add button displays the Add Scenario dialog box.

From within this dialog box, you can name the scenario and identify the cells for which 
you want to define alternative values. After you click OK, a new dialog box opens with 
spaces for you to type the new values.

Clicking OK returns you to the Scenario Manager dialog box. From there, clicking the Show 
button replaces the values in the original worksheet with the alternative values you just 
defined in the scenario. Any formulas referencing cells with changed values will recalculate 
their results. You can then remove the scenario by clicking the Undo button on the Quick 
Access Toolbar.

Important If you save and close a workbook while a scenario is in effect, those values become 
the default values for the cells changed by the scenario! You should seriously consider creating 
a scenario that contains the original values of the cells you change or creating a scenario 
summary worksheet (a topic covered in the next section).
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In this exercise, you’ll create a scenario to measure the projected impact on total revenue 
of a rate increase on two-day shipping.

SET UP You need the 2DayScenario_start workbook located in your Chapter08 
practice file folder to complete this exercise. Start Excel, open the 2DayScenario_start 
workbook, and save it as 2DayScenario. Then follow the steps. 

1. On the Data tab, in the Data Tools group, click What-If Analysis and then, in the 
list, click Scenario Manager.

The Scenario Manager dialog box opens.

2. Click Add.

The Add Scenario dialog box opens.

3. In the Scenario name field, type 2DayIncrease.

4. At the right edge of the Changing cells field, click the Collapse Dialog button so 
the worksheet contents are visible.

The Add Scenario dialog box collapses.

5. In the worksheet, click cell C5 and then, in the Add Scenario dialog box, click the 
Expand Dialog button.

$C$5 appears in the Changing Cells field, and the dialog box title changes to Edit 
Scenario.

6. Click OK.

The Scenario Values dialog box opens.
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7. In the value field, type 13.2, and then click OK.

The Scenario Values dialog box closes, and the Scenario Manager is displayed again.

8. If necessary, drag the Scenario Manager dialog box to another location on the 
screen so that you can view the entire table.

9. In the Scenario Manager dialog box, click Show.

Excel applies the scenario, changing the value in cell C5 to $13.20, which in turn 
increases the value in cell E8 to $747,450,000.00.

Troubleshooting The appearance of buttons and groups on the ribbon changes depending 
on the width of the program window. For information about changing the appearance of 
the ribbon to match our screen images, see “Modifying the Display of the Ribbon” at the 
beginning of this book.

10. In the Scenario Manager dialog box, click Close.

11. On the Quick Access Toolbar, click the Undo button.

Excel removes the effect of the scenario.

CLEAN UP Save the 2DayScenario workbook, and then close it.
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Defining Multiple Alternative Data Sets
One great feature of Excel scenarios is that you’re not limited to creating one alternative  
data set—you can create as many scenarios as you like and apply them by using the 
Scenario Manager. To apply more than one scenario by using the Scenario Manager, 
click the name of the first scenario you want to display, click the Show button, and 
then do the same for any subsequent scenarios. The values you defined as part of 
those scenarios will appear in your worksheet, and Excel will update any calculations 
involving the changed cells.

Tip If you apply a scenario to a worksheet and then apply another scenario to the same 
worksheet, both sets of changes appear. If multiple scenarios change the same cell, the cell 
will contain the value in the most recently applied scenario.

Applying multiple scenarios alters the values in your worksheets. You can see how those 
changes affect your formulas, but Excel also gives you a way to view the results of all 
your scenarios in a single, separate worksheet. To create a worksheet in your current 
workbook that summarizes the changes caused by your scenarios, open the Scenario 
Manager, and then click the Summary button. When you do, the Scenario Summary 
dialog box opens.

From within the dialog box, you can choose the type of summary worksheet you want to 
create and the cells you want to display in the summary worksheet. To choose the cells 
to display in the summary, click the Collapse Dialog button in the box, select the cells you 
want to display, and then expand the dialog box. After you verify that the range in the 
box represents the cells you want to have included on the summary sheet, click OK to 
create the new worksheet.
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It’s a good idea to create an “undo” scenario named Normal that holds the original values 
of the cells you’re going to change before they’re changed in other scenarios. For example, 
if you create a scenario named High Fuel Costs that changes the sales figures in three cells, 
your Normal scenario restores those cells to their original values. That way, even if you 
accidentally modify your worksheet, you can apply the Normal scenario and not have to 
reconstruct the worksheet from scratch.

Tip Each scenario can change a maximum of 32 cells, so you might need to create more than 
one scenario to ensure that you can restore a worksheet.

In this exercise, you’ll create scenarios to represent projected revenue increases from 
two rate changes, view the scenarios, and then summarize the scenario results in a 
new worksheet.

SET UP You need the MultipleScenarios_start workbook located in your Chapter08 
practice file folder to complete this exercise. Open the MultipleScenarios_start 
workbook, and save it as MultipleScenarios. Then follow the steps. 

1. On the Data tab, in the Data Tools group, click What-If Analysis and then, in the 
list, click Scenario Manager.

The Scenario Manager dialog box opens.

2. Click Add.

The Add Scenario dialog box opens.

3. In the Scenario name field, type 3DayIncrease.

4. At the right edge of the Changing cells field, click the Collapse Dialog button.

The Add Scenario dialog box collapses.

5. In the worksheet, click cell C4 and then, in the dialog box, click the Expand Dialog 
button.

$C$4 appears in the Changing Cells field, and the dialog box title changes to Edit 
Scenario.

6. Click OK.

The Scenario Values dialog box opens.

7. In the value field, type 11.50.
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8. Click OK.

The Scenario Values dialog box closes, and the Scenario Manager is displayed 
again.

9. Click Add.

The Add Scenario dialog box opens.

10. In the Scenario name field, type Ground and Overnight Increase.

11. At the right edge of the Changing cells field, click the Collapse Dialog button.

The Add Scenario dialog box collapses.

12. Click cell C3, hold down the Ctrl key, and click cell C6. Then click the Expand 
Dialog button.

$C$3,$C$6 appears in the Changing Cells field, and the dialog box title changes to 
Edit Scenario.

13. Click OK.

The Scenario Values dialog box opens.

14. In the $C$3 field, type 10.15.

15. In the $C$6 field, type 18.5.

16. Click OK.

The Scenario Values dialog box closes, and the Scenario Manager dialog box is 
displayed again.
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17. Click Summary.

The Scenario Summary dialog box opens.

18. Verify that the Scenario summary option is selected and that cell E8 appears in 
the Result cells field.

19. Click OK.

Excel creates a Scenario Summary worksheet.

CLEAN UP Save the MultipleScenarios workbook, and then close it.
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Varying Your Data to Get a Desired Result  
by Using Goal Seek

When you run an organization, you must track how every element performs, both in 
absolute terms and in relation to other parts of the organization. Just as you might want 
to reward your employees for maintaining a perfect safety record and keeping down 
your insurance rates, you might also want to stop carrying products you cannot sell.

When you plan how you want to grow your business, you should have specific goals in 
mind for each department or product category. For example, Lori Penor of Consolidated 
Messenger might have the goal of reducing the firm’s labor costs by 20 percent as 
compared to the previous year. Finding the labor amount that represents a 20-percent 
decrease is simple, but expressing goals in other ways can make finding the solution 
more challenging. Instead of decreasing labor costs 20 percent over the previous year, 
Lori might want to decrease labor costs so they represent no more than 20 percent of 
the company’s total outlay.

As an example, consider a worksheet that holds cost figures for Consolidated Messenger’s 
operations and uses those figures to calculate both total costs and the share each category 
has of that total.

Important In the worksheet, the values in the Share row are displayed as percentages, but the 
underlying values are decimals. For example, Excel represents 0.3064 as 30.64%.

Although it would certainly be possible to figure the target number that would make labor 
costs represent 20 percent of the total, there is an easier way to do it in Excel: Goal Seek. 
To use Goal Seek, you display the Data tab and then, in the Data Tools group, click What-If 
Analysis. On the menu that is displayed, click Goal Seek to open the Goal Seek dialog box.
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Important If you save a workbook with the results of a Goal Seek calculation in place, you will 
overwrite the values in your workbook.

In the dialog box, you identify the cell with the target value; in this example, it is cell C4, 
which has the percentage of costs accounted for by the Labor category. The To Value 
field has the target value (.2, which is equivalent to 20 percent), and the By Changing 
Cell field identifies the cell with the value Excel should change to generate the target 
value of 20 percent in cell C4. In this example, the cell to be changed is C3.

Clicking OK tells Excel to find a solution for the goal you set. When Excel finishes its 
work, the new values appear in the designated cells, and the Goal Seek Status dialog 
box opens.

Tip Goal Seek finds the closest solution it can without exceeding the target value. In this case, 
the closest percentage it could find was 19.97 percent.

In this exercise, you’ll use Goal Seek to determine how much you need to decrease 
transportation costs so those costs make up no more than 40 percent of Consolidated 
Messenger’s operating costs.

SET UP You need the TargetValues_start workbook located in your Chapter08 
practice file folder to complete this exercise. Open the TargetValues_start workbook, 
and save it as TargetValues. Then follow the steps. 

1. On the Data tab, in the Data Tools group, click What-If Analysis and then, in the 
list, click Goal Seek.
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The Goal Seek dialog box opens.

2. In the Set cell field, type D4.

3. In the To value field, type .4.

4. In the By changing cell field, type D3.

5. Click OK.

Excel displays the solution in both the worksheet and the Goal Seek Status  
dialog box. 

6. Click Cancel.

Excel closes the Goal Seek Status dialog box without saving the new worksheet 
values.

CLEAN UP Save the TargetValues workbook, and then close it.
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Finding Optimal Solutions by Using Solver
Goal Seek is a great tool for finding out how much you need to change a single input 
value to generate a desired result from a formula, but it’s of no help if you want to find 
the best mix of several input values. For example, marketing vice president Craig Dewar 
might want to advertise in four national magazines to drive customers to Consolidated 
Messenger’s Web site, but he might not know the best mix of ads to reach the greatest  
number of readers. He asked the publishers for ad pricing and readership numbers, which 
he recorded in a spreadsheet, along with the minimum number of ads per publication  
(three) and the minimum number of times he wants the ad to be seen (10,000,000). 
Because one of the magazines has a high percentage of corporate executive readers, 
Craig does want to take out at least four ads in that publication, despite its relatively 
low readership. The goal of the ad campaign is for the ads to be seen as many times  
as possible without costing the company more than the $3,000,000 budget.

Tip It helps to spell out every aspect of your problem so that you can identify the cells you 
want Solver to use in its calculations.

If you performed a complete installation when you installed Excel on your computer, 
you see the Solver button on the Data tab in the Analysis group. If not, you need to 
install the Solver Add-In. To do so, click the File tab, and then click Options. In the Excel 
Options dialog box, click Add-Ins to display the Add-Ins page. At the bottom of the 
dialog box, in the Manage list, click Excel Add-Ins, and then click Go to display the 
Add-Ins dialog box. Select the Solver Add-in check box and click OK to install Solver.
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Tip You might be prompted for the Microsoft Office system installation CD. If so, put the CD 
in your CD drive, and click OK.

After the installation is complete, Solver appears on the Data tab, in the Analysis group. 
Clicking Solver displays the Solver Parameters dialog box.

The first step of setting up your Solver problem is to identify the cell that contains the 
summary formula you want to establish as your objective. To identify that cell, click in 
the Set Objective box, click the target cell in the worksheet, and then select the option 
representing whether you want to minimize the cell’s value, maximize the cell’s value, or 
make the cell take on a specific value. Next, you click in the By Changing Variable Cells box 
and select the cells Solver should vary to change the value in the objective cell. Finally, 
you can create constraints that will set the limits for the values Solver can use. To do so, 
click Add to open the Add Constraint dialog box.
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You add constraints to the Solver problem by selecting the cells to which you want to 
apply the constraint, selecting the comparison operation (such as less than or equal 
to, greater than or equal to, or must be an integer), and clicking in the Constraint box 
to select the cell with the value of the constraint. You could also type a value in the 
Constraint box, but referring to a cell makes it possible for you to change the con-
straint later without opening Solver.

Tip After you run Solver, you can use the commands in the Solver Results dialog box to save 
the results as changes to your worksheet or create a scenario based on the changed data.

In this exercise, you’ll use Solver to determine the best mix of ads given the following 
constraints:

● You want to maximize the number of people who see the ads.

● You must buy at least 8 ads in 3 magazines and at least 10 in the fourth.

● You can’t buy part of an ad (that is, all numbers must be integers).

● You can buy no more than 20 ads in any one magazine.

● You must reach at least 10,000,000 people.

● Your ad budget is $3,000,000.

SET UP You need the AdBuy_start workbook located in your Chapter08 practice 
file folder to complete this exercise. Open the AdBuy_start workbook, and save it as 
AdBuy. Then follow the steps. 

1. If the Solver button doesn’t appear in the Analysis group on the Data tab, follow 
the instructions from earlier in this section to install it.

2. In the Analysis group on the Data tab, click Solver.

The Solver Parameters dialog box opens.

3. Click in the Set Objective box, and then click cell G9.

$G$9 appears in the Set Objective field.
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4. Click Max.

5. Click in the By Changing Variable Cells field, and select cells E5:E8.

$E$5:$E$8 appears in the By Changing Variable Cells field.

6. Click Add.

The Add Constraint dialog box opens.

7. Select cells E5:E8.

$E$5:$E$8 appears in the Cell Reference field.
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8. In the operator list, click int. Then click Add.

Excel adds the constraint to the Solver problem, and the Add Constraint dialog box 
clears to accept the next constraint.

9. Click cell F9.

=$F$9 appears in the Cell Reference field.

10. Click in the Constraint field, and then click cell G11.

=$G$11 appears in the Constraint field.

11. Click Add.

Excel adds the constraint to the Solver problem, and the Add Constraint dialog box 
clears to accept the next constraint.

12. Click cell G9.

$G$9 appears in the Cell Reference field.

13. In the operator list, click >=.

14. Click in the Constraint field, and then click cell G12.

=$G$12 appears in the Constraint field.

15. Click Add.

Excel adds the constraint to the Solver problem, and the Add Constraint dialog box 
clears to accept the next constraint.

16. Select cells E5:E7.

$E$5:$E$7 appears in the Cell Reference field.

17. In the operator list, click >=.

18. Click in the Constraint field, and then click cell G13.
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=$G$13 appears in the Constraint field.

19. Click Add.

Excel adds the constraint to the Solver problem, and the Add Constraint dialog box 
clears to accept the next constraint.

20. Click cell E8.

$E$8 appears in the Cell Reference field.

21. In the operator list, click >=.

22. Click in the Constraint field, and then click cell G14.

=$G$14 appears in the Constraint field.

23. Click Add.

Excel adds the constraint to the Solver problem, and the Add Constraint dialog box 
clears to accept the next constraint.

24. Select cells E5:E8.

$E$5:$E$8 appears in the Cell Reference field.

25. Verify that the <= operator appears in the operator field, click in the Constraint 
field, and then click cell G15.

=$G$15 appears in the Constraint field.

26. Click OK.

Excel adds the constraint to the Solver problem and closes the Add Constraint 
dialog box, and the Solver Parameters dialog box opens again.

27. Click Solve.

The Solver Results dialog box opens, indicating that Solver found a solution. The 
result is displayed in the body of the worksheet.
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28. Click Cancel.

The Solver Results dialog box closes.

CLEAN UP Save the AdBuy workbook, and then close it.

Analyzing Data by Using Descriptive Statistics
Experienced business people can tell a lot about numbers just by looking at them to see 
if they “look right.” That is, the sales figures are about where they’re supposed to be for a 
particular hour, day, or month; the average seems about right; and sales have increased 
from year to year. When you need more than an informal assessment, however, you can 
use the tools in the Analysis ToolPak. 

If you don’t see the Data Analysis item in the Analysis group on the Data tab, you can 
install it. To do so, click the File tab, and then click Options. In the Excel Options dialog 
box, click Add-Ins to display the Add-Ins page. At the bottom of the dialog box, in the 
Manage list, click Excel Add-Ins, and then click Go to display the Add-Ins dialog box. 
Select the Analysis ToolPak check box and click OK.

Tip You might be prompted for the Microsoft Office system installation CD. If so, put the CD 
in your CD drive, and click OK.
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After the installation is complete, the Data Analysis item appears in the Analysis group 
on the Data tab.

You then click the item representing the type of data analysis you want to perform, click 
OK, and use the commands in the resulting dialog box to analyze your data.

In this exercise, you’ll use the Analysis ToolPak to generate descriptive statistics of driver 
sorting time data.

SET UP You need the DriverSortTimes_start workbook located in your Chapter08 
practice file folder to complete this exercise. Open the DriverSortTimes_start 
workbook, and save it as DriverSortTimes. Then follow the steps. 

1. On the Data tab, in the Analysis group, click Data Analysis.

The Data Analysis dialog box opens.

2. Click Descriptive Statistics, and then click OK.

The Descriptive Statistics dialog box opens.

3. Click in the Input Range field, and then select cells C3:C17.

$C$3:$C$17 appears in the Input Range field.
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4. Select the Summary statistics check box.

5. Click OK.

A new worksheet that contains summary statistics about the selected data appears.

CLEAN UP Save the DriverSortTimes workbook, and then close it. If you’re not 
continuing directly to the next chapter, exit Excel.

Key Points
● Scenarios enable you to describe many potential business cases within a single 

workbook.

● It’s usually a good idea to create a “normal” scenario that enables you to reset 
your worksheet.

● Remember that you can change up to 32 cells in a scenario, but no more.

● You can summarize your scenarios on a new worksheet to compare how each 
scenario approaches the data.

● Use Goal Seek to determine what value you need in a single cell to generate the 
desired result from a formula.

● If you want to vary the values in more than one cell to find the optimal mix of inputs 
for a calculation, use the Solver Add-In.

● Advanced statistical tools are available in the Analysis ToolPak—use them to examine 
your data thoroughly.
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9 Creating Dynamic 
Worksheets by Using  
PivotTables

In this chapter, you will learn how to
✔ Analyze data dynamically by using PivotTables.
✔ Filter, show, and hide PivotTable data.
✔ Edit PivotTables.
✔ Format PivotTables.
✔ Create PivotTables from external data.

When you create Microsoft Excel 2010 worksheets, you must consider how you want the 
data to appear when you show it to your colleagues. You can change the formatting of 
your data to emphasize the contents of specific cells, sort and filter your worksheets based 
on the contents of specific columns, or hide rows containing data that isn’t relevant to the 
point you’re trying to make.

One limitation of the standard Excel worksheet is that you can’t easily change how 
the data is organized on the page. For example, in a worksheet in which each column 
represents an hour in the day, each row represents a day in a month, and the body of 
the worksheet contains the total sales for every hourly period of the month, you can’t 
change the worksheet quickly so that it displays only sales on Tuesdays during the 
afternoon.

There is an Excel tool with which you can create worksheets that can be sorted, filtered, 
and rearranged dynamically to emphasize different aspects of your data. That tool is the 
PivotTable.
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In this chapter, you’ll learn how to create and edit PivotTables from an existing work-
sheet, focus your PivotTable data using filters and Slicers, format PivotTables, and  
create a PivotTable with data imported from a text file.

Practice Files Before you can complete the exercises in this chapter, you need to copy 
the book’s practice files to your computer. The practice files you’ll use to complete the 
exercises in this chapter are in the Chapter09 practice file folder. A complete list of 
practice files is provided in “Using the Practice Files” at the beginning of this book.

Analyzing Data Dynamically by Using PivotTables
With Excel worksheets you can gather and present important data, but the standard work-
sheet can’t be changed from its original configuration easily. As an example, consider a 
worksheet that records monthly package volumes for each of nine distribution centers in 
the United States. 

Troubleshooting The appearance of buttons and groups on the ribbon changes depending 
on the width of the program window. For information about changing the appearance of 
the ribbon to match our screen images, see “Modifying the Display of the Ribbon” at the 
beginning of this book.
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The data in the worksheet is organized so that each row represents a distribution center 
and each column represents a month of the year. When presented in this arrangement, 
the monthly totals for all centers and the yearly total for each distribution center are 
given equal billing: neither set of totals stands out.

Such a neutral presentation of your data is versatile, but it has limitations. First, although 
you can use sorting and filtering to restrict the rows or columns shown, it’s difficult to 
change the worksheet’s organization. For example, in this worksheet, you can’t easily 
reorganize the contents of your worksheet so that the months are assigned to the rows 
and the distribution centers are assigned to the columns.

The Excel tool to reorganize and redisplay your data dynamically is the PivotTable. You 
can create a PivotTable, or dynamic worksheet, that enables you to reorganize and filter 
your data on the fly. For instance, you can create a PivotTable with the same layout as 
the worksheet described previously, which emphasizes totals by month, and then change 
the PivotTable layout to have the rows represent the months of the year and the columns 
represent the distribution centers. The new layout emphasizes the totals by regional 
distribution center.
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To create a PivotTable, you must have your data collected in a list. Excel tables mesh 
perfectly with PivotTable dynamic views; not only do Excel tables have a well-defined 
column and row structure, but the ability to refer to an Excel table by its name also 
greatly simplifies PivotTable creation and management.

In the Excel table used to create the distribution PivotTable, each row of the table con-
tains a value representing the distribution center, date, month, week, weekday, day, and 
volume for every day of the years 2009 and 2010.

Excel needs that data when it creates the PivotTable so that it can maintain relation-
ships among the data. If you want to filter your PivotTable so that it shows all package 
volumes on Thursdays in January, for example, Excel must be able to identify January 11 
as a Thursday.

After you create an Excel table, you can click any cell in the table, display the Insert tab 
and then, in the Tables group, click PivotTable to open the Create PivotTable dialog box.
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In this dialog box, you verify the data source for your PivotTable and whether you want to 
create a PivotTable on a new worksheet or an existing worksheet. After you click OK, Excel 
displays a new or existing worksheet and displays the PivotTable Field List task pane.

Tip You should always place your PivotTable on its own worksheet to avoid cluttering the 
display.
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If the PivotTable Field List task pane isn’t visible, you can display it by clicking any cell in 
the PivotTable to display the PivotTable Tools contextual tabs. On the Options contextual 
tab, in the Show/Hide group, click Field List.

To assign a field, or column of data, to an area of the PivotTable, drag the field header 
from the Choose Fields To Add To Report area at the top of the PivotTable Field List task 
pane to the Drag Fields Between Areas Below area at the bottom of the task pane. For 
example, if you drag the Volume field header to the Values area, the PivotTable displays 
the total of all entries in the Volume column. 
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It’s important to note that the order in which you enter the fields in the Row Labels 
and Column Labels areas affects how Excel organizes the data in your PivotTable. As an 
example, consider a PivotTable that groups the PivotTable rows by distribution center 
and then by month.
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The same PivotTable data could also be organized by month and then by distribution 
center.

In the preceding examples, all the field headers are in the Row Labels area. If you drag 
the Center header from the Row Labels area to the Column Labels area, the PivotTable 
reorganizes (pivots) its data to form a different configuration.
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To pivot a PivotTable, you drag a field header to a new position in the PivotTable Field List 
task pane. As you drag a field within the task pane, Excel displays a blue line in the interior 
of the target area so you know where the field will appear when you release the left mouse 
button. If your data set is large or if you based your PivotTable on a data collection on 
another computer, it might take some time for Excel to reorganize the PivotTable after a 
pivot. You can have Excel delay redrawing the PivotTable by selecting the Defer Layout 
Update check box in the lower-left corner of the PivotTable Field List task pane. When 
you’re ready for Excel to display the reorganized PivotTable, click Update.

If you expect your PivotTable source data to change, such as when you link to an external 
database that records shipments or labor hours, you should ensure that your PivotTable 
summarizes all the available data. To do that, you can refresh the PivotTable connection 
to its data source. If Excel detects new data in the source table, it updates the PivotTable 
contents accordingly. To refresh your PivotTable, click any cell in the PivotTable and then, 
on the Options contextual tab, in the Data group, click Refresh.
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In this exercise, you’ll create a PivotTable by using data from a table, add fields to  
the PivotTable, and then pivot the PivotTable.

SET UP You need the Creating_start workbook located in your Chapter09 practice 
file folder to complete this exercise. Start Excel, open the Creating_start workbook, 
and save it as Creating. Then follow the steps. 

1. Click any cell in the Excel table.

2. On the Insert tab, in the Tables group, click the PivotTable button (not the arrow).

The Create PivotTable dialog box opens.

3. Verify that the DailyVolumes table name appears in the Table/Range field and 
that the New Worksheet option is selected.

4. Click OK.

Excel creates a PivotTable on a new worksheet.

5. In the PivotTable Field List task pane, drag the Center field header to the Row 
Labels area.

Excel adds the Center field values to the PivotTable row area.
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6. In the PivotTable Field List task pane, drag the Year field header to the Column 
Labels area.

Excel adds the Year field values to the PivotTable column area.

7. In the PivotTable Field List task pane, drag the Volume field header to the 
Values area.

Excel fills in the body of the PivotTable with the Volume field values.

8. In the PivotTable Field List task pane, in the Column Labels area, drag the 
Year field header to the Row Labels area, and drop it beneath the Center field 
header.

Excel changes the PivotTable to reflect the new organization.

CLEAN UP Save the Creating workbook, and then close it.
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Filtering, Showing, and Hiding PivotTable Data
PivotTables often summarize huge data sets in a relatively small worksheet. The more 
details you can capture and write to a table, the more flexibility you have in analyzing 
the data. As an example, consider all the details captured in a table in which each row 
contains a value representing the distribution center, date, month, week, weekday, day, 
and volume for every day of the year.

Each column, in turn, contains numerous values: there are nine distribution centers, 
data from two years, 12 months in a year, seven weekdays, and as many as five weeks 
and 31 days in a month. Just as you can filter the data that appears in an Excel table 
or other data collection, you can filter the data displayed in a PivotTable by selecting 
which values you want the PivotTable to include.

See Also For more information on filtering an Excel table, see “Limiting Data That Appears on 
Your Screen” in Chapter 5, “Focusing on Specific Data by Using Filters.”
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To filter a PivotTable based on a field’s contents, click the field’s header in the Choose 
Fields To Add To Report area of the PivotTable Field List task pane. When you do, Excel 
displays a menu of sorting and filtering options.

The PivotTable displays several sorting options, commands for different categories of 
filters, and a list of items that appear in the field you want to filter. Every list item has a 
check box next to it. Items with a check mark in the box are currently displayed in the 
PivotTable, and items without a check mark are hidden. 

The first entry at the top of the item list is the Select All check box. The Select All check 
box can have one of three states: displaying a check mark, displaying a black square,  
or empty. If the Select All check box contains a check mark, then the PivotTable dis-
plays every item in the list. If the Select All check box is empty, then no filter items are 
selected. Finally, if the Select All check box contains a black square, it means that some, 
but not all, of the items in the list are displayed. Selecting only the Northwest check box, 
for example, leads to a PivotTable configuration in which only the data for the Northwest 
center is displayed.
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If you’d rather display as much PivotTable data as possible, you can hide the PivotTable 
Field List task pane and filter the PivotTable by using the filter arrows on the Row Labels 
and Column Labels headers within the body of the PivotTable. Clicking either of those 
headers enables you to select a field by which you can filter; you can then define the 
filter by using the same controls you see when you click a field header in the PivotTable 
Field List task pane.

Excel indicates that a PivotTable has filters applied by placing a filter indicator next to the 
Column Labels or Row Labels header, as appropriate, and the filtered field name in 
the PivotTable Field List task pane.
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So far, all the fields by which we’ve filtered the PivotTable have changed the organiza-
tion of the data in the PivotTable. Adding some fields to a PivotTable, however, might 
create unwanted complexity. For example, you might want to filter a PivotTable by 
weekday, but adding the Weekday field to the body of the PivotTable expands the 
table unnecessarily.

Instead of adding the Weekday field to the Row Labels or Column Labels area, you can 
drag the field to the Report Filter area near the bottom of the PivotTable Field List task 
pane. Doing so leaves the body of the PivotTable unchanged, but adds a new area above 
the PivotTable in its worksheet.
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Tip In Excel 2003 and earlier versions, this area was called the Page Field area.

When you click the filter arrow of a field in the Report Filter area, Excel displays a list of 
the values in the field. When you click the filter arrow, you can choose to filter by one 
value at a time. If you’d like to filter your PivotTable by more than one value, you can 
do so by selecting the Select Multiple Items check box.

If your PivotTable has more than one field in the Row Labels area, you can filter values 
in a PivotTable by hiding and collapsing levels of detail within the report. To do that, 
you click the Hide Detail control (which looks like a box with a minus sign in it) or the 
Show Detail control (which looks like a box with a plus sign in it) next to a header.  
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For example, you might have your data divided by year; clicking the Show Detail control 
next to the 2009 year header would display that year’s details. Conversely, clicking the 
2010 year header’s Hide Detail control would hide the individual months’ values and 
display only the year’s total.

Excel 2010 provides two new ways for you to filter PivotTables: search filters and Slicers. 
With a search filter, you can type in a series of characters for Excel to filter that field’s 
values. To create a search filter, click a field’s filter arrow and type the character string 
for which you want to search in the filter menu’s Search box.

Filtering, Showing, and Hiding PivotTable Data  227

www.it-ebooks.info

http://www.it-ebooks.info/


228  Chapter 9 Creating Dynamic Worksheets by Using PivotTables

For example, if the PivotTable’s Center field contains the values Atlantic, Central, Midwest, 
Mountain West, North Central, Northeast, Northwest, Southeast, and Southwest, typing 
the character string “No” limits the values to North Central, Northeast, and Northwest.

Tip Search filters look for the character string you specify anywhere within a field’s value, 
not just at the start of the value. In the previous example, the search filter string “cen” would 
return both Central and North Central.

In versions of Excel prior to Excel 2010, the only visual indication that you had applied a 
filter to a field was the indicator added to a field’s filter arrow. The indicator told users  
that there was an active filter applied to that field but provided no information on 
which values were displayed and which were hidden. In Excel 2010, Slicers provide a 
visual indication of which items are currently displayed or hidden in a PivotTable. 
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To create a Slicer, click any cell in a PivotTable and then, on the Options contextual tab 
of the ribbon, in the Sort & Filter group, click Insert Slicer to display the Insert Slicers 
dialog box.

Select the check box next to the fields for which you want to create a Slicer, and click OK. 
When you do, Excel 2010 displays a Slicer for each field you identified.

Filtering, Showing, and Hiding PivotTable Data  229

www.it-ebooks.info

http://www.it-ebooks.info/


230  Chapter 9 Creating Dynamic Worksheets by Using PivotTables

Tip If you have already applied a filter to the field for which you display a Slicer, the Slicer 
reflects the filter’s result.

A Slicer displays the values within the PivotTable field you identified. Any value displayed in 
color (or gray if you select a gray-and-white color scheme) appears within the PivotTable. 
Values displayed in light gray or white do not appear in the PivotTable. 

Clicking an item in a Slicer changes that item’s state—if a value is currently displayed in 
a PivotTable, clicking it hides it. If it’s hidden, clicking its value in the Slicer displays it 
in the PivotTable. As with other objects in an Excel 2010 workbook, you can use the Shift 
and Ctrl keys to help define your selections. For example, suppose you create a Slicer for 
the Month field while every month is displayed.
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If you want to hide every month except January, February, and March, you click the 
January item to hide every month except January. Then hold down the Shift key 
and click March to have Excel 2010 display just the data for the months of January, 
February, and March. You can then add another month, such as July, to the filter by 
holding down the Ctrl key and clicking July in the Slicer.
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To use a Slicer to remove a filter, click the Clear Filter button in the upper-right corner of 
the Slicer. If you want to resize a Slicer, you can do so by dragging the resize handle in the 
lower-right corner of the Slicer. To hide the Slicer, right-click it and then click the menu 
command that starts with the word “Remove.” For example, the Month field’s menu com-
mand would be Remove Month.

Tip You can change a Slicer’s formatting by clicking the Slicer and then, on the Slicer Tools 
Options contextual tab on the ribbon, clicking a style in the Slicer Styles gallery.

In this exercise, you’ll focus the data displayed in a PivotTable by creating a filter, by filter-
ing a PivotTable based on the contents of a field in the Report Filters area, by showing and 
hiding levels of detail within the body of the PivotTable, by using the Search box, and by 
using Slicers.

SET UP You need the Focusing_start workbook located in your Chapter09 practice 
file folder to complete this exercise. Open the Focusing_start workbook, and save it 
as Focusing. Then follow the steps. 

1. On the Sheet2 worksheet, click any cell in the PivotTable.

2. In the PivotTable Field List task pane’s Choose fields to add to report area, 
click the Center field header, click the Center field filter arrow, and then clear the 
(Select All) check box.
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Excel clears all the check boxes in the filter menu.

3. Select the Northwest check box, and then click OK.

Excel filters the PivotTable.

4. On the Quick Access Toolbar, click the Undo button.

Excel removes the filter.

5. In the PivotTable Field List task pane, drag the Weekday field header from the 
Choose fields to add to report area to the Report Filter area in the Drag fields 
between areas below area.

6. In the PivotTable Field List task pane, click the Close button.

The PivotTable Field List task pane closes.

7. In the body of the worksheet, click the Weekday filter arrow, and then, if necessary, 
select the Select Multiple Items check box.

Excel adds check boxes beside the items in the Weekday field filter list.

8. Clear the All check box.

Excel clears each check box in the list.
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9. Select the Tuesday and Thursday check boxes, and then click OK.

Excel filters the PivotTable, summarizing only those values from Tuesdays and 
Thursdays.

10. In cell A5, click the Hide Detail button.

Excel collapses rows that contain data from the year 2009, leaving only the subtotal 
row that summarizes that year’s data.

11. In cell A5, click  the Show Detail button.

Excel redisplays the collapsed rows.

12. On the ribbon, click the Options contextual tab, and then, in the Show group, click 
Field List.

The PivotTable Field List task pane opens.

13. In the PivotTable Field List task pane, click the Month field header arrow.

The filter menu opens.
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14. In the Search box, type Ju.

Excel displays the months June and July in the filter list.

15. Click OK.

Excel applies the filter.

16. On the Options contextual tab of the ribbon, in the Actions group, click the Clear 
button, and then click Clear Filters.

Excel clears all filters from the PivotTable.

17. On the Options contextual tab of the ribbon, in the Sort & Filter group, click 
Insert Slicer.

The Insert Slicers dialog box opens.

 18. In the Insert Slicers dialog box, select the Center check box, and then click OK.

A Slicer for the Center field appears.

 19. Click the Atlantic item.

Excel filters the PivotTable so only results for the Atlantic center appear.
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20. In the Slicer, click Midwest, and then, while holding down the Ctrl key, click 
Mountain West and then Northwest.

Excel filters the PivotTable so it displays results for the Midwest, Mountain West, 
and Northwest centers.

21. In the upper-right corner of the Slicer, click the Clear Filter button.

Excel removes the filter from the Center field.

22. Right-click the Slicer, and then click Remove "Center".

Excel closes the Slicer.

CLEAN UP Save the Focusing workbook, and then close it.

Editing PivotTables
After you create a PivotTable, you can rename it, edit it to control how it summarizes your 
data, and use the PivotTable cell data in a formula. As an example, consider a PivotTable 
named PivotTable2 that summarizes package volumes for every Consolidated Messengers 
regional distribution hub.
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Excel displays the PivotTable name on the Options contextual tab, in the PivotTable 
Options group. The name PivotTable2 doesn’t help you or your colleagues understand 
the data the PivotTable contains, particularly if you use the PivotTable data in a formula 
on another worksheet. To give your PivotTable a more descriptive name, click any cell in 
the PivotTable and then, on the Options contextual tab, in the PivotTable Options group, 
type the new name in the PivotTable Name field.

When you create a PivotTable with at least one field in the Row Labels area and one field 
in the Column Labels area of the PivotTable Field List task pane, Excel adds a grand total 
row and column to summarize your data. You can control how and where these sum-
mary rows and columns appear by clicking any PivotTable cell and then, on the Design 
contextual tab, in the Layout group, clicking either the Subtotals or Grand Totals button 
and selecting the desired layout.

After you create a PivotTable, Excel determines the best way to summarize the data in the 
column you assign to the Values area. For numeric data, for example, Excel uses the SUM 
function. If you want to change a PivotTable summary function, right-click any data cell in 
the PivotTable values area, point to Summarize Values By, and then click the desired opera-
tion. If you want to use a function other than those listed, click More Options to display the 
Value Field Settings dialog box. On the Summarize Values By page of the dialog box, you 
can choose the summary operation you want to use.
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You can also change how the PivotTable displays the data in the Values area. On the Show 
Values As page of the Value Field Settings dialog box, you can select whether to display 
each cell’s percentage contribution to its column’s total, its row’s total, or its contribution 
to the total of all values displayed in the PivotTable.

If you want, you can create a formula that incorporates a value from a PivotTable cell. 
To do so, you click the cell where you want to create the formula, type an equal sign, 
and then click the cell in the PivotTable that contains the data you want to appear in the 
other cell. A GETPIVOTDATA formula appears in the formula box of the worksheet that 
contains the PivotTable. When you press Enter, Excel creates the GETPIVOTDATA formula 
and displays the contents of the PivotTable cell in the target cell.
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In this exercise, you’ll rename a PivotTable, specify whether subtotal and grand total rows 
will appear, change the PivotTable summary function, display each cell’s contribution to 
its row’s total, and create a formula that incorporates a value in a PivotTable cell.

SET UP You need the Editing_start workbook located in your Chapter09 practice 
file folder to complete this exercise. Open the Editing_start workbook, and save it 
as Editing. Then follow the steps.

1. On the Sheet2 worksheet, click any cell in the PivotTable.

2. On the Options contextual tab, in the PivotTable group, in the PivotTable Name 
field, type VolumeSummary and press Enter.

Excel renames the PivotTable.

3. On the Design contextual tab, in the Layout group, click Subtotals, and then click 
Do Not Show Subtotals.

Excel removes the subtotal rows from the PivotTable.

4. On the Design contextual tab, in the Layout group, click Grand Totals, and then 
click On for columns only.

Excel removes the cells that calculate each row’s grand total.

Editing PivotTables  239

www.it-ebooks.info

http://www.it-ebooks.info/


240  Chapter 9 Creating Dynamic Worksheets by Using PivotTables

5. On the Quick Access Toolbar, click the Undo button.

Excel reverses the last change.

6. Right-click any data cell in the PivotTable, point to Summarize Values By, and then 
click Average.

Excel changes the Value field summary operation.

7. On the Quick Access Toolbar, click the Undo button.

Excel reverses the last change.

8. Right-click any data cell in the PivotTable, and then click Value Field Settings.

The Value Field Settings dialog box opens.

9. Click the Show Values As tab.

The Show Values As page appears.

10. In the Show Values As list, click % of Row Total.

11. Click OK.

Excel changes how it calculates the values in the PivotTable.
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12. On the Quick Access Toolbar, click the Undo button.

Excel reverses the last change.

13. On the Design tab, in the Layout group, click Subtotals, and then click Show All 
Subtotals at Bottom of Group.

Excel displays subtotals in the workbook.

14. Click the Package Summary sheet tab.

The Package Summary worksheet appears.

15. In cell C4, type =, but do not press Enter.

16. Click the PivotTable sheet tab.

The PivotTable worksheet appears.

17. Click cell K32, and then press Enter.

Excel creates the formula =GETPIVOTDATA(“Volume”,PivotTable!$A$3,”Year”,2010) 
in cell C4.
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CLEAN UP Save the Focusing workbook, and then close it.

Formatting PivotTables
PivotTables are the ideal tools for summarizing and examining large data tables, even 
those containing more than 10,000 or even 100,000 rows. Even though PivotTables often 
end up as compact summaries, you should do everything you can to make your data more 
comprehensible. One way to improve your data’s readability is to apply a number format 
to the PivotTable Values field. To apply a number format to a field, right-click any cell in the 
field, and then click Number Format to display the Format Cells dialog box. Select or define 
the format you want to apply, and then click OK to enact the change.

See Also For more information on selecting and defining cell formats by using the Format 
Cells dialog box, see “Formatting Cells” in Chapter 4, “Changing Workbook Appearance.”

Analysts often use PivotTables to summarize and examine organizational data with an 
eye to making important decisions about the company. For example, chief operating 
officer Lori Penor might examine monthly package volumes handled by Consolidated 
Messenger and notice that there’s a surge in package volume during the winter months 
in the United States.
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Excel extends the capabilities of your PivotTables by enabling you to apply a conditional 
format to the PivotTable cells. What’s more, you can select whether to apply the condi-
tional format to every cell in the Values area, to every cell at the same level as the selected 
cell (that is, a regular data cell, a subtotal cell, or a grand total cell) or to every cell that 
contains or draws its values from the selected cell’s field (such as the Volume field in the 
previous example).

To apply a conditional format to a PivotTable field, click a cell in the Values area. On the 
Home tab, in the Styles group, click Conditional Formatting, and then create the desired 
conditional format. After you do, Excel displays a Formatting Options action button, 
which offers three options for applying the conditional format:

● Selected Cells Applies the conditional format to the selected cells only

● All Cells Showing Sum of field_name Values Applies the conditional format to every 
cell in the data area, regardless of whether the cell is in the data area, a subtotal row 
or column, or a grand total row or column

● All Cells Showing Sum of field_name Values for Fields Applies the conditional 
format to every cell at the same level (for example, data cell, subtotal, or grand 
total) as the selected cells
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See Also For more information on creating conditional formats, see “Changing the 
Appearance of Data Based on Its Value” in Chapter 4, “Changing Workbook Appearance.”

In Excel, you can take full advantage of the Microsoft Office system enhanced formatting 
capabilities to apply existing formats to your PivotTables. Just as you can create Excel 
table formats, you can also create your own PivotTable formats to match your organi-
zation’s desired color scheme.

To apply a PivotTable style, click any cell in the PivotTable and then, on the Design con-
textual tab, in the PivotTable Styles group, click the gallery item representing the style 
you want to apply. If you want to create your own PivotTable style, click the More button 
in the PivotTable Styles gallery (in the lower-right corner of the gallery), and then click 
New PivotTable Style to display the New PivotTable Quick Style dialog box.

Type a name for the style in the Name field, click the first table element you want to cus-
tomize, and then click Format. Use the controls in the Format Cells dialog box to change 
the element’s appearance. After you click OK to close the Format Cells dialog box, the New 
PivotTable Quick Style dialog box Preview pane displays the style’s appearance. If you want 
Excel to use the style by default, select the Set As Default PivotTable Quick Style For This 
Document check box. After you finish creating your formats, click OK to close the New 
PivotTable Quick Style dialog box and save your style.
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The Design contextual tab contains many other tools you can use to format your PivotTable, 
but one of the most useful is the Banded Columns check box, which you can find in the 
PivotTable Style Options group. If you select a PivotTable style that offers banded rows as 
an option, selecting the Banded Rows check box turns banding on. If you prefer not to have 
Excel band the rows in your PivotTable, clearing the check box turns banding off.

In this exercise, you’ll apply a number format to a PivotTable values field, apply a PivotTable 
style, create your own PivotTable style, give your PivotTable banded rows, and apply a con-
ditional format to a PivotTable.

SET UP You need the Formatting_start workbook located in your Chapter09 practice 
file folder to complete this exercise. Open the Formatting_start workbook, and save it 
as Formatting. Then follow the steps. 

1. On the Sheet2 worksheet, right-click any data cell, and then click Number Format.

The Format Cells dialog box opens.

2. In the Category list, click Number.

The Number page is displayed.
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3. In the Decimal places field, type 0.

4. Select the Use 1000 Separator (,) check box.

 5. Click OK.

Excel reformats your PivotTable data.

 6. If necessary, on the Design contextual tab, in the PivotTable Style Options group, 
select the Banded Rows check box.

 7. On the Design contextual tab, in the PivotTable Styles group, click the More 
button. Then, in the top row of the gallery, click the third style from the left. 
(When you point to it, Excel displays a ScreenTip that reads Pivot Style Light 2.)
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Excel applies the PivotTable style.

8. In the lower-right corner of the PivotTable Styles gallery, click the More button.

The gallery expands.

9. Click New PivotTable Style.

The New PivotTable Quick Style dialog box opens.
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10. In the Name field, type Custom Style 1.

11. In the Table Element list, click Header Row, and then click Format.

The Format Cells dialog box opens.

12. On the Font page, in the Color list, click the white square.

13. On the Border page, in the Presets area, click Outline.

14. On the Fill page, in the Background Color area, click the purple square at the 
lower-right corner of the color palette.

15. Click OK.

The Format Cells dialog box closes, and the style change appears in the Preview 
pane of the New PivotTable Quick Style dialog box.

16. In the Table Element list, click Second Row Stripe, and then click Format.

The Format Cells dialog box opens.

17. On the Fill page, in the middle part of the Background Color area, click the 
eighth square in the second row (it’s a light, dusty purple).

18. Click OK twice.
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The Format Cells dialog box closes, and your format appears in the PivotTable 
Styles gallery.

19. Click the new style.

Excel formats your PivotTable using your custom PivotTable style.

20. On the Design contextual tab, in the PivotTable Style Options group, clear the 
Banded Rows check box.

Excel removes the banding from your PivotTable and from the preview of the 
custom style.

Formatting PivotTables  249

www.it-ebooks.info

http://www.it-ebooks.info/


250  Chapter 9 Creating Dynamic Worksheets by Using PivotTables

21. Select the cell ranges K6:K17 and K19:K30.

22. On the Home tab, in the Styles group, click Conditional Formatting, point to 
Color Scales, and in the top row, click the second three-color scale from the left.

Excel applies the conditional format to the selected cells.

CLEAN UP Save the Formatting workbook, and then close it.

Creating PivotTables from External Data
Although most of the time you will create PivotTables from data stored in Excel worksheets, 
you can also bring data from outside sources into Excel. For example, you might need 
to work with data created in another spreadsheet program with a file format that Excel 
can’t read directly. Fortunately, you can export the data from the original program into a 
text file, which Excel then translates into a worksheet.
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Tip The data import technique shown here isn’t exclusive to PivotTables. You can use this 
procedure to bring data into your worksheets for any purpose.

Spreadsheet programs store data in cells, so the goal of representing spreadsheet data in 
a text file is to indicate where the contents of one cell end and those of the next cell begin. 
The character that marks the end of a cell is a delimiter, in that it marks the end (or “limit”) 
of a cell. The most common cell delimiter is the comma, so the delimited sequence 15, 18, 
24, 28 represents data in four cells. The problem with using commas to delimit financial 
data is that larger values—such as 52,802—can be written by using commas as thousands 
markers. To avoid confusion when importing a text file, the most commonly used delimiter 
for financial data is the Tab character.

To import data from a text file, on the Data tab, in the Get External Data group, click 
From Text to display the Import Text File dialog box.
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From within the Import Text File dialog box, browse to the directory that contains  
the text file you want to import. Double-clicking the file launches the Text Import 
wizard.

On the first page of the Text Import wizard, you can indicate whether the data file you 
are importing is Delimited or Fixed Width; Fixed Width means that each cell value will fall 
within a specific position in the file. Clicking Next to accept the default choice, Delimited 
(which Excel assigns after examining the data source you selected), advances you to the 
next wizard page.
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On this page, you can choose the delimiter for the file (in this case, Excel detected tabs in 
the file and selected the Tab check box for you) and gives you a preview of what the text 
file will look like when imported. Clicking Next advances you to the final wizard page.
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On this page, you can change the data type and formatting of the columns in your data. 
Because you’ll assign number styles and PivotTable Quick Styles after you create the 
PivotTable, you can click Finish to import the data into your worksheet. After the data is 
in Excel, you can work with it normally.

In this exercise, you’ll import data into Excel from a text file and then create a PivotTable 
based on that data.

SET UP You need the Creating_start text file located in your Chapter09 practice file 
folder to complete this exercise. 

1. Create a new Excel workbook. On the Data tab, click the Get External Data button, 
and then click From Text.

The Import Text File dialog box opens.

2. Navigate to the Chapter09 practice file folder, and then double-click 
Creating_start.txt.

The Text Import wizard starts.

3. Verify that the Delimited option is selected, and then click Next.

The next Text Import Wizard page opens.

 4. In the Delimiters area, verify that the Tab check box is selected and also verify 
that the data displayed in the Data preview area reflects the structure you 
expect.

 5. Click Finish.

Clicking Finish skips page 3 of the wizard, which has commands you can use 
to assign specific data types to each column. Excel assigns data types for you, 
so you don’t need to do so. After you click Finish, the Import Data dialog box 
opens.
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6. Verify that the Existing worksheet option is selected, and then click OK.

Excel imports the data into your workbook.

7. On the Home tab, in the Styles group, click Format as Table, and then click the 
first table style.

The Format As Table dialog box opens.

8. Verify that the My table has headers check box is selected and that the range 
=$A$1:$H$6571 appears in the Where is the data for your table? box, and 
then click OK.

A confirmation dialog box opens.

9. Click Yes to confirm you want to create the Excel table and break its link to the 
external data source.

Excel creates an Excel table from your imported data.

10. On the Insert tab, in the Tables group, click PivotTable.

The Create PivotTable dialog box opens.

11. Verify that the Select a table or range option is selected, that Table1 appears in 
the Table/Range field, and that the New Worksheet option is selected.

12. Click OK.

Excel creates the PivotTable on a new worksheet.

13. In the PivotTable Field List task pane, drag the Volume field header to the 
Values area.

14. Drag the Weekday field header to the Column Labels area.

15. Drag the Center field header to the Row Labels data area.
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16. On the Quick Access Toolbar, click the Save button.

The Save As dialog box opens.

17. Browse to the Chapter09 folder.

18. In the File name field, type ImportedData.

19. Click Save.

Excel saves your file.

CLEAN UP Close the Imported Data workbook. If you’re not continuing directly to 
the next chapter, exit Excel.
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Key Points
● A PivotTable is a versatile tool you can use to rearrange your data dynamically, 

enabling you to emphasize different aspects of your data without creating new 
worksheets.

● PivotTable data must be formatted as a list. By using a data table as the PivotTable 
data source, you can streamline the creation process by referring to the table name 
instead of being required to select the entire range that contains  
the data you want to summarize.

● Excel comes with many attractive styles for PivotTables; you’ll probably find one 
you like.

● With the PivotTable Field List task pane, you can create your PivotTable by using 
a straightforward, compact tool.

● Just as you can limit the data shown in a static worksheet, you can use filters to 
limit the data shown in a PivotTable.

● Excel 2010 includes two new types of filters, search filters and Slicers, that you can 
use to limit the data in your PivotTables.

● If you have data in a compatible format, such as a text file, you can import that 
data into Excel and create a PivotTable from it.
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10 Creating Charts 
and Graphics

In this chapter, you will learn how to
✔ Create charts.
✔ Customize the appearance of charts.
✔ Find trends in your data.
✔ Summarize your data by using sparklines.
✔ Create dynamic charts by using PivotCharts.
✔ Create diagrams by using SmartArt.
✔ Create shapes and mathematical equations.

When you enter data into a Microsoft Excel 2010 worksheet, you create a record of 
important events, whether they are individual sales, sales for an hour of a day, or the 
price of a product. What a list of values in cells can’t communicate easily, however, is 
the overall trends in the data. The best way to communicate trends in a large collection 
of data is by creating a chart, which summarizes data visually. In addition to the stan-
dard charts, with Excel 2010 you can create compact charts called sparklines, which 
summarize a data series using a graph contained within a single cell.

You have a great deal of control over your charts’ appearance—you can change the color 
of any chart element, choose a different chart type to better summarize the underlying 
data, and change the display properties of text and numbers in a chart. If the data in the 
worksheet used to create a chart represents a progression through time, such as sales over 
several months, you can have Excel extrapolate future sales and add a trendline to the 
graph representing that prediction.

Just as you can create a PivotTable dynamic view to reorganize your data dynamically, 
you can create a PivotChart dynamic view that reflects the contents and organization of 
the associated PivotTable. You can also add shapes, display mathematical equations, and 
create diagrams, such as organizational charts, that are useful in many organizations.
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In this chapter, you’ll learn how to create a chart and customize its elements, find trends 
in your overall data, summarize data using sparklines, create dynamic charts, and create 
and format shapes, diagrams, and shapes containing mathematical equations.

Practice Files Before you can complete the exercises in this chapter, you need to copy 
the book’s practice files to your computer. The practice files you’ll use to complete the 
exercises in this chapter are in the Chapter10 practice file folder. A complete list of 
practice files is provided in “Using the Practice Files” at the beginning of this book.

Creating Charts
To create a chart, select the data you want to summarize visually and then, on the Insert 
tab, in the Charts group, click the type of chart you want to create to have Excel display 
the available chart subtypes. 

Troubleshooting The appearance of buttons and groups on the ribbon changes depending 
on the width of the program window. For information about changing the appearance of 
the ribbon to match our screen images, see “Modifying the Display of the Ribbon” at the 
beginning of this book.
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When you click a chart subtype, Excel creates the chart by using the default layout and 
color scheme defined in your workbook’s theme. 

Keyboard Shortcut Press F11 to create a chart of the default type. Unless you or another user 
changed the default, Excel creates a column chart.

See Also To see a complete list of keyboard shortcuts, see “Keyboard Shortcuts” at the end of 
this book.

If Excel doesn’t plot your data the way you want it to, you can change the axis on 
which Excel plots a data column. The most common reason for incorrect data plotting 
is that the column to be plotted on the horizontal axis contains numerical data instead 
of textual data. For example, if your data includes a Year column and a Volume column, 
instead of plotting volume data for each consecutive year along the horizontal axis, 
Excel plots both of those columns in the body of the chart and creates a sequential 
series to provide values for the horizontal axis.
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You can change which data Excel applies to the vertical axis (also known as the y-axis) 
and the horizontal axis (also known as the x-axis). To make that change, select the 
chart and then, on the Design tab, in the Data group, click Select Data to display 
the Select Data Source dialog box.

The Year column doesn’t belong in the Legend Entries (Series) pane, which corresponds 
to a column chart’s vertical axis. To remove a column from an axis, select the column’s 
name, and then click Remove. To add the column to the Horizontal (Category) Axis 
Labels pane, click that pane’s Edit button to display the Axis Labels dialog box.

In the Axis Labels dialog box, click the Collapse Dialog button at the right edge of the 
Axis Label Range field, select the cells to provide the values for the horizontal axis (not 
including the column header, if any), click the Expand Dialog button, and then click OK. 
Click OK again to close the Select Data Source dialog box and revise your chart.
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After you create your chart, you can change its size to reflect whether the chart should 
dominate its worksheet or take on a role as another informative element on the work-
sheet. For example, Gary Schare, the chief executive officer of Consolidated Messenger, 
could create a workbook that summarizes the performance of each of his company’s 
business units. In that case, he would display the chart and data for each business unit 
on the same worksheet, so he would want to make his charts small.

To resize a chart, select the chart, and then drag one of the handles on the chart’s 
edges. Handles in the middle of the edges enable you to resize the chart in one direc-
tion. Dragging a handle on the left or right edge enables you to make the chart narrower 
or wider, whereas dragging the handles on the chart’s top and bottom edges enable you 
to make the chart shorter or taller. Dragging a corner handle enables you to change the 
chart’s height and width at the same time; holding down the Shift key as you drag the 
corner handle changes the chart’s size without changing its proportions.

Just as you can control a chart’s size, you can also control its location. To move a chart 
within a worksheet, drag the chart to the desired location. If you want to move the 
chart to a new worksheet, click the chart and then, on the Design contextual tab, in 
the Location group, click Move Chart to display the Move Chart dialog box.
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To move the chart to a new chart sheet, select the New Sheet option and type the 
new sheet’s name in the accompanying field. Selecting the New Sheet option creates 
a chart sheet that contains only your chart. You can still resize the chart on that sheet, 
but when Excel creates the new chart sheet, the chart takes up the full sheet. 

To move the chart to an existing worksheet, select the Object In option and then, in the 
Object In list, click the worksheet to which you want to move the chart.

In this exercise, you’ll create a chart, change how the chart plots your data, move your 
chart within a worksheet, and move your chart to its own chart sheet.

SET UP You need the YearlyPackageVolume_start workbook located in your 
Chapter10 practice file folder to complete this exercise. Start Excel, open the 
YearlyPackageVolume_start workbook, and save it as YearlyPackageVolume. 
Then follow the steps. 

1. On the Data worksheet, click any cell in the Excel table.

2. On the Insert tab, in the Charts group, click Bar and then, in the 2D Bar group, 
click the first chart subtype. (The chart subtype is named Clustered Bar).

Excel creates the chart, with both the Year and Volume data series plotted in the 
body of the chart.
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3. On the Design tab, in the Data group, click Select Data.

The Select Data Source dialog box opens.

4. In the Legend Entries (Series) area, click Year.

5. Click Remove.

The Year series disappears.

6. In the Horizontal (Category) Axis Labels area, click Edit.

The Axis Labels dialog box opens.

 7. Select cells B3:B9, and then click OK.

The Axis Labels dialog box closes, and the Select Data Source dialog box reappears 
with the years in the Horizontal (Category) Axis Labels area.
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8. Click OK.

Excel redraws your chart, using the years as the values for the horizontal axis.

9. Move the mouse pointer over the body of the chart.

The mouse pointer changes to a four-headed arrow.

10. Drag the chart up and to the left so that it covers the Excel table.

11. On the Design tab, in the Location group, click Move Chart.

The Move Chart dialog box opens.

12. Click New sheet, type Volume Chart in the sheet name box, and then click OK.

Your chart appears on a chart sheet named Volume Chart.

CLEAN UP Save the YearlyPackageVolume workbook, and then close it.
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Customizing the Appearance of Charts
If you want to change a chart’s appearance, select the chart and then, on the Design tab, 
click a style in the Chart Styles gallery. The gallery contains far more chart styles than are 
shown on the ribbon—to select a new look for your chart, click the More button at 
the gallery’s lower-right corner, and then click the design you want.

Tip The styles in the Chart Styles gallery are tied to your workbook’s theme. If you change 
your workbook’s theme, Excel changes your chart’s appearance to reflect the new theme’s 
colors.

When you create a chart by using the tools in the Insert tab’s Charts group, Excel creates 
an attractive chart that focuses on the data. In most cases, the chart has a title, legend 
(list of data series displayed in the chart), horizontal lines in the body of the chart to 
make it easier to discern individual values, and axis labels. If you want to create a chart 
that has more or different elements, such as additional data labels for each data point 
plotted on your chart, you can do so by selecting the chart and then, on the Design tab, 
in the Chart Layouts group, clicking the layout you want.

If you don’t find the exact chart layout you like, you can use the tools on the Layout 
contextual tab to control each element’s appearance and placement.
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In the Axes group, clicking Gridlines enables you to determine whether the chart displays 
horizontal and vertical gridlines and, if it does, at what value intervals they should appear.

In addition to changing your chart’s layout, you can control the appearance of each 
element within the chart. To select a chart element to format, click that element. For 
example, if you want to change the formatting of the data series named Volume in the 
column chart you created in the previous exercise, clicking any column in the series 
selects the entire series. Any formatting changes you make then apply to every point 
in the entire series. If you want to change a single data point, select the entire series, 
and then click the chart element (for example, a column) that represents the data point 
you want to change. For example, you can highlight the column representing the year 
2008 in the chart you created in the previous exercise.

You can display a list of the selectable chart elements by selecting the chart and then, 
on the Format tab, in the Current Selection group, clicking the Chart Elements arrow. 
Then just click the desired chart element to select it.

After you select the chart element, you can drag one of the element’s handles to resize 
the element or drag the element to another location within the chart. To change the chart 
element’s format, use the tools and dialog box launchers in the Format tab’s Shape Styles, 
Word Art Styles, Arrange, and Size groups to change the element’s appearance. You can 
also select the chart element and then, on the Format tab, in the Current Selection group, 
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click Format Selection to display a Format dialog box that enables you to change the chart 
element’s appearance.

If you think you want to apply the same set of changes to charts you’ll create in the future, 
you can save your chart as a chart template. When you select the data you want to sum-
marize visually and apply the chart template, you’ll create consistently formatted charts in 
a minimum of steps. To save a chart as a chart template, select the chart you want to use 
as a template and then, on the Design tab, in the Type group, click Save Template. Use the 
controls in the dialog box that appears to name and save your template. Then, to create 
a chart based on that template, select the data you want to summarize and then, on the 
Insert tab, in the Charts group, click any chart type, and then click All Chart Types to dis-
play the Create Charts dialog box. Under Choose A Chart Type, click Templates, and then 
click the template you want to use.

Tip You can apply a template to an existing chart by selecting the chart and then, on the 
Design tab, in the Type group, clicking Change Chart Type to display the Change Chart Type 
dialog box. Click Templates, and then click the template you want to use.
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In this exercise, you’ll change a chart’s layout, apply a new Chart Style, change the 
number format of the values on the vertical axis, save the chart as a chart template, 
and apply the template to another chart.

SET UP You need the VolumeByCenter_start workbook located in your Chapter10 
practice file folder to complete this exercise. Open the VolumeByCenter_start 
workbook, and save it as VolumeByCenter. Then follow the steps. 

1. On the Presentation worksheet, select the chart.

2. On the Design tab, in the Chart Layouts group, click the first chart layout (its 
screen tip says the layout name is Layout 1).

Excel changes the chart’s layout.

3. On the Design contextual tab, in the Chart Styles group, click the More button.

The Chart Styles gallery expands.
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4. Click Style 7 (it’s the second-from-the-right style on the top row of the gallery).

Excel changes the chart’s style.

5. Right-click the values on the vertical axis, and then click Format Axis.

The Format Axis dialog box opens.

6. In the left pane, click Number.

The Format Axis dialog box displays the Number page.

7. In the Category list, click Number.

The Format Axis dialog box displays the Number style’s options.

8. In the Decimal places field, type 0.

9. If necessary, select the Use 1000 Separator (,) check box.

10. Click Close.
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Excel changes the format of the values on the vertical axis.

11. On the Design contextual tab, in the Type group, click Save As Template.

The Save Chart Template dialog box opens.

12. In the File name field, type Cool Blue.

13. Click Save.

Excel saves your template.

14. On the tab bar, click the Yearly Summary sheet tab.

The Yearly Summary worksheet appears.
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15. Select the chart and then, on the Design tab, in the Type group, click Change 
Chart Type.

The Change Chart Type dialog box opens.

16. Click Templates.

The My Templates list appears.

17. Click the Cool Blue custom template, and then click OK.

Excel applies the template to your chart.

CLEAN UP Save the VolumeByCenter workbook, and then close it.

Customizing the Appearance of Charts
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Finding Trends in Your Data
You can use the data in Excel workbooks to discover how your business has performed in 
the past, but you can also have Excel 2010 make its best guess, for example, as to future 
shipping revenues if the current trend continues. As an example, consider a graph that 
shows the fleet maintenance costs for the years 2004 through 2009 for Consolidated 
Messenger.

The total has increased from 2004 to 2009, but the growth hasn’t been uniform, so 
guessing how much maintenance costs would increase if the overall trend continued 
would require difficult mathematical computations. Fortunately, Excel knows that math. 
To have Excel project future values in the maintenance costs data series, click the chart 
and then, on the Layout tab, in the Analysis group, click Trendline. Click More Trendline 
Options to display the Format Trendline dialog box.

With the Trendline Options page of the Format Trendline dialog box, you can choose 
the data distribution that Excel should expect when it makes its projection. The right 
choice for most business data is Linear—the other distributions (such as Exponential, 
Logarithmic, and Polynomial) are used for scientific and operations research 
applications.
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Tip If you don’t know which distribution to choose, use Linear. The other distributions are 
used for scientific and engineering applications and you will know, or be told by a colleague, 
when to use them.

After you pick the distribution type, you need to tell Excel how far ahead to project 
the data trend. The horizontal axis of the chart used in this example shows revenues by 
year from 2004 to 2009. To tell Excel how far in the future to look, type a number in the 
Forecast area’s Forward box. In this case, to look ahead one year, type 1 in the Forward 
box, and then click OK to add the trendline to the chart.

Tip When you click the Trendline button in the Analysis group, one of the options Excel 
displays is Linear Forecast Trendline, which adds a trendline with a two-period forecast.

As with other chart elements, you can double-click the trendline to open a formatting 
dialog box and change the line’s appearance.
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In this exercise, you’ll add a trendline to a chart.

SET UP You need the FutureVolumes_start workbook located in your Chapter10 
practice file folder to complete this exercise. Open the FutureVolumes_start 
workbook, and save it as FutureVolumes. Then follow the steps. 

1. Select the chart.

2. On the Layout contextual tab, in the Analysis group, click Trendline, and then 
click More Trendline Options.

The Format Trendline dialog box opens.

3. If necessary, in the Trend/Regression Type area, click Linear.

4. In the Forecast area, in the Forward field, type 3.

5. Click Close.

Excel adds the trendline to the chart.

CLEAN UP Save the FutureVolumes workbook, and then close it.

Summarizing Your Data by Using Sparklines
You can create charts in Excel workbooks to summarize your data visually, by using 
legends, labels, and colors to highlight aspects of your data. It is possible to create 
very small charts to summarize your data in an overview worksheet, but you can also 
use sparklines, which are new in Excel 2010, to create compact, informative charts that 
provide valuable context for your data.

Edward Tufte introduced sparklines in his book Beautiful Evidence (Graphics Press, 2006), 
with the goal of creating charts that imparted their information in approximately the same 
space as a word of printed text. In Excel 2010, a sparkline occupies a single cell, which makes 
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it ideal for use in summary worksheets. As an example, suppose Lori Penor wanted to sum-
marize the monthly revenue data for one of Consolidated Messenger’s local branches.

Lori can create three types of sparklines: line, column, and win/loss. The line and column 
sparklines are compact versions of the standard line and column charts. The win/loss 
sparkline indicates whether a cell value is positive (a win), negative (a loss), or zero (a tie). 
To create a line sparkline, you select the data you want to summarize and then, on the 
Insert tab, in the Sparklines group, click the Line button. When you do, Excel 2010 
displays the Create Sparklines dialog box.

The data range you selected appears in the Data Range box. If the data range is not 
correct, you can click the Collapse Dialog button to the right of the Data Range box, 
select the correct cells, and then click the Expand Dialog button. Then, in the Location 
Range box, type the address of the cell into which you want to place your sparkline. 
When you click OK, Excel creates a line sparkline in the cell you specified.
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You follow the same basic procedure to create a column sparkline, except that instead of 
clicking the Line button in the Insert tab’s Sparklines group, you click the Column button. 
To create a win/loss sparkline, you need to ensure that your data contains, or could con-
tain, both positive and negative values. If you measured monthly revenue for Consolidated 
Messenger, every value would be positive and the win/loss sparkline would impart no 
meaningful information. Comparing revenue to revenue targets, however, could result 
in positive, negative, or tie values, which can be meaningfully summarized by using a 
win/loss sparkline.

To create a win/loss sparkline, follow the same data selection process and click the Win/
Loss button. 
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Months in which Consolidated Messenger’s branch exceeded its revenue target appear 
in the top half of the cell in blue, months in which the branch fell short of its target 
appear in the bottom half of the cell in red, and the month in which the revenue was 
exactly the same as the target is blank.

After you create a sparkline, you can change its appearance. Because a sparkline takes up 
the entire interior of a single cell, resizing that cell’s row or column resizes the sparkline. 
You can also change a sparkline’s formatting. When you click a sparkline, Excel displays 
the Sparkline Tools Design contextual tab.

You can use the tools on the Design contextual tab to select a new style; show or hide 
value markers; change the color of your sparkline or the markers; edit the data used to 
create the sparkline; modify the labels on the sparkline’s axes; or group, ungroup, or clear 
sparklines. You can’t delete a sparkline by clicking its cell and then pressing the Delete or 
Backspace key—you must click the cell and then, on the Design contextual tab of the 
ribbon, click the Clear button.

Tip Remember that sparklines work best when displayed in compact form. If you find yourself 
adding markers and labels to a sparkline, you might consider using a regular chart to take 
advantage of its wider range of formatting and customization options.

In this exercise, you’ll create a line, column, and win/loss sparkline, change the sparkline’s 
formatting, and clear a sparkline from a cell.

SET UP You need the RevenueSummary_start workbook located in your Chapter10 
practice file folder to complete this exercise. Open the RevenueSummary_start 
workbook, and save it as RevenueSummary. Then follow the steps. 

1. Select the cell range C3:C14.

2. On the Insert tab, in the Sparklines group, click Line.

The Create Sparklines dialog box opens.

3. Verify that C3:C14 appears in the Data Range box. Then, in the Location Range 
box, type G3 and click OK.

Excel 2010 creates a line sparkline in cell G3.

4. Select the cell range C3:C14.

5. On the Insert tab, in the Sparklines group, click Column.

The Create Sparklines dialog box opens.

www.it-ebooks.info

http://www.it-ebooks.info/


280  Chapter 10 Creating Charts and Graphics

6. Verify that C3:C14 appears in the Data Range box. Then, in the Location Range 
box, type H3 and click OK.

Excel creates a column sparkline in cell H3.

7. Drag the right edge of the column H header to the right until the cell’s width is 
approximately doubled.

Excel displays more details in the sparkline.

8. Select the cell range E3:E14.

9. On the Insert tab, in the Sparklines group, click Win/Loss.

The Create Sparklines dialog box opens.

10. Verify that E3:E14 appears in the Data Range box. Then, in the Location Range 
box, type I3 and click OK.

Excel creates a win/loss sparkline in cell I3.

 11. With cell I3 still selected, on the Design contextual tab, in the Style gallery, click 
the right-most sparkline style.

Excel changes the win/loss sparkline’s appearance.

 12. Click cell G3 and then, on the Design contextual tab, in the Group group, click 
the Clear button.

The sparkline disappears.

CLEAN UP Save the RevenueSummary workbook, and then close it.
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Creating Dynamic Charts by Using PivotCharts
Just as you can create PivotTables that you can reorganize on the fly to emphasize 
different aspects of the data in a list, you can also create dynamic charts, or PivotCharts, 
to reflect the contents and organization of a PivotTable.

Creating a PivotChart is fairly straightforward. Just click any cell in a list or Excel table 
you would use to create a PivotTable, and then click the Insert tab. In the Tables group, 
in the PivotTable list, click PivotChart to create the chart. To create a PivotChart from 
an existing PivotTable, click a cell in the PivotTable, display the Insert tab and then, in 
the Charts group, click the type of chart you want to create. After you complete either 
of these procedures, Excel displays a new PivotChart in your workbook.

Any changes to the PivotTable on which the PivotChart is based are reflected in the 
PivotChart. For example, if the data in an underlying data set changes, clicking the Refresh 
button in the Data group on the Analyze contextual tab will change the PivotChart 
to reflect the new data. Also, if you filter the contents of a PivotTable, the filter will be 
reflected in the PivotChart. For instance, if you click 2006 in the Year list of a revenue 
analysis PivotTable and then click OK, both the PivotTable and the PivotChart will show 
only revenues from 2006.
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See Also For more information on manipulating PivotTables, see “Filtering, Showing, and 
Hiding PivotTable Data” in Chapter 9, “Creating Dynamic Worksheets by Using PivotTables.”

A PivotChart has tools with which you can filter the data in the PivotChart and PivotTable. 
Clicking the Year arrow, clicking (All) in the list that appears, and then clicking OK will  
restore the PivotChart to its original configuration.

If you ever want to change the chart type of an existing chart, you can do so by selecting 
the chart and then, on the Design tab, in the Type group, clicking Change Chart Type to 
display the Change Chart Type dialog box. When you select the type you want and click 
OK, Excel re-creates your chart.

Important If your data is the wrong type to be represented by the chart type you select, 
Excel displays an error message.

In this exercise, you’ll create a PivotTable and associated PivotChart, change the underlying 
data and update the PivotChart to reflect that change, change the PivotChart’s type, and 
then filter a PivotTable and PivotChart.
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SET UP You need the RevenueAnalysis_start workbook located in your Chapter10 
practice file folder to complete this exercise. Open the RevenueAnalysis_start 
workbook, and save it as RevenueAnalysis. Then follow the steps. 

1. On the Through 2009 worksheet, click any cell in the Excel table.

2. On the Insert tab, in the Tables group, click the PivotTable arrow and then, in the 
list that appears, click PivotChart.

The Create PivotTable With PivotChart dialog box opens.

3. Verify that the QuarterlyRevenue table appears in the Table/Range field and that 
the New Worksheet option is selected.

4. Click OK.

Excel creates the PivotTable and associated PivotChart.

5. In the PivotTable Field List task pane, drag the Center field header from the 
Choose fields to add to report area to the Legend Fields area.

6. Drag the Year field header from the Choose fields to add to report area to the 
Axis Fields area.

7. Drag the Quarter field header from the Choose fields to add to report area to 
the Axis Fields area, positioning it below the Year field header.

8. Drag the Revenue field header from the Choose fields to add to report area to 
the Values area.

Excel updates the PivotChart to reflect the field placements.
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9. Click the 2010 sheet tab.

The 2010 worksheet appears.

10. Select the data in cells B2:E10, and then press Ctrl+C.

Excel copies the data to the Microsoft Office Clipboard.

11. On the tab bar, click the Through 2009 sheet tab.

The Through 2009 worksheet appears.

12. Select cell B147, and then press Ctrl+V.

Excel pastes the data into the worksheet and includes it in the Excel table.

13. Click the tab of the worksheet that contains the PivotTable and the PivotChart.

The PivotChart appears.
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14. Select the PivotChart and then, on the Analyze contextual tab, in the Data group, 
click Refresh.

Excel adds the new table data to your PivotChart.

15. On the Design contextual tab, in the Type group, click Change Chart Type.

The Change Chart Type dialog box opens.

16. Click Line, and then click the first Line chart subtype.

17. Click OK.

Excel changes your PivotChart to a line chart.

18. In the PivotTable Field List task pane, in the Choose fields to add to report 
area, point to the Center field header.
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19. Click the filter arrow that appears and then, in the filter menu, clear the Select All 
check box.

Excel removes the check boxes from the filter list items.

20. Select the Northeast check box, and then click OK.

Excel filters the PivotChart.

CLEAN UP Save the RevenueAnalysis workbook, and then close it.

Creating Diagrams by Using SmartArt
As an international delivery company, Consolidated Messenger’s business processes are 
quite complex. Many times, chief operating officer Lori Penor summarizes the company’s 
processes for the board of directors by creating diagrams. Excel has just the tool she needs 
to create those diagrams: SmartArt. To create a SmartArt graphic, on the Insert tab, in the 
Illustrations group, click SmartArt to display the Choose A SmartArt Graphic dialog box.
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Clicking one of the buttons in the Choose A SmartArt Graphic dialog box selects the 
type of diagram the button represents and causes a description of the diagram type 
to appear in the rightmost pane of the dialog box. Clicking All displays every available 
SmartArt graphic type. The following table lists the nine types of diagrams you can 
create by using the Choose A SmartArt Graphic dialog box.

Diagram Description
List Shows a series of items that typically require a large amount of text  

to explain
Process Shows a progression of sequential steps through a task, process, or 

workflow
Cycle Shows a process with a continuous cycle or relationships of core elements

Hierarchy Shows hierarchical relationships, such as those within a company

Relationship Shows the relationships between two or more items

Matrix Shows the relationship of components to a whole by using quadrants

Pyramid Shows proportional, foundation-based, or hierarchical relationships such 
as a series of skills

Picture Shows one or more images with captions

Office.com Shows diagrams available from Office.com

Tip Some of the diagram types can be used to illustrate several types of relationships. Be 
sure to examine all your options before you decide on the type of diagram to use to illustrate 
your point.
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After you click the button representing the type of diagram you want to create, clicking 
OK adds the diagram to your worksheet. 

While the diagram is selected, Excel displays the SmartArt Tools Design and Format 
contextual tabs. You can use the tools on the Design contextual tab to change the 
graphic’s layout, style, or color scheme. The Design contextual tab also contains 
the Create Graphic group, which is home to tools you can use to add a shape to the 
SmartArt graphic, add text to the graphic, and promote or demote shapes within  
the graphic.

As an example, consider a process diagram that describes how Consolidated Messenger 
handles a package within one of the company’s regional distribution centers.
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The Text Pane, located to the left of the SmartArt graphic, enables you to add text to a 
shape without having to click and type within the shape. If you enter the process steps 
in the wrong order, you can move a shape by right-clicking the shape you want to move 
and then clicking Cut on the shortcut menu that appears. To paste the shape back into the 
graphic, right-click the shape to the left of where you want the pasted shape to appear, 
and then click Paste. For example, if you have a five-step process and accidentally switch 
the second and third steps, you can move the third step to the second position by right-
clicking the third step, clicking Cut, right-clicking the first shape, and then clicking Paste.

If you want to  add a shape to a SmartArt graphic, to add a step to a process, for instance, 
click a shape next to the position you want the new shape to occupy and then, on the 
Design contextual tab, in the Create Graphic group, click Add Shape, and then click 
the option that represents where you want the new shape to appear in relation to the 
selected shape.
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Tip The options that appear when you click Add Shape depend on the type of SmartArt 
graphic you created and which graphic element is selected. For an organizational chart, the 
options are Add Shape After, Add Shape Before, Add Shape Above, Add Shape Below, and 
Add Assistant.

You can edit the graphic’s elements by using the buttons on the Format contextual tab as 
well as by right-clicking the shape and then clicking Format Shape to display the Format 
Shape dialog box. If you have selected the text in a shape, you can use the tools in the 
Font group on the Home tab to change the text’s appearance.

Tip The controls in the Format Shape dialog box enable you to change the shape’s fill color, 
borders, shadow, 3-D appearance, and text box properties.

In this exercise, you’ll create an organization chart, fill in the shapes, delete a shape, add a 
shape, change the layout of the diagram without changing the information it embodies, 
and change the formatting of one of the diagram elements.

SET UP You need the OrgChart_start workbook located in your Chapter10 practice 
file folder to complete this exercise. Open the OrgChart_start workbook, and save it 
as OrgChart. Then follow the steps. 

1. On the Insert tab, in the Illustrations group, click SmartArt.

The Choose A SmartArt Graphic dialog box opens.

2. Click Hierarchy.

The Hierarchy graphic subtypes appear.
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3. Click the first subtype (Organization Chart), and then click OK.

Excel creates the organization chart graphic.

4. In the Type your text here pane, in the first text box, type CEO, and then press 
the Down Arrow key.

The value CEO appears in the shape at the top level of the organization chart.

5. In the SmartArt diagram, right-click the assistant box, located below and to the left 
of the CEO shape, and then click Cut.

Excel removes the shape and moves the shapes on the third level of the organization 
chart to the second level.

6. Click the leftmost shape on the second level of the organization chart, and then 
type COO.

7. Click the middle shape on the second level of the organization chart, and then 
type CIO.
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8. Click the rightmost shape on the second level of the organization chart, and then 
type CFO.

9. Click the CFO shape. On the Design contextual tab, in the Create Graphic group, 
in the Add Shape list, click Add Shape Below.

A new shape appears below the CFO shape.

10. In the new shape, type Comptroller.

11. On the Design contextual tab, in the Layouts group, click the second layout from 
the left on the second line of layouts.

Excel applies the new layout to your organization chart.

12. Right-click the Comptroller shape, and then click Format Shape.

The Format Shape dialog box opens.

13. If necessary, click the Fill category.

Excel displays the fill options.
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14. Verify that the Solid fill option is selected, click the Color button and then, in the 
Standard color area of the color picker, click the red square.

15. Click Close.

Excel changes the shape’s fill to red.

CLEAN UP Save the OrgChart workbook, and then close it. 

Creating Shapes and Mathematical Equations
With Excel, you can analyze your worksheet data in many ways, including summarizing 
your data and business processes visually by using charts and SmartArt. You can also 
augment your worksheets by adding objects such as geometric shapes, lines, flowchart 
symbols, and banners. 
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To add a shape to your worksheet, click the Insert tab and then, in the Illustrations group, 
click the Shapes button to display the shapes available. When you click a shape in the 
gallery, your mouse pointer changes from a white arrow to a thin black crosshair. To 
draw your shape, click anywhere in the worksheet and drag the mouse pointer until 
your shape is the size you want. When you release the mouse button, your shape  
appears and Excel displays the Drawing Tools Format contextual tab on the ribbon.

Tip Holding down the Shift key while you draw a shape keeps the shape’s proportions constant. 
For example, clicking the Rectangle tool and then holding down the Shift key while you draw 
the shape causes you to draw a square.

You can resize a shape by clicking the shape and then dragging one of the resizing handles 
around the edge of the shape. Dragging a handle on a side of the shape lets you drag that 
side to a new position; dragging a handle on the corner of the shape lets you affect height 
and width simultaneously. If you hold down the Shift key while you drag a shape’s corner, 
Excel keeps the shape’s height and width in proportion as you drag the corner. To rotate a 
shape, select the shape and then drag the green circle at the top of the selection outline in 
a circle until the shape is in the orientation you want.

Tip You can assign your shape a specific height and width by clicking the shape and then, 
on the Format contextual tab, in the Size group, typing the values you want in the height 
and width boxes.

After you create a shape, you can use the controls on the Format contextual tab to change 
its formatting. To apply a pre-defined style, click the More button at the bottom right 
corner of the Shape Styles group’s gallery and then click the style you want to apply. 
If none of the pre-defined styles are exactly what you want, you can use the Shape 
Fill, Shape Outline, and Shape Effects buttons’ options to change those aspects of the 
shape’s appearance.

Tip When you point to a formatting option, such as a style or option displayed in the Shape 
Fill, Shape Outline, or Shape Effects lists, Excel displays a live preview of how your shape would 
appear if you applied that formatting option. You can preview as many options as you like 
before committing to a change.
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If you want to use a shape as a label or header in a worksheet, you can add text to the 
shape’s interior. To do so, select the shape and begin typing; when you’re done adding 
text, click outside the shape to deselect it. You can edit a shape’s text by moving the 
mouse pointer over the text. When the mouse pointer is in position for you to edit the 
text, it will change from a white pointer with a four-pointed arrow to a black I-bar. You 
can then click the text to start editing it. If you want to change the text’s appearance, 
you can use the commands on the Home tab or on the Mini Toolbar that appears 
when you select the text.

You can move a shape within your worksheet by dragging it to a new position. If your 
worksheet contains multiple shapes, you can align and distribute them within the work-
sheet. Aligning shapes horizontally means arranging them so they are lined up by their 
top edge, bottom edge, or center. Aligning them vertically means they have the same 
right edge, left edge, or center. To align a series of shapes, hold down the Ctrl key and 
click the shapes you want to align. Then, on the Format contextual tab, in the Arrange 
group, click Align, and then click the alignment option you want. 

Distributing shapes moves the shapes so they have a consistent horizontal or vertical 
distance between them. To do so, select three or more shapes on a worksheet, click the 
Format contextual tab and then, in the Arrange group, click Align and then click either 
Distribute Horizontally or Distribute Vertically.
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If you have multiple shapes on a worksheet, you will find that Excel arranges them from 
front to back, placing newer shapes in front of older shapes. 

To change the order of the shapes, select the shape in the back, click the Format con-
textual tab, and then, in the Arrange group, click Bring Forward. When you do, Excel 
moves the back shape in front of the front shape. Clicking Send Backward has the 
opposite effect, moving the selected shape one layer back in the order. If you click the 
Bring Forward button’s arrow, you can choose to bring a shape all the way to the front 
of the order; similarly, by clicking the Send Backward button’s arrow, you can choose 
to send a shape to the back of the order.

One other way to work with shapes in Excel is to add mathematical equations to their 
interior. As an example, a business analyst might evaluate Consolidated Messenger’s 
financial performance using a ratio that can be expressed using an equation. To add an 
equation to a shape, click the shape and then, on the Insert tab, in the Symbols group, 
click Equation, and then click the Equation Tools Design contextual tab on the ribbon to 
display the new interface for editing equations.
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Tip Clicking the Equation button’s arrow displays a list of common equations, such as the 
Pythagorean Theorem, that you can add with a single click.

Click any of the controls in the Structures group to begin creating an equation of that 
type. You can fill in the details of a structure by adding text normally or by adding 
symbols from the gallery in the Symbols group.

In this exercise, you’ll create a circle and a rectangle, change the shapes’ formatting, 
reorder the shapes, align the shapes, add text to the circle, and then add an equation 
to the rectangle.

SET UP You need the Shapes_start workbook located in your Chapter10 practice 
file folder to complete this exercise. Open the Shapes_start workbook, and save it 
as Shapes. Then follow the steps. 

1. On the Insert tab, in the Illustrations group, click the Shapes button, and then 
click the oval.

The mouse pointer changes to a thin black crosshair.

2. Starting near cell C3, hold down the Shift key and drag the mouse pointer to 
approximately cell E9.

Excel draws a circle.

3. On the Format contextual tab, in the Shapes Styles group’s gallery, click the 
second style.

Excel formats the shape with white text and a black background.

4. On the Insert tab, in the Illustrations group, click the Shapes button, and then 
click the rectangle shape.

The mouse pointer changes to a thin black crosshair.

5. Starting near cell G3, drag the mouse pointer to cell K9.

Excel draws a rectangle.

6. On the Format contextual tab, in the Shapes Styles group’s gallery, click the 
first style.

Excel formats the shape with black text, an orange border, and a white background.
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7. Click the circle and type 2011 Revenue Projections. Then, on the Home tab, in 
the Alignment group, click the Middle Align button.

The text is centered vertically within the circle.

8. On the Home tab, in the Alignment group, click the Center button.

The text is centered horizontally within the circle.

9. Hold down Ctrl and click the circle and the rectangle. Then, on the Format contextual 
tab, in the Arrange group, click the Align button and then click Align Center.

Excel centers the shapes horizontally.

10. Without releasing the selection, on the Format contextual tab, in the Arrange 
group, click the Align button and then click Align Middle. 

Excel centers the shapes vertically.
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11. Click any spot on the worksheet outside of the circle and rectangle to release the 
selection, and then click the rectangle.

12. On the Format contextual tab, in the Arrange group, click Send Backward.

Excel moves the rectangle behind the circle.

13. Press Ctrl+Z to undo the last action.

Excel moves the rectangle in front of the circle.

14. Click anywhere on the worksheet except on the circle or the rectangle. Click the 
rectangle and then, on the Insert tab, in the Symbols group, click Equation.

The text Type Equation Here appears in the rectangle.

15. On the Equation Tools Design contextual tab, in the Structures group, click the 
Script button, and then click the Subscript structure (the second from the left in 
the top row).

The Subscript structure’s outline appears in the rectangle.

16. Click the left box of the structure and type Year.

17. Click the right box of the structure and type Previous.

18. Press the Right Arrow key once to move the cursor to the right of the word Previous 
and then, in the Symbols group’s gallery, click the Plus Minus symbol (the first 
symbol on the top row).
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19. In the Symbols group’s gallery, click the Infinity symbol (the second symbol on 
the top row).

20. Select all of the text in the rectangle and then, on the Home tab, in the Font 
group, click the Increase Font Size button four times.

Excel increases the equation text’s font size.

CLEAN UP Save the Shapes workbook, and then close it. If you’re not continuing 
directly to the next chapter, exit Excel.
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Key Points
● You can use charts to summarize large sets of data in an easy-to-follow visual format.

● You’re not stuck with the chart you create; if you want to change it, you can.

● If you format many of your charts the same way, creating a chart template can save 
you a lot of work in the future.

● Adding chart labels and a legend makes your chart much easier to follow.

● If your chart data represents a series of events over time (such as monthly or 
yearly sales), you can use trendline analysis to extrapolate future events based 
on the past data.

● With sparklines, which are new in Excel 2010, you can summarize your data in a 
compact space, providing valuable context for values in your worksheets.

● With a PivotChart, you can rearrange your chart on the fly, emphasizing different 
aspects of the same data without having to create a new chart for each view.

● With Excel, you can quickly create and modify common business and organizational 
diagrams, such as organization charts and process diagrams.

● You can create and modify shapes to enhance your workbook’s visual impact.

● The improved equation editing capabilities help Excel 2010 users communicate 
their thinking to their colleagues.
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11 Printing
In this chapter, you will learn how to
✔ Add headers and footers to printed pages.
✔ Prepare worksheets for printing.
✔ Print worksheets.
✔ Print parts of worksheets.
✔ Print charts.

Microsoft Excel 2010 gives you a wide range of tools with which to create and manipu-
late your data. By using filters, by sorting, and by creating PivotTables and charts, you can 
change your worksheets so that they convey the greatest possible amount of information. 
After you configure your worksheet so that it shows your data to best advantage, you can 
print your Excel documents to use in a presentation or include in a report. You can choose 
to print all or part of any of your worksheets, change how your data and charts appear 
on the printed page, and even suppress any error messages that might appear in your 
worksheets.

In this chapter, you’ll learn how to prepare your worksheets for printing, print all or part 
of a worksheet, print charts, and add headers and footers to your worksheets.

Practice Files Before you can complete the exercises in this chapter, you need to copy 
the book’s practice files to your computer. The practice files you’ll use to complete the 
exercises in this chapter are in the Chapter11 practice file folder. A complete list of 
practice files is provided in “Using the Practice Files” at the beginning of this book.
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Adding Headers and Footers to Printed Pages
If you want to ensure that the same information appears at the top or bottom of every 
printed page, you can do so by using headers or footers. A header is a section that 
appears at the top of every printed page; a footer is a section that appears at the bot-
tom of every printed page. To create a header or footer in Excel, you display the Insert 
tab and then, in the Text group, click Header & Footer to display the Header & Footer 
Tools Design contextual tab.

Troubleshooting The appearance of buttons and groups on the ribbon changes depending 
on the width of the program window. For information about changing the appearance of 
the ribbon to match our screen images, see “Modifying the Display of the Ribbon” at the 
beginning of this book.

When you display your workbook’s headers and footers, Excel displays the workbook 
in Page Layout view. Page Layout view shows you exactly how your workbook will look 
when printed, while still enabling you to edit your file, a capability not provided by Print 
Preview. You can also switch to Page Layout view by displaying the View tab and then, in 
the Workbook Views group, clicking Page Layout.
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See Also For information about editing your workbook in Print Preview mode, see the 
“Previewing Worksheets Before Printing” section later in this chapter.

Excel divides its headers and footers into left, middle, and right sections. When you 
point to an editable header or footer section, Excel highlights the section to indicate 
that clicking the left mouse button will open that header or footer section for editing.

Tip If you have a chart selected when you click the Header & Footer button on the Insert 
tab, Excel displays the Header/Footer page of the Page Setup dialog box instead of opening 
a header or footer section for editing.

When you click a header or footer section, Excel displays the Design contextual tab on 
the ribbon. The Design contextual tab contains several standard headers and footers, 
such as page numbers by themselves or followed by the name of the workbook. To add 
an Auto Header to your workbook, display the Design contextual tab and then, in the 
Header & Footer group, click Header. Then click the header you want to apply. The list 
of headers that appears will vary depending on the properties and contents of your 
worksheet and workbook.
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You can also create custom headers by typing your own text or by using the commands 
in the Header & Footer Elements group to insert a date, time, worksheet name, or page 
number. You can also add a graphic, such as a company logo, to a worksheet. By adding 
graphics, you can identify the worksheet as referring to your company and help reinforce 
your company’s identity if you include the worksheet in a printed report distributed out-
side your company. After you insert a graphic into a header or footer, the Format Picture 
button in the Header & Footer Elements group will become available. Clicking that button 
opens a dialog box with tools for editing your graphic.

In this exercise, you’ll create a custom header for a workbook. You’ll add a graphic to the 
footer and then edit the graphic by using the Format Picture dialog box.

SET UP You need the RevenueByCustomer_start workbook and the 
ConsolidatedMessenger image located in your Chapter11 practice file folder  
to complete this exercise. Start Excel, open the RevenueByCustomer_start  
workbook, and save it as RevenueByCustomer. Then follow the steps.

1. On the Insert tab, in the Text group, click Header & Footer.

Excel displays your workbook in Page Layout view.
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2. In the middle header section, type Q1 2010, and then press Enter.

3. On the Design contextual tab, in the Header & Footer Elements group, click 
File Name.

Excel adds the &[File] code to the header.

4. To the right of the &[File] code, type a comma, and then press the Spacebar.

5. On the Design contextual tab, in the Header & Footer Elements group, click 
Current Date.

Excel changes the contents of the middle header section to &[File], &[Date].

6. Press Tab.

Excel highlights the right header section; the workbook name and current date 
appear in the middle header section.

7. On the Design contextual tab, in the Navigation group, click Go to Footer.

Excel highlights the right footer section.

8. Click the middle footer section.
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9. On the Design contextual tab, in the Header & Footer Elements group, click 
Picture.

The Insert Picture dialog box opens.

10. Navigate to the Chapter11 folder, and then double-click ConsolidatedMessenger.png.

The code &[Picture] appears in the middle footer section.

11. Click any worksheet cell above the footer.

Excel displays the worksheet as it will be printed.

12. Click the image in the footer and then, on the Design contextual tab, click Format 
Picture.

The Format Picture dialog box opens.

13. Click the Size tab if the Size page is not already displayed.

14. In the Scale area of the dialog box, in the Height field, type 80%, and then press 
Enter.

The Format Picture dialog box closes.
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15. Click any worksheet cell above the footer. 

Excel displays the newly formatted picture.

CLEAN UP Save the RevenueByCustomer workbook, and then close it.

Preparing Worksheets for Printing
When you are ready to print your workbook, you can change the workbook’s properties 
to ensure that your worksheets display all your information and that printing is centered 
on the page. In Excel, all of these printing functions are gathered together in one place: 
the Backstage view. To preview your workbook in the Backstage view, click the File tab 
and then click Print.

Keyboard Shortcut Press Ctrl+P to preview your worksheet in the Backstage view.

See Also For more information about keyboard shortcuts, see “Keyboard Shortcuts” at the 
end of this book.
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Excel comes with three margin settings: Normal, Wide, and Narrow. Excel applies the 
Normal setting by default, but you can select any of the three options by displaying  
the workbook in the Backstage view and then, in the Settings area, clicking the Margins 
button and clicking the desired setting. If you want finer control over your margins, click 
the Margins button and then Custom Margins to display the Margins page of the Page 
Setup dialog box.

If you want to display a worksheet’s margins while you have its workbook open in 
the Backstage view, click the Show Margins button near the bottom-right corner of the 
Backstage view window.
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You can drag each margin line to change the corresponding margin’s position, increasing 
or decreasing the amount of space allocated to each worksheet section. Do bear in mind 
that increasing the size of the header or footer reduces the size of the worksheet body, 
meaning that fewer rows can be printed on a page.

Another issue with printing worksheets is that the data in worksheets tends to be wider 
horizontally than a standard sheet of paper. You can use the commands in the Backstage 
view to change the alignment of the rows and columns on the page. When the columns 
parallel the long edge of a piece of paper, the page is laid out in portrait mode; when 
the columns parallel the short edge of a piece of paper, it is in landscape mode. 
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Changing between portrait and landscape mode can result in a better fit, but you might 
find that not all of your data will fit on a single printed page. This is where the options 
available on the Scaling button in the Backstage view come to the rescue. With the Scaling 
button’s options, you can perform three tasks: reduce the size of the worksheet’s contents 
until the worksheet can be printed on a single page, reduce the size of the worksheet’s 
contents until all of the worksheet’s columns fit on a single page, or reduce the size of 
the worksheet’s contents until all of the worksheet’s rows fit on a single page. You can 
make the same changes (and more) by using the controls in the Page Setup dialog box. 
To display the Page Setup dialog box, click the Page Layout tab, and then click the Page 
Setup dialog box launcher.

Previewing Worksheets Before Printing
You can view your worksheet as it will be printed by clicking the File tab and then clicking 
Print in the left pane. When you do, Excel displays the active worksheet in the Backstage 
view, which includes a preview of the printed worksheet.

When Excel displays your worksheet in the Backstage view, it shows the active worksheet 
as it will be printed with its current settings. At the bottom of the Backstage view, Excel 
indicates how many pages the worksheet will require when printed and the number of 
the page you are viewing.

Tip When you display a workbook in the Backstage view, you can see the next printed page 
by pressing the Page Down key; to move to the previous page, press the Page Up key. You 
can also use the Previous and Next arrows at the bottom of the Backstage view, type a page 
number in the Current Page box, or scroll through the pages by using the vertical scroll bar 
at the right edge of the Backstage view.

Changing Page Breaks in a Worksheet
Another way to affect how your worksheet will appear on the printed page is to change 
where Excel assigns its page breaks. A page break is the point at which Excel prints all 
subsequent data on a new sheet of paper. You can make these changes indirectly by 
modifying a worksheet’s margins, but you can do so directly by displaying your document 
in Page Break Preview mode. To display your worksheet in Page Break Preview mode, on 
the View tab, in the Workbook Views group, click Page Break Preview.
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The blue lines in the window represent the page breaks. If you want to set a page break 
manually, you can do so by displaying your worksheet in Page Break Preview mode, 
right-clicking the row header of the row below where you want the new page to start, 
and clicking Insert Page Break. In other words, if you right-click the row header of row 
15 and click Insert Page Break, row 14 will be the last row on the first printed page, and 
row 15 will be the first row on the second printed page. The same technique applies to 
columns: If you right-click the column H column header and click Insert Page Break, col-
umn G will be the last column on the first printed page, and column H will be the first 
column on the second printed page.

You can also add page breaks without displaying your workbook in Page Break Preview 
mode. To add a page break while your workbook is open in Normal view, click a row or 
column header and then, on the Page Layout tab, in the Page Setup area, click Breaks, 
and then click Insert Page Break. Items in the Breaks list also enable you to delete a page 
break or to reset all of the page breaks in your worksheets.
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Important Be sure to click a row header or column header when you want to insert a single 
page break. If you view a workbook in Page Break Preview mode, right-click a cell within the 
body of a worksheet, and then click Insert Page Break, Excel creates both a vertical page break 
to the left of the selected cell and a horizontal page break above the selected cell.

To move a page break, drag the line representing the break to its new position. Excel 
will change the worksheet’s properties so that the area you defined will be printed on 
a single page.

Changing the Page Printing Order for Worksheets
When you view a document in Page Break Preview mode, Excel indicates the order in 
which the pages will be printed with light gray words on the worksheet pages. (These 
indicators appear only in Page Break Preview mode; they don’t show up when the docu-
ment is printed.) You can change the order in which the pages are printed by displaying 
the Page Layout tab, clicking the Page Setup dialog box launcher, and displaying the 
Sheet page of the Page Setup dialog box.
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In the Page Order area, selecting the Over, Then Down option changes the order in which 
the worksheets will be printed from the default Down, Then Over. You might want to 
change the printing order to keep certain information together on consecutive printed 
pages. For example, suppose you have a worksheet that is designed to hold hourly package 
pickup information; the columns represent hours of the day, and the rows represent days 
of the month. If you want to print out consecutive days for each hour, you use Down, Then 
Over. In a typical configuration, pages 1 and 2 would enable you to see the 5:00 A.M. to 
11:00 A.M. pickups for the months of January and February, pages 3 and 4 would enable 
you to see the 12:00 P.M. to 5:00 P.M. pickups for those months, and so on.
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Changing the print order to Over, Then Down for the previous example could print 
consecutive hours for each day. Pages 1 and 2 would enable you to see the 5:00 A.M. 
to 5:00 P.M. pickups for January, and pages 3 and 4 would enable you to see the same 
pickups for February.

In this exercise, you’ll preview a worksheet before printing, change a worksheet’s margins, 
change a worksheet’s orientation, reduce a worksheet’s size, add a page break, and change 
the page printing order.

SET UP You need the PickupsByHour_start workbook located in your Chapter11 
practice file folder to complete this exercise. Open the PickupsByHour_start 
workbook, and save it as PickupsByHour. Then follow the steps. 

 1. While displaying the JanFeb worksheet, click the File tab and then click Print.

The workbook appears in the Backstage view.

2. In the Backstage view, click the Orientation button, and then click Landscape 
Orientation.

Excel reorients the worksheet.
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3. In the Backstage view, click the Scaling button, and then click Custom Scaling 
Options.

The Page page of the Page Setup dialog box opens.

4. In the Adjust to field, type 80%, and then press Enter.

Excel resizes your worksheet.

5. On the ribbon, click the Page Layout tab.

Excel displays the JanFeb worksheet and the Page Layout tab.

6. Click the row header for row 38.

Excel highlights row 38.

7. On the Page Layout tab, in the Page Setup group, click Breaks, and then click 
Insert Page Break.

Excel sets a horizontal page break above row 38.
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8. On the tab bar, click the MarJun sheet tab.

The MarJun worksheet appears.

9. On the Page Layout tab, in the Page Setup group, click Margins, and then 
click Wide.

Excel applies wide margins to the worksheet.

10. On the Page Layout tab, click the Page Setup dialog box launcher.

The Page Setup dialog box opens.

11. If necessary, click the Sheet tab.

The Sheet page is displayed.

12. In the Page order area, click Over, then down.

13. Click OK.

14. If desired, click the File tab, point to Print, and then click the Print button.

Excel prints your worksheet.

CLEAN UP Save the PickupsByHour workbook, and then close it.

Printing Worksheets
When you’re ready to print a worksheet, all you have to do is click the File tab, click Print, 
and then click the Print button. If you want a little more say in how Excel prints your work-
sheet, you can use the commands on the Print page of the Backstage view to determine 
how Excel prints your worksheet. For example, you can choose the printer to which you 
want to send this job, print multiple copies of the worksheet, and select whether the copies 
are collated (all pages of a document are printed together) or not (multiple copies of the 
same page are printed together).
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If you want to print more than one worksheet from the active workbook, but not every 
worksheet in the workbook, you can select the worksheets to print from the tab bar. To 
select the worksheets to print, hold down the Ctrl key while you click the sheet tabs of the 
worksheets you want to print. Then click the File tab, click Print, and click the Print button.

Tip The worksheets you select for printing do not need to be next to one another in the 
workbook.

One helpful option on the Sheet page of the Page Setup dialog box is the Cell Errors As 
box, which enables you to select how Excel will print any errors in your worksheet. You 
can print an error as it normally appears in the worksheet, print a blank cell in place of 
the error, or choose one of two other indicators that are not standard error messages.

After you prepare your workbook for printing, you can specify which elements to print by 
displaying the Print page of the Backstage view and then clicking the Print What button, 
which displays Print Active Sheets by default. To print the entire worksheet, verify that the 
Print What button displays Print Active Sheets, and then click the Print button. To print 
every worksheet in the active workbook, click the Print What button, click the Print Entire 
Workbook option, and then click the Print button.

In this exercise, you’ll print nonadjacent worksheets in your workbook and suppress errors 
in the printed worksheet.

SET UP You need the SummaryByCustomer_start workbook located in 
your Chapter11 practice file folder to complete this exercise. Open the 
SummaryByCustomer_start workbook, and save it as SummaryByCustomer. 
Then follow the steps. 

1. If necessary, display the Summary worksheet.

2. On the Page Layout tab, click the Page Setup dialog box launcher.

The Page Setup dialog box opens.

3. Click the Sheet tab.

The Sheet page is displayed.
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4. In the Cell errors as list, click <blank>.

5. Click OK.

6. Hold down the Ctrl key and then, on the tab bar, click the Northwind sheet tab.

Excel selects the Summary and Northwind worksheets.

 7. Click the File tab, and then click Print.

The Print page of the Backstage view is displayed.

8. In the Settings area, verify that the Print Active Sheets option is selected.

9. Click any ribbon tab to cancel printing, or click the Print button if you want to print 
the worksheets.

CLEAN UP Save the SummaryByCustomer workbook, and then close it.
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Printing Parts of Worksheets
Excel gives you a great deal of control over what your worksheets look like when you 
print them, but you also have a lot of control over which parts of your worksheets will 
be printed. For example, you can use the commands available on the Print page of the 
Backstage view to choose which pages of a multipage worksheet you want to print.

In the Settings area of the Print page of the Backstage view, you can fill in the page 
numbers you want to print in the Pages From and To boxes.

Tip You can also use the Page Break Preview window to determine which pages to print, and 
if the pages aren’t in an order you like, you can use the commands on the Sheet page of the 
Page Setup dialog box to change the order in which they will be printed.

Another way you can modify how a worksheet will be printed is to have Excel fit the entire 
worksheet on a specified number of pages. For example, you can have Excel resize a work-
sheet so that it will fit on a single printed page. Fitting a worksheet onto a single page is a 
handy tool when you need to add a sales or other summary to a report and don’t want to 
spread important information across more than one page.

To have Excel fit a worksheet on a set number of pages, display the Page Layout tab and 
use the controls in the Scale To Fit group. In the Width and Height lists, you can select 
how many pages wide or tall you want your printout to be.

If you want to print a portion of a worksheet instead of the entire worksheet, you can 
define the area or areas you want to have printed. To identify the area of the worksheet 
you want to print, select the cells with the data you want to print and, on the Page Layout 
tab, in the Page Setup group, click Print Area and then click Set Print Area. Excel marks the 
area with a dotted line around the border of the selected cells and prints only the cells 
you selected. To remove the selection, click Print Area, and then click Clear Print Area.

Tip You can include noncontiguous groups of cells in the area to be printed by holding down 
the Ctrl key as you select the cells.

After you define a print area, you can use the Page Setup dialog box to position the print 
area on the page. Specifically, you can have Excel center the print area on the page by 
selecting the Horizontally and Vertically check boxes in the Center On Page area of the 
Margins page.
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If the contents of a worksheet will take up more than one printed page, you can have 
Excel repeat one or more rows at the top of the page or columns at the left of the page. 
For example, if you want to print a lengthy worksheet containing the mailing addresses 
of customers signed up to receive your company’s monthly newsletter, you could repeat 
the column headings Name, Address, City, and so forth at the top of the page. To repeat 
rows at the top of each printed page, on the Page Layout tab, in the Page Setup group, 
click Print Titles. Excel will display the Sheet page of the Page Setup dialog box. 

On the Sheet page of the Page Setup dialog box, you can use the commands in the 
Print Titles area to select the rows or columns to repeat. To choose rows to repeat at 
the top of the page, click the Collapse Dialog button next to the Rows To Repeat At 
Top box, select the rows, and then click the Expand Dialog button. The rows you  
selected appear in the Rows To Repeat At Top box.

Similarly, to have a set of columns appear at the left of every printed page, click the Collapse 
Dialog button next to the Columns To Repeat At Left box, select the columns, and then 
click the Expand Dialog button. When you’re done, click OK to accept the settings.

In this exercise, you’ll select certain pages of a worksheet to print, have Excel fit your 
printed worksheet on a set number of pages, define a multi-region print area, center  
the printed material on the page, and repeat columns at the left edge of each printed page.
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SET UP You need the HourlyPickups_start workbook located in your Chapter11 
practice file folder to complete this exercise. Open the HourlyPickups_start 
workbook, and save it as HourlyPickups. Then follow the steps. 

1. On the Page Layout tab, in the Page Setup group, click Print Titles.

The Page Setup dialog box opens, displaying the Sheet page.

2. At the right edge of the Columns to repeat at left field, click the Collapse Dialog 
button.

The dialog box collapses.

3. Select the column header of column A, and drag to select the column header of 
column B, too.

The reference $A:$B appears in the Columns To Repeat At Left field.

4. At the right edge of the Columns to repeat at left field, click the Expand Dialog 
button.

The dialog box expands.

5. Click Print Preview.

Excel displays your worksheet in the Backstage view, which includes a preview of 
how your worksheet will appear when printed.
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6. Under Pages in the Settings area, in the From field, type 1; in the To field, type 2.

7. On the ribbon, click the Page Layout tab; in the Scale to Fit group, click the 
Width arrow and then, in the list that appears, click 1 page.

8. Click the Height arrow and then, in the list that appears, click 2 pages.

Excel resizes your worksheet so that it will fit on two printed pages. The new scaling 
and size values appear in the Scale To Fit group on the Page Layout tab.

9. Select the cell range A1:E8, hold down the Ctrl key, and then select the cell range 
A38:E45.

10. On the Page Layout tab, in the Page Setup group, click Print Area, and then click 
Set Print Area.

 11. Click the Page Setup dialog box launcher.

The Page Setup dialog box opens.

 12. On the Margins page of the dialog box, in the Center on page area, select the 
Horizontally and Vertically check boxes.

 13. Click Print Preview.

Excel displays your worksheet in the Backstage view.
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14. On the ribbon, click the Page Layout tab.

Excel displays your worksheet in Normal view.

15. In the Page Setup group, click Print Area, and then click Clear Print Area.

Excel removes the print areas defined for the JanFeb worksheet.

CLEAN UP Save the HourlyPickups workbook, and then close it.

Printing Charts
With charts, which are graphic representations of your Excel data, you can communicate 
lots of information with a single picture. Depending on your data and the type of chart 
you make, you can show trends across time, indicate the revenue share for various depart-
ments in a company for a month, or project future sales using trendline analysis. After you 
create a chart, you can print it to include in a report or use in a presentation.

If you embed a chart in a worksheet, however, the chart will probably obscure some of 
your data unless you move the chart to a second page in the worksheet. That’s one way 
to handle printing a chart or the underlying worksheet, but there are other ways that 
don’t involve changing the layout of your worksheets.

To print a chart, click the chart, click the File tab, and then click Print to display the Print 
page in the Backstage view. In the Settings area, Print Selected Chart will be the only 
option available. If you click anywhere on the worksheet outside the chart, the Print 
What area opens with the Print Active Sheets option selected, meaning that the chart 
and underlying worksheet are printed as they appear on the screen. When you’re ready 
to print the chart, click the Print button.

In this exercise, you’ll print a chart.

SET UP You need the CorporateRevenue_start workbook located in your Chapter11 
practice file folder to complete this exercise. Open the CorporateRevenue_start 
workbook, and save it as CorporateRevenue. Then follow the steps. 

1. Select the chart.

 2. Click the File tab, and then click Print.

The Print page of the Backstage view is displayed.
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3. Verify that the Print Selected Chart option is selected, and then click Print (or click 
any tab on the ribbon to exit the Backstage view if you don’t want to print the chart).

CLEAN UP Close the CorporateRevenue workbook. If you’re not continuing directly 
to the next chapter, exit Excel.

Key Points
● Through the new Backstage view, Excel gives you complete control over how your 

worksheets appear on the printed page. Don’t be afraid to experiment until you 
find a look you like.

● Displaying a worksheet in the Backstage view enables you to see what your work-
sheet will look like on paper before you print, which is a useful feature, especially if 
you’re using an expensive color printer.

● You can preview where the page breaks will fall when you print a worksheet, and 
you can change them if you want.

● Don’t forget that you can have Excel avoid printing error codes! You can repeat 
rows or columns in a printed worksheet.

● If you want to print a chart without printing the rest of the accompanying worksheet, 
be sure to select the chart before you start the printing procedure.
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12 Automating 
Repetitive Tasks  
by Using Macros

In this chapter, you will learn how to
✔ Enable and examine macros.
✔ Create and modify macros.
✔ Run macros when a button is clicked.
✔ Run macros when a workbook is opened.

Many tasks you perform in Microsoft Excel 2010 are done once (for example, entering sales 
data for a particular day or adding formulas to a worksheet) or can be repeated quickly by 
using tools in Excel (for example, changing the format of a cell range). However, there are 
probably one or two tasks you perform frequently that require a lot of steps to accomplish. 
For example, you might have several cells in a worksheet that contain important data you 
use quite often in presentations to your colleagues. Instead of going through a lengthy 
series of steps to highlight the cells with the important information, you can create a 
macro, which is a recorded series of actions, to perform the steps for you. After you 
have created a macro, you can run, edit, or delete it as needed.

In Excel, you run and edit macros by using the items available in the Macros group on 
the View tab. You can make your macros easier to access by creating new buttons on the 
Quick Access Toolbar, to which you can assign your macros. If you run a macro to highlight 
specific cells in a worksheet every time you show that worksheet to a colleague, you can 
save time by adding a Quick Access Toolbar button that runs the macro to highlight the 
cells for you.

 Contents

12 Automating  
  
Repetitive Tasks  
  
by Using Macros 329

Enabling and Examining Macros. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .330
Macro Security in Excel 2010 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .330
Examining Macros . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .332

Creating and Modifying Macros . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .336
Running Macros When a Button Is Clicked . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .339
Running Macros When a Workbook Is Opened. . . . . . . . . . . . . . . . . . . . . . . . . . . . . .344
Key Points . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .347

www.it-ebooks.info

http://www.it-ebooks.info/


330  Chapter 12 Automating Repetitive Tasks by Using Macros

Another handy feature of Excel macros is that you can create macros that run when a 
workbook is opened. For example, you might want to ensure that no cells in a worksheet 
are highlighted when the worksheet opens. You can create a macro that removes any 
special formatting from your worksheet cells when its workbook opens, enabling you to 
emphasize the data you want as you present the information to your colleagues.

In this chapter, you’ll learn how to open, run, create, and modify macros; create Quick 
Access Toolbar buttons and shapes that enable you to run macros with a single mouse 
click; define macro security settings; and run a macro when a workbook is opened.

Practice Files Before you can complete the exercises in this chapter, you need to copy 
the book’s practice files to your computer. The practice files you’ll use to complete the 
exercises in this chapter are in the Chapter12 practice file folder. A complete list of 
practice files is provided in “Using the Practice Files” at the beginning of this book.

Enabling and Examining Macros
It’s possible for unscrupulous programmers to write viruses and other harmful programs 
by using the Microsoft Visual Basic for Applications (VBA) programming language, so 
you need to be sure that you don’t run macros from unknown sources. In addition to 
running protective software such as Windows Defender, you can also change your Excel 
macro security settings to control when macros can be run. After you’re sure a macro is 
safe, you open it in the Visual Basic Editor to examine its code. 

Macro Security in Excel 2010
In versions of Excel prior to Excel 2007, you could define macro security levels to determine 
which macros, if any, your workbooks would be allowed to run, but there was no work-
book type in which all macros were disallowed. Excel 2010 has several file types you can 
use to control whether a workbook will allow macros to be run. The following table 
summarizes the macro-related file types.

Extension Description
.xlsx Regular Excel 2010 workbook; macros are disabled
.xlsm Regular Excel 2010 workbook; macros are enabled

.xltx Excel 2010 template workbook; macros are disabled

.xltm Excel 2010 template workbook; macros are enabled
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When you open a macro-enabled workbook, the Excel program-level security settings 
might prevent the workbook from running the macro code. When that happens, Excel 
displays a security warning on the Message Bar.

Troubleshooting The appearance of buttons and groups on the ribbon changes depending 
on the width of the program window. For information about changing the appearance of 
the ribbon to match our screen images, see “Modifying the Display of the Ribbon” at the 
beginning of this book.

Clicking the Enable Content button lets the workbook use its macros. Always take the 
time to verify the workbook’s source and consider whether you expected the workbook 
to contain macros before you enable the content. If you decide not to enable the macros 
in a workbook, click the Close button at the right edge of the Message Bar.

You can change your program-level security settings to make them more or less restrictive; 
to do so, click the File tab, click Options, and then, in the Excel Options dialog box, click the 
Trust Center category. On the page that appears, click the Trust Center Settings button to 
display the Trust Center dialog box.
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The Excel default macro security level is Disable All Macros With Notification, which means 
that Excel displays a warning on the Message Bar but allows you to enable the macros man-
ually. Selecting the Disable All Macros Without Notification option does exactly what the 
label says. If Consolidated Messenger’s company policy is to disallow all macros in all Excel 
workbooks, its employees would select the Disable All Macros Without Notification option.

Important Because it is possible to write macros that act as viruses, potentially causing harm 
to your computer and spreading copies of themselves to other computers, you should never 
choose the Enable All Macros security setting, even if you have virus-checking software 
installed on your computer.

Examining Macros
The best way to get an idea of how macros work is to examine an existing macro. To do 
that, display the View tab. In the Macros group, click the Macros button, and then click 
View Macros. 

Tip In the Macro dialog box, you can display the macros available in other workbooks by 
clicking the Macros In box and selecting a workbook by name or selecting All Open Workbooks 
to display every macro in any open workbook. If you select either of those choices, the macro 
names that are displayed include the name of the workbook in which the macro is stored. 
Clicking This Workbook displays the macros in the active workbook.

The Macro dialog box displays a list of macros in your workbook. To view the code behind 
a macro, you click the macro’s name and then click Edit to open the Visual Basic Editor.
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Keyboard Shortcut You can also open and close the Visual Basic Editor by pressing Alt+F11.

See Also To see a complete list of keyboard shortcuts, see “Keyboard Shortcuts” at the end of 
this book.

Excel macros are recorded by using VBA. Consider, for example, the code for a macro that 
selects the cell range C4:C9 and changes the cells’ formatting to bold. The first line of the 
macro identifies the cell range to be selected (in this case, cells C4:C9). After the macro 
selects the cells, the next line of the macro changes the formatting of the selected cells to 
bold, which has the same result as clicking a cell and then clicking the Bold button in the 
Font group on the Home tab.

To see how the macro works, you can open the Macro dialog box, click the name of the 
macro you want to examine, and then click Step Into. The Visual Basic Editor opens, with 
a highlight around the instruction that will be executed next. 
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To execute an instruction, press F8. The highlight moves to the next instruction, and your 
worksheet then changes to reflect the action that resulted from executing the preceding 
instruction.

You can run a macro without stopping after each instruction by opening the Macro dialog 
box, clicking the macro to run, and then clicking Run. You’ll usually run the macro this way; 
after all, the point of using macros is to save time.

In this exercise, you’ll examine a macro in the Visual Basic Editor, move through the first 
part of the macro one step at a time, and then run the entire macro without stopping.

SET UP You need the VolumeHighlights_start workbook located in your Chapter12 
practice file folder to complete this exercise. Start Excel, open the VolumeHighlights_start 
workbook, click the Enable Content button on the Message Bar (if necessary), and 
save the workbook as VolumeHighlights. Then follow the steps. 

1. On the View tab, in the Macros group, click the Macros arrow and then, in the list 
that appears, click View Macros.

The Macro dialog box opens.

2. Click the HighlightSouthern macro, and then, to display the macro code, click Edit.

The Visual Basic Editor opens, with the code for the HighlightSouthern macro 
displayed in the Module1 (Code) window.
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3. In the Visual Basic Editor window, click the Close button.

The Visual Basic Editor closes, and Excel displays the VolumeHighlights workbook.

4. In the Macros list, click View Macros.

The Macro dialog box opens.

5. Click the HighlightSouthern macro, and then click Step Into.

The macro appears in the Visual Basic Editor, with the first macro instruction 
highlighted.

6. Press the F8 key.

Excel highlights the next instruction.

7. Press F8 again.

The macro selects the Atlantic row in the table.

8. Press F8 twice.

The macro changes the Atlantic row’s text color to red.
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9. Click the Visual Basic Editor Close button.

A warning dialog box opens, indicating that closing the Visual Basic Editor will stop 
the debugger.

10. Click OK.

The Visual Basic Editor closes.

11. In the Macros list, click View Macros.

The Macro dialog box opens.

12. Click the HighlightSouthern macro.

13. Click Run.

The Macro dialog box closes, and Excel runs the entire macro.

14. On the Quick Access Toolbar, click the Save button.

Excel saves your work.

CLEAN UP Close the VolumeHighlights workbook.

Creating and Modifying Macros
The first step of creating a macro is to plan the process you want to automate. Computers 
today are quite fast, so adding an extra step that doesn’t affect the outcome of a process 
doesn’t slow you down noticeably, but leaving out a step means you will need to re-record 
your macro. After you plan your process, you can create a macro by clicking the View tab 
and then, in the Macros group, clicking the Macros arrow. In the list that appears, click 
Record Macro. When you do, the Record Macro dialog box opens.
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After you type the name of your macro in the Macro Name box, click OK. You can now 
perform the actions you want Excel to repeat later; when you’re done, in the Macros list, 
click Stop Recording to add your macro to the list of macros available in your workbook.

To modify an existing macro, you can simply delete the macro and re-record it. Or if you 
just need to make a quick change, you can open it in the Visual Basic Editor and add to 
or change the macro’s instructions. To delete a macro, open the Macro dialog box, click 
the macro you want to delete, and then click Delete.

See Also For more information about using the Visual Basic Editor, press Alt+F11 to display 
the Visual Basic Editor, and then press F1 to display the Visual Basic Help dialog box.

In this exercise, you’ll record, edit, save, and run a macro that removes the bold formatting 
from selected cells.

SET UP You need the YearlySalesSummary_start workbook located in your Chapter12 
practice file folder to complete this exercise. Open the YearlySalesSummary_start 
workbook, click the Enable Content button on the Message Bar (if necessary), and 
save the workbook as YearlySalesSummary. Then follow the steps. 

1. On the View tab, in the Macros group, click the Macros arrow and then, in the list 
that appears, click Record Macro.

The Record Macro dialog box opens.

2. In the Macro name box, delete the existing name, and then type RemoveHighlight.

3. Click OK.

The Record Macro dialog box closes.
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4. Select the cell range C4:C7.

The text in these cells is currently bold.

5. On the Home tab, in the Font group, click the Bold button.

6. On the View tab, in the Macros list, click Stop Recording.

Excel stops recording the macro.

7. In the Macros list, click View Macros.

The Macro dialog box opens.

8. In the Macro name area, click RemoveHighlight, and then click Edit.

The Visual Basic Editor starts.

9. Edit the line of code that currently reads Range(“C4:C7”).Select so that it reads 
Range(“C3:C9”).Select.
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This macro statement selects the cell range C3:C9, not the incorrect range C4:C7.

10. On the Standard toolbar of the Visual Basic Editor, click the Save button to save 
your change.

11. On the title bar of the Visual Basic Editor window, click the Close button.

The Visual Basic Editor closes.

12. Select cells C3:C9, format them as bold, and then click cell C9.

Excel formats the cells’ contents in bold and then removes the highlight from 
cells C3:C9.

13. In the Macros list, click View Macros.

The Macro dialog box opens.

14. Click RemoveHighlight, and then click Run.

The bold formatting is removed from cells C3:C9.

15. On the Quick Access Toolbar, click the Save button.

Excel saves your workbook.

CLEAN UP Close the YearlySalesSummary workbook.

Running Macros When a Button Is Clicked
The ribbon enables you to discover the commands built into Excel quickly. However, it can 
take a few seconds to display the View tab, open the Macro dialog box, select the macro 
you want to run, and click the Run button. When you’re in the middle of a presentation,  
taking even those few seconds can reduce your momentum and force you to regain your 
audience’s attention. Excel offers several ways for you to make your macros more accessible.

If you want to display the Macro dialog box quickly, you can add the View Macros button 
to the Quick Access Toolbar. To do so, click the Customize Quick Access Toolbar button at 
the right edge of the Quick Access Toolbar, and then click More Commands to display the 
Customize The Quick Access Toolbar page of the Excel Options dialog box.
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See Also For more information about customizing the Quick Access Toolbar, see “Customizing 
the Excel 2010 Program Window” in Chapter 1, “Setting Up a Workbook.”

When you display the Popular Commands command group, you’ll see that the last item 
in the command pane is View Macros. When you click the View Macros item, click the 
Add button, and then click OK, Excel adds the command to the Quick Access Toolbar and 
closes the Excel Options dialog box. Clicking the View Macros button on the Quick Access 
Toolbar displays the Macro dialog box, which saves a significant amount of time compared 
to displaying the View tab and moving the mouse to the far right edge of the ribbon.

If you prefer to run a macro without having to display the Macro dialog box, you can 
do so by adding a button representing the macro to the Quick Access Toolbar. Clicking 
that button runs the macro immediately, which is very handy when you create a macro 
for a task you perform frequently. To add a button representing a macro to the Quick 
Access Toolbar, click the Customize Quick Access Toolbar button at the right edge of 
the Quick Access Toolbar, and then click More Commands to display the Customize The 
Quick Access Toolbar page of the Excel Options dialog box. From there, in the Choose 
Commands From list, click Macros. Click the macro you want represented on the Quick 
Access Toolbar, click Add, and then click OK.
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If you add more than one macro button to the Quick Access Toolbar or if you want to 
change the button that represents your macro on the Quick Access Toolbar, you can select 
a new button from more than 160 options. To assign a new button to your macro, click the 
macro item in the Customize Quick Access Toolbar pane and click the Modify button to 
display your choices. Click the symbol you want, type a new text value to appear when a 
user points to the button, and then click OK twice (the first time to close the Modify Button 
dialog box and the second to close the Excel Options dialog box).

Finally, you can have Excel run a macro when you click a shape in your workbook. Assigning 
macros to shapes enables you to create “buttons” that are graphically richer than those 
available on the Quick Access Toolbar. If you’re so inclined, you can even create custom 
button layouts that represent other objects, such as a remote control. To run a macro 
when you click a shape, right-click the shape, and then click Assign Macro on the short-
cut menu that opens. In the Assign Macro dialog box, click the macro you want to run 
when you click the shape, and then click OK.

Important When you assign a macro to run when you click a shape, don’t change the name of 
the macro that appears in the Assign Macro dialog box. The name that appears refers to the 
object and what the object should do when it is clicked; changing the macro name breaks that 
connection and prevents Excel from running the macro.
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In this exercise, you’ll add the View Macros button to the Quick Access Toolbar, add a 
macro button to the Quick Access Toolbar, assign a macro to a workbook shape, and 
then run the macros.

SET UP You need the PerformanceDashboard_start workbook located in your Chapter12 
practice file folder to complete this exercise. Open the PerformanceDashboard_start 
workbook, click the Enable Content button on the Message Bar (if necessary), and save 
the workbook as PerformanceDashboard. Then follow the steps. 

1. On the Quick Access Toolbar, click the Customize Quick Access Toolbar button, 
and then click More Commands.

The Customize The Quick Access Toolbar page of the Excel Options dialog box opens, 
displaying the Popular Commands category in the Choose Commands From pane.

2. In the list of available commands, click View Macros.

3. Click Add.

The View Macros command appears in the Customize Quick Access Toolbar pane.

4. In the Choose commands from list, click Macros.

The available macros appear in the pane below.

 5. In the Choose commands from pane, click SavingsHighlight.

Troubleshooting If macros in the workbook are not enabled, the SavingsHighlight 
macro will not appear in the list.
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6. Click Add.

The SavingsHighlight macro appears in the Customize Quick Access Toolbar pane.

7. In the Customize Quick Access Toolbar pane, click the SavingsHighlight 
command.

8. Click Modify.

The Modify Button dialog box opens.

9. Click the blue button with the white circle inside it (the fourth button from the left 
on the top row).

10. Click OK twice to close the Modify Button dialog box and the Excel Options 
dialog box.

The Excel Options dialog box closes, and the View Macros and SavingsHighlight 
buttons appear on the Quick Access Toolbar.

11. On the worksheet, right-click the Show Efficiency shape, and then click Assign 
Macro.

The Assign Macro dialog box opens.

12. Click EfficiencyHighlight, and then click OK.

The Assign Macro dialog box closes.

13. On the Quick Access Toolbar, click the SavingsHighlight button.

Excel runs the macro, which applies a conditional format to the values in the 
Savings column of the table on the left.
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14. Click the Show Efficiency shape.

Excel runs the macro, which applies a conditional format to the values in the 
Efficiency column of the table on the right.

15. On the Quick Access Toolbar, click the Save button to save your work.

CLEAN UP Close the PerformanceDashboard workbook.

Running Macros When a Workbook Is Opened
One advantage of writing Excel macros in VBA is that you can have Excel run a macro 
whenever a workbook is opened. For example, if you use a worksheet for presentations, 
you can create macros that render the contents of selected cells in bold type, italic, or 
different typefaces to set the data apart from data in neighboring cells. If you close a 
workbook without removing that formatting, however, the contents of your workbook 
will still have that formatting applied when you open it. Although this is not a catastrophe, 
returning the workbook to its original formatting might take a few seconds to accomplish.

Instead of running a macro manually, or even from a toolbar button or a menu, you can 
have Excel run a macro whenever a workbook is opened. The trick of making that happen is 
in the name you give the macro. Whenever Excel finds a macro with the name Auto_Open, 
it runs the macro when the workbook to which it is attached is opened.

Tip If you have your macro security set to the Disable With Notification level, clicking the 
Options button that appears on the Message Bar, selecting the Enable This Content option, 
and then clicking OK allows the Auto_Open macro to run.
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In this exercise, you’ll create and test a macro that runs whenever someone opens the 
workbook to which it is attached.

SET UP You need the RunOnOpen_start workbook located in your Chapter12 
practice file folder to complete this exercise. Open the RunOnOpen_start workbook, 
click the Enable Content button on the Message Bar (if necessary), and save the 
workbook as RunOnOpen. Then follow the steps. 

1. On the View tab, in the Macros group, click the Macros arrow and then, in the list 
that appears, click Record Macro.

The Record Macro dialog box opens.

2. In the Macro name box, delete the existing name, and then type Auto_Open.

3. Click OK.

The Record Macro dialog box closes.

4. Select the cell range B3:C11.

5. On the Home tab, in the Font group, click the Bold button twice.

The first click of the Bold button formats all the selected cells in bold; the second 
click removes the bold formatting from all the selected cells.

6. Click cell C11 and then, in the Macros list, click Stop Recording.

Excel stops recording your macro.

 7. In the Macros list, click View Macros.

The Macro dialog box opens.
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8. Click Highlight, and then click Run.

The contents of cells C4, C6, and C10 appear in bold type.

9. On the Quick Access Toolbar, click the Save button to save your work.

10. Click the Close button to close the RunOnOpen workbook.

11. Click the File tab and then, in the Recent Documents list, click RunOnOpen.xlsm. 
If a warning appears, click Enable Content, and then click OK to enable macros. 

RunOnOpen opens, and the contents of cells C4, C6, and C10 change immediately 
to regular type.

12. On the Quick Access Toolbar, click the Save button to save your work.

CLEAN UP Close the RunOnOpen workbook. If you’re not continuing directly to the 
next chapter, exit Excel.
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Key Points
● Macros are handy tools you can use to perform repetitive tasks quickly, such as 

inserting blocks of text.

● You don’t have to be a programmer to use macros; you can record your actions 
and have Excel save them as a macro.

● Excel uses macro-enabled workbook types, which have the file extensions .xlsm 
(a macro-enabled workbook) and .xltm (a macro-enabled template workbook).

● If you’re curious about what a macro looks like, you can display it in the Visual 
Basic Editor. If you know a little VBA, or if you just want to experiment, feel free 
to modify the macro code and see what happens.

● You can create Quick Access Toolbar buttons and shapes that, when clicked, run 
a macro.

● If you want a macro to run whenever you open a workbook, create a macro named 
Auto_Open.
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In this chapter, you will learn how to
✔ Include Office documents in workbooks.
✔ Store workbooks as parts of other Office documents.
✔ Create hyperlinks.
✔ Paste charts into other documents.

By itself, Microsoft Excel 2010 provides a broad range of tools so that you can store, 
present, and summarize your financial data. When you use other Microsoft Office 2010 
programs, you can extend your capabilities even further, creating databases, presenta-
tions, written reports, and custom Web pages through which you can organize and 
communicate your data in print and over networks.

All the Office programs interact with each other in many useful ways. For example, you 
can include a file created with another Office program in an Excel workbook. If you use 
Microsoft Word 2010 to write a quick note about why a customer’s shipping expenditures 
decreased significantly in January, you can include the report in your workbook. Similarly, 
you can include your Excel workbooks in documents created with other Office programs.  
If you want to copy only part of a workbook, such as a chart, to another Office docu-
ment, you can do that as well.

Excel integrates well with the Web. If you know of a Web-based resource that would be 
useful to someone who is viewing a document, you can create a hyperlink, or connection 
from a document to a place in the same file or to another file anywhere on a network or 
the Internet that the user’s computer can reach. 
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In this chapter, you will learn how to include an Office 2010 document in a worksheet, 
store an Excel workbook as part of another Office document, create hyperlinks, and paste 
an Excel chart into another document.

Practice Files Before you can complete the exercises in this chapter, you need to copy 
the book’s practice files to your computer. The practice files you’ll use to complete the 
exercises in this chapter are in the Chapter13 practice file folder. A complete list of 
practice files is provided in “Using the Practice Files” at the beginning of this book.

Including Office Documents in Workbooks
One benefit of working with Excel 2010 is that because it is part of Office 2010, it is 
possible to combine data from Excel and other Office programs to create informative 
documents and presentations. Just as you do when you combine data from more than 
one Excel document, when you combine information from another Office file with an 
Excel workbook, you can either paste the other Office document into the Excel work-
book or create a link between the workbook and the other document.

There are two advantages to creating a link between your Excel workbook and the 
other file. The first benefit is that linking to the other file, as opposed to copying the 
entire file into your workbook, keeps your Excel workbook small. If the workbook is 
copied to another drive or computer, you can maintain the link by copying the linked 
file along with the Excel workbook or by re-creating the link if the linked file is on the 
same network as the Excel workbook. It is also possible to use the workbook if the linked 
file isn’t available. The second benefit of linking to another file is that any changes in 
the file to which you link are reflected in your Excel workbook.

You create a link between an Excel workbook and another Office document by clicking 
the cell where you want the document to appear, clicking the Insert tab and then, in the 
Text group, clicking Object to display the Object dialog box. In the Object dialog box, 
click the Create From File tab.
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Clicking the Browse button on the Create From File page opens the Browse dialog box, 
from which you can browse to the folder containing the file you want to link to. After 
you locate the file, double-clicking it closes the Browse dialog box and adds the file’s 
name and path to the File Name box of the Object dialog box. To create a link to the 
file, select the Link To File check box, and click OK. When you do, the file appears in 
your workbook near the active cell.

If you want to link a file to your workbook but don’t want the file image to take up much 
space on the screen, you can also select the Display As Icon check box. After you select 
the file and click OK, the file will be represented by the same icon used to represent it in 
Windows. Double-clicking the icon displays the file.
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After you have linked a file—for example, a Microsoft PowerPoint 2010 presentation—to 
your Excel workbook, you can edit the file by right-clicking its image or icon in your work-
book and then, on the shortcut menu that appears, pointing to the appropriate Object 
command and clicking Edit. For a PowerPoint file, you point to Presentation Object. The 
file will open in its native application. When you finish editing the file, your changes 
appear in your workbook.

Tip The specific menu item you point to changes to reflect the program used to create the 
file to which you want to link. For a Word 2010 document, for example, the menu item you 
point to is Document Object.

In this exercise, you’ll link a PowerPoint 2010 presentation showing a business summary 
to an Excel workbook and then edit the presentation from within Excel. 

Important You must have PowerPoint 2010 installed on your computer to complete this 
exercise.

SET UP You need the SummaryPresentation_start workbook and 
the 2010YearlyRevenueSummary_start presentation located in your 
Chapter13 practice file folder to complete this exercise. Start Excel, open the 
SummaryPresentation_start workbook, and save it as SummaryPresentation. 
Then start PowerPoint, open the 2010YearlyRevenueSummary_start presentation,  
and save it as 2010YearlyRevenueSummary. Close PowerPoint, and then follow 
the steps. 

1. In the SummaryPresentation workbook, on the Insert tab, in the Text group, 
click Object.

The Object dialog box opens.

2. Click the Create from File tab.

The Create From File page is displayed.

3. Click Browse.

The Browse dialog box opens.
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4. Browse to the 2010YearlyRevenueSummary.pptx presentation, and then click 
Insert.

The Browse dialog box closes, and the full file path of the 
2010YearlyRevenueSummary presentation appears in the File Name box.

5. Select the Link to file check box, and then click OK.

Excel creates a link from your workbook to the presentation.

6. Right-click the presentation, point to Presentation Object, and then click Edit.

The presentation opens in a PowerPoint 2010 window.
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Troubleshooting The appearance of buttons and groups on the ribbon changes depending 
on the width of the program window. For information about changing the appearance of 
the ribbon to match our screen images, see “Modifying the Display of the Ribbon” at the 
beginning of this book.

7. Click Consolidated Messenger FY2010.

The text box containing Consolidated Messenger FY2010 is activated.

8. Select the FY2010 text, and then type Calendar Year 2010.

9. In PowerPoint, on the Quick Access Toolbar, click the Save button.

PowerPoint saves your changes, and Excel updates the linked object’s appearance 
to reflect the new text.

10. Click the File tab, and then click Save.

CLEAN UP Close the SummaryPresentation workbook and the 
2010YearlyRevenueSummary presentation. If you don’t plan to  
work through the next exercise immediately, exit PowerPoint.
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Storing Workbooks as Parts of Other  
Office Documents

In the preceding section, you linked to another file from within your Excel workbook. The 
advantages of linking to a second file are that the size of your workbook is kept small and 
any changes in the second document will be reflected in your workbook.  The disadvan-
tage is that the second document must be copied with the workbook—or at least be on 
a network-accessible computer. If Excel can’t find or access the second file where the link 
says it is located, Excel can’t display it. You can still open your workbook, but you won’t see 
the linked file’s contents.

If file size isn’t an issue and you want to ensure that the second document is always 
available, you can embed the file in your workbook. Embedding another file in an Excel 
workbook means that the entirety of the other file is saved as part of your workbook. 
Wherever your workbook goes, the embedded file goes along with it. Of course, the 
embedded version of the file is no longer connected to the original file, so changes in 
one aren’t reflected in the other.

Important To view a linked or embedded file, you must have the program used to create it 
installed on the computer on which you open the workbook.

You can embed a file in an Excel workbook by following the procedure described in the 
preceding section but leaving the Link To File check box cleared.

It is also possible to embed your Excel workbooks in other Office documents. In PowerPoint, 
for example, you can embed an Excel file in a presentation by displaying the Insert tab in 
PowerPoint and then, in the Text group, clicking Object to display the Insert Object dialog 
box. Then in the Insert Object dialog box, select Create From File.
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To identify the file you want to embed, click the Browse button and then, in the Browse 
dialog box that opens, navigate to the folder where the file is stored and double-click 
the file. The Browse dialog box closes, and the file path appears in the File box. Click OK 
to embed your workbook in the presentation.

If you want to  embed a workbook in a file created with any other Office program but 
don’t want the worksheet to take up much space on the screen, select the Display As 
Icon check box. After you select the file to embed and click OK, the file is represented  
by the same icon used to represent it in Windows. Double-clicking the icon opens 
the embedded document in its original application.

Troubleshooting If your Excel workbook’s cells don’t have a background fill color (that is, 
you have the No Fill option selected), PowerPoint treats the cells’ backgrounds as if they 
were transparent. If you were to place cells with black text and no background fill over a 
dark background, you would not be able to see the text. To make your text visible, fill the 
cells with a very light gray color so the presentation’s background doesn’t show through.

To edit an embedded Excel workbook, right-click the workbook (or the icon representing 
it) and then, on the shortcut menu that appears, point to Worksheet Object and click Edit. 
The workbook opens for editing. After you finish making your changes, you can click 
anywhere outside the workbook to return to the presentation.

In this exercise, you’ll embed an Excel workbook containing sales data in a PowerPoint 
presentation.

Important You must have PowerPoint 2010 installed on your computer to complete this 
exercise.

SET UP You need the 2010YearlyRevenueSummary presentation you created in the 
previous exercise, and the RevenueByServiceLevel_start workbook located in your 
Chapter13 practice file folder to complete this exercise. If you did not complete the 
previous exercise, you should do so now. Open the RevenueByServiceLevel_start 
workbook, and save it as RevenueByServiceLevel. Then, if necessary open the 
2010YearlyRevenueSummary presentation. Then follow the steps. 

1. In the Slides panel of the presentation window, click the second slide.

The second slide appears.

2. On the Insert tab, in the Text group, click Object.

The Insert Object dialog box opens.
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3. Select Create from file.

The Insert Object dialog box changes to allow you to enter a file name.

4. Click Browse.

The Browse dialog box opens.

5. Browse to the RevenueByServiceLevel workbook and double-click it.

The Browse dialog box closes, and the file’s full path appears in the File box.

6. Click OK.

The workbook appears in your presentation.

CLEAN UP Save the RevenueByServiceLevel workbook and the 
2010YearlyRevenueSummary presentation, and then close those files.  
Exit PowerPoint.
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Creating Hyperlinks
One of the characteristics of the Web is that documents published on Web pages can have 
references, or hyperlinks, to locations in the same document or to other Web documents. A 
hyperlink functions much like a link between two cells or between two files, but hyperlinks 
can reach any computer on the Web, not just those on a corporate network. Hyperlinks that 
haven’t been clicked usually appear as underlined blue text, and hyperlinks that have been 
followed appear as underlined purple text, but those settings can be changed.

To create a hyperlink, click the cell in which you want to insert the hyperlink and then, 
on the Insert tab, click Hyperlink. The Insert Hyperlink dialog box opens.

Keyboard Shortcut You can also open the Insert Hyperlink dialog box by pressing Ctrl+K. 

See Also For more information about keyboard shortcuts, see “Keyboard Shortcuts” at the 
end of this book.
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You can choose one of four types of targets, or destinations, for your hyperlink: an existing 
file or Web page, a place in the current document, a new document you create on the spot, 
or an e-mail address. By default, the Insert Hyperlink dialog box displays the tools to 
connect to an existing file or Web page.

To create a hyperlink to another file or Web page, you can use the Look In navigation tool 
to locate the file. If you recently opened the file or Web page to which you want to link, 
you can click either the Browsed Pages or the Recent Files button to display the Web pages 
or files in your History list.

If you want to create a hyperlink to another place in the current Excel workbook, you 
can click the Place In This Document button to display a list of available targets in the 
current workbook.
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To select the worksheet to which you want to refer, you click the worksheet name in the 
Or Select A Place In This Document box. When you do, a reference with the name of 
the worksheet and cell A1 on that worksheet appears in the Text To Display box.

If you want to refer to a cell other than A1 on the selected worksheet, click the worksheet 
name in the Or Select A Place In This Document box, and then change the cell reference 
in the Type The Cell Reference box.

You can also create a hyperlink that generates an e-mail message to an address of your 
choice. To create this type of hyperlink, which is called a mailto hyperlink, click the E-mail 
Address button.
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In the dialog box that opens, you can type the recipient’s e-mail address in the E-mail 
Address box and the subject line for messages sent via this hyperlink in the Subject box.

Tip If you use Windows Mail, Microsoft Outlook, or Microsoft Outlook Express as your 
e-mail program, a list of recently used addresses will appear in the Recently Used E-Mail 
Addresses box. You can insert any of those addresses in the E-mail Address box by clicking 
the address.

Clicking a mailto hyperlink causes the user’s default e-mail program to open and create 
a new e-mail message. The e-mail message is addressed to the address you entered in 
the E-mail Address box, and the subject is set to the text you typed in the Subject box.

Regardless of the type of hyperlink you create, you can specify the text you want to 
represent the hyperlink in your worksheet. You type that text in the Text To Display 
box. When you click OK, the text you type there appears in your worksheet, formatted  
as a hyperlink.

Tip If you leave the Text To Display box empty, the actual link will appear in your worksheet.

To edit an existing hyperlink, click the cell containing the hyperlink and then, on the 
shortcut menu that appears, click Edit Hyperlink. You can also click Open Hyperlink to 
go to the target document or create a new e-mail message, or click Remove Hyperlink 
to delete the hyperlink.

Tip If you delete a hyperlink from a cell, the text from the Text To Display box remains in the 
cell, but it no longer functions as a hyperlink.

In this exercise, you’ll create a hyperlink to another document and then a second hyperlink 
to a different location in the current workbook.

SET UP You need the Hyperlink_start and LevelDescriptions_start workbooks located in 
your Chapter13 practice file folder to complete this exercise. Open the Hyperlink_start 
workbook and save it as Hyperlink, and then open the LevelDescriptions_start workbook 
and save it as LevelDescriptions. Then follow the steps. 

1. In the Hyperlink workbook, on the Revenue by Level worksheet, click cell B9.

2. On  the Insert tab, in the Links group, click the Hyperlink button.

The Insert Hyperlink dialog box opens.

3. If necessary, click the Existing File or Web Page button.
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4. If necessary, use the controls to the right of the Look in box to navigate to the 
Chapter13 practice file folder.

The files in the target folder appear in the Insert Hyperlink dialog box.

5. In the file list, click the LevelDescriptions workbook, and then click OK.

The workbook’s full path appears in the Text To Display box and the Address box.

6. In the Text to display box, edit the value so that it reads LevelDescriptions.

7. Click OK.

8. Click the hyperlink in cell B9.

The LevelDescriptions workbook appears.

9. In the LevelDescriptions workbook, click the File tab, and then click Close.

The LevelDescriptions workbook closes.

 10. Right-click cell B11, and then click Hyperlink.

The Insert Hyperlink dialog box opens.

 11. In the Link to pane, click Place in This Document.

The document elements to which you can link appear in the dialog box.
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12. In the Or select a place in this document pane, click Notes.

13. Click OK.

The Insert Hyperlink dialog box closes, and Excel creates a hyperlink in cell B11.

14. Right-click cell B11, and then click Edit Hyperlink.

The Edit Hyperlink dialog box opens.

15. Edit the Text to display box’s value so it reads Revenue Notes.

16. Click OK.

The Edit Hyperlink dialog box closes, and the text in cell B11 changes to Revenue 
Notes.

17. On the Quick Access Toolbar, click the Save button to save your work.

CLEAN UP Close the Hyperlink and LevelDescriptions workbooks.
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Pasting Charts into Other Documents
One more way to include objects from one workbook in another Office document is to 
copy the object you want to share and then paste it into its new location. You can copy 
Excel charts to Word documents and PowerPoint presentations to reuse your data with-
out inserting a worksheet into the file and re-creating your chart in that new location. 

When you want to copy the current appearance of the chart to another document 
without creating a link back to the chart, you right-click the chart and click Copy on the 
shortcut menu that appears to copy the chart to the Microsoft Office Clipboard. Then, in 
the document into which you want to paste the chart’s image, on the Home tab of the 
ribbon, in the Clipboard group, click the Paste button’s arrow to display the palette of 
paste options available. The last option on the right, Picture, pastes an image of the 
chart in its current state.

In this exercise, you’ll copy a chart containing sales information to the Clipboard and 
paste an image of the chart into a PowerPoint presentation.

Important You must have PowerPoint installed on your computer to complete this exercise.

SET UP You need the RevenueChart_start workbook and the RevenueSummary_start 
presentation located in your Chapter13 practice file folder to complete this exercise. 
Open the RevenueChart_start workbook and save it as RevenueChart. Then open the 
RevenueSummary_start presentation and save it as RevenueSummary. Then follow 
the steps. 

1. In the RevenueChart workbook, right-click the chart, and then click Copy.

Excel copies the chart to the Clipboard.

2. Display the RevenueSummary presentation, which contains a single, blank slide.

3. Right-click a blank spot in the visible slide, and then, in the Paste Options area of 
the shortcut menu, click the Picture icon.

The chart appears as a static image.
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CLEAN UP Save the RevenueChart workbook and the RevenueSummary presentation, 
and exit PowerPoint. If you are not continuing directly to the next chapter, exit Excel.

Key Points
● Excel is a versatile program. You can exchange data between Excel and other Office 

programs in just a few steps.

● One benefit of Excel is that, because it is part of Microsoft Office 2010, you can 
embed Excel worksheets in other Office documents and embed other Office 
documents (such as PowerPoint presentations) in Excel workbooks.

● Excel works smoothly with the Web; adding hyperlinks to Web pages, other docu-
ments, or specific locations in the current workbook is possible through the Insert 
Hyperlink dialog box.

● After you create a hyperlink, you can edit it to reflect changes in the target site’s 
design and layout. 

● Excel is the easiest Microsoft Office system program in which to create charts. After 
you create a chart in Excel, you can paste it directly into another Office document.
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14 Collaborating 
with Colleagues

In this chapter, you will learn how to
✔ Share workbooks.
✔ Manage comments.
✔ Track and manage colleagues’ changes.
✔ Protect workbooks and worksheets.
✔ Authenticate workbooks.
✔ Save workbooks for the Web.

Even though one individual might be responsible for managing an organization’s financial 
data and related information, many people have input when making revenue projections. 
You and your colleagues can enhance the Microsoft Excel 2010 workbook data you share 
by adding comments that offer insight into the information the data represents, such as 
why revenue was so strong during a particular month or whether a service level might be 
discontinued. If the workbook in which those projections and comments will be stored 
is available on a network or an intranet, you can allow more than one user to access the 
workbook at a time by turning on workbook sharing. When a workbook has been shared 
with your colleagues, you can have the workbook mark and record any changes made to 
it. You can then decide which changes to keep and which to reject. 

If you prefer to limit the number of colleagues who can view and edit your workbooks, 
you can add password protection to a workbook, worksheet, cell range, or even an 
individual cell. Adding password protection prevents changes to critical elements of 
your workbooks. You can also hide formulas used to calculate values.
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If you work in an environment in which you and your colleagues, both inside and outside 
your organization, exchange files frequently, you can use a digital signature to help verify 
that your workbooks and any macros they contain are from a trusted source. 

Finally, if you want to display information on a Web site, you can do so by saving a work-
book as a Web page. Your colleagues won’t be able to edit the workbook, but they will 
be able to view it and comment by e-mail or phone.

In this chapter, you’ll learn how to share a workbook, manage comments in workbook 
cells, track and manage changes made by colleagues, protect workbooks and work-
sheets, digitally sign your workbooks, and save your workbooks for the Web.

Practice Files Before you can complete the exercises in this chapter, you need to copy 
the book’s practice files to your computer. The practice files you’ll use to complete the 
exercises in this chapter are in the Chapter14 practice file folder. A complete list of 
practice files is provided in “Using the Practice Files” at the beginning of this book.

Sharing Workbooks
To enable several users to edit a workbook simultaneously, you must turn on workbook 
sharing. Workbook sharing is perfect for an enterprise such as Consolidated Messenger, 
whose employees need to look up customer information, shipment numbers, and details 
on mistaken deliveries.

To turn on workbook sharing, on the Review tab, in the Changes group, click Share 
Workbook. On the Editing page of the Share Workbook dialog box, turn on workbook 
sharing by selecting the Allow Changes By More Than One User At The Same Time 
check box. You can then set the sharing options for the active workbook by clicking the 
Advanced tab.
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Important You can’t share a workbook that contains an Excel table. To share the workbook, 
convert the Excel table to a regular cell range by clicking the Excel table, clicking the Design 
tab and then, in the Tools group, clicking Convert To Range. Click Yes in the dialog box that 
opens to confirm the change.

On the Advanced page of the Share Workbook dialog box, two settings are of particular 
interest. The first determines whether Excel should maintain a history of changes made 
to the workbook and, if so, for how many days it should keep the history. The default 
setting is for the program to retain a record of all changes made in the past 30 days, but 
you can enter any number of days you like. If you revisit your workbook on a regular 
basis, maintaining a list of all changes for the past 180 days might not be unreasonable. 
For a workbook that changes less frequently, a history reaching back 365 days (one year) 
could meet your tracking and auditing needs. Excel deletes the record of any changes 
made earlier than the time you set.

Tip You should find out whether your organization has an information retention policy that 
would affect the amount of time you should keep your workbooks’ change histories.

The other important setting on this page deals with how Excel decides which of two 
conflicting changes in a cell should be applied. For example, a service level’s price might 
change, and two of your colleagues might type in what they think the new price should 
be. Selecting the Ask Me Which Changes Win option enables you to decide whether to 
keep the original price or the changed price.
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There are two main ways to share a workbook with your colleagues: you can make it 
available over your organization’s network, and you can send a copy of the file to your 
colleagues via e-mail. Every organization’s network is different, so you should check with 
your network administrators to determine the best way to share a file. Similarly, although 
the specific command to attach a file to an e-mail message is different in every e-mail 
program, the most common method of attaching a file is to create a new e-mail mes-
sage and then click the Attach button, as in Microsoft Outlook 2010.

In this exercise, you’ll turn on workbook sharing and then attach the file to an Outlook 
2010 e-mail message.

Important You must have Outlook 2010 installed on your computer to follow this procedure 
exactly.

SET UP You need the CostProjections_start workbook located in your Chapter14 
practice file folder to complete this exercise. Start Excel, open the CostProjections_start 
workbook, and save it as CostProjections. Then start Outlook, and follow the steps. 

1. In Excel, on the Review tab, in the Changes group, click Share Workbook.

The Share Workbook dialog box opens.

2. Select the Allow changes by more than one user at the same time check box.
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Tip Workbook merging is the process of bringing changes from several copies of a 
shared workbook into the source workbook. For more information on the topic, press 
F1 to display the Excel Help dialog box, search for workbook merging, and click the 
Merge Copies Of A Shared Workbook link.

3. Click OK.

A message box appears, indicating that you must save the workbook for the action 
to take effect.

4. Click OK.

Excel saves and shares the workbook.

5. Click the File tab, click Save & Send, and then click Send Using E-mail.

6. Click Send as Attachment.

A new e-mail message opens with the CostProjections workbook attached.

7. Type an address in the To box.

8. Click Send.

Your e-mail program sends the message. If Excel had to open your e-mail program 
to send the message, the program would close at this point.

CLEAN UP Close the CostProjections workbook.
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Saving a Workbook for Secure Electronic Distribution

You can create a secure, read-only copy of a workbook for electronic distribution 
by saving it as a Portable Document Format (PDF) or XML Paper Specification (XPS) 
file. The controls you use to do so are available on the Save & Send page of the 
Backstage view.

Tip You can also save a workbook as a PDF or XPS document by clicking the File tab 
and clicking Save As. Then, in the Save As dialog box, in the Save As Type list, select 
either PDF or XPS to create a file of the desired type.

To save a workbook as a PDF or XPS file:

1. Click the File tab, click Save & Send, click Create PDF/XPS Document, and then 
click the Create PDF/XPS button.

2. In the Publish As PDF Or XPS dialog box, select the file format you want.

3. If you plan to distribute the file online but not print it, click Minimum Size.

4. If you want to specify what portion of the workbook or types of content to 
publish, click the Options button, make your selections, and then click OK.

5. Click Publish.

Managing Comments
Excel makes it easy for you and your colleagues to insert comments in workbook cells, 
adding insights that go beyond the cell data. For example, if a regional processing 
center’s package volume is exceptionally high on a particular day, the center’s manager 
can add a comment to the cell in which shipments are recorded for that day, noting 
that two very large bulk shipments accounted for the disparity.

When you add a comment to a cell, a flag appears in the upper-right corner of the 
cell. When you point to a cell that contains a comment, the comment appears in a 
box next to the cell, along with the user name of the user who was logged on to the 
computer on which the comment was created.
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Important Note that the name attributed to a comment might not be the same as the name 
of the person who actually created it. Access controls, such as those that require users to enter 
account names and passwords when they access a computer, can help track the person who 
made a comment or change.

You can add a comment to a cell by clicking the cell, clicking the Review tab, and then 
clicking New Comment. When you do, the comment flag appears in the cell, and a 
comment box appears next to the cell. You can type the comment in the box and, 
when you’re done, click another cell to close the box. When you point to the cell that 
contains the comment, the comment appears next to the cell.

If you want a comment to be shown the entire time the workbook is open, click the cell 
that contains the comment, click the Review tab and then, in the Comments group, click 
Show/Hide Comment. You can hide the comment by clicking the same button when the 
comment appears in the workbook, and delete the comment by clicking the Review tab 
and then, in the Comments group, clicking Delete. Or you can open the comment for 
editing by clicking Edit Comment in the Comments group.

Troubleshooting The appearance of buttons and groups on the ribbon changes depending 
on the width of the program window. For information about changing the appearance of 
the ribbon to match our screen images, see “Modifying the Display of the Ribbon” at the 
beginning of this book.

Important When someone other than the original user edits a comment, that person’s input 
is marked with the new user’s name and is added to the original comment. 
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You can control whether a cell displays just the comment indicator or the indicator and 
the comment itself by clicking a cell that contains a comment and then, on the Review 
tab, clicking the Show/Hide Comment button. Clicking the Show/Hide Comment button 
again reverses your action. If you’ve just begun to review a worksheet and want to dis-
play all of the comments on the sheet, display the Review tab and click the Show All 
Comments button. To move through the worksheet’s comments one at a time, click the 
Previous or Next button.

In this exercise, you’ll add comments to two cells. You will then highlight the cells that 
contain comments, review a comment, and delete that comment.

SET UP You need the ProjectionsForComment_start workbook located in your Chapter14 
practice file folder to complete this exercise. Open the ProjectionsForComment_start 
workbook, and save it as ProjectionsForComment. Then follow the steps. 

1. Click cell E6.

2. On the Review tab, in the Comments group, click New Comment.

A red comment flag appears in cell E6, and a comment box appears next to the cell.

3. In the comment box, type Seems optimistic; move some improvement to the 
next year? 

4. Click any cell outside the comment box.

The comment box disappears.

5. Click cell G7.

6. On the Review tab, in the Comments group, click New Comment.

A red comment flag appears in cell G7, and a comment box appears next to the cell.
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7. In the comment box, type Should see more increase as we integrate new 
processes. 

8. Click any cell outside the comment box.

The comment box disappears.

9. Click cell G7.

10. On the Review tab, in the Comments group, click Delete.

Excel deletes the comment.

CLEAN UP Save the ProjectionsForComment workbook, and then close it.

Tracking and Managing Colleagues’ Changes
Whenever you collaborate with your colleagues to produce or edit a document, you should 
consider tracking the changes each user makes. When you turn on change tracking, any 
changes made to the workbook are highlighted in a color assigned to the user who made 
the changes. One benefit of tracking changes is that if you have a question about a change, 
you can quickly identify who made the change and verify that it is correct. In Excel, you can 
turn on change tracking in a workbook by clicking the Review tab and then, in the Changes 
group, clicking Track Changes and then Highlight Changes.

In the Highlight Changes dialog box that opens, select the Track Changes While Editing check 
box. Selecting this check box saves your workbook, turns on change tracking, and also shares 
your workbook, enabling more than one user to access the workbook simultaneously. 
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You can use the commands in the Highlight Changes dialog box to choose which 
changes to track. Clearing the When, Who, and Where check boxes makes Excel track 
all changes, whereas selecting a check box and using the commands to specify a time 
frame, users, or areas of the workbook limits which changes are highlighted. Each user’s 
changes are displayed in a unique color. When you point to a cell that contains a change, 
the date and time when the change was made and the name of the user who made it 
appear as a ScreenTip.

After you and your colleagues finish modifying a workbook, anyone with permission to 
open the workbook can decide which changes to accept and which changes to reject. 
To start the process, click the Review tab. In the Changes group, click Track Changes, and 
then click Accept Or Reject Changes. After you clear the message box that indicates Excel 
will save your workbook, the Select Changes To Accept Or Reject dialog box opens. From 
the When list, you can choose which changes to review. The default choice is Not Yet 
Reviewed, but you can also click Since Date to open a dialog box in which you can enter 
the starting date of changes you want to review. To review all changes in your workbook, 
clear the When, Who, and Where check boxes.

Tip After you and your colleagues have finished making changes, you should turn off workbook 
sharing to help ensure that you are the only person able to review the changes and decide 
which to accept.

When you are ready to accept or reject changes, click OK. The Accept Or Reject Changes 
dialog box opens and displays the first change, which is described in the body of the dialog 
box. Clicking the Accept button finalizes the change; clicking the Reject button removes the 
change, restores the cell to its previous value, and erases any record of the change. Clicking 
Accept All or Reject All finalizes all changes or restores all cells to their original values, but 
you should choose one of those options only if you are absolutely certain you are doing 
the right thing. 

Important Clicking the Undo button on the Quick Access Toolbar or pressing Ctrl+Z will not 
undo the operation.

You can create an itemized record of all changes made since the last time you saved the 
workbook by adding a History worksheet to your workbook. To add a History worksheet, 
click Track Changes in the Changes group, and then click Highlight Changes to open the 
Highlight Changes dialog box. Select the List Changes On A New Sheet check box. When 
you click OK, a new worksheet named History opens in your workbook. Excel will delete 
the History worksheet the next time you save your workbook.
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In this exercise, you’ll turn on change tracking in a workbook, make changes to the 
workbook, accept the changes, and create a History worksheet.

SET UP You need the ProjectionChangeTracking_start workbook 
located in your Chapter14 practice file folder to complete this exercise.  
Open the ProjectionChangeTracking_start workbook, and save it as  
ProjectionChangeTracking. Then follow the steps. 

1. On the Review tab, in the Changes group, click Track Changes, and then click 
Highlight Changes.

The Highlight Changes dialog box opens.

2. Select the Track changes while editing check box to activate the Highlight 
which changes area, and clear the When check box.

 3. Click OK.

A message box appears, indicating that Excel will save the workbook.

 4. Click OK.

The message box closes. Excel saves the workbook and begins tracking changes.

 5. In cell E6, type 16%, and then press Enter.

A blue flag appears in the upper-left corner of cell E6.

 6. In cell E7, type 14%, and then press Enter.

A blue flag appears in the upper-left corner of cell E7.
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7. On the Quick Access Toolbar, click the Save button to save your work.

8. On the Review tab, in the Changes group, click Track Changes, and then click 
Highlight Changes.

The Highlight Changes dialog box opens.

9. Select the List changes on a new sheet check box, clear the When check box, and 
then click OK.

Excel creates and displays a worksheet named History, which contains a list of all 
changes made since the last time a user accepted or rejected changes.

10. Click the Sheet1 sheet tab.

The Sheet1 worksheet opens.

11. On the Review tab, in the Changes group, click Track Changes, and then click 
Accept/Reject Changes.

The Select Changes To Accept Or Reject dialog box opens.

12. Click OK.

The Accept Or Reject Changes dialog box displays the first change.
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13. Click Accept.

Excel keeps the change and then displays the next change.

14. Click Accept.

Excel keeps the change and deletes the History worksheet. The Accept Or Reject 
Changes dialog box closes.

CLEAN UP Save the ProjectionChangeTracking workbook, and then close it.

Protecting Workbooks and Worksheets
Excel gives you the ability to share your workbooks over the Web, over a corporate intranet, 
or by copying files for other users to take on business trips. An important part of sharing 
files, however, is ensuring that only those users you want to have access to the files can 
open or modify them. For example, Consolidated Messenger might have a series of com-
puters available in a processing center so supervisors can look up package volumes and 
handling efficiency information. Although those computers are vital tools for managing 
the business process, it doesn’t help the company to have unauthorized personnel, even 
those with good intentions, accessing critical workbooks.

You can limit access to your workbooks or elements within workbooks by setting passwords. 
When you set a password for an Excel workbook, any users who want to access the protected 
workbook must enter the workbook’s password in a dialog box that opens when they try to 
open the file. If users don’t know the password, they cannot open the workbook.

To set a password for a workbook, open the workbook to be protected, and click the File 
tab to display the workbook in the Backstage view. Then, on the Info page of the Backstage 
view, click the Protect Workbook button and then click Encrypt With Password. The Encrypt 
Document dialog box opens, with a Password box in which you can type your password. After 
you click OK, the Confirm Password dialog box opens, in which you can verify the password 
required to open the workbook. After you have confirmed the password, click OK. Now the 
Info page of the Backstage view indicates that users must enter a password to open the file.
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To remove the passwords from a workbook, repeat these steps, but delete the passwords 
from the Encrypt Document dialog box and save the file.

Tip The best passwords are long strings of random characters, but random characters are 
hard to remember. One good method of creating hard-to-guess passwords is to base your 
password on a longer phrase. For example, “I learned about passwords in Chapter 14 of 
Microsoft Excel 2010 Step by Step” could translate to the password IlapiC14oME2SbS. In any 
event, avoid dictionary words in English or any other language, because they can be found 
easily by password-guessing programs available on the Internet; include both uppercase 
and lowercase letters; and use characters other than letters or numbers if possible.

If you want to allow anyone to open a workbook but want to prevent unauthorized 
users from editing a worksheet, you can protect a worksheet by displaying that work-
sheet, clicking the Review tab and then, in the Changes group, clicking Protect Sheet 
to open the Protect Sheet dialog box.
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In the Protect Sheet dialog box, you select the Protect Worksheet And Contents Of Locked 
Cells check box to protect the sheet. You can also set a password that a user must type in 
before protection can be turned off again and choose which elements of the worksheet a 
user can change while protection is turned on. To enable a user to change a worksheet 
element without entering the password, select the check box next to that element’s name.

The check box at the top of the worksheet mentions locked cells. A locked cell is a cell that 
can’t be changed when worksheet protection is turned on. You can lock or unlock a cell by 
right-clicking the cell and clicking Format Cells on the shortcut menu that appears. In the 
Format Cells dialog box, you click the Protection tab and select the Locked check box.

When worksheet protection is turned on, selecting the Locked check box prevents unauthor- 
ized users from changing the contents or formatting of the locked cell, whereas selecting the 
Hidden check box hides the formulas in the cell. You might want to hide the formula in a cell 
if you draw sensitive data, such as customer contact information, from another workbook 
and don’t want casual users to see the name of the workbook in a formula.

Finally, you can password-protect a cell range. For example, you might want to let users 
enter values in most worksheet cells but also want to protect the cells with formulas that 
perform calculations based on those values. To password-protect a range of cells, select 
the cells to protect, click the Review tab and then, in the Changes group, click Allow 
Users To Edit Ranges. The Allow Users To Edit Ranges dialog box opens.
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To create a protected range, click the New button to display the New Range dialog 
box. Type a name for the range in the Title box, and then type a password in the Range 
Password box. When you click OK, Excel asks you to confirm the password; after you do, 
click OK in the Confirm Password dialog box and again in the Allow Users To Edit Ranges 
dialog box to protect the range. Now, whenever users try to edit a cell in the protected 
range, they are prompted for a password. 

Tip Remember that a range of cells can mean just one cell!

In this exercise, you’ll password-protect a workbook, a worksheet, and a range of cells. 
You will also hide the formula in a cell.

SET UP You need the SecureInfo_start workbook located in your Chapter14 practice 
file folder to complete this exercise. Open the SecureInfo_start workbook, and save it 
as SecureInfo. Then follow the steps. 

1. Click the File tab, and then, if necessary, click Info.

The Info page of the Backstage view is displayed.

2. Click the Protect Workbook button, and then click Encrypt with Password.

The Encrypt Document dialog box opens.
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3. Type work14pro in the Password box.

4. Click OK.

The Confirm Password dialog box opens.

5. In the Reenter password box, type work14pro.

6. Click OK.

The Confirm Password dialog box closes.

7. Click the Review tab of the ribbon and, if necessary, click the Performance 
sheet tab.

The Performance worksheet opens.

8. Right-click cell B8, and then click Format Cells.

The Format Cells dialog box opens.

9. Click the Protection tab.

The Protection page is displayed.

10. Select the Hidden and Locked check boxes, and then click OK.

Excel formats cell B8 so that it won’t display its formula after you protect the 
worksheet.
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11. On the Review tab, in the Changes group, click Protect Sheet.

The Protect Sheet dialog box opens.

12. In the Password to unprotect sheet box, type prot300pswd.

13. Clear the Select locked cells and Select unlocked cells check boxes, and then 
click OK.

The Confirm Password dialog box opens.

14. In the Reenter password to proceed box, type prot300pswd, and then click OK.

15. Click the Weights sheet tab.

The Weights worksheet opens.

16. Select the cell range B2:C7.

17. On the Review tab, in the Changes group, click Allow Users to Edit Ranges.

The Allow Users To Edit Ranges dialog box opens.

18. Click New.

The New Range dialog box opens, with the range B2:C7 displayed in the Refers To 
Cells box.

19. In the Title box, type AllWeights.

20. In the Range password box, type work14pro, and then click OK.

21. In the Confirm Password dialog box, reenter the password work14pro.

The range appears in the Allow Users To Edit Ranges box.

22. Click Protect Sheet.

The Protect Sheet dialog box opens.

23. In the Password to unprotect sheet box, type work14pro, and then click OK.

24. In the Confirm Password dialog box, reenter the password work14pro, and then 
click OK.

CLEAN UP Save the SecureInfo workbook, and then close it.
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Finalizing a Workbook

Distributing a workbook to other users carries many risks, not the least of which 
is the possibility that the workbook might contain private information you don’t 
want to share with users outside your organization. With Excel, you can inspect a 
workbook for information you might not want to distribute to other people, and 
create a read-only final version that prevents other people from making changes 
to the workbook content.

Using the Document Inspector, you can quickly locate comments and annotations, 
document properties and personal information, custom XML data, headers and 
footers, hidden rows and columns, hidden worksheets, and invisible content. You 
can then easily remove any hidden or personal information that the Document 
Inspector finds.

To inspect and remove hidden or personal information, follow these steps:

1. Save the file.

2. Click the File tab, and then, on the Info page of the Backstage view, click Check 
for Issues, and then click Inspect Document.

3. In the Document Inspector window, clear the check box of any content type 
you want to remain in the document, and click Inspect.

4. In the inspection results list, click the Remove All button to the right of any 
category of data you want to remove.

Marking a workbook as final sets the status property to Final and turns off data entry, 
editing commands, and proofreading marks.

To mark a workbook as final, follow these steps:

 1. Click the File tab, and then, on the Info page of the Backstage view, click 
Protect Workbook, and then click Mark as Final.

 2. In the message box indicating that the file will be marked as final and then 
saved, click OK.

 3. In the message box indicating that the file has been marked as final, click OK.

To restore functionality to a workbook that has been marked as final, click the File tab 
and then, on the Info page of the Backstage view, click Protect Workbook, and then 
click Mark As Final to change its status.
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Authenticating Workbooks
The unfortunate reality of exchanging files over networks, especially over the Internet, is 
that you need to be sure you know the origin of the files you’re working with. One way 
an organization can guard against files with viruses or substitute data is to authenticate 
every workbook using a digital signature. A digital signature is a character string created 
by combining a user’s unique secret digital signature file mathematically with the contents 
of the workbook, which programs such as Excel can recognize and use to verify the iden-
tity of the user who signed the file. A good analogy for a digital signature is a wax seal, 
which was used for thousands of years to verify the integrity and origin of a document.

Tip The technical details of and procedure for managing digital certificates are beyond the 
scope of this book, but your network administrator should be able to create a digital certificate 
for you. You can also directly purchase a digital signature from a third party, which can usually 
be renewed annually for a small fee. For the purposes of this book, you’ll use the selfcert.exe 
Microsoft Office accessory program to generate a certificate with which to perform the exercise 
at the end of this topic. This type of certificate is useful for certifying a document as part of a 
demonstration, but other users will not accept it as a valid certificate to verify that the contents 
of the document haven’t changed since it was signed.

To create a digital certificate that you can use as a demonstration, open the Start menu, 
click All Programs, click Microsoft Office, click Microsoft Office 2010 Tools, and then click 
Digital Certificate For VBA Projects. In the Create Digital Certificate dialog box, type a 
name for your certificate and click OK to have the program create your trial certificate. 
Then, in Excel, click the File tab and on the Info page of the Backstage view, click Protect 
Workbook and then click Add A Digital Signature. In the Sign dialog box, type your 
purpose for signing the document, and then click Sign to sign your workbook.

Tip After you click Add A Digital Signature, Excel displays a dialog box, indicating that you can 
buy digital signatures from third-party providers. To get information about those services, click 
the Signature Services From The Office Marketplace button. To bypass the message, click OK; to 
prevent the dialog box from appearing again, select the Don’t Show This Message Again check 
box, and then click OK.

If you have several certificates from which to choose, and the desired certificate doesn’t 
appear in the Sign dialog box, you can click Change to display the Select Certificate 
dialog box. In the Select Certificate dialog box, click the certificate with which you 
want to sign the workbook, and then click OK. The Select Certificate dialog box closes, 
and the certificate with which you signed the workbook appears in the Sign dialog 
box. As before, click Sign to sign your document by using the digital certificate.

In this exercise, you’ll create a digital certificate and digitally sign a workbook by using 
the certificate.
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SET UP You need the ProjectionsSigned_start workbook located in your Chapter14 
practice file folder to complete this exercise. Open the ProjectionsSigned_start 
workbook, and save it as ProjectionsSigned. Then follow the steps. 

1. On the Start menu, click All Programs, click Microsoft Office, click Microsoft 
Office 2010 Tools, and then click Digital Certificate for VBA Projects.

The Create Digital Certificate dialog box opens.

2. In the Your certificate’s name box, type Excel2010SBS, and then click OK.

A message box indicates that the program created your certificate successfully.

3. Click OK.

The message box closes.

4. Click the File tab and then, if necessary, click Info. Click Protect Workbook and 
then click Add a Digital Signature.

A message box appears, offering the opportunity to view signature services on 
Office Marketplace.

5. Click OK.

The message box closes, and the Sign dialog box opens.

6. In the Purpose for signing this document box, type Testing.

7. Verify that the Excel2010SBS certificate appears in the Signing as area of the dialog 
box, and then click Sign.

The Signature Confirmation dialog box opens.

8. Click OK.

The Signatures task pane opens and the workbook is marked as final. If you edit the 
workbook, it will invalidate the digital signature, which is based on the workbook’s 
contents at the time you signed it.

CLEAN UP Save the ProjectionsSigned workbook, and then close it.
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Saving Workbooks for the Web
With Excel, you can save your workbooks as Web documents, so you and your col-
leagues can view workbooks over the Internet or an organization’s intranet. For a docu-
ment to be viewable on the Web, it must be saved as a Hypertext Markup Language 
(HTML) file. HTML files, which end with either the .htm or the .html extension, include 
tags that tell a Web browser such as Windows Internet Explorer how to display the con-
tents of the file.

For example, you might want to set the data labels in a workbook apart from the rest of 
the data by having the labels displayed with bold text. The coding in an HTML file that 
indicates text to be displayed as bold text is <b>...</b>, where the ellipsis between the 
tags is replaced by the text to be displayed. So the following HTML fragment would be 
displayed as Excel in a Web page:

<b>Excel</b>

You can create HTML files in Excel by clicking the File tab and clicking Save As to display 
the Save As dialog box. To save a workbook as an HTML file, click the Save As Type arrow 
and then click Web Page. Then, in the Save As dialog box, select the Entire Workbook 
option, type a name for the file in the File Name box, and click Save to have Excel create 
an HTML document for each sheet in the workbook.

Tip If the only sheet in your workbook that contains data is the one displayed when you save 
the workbook as a Web page, Excel only saves that worksheet as a Web page.

After you save an Excel workbook as a set of HTML documents, you can open it in your 
Web browser. To open the Excel file, start Internet Explorer, and then click Open on the File 
menu to display the Open dialog box. In the Open dialog box, click the Browse button to 
open the Windows Internet Explorer dialog box. You can use the commands in that dialog 
box to identify the file you want to open.

When you double-click the file you want to open, the Windows Internet Explorer dialog box 
closes and the file’s name and path appear in the Open box. To display the Excel workbook, 
click OK, and the workbook appears in Internet Explorer. You can move among the work-
book’s worksheets by clicking the sheet tabs in the lower-left corner of the page.

Saving a workbook to an organization’s intranet site enables you to share data with 
your colleagues. For example, Consolidated Messenger’s chief operating officer, Lori 
Penor, could save a daily report on package misdeliveries to her team’s intranet so that 
everyone could examine what happened, where the problem occurred, and how to fix 
the problem. It’s also possible to save a workbook as a Web file that retains a link to the 
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original workbook. Whenever someone updates the workbook, Excel updates the Web 
files to reflect the new content.

To publish a workbook to the Web, click the File tab, click Save As and then, in the Save 
As Type list, click Web Page. When you do, Excel displays the Publish button; clicking the 
Publish button displays the Publish As Web Page dialog box.

You can use the options in the Publish As Web Page dialog box to select which elements 
of your workbook you want to publish to the Web. Clicking the Choose arrow displays a 
list of publishable items, including the option to publish the entire workbook, items on 
specific sheets, or a range of cells. To have Excel update the Web page whenever some-
one updates the source workbook, select the AutoRepublish Every Time This Workbook 
Is Saved check box. You can also specify which text appears on the Web page’s title bar. 
To do so, click the Change button, type the page title in the Set Title dialog box, and 
click OK. When you save a workbook that has AutoRepublish turned on, Excel displays a 
dialog box indicating that the changes will update the associated Web file.

Important When you save a PivotTable to the Web, the PivotTable doesn’t retain its interactivity. 
Instead, Excel publishes a static image of the PivotTable’s current configuration.

In this exercise, you’ll save a workbook as a Web page and then publish a worksheet’s 
PivotTable to the Web.

SET UP You need the ShipmentSummary_start workbook located in your Chapter14 
practice file folder to complete this exercise. Open the ShipmentSummary_start 
workbook, and save it as ShipmentSummary. Then follow the steps. 

1. Click the File tab, and then click Save As.

The Save As dialog box opens.
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2. In the File name box, type ShipmentSummaryWeb.

3. In the Save as type list, click Web Page.

The Save As dialog box changes to reflect the Web Page file type.

4. Click Save.

A warning message box appears, indicating that the workbook might contain 
elements that can’t be saved in a Web page.

5. Click Yes to save the workbook as a Web file.

The message box closes, and Excel saves the workbook as a Web page.

6. Click the File tab, and then click Close.

7. Click the File tab, click Recent, and then, in the list of recently viewed files, click 
ShipmentSummary.

The ShipmentSummary workbook opens.
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8. Click the File tab, and then click Save As.

The Save As dialog box opens.

9. In the File name box, type ShipmentSummaryPublish.

10. In the Save as type list, click Web Page.

The Save As dialog box changes to reflect the Web Page file type.

11. Click Publish.

The Publish As Web Page dialog box opens.

12. In the Choose list, click Items on Sheet2.

The available items on Sheet2 appear.

13. In the Item to publish list, click PivotTable.

14. Select the AutoRepublish every time this workbook is saved check box.

15. Click Publish.

Excel publishes the PivotTable to a Web page. Excel will update the contents of the 
Web page whenever a user saves the ShipmentSummary workbook.

CLEAN UP Save the ShipmentSummary workbook, and then close it. Exit Excel.
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Key Points
● Sharing a workbook enables more than one user to view and edit the data at one 

time, which is useful in group projects in which each member has a distinct area of 
responsibility.

● Sending files by e-mail is a very efficient means of collaborating with colleagues. 

● Adding comments to cells is a quick way to let your colleagues know what you’re 
thinking without taking up valuable space in a cell.

● Tracking changes is vital when you share responsibility for a workbook with several 
other people.

● When your workbook’s data is too important to leave lying around in the open, use 
passwords to protect all or part of the file!

● Authenticating workbooks with digital signatures helps to identify the source of 
your files, so you won’t have to guess about the origins of that next attachment in 
your e-mail inbox.

● Saving a workbook as a Web-accessible HTML document is as easy as saving it as 
a regular Excel file, and opening a workbook saved for the Web is just as easy as 
opening any other Web page.

● Use the AutoRepublish facility to update Excel files on the Web. Whenever anyone 
changes the original workbook, Excel writes the edits to the HTML version of the file.
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Glossary
3-D reference A pattern for referring to the 

workbook, worksheet, and cell from which a 
value should be read.

absolute reference A cell reference, such as =$B$3, 
that doesn’t change when you copy a formula 
containing the reference to another cell.

active cell The cell that is currently selected and 
open for editing.

add-in A supplemental program that can be used 
to extend Excel’s functions.

alignment The manner in which a cell’s contents 
are arranged within that cell (for example, 
centered).

arguments The specific data a function requires 
to calculate a value.

aspect ratio The relationship between a graphic’s 
height and its width.

auditing The process of examining a worksheet 
for errors.

AutoComplete The Excel functionality that com-
pletes data entry for a cell based on similar 
values in other cells in the same column.

AutoFill The Excel functionality that extends 
a series of values based on the contents of a 
single cell. See also Fill Series.

AutoFilter An Excel tool you can use to create 
filters.

AutoRepublish An Excel technology that maintains 
a link between a Web document and the work-
sheet on which the Web document is based, and  
updates the Web document whenever the 
original worksheet is saved.

Backstage view A new view in Excel 2010, accessed 
by clicking the File tab, that gathers workbook 
management tasks into a single location.

browser A program with which users view Web 
documents.

cell The box at the intersection of a row and a 
column.

cell range A group of cells.

cell reference The letter and number combination, 
such as C16, that identifies the row and column 
intersection of a cell.

chart  A visual summary of worksheet data, also 
called a graph.

column Cells that are on the same vertical line in 
a worksheet.

conditional format A format that is applied only 
when cell contents meet certain criteria.

conditional formula A formula that calculates a 
value using one of two different expressions, 
depending on whether a third expression is 
true or false.

data bar A horizontal line within a cell that 
indicates the relative magnitude of the cell’s 
value.

data consolidation Summarizing data from a set 
of similar cell ranges.

dependent A cell with a formula that uses the 
value from a particular cell. See also precedent.

embed To save a file as part of another file, as 
opposed to linking one file to another. See 
also link.

error code A brief message that appears in a work-
sheet cell, describing a problem with a formula 
or a function.

Excel table An Excel object with which you can 
store and refer to data based on the name  
of the table and the names of its columns 
and rows.
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Extensible Markup Language (XML)  A content-
marking system with which you store data about 
the contents of a document in that document.

field A column of data used to create a PivotTable.

fill handle The square at the lower-right corner 
of a cell that can be dragged to indicate other 
cells that should hold values in the series  
defined by the active cell.

FillSeries The ability to extend a series of values 
based on the contents of two cells, where the 
first cell has the starting value for the series 
and the second cell shows the increment. See 
also AutoFill.

filter A rule that Excel uses to determine which 
worksheet rows to display.

format A predefined set of characteristics that 
can be applied to cell contents.

formula An expression used to calculate a value.

Formula AutoComplete The Excel functionality 
with which you can enter a formula quickly by 
selecting functions, named ranges, and table 
references that appear when you begin to 
type the formula into a cell.

formula bar The area just above the worksheet 
grid that displays the active cell’s formula and 
within which you can edit the formula.

function A predefined formula.

Goal Seek An analysis tool that finds the value 
for a selected cell that would produce a given 
result from a calculation.

graph A visual summary of worksheet data, also 
called a chart.

header An area of the worksheet that appears 
above the contents of the worksheet grid when 
you print the worksheet or view it in Layout View.

HTML See Hypertext Markup Language.

hyperlink A reference to a file on the Web.

Hypertext Markup Language (HTML) A doc-
ument-formatting system that tells a Web 
browser such as Windows Internet Explorer 
how to display the contents of a file.

icon set A conditional format that uses distinct 
visual indicators to designate how a value com-
pares to a set of criteria.

landscape mode A display and printing mode 
whereby columns run parallel to the short 
edge of a sheet of paper.

link A formula that has a cell show the value from 
another cell.

live preview A feature of Excel that displays the 
result of an operation, such as pasting data or 
applying a cell style, without implementing the 
change until you complete the operation.

locked cell A cell that cannot be modified if its 
worksheet is protected.

macro A series of recorded automated actions 
that can be replayed.

mailto hyperlink A special type of hyperlink with 
which a user creates an e-mail message to a 
particular e-mail address.

Merge And Center An operation that combines 
a contiguous group of cells into a single cell. 
Selecting a merged cell and clicking the Merge 
And Center button splits the merged cells into 
the original group of separate cells.

named range A group of related cells defined by 
a single name.

Paste Options A button that appears after 
you paste an item from the Microsoft Office 
Clipboard into your workbook, and which 
provides options for how the item appears  
in the workbook.

Pick from List The Excel functionality that allows 
you to enter a value into a cell by choosing the 
value from the set of values already entered 
into cells in the same column.

pivot To reorganize the contents of a PivotTable.

PivotChart A chart that is linked to a PivotTable and 
that can be reorganized dynamically to empha-
size different aspects of the underlying data.

PivotTable A dynamic worksheet that can be 
reorganized by a user.
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portrait mode A display and printing mode 
whereby columns run parallel to the long edge 
of a sheet of paper.

precedent A cell that is used in a formula.

primary key A field or group of fields with values 
that distinguish a row of data from all other rows.

property A file detail, such as an author name or 
project code, that helps identify the file.

Quick Access Toolbar A customizable toolbar that 
contains a set of commands that are indepen-
dent of the tab on the ribbon that is currently 
displayed.

range A group of related cells.

refresh To update the contents of one document 
when the contents of another document are 
changed.

relative reference A cell reference in a formula, 
such as =B3, that refers to a cell that is a specific 
distance away from the cell that contains the 
formula. For example, if the formula =B3 were 
in cell C3, copying the formula to cell C4 would 
cause the formula to change to =B4. See also 
absolute reference.

ribbon The tab-based user interface introduced 
in Microsoft Office 2007.

row Cells that are on the same horizontal line 
in a worksheet.

scenario An alternative data set with which you 
view the impact of specific changes on your 
worksheet.

search filter A filter in which you type a string of 
characters and have Excel display every value 
within an Excel table, data set, or PivotTable 
that contains that character string.

sharing Making a workbook available for 
more than one user to open and modify 
simultaneously.

sheet tab The indicator for selecting a worksheet, 
located at the bottom of the workbook window.

Slicer An Excel tool with which you can filter an 
Excel table, data list, or PivotTable while indi-
cating which items are displayed and which 
are hidden.

Solver An Excel add-in that finds the optimal value 
for one cell by varying the results of other cells.

sort To reorder the contents of a worksheet 
based on a criterion.

sparkline A compact chart that summarizes data 
visually within a single worksheet cell.

subtotal A partial total for related data in a 
worksheet.

template A workbook used as a pattern for 
creating other workbooks.

theme A predefined format that can be applied 
to a worksheet.

tracer arrow An arrow that indicates the formulas 
to which a cell contributes its value (a depen-
dent arrow) or the cells from which a formula 
derives its value (a precedent arrow).

trendline A projection of future data (such as 
sales) based on past performance.

validation rule A test that data must pass to 
be entered into a cell without generating a 
warning message.

watch Display of a cell’s contents in a separate 
window even when the cell is not visible in the 
Excel workbook.

what-if analysis Analysis of the contents of a work-
sheet to determine the impact that specific 
changes have on your calculations.

workbook The basic Excel document, consisting 
of one or more worksheets.

worksheet A page in an Excel workbook.

workspace An Excel file type (.xlw) that allows 
you to open several files at once.

XML See Extensible Markup Language.
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Keyboard Shortcuts
This list of shortcuts is a comprehensive list derived from Microsoft Excel 2010 Help. 
Some of the shortcuts might not be available in every version of Excel 2010.

Ctrl Combination Shortcut Keys

Key Description
Ctrl+Shift+( Unhides any hidden rows within the selection. 
Ctrl+Shift+& Applies the outline border to the selected cells. 

Ctrl+Shift+_ Removes the outline border from the selected cells. 

Ctrl+Shift+~ Applies the General number format. 

Ctrl+Shift+$ Applies the Currency format with two decimal places (negative numbers 
in parentheses). 

Ctrl+Shift+% Applies the Percentage format with no decimal places. 

Ctrl+Shift+^ Applies the Scientific number format with two decimal places. 

Ctrl+Shift+# Applies the Date format with the day, month, and year. 

Ctrl+Shift+@ Applies the Time format with the hour and minute, and A.M. or P.M. 

Ctrl+Shift+! Applies the Number format with two decimal places, thousands separator, 
and minus sign (-) for negative values. 

Ctrl+Shift+* Selects the current region around the active cell (the data area enclosed 
by blank rows and blank columns). In a PivotTable, it selects the entire 
PivotTable report.

Ctrl+Shift+: Enters the current time. 

Ctrl+Shift+” Copies the value from the cell above the active cell into the cell or the 
formula bar. 

Ctrl+Shift+Plus (+) Displays the Insert dialog box to insert blank cells. 

Ctrl+Minus (-) Displays the Delete dialog box to delete the selected cells. 

Ctrl+; Enters the current date. 

Ctrl+̀  Toggles between displaying cell values and displaying formulas in the 
worksheet. 

Ctrl+’ Copies a formula from the cell above the active cell into the cell or the 
formula bar. 

Ctrl+1 Displays the Format Cells dialog box. 

(continued)
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398  Keyboard Shortcuts

Key Description
Ctrl+2 Toggles to apply or remove bold formatting. 

Ctrl+3 Toggles to apply or remove italic formatting. 

Ctrl+4 Toggles to apply or remove underlining. 

Ctrl+5 Toggles to apply or remove strikethrough. 

Ctrl+6 Toggles between hiding and displaying objects. 

Ctrl+8 Toggles to display or hide the outline symbols. 

Ctrl+9 Hides the selected rows. 

Ctrl+0 Hides the selected columns. 

Ctrl+A Selects the entire worksheet. If the worksheet contains data, Ctrl+A selects 
the current region. Pressing Ctrl+A a second time selects the entire work-
sheet. When the insertion point is to the right of a function name in a 
formula, displays the Function Arguments dialog box.

Ctrl+Shift+A Inserts the argument names and parentheses when the insertion point is 
to the right of a function name in a formula.

Ctrl+B Toggles to apply or remove bold formatting. 

Ctrl+C Copies the selected cells. 

Ctrl+D Uses the Fill Down command to copy the contents and format of the 
topmost cell of a selected range into the cells below. 

Ctrl+F Displays the Find And Replace dialog box, with the Find page active. 
Shift+F5 also displays this page, whereas Shift+F4 repeats the last  
Find action.

Ctrl+Shift+F Opens the Format Cells dialog box with the Font page active.

Ctrl+G Displays the Go To dialog box. F5 also displays this dialog box.

Ctrl+H Displays the Find And Replace dialog box, with the Replace page active. 

Ctrl+I Toggles to apply or remove italic formatting. 

Ctrl+K Displays the Insert Hyperlink dialog box for new hyperlinks or the Edit 
Hyperlink dialog box for selected existing hyperlinks. 

Ctrl+L Displays the Create Table dialog box. 

Ctrl+N Creates a new, blank workbook. 

Ctrl+O Displays the Open dialog box to open or find a file.

Ctrl+Shift+O Selects all cells that contain comments.

Ctrl+P Displays the Print page in the Backstage view.

Ctrl+Shift+P Opens the Format Cells dialog box with the Font page active.

Ctrl+R Uses the Fill Right command to copy the contents and format of the 
leftmost cell of a selected range into the cells to the right. 

Ctrl+S Saves the active file with its current file name, location, and file format. 
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Key Description
Ctrl+T Displays the Create Table dialog box. 

Ctrl+U Toggles to apply or remove underlining.

Ctrl+Shift+U Toggles between expanding and collapsing the formula bar. 

Ctrl+V Inserts the contents of the Microsoft Office Clipboard at the insertion 
point and replaces any selection. Available only after you have cut or 
copied an object, text, or cell contents.

Ctrl+Alt+V Displays the Paste Special dialog box. Available only after you have cut 
or copied an object, text, or cell contents on a worksheet or in another 
program.

Ctrl+W Closes the selected workbook window. 

Ctrl+X Cuts the selected cells. 

Ctrl+Y Repeats the last command or action, if possible. 

Ctrl+Z Uses the Undo command to reverse the last command or to delete the 
last entry that you typed.

Tip The Ctrl combinations Ctrl+E, Ctrl+J, Ctrl+M, and Ctrl+Q are currently unassigned to any 
shortcuts.

Function Keys

Key Description
F1 Displays the Excel Help task pane.
Ctrl+F1 Displays or hides the ribbon.

Alt+F1 Creates an embedded chart of the data in the current range.

Alt+Shift+F1 Inserts a new worksheet.

F2 Opens the active cell for editing and positions the insertion point at the 
end of the cell contents. It also moves the insertion point into the formula 
bar when editing in a cell is turned off.

Ctrl+F2 Displays the print preview area on the Print page in the Backstage view.

Shift+F2 Adds a cell comment or opens an existing comment for editing.

F3 Displays the Paste Name dialog box. Available only if there are existing 
names in the workbook.

Shift+F3 Displays the Insert Function dialog box.

F4 Repeats the last command or action, if possible.

Ctrl+F4 Closes the selected workbook window.

Alt+F4 Closes Excel.

F5 Displays the Go To dialog box.

(continued)
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Key Description
Ctrl+F5 Restores the window size of the selected workbook window.

F6 Switches between the worksheet, ribbon, task pane, and Zoom controls. 
In a worksheet that has been split, F6 includes the split panes when 
switching between panes and the ribbon area. 

Ctrl+F6 Switches to the next workbook window when more than one workbook 
window is open.

Shift+F6 Switches between the worksheet, Zoom controls, task pane, and ribbon.

F7 Displays the Spelling dialog box to check spelling in the active worksheet 
or selected range.

Ctrl+F7 Performs the Move command on the workbook window when it is not 
maximized. Use the arrow keys to move the window, and when finished 
press Enter or Esc to cancel.

F8 Turns extend mode on or off. In extend mode, Extended Selection appears 
in the status line, and the arrow keys extend the selection.

Ctrl+F8 Performs the Size command (on the Control menu for the workbook 
window) when a workbook is not maximized.

Alt+F8 Displays the Macro dialog box to create, run, edit, or delete a macro.

Shift+F8 Enables you to add a nonadjacent cell or range to a selection of cells by 
using the arrow keys.

F9 Calculates all worksheets in all open workbooks.

Ctrl+F9 Minimizes a workbook window to an icon.

Shift+F9 Calculates the active worksheet.

Ctrl+Alt+F9 Calculates all worksheets in all open workbooks, regardless of whether 
they have changed since the last calculation.

Ctrl+Alt+Shift+F9 Rechecks dependent formulas, and then calculates all cells in all open 
workbooks, including cells not marked as needing to be calculated.

F10 Turns key tips on or off. (Pressing Alt does the same thing.)

Ctrl+F10 Maximizes or restores the selected workbook window.

Shift+F10 Displays the shortcut menu for a selected item.

Alt+Shift+F10 Displays the menu or message for an Error Checking button. 

F11 Creates a chart of the data in the current range in a separate Chart sheet.

Alt+F11 Opens the Microsoft Visual Basic Editor, in which you can create a 
macro by using Visual Basic for Applications (VBA).

Shift+F11 Inserts a new worksheet.

F12 Displays the Save As dialog box.
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Other Useful Shortcut Keys

Key Description
Arrow keys Moves one cell up, down, left, or right in a worksheet. 
Ctrl+Arrow key Moves to the edge of the current data region (range of cells that 

contains data and that is bounded by empty cells or datasheet 
borders) in a worksheet.

Shift+Arrow key Extends the selection of cells by one cell.

Ctrl+Shift+Arrow key Extends the selection of cells to the last nonblank cell in the same 
column or row as the active cell, or if the next cell is blank, extends 
the selection to the next nonblank cell.

Left Arrow or  
Right Arrow 

Selects the tab to the left or right when the ribbon is selected. When 
a submenu is open or selected, these arrow keys switch between the 
main menu and the submenu. 

Down Arrow or  
Up Arrow 

Selects the next or previous command when a menu or submenu is 
open. When a ribbon tab is selected, these keys navigate up or down 
the tab group. In a dialog box, arrow keys move between options in 
an open drop-down list, or between options in a group of options.

Down Arrow or 
Alt+Down Arrow 

Opens a selected drop-down list.

Backspace Deletes one character to the left in the formula bar. Also clears the 
content of the active cell. In cell editing mode, deletes the character 
to the left of the insertion point.

Delete Removes the cell contents (data and formulas) from selected cells 
without affecting cell formats or comments. In cell editing mode, 
deletes the character to the right of the insertion point. 

End Turns End mode on. In End mode, you can press an arrow key to 
move to the next nonblank cell in the same column or row as the 
active cell. If the cells are blank, pressing End followed by an arrow 
key moves to the last cell in the row or column. End also selects the 
last command on the menu when a menu or submenu is visible.

Ctrl+End Moves to the last cell on a worksheet, to the lowest used row of the 
rightmost used column. If the cursor is in the formula bar, Ctrl+End 
moves the cursor to the end of the text.

Ctrl+Shift+End Extends the selection of cells to the last used cell on the worksheet 
(lower-right corner). If the cursor is in the formula bar, Ctrl+Shift+End 
selects all text in the formula bar from the cursor position to the 
end—this does not affect the height of the formula bar. 

(continued)
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Key Description
Enter Completes a cell entry from the cell or the formula bar, and selects the 

cell below (by default). In a data form, moves to the first field in the 
next record. Opens a selected menu (press F10 to activate the menu 
bar) or performs the action for a selected command. In a dialog box, 
performs the action for the default command button in the dialog 
box (the button with the bold outline, often the OK button).

Alt+Enter Starts a new line in the same cell.

Ctrl+Enter Fills the selected cell range with the current entry.

Shift+Enter Completes a cell entry and selects the cell above.

Esc Cancels an entry in the cell or formula bar. Closes an open menu or 
submenu, dialog box, or message window. Also closes full screen 
mode when this mode has been applied, and returns to normal 
screen mode to display the ribbon and status bar again.

Home Moves to the beginning of a row in a worksheet. Moves to the cell 
in the upper-left corner of the window when Scroll Lock is turned 
on. Selects the first command on the menu when a menu or sub-
menu is visible.

Ctrl+Home Moves to the beginning of a worksheet.

Ctrl+Shift+Home Extends the selection of cells to the beginning of the worksheet.

Page Down Moves one screen down in a worksheet. 

Alt+Page Down Moves one screen to the right in a worksheet.

Ctrl+Page Down Moves to the next sheet in a workbook.

Ctrl+Shift+Page Down Selects the current and next sheet in a workbook.

Page Up Moves one screen up in a worksheet.

Alt+Page Up Moves one screen to the left in a worksheet.

Ctrl+Page Up Moves to the previous sheet in a workbook.

Ctrl+Shift+Page Up Selects the current and previous sheet in a workbook.

Spacebar In a dialog box, performs the action for the selected button, or 
selects or clears a check box.

Ctrl+Spacebar Selects an entire column in a worksheet.

Shift+Spacebar Selects an entire row in a worksheet.

Ctrl+Shift+Spacebar Selects the entire worksheet. If the worksheet contains data, Ctrl+ 
Shift+Spacebar selects the current region. Pressing Ctrl+Shift+ 
Spacebar a second time selects the current region and its summary 
rows. Pressing Ctrl+Shift+Spacebar a third time selects the entire 
worksheet. When an object is selected, Ctrl+Shift+Spacebar selects 
all objects on a worksheet.
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Key Description
Alt+Spacebar Displays the Control menu for the Excel window.

Tab Moves one cell to the right in a worksheet. Moves between unlocked 
cells in a protected worksheet. Moves to the next option or option 
group in a dialog box.

Shift+Tab Moves to the previous cell in a worksheet or the previous option in 
a dialog box.

Ctrl+Tab Switches to the next page in a dialog box.

Ctrl+Shift+Tab Switches to the previous page in a dialog box.
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Symbols and 
Numbers
$ (dollar sign)

in absolute references, 68
in link references, 176

= (equal sign)
in formulas, 60
in link references, 176, 177

##### error code, 75
! (exclamation point), in references, 176
[ ] (square brackets)

in formulas, 63, 73
in references, 176

3-D appearance, SmartArt graphic, changing, 290
3-D references, 176, 393
64-bit version of Excel 2010, xxii

A
absolute references, 81

changing to relative references, 68
defined, 393
dollar sign ($) in, 68

Accept Or Reject Changes dialog box, 376, 378
accepting changes, 376, 378
actions, recording in macros. See macros
active cells

in cell group, 35
defined, 34, 393
in filtering, 122

Add Constraint dialog box, 202, 204
Add Scenario dialog box, 191, 192
Add Shape button (SmartArt), 289, 290
adding borders 

to cells, 86, 88
to images, 114

adding cells to formulas, 64
adding comments, 373, 374
adding headers and footers, 306
adding data to Excel tables, 49, 51
adding digital signatures, 386, 387
adding equations to shapes, 296, 299
adding formulas to Excel tables, 67
adding functions to formulas, 60
adding images to worksheets, 113, 116

adding macros to Quick Access Toolbar, 339
adding shapes to worksheets, 294, 297
adding sort levels, 146, 148
adding styles to Cell Styles gallery, 91
adding subtotals to worksheets, 158
adding text to shapes, 295, 298
adding values together, 60. See also SUM function
Add-Ins, 393. See also Analysis ToolPak, Solver
Add-Ins dialog box, 201, 207
Advanced Filter dialog box, 132, 133
AGGREGATE function, 133

compared to SUBTOTAL, 131
function_num argument in, 131
ignoring in AGGREGATE function, 132
ignoring errors in, 132
ignoring hidden rows in, 132
ignoring SUBTOTAL function in, 132
introduced, 131
operations, summarized, 131
options argument in, 132
syntax, 131

Align button (shapes), 295, 298
aligning shapes, 295, 298
aligning text in shapes, 298
alignment

cell, changing, 92
shapes, 295

Allow Users To Edit Ranges button, 381, 384
Allow Users To Edit Ranges dialog box, 381, 382, 384
alternative data sets. See scenarios
Analysis group, installing, 201, 207
Analysis ToolPak

generating summary statistics with, 209
input range, 208
installing, 207
selecting type of data to analyze, 208

Analyze contextual tab (PivotChart), refreshing 
data from, 281, 285

analyzing data. See data analysis
And option, in filters, 127
annotations, finding and removing with 

Document Inspector, 385
applying table styles, 97
applying themes, 94
arguments, 70. See also specific functions

defined, 62, 393
error codes for, 75, 161

Arrange All button, 17, 25

Index
 Contents
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Arrange Windows dialog box, 17, 25
arranging workbook windows, 17
arrows

on buttons, 85
filter, 122, 124, 125
filter, in PivotTables, 224
filter, in Report Filter area, 226
tracer, 75, 76, 78-79

aspect ratio, defined, 393
Assign Macro dialog box, 341, 343

macro name in, importance of not changing, 341
assigning fields to PivotTables, 216
Attach button (Outlook 2010), sharing workbooks 

with, 370
attachments, e-mail, sending workbooks as, 370, 371
auditing

changes. See change tracking
errors, 74, 393

authenticating workbooks. See digital signatures
AutoCalculate, 129, 133
AutoComplete, 31, 393
AutoCorrect Options action button, 49
AutoExpansion, Excel table, 49
AutoFill, 30-31, 393
AutoFill Options button, 32, 34
AutoFilter, 122, 393
automating tasks. See macros
Auto_Open macro, 344-346
AutoRepublish

defined, 393
updating Web pages with, 389, 391

AVERAGE function, 61
and filters, 129
and hidden rows, 129
limitations of, 129

AVERAGEIF function, 71, 72, 74
AVERAGEIFS function, 71, 73
averages

functions for calculating, 71
viewing with AutoCalculate, 129, 133

axes, chart. See charts
Axis Labels dialog box, 262, 265

B
Back button (Help), xxxix
backgrounds

deleting images from, 115, 118
of images, removing, xxi, 114, 116
patterns, creating, 115, 117
watermarks, 115

Backstage view
defined, 393
managing workbooks in, ix

Backstage view (Info page)
adding digital certificates from, 386, 387
Document Inspector on, 385
finalizing workbooks from, 385
password entry on, 379
restoring functionality to finalized workbooks 

from, 385
setting passwords from, 379, 382

Backstage view (Print page)
Margins button, 310, 318
navigating, 312
Orientation button, 316
previewing workbooks in, 309, 312, 316
Print Selected Chart button, 326
Print What button, 320
printing commands in, 309, 318
Scaling button, 312, 317
scroll bar, 312
selecting print pages in, 322
Settings area, 322
Show Margins button, 310

Backstage view (Save & Send page)
publishing workbooks to Web from, 389
saving read-only PDF or XPS files from, 372
saving workbooks as Web pages from, 388, 389
sharing workbooks via e-mail from, 371

balloons. See ScreenTips
banded columns or rows, PivotTable style, 245, 246
bar charts. See charts
Bing search engine, 44
Bold button, 85, 87
boldfacing, 85, 87
book features and conventions, xxxi
borders

adding to cells, 86, 88
adding to images, 114
SmartArt graphic, changing, 290

Breaks button, 313, 317
breaks, page. See page breaks
Bring Forward button (shapes), 296
broken links. See linking; file linking
Browse dialog box (file embedding), 356, 357
Browse dialog box (file linking), 351, 352
browsers, defined, 393
business cases, analyzing. See data analysis
business planning

Goal Seek and, 198
Solver and, 201

buttons
adding to Quick Access Toolbar, 18, 25
arrows on, 85
custom, (shapes) running macros from, 341, 344
macro, adding to Quick Access Toolbar, 340-342
on Quick Access Toolbar, changing, 341, 343

406  Arrange Windows dialog box
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C
Calculate Now button, 61
calculations. See also formulas; subtotals

and data changes. See scenarios
ignoring values in, 131

capitalization
searching for, 40
sorting and, 147

cascading workbook windows, 17, 25
cell groups, active cells in, 35
cells

absolute references. See absolute references
active. See active cells
adding comments to. See comments
adding hyperlinks to, 358
adding to formulas, 64
alignment, changing, 92
borders, 86, 88
color. See fill color
comments in. See comments
copying, 32, 35
defined, 393
defining alternative values for, 191, 192
deleting, 12, 14
deleting contents of, 85
deleting formatting of, 85
delimiters, 251
entering data into, 30
fill color. See fill color
filling with data series, 30, 32
filtering. See filters
finding sum of, 60
flags in. See comments
formatting. See formatting
hiding formulas in, 381, 383
hyperlink references in, changing, 360
inserting, 12, 14
linked, updating, 177
linking. See linking
locked. See locked cells
maximum number in scenarios, 195
monitoring values in, 77, 78
moving, 12, 14
moving to, 34
noncontiguous, selecting for printing, 322, 325
number formatting in, 93
pasting formulas in, 65
pointing to. See references
printing, 322
ranges. See ranges
references. See references
in scenario summaries, displaying, 194
selected, printing, 322
selecting, 34

selecting with macros, 333
setting validation rules for, 136
shading. See fill color
Solver objective, setting, 202, 203
Solver variable, setting, 202, 204
sorting. See sorting
sparklines in. See sparklines
testing values in. See conditional formatting
visible, summarizing, 129, 131

Cell Styles gallery, 90, 91
centering print areas, 322
centering shapes. See shapes, aligning
Change Chart Type button (charts), 269, 273
Change Chart Type button (PivotCharts), 282, 285
Change Chart Type dialog box (charts), 269, 273
Change Chart Type dialog box (PivotCharts), 282, 285
change tracking, 375-378

accepting (finalizing) changes, 376, 378
appearance of tracked changes, 375, 376
dates of changes, viewing, 376
distinguishing different users’, 376
histories, creating, 376
histories, settings for, 369
identifying authors, 376
identifying editors, 373
information retention policies and, 369
rejecting changes, 376
removing changes, 376
reviewing changes, 376, 378
ScreenTips, 376
tracking all changes, 376, 377
turning on, 375, 377

changes
accepting (finalizing), 376, 378
auditing. See change tracking
authors, identifying, 373
keeping history of, 369, 376, 378
reconciling conflicts, in shared workbooks, 369
redoing, 44
rejecting, 376
removing, 376
reviewing, 376, 378
tracking. See change tracking
undoing, 44

changing color of worksheet tabs, 8, 9
changing conditional formatting rules, 107, 111
changing embedded files, 355, 356
changing error settings, 76
changing filter criteria, 123
changing font size, 87
changing formatting with macros, 333
changing linked files, 352
changing order of conditional formatting rules, 107
changing order of worksheets, 8, 9
changing position of images, 114

changing position of images  407
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changing range definitions, 58
changing reference type, 68
changing shape of images, 114
changing sort order, 150
changing themes, 96, 100

effect of, 82
character strings, in search filters, 228
chart elements, 267-268, 271
Chart Elements button, 268
charts

2D-bar, creating, 264
adding gridlines to, 268
appearance, and themes, 261
axes, changing data on, 261, 265
axes, formatting, 271
axis labels, 267
bar, creating, 264
categories, changing, 262, 265
column headers, omitting from data selection, 262
creating, 260, 264
customizing appearance of, 267, 270
customizing data plotting, 261, 265
customizing elements of, 267, 271
data points, changing formatting, 268
data series, changing formatting, 268
default type, creating, 261
defined, 259, 393
elements of. See chart elements
embedded, printing problems with, 326
formatting, 267, 270
gridlines, 267
height, changing, 263
horizontal axis (x-axis), changing data on, 262, 265
incorrect plotting, reasons for, 261
layout, changing, 270
legends, changing, 262, 265. 267
moving, 263, 264, 266
numbers in, formatting, 271
page headers and footers and, 305
pasting into other Office documents, 364
printing, 326
printing problems with Print What button, 326
resizing, 263
sparklines. See sparklines
style, changing, 267, 270
templates, 269, 272
types, 260
vertical axis (y-axis), changing data on, 262, 265
width, changing, 263
and workbook themes, 267

chart sheets, inserting, 170
Chart Styles gallery, 267, 270
checking spelling, 43, 46
Choose A SmartArt Graphic dialog box, 286, 290
circles, drawing, 297

Clear button, 85
clearing filters, 124, 126, 127
clearing table styles, 97
clearing validation rules, 137
closing comments, 373
code

HTML, in Web pages, 388
macro, viewing, 332, 334

collaboration. See sharing workbooks
Collapse Dialog button, 182
collating printed copies, 318
color

in change tracking, 376
conditional formatting and. See data bars; 

color scales
filling cells with. See fill color
of hyperlinks, 358
sorting by, 146
and themes, 95
worksheet tabs, changing, 8, 9

color scales, 109, 110
Colors dialog box, 95
Column button (sparklines), 278, 279
Column Labels area. See PivotTables
Column Labels header. See PivotTables
columns, Excel table

adding and removing, 50
references to, 177

columns, PivotTable. See PivotTable fields
columns, worksheet

##### error code, 75
changing multiple, 11
changing width, 11
copying, 35
defined, 393
deleting, 12
filtering. See filters
formatting, 86
formatting, and importing, 254
headers. See headers, column and row
hidden, removing with Document Inspector, 385
hiding, 12, 13
hiding labels, 23
inserting, 11, 13
labels. See labels, row and column
moving, 35
multiple, sorting by, 146, 148
repeating in printouts, 323, 324
selecting, 35
sorting on, 144
subtotals and, 153
unhiding, 12
width errors, 75

comma, as delimiter, 251

408  changing range definitions
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commands, adding to Quick Access Toolbar. See 
buttons, adding to Quick Access Toolbar

comments, 372-374
adding, 373, 374
appearance of, 372, 373, 374
authors, identifying, 373
closing, 373, 374
deleting, 373, 375
displaying, 373-374
editing, 373
flags indicating, 372
hiding, 373, 374
keeping open, 373, 374
moving through, 374
pointing to, 373
in ranges, 56
removing with Document Inspector, 385
username in, 372, 373

comparing values 
by using color scales, 109, 110
by using data bars, 111
by using icon sets, 111

comparison operations, in Solver problems,  
203, 205

Compatibility Functions, xiv
conditional formatting

color scales, 109, 110
creating, 106
data bars, xviii, 108, 111
defined, 106, 393
Excel 2010 improvements, xx
icon sets, xix, 109, 111
PivotTables and, 243, 250
referencing other worksheets, xx
rules, 107, 111-112
summary formulas and, 110

Conditional Formatting button, 107
and PivotTables, 243, 250

Conditional Formatting Rules Manager, 107,  
109, 111

conditional formulas, 70, 393.
conditional functions, summarized, 71
conditions, setting. See validation rules
Confirm Password dialog box, 379, 382, 383, 384
Consolidate dialog box, 181, 182
consolidating data. See data consolidation
constraints, in Solver problems, 202-203, 204
Convert To Range button (Excel tables), 369
converting Excel tables to ranges, 51, 369
Copy button, 37, 134
copying and pasting data, limitations of, 175
copying and pasting formulas, 65, 68
copying cells, 32, 35
copying data, 37

copying formatting, 32, 34
copying ranges, 35
copying worksheet columns, 35
copying worksheet rows, 35
copying worksheets, 7, 9

effect on Office Themes, 8
COUNT function, 61, 71
COUNTA function, 71
COUNTBLANK function, 71
COUNTIF function, 71
COUNTIFS function, 71, 73
counting entries, 61
counts, viewing with AutoCalculate, 129, 133
Create button, 2
Create Charts dialog box, templates in, 269
Create Digital Certificate dialog box (Office 2010), 

386, 387
Create Names From Selection dialog box, 57
Create PivotTable dialog box, 214, 220

and imported data, 255
Create PivotTable With PivotChart dialog box, 283
Create Sparklines dialog box, 277, 279
creating charts, 260, 264
creating custom sorts, 146, 148
creating custom sort lists, 147, 150
creating digital signatures, 386, 387
creating Excel tables, 49, 51
creating file links, 350, 352
creating filters, 122, 127
creating formulas, 60, 69
creating hyperlinks, 358, 359, 361
creating macros. See macros, recording
creating passwords, 380
creating PivotCharts, 281
creating PivotTables, 214, 220
creating ranges, 56, 58-59
creating scenarios, 190, 192
creating scenario summaries, 194, 197
creating search filters, 227
creating secure workbooks for electronic 

distribution, 372
creating shapes, 294
creating Slicers, 229, 235
creating styles, 90, 91
creating table styles, 96, 97
creating themes, 96
creating workbook templates, 169, 171
creating workbooks, 2
creating workbooks from templates, 169, 172
creating worksheet templates, 170, 174
creating worksheets, 7
criteria

multiple, in functions, 73
sort, 146
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Ctrl key
in keyboard shortcuts, 397
selecting noncontiguous cells for printing with, 

322, 325
selecting shapes with, 295, 298
selecting Slicer data with, 231, 236
selecting worksheets for printing with, 320, 321

currency, formatting, 103, 105
Custom AutoFilter dialog box, 127
Custom DPI Setting dialog box, xxviii
customizations, exporting, 19, 22
customizing Excel 2010, 15
customizing the ribbon, 20
customizing the Quick Access Toolbar, 18, 339, 342
Custom Lists dialog box, 147, 150
custom sort, creating, 146, 148
custom sort lists, creating and applying,  

147–148, 150
custom XLM data, removing with Document 

Inspector, 385
Cycle graphic (SmartArt), 287

D
data

accessing from mobile devices, xxiii
accessing from the Web, xxiii
adding to Excel tables, 49, 51
analyzing. See data analysis
changing, and impact on calculations. See scenarios
combining. See data consolidation
copying, 37
copying and pasting, limitations of, 175
cutting, 37
deleting, without deleting formatting, 85
distribution, in trendlines. See data distribution 

(trendlines)
dynamic presentation of. See PivotTables; charts
entering, 30
Excel, and other Office documents, combining, 350
Excel table, summarizing, 50, 51
filtering. See filters; PivotTables
finding, 38. See also searching worksheets
focusing, 121. See also PivotTables
forecasting. See trendlines
formatting. See formatting
grouping, 56
imported, 250, 254-255
incorrectly plotted on charts, reasons for, 261
keeping together when printing, 315
manipulating, drawbacks of, 190
manipulating very large data sets, xxii
modifying, 40
numbers. See numbers

organization, changing. See PivotTables
pasting, x, 37
private, removing from workbooks, 385
projection. See trendlines
refreshing, in PivotCharts, 281
refreshing, in PivotTables, 219
related, linking. See linking
relationships, creating. See linking
relationships, in PivotTables, 214
reordering. See sorting
repeating values, entering, 31, 33 
replacing, 38-39, 42-43
restoring, 44
restoring, and change tracking, 376
restoring, after scenario application, 195
samples, creating with RANDBETWEEN, 128
sensitive, protecting by hiding formulas, 381
sensitive, removing with Document Inspector, 385
sets. See scenarios
sharing. See sharing workbooks
sorting. See sorting
source, for PivotTables, 215, 219, 250
subtotals, calculating, 153
summarizing. See charts; data consolidation; 

formulas; functions; sparklines; subtotals
summarizing with AutoCalculate, 129, 133
summarizing, in PivotTables, 237
summarizing very large data sets, xxii
in templates, 168
transposing, 37
validation. See validation rules

data analysis. See also charts
with Analysis ToolPak, 207
Data Analysis button, 207
descriptive statistics, 207
with Goal Seek, 198
with multiple scenarios, 194
with PivotTables. See PivotTables
with PowerPivot, xxii
with scenarios, 190
with Solver, 201
what-if analysis, 190

Data Analysis button, 207-208
Data Analysis dialog box, 208
data bars, xviii, 108, 111, 393

in Excel 2007, 108
in Excel 2010, xviii, xix, 108
gradient fill in, 108
and negative values, 109

data consolidation
adding and removing ranges, 182, 183
cell position and, 182
choosing calculations, 182
defined, 181, 393
links in, 181
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data distribution (trendlines)
Exponential, 274
Linear, 274, 276
Logarithmic, 274
Polynomial, 274
recommended, 275

data entry
ensuring accuracy of, 135
techniques, summarized, 31

data entry tools, 29
AutoComplete, 31
AutoFill, 30
AutoFill Options button, 32, 34
Fill Series, 30
Pick From Drop-Down List, 31, 33

data points, in charts, formatting, 268
data series

in charts, formatting, 268
creating with custom sort lists, 148
entering previous values, 31
entering with AutoFill, 30, 31
entering with AutoFill Options, 32
entering with FillSeries, 30, 31
in Excel tables, 50
types of, 31

data types. See also numbers; text
and changing chart type, 282
currency, 102
dates, 102
and filters, 122
phone numbers, 102

Data Validation button, 135
Data Validation dialog box, 135, 138
&[Date] code, in headers and footers, 307
dates

adding to page headers and footers, 306, 307
change tracking within, 376
filtering, 122, 125
formatting, 103, 104
and Locale setting, 103
months, sorting, 147
Sort & Filter list options for, 145
sorting, 145

days, filling cells with series, 32
days of the week, sorting, 147
debugger warning dialog box (Visual Basic 

Editor), 336
decimals, displayed as percentages, 198
default table style, changing, 97
default workbook, 2
defining filter rules, 124
Delete button (comments), 373, 375
Delete dialog box, 12, 14
deleting background images, 115, 118
deleting cells, 12, 14

deleting columns, 12
deleting comments, 373, 375
deleting conditional formatting rules, 107
deleting custom styles, 91
deleting data, 85
deleting hyperlinks, 361
deleting macros, 337
deleting page breaks, 313
deleting ranges, 58
deleting rows, 12
deleting sparklines, 279
deleting watches, 77, 81
deleting worksheets, 8, 10
delimiters, 251, 254
dependents

defined, 76, 393
tracing, to identify errors, 76

Descriptive Statistics dialog box, 208
Design contextual tab (charts)

applying templates from, 269
changing data source from, 262, 265
Chart Styles gallery, 267, 270
choosing layouts from, 267, 270
creating chart templates from, 269
moving charts from, 263, 266

Design contextual tab (Excel table), 51
Convert To Range button on, 369
converting Excel tables to ranges from, 369

Design contextual tab (Header & Footer), 304, 
305, 307

Design contextual tab (PivotCharts), changing 
chart type from, 282, 285

Design contextual tab (PivotTables), 237, 239, 244
detail levels (PivotTable), hiding, 226
diagrams. See SmartArt graphics
dialog boxes

displaying errors in, 76
filtering criteria, 123
help with, xxxvii

dictionary, adding words to, 43, 46
digital certificates, Office 2010 selfcert.exe 

accessory, 386
digital signatures

adding, 386, 387
creating, 386, 387
editing workbooks and, 387
finalizing workbooks and, 387
finding, 386
naming, 387
purchasing, 386, 387

Disable All Macros With Notification (security 
level), 332

Disable All Macros Without Notification (security 
level), 332

disabling macros, 331
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display font, Excel, changing, 87, 89
display settings different from book, xxix
displaying comments, 373, 374
displaying custom error messages, 72
displaying errors in a dialog box, 76
displaying formula details, 77
displaying headers and footers, 304
displaying hidden worksheets, 8, 10
displaying ranges, 57
displaying scenarios, 191
displaying worksheets, 7
distributing shapes, 295
distributing workbooks electronically. See sharing 

workbooks
#DIV/0! error code, 75
Document Inspector, removing sensitive data 

with, 385
Document Properties button, 5
Document Properties panel, 3-5
dollar sign ($)

in absolute references, 68
in link references, 176

dpi settings, xxviii
dragging

to change margins, 311
to copy formulas, 66
to fill cells, 30
to move chart elements, 268
to move charts, 263, 266
to move shapes, 295
to pivot PivotTables, 219, 221
to resize chart elements, 268
to resize charts, 263
to resize images, 114
to resize shapes, 294
to select cells, 34

drawing shapes, 294, 297
Drawing Tools Format contextual tab

aligning shapes with, 295, 298
changing shape formatting with, 294
creating shapes with, 294, 297
distributing shapes with, 295
specifying shape height and width with, 294

dynamic charts. See PivotCharts
dynamic worksheets. See PivotTables

E
Edit Comment button, 373
Edit Formatting Rule dialog box, 108, 109, 111
Edit Hyperlink dialog box, 363
Edit Links dialog box, 177, 179
Edit Name dialog box, 58

Edit Scenario dialog box, 192
editing comments, 373
editing conditional formatting rules, 107, 111
editing embedded files, 355, 356
editing formulas, 60
editing headers and footers, 305
editing hyperlinks, 361, 363
editing linked files, 352
editing macros, 337, 338
editing ranges, 58, 59
editing shared workbooks. See sharing workbooks
editing text in shapes, 295
editing workbooks saved as Web pages,  

inability, 368
electronic distribution, securing workbooks  

for, 372
e-mail addresses, creating hyperlinks to, 360
e-mail messages

creating with hyperlinks, 360
sharing workbooks via, 370, 371

embedding files. See file embedding
Enable All Macros (security level), not 

recommended, 332
Enable Content button (macro security), 331
enabling macros, 331, 332
Encarta dictionary, 44
Encrypt Document dialog box, 379, 382
encrypting workbooks. See passwords
entering data, 29, 30
entering data series, 30
entering ranges in formulas, 69
equal sign (=)

in formulas, 60
in link references, 176, 177

Equation button, 296-297, 299
equations

adding to shapes, 296, 297, 299
adding symbols to, 297, 300
common, listed on Equation button, 297
Excel 2010 improvements, xxi
subscript in, 299

Equation Tools Design contextual tab, 296, 299
Error button, 75
Error Checking button, 79
Error Checking dialog box, 76, 79
error codes

#####, 75
common, summarized, 75
defined, 393
#DIV/0!, 75
#N/A, in lookup functions, 161, 163
#NAME?, 75
#REF!, 75, 177
#VALUE!, 75
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error messages
adding icons to, 139
Cancel button in, 140
displaying default, 140
displaying with validation rules, 137, 138
Retry button in, 140

errors
auditing, 74
codes. See error codes
displaying custom messages, 72
displaying in dialog box, 76, 79
Error button, 75
finding information about, 75, 79
ignoring, 76
ignoring in AGGREGATE function, 132
in links, 177, 178
messages. See error messages
printing options for, 320
reference, 75
settings, changing, 76
tracing dependents to identify, 75
tracing precedents to identify, 75

Evaluate Formula button, 77, 80
Evaluate Formula dialog box, 77, 80
examining formulas, 77, 80
Excel 2007

data bars in, 108
icon sets in, 109

Excel 2010
64-bit version, xxii
Backstage view, introduced, ix
collaborating on the Web with, xxiii
Compatibility Functions and, xiv
conditional formatting, improved, xviii
custom sort lists in, 148
data bars in, xviii, 108
equations, improved, xxi
Excel Mobile 2010, xxiii
Excel Web App, xxiii
File tab, introduced, ix
functions, backward compatibility, xiii
functions, improved, xii
functions, new naming conventions, xii
functions, saving in older formats, xv
functions, statistical distribution, listed, xii
functions, statistical summary, listed, xiii
icon sets in, xix, 109
image editing, improved, xxi
installing Analysis ToolPak, 207
installing Solver, 201
macro security in, 330
macro security level, default, 332
maximum number of sort levels in, 146
and mobile devices, xxiii
new features in, ix

older functions in, xiii
Paste Live Preview, introduced, x
PowerPivot (Project Gemini), xxii
printing commands, new location of, 309
program window, customizing, 15
Project Gemini (PowerPivot), xxii
ribbon modification options, improved, xi
search filters in, xvii
security levels, changing, 331
Slicers in, xvi
sparklines in, xv
starting, 1, 3
user interface, customizing, 15
workbooks, embedding other Office documents in. 

See file embedding
workbooks, linking to other Office documents. 

See file linking
workbooks, linking to Web. See hyperlinks

Excel, earlier versions of. See also Excel 2007
custom sort lists in, 148
file formats, 3
macro security in, 330
maximum number of sort levels in, 146
older functions in Excel 2010, xiii
Page Field (Report Filter) area in, 226
Paste Options button, 35
pasting in, 35

Excel file formats
Excel 97-2003 template (.xlt), 169
macro-enabled and disabled, summarized, 330
macro-enabled Excel 2010 template (.xltm), 169
template (.xltx), 169, 171
saving workbooks in, 3
workspace (.xlw), 186

Excel files. See workbooks
Excel Help button, xxxvii, xxxviii
Excel Help window, xxxviii–xl
Excel Mobile 2010, xxiii
Excel Options dialog box

Add-Ins page, 201, 207
Customize The Quick Access Toolbar page, 18, 25, 

339, 340, 342
Customize The Ribbon page, 20, 26
Trust Center, 331

Excel tables
adding data to, 49, 51
adding fill color to, 98
adding formulas to, 67
adding and removing columns, 50
adding and removing rows, 50
AutoExpansion, 49
converting to ranges, 51, 369
creating, 49, 51
creating charts from, 264
creating PivotTables from, 214
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Excel tables (continued)
data series in, 50
defined, 393
Design contextual tab, 51
filtering. See filters
formatting, 96
formulas in, 50, 51
in formulas, 63
introduced, 29
linking, and hidden Totals row, 177
linking to cells in, 177
names, adding to formulas, 69
names, and PivotTables, 214
references to, 177
renaming, 50, 52
resizing, 50
and shared workbooks, incompatibility, 369
summarizing data in, 50, 51
table style gallery, 49
Totals row, 50, 177
VLOOKUP function and, 161

Excel table styles. See table styles
Excel Web App, xxiii
exclamation point (!), in references, 176
exercise format, xxix
Expand Dialog button, 182
Extensible Markup Language (XML), defined, 394

F
F8 key, stepping through macro instructions with, 

334, 335
F11 key, creating default charts with, 261
features and conventions of book, xxxi
field assignment (PivotTable), previewing, 219
Field List button, 216
fields, PivotTable. See PivotTable fields
&[File] code, in headers and footers, 307
file embedding, 355-356

charts, 364
defined, 355, 393
embedding a workbook, 356
embedding in a workbook, 355
locating files to embed, 356, 357
troubleshooting unreadable text, 356
working with embedded files, 355, 356

file formats, Excel. See Excel file formats
file formats, non-Excel

.htm and .html, 388
Portable Document Format (PDF), 372
XML Paper Specification (XPS), 372

file information. See workbook properties

file linking
appearance of linked files, 351
and broken links, 350
changing linked files, 350, 352, 353
compared to embedding, 350, 355
creating a link, 350, 352
disadvantages of, 355
displaying linked files, 351
editing linked files, 352, 353
Excel workbooks to other Office documents, 349, 

350, 352
importance of file location, 355
locating files to link to, 351, 352
maintaining links when moving, 350
overview, 349
troubleshooting unreadable text, 356
Web pages and original workbooks, 388

file names, adding to page headers and footers, 307
File tab, replacement for Microsoft Office button, ix. 

See also Backstage view
files

creating hyperlinks to, 359, 362
embedded, working with, 355, 356
linked, appearance of, 351
linked, compared to embedded, 350, 355
linked, working with, 350, 351, 352, 353
locating for hyperlinks, 359, 362
location, and file linking, 355
moving, and maintaining links, 350
PDF, creating, 372
sharing. See sharing workbooks
XPS, creating, 372

fill color
adding to cells, 86, 88
adding to Excel table, 98
data bars, 108
and file linking, troubleshooting, 356
No Fill setting, and file linking, 356
SmartArt graphic, changing, 290, 293
sorting by, 146, 152

Fill Days option, 32
fill handle, 30

AutoFill Options button, 32, 34
controlling data series entry, 31
copying formulas with, 66
defined, 394
repeating values with, 31, 33

fill operations, options for, 32
Fill Weekdays option, 32
FillSeries, 30, 31, 394
filter arrows, 122, 125

funnel, 124
in PivotTables, 224
in Report Filter area, 226

414  Excel table styles

www.it-ebooks.info

http://www.it-ebooks.info/


filter indicators, in PivotTables, 224
filter panel, 123
filters, 121, 122

active cells in, 122
AutoFilter, 122
and AVERAGE function, 129
clearing, 124, 126, 127
creating, 122, 127
criteria, changing, 123
and data types, 122
date, 122, 125
defined, 122, 394
filter arrows, 122, 125
filter panel display, 123
funnel filter arrow, 124
for highest or lowest value, 123
indicators in PivotTable field headers, 224
labels in, 122
options menu, 122
PivotChart, 282, 286
PivotTable, 222, 232, 281
removing, 124, 126, 127, 235
Report Filter area (PivotTables), 226
rules, defining, 124
Search box, 123, 126
search filters, defined, 123
search filters, in PivotTables, 227, 235
Slicers. See Slicers
and SUBTOTAL function, 131
and SUM function, 129
summarizing data, 129, 131
Top 10 filter, 123
turning off, 124

filtering criteria dialog box, 123
Final, workbook status property, 385
finalizing changes, 376
Find And Replace dialog box, 38, 40

clearing formatting from, 43
options summarized, 39

Find Format dialog box, 39, 41
finding data, 38. See also searching worksheets

unique values and, 160
with VLOOKUP function, 161

finding digital signatures, 386
finding error information, 75
finding maximum value, 61
finding minimum value, 61
finding sensitive data, 385
first row or column, unhiding, 12
focusing data, 121
font, changing, 93
font color, sorting by, 146
Font Color button, 94

font size, changing, 87
footers, page

adding dates and times to, 306, 307
adding file names to, 307
adding graphics to, 306, 308
adding page numbers to, 306
adding worksheet names to, 306
adding to worksheets, 304
and charts, 305
creating, 306
&[Date] code in, 307
displaying, 304
editing, 305
&[File] code in, 307
removing with Document Inspector, 385
introduced, 304
page numbers in, 305
&[Picture] code in, 308
predefined, adding to worksheets, 305
resizing, and effect on worksheet body, 311
switching to, from header, 307
workbook name in, 305

forecasting data. See trendlines
format, previewing. See live preview
Format As Table button, 49, 255
Format As Table dialog box, 49, 51, 255
Format Axis dialog box, 271
Format button, 11
Format Cells dialog box, 90

Alignment page, 92
Borders page, 86
creating PivotTable styles with, 244, 248
defining table styles in, 97
editing conditional formatting rules in, 108
Fill page, 97
hiding formulas in, 381, 383
locking and unlocking cells from, 381, 383
Number page, 93, 102, 103, 104
PivotTables and, 242, 245
Protection page, 381, 383

Format contextual tab (charts), 268
Format dialog box (charts), 269
Format Painter button, 91
Format Picture button (page headers and footers), 

306, 308
Format Picture dialog box (page headers and 

footers), 308
Format Shape button (SmartArt), 290, 292
Format Shape dialog box (SmartArt), 290, 292
Format Trendline dialog box, 274, 276
formats, conditional. See conditional formatting
formats, Excel. See Excel file formats
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formatting
alignment, 92
applying with Format Painter, 91
boldfacing, 85, 87
buttons, 85, 86
cell, copying, 32, 34
cell, deleting, 85
cell, preserving when deleting data, 85
cell, and VLOOKUP function, 163
changing based on values. See conditional 

formatting
changing, with macros, 333
chart elements, 268
charts, 267
clearing, 43, 85
column, changing, 86
conditional. See conditional formatting
currency, 103, 105
dates, 103, 104
defined, 394
Excel display font, changing, 87, 89
Excel tables. See table styles
font size, changing, 87
fonts, 93
ignoring, in cell copying, 32
inserting and, 11, 13
italics, 88
labels, 83, 84
Mini Toolbar, 86
noncontiguous cells, 88
numbers, 93, 101, 103, 105
pasting and, 37
phone numbers, 102, 105
PivotTables, 242
row, changing, 86
saving. See themes; styles; templates, workbook
searching for, 39, 41
shapes, 294
SmartArt graphics, 290
sparklines, 279
Special formats, 102
styles. See styles
text in shapes, 295, 300
themes. See themes
time, 93
tools, 85, 86

formatting (HTML), workbook labels for Web 
pages, 388

Formatting Options action button, 243
Formula AutoComplete, 62, 69, 70 394

Compatibility Functions in list, xiv
formula bar

changing data in, 40
contents of, 34
defined, 394

editing formulas in, 60
Excel display font, changing, 87, 89
hiding, 23
phone numbers in, 102

formula box. See formula bar
formulas

absolute references in, 81
adding contiguous cells to, 64
adding Excel table names to, 69
adding to Excel tables, 67
adding functions to, 60
adding noncontiguous cells to, 64
Calculate Now button, 61
conditional, introduced, 70
copying and pasting, 65, 68
creating, 60, 62, 69
defined, 60, 394
details, displaying, 77
displaying messages with, 70
editing, 60
entering ranges in, 69
equal sign (=) in, 60
erroneously treated as text, 60
errors. See errors
examining, 77, 80
Excel tables in, 63
in Excel tables, 50, 51
Formula AutoComplete, 62, 69, 70
hiding, 381
linking, 176
multiple worksheets and, 17
and PivotTables, 238, 241
protecting from unauthorized access, 381, 383
ranges in, 56, 62
relative references in, 65, 81
revising, 60
scenarios and, 191
searching in, 40
square brackets in, 63
troubleshooting, 60
unrecognized text in, 75

Forward button (Help), xxxix
From Text button (importing), 251, 254
Function Arguments dialog box, 70, 71
functions. See also specific functions

adding to formulas, 60
arguments, 62, 70
and AutoCalculate, 129
automatic recalculation of, 128
Compatibility Functions, xiv
conditional, summarized, 71
defined, 60, 394
earlier versions of, in Excel 2010, xiii
Excel 2010, backward compatibility, xiii
Excel 2010, improved, xii
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Excel 2010, naming conventions, xii
Excel 2010, saving in older formats, xv
Function Arguments dialog box, 70
lookup. See VLOOKUP function; HLOOKUP function
multiple criteria in, 73
naming conventions in Excel 2010, xii
statistical distribution, listed, xii
statistical summary, listed, xiii
summary (PivotTable), changing, 237, 240
volatile, defined, 128

funnel icon, in filter arrow, 124
future values, projecting. See trendlines

G
Get External Data button, 251, 254
GETPIVOTDATA function, 238, 241
goals

testing with Goal Seek, 198
testing with Solver, 201

Goal Seek
approximation to target value, 199
business planning and, 198
compared to Solver, 201
defined, 394
finding target values with, 198, 199
location of, 198
saving and closing with, 199
viewing results, 199, 200

Goal Seek dialog box, 198-200
Goal Seek Status dialog box, 199
Go to Footer button, 307
grand total level, 156
grand total row (PivotTables), 237, 239
grand totals, in PivotTables, 243
Grand Totals button (PivotTables), 237, 239
graphics, in page headers and footers, 306, 308
graphics, creating. See SmartArt graphics
graphs. See charts
gridlines, adding to charts, 268
Gridlines button (charts), 268
grouping related data, 56
grouping workbooks. See workspaces

H
Header button (page headers and footers), 305
Header & Footer button, 304, 306

and charts, 305
headers, column and row

changing formatting with, 86
and charts, omitting from, 262
defined, 36

and displaying unique values, 133, 134
filter arrow in, 125
setting page breaks with, 313
shapes as, 295
sorting and, 146
and SUBTOTAL function, 130

headers, field (PivotTable). See PivotTable fields
headers, page

adding dates and times to, 306, 307
adding file names to, 307
adding graphics to, 306, 308
adding page numbers to, 306
adding worksheet names to, 306
adding to worksheets, 304
and charts, 305
creating, 306
&[Date] code in, 307
defined, 394
displaying, 304
editing, 305
exiting editing mode, 308
&[File] code in, 307
removing with Document Inspector, 385
page numbers in, 305
&[Picture] code in, 308
predefined (Auto Headers), adding to 

worksheets, 305
resizing, and effect on worksheet body, 311
switching to, from footer, 307
workbook name in, 305

height, row, changing, 11
height, shape, changing, 294
Help button,xxxvii, xxxviii
Help window, xxxviii–xl
hidden rows

cause of errors, 177
removing with Document Inspector, 385
ignoring in AGGREGATE function, 132
Totals row, and linking, 177

hidden worksheets
removing with Document Inspector, 385
redisplaying, 8, 10

Hide Detail button, in outline area, 155, 158
Hide Detail button (PivotTables), 226, 234
hiding columns, 12, 13
hiding detail levels (PivotTable), 226
hiding Document Properties panel, 4
hiding formula bar, 23
hiding formulas, 381, 383
hiding labels, 23
hiding PivotTable Field List task pane, 224
hiding ribbon, 23
hiding rows, 12

in subtotals, 155, 158
hiding tracer arrows, 76, 79, 80

hiding tracer arrows  417

www.it-ebooks.info

http://www.it-ebooks.info/


hiding worksheets, 8, 9
Hierarchy graphic (SmartArt), 287, 290
Highlight Changes dialog box, 375, 376, 377, 378

List Changes On A New Sheet check box, effects 
of, 376, 378

sharing workbooks from, 375
Track Changes While Editing check box, effects of, 

375
tracking specific changes from, 376

history, of workbook changes, keeping, 369, 376, 378
History worksheets

adding, 376, 378
deleted when saving workbook, 376

HLOOKUP function, 163. See also VLOOKUP function
.htm (HTML) file format, 388
.html file format, 388
HTML files, 388, 394

saving workbooks and worksheets as, 388
Hyperlink button, 358, 361
hyperlinks

changing cell reference, 360
color of, 358
compared with links, 358
creating, 358, 359, 361, 362
defined, 349, 358, 394
deleting, 361
editing, 361, 363
to e-mail addresses, creating, 360
to existing files, creating, 359, 361
locating files for, 359, 362
locating Web pages for, 359
to locations in same workbook, 358
mailto, effect of clicking, 361
mailto, creating, 360
to new document, 359
opening, 361
to other Web documents, 358
shortcut menu options, 361
specifying text for, 361
targets, listed, 359
to Web pages, creating, 359

Hypertext Markup Language files. See HTML files

I
icon sets, 109, 111

defined, 394
in Excel 2007, 109
in Excel 2010, xix, 109
rules, changing, 109, 111

icons
displaying embedded files as, 356
displaying linked files as, 351
sorting by, 146

IF function, 70, 134
displaying messages with, 71, 73

IFERROR function, 71
ignoring errors, 76
images

adding borders to, 114
adding to worksheets, 113, 116
background, deleting, 115, 118
background of, removing, xxi, 114, 116
background, repeating, 115, 117
background, as watermarks, 115
changing, 114
editing improvements in Excel 2010, xxi
moving, 117
resizing, 114, 117

Import Data dialog box, 254
Import/Export button, 18, 22
Import Text File dialog box, 251, 254
importing data files, 250, 252, 254
importing text files, 253–254
Info page (Backstage view). See Backstage view 

(Info page)
information bar. See status bar
information retention policies, and workbook 

change histories, 369
Insert dialog box, 12, 14, 170, 174

adding worksheets from, 171
General page, 170
Spreadsheet Solutions page, 170

Insert Function dialog box, 50, 60
conditional functions in, 70

Insert Hyperlink dialog box, 358, 361
creating mailto hyperlinks with, 361
specifying text to display in, 361

Insert Object dialog box (file embedding),  
355, 356

Insert Options button, 11, 13
Insert Picture dialog box, 113, 116
Insert Picture dialog box (page headers and 

footers), 308
Insert Slicer button, 229, 235
Insert Slicers dialog box, 229, 235
Insert Worksheet button, 7
inserting cells, 12, 14
inserting columns, 11, 13
inserting rows, 11, 13
installing Analysis ToolPak, 207
installing Solver, 201
Internet, viewing workbooks on, 388
intranets, viewing and sharing workbooks via, 388
invisible content, removing with Document 

Inspector, 385
Italic button, 87
italics, applying to data, 88
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K
keyboard shortcuts, 397
keywords, 3, 5

L
labels, row and column

in filters, 122
formatting, 83, 84
formatting for Web pages (HTML), 388
hiding, 23
as range names, 57
shapes as, 295
in templates, 168

landscape mode (orientation), 311, 316, 394
Layout contextual tab (charts)

creating trendlines from, 274, 276
customizing charts from, 267

layouts, chart. See charts
legends. See charts, legends
levels, subtotal. See subtotal levels
Linear data distribution (trendlines), 274, 276
Line button (sparklines), 277, 279
linking, 176

broken links, finding and fixing, 177, 179
to cells in Excel tables, 177
creating a link, 176, 177
defined, 394
and deleted source worksheets, 177, 178
equal sign (=) in, 176, 177
errors in, 177, 178
with formulas, 176
and hidden Excel table Totals row, 177
introduced, 168
references in, 176, 178
#REF! error code in, 177, 178
and renamed source worksheets, 177
source cells, 176
target cells, 176
updating linked cells, 177
workbooks to other Office documents. See file 

linking
workbooks to the Web. See hyperlinks

links, broken. See linking
List graphic (SmartArt), 287
live preview

defined, 394
of shapes, 294
of styles, 90

Live Preview, Paste, 36
loan payments, calculating with PMT function, 62

locked cells
and hidden formulas, compared, 381
defined, 381, 394
locking and unlocking, 381
protecting, 381, 383

logos. See graphics
Look In navigational tool

creating hyperlinks in current workbook with, 
359, 362

finding files for hyperlinks with, 359, 362
finding Web pages for hyperlinks with, 359

lookup functions. See VLOOKUP function, 
HLOOKUP function

lookup_value argument, in VLOOKUP function, 161

M
Macro dialog box, 332, 334

deleting macros in, 337
displaying from Quick Access Toolbar, 339
running macros from, 334, 336
running macros without, 340
stepping through macros with, 333, 335

macro-disabled workbooks, 330
macro-enabled workbooks, 330, 331
macros

in active workbook, viewing, 332
adding to Quick Access Toolbar, 340, 341, 342
assigning to shapes (custom buttons), 341, 343
Auto_Open, 344, 345
changing formatting with, 333
code, viewing, 332, 334
creating, 336, 337
defined, 329, 394
deleting, 337
Disable All Macros With Notification security 

level, 332
Disable All Macros Without Notification security 

level, 332
disabling, 331
editing, 337, 338
Enable All Macros security level, not 

recommended, 332
enabling, 331, 332
file formats for, summarized, 330
instructions, stepping through, 333, 335
location on ribbon, 329
naming, 337
opening macro-enabled workbooks, 331
in other workbooks, viewing, 332
recording, 336, 337
running, 334, 336
running from custom buttons (shapes), 341, 344
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macros (continued)
running from Quick Access Toolbar, 343
running from the ribbon, 339
running when workbook opens, 344
saving changes to, 339
security and, 330-332
Security Warning Message Bar, 331, 332
selecting cells with, 333
stepping through, 333, 335
stopping recording, 337, 338
viewing, 332, 334
viewing code, 332, 334
viruses and, 330, 332

Macros button, 332, 334
recording Auto_Open macro with, 345
recording macros with, 336, 337

magnification level
changing. See zooming
changing globally, xxvii

mailto hyperlinks
and Microsoft Outlook, 361
and Microsoft Outlook Express, 361
and Windows Mail, 361
creating, 360
defined, 394
effect of clicking, 361

managing ranges, 58
Margins button (Backstage view Print page), 310, 318
margins, worksheet, 310

changing, by dragging, 311
custom, setting, 310
default, 310
displaying, 310
predefined, 310
predefined, setting, 318

mathematical equations. See equations
Matrix graphic (SmartArt), 287
MAX function, 61
maximum number of cells in scenarios, 195
maximum value

advantage of identifying, 55
finding, 61
in Solver objectives, 202, 204

Merge And Center, defined, 394
merging workbooks, 371
Message Bar, macro security warning on, 331, 332
messages

e-mail. See e-mail messages
entry, displaying with validation rules, 137, 138
error, adding icons to, 139
error, displaying custom, 72, 137, 138
error, displaying default, 140
error, displaying with validation rules, 137, 138

Microsoft Bing search engine. See Bing search 
engine

Microsoft Encarta dictionary. See Encarta 
dictionary

Microsoft Excel 2010. See Excel 2010
Microsoft Excel Help button, xxxvii, xxxviii
Microsoft Office 2010. See Office 2010
Microsoft Office button, replaced by File tab, ix
Microsoft Office.com graphics. See Office.com, 

graphics
Microsoft Outlook, and creating mailto 

hyperlinks, 361
Microsoft Outlook Express, and creating mailto 

hyperlinks, 361
Microsoft PowerPoint 2010. See PowerPoint 2010
Microsoft Product Support Services, xli
Microsoft Visual Basic Editor. See Visual Basic Editor
Microsoft Visual Basic for Applications (VBA). 

See Visual Basic for Applications (VBA) 
programming language

Microsoft Word 2010. See Word 2010
MIN function, 61
minimum value

advantage of identifying, 55
finding, 61
in Solver objectives, 202

Mini Toolbar, 86
mobile devices

accessing Excel data from, xxiii
and Excel 2010, xxiii
Excel Mobile 2010, xxiii

Modify Button dialog box, 343
monitoring values in cells, 77, 78
months

entering series with AutoFill, 30
sorting, 147

Move Chart button, 263, 266
Move Chart dialog box, 263, 266
Move or Copy dialog box, 7, 9
Move Down button, 18
Move Up button, 18
moving cells, 12, 14
moving chart elements, 268
moving charts, 263, 266
moving through comments, 374
moving images, 117
moving page breaks, 314
moving shapes, 295
moving to cells, 34
moving worksheet columns, 35
multiple criteria, in functions, 73
multiple scenarios

applying, 194, 195
and values in same cell, 194
viewing in single worksheet. See scenario 

summaries
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N
#N/A error code, in lookup functions, 161, 163
Name box, creating ranges in, 57, 59
#NAME? error code, 75
Name Manager dialog box, 58, 59
named ranges. See ranges
naming digital signatures, 387
naming macros, 337
naming scenarios, 191, 192
networks, sharing workbooks over, 370, 388
New Comment button, 373, 374
New Formatting Rule dialog box, 107, 109
New Name dialog box, 56, 60
New PivotTable Quick Style dialog box, 244, 247

Preview pane in, 244, 248
New Range dialog box, 382, 384
New Table Quick Style dialog box, 96, 97
Next button (comments), 374
noncontiguous cells, adding to formulas, 64
Normal view, setting page breaks in, 313, 317
NOW function, 61
Number Format button, 104
number formats, applying to PivotTables,  

242, 245
numbers. See also values

1000 separator (,), in charts, 271
adding text to values, 103, 106
currency, formatting, 103, 105
dates, formatting, 103, 104
decimal places, in charts, 271
decimals displayed as percentages, 198
formatting, 101, 103, 105
formatting, changing, 93
in charts, formatting, 271
negative, and data bars, 109
negative, displaying, 103
page. See page numbers
phone numbers, formatting, 102, 105
Sort & Filter list options for, 145
sorting, 144, 147
specifying in validation rules, 138
summarized in PivotTables, 237
target, finding with Goal Seek, 198, 199
target, finding with Solver, 201

O
Object button (file embedding), 355, 356
Object button (file linking), 350, 352
Object dialog box (file embedding), Link To File 

check box, embedding and, 355

Object dialog box (file linking), 350, 352
creating links in, 351
Display As Icon check box, 351
Link To File check box, linking and, 351, 353

objectives, Solver
maximum value, 202, 204
minimum value, 202
restricting to specific value, 202
setting, 202, 203

Office 2010
selfcert.exe (digital certificate) accessory, 386
system installation CD, 202, 207
themes in, 96

Office 2010 documents
embedding in workbooks, 355
embedding workbooks in, 355
linking to workbooks, 349, 350
pasting charts into, 364

Office.com
graphics (SmartArt), 287
templates, 169

Office Marketplace, digital signatures available 
from, 386, 387

Office theme, 94
Office Themes, and copying worksheets, 8
opening hyperlinks, 361
opening macro-enabled workbooks, 331
opening workbooks, running macros when, 344
opening workbooks saved as Web pages, 388
operations, comparison, in Solver problems, 203, 205
Options contextual tab (PivotTable), 229, 235,  

237, 239
order

of conditional formatting rules, changing, 107
of fields in PivotTables, 217
of printed pages. See page order (printing)
of shapes, changing, 296, 299
sort. See sort order
of worksheets, changing, 8, 9

organizational chart, Add Shape button options, 290
orientation. See page orientation
Orientation button (Backstage view Print page), 316
outline area, 154
outline levels. See subtotal levels
Outlook 2010, sharing workbooks with, 370

P
Page Break Preview button, 312
Page Break Preview mode, 312

page order indicators in, 314
selecting pages in, 322
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page breaks, 312
blue lines representing, 313
defined, 312
deleting, 313
moving, 314
Page Break Preview mode, 312
resetting all, 313
setting from cell, 314
setting manually, 313, 317
setting in Normal view, 313, 317
single, inserting, 314

Page Down key, navigating print previews with, 312
Page Field area. See Report Filter area
page footers. See footers, page
page headers. See headers, page
Page Layout button, 304
Page Layout view

editing workbooks in, 304
headers and footers in, 304
switching to, 304, 306

page numbers
adding to page headers and footers, 306
in page headers and footers, 305

page order (printing), 314
changing, 314, 318
indicators, in Page Break Preview mode, 314
keeping data together with, 315

page orientation
changing, 311, 316
landscape mode, 311, 316
portrait mode, 311

Page Setup dialog box
changing page order in, 314, 318
changing print page order in, 322
errors, printing options for, 320
fitting worksheets on printed page with, 312, 317
Header/Footer page, and charts, 305
positioning print area in, 322, 325
printing titles in, 323, 324
setting custom margins in, 310

pages, printed. See printing
Page Up key, navigating print previews with, 312
parts of worksheets, publishing as Web pages, 389
parts of worksheets, printing. See printing
passwords

creating, 380
recommendations for, 380
removing from workbooks, 380
setting for ranges, 382
setting for workbooks, 379
setting for worksheets, 381, 384

Paste button, 37
Paste gallery, 35
Paste Live Preview, 35

introduced, x

overview of, x
turning on, 36

Paste Options button, 36
defined, 394
in earlier versions of Excel, 35
turning on, 36

Paste Picture button (pasting charts), 364
Paste Preview. See Paste Live Preview
Paste Special dialog box, 36
pasting, 37

in earlier versions of Excel, 35
Excel charts into other Office documents, 364
formulas in cells, 65
Paste Live Preview, x, 35
previewing, 35
specialized, 37
undoing, 36

pattern, background, creating, 115, 117
PDF (Portable Document Format) files, saving 

workbooks as, 372
percentages

decimals displayed as, 198
in Values area (PivotTables), 238, 240

personal information, removing with Document 
Inspector, 385

phone numbers
formatting, 102, 105
troubleshooting, 103

phones, accessing Excel data from, xxiii
photos. See images
Pick From Drop-Down List (Excel functionality)

data entry with, 31, 33
defined, 31, 394

Picture button (page headers and footers), 308
&[Picture] code, in headers and footers, 308
Picture graphic (SmartArt), 287
Picture Tools Format contextual tab, 113
pictures. See images
PivotCharts

and changes to underlying PivotTables, 281, 283
changing chart type, and wrong data type, 282
changing data in, 283
creating, 281, 283
creating from existing PivotTables, 281
defined, 394
filtering, 282, 286
filtering PivotTables and, 281
introduced, 259, 281
refreshing, 281
restoring after filtering, 282
type, changing, 282, 285

pivoting PivotTables, 218, 221, 394
PivotTable button, 220

creating PivotCharts from, 281, 283
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PivotTable Field List task pane, 220
Choose Fields To Add To Report area, 216
displaying, 216
Drag Fields Between Areas Below area, 216
filter menu, 223, 232
filtered field names in, 224
filtering in, 223
hiding, 224
introduced, 215
Report Filter area in, 225, 233
sorting in, 223

PivotTable fields
assigning to PivotTable areas, 216, 220
defined, 394
dragging to Report Filter area, 225, 233
filtered names in PivotTable Field List task pane, 

224
filtering on, 223
filtering items in, 223
filtering in Report Filter area, 226
headers, dragging to assign fields, 216, 220
headers, filter arrows in, 224
order of, 217
selecting all items for filtering, 223

PivotTable filter menu
check marks in, 223, 232
field items in, 223
Select All check box, 223, 232

PivotTables
applying styles, 244, 246
assigning fields to, 216, 220
changing, and dependent PivotCharts, 281, 283
changing source data and, 219
Column Labels area, 217, 221
Column Labels header, filter arrows in, 224
conditional formatting in, 243, 250
creating, 214, 220
creating from Excel tables, 214
creating on existing worksheet, 215
creating on new worksheet, 215
creating, structure required for, 214
creating styles, 244, 247
data relationships in, 214
data source for, 215, 250, 254
Defer Layout Update check box, 219
defined, 394
details, importance of, 222
existing, creating PivotCharts from, 281
Field List button, 216
fields. See PivotTable fields
filter arrows in, 224
filter indicators in, 224
filter menu. See PivotTable filter menu
filtering, 222, 232
filtering by multiple values, 226, 233

filtering by one value, 226
filtering, and PivotCharts, 281
filters, removing, 233
formatting, 242
and formulas, 238, 241
grand total row, formatting, 237
Hide Detail button, 226, 234
hiding detail levels, 226, 234
importing data for, 250, 254
introduced, 211
maximizing display, 224
percentages in Values area, 238, 240
and PivotCharts, compared, 281
pivoting, 218, 221
PivotTable Field List task pane, 215, 220
preview of field assignment, 219
redraw time, and data on other computers, 219
redraw time, and large data sets, 219
refreshing data in, 219
renaming, 237, 239
Report Filter area in, 225, 233
Row Labels area, 217, 220
Row Labels header, filter arrows in, 224
search filters in, xvii, 227, 235
Second Row Stripe style, 248
Show Detail button, 226, 234
showing detail levels, 234
Slicers, xvi, 228. See also Slicers
structure required to create, 214
styles, banded columns, 245
subtotal rows, formatting, 237
summarizing data in, 237
summary functions, changing, 237, 240
Tools contextual tab, 216
update, delaying, 219
updating, 219
Values area, 221
Values area, data display in, 238, 240
Values area, data summary in, 237
Values area, formatting, 242, 245
on Web pages, loss of interactivity, 389

PMT function, 61
popup tips. See ScreenTips
Portable Document Format (PDF) files

saving workbooks as, 372
setting size of, 372

portrait mode (orientation), 311, 395
PowerPivot (Project Gemini), xxii
PowerPoint 2010, linking presentations to Excel 

workbooks, 352
ppi settings, xxviii
practice files

downloading, xxxiii
list of, xxxiii
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precedents
defined, 75, 395
tracing, to identify errors, 75

previewing field assignments (PivotTable), 219
previewing formats. See live preview
previewing pasted data with Paste Live  

Preview, x, 35
previewing, print

Backstage view, 309, 312, 316
number of pages, 312
page breaks, 312
Page Layout view, 304
Print Preview, limitations of, 304
saving money with, 327

previewing worksheet templates, 171
Previous button (comments), 374
primary key column

defined, 395
unique values, 160

print area
centering, 322
defining, 322, 325
positioning on page, 322

Print Area button, 322
Print button (Backstage view Print page), 318
Print Preview, limitations of, 304
Print Selected Chart button (Backstage view Print 

page), 326
Print Titles button, 323, 324
Print What button (Backstage view Print page), 320

printing charts with, drawbacks of, 326
printer, choosing, 318
printing

Backstage view, 309
centering print area, 322
charts, 326
charts, importance of selecting, 326
charts, and Print What button, 326
clearing selected cells, 322, 326
collating copies, 318
commands, Excel 2010 location of, 309
customizing, 318
entire worksheet, 320
and errors, options for, 320
fitting worksheets on pages, 312, 317, 322, 325
footers and, 304
headers and, 304
Help topics, xxxvii
multiple copies, 318
number of pages required, viewing, 312
page breaks, 312. See also page breaks
page order, 314
parts of worksheets, 322
positioning print area, 322
print area, defining, 322

printer, choosing, 318
print titles, 323
repeating rows or columns in, 323, 324
scaling worksheets for specified pages, 322, 325
selecting noncontiguous cells for, 322
selecting worksheet elements for, 320
selecting worksheet pages for, 322
selecting worksheets for, 320, 321
worksheets, 318, 321
all worksheets in workbook, 320

private data, removing from workbooks, 385
Process graphic (SmartArt), 287, 288
program window, Excel 2010

customizing, 15
maximizing space, 23
resizing, xxvi

Project Gemini (PowerPivot), xxii
projecting values. See trendlines
Properties dialog box, 3, 5
properties, file. See workbook properties
Protect Sheet button, 380, 384
Protect Sheet dialog box, 380, 384

selecting elements to protect, 381
setting passwords in, 381, 384

protecting formulas from unauthorized access, 
381, 383

protecting locked cells from unauthorized access, 
381, 383

protecting ranges from unauthorized access,  
381, 384

protecting workbooks from unauthorized access, 
379, 382, 385

protecting worksheets from unauthorized access, 
380, 384

Publish As PDF Or XPS dialog box, 372
Publish As Web Page dialog box, 389, 391
publishing entire workbooks to the Web, 389
publishing parts of workbooks to the Web, 389, 391
publishing workbooks to the Web, 389, 391
purchasing digital signatures, 386, 387
Pyramid graphic (SmartArt), 287

Q
Quick Access Toolbar

adding buttons to, 18, 25
adding macro buttons to, 340, 342
adding multiple macro button to, 341
adding View Macros button to, 339, 342
changing buttons on, 341
changing button positions, 19
customizing, 18, 339, 342
defined, 395
displaying Macros dialog box from, 339
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exporting customizations, 19
location, 18
Redo button, 44
removing buttons, 19
resetting, 19
running macros from, 340, 342, 343
Undo button, 44

quotes (quotation marks), in text strings, 104, 106

R
RAND function, 128, 134
RANDBETWEEN function, 128
random characters, passwords and, 380
random rows, selecting, 128
random values, generating, 128
range_lookup argument, in VLOOKUP function, 161
ranges

changing definition of, 58
comments, 56
converting Excel tables to, 369
copying, 35
creating, 56, 58
creating series of, 57
data consolidation and, 182
defined, 34, 56, 393, 394, 395
deleting, 58
displaying, 57
editing, 58, 59
entering in formulas, 69
filtering, 58
formatting. See formatting
in formulas, 56
labels as range names, 57
managing, 58
Name Manager dialog box, 59
names, in formulas, 62
New Name dialog box, 56, 60
printing, 322
protecting from unauthorized access, 381, 384
selecting, 34
selecting for sparklines, 277, 279
setting availability of, 56
setting passwords for, 382
VLOOKUP function and, 161

read-only workbooks, creating, 372, 385
recalculation time

displaying, 61
updating, 61

reconciling changes in shared workbooks, 369
record of changes, keeping. See change tracking, 

histories
Record Macro dialog box, 336, 337
recording Auto_Open macro, 345

recording macros, 336, 337
stopping, 337

redoing changes, 44
#REF! error code, 75

in link references, 177, 178
references

3-D, 176
absolute. See absolute references
cells in, 176
to cells in the same workbook, 177
to cells in the same worksheet, 177
defined, 393
dollar sign ($) in, 176
errors, 75
to Excel tables, 177
exclamation point (!) in, 176
hyperlink, changing, 360
in linking, 176, 178
relative. See relative references
single quotes in, 176
in Solver problems, 203
square brackets [ ] in, 176
types of, changing, 68, 69
types of, summarized, 68
to Web. See hyperlinks
workbooks in, 176
worksheets in, 176

Refresh All button, 18
Refresh button (PivotChart), 281, 285
refreshing data in PivotTables, 219
refreshing, defined, 395
refreshing PivotCharts, 281
refreshing Web pages, 389
rejecting changes, 376
related data

grouping, 56
linking, 175

Relationship graphic (SmartArt), 287
relative references, 66, 81

changing to absolute references, 68, 69
defined, 65, 395
usefulness of, 66

Remove All button (Document Inspector), 385
Remove Arrows button, 78
removing all changes, 376
removing background of images, 114, 116
removing changes, 376
removing filters, 124, 126, 127, 232, 236
removing passwords from workbooks, 380
removing scenarios, 191, 193
renaming Excel tables, 50, 52
renaming worksheets, 7, 9
reordering data. See sorting
repeating background images, 115, 117
repeating values with the fill handle, 31, 33
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Replace All, 39
replacing data, 38, 42
Report Filter area

in earlier versions of Excel (Page Field area), 226
filter arrows in, 226
in PivotTables, 225, 233

reports, Word 2010, linking to workbooks, 349
Research task pane, 44

Bing search engine, 44
Encarta dictionary, 44
Thesaurus, 44, 47
translation tools, 45, 47

research tools, 44. See also Research task pane
resetting all page breaks, 313
resize handles

chart, 263
chart element, 268
Excel table, 50
shape, 294

resizing chart elements, 268
resizing charts, 263
resizing headers and footers, 311
resizing images, 114, 117
resizing program window, xxvi
resizing ribbon, xxvi
resizing shapes, 294
resizing sparklines, 279, 280
resizing worksheets, 312, 322
resolution. See screen resolution
restoring data, 44

with change tracking, 376
after scenario application, 195

restoring functionality to finalized workbooks, 385
reviewing changes, 376, 378

all changes, 376
since a specific date, 376
turning off workbook sharing, importance of, 376

revising formulas, 60
ribbon

button appearance, xxvi
commands on, xxv
customizing, xi
decreasing width of, xxvi
defined, 395
dynamic nature of, xxv
Excel 2010, modifying, xi
exporting customizations, 22
groups, displaying all commands in, xxvi
hidden groups, displaying, xxvi
hiding and displaying, 23
introduced, ix
Main Tabs, 20
modifying in Excel 2010, xi
overview of, xxv
resetting, 19

restoring, 23
running macros from, 339
tabs. See ribbon tabs
tabs and groups, renaming, 22
Tool Tabs, 20
width, changing, xxvi

ribbon tabs
adding groups to, 21
changing groups on, 21
changing order of, 20, 26
creating custom, 21, 26
hiding, 20
removing groups from, 21

rotating shapes, 294
Row Labels area, Row Labels header. See PivotTables
rows, Excel table

adding and removing, 50
creating, 49
references to, 177

rows, worksheet
changing height, 11
changing multiple, 11
copying, 35
defined, 395
deleting, 12
filtering. See filters
formatting, 86
headers. See headers, column and row
headers, defined, 35
hidden, and SUM and AVERAGE functions, 129
hidden, finding and removing with Document 

Inspector, 385
hidden, ignoring in AGGREGATE function, 132
hidden, restoring with Show Detail button, 155
hiding, 12
hiding with Hide Detail button, 155, 158
hiding labels, 23
hiding and showing with level buttons, 156, 159
inserting, 11, 13
labels. See labels, row and column
labels as range names, 57
random, selecting, 128
repeating in printouts, 323
selecting, 35
showing with Show Detail button, 155, 158
sorting. See sorting
unhiding, 12

rules
conditional formatting. See conditional formatting
filter, defining, 124
validation. See validation rules

running macros, 334, 336
running macros from shapes (custom buttons), 

341, 344
running macros when workbooks open, 344
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S
sample data, creating with RANDBETWEEN, 128
Save As command, 3, 5
Save As dialog box, 5

Excel 97-2003 file format (.xlt) in, 169
macro-enabled Excel 2010 template file format 

(.xltm) in, 169
PDF format in, 372
saving workbooks as Web pages in, 388, 389
template file format (.xltx) in, 169
XPS format in, 372

Save button, 6
Save Chart Template dialog box, 272
Save Current Theme dialog box, 96, 100
Save & Send page (Backstage view). See Backstage 

view (Save & Send page)
Save Template button (charts), 269
Save Workspace dialog box, 184, 185
saving conditional formatting rules, 107
saving formatting. See templates, workbook
saving workbooks, 3, 5, 6

for electronic distribution, 372
recommended frequency, 3
Save As command, 3
specifying file formats, 3
as Web pages. See Web pages

Scaling button (Backstage view Print page),  
312, 317

scaling worksheets, 322
Scenario Manager dialog box, 190, 192

applying multiple scenarios with, 194, 195
scenarios

alternative values in, 190
creating, 190, 192
creating from Solver results, 203
defined, 395
displaying, 191, 193
formulas and, 191
identifying cells for, 191, 192
introduced, 190
maximum number of cells in, 195
multiple, applying, 194, 195
multiple, and values in same cell, 194
multiple, viewing in single worksheet.  

See scenario summaries
naming, 191, 192
of original worksheet, importance of, 191
removing, 191, 193
saving and closing with, 191
Scenario Manager, 190, 192
scenario summaries, 194, 197
“undo,” creating, 195
what-if analysis and, 190

scenario summaries
cells, displaying, 194
creating, 194, 197
importance of, 191
introduced, 194
type, choosing, 194

Scenario Summary dialog box, 194, 197
Scenario Values dialog box, 191, 192
screen magnification, changing, xxvii
screen resolution, xxvii
ScreenTips, xxxvii
Script button (equations), 299
Search box, filtering and, 123, 126
search filters, 123

character strings in, 228
creating, 227, 235
defined, 395
introduced, xvii, 227
in PivotTables, 227, 235

searching, filtering and, 123
searching Help, xxxix-xl
searching worksheets, 38, 40

for formatting, 39
lookup functions, 161
refining searches, 38
unique values and, 160

security
anti-virus software, and macros, 330
encrypting workbooks. See passwords
Excel 2010 levels, changing, 331
hiding formulas, 381
importance of verifying workbook source,  

331, 386
macro, default level, 332
macro, in earlier versions of Excel, 330
macro, in Excel 2010, 330
macro settings, changing, 330
macro warning on Message Bar, 331, 332
macros and, 330
and opening macro-enabled workbooks, 331
passwords. See passwords
read-only copies, creating, 372
saving workbooks for electronic distribution, 372
Windows Defender, 330
workbook authentication (digital signatures), 386

Security Warning Message Bar (macros), 331, 332
Select All button, 12
Select Certificate dialog box, 386
Select Changes To Accept Or Reject dialog box, 

376, 378
Select Data button (charts), 262, 265
Select Data Source dialog box (charts), 262, 265
selecting cells, 34
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selecting cells with macros, 333
selecting ranges, 34
selecting shapes, 295
selecting worksheet columns, 35
selecting worksheet rows, 35
selections, creating ranges from, 57
selfcert.exe Office 2010 digital certificate 

accessory, 386
Send Backward button (shapes), 296, 299
sequences. See data series
series. See data series
Set Title dialog box (Web pages), 389
setting margins, 310
setting page breaks, 313, 317
setting passwords for ranges, 382
setting passwords for workbooks, 379
setting passwords for worksheets, 381, 384
setting a watch, 77, 78
setting workbook properties, 3, 5
shading, adding to cells. See fill color
shadows, SmartArt graphic, changing, 290
Shape Effects button, 294
Shape Fill button, 294
Shape Outline button, 294
shapes

adding equations to, 296, 299
adding to SmartArt graphics, 289, 292
adding text to, 295, 298
adding to worksheets, 294, 297
aligning, 295, 298
arranging (alignment), 295, 298
arranging (distribution), 295
arranging (order), 296, 299
creating, 294
creating proportionally, 294
distributing, 295
drawing, 294, 297
effects, changing, 294
fill, changing, 294
formatting, 294
as headers, 295
height, changing, 294
height, specifying, 294
as labels, 295
live previews of, 294
macros, assigning to. See shapes (custom buttons)
moving, 295
moving forward and backward, 296
order of, changing, 296, 299
outline, changing, 294
resize handles, 294
resizing, 294
resizing proportionally, 294
rotating, 294
selecting, 295

in SmartArt graphics, moving, 289
text in, aligning, 298
text in, editing, 295
text in, formatting, 295, 300
width, changing, 294
width, specifying, 294

Shapes button, 294, 297
shapes (custom buttons)

assigning macros to, 341, 343
running macros from, 341, 344

Shapes gallery, 294, 297
Share Workbook button, 368, 370
Share Workbook dialog box, 368, 370
sharing workbooks

change histories, default setting for, 369
change histories, keeping, 369, 376, 378
change histories, and retention policies, 369
change histories, recommended settings, 369
comments. See comments
defined, 395
digital signatures and. See digital signatures
via e-mail messages, 370, 371
and Excel tables, incompatibility, 369
with Excel Web App, xxiii
hiding formulas, 381, 383
from Highlight Changes dialog box, 375
over intranets, 388
introduced, 367
merging, 371
over networks, 370, 388
options, setting, 368
via Outlook 2010 messages, 370
protecting locked cells, 381, 383
protecting ranges, 381, 384
protecting shared workbooks. See passwords
protecting worksheets, 380, 384
reconciling changes, 369
removing private information with Document 

Inspector, 385
risks of, 385
saving for secure electronic distribution, 372
tracking comment creators, 373
turning off, for reviewing changes, 376
turning on workbook sharing, 368, 370
as Web pages, limitations of, 368
on the Web. See Web pages

Sheet Background dialog box, 115, 117
sheet tabs

defined, 395
in workbooks saved as Web pages, 388

Shift key
changing chart size proportionally with, 263
changing shape size proportionally with, 294
creating shapes proportionally with, 294, 297
selecting Slicer data with, 231
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shortcuts. See keyboard shortcuts
Show All Comments button, 374
Show Detail button

in subtotal levels, 158
in subtotal outline, 155

Show Detail button (PivotTables), 226, 234
Show/Hide Comment button, 373, 374
Show Margins button (Backstage view Print 

page), 310
Show Table of Contents button, xxxix
Sign dialog box (digital signatures), 386, 387
Signature Confirmation dialog box, 387
signatures, digital. See digital signatures
signing workbooks (digital signatures), 386
single quotes, in references, 176
Slicer Tools Options contextual tab, 232
Slicers, 228

colored values in, 230
creating, 229, 235
defined, 395
filters and, 230
formatting, changing, 232
hiding, 232
introduced, xvi, 228
light gray or white values in, 230
removing filters with, 232, 236
resizing, 232
selecting values in, 230
Shift and Ctrl keys and, 231, 236

SmartArt, introduced, 286
SmartArt button, 286, 290
SmartArt graphics

adding shapes to, 288, 289, 292
adding text to, 288, 289, 291
adding to worksheets, 288
changing appearance of, 288
changing order of elements, 288, 289, 291
choosing, 287
color, changing, 293
Create Graphic group, 288
creating, 286
Cycle type, 287
displaying all, 287
formatting, 290
Hierarchy type, 287, 290
layout, changing, 292
List type, 287
Matrix type, 287
moving shapes in, 289, 291
from Office.com, 287
Picture type, 287
Process type, 287, 288
Pyramid type, 287
Relationship type, 287

text in, formatting, 290
Text Pane, 289
types, summarized, 287

SmartArt Tools Design contextual tab, 288, 289, 292
SmartArt Tools Format contextual tab, 288, 290
software, security, 330
Solver

Add Constraint dialog box, 202, 204
business planning and, 201
cell references in, 203
compared to Goal Seek, 201
comparison operations in, 203, 205
constraints, 203, 204
constraints, changing, 203
constraints, setting, 202
defined, 395
finding target values with, 201
installing, 201
objectives, setting, 202, 203
preparing to use, 201
results, creating a scenario from, 203
results, saving, 203
results, viewing, 203, 206
setting up problems with, 202, 203
Solver Results dialog box, 203, 206
variables, setting, 202, 204

Solver button, 201, 203
Solver Parameters dialog box, 202, 203
Solver Results dialog box, 203, 206
Sort dialog box, 146, 148

custom lists in, 148
My Data Has Headers check box, 146

Sort & Filter button, 146, 148
Sort & Filter list

date options, 145
numeric options, 145
Sort Largest to Smallest option, 144
Sort Smallest to Largest option, 145
text options, 145, 148

sort levels
adding, 146, 148
changing order of, 147, 150
changing orientation of, 147
copying, 147
deleting, 147, 151
making case sensitive, 147
maximum number of, 146

sort order, 146
changing, 147

Sort Options dialog box, 147
sorting

adding levels, 146, 148
criteria, 146
custom lists, creating, 147, 150
custom sort, creating, 146, 148
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sorting (continued)
days of the week, 147
default behavior, 147
defined, 144, 395
by fill color, 146, 152
by font color, 146
headers and, 146
by icon, 146
largest to smallest, 144
levels. See sort levels
months, 147
by multiple columns, 146, 148
overview, 143
smallest to largest, 145
Sort & Filter list, 144, 148
special lists, 147
by value, 146

source cells. See linking
sparklines

best use of, 279
changing appearance of, 279, 280
changing data in, 279
clearing, 279, 280
column type, xv, 277
column type, creating, 278, 279
defined, xv, 259, 276, 395
deleting, 279, 280
destination cell, selecting, 277, 279
formatting, 279
grouping and ungrouping, 279
increasing detail in, 280
line type, xv, 277, 279
purpose of, 276
and regular charts, compared, 279
resizing, 279, 280
selecting ranges for, 277, 279
win/loss type, xv, 277, 278

Sparkline Tools Design contextual tab, 279, 280
Special formats (number), 102
spelling checker, 43, 46
Spelling dialog box, 46
spreadsheet programs

cells in, 251
exporting data to text files, 250

spreadsheets. See worksheets
square brackets [ ]

in formulas, 63, 73
in references, 176

starting Excel 2010, 1, 3
statistics

generating, with Analysis ToolPak, 207, 208
summary, generating with Analysis ToolPak, 209

status bar, AutoCalculate on, 129
strings. See text strings
Style dialog box, 90, 91

styles
adding to Cell Styles gallery, 91
applying, 90
Cell Styles gallery, 90
chart. See charts
creating, 90, 91
deleting, 91
Excel table. See table styles
live preview of, 90
overview, 90
PivotTable, 244, 247

subscript, adding to equations, 299
Subtotal dialog box, 153, 157

default options, 157
removing subtotals, 157

SUBTOTAL function
AVERAGE operation, 130
and column headers, 130
compared to AGGREGATE, 131
COUNTA operation, 130
COUNT operation, 130
and filters, 131
function_num argument, defined, 129
ignoring in AGGREGATE function, 132
introduced, 129
limitations of, 131
MAX operation, 130
MIN operation, 130
operations, summarized, 130
operations that exclude manually hidden values, 130
operations that include manually hidden values, 130
PRODUCT operation, 130
STDEV.P operation, 130
STDEV.S operation, 130
SUM operation, 130
syntax, 129
VAR.P operation, 130
VAR.S operation, 130

subtotal level buttons, in outlines, 156, 159
subtotal levels, 154

adding, 156, 158
Hide Detail button, 155, 158
hiding rows in, 155, 158
level buttons, 156, 159
numbered, summarized, 156
removing, 157
Show Detail button, 155, 158
showing rows in, 155, 158

subtotals
adding to worksheets, 154, 158
calculating, 153
columns and, 153
conditional formatting, in PivotTables, 243
defined, 395
outlines. See subtotal levels
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in PivotTables, 237
in PivotTables, and conditional formatting, 243
in PivotTables, hiding, 239
removing all from worksheet, 157

Subtotals button (PivotTables), 237, 239
SUM function, 61, 69

and filters, 129
and hidden rows, 129
in PivotTables, 237
limitations of, 129

SUMIF function, 71
SUMIFS function, 71, 73, 74
summaries, scenario. See scenario summaries
summarizing data. See also data consolidation; 

formulas; functions; subtotals
with AutoCalculate, 129
in Excel tables, 50, 51
with sparklines. See sparklines

summary formulas, and conditional formatting, 110
summary functions, PivotTable, changing, 237
summary statistics, generating with Analysis 

ToolPak, 209
switching between workbooks, 1
Switch Windows button, 10, 17, 25
switching themes, effect of, 95
symbols

adding to equations, 297, 300
Quick Access Toolbar button, changing, 341, 343

synonyms, finding. See Thesaurus

T
tab bar

introduced, 7
selecting worksheets for printing with, 320, 321

Tab character, as delimiter, 251, 254
Tab key, moving through page headers and footers 

with, 307
table of contents, in Help window, displaying, 

xxxix
table styles

applying, 97
clearing, 97
creating, 96, 97
default, changing, 97

tables, Excel. See Excel tables
target cells. See linking
target values

finding with Goal Seek, 198, 199
finding, from multiple input values, 201
finding with Solver, 201
Goal Seek approximation to, 199
identifying in Goal Seek dialog box, 199, 200

tasks, automating. See macros

templates, chart
applying, 269
applying to existing chart, 269, 273
in Create Charts dialog box, 269
creating, 269, 272
displaying, 269

templates, workbook
adding worksheets to, 168
benefit of, 167
blank, 169
changing, 169
creating, 169, 171
creating workbooks from, 169, 172
defined, 167, 395
Excel 97-2003 file format (.xlt), 169
file format (.xltx), 169, 171
file format, macro-enabled (.xltm), 330
labels in, 168
location, 169
macro-enabled Excel 2010 file format (.xltm), 169
More Templates folder, 170
from Office.com, 169
preconfigured, 170
preparing workbooks for, 168
recently used, 169, 173
removing worksheets from, 168
samples, 169, 172
saving, 169, 174

templates, worksheet
creating, 170, 174
inserting, 170, 174
previews of, 171

text
adding to numbers, 103, 106
adding to shapes, 295, 298
adding to SmartArt graphics, 289, 291
hyperlink, effect of deleting hyperlink on, 361
hyperlink, specifying, 361
Quick Access Toolbar button, changing, 341
in shapes, aligning, 298
in shapes, editing, 295
in shapes, formatting, 295, 300
in SmartArt graphics, formatting, 290
Sort & Filter list options for, 145
sorting, 145, 148
not specifying for hyperlinks, effect of, 361
typing into comments, 373, 374

text box properties, SmartArt graphic,  
changing, 290

text files
exporting spreadsheet data to, 250
as sources for PivotTables, 250

Text Import wizard, 252, 254
text size. See font size
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text strings, quotation marks in, 104, 106
themes

active, and available colors, 95
active, and chart appearance, 261, 267
applying, 94
changing, 96, 100
changing, effect of, 96
changing, effect on charts, 267
and Chart Styles options, 267
colors in palette, 95
creating, 96
default, 94
defined, 94, 395
Office theme, 94
in other Office programs, 96
switching, effect of, 95

Themes button, 96, 101
Thesaurus, 44, 47
time

adding to page headers and footers, 306
formatting cells for, 93
progression, and trendlines, 259

time of recalculation, using NOW function to 
display, 61

tools
formatting. See formatting
SmartArt, 288
statistical analysis. See Analysis ToolPak

tools, data entry
AutoComplete, 31
AutoFill, 30
AutoFill Options button, 32, 34
FillSeries, 30
overview, 29
Pick From Drop-Down List, 31, 33

tools, research, 44. See also Research task pane
Top 10 AutoFilter dialog box, 123, 126
Top 10 filter, 123
Total row, Excel table, 50
totals, viewing with AutoCalculate, 129, 133
Totals row, hidden, and linking errors, 177
Trace Precedents button, 78
tracer arrows, 75, 78, 80

defined, 395
hiding, 76, 79, 80

tracing dependents, to identify errors, 76
tracing precedents, 78

to identify errors, 75
Track Changes button, 375, 377

accepting or rejecting changes from, 376, 378
saving change history from, 376, 378

tracking changes. See change tracking
translating words, 45, 47
translations, Excel, limitations of, 45
transposing data, in paste operations, 37

Trendline button, 274, 276
Linear Forecast Trendline option, 275

trendlines
creating, 274, 276
data distribution, choosing, 274, 276
defined, 395
formatting, 275
introduced, 259
length of projection, 275, 276

trends
introduced, 274
value of charts for communicating, 259

troubleshooting formulas, 60
Trust Center, 331
Trust Center dialog box, 331

U
Undo button, 44

and accepted or rejected changes, not usable, 376
removing filters with, 127

“undo” scenarios, creating, 194
undoing changes, 44
Unhide dialog box, 8, 10
unhiding columns, 12
unhiding rows, 12
unique values

customer IDs, 160
displaying, 132, 133
and headers, 133, 134
and lookup functions, 160
primary key column, 160

updating PivotTables, 219
updating Web pages, 389
user input, validating. See validation rules
user interface, Excel 2010, customizing, 15
usernames, in comments, 372, 373

V
validation circles

displaying, 136, 140
hiding, 137, 140

validation rules
creating, 135
creating entry messages with, 137, 138
creating error messages with, 137, 138
defined, 395
and existing data, 136
introduced, 135
requiring numeric values, 136
setting for multiple cells, 136
specifying minimum and maximum, 138
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specifying whole numbers, 138
turning off, 137
validation circles, 136, 140
violations, displaying, 136, 140

#VALUE! error code, 75
Value Field Settings dialog box, 237, 240
values. See also numbers

adding together, 60
alternative, defining, 191
alternative, displaying, 191, 193
alternative, in scenarios, 190
average, viewing with AutoCalculate, 129, 133
comparing, with color scales, 109, 110
comparing, with data bars, 108, 111
comparing, with icon sets, 109, 111
count, viewing with AutoCalculate, 129, 133
decimals, displayed as percentages, 198
filtering, in PivotTables, 222, 232
filtering for highest or lowest, 123, 126
ignoring in calculations, 131
linking. See linking
maximum and minimum, 55, 61
monitoring, 77, 78
multiple input, and Solver, 201
and multiple scenario applications, 194
overwriting with Goal Seek, 199
percentages, 198
PivotTable, and use in formulas, 238, 241
in PivotTables, filtering, 222, 232
preserving in “undo” scenarios, 195
projecting. See trendlines
replacing, 38
searching for, 38
searching in, 40
in Slicers, selecting, 230
sorting. See sorting
sorting by, 146
subtotaling, 153
sum of, 60
target. See target values
testing. See conditional formatting
total, viewing with AutoCalculate, 129, 133
unique. See unique values
variable, identifying in Goal Seek dialog box,  

199, 200
Values area (PivotTable). See PivotTables
variables, Solver, setting, 202, 204
VBA (Visual Basic for Applications). See Visual 

Basic for Applications (VBA) programming 
language

verifying workbook author identity. See digital 
signatures

viewing macro code, 332, 334
viewing macros, 332, 334
viewing workbook properties, 3

View Macros button, adding to Quick Access 
Toolbar, 339, 342

View tab, zooming, 16
views, Page Layout. See Page Layout view
viruses

avoiding with digital signatures, 386
macros and, 330, 332

visible cells, summarizing, 129, 131
Visual Basic Editor

debugger warning dialog box in, 336
editing macros in, 337, 338
getting help with, 337
saving changes in, 339
stepping through macros with, 333
viewing macro code in, 332, 334

Visual Basic for Applications (VBA) programming 
language

macros and, 330, 333
viruses and, 330

VLOOKUP function, 161
approximate matches, finding, 161, 163
arguments, summarized, 161
cell formats and, 163
display of results from, 161
exact matches, finding, 161, 163
Excel tables and, 161
lookup value, 161
range_lookup argument, limitations of, 161
range_lookup argument settings, 161, 163
ranges and, 161
syntax, 161

volatile functions, defined, 128

W
watch

defined, 395
deleting, 77, 81
setting, 77, 78

Watch Window
defined, 77
deleting a watch, 77, 81
setting a watch, 77, 78

watermarks, as background images, 115
Web pages

AutoRepublish and, 389
creating hyperlinks to, 359
Excel Web App, xxiii
formatting workbook labels for, 388
HTML code in, 388
HTML files, 388
hyperlinks to. See hyperlinks
linking to Excel workbooks, overview, 349
linking to original workbooks, 388
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Web pages (continued)
locating for hyperlinks, 359
opening, 388
and PivotTables, loss of interactivity, 389
publishing, 389, 391
publishing entire workbooks as, 389
publishing parts of workbooks as, 389, 391
saving workbooks as, 388, 389. See also HTML files
saving workbooks as, warning message, 390
tags, 388
title bar text, choosing, 389
updating from linked source files, 389, 391
workbooks as, limitations of, 368
workbooks saved as, sheet tabs in, 388

what-if analysis
defined, 395
introduced, 190

What-If Analysis button, 192
Goal Seek in, 198, 199

width, column, changing, 11
width, shape, changing, 294
Windows Defender, and macros, 330
Windows icons

as embedded file images, 356
as linked file images, 351

Windows Internet Explorer, opening workbooks 
saved as Web pages in, 388

Windows Mail, and creating mailto hyperlinks, 361
Windows Phone, accessing Excel data from, xxiii
windows, workbook

arranging multiple, 17, 24
cascading, 17, 25

Win/Loss button (sparklines), 278
win/loss sparklines

color bars in, 279
creating, 278, 280
defined, 277
positive and negative numbers in, 277, 278

wizards, Text Import, 252, 254
Word 2010

linked documents, editing, 352
linking documents to Excel workbooks, 349

word choice, researching, 44
words

adding to dictionary, 43, 46
sorting, default behavior, 147

workbook, default, 2
workbook properties

defined, 395
deleting, 4
finding and removing with Document  

Inspector, 385
setting, 3-6
status, setting as Final, 385
viewing, 3

workbooks
adding worksheets to, 171
arranging multiple windows, 17, 24
authenticating. See digital signatures
and broken file links, 350
changes, tracking. See change tracking
comments in. See comments
copying worksheets, 7, 9
creating, 2, 4
creating hyperlinks within, 359, 362
creating from templates, 169, 172
defined, 395
deleted, and linking, 177
displaying side by side, 17
displaying two simultaneously, 17
Document Properties panel, 3
editing, and digital signatures, 387
editing by multiple people. See sharing workbooks
editing in Page Layout view, 304
embedding in other Office documents, 355, 356
embedding other Office documents in, 355
entire, publishing to the Web, 389
Excel display font, changing, 87, 89
filtering ranges, 58
finalized, restoring functionality, 385
finalizing, 385, 387
grouping. See workspaces
hyperlinks in. See hyperlinks
identity of author, verifying. See digital signatures
limiting access to, 379
linked files in, appearance of, 351
linking to other Office documents, 349, 350
linking to the Web, 349
links, introduced, 168
macro-disabled, 330
macro-enabled, 330-331
macro security warning message, 331, 332
macros in. See macros
macros on custom buttons (shapes) in, 341, 343
managing in Backstage view, ix
margins. See margins, worksheet
merging, 371
moving charts to, 264
names, in headers and footers, 305
opening, running macros when, 344
opening simultaneously. See workspaces
Page Layout view. See Page Layout view
previewing in Backstage view, 309, 312, 316
previews, navigating in, 312
printing all worksheets in, 320
properties. See workbook properties
protecting formulas from unauthorized access, 

381, 383
protecting ranges from unauthorized access,  

381, 384
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protecting from unauthorized access, 379, 382, 385
protecting worksheets from unauthorized access, 

380, 384
publishing to the Web, 389, 391
read-only, creating, 372, 385
in references, 176
removing passwords from, 380
removing private information from, 385
renamed, and linking, 177
restoring formatting when opening, 344
saved with Goal Seek results in effect, 199
saved with scenario in effect, 191
saved as Web pages, opening, 388
saving, 3, 6
saving as PDF files, 372
saving as Web pages. See Web pages
saving as XPS files, 372
saving frequency, 3
securing for electronic distribution, 372
Security Warning Message Bar in, 331, 332
sending as e-mail attachments, 370, 371
setting passwords for, 379
shapes, running macros from, 343
shared, and Excel table incompatibility, 369
shared, change history for, 369, 376, 378
sharing. See sharing workbooks
signing (digital signatures), 386
source, importance of verifying, 331, 386
switching between, 1, 17, 24
templates. See templates, workbook
themes. See themes
tracking changes in. See change tracking
viewing macros in, 332
viewing on Internet, 388
viewing on intranets, 388
views, Page Layout. See Page Layout view
as Web pages, moving through, 388

worksheet, target, in data consolidation, 182
worksheets

adding images to, 113, 116
adding shapes to, 294, 297
adding SmartArt graphics to, 288
adding subtotals to, 154, 158
adding to templates, 168
adding to workbook from Insert dialog box, 171
all in workbook, printing, 320
background images in. See backgrounds
blank, inserting, 170
cells. See cells
changing order of, 8, 9
changing tab color, 8, 9
columns. See columns, worksheet
comments in. See comments
configuration, changing. See PivotTables
copying, 7, 9

creating, 7
creating from imported text files, 250
defined, 395
deleted, and linking, 177, 178
deleting, 8, 10
displaying, 7
dynamic. See PivotTables
elements, selecting for printing, 320
entire, printing, 320
filtering. See filters
fitting on printed pages, 312, 317, 322, 325
formatting. See formatting
headers and footers on, 304
hidden, finding and removing with Document 

Inspector, 385
hidden, redisplaying, 8, 10
hiding, 8, 9
History, adding, 376, 378
macros in. See macros
macros on custom buttons (shapes) in, 341, 343
margins. See margins, worksheet
names, adding to page headers and footers, 306
Page Layout view. See Page Layout view
previewing in Backstage view, 309, 312, 316
previews, navigating in, 312
printing, 318, 321
printing parts of, 322
protecting, 380, 384
purpose of, 7
reducing, to print columns on single page, 312
reducing, to print on single page, 312, 322
in references, 176
removing from templates, 168
renamed, and linking, 177
renaming, 7, 9
resizing, 312, 317, 322, 325
restoring after scenario application, 195
rows. See rows, worksheet
saving as individual HTML files, 388
scaling to fit specified printout pages, 322, 325
scenario summary, creating, 194, 197
searching, 38
selecting for printing, 32–322
setting passwords for, 381, 384
sorting. See sorting
subtotal levels, 154
summary, sparklines in, 277
tabs, changing color of, 8, 9
templates, creating, 170, 174
views, Page Layout. See Page Layout view

workspaces
defined, 167, 395
defining, 184, 185
file format (.xlw), 186
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X
.xlsm (macro-enabled Excel 2010 workbook) file 

format, 330
.xlsx (workbook) file format, 330
.xlt (Excel 97-2003 template) file format, 169
.xltm (macro-enabled Excel 2010 template) file 

format, 169, 330
.xltx (template) file format, 169, 330
.xlw (workspace) file format, 186
XML (Extensible Markup Language), defined, 395
XML Paper Specification (XPS) files, saving 

workbooks as, 372
XPS files. See XML Paper Specification (XPS) files

Z
zeros in number formatting, 103
Zoom button, 16, 24
Zoom control, 16
Zoom dialog box, 16, 24
Zoom To Selection button, 16, 24
zooming, 23

overview, 16
specific zoom level, 16
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