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INTRODUCTION

Business intelligence (BI) is what you get when you analyze raw data and turn that information  
into actionable knowledge. BI can help an organization identify cost-cutting opportunities, uncover 
new business opportunities, recognize changing business environments, identify data anomalies, 
and create widely accessible reports.

The BI concept is overtaking corporate executives who are eager to turn impossible amounts of data 
into useful knowledge. As a result of this trend, software vendors who focus on BI and build dash-
boards are coming out of the woodwork. Dashboards are ideal mechanisms for delivering this tar-
geted information in a graphical, user-friendly form. New consulting firms touting their BI knowledge 
are popping up virtually every week. And even the traditional enterprise solution providers like 
Business Objects and SAP are offering new BI capabilities presented in a dashboard format.

So maybe you’ve been hit with dashboard fever? Or maybe you’re holding this book because some-
one is asking you to create BI solutions (that is, create a dashboard) in Excel.

Although many IT managers would scoff at the thought of using Excel as a BI tool to create a dash-
board, Excel is inherently part of the enterprise-BI-tool portfolio. Whether IT managers are keen to 
acknowledge it or not, most of the data analysis and reporting done in business today is done by 
using a spreadsheet program. We see several significant reasons to use Excel as the platform for your 
dashboards and reports. They are as follows:

➤	 Familiarity with Excel: If you work in corporate America, you’re conversant in the language of 
Excel. You can send even the most seasoned senior vice-president an Excel-based presenta-
tion and trust he’ll know what to do with it. With an Excel dashboard, your users spend less 
time figuring how to use the tool and more time viewing the data.

➤	 Built-in flexibility: With most enterprise dashboards, the ability to analyze the data outside of 
the predefined views is either disabled or unavailable. In Excel, features such as pivot tables, 
drop-down lists, and other interactive controls (such as a check box) don’t lock your audi-
ence into one view. And because an Excel workbook contains multiple worksheets, the users 
have space to add their own data analysis as needed.
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➤	 Rapid development: Using Excel to build your own dashboards can liberate you from 
assorted resource and time limitations from within an organization. With Excel, you can 
develop dashboards faster and adapt more quickly to changing business requirements.

➤	 Powerful data connectivity and automation capabilities: Excel is not the toy application some  
IT managers make it out to be. With its own native programming language and its robust 
object model, Excel can help to automate certain processes and even connect with various 
data sources. With a few advanced techniques, your dashboard can practically run on its own.

➤	 Little to no incremental costs: Not all of us can work for multi-billion dollar companies that 
can afford enterprise-level reporting solutions. In most companies, funding for new comput-
ers and servers is limited, let alone funding for expensive dashboard software packages. For 
those companies, Excel is frankly the most cost-effective way to deliver key business report-
ing tools without compromising too deeply on usability and function.

Excel contains so many functions and features that it’s difficult to know where to start. Enter your 
humble authors, spirited into your hands via this book. Here we show you how you can turn Excel 
into your own personal BI tool. With a few fundamentals and some of the new BI functionality 
Microsoft has included in this latest version of Excel, you can go from reporting data with simple 
tables to creating meaningful dashboards sure to wow everyone.

What You Need to Know
The goal of this book is to show you how to leverage Excel functionality to build and manage better 
presentations. Each chapter in this book provides a comprehensive review of Excel functions and fea-
tures, and the analytical concepts that will help you create better reporting components — compo-
nents that can be used for both dashboards and reports. As you move through this book, you’ll be 
able to create increasingly sophisticated components.

After reading this book, you’ll be able to:

➤	 Analyze large amounts of data and report those results in a meaningful way.

➤	 Get better visibility into data from different perspectives.

➤	 Add interactive controls to show various views.

➤	 Automate repetitive tasks and processes.

➤	 Create eye-catching visualizations.

➤	 Create impressive dashboards and What-If analyses.

➤	 Access external data sources to expand your message.
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What You Need to Have
In order to get the most out of this book, it’s best that you have certain skills before diving into the 
topics highlighted in this book. The ideal candidate for this book will have the following:

➤	 Some experience working with data and familiarity with the basic concepts of data analysis 
such as working with tables, aggregating data, and performing calculations

➤	 Experience using Excel with a strong grasp of concepts such as table structures, filtering, 
sorting, and using formulas

Conventions in This Book
Take a minute to skim this section and become familiar with some of the typographic conventions 
used throughout this book.

Keyboard conventions
You need to use the keyboard to enter formulas. In addition, you can work with menus and dialog 
boxes directly from the keyboard — a method you may find easier if your hands are already posi-
tioned over the keys.

Formula listings
Formulas usually appear on a separate line in monospace font. For example, we may list the follow-
ing formula:

=VLOOKUP(StockNumber,PriceList,2,False)

Excel supports a special type of formula known as an array formula. When you enter an array formula, 
press Ctrl+Shift+Enter (not just Enter). Excel encloses an array formula in brackets in order to remind 
you that it’s an array formula. When we list an array formula, we include the brackets to make it clear 
that it is, in fact, an array formula. For example:

{=SUM(LEN(A1:A10))}

Note 	

Do not type the brackets for an array formula. Excel puts them in automatically.
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Key names
Names of keys on the keyboard appear in normal type, for example Alt, Home, PgDn, and Ctrl. When 
you need to press two keys simultaneously, the keys are connected with a plus sign: for example, 
“Press Ctrl+G to display the Go To dialog box.”

Functions, procedures, and named ranges
Excel’s worksheet functions appear in all uppercase, like so: “Use the SUM function to add the values 
in column A.”

Macro and procedure names appear in normal type: “Execute the InsertTotals procedure.” We often 
use mixed upper- and lowercase letters to make these names easier to read. Named ranges appear in 
italic: “Select the InputArea range.”

Unless you’re dealing with text inside quotation marks, Excel is not sensitive to case. In other words, 
both of the following formulas produce the same result:

=SUM(A1:A50)
=sum(a1:a50)

Excel, however, will convert the characters in the second formula to uppercase.

Mouse conventions
The mouse terminology in this book is all standard fare: “pointing,” “clicking,” “right-clicking,” “drag-
ging,” and so on. You know the drill.

What the icons mean
Throughout the book, icons appear to call your attention to points that are particularly important.

New Feature	

This icon indicates a feature new to Excel 2013.

Note 	

This icon tells you that something is important — perhaps a concept that may help you 
master the task at hand or something fundamental for understanding subsequent 
material.

Tip 	

This icon indicates a more efficient way of doing something or a technique that may not 
be obvious. These icons will often impress your officemates.
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This icon indicates that an example file is on the companion website: 

www.wiley.com/go/exceldr

	

We use Caution icons when the operation that we’re describing can cause problems if 
you’re not careful.

Cross-Ref	

We use the Cross-Reference icon to refer you to other chapters that have more to say on 
a particular topic.

How This Book Is Organized
The chapters in this book are organized into six parts. Each of these parts includes chapters that build 
on the previous chapters’ instruction. The idea is that as you go through each part, you will be able to 
build dashboards of increasing complexity until you’re an Excel dashboarding guru.

Part I: Getting Started with Excel Dashboards
Part I is all about helping you think about your data in terms of creating effective dashboards and 
reports. Chapter 1 introduces you to the topics of dashboards and reports, defining some of the basic 
concepts and outlining key steps to take to prepare for a successful project. Chapter 2 shows you 
how to design effective data tables. Chapter 3 shows you how you can leverage the sparkline func-
tionality found in Excel 2013. Finally, Chapter 4 rounds out this section with a look at the various 
techniques that you can use to visualize data without the use of charts or graphs.

Part II: Introducing Charts into Your Dashboards
Part II provides a solid foundation in visualizing data using Excel charts. Chapter 5 starts with the 
basics, introducing you to Excel’s charting engine. Chapters 6 and 7 focus on formatting techniques 
that enable you to build customized charts that fit your distinct needs. After that, Part II takes you 
beyond basic chart-building with a look at some advanced business techniques that can help make 
your dashboards more meaningful. Starting with Chapter 8, we demonstrate how to represent trend-
ing across multiple series and distinct time periods. In Chapter 9, we explore how best to use charts 
to group data into meaningful views. And Chapter 10 demonstrates some of charting techniques 
that can help you display and measure performance against a target. By the end of this section, you 
will be able to effectively leverage Excel charts to synthesize your data into meaningful visualizations.

On the Web

Caution
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Part III: Advanced Dashboarding Concepts
In Part III, we offer an in-depth look at some of the key dashboarding concepts you can leverage to 
create a cutting–edge dashboard presentation. Chapter 11 shows you how to build an effective data 
model that provides the foundation upon which your dashboard or report is built. In this chapter, 
you discover the impact of poorly organized data and how to set up the source data for the most 
positive outcome. Chapter 12 illustrates how interactive controls can provide your clients with a  
simple interface, allowing them to easily navigate through and interact with your dashboard or 
report. Chapter 13 provides a clear understanding of how you can leverage macros to automate  
your reporting systems.

Part IV: Pivot Table Driven Dashboards
With Part IV, you find out how pivot tables can enhance your analytical and reporting capabilities, as 
well as your dashboards. In Chapter 14, we introduce you to pivot tables and explore how this Excel 
feature can play an integral role in Excel-based presentations. Chapter 15 provides a primer on build-
ing pivot charts, giving you a solid understanding of how Excel pivot charts work with pivot tables. 
Chapter 16 shows you how pivot slicers can add interactive filtering capabilities to your pivot report-
ing. Finally, Chapter 17 introduces you to the new internal Data Model and Power View features of 
Excel 2013.

Part V: Working with the Outside World
The theme in Part V is importing information from external data sources. Chapter 18 explores some 
of the ways to incorporate data that doesn’t originate in Excel. In this chapter, you learn how to 
import data from external sources, such as Microsoft Access and SQL Server, as well as create systems 
that allow for dynamic refreshing of external data sources. Chapter 19 wraps up this look at Excel 
dashboards and reports by showing you the various ways to distribute and present your work in a 
safe and effective way.

About the Companion Website
This book contains many examples, and the workbooks for those examples are available on the com-
panion website that is arranged in directories that correspond to the chapters. You can download 
example files for this book at the following website:

www.wiley.com/go/exceldr

The example workbook files on the website aren’t compressed (installation isn’t required). These files 
are all Excel 2007–2013 files.
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About the Power Utility Pak Offer
Toward the back of the book, you’ll find a coupon that you can redeem for a discounted copy of John 
Walkenbach’s award-winning Power Utility Pak — a collection of useful Excel utilities, plus many new 
worksheet functions. John developed this package using VBA exclusively.

You can also use this coupon to purchase the complete VBA source code for a nominal fee. Studying 
the code is an excellent way to pick up some useful programming techniques.

You can download a 30-day trial version of the most-recent version of the Power Utility Pak from 
John’s website:

http://spreadsheetpage.com

If you find it useful, use the coupon to purchase a licensed copy at a discount.

Reach Out
We’re always interested in getting feedback on our books. The best way to provide this feedback is 
via e-mail. Send your comments and suggestions to

mha105@yahoo.com
john@j-walk.com

Unfortunately, we’re not able to reply to specific questions. Posting your question to one of the Excel 
newsgroups is, by far, the best way to get such assistance.

Also, when you’re out surfing the web, don’t overlook John’s website (“The Spreadsheet Page”). 
You’ll find lots of useful Excel information, including tips and downloads. The URL is

http://spreadsheetpage.com

Now, without further ado, it’s time to turn the page and expand your horizons.
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1
Introducing  
Dashboards
In This Chapter

●	 Defining dashboards and reports

●	 Determining user requirements

●	 Establishing visualization and design principles

●	 Reviewing your dashboard prior to distribution

Creating a dashboard in Excel is not the same as creating a standard table-driven analysis. It’s tempt-
ing to jump right in and start building away, but a dashboard requires far more preparation than a 
typical Excel report. It calls for closer communication with business leaders, stricter data modeling 
techniques, and the following of certain best practices. It’s helpful to be familiar with fundamental 
dashboard concepts before venturing off into the mechanics of building your own. In this chapter, 
we discuss basic dashboard concepts and design principles and what it takes to prepare for a dash-
boarding project.

On the Web	

All workbook examples that we list in this book are available on this book’s companion 
website at www.wiley.com/go/exceldr.

What Are Dashboards and Reports?
It isn’t difficult to use the words report and dashboard interchangeably. In fact, the line between 
dashboards and reports frequently gets muddied. We see countless reports that are referred to as 
dashboards just because they include a few charts. Likewise, we see many examples of what could 
be considered dashboards but are called reports.
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Part I: Getting Started with Excel Dashboards12

Now this may all seem like semantics to you, but it’s helpful to clear the air a bit and understand the 
core attributes of both dashboards and reports.

Defining reports
Reports are probably the most common way to communicate business intelligence. A report can be 
described as a document that contains data used for viewing and analysis. It can be as simple as a 
data table (or a database) or as complex as a subtotaled view with interactive drilling.

The key attribute of a report is that it doesn’t lead a reader to a predefined conclusion. Although a 
report can include analysis, aggregations, calculations, and even charts, reports often require the 
reader to apply his own judgment and analysis to the data.

To clarify this concept, Figure 1-1 shows an example of a report. This report shows National Park visi-
tor statistics by year. Although this data can be useful, this report doesn’t steer the reader to any pre-
defined conclusions or in any directions; it simply presents the aggregated data.

Figure 1-1: Reports present data for viewing but don’t lead readers to predefined conclusions.

Defining dashboards
A dashboard is a visual interface that provides at-a-glance views into key measures relevant to a par-
ticular objective or business process. A dashboard consists of three key attributes.

➤	 Displays data graphically (such as in charts). Provides visualizations that help focus attention 
on key trends, comparisons, and exceptions.

➤	 Displays only data that is relevant to the goal of the dashboard.

➤	 Contains predefined conclusions relevant to the goal of the dashboard and relieves the 
reader from having to perform her own analysis.

Figure 1-2 illustrates a dashboard that uses the same data shown in Figure 1-1. This dashboard dis-
plays information about National Park attendance. As you can see, this presentation has all the key 
attributes that define a dashboard. First, it’s a visual display that allows you to quickly recognize the 
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Chapter 1: Introducing Dashboards 13

overall trend of the attendance. Second, not all the details of the data are shown in this presentation; 
only the key pieces of information that support the goal of this dashboard. Finally, by virtue of its 
objective, this dashboard effectively presents you with analysis and conclusions about the trending 
of attendance.

Figure 1-2: A dashboard provides an at-a-glance view into key measures relevant to a particular objective or 
business process.

As you take in this concept of reports versus dashboards, remember that Excel doesn’t provide tools 
specifically designed for dashboards or reports. The beauty of Excel is that any of its tools can be 
used to perform virtually any task that you need. For example, you can use the chart, pivot tables, 
and macros features in a basic report or to play a key role in a dashboard presentation. In this book, 
we introduce you to the many ways that you can leverage everyday Excel tools to build your own 
dashboard components.

Establish the User Requirements
Imagine that your objective is to create a dashboard that provides information about monthly ser-
vice subscriptions. Do you jump to action and slap together whatever comes to mind? Do you take a 
guess at what information would be useful in a dashboard like this? These questions sound ridicu-
lous, but it happens more that you think. We are constantly called to action but are rarely provided 
the time to gather the true requirements for the project. Between limited information and false 
deadlines, the end product often ends up not being used or causing more work than value.

This brings us to one of the key steps in preparing to build a dashboard — collecting user require-
ments. These user requirements include defining your audience, data sources, performance mea-
sures, refresh schedules, and so on.

In the non-IT world of the Excel analyst, user requirements are practically useless because of the hard 
left and right turns we’re asked to make every day. So the gathering of user requirements sometimes 
seems like a waste of valuable time in the ever-changing business environment. 

www.it-ebooks.info

http://www.it-ebooks.info/


Part I: Getting Started with Excel Dashboards14

But it’s time to get into the dashboard state of mind. After all, would you rather spend your time 
upfront gathering user requirements or at the end painstakingly redesigning the dashboard you’ll 
surely come to hate?

Consider how many times you’ve been asked for an analysis, only to be told, “No. I meant this.” Or, 
“Now that I see it, I realize I need this.” As frustrating as that can be for a single analysis, imagine run-
ning into this during the creation of a complex dashboard with several data integration processes. 

The process of gathering user requirements doesn’t have to be an overly complicated or formal one. 
Here are some simple things you can do to ensure that you have a solid idea of the purpose of the 
dashboard.

When collecting user requirements for your dashboard, focus on the types of data that you need, the 
dimensions of data that you require, the data sources that you will use, and so on. This is a good 
thing; without solid data processes, your dashboards won’t be effective or maintainable. 

Define the message(s)
When receiving requirements for a new dashboard project, don’t be afraid to clarify who exactly is 
making the initial request and talk to them about what they’re really asking for. Discuss the purpose 
of the dashboard and the triggers that caused them to ask for a dashboard in the first place. You may 
find, after discussing the matter, that a simple Excel report will meet their needs, foregoing the need 
for a full-on dashboard.

Establish the audience
If a dashboard is warranted, talk about who the end users will be. Take some time to meet with some 
of the end users and talk about how they plan to use the dashboard. For example, will the dashboard 
be used as a performance tool for regional managers or perhaps to share data with external custom-
ers? Talking through these fundamentals with the right people will help align your thoughts and 
avoid missed requirements later.

Define the performance measures
Most dashboards are designed around a set of measures called Key Performance Indicators (KPIs). A 
KPI is an indicator of the level of performance of a task deemed to be essential to daily operations or 
processes. The idea around a KPI is that it will reveal performance that is outside the norm, signaling 
the need for attention and intervention. Although the measures you place into your dashboards may 
not officially be called KPIs, they undoubtedly serve the same purpose — to draw attention to prob-
lem areas.

www.it-ebooks.info

http://www.it-ebooks.info/


Chapter 1: Introducing Dashboards 15

	

The topic of creating effective KPIs for your organization is worthy of its own book and 
outside the scope for this endeavor. For a detailed guide on KPI development strategies, 
pick up David Parmenter’s book, Key Performance Indicators: Developing, Implementing, 
and Using Winning KPIs, published by John Wiley & Sons, Inc. This book provides an 
excellent step-by-step approach to developing and implementing KPIs. 

The measures that you use on a dashboard should support the initial goal of that dashboard. For 
example, if you create a dashboard that focuses on supply chain processes, it may not make sense to 
have HR head count data included. It’s generally good to avoid nice-to-know data in your dashboards 
simply to fill white space or because the data is available. If the data doesn’t support the core goal of 
the dashboard, leave it out.

Here’s another tip. When gathering the measures required for the dashboard, we find that it often 
helps to write out a sentence to describe the measure needed. For example, instead of simply writing 
the word “Revenue” into our user requirements, we write what we call a component question such as 
“What is the overall revenue trend for the last two years?” We call it a component question because 
we will ultimately task a single component, such as a chart or a table, to answer the question. For 
instance, if the component question is “What is the overall revenue trend for the last two years?” you 
can imagine a chart component answering that question by showing the two-year revenue trend.

We sometimes take this a step further and actually incorporate the component questions into a 
mock layout of the dashboard to get a high-level sense of what data the dashboard will require. 
Figure 1-3 illustrates an example.

Each box in this dashboard layout mockup represents a component on the dashboard and its 
approximate position. The questions within each box provide a sense of the types of data required to 
create the measures for the dashboard.

Figure 1-3: Each box in this dashboard layout mockup represents a component and the type of data required to 
create the measures.

Note
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List the required data sources
After you have the list of measures that you need on the dashboard, it’s important to take a tally of 
the available databases or other source systems to determine whether the data required to produce 
those measures is available.

➤	 Do you have access to the data sources necessary?

➤	 How often are those data sources updated?

➤	 Who owns and maintains those data sources?

➤	 What are the processes to get the data from those resources?

➤	 Does the data even exist?

You’ll need answers to these questions when negotiating development time, refresh intervals, and 
phasing.

Tip 	

Conventional wisdom says that the measures on your dashboard should not be gov-
erned by the availability of data. Instead, let dashboard KPIs and measures govern the 
data sources in your organization. Although we agree with the spirit of that statement, 
we’ve been involved in too many dashboard projects that have fallen apart because of 
lack of data. Real-world experience has taught us the difference between the ideal and 
the ordeal.

If your organizational strategy requires that you collect and measure data that is nonexistent or not 
available, press pause on the dashboard project and turn your attention to creating a data collection 
mechanism that will help you to get the data you need.

Define the dimensions and filters
In the context of building a dashboard, a dimension is a data category that you use to organize busi-
ness data. Examples of dimensions are region, market, branch, manager, and employee. When you 
define a dimension in the user requirements stage, you can determine how the measures should be 
grouped or distributed. For example, if your dashboard should report data by employee, you will 
need to ensure that your data collection processes include employee details. As you can imagine, 
adding a new dimension after the dashboard is built can get complicated, especially when your pro-
cesses require collecting data across multiple data sources. The bottom line is that locking down the 
dimensions for a dashboard early in the process will definitely save you headaches.

Along those same lines, you want to know the types of filters that you’ll need. Filters are mechanisms 
that allow you to narrow the scope of the data to a single dimension. For example, you can filter by 
year, employee, or region. Again, if you don’t account for a particular filter while establishing your 
data collection process, you will likely be forced into an unpleasant redesign of both your processes 
and your dashboard.
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Determine the need for drill-down details
Many dashboards provide drill-down features that allow you to click through to the details of a  
specific measure. You want to get a clear understanding of the types of drill downs your users have 
in mind.

To most users, a drill-down feature means the ability to get a raw data table supporting the measures 
shown on the dashboard. Although this isn’t always practical or possible, at minimum, you can set 
expectations and document the request for future dashboard versions. This allows you to plan for 
any macros, links, or other solutions that you may have to include with your dashboards.

Establish the update schedule
An update schedule refers to how often a dashboard is changed to reflect the latest information avail-
able. As the one who will build and maintain the dashboard, it’s important that you have a say in 
these schedules. Your customer may not know what it will take to update the dashboard in question. 
While talking about this schedule, keep in mind the refresh rates of the different data sources you will 
need to get the measures. You won’t be able to refresh your dashboard any faster than your data 
sources. Also, negotiate enough development time to build macros that will automate redundant 
and time-consuming updating tasks.

A Quick Look at Dashboard  
Design Principles
Excel users live in a world of numbers and tables, not visualization and design. Your typical Excel ana-
lyst has no background in visual design and is often left to rely on his own visual instincts to design 
his dashboards. As a result, most Excel-based dashboards have little thought given to effective visual 
design, often resulting in overly cluttered and ineffective UI.

The good news is that dashboards have been around for a long time, so we have a vast Knowledge 
Base of prescribed visualization and dashboard design principles. Although many of these principles 
seem like common sense, these are concepts that Excel users don’t think about regularly. Let’s break 
that trend and review a few dashboard design principles that will improve the design of your Excel 
dashboards.

Note 	

Many of the concepts in this section come from the work of Stephen Few, visualization 
expert and author of several books and articles on dashboard design principles. Because 
this book focuses on the technical aspects of building dashboards in Excel, this section 
offers a high-level look at dashboard design. If you find yourself captivated by the sub-
ject, feel free to visit www.perceptualedge.com to see Stephen Few’s website.
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Rule number 1: Keep it simple
Dashboard design expert Stephen Few has the mantra, “Simplify, Simplify, Simplify.” A dashboard 
that is cluttered with too many measures and too much eye candy can dilute the significant informa-
tion that you’re trying to present. How many times has someone told you that your reports look 
busy? In essence, they’re saying that you have too much on the page or screen, making it hard to see 
the actual data.

Here are few actions you can take to ensure a simpler and more effective dashboard design.

Don’t turn your dashboard into a data mart
Admit it. You include as much information in a report as possible, primarily to avoid being asked for 
additional information. We all do it. But in the dashboard state of mind, you have to fight the urge to 
force every piece of data available onto your dashboard. 

Overwhelming users with too much data can cause them to lose sight of the primary goal of the 
dashboard and focus on inconsequential data. The measures used on a dashboard should support 
the initial purpose of that dashboard. Avoid the urge to fill white space for the sake of symmetry and 
appearances. Don’t include nice-to-know data just because the data is available. If the data doesn’t 
support the core purpose of the dashboard, leave it out.

Forget about the fancy formatting
The key to communicating effectively with your dashboard is to present your data as simply as possi-
ble. There’s no need to wrap it in eye candy to make it more interesting. It’s okay to have a dashboard 
with little to no color or formatting. You’ll find that the lack of fancy formatting only calls attention to 
the actual data. Focus on the data and not shiny happy graphics. 

To help drive this point home, we created the chart shown in Figure 1-4 (formatting and all). Excel 
makes it easy to achieve these types of effects with its layout and style features. The problem is that 
these effects subdue the very data we’re trying to present. Furthermore, if we include this chart on a 
page with five to ten other charts with the same formatting, we get a dashboard that’s difficult to 
look at — much less to read.

Figure 1-4: Fancy formatting can be overwhelming, overshadowing the very data you’re trying to present.
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Figure 1-5 shows the same data without the fancy formatting. Not only is the chart easier to read but 
also you can process the data more effectively from this chart.

Figure 1-5: Charts should present your data as simply as possible.

Here are some simple tips to keep from overdoing the fancy factor:

➤	 Avoid using colors or background fills to organize your dashboards. Colors, in general, 
should be used sparingly, reserved only for information about key data points. For example, 
assigning red, yellow, and green to measures traditionally indicates performance level. 
Coloring sections of your dashboard only distracts your audience from your message.

➤	 De-emphasize borders, backgrounds, and other elements that define dashboard areas. Try  
to use the natural white space between your components to partition your dashboard. If 
borders are necessary, format them to lighter hues than your data. Light grays are typically 
ideal for borders. The idea is to indicate sections without distracting from the information 
displayed.

➤	 Excel 2013 makes it easy to apply effects that make everything look shiny, glittery, and gen-
erally happy. Although these formatting features make for great marketing tools, they don’t 
do you or your dashboard any favors. Avoid applying fancy effects such as gradients, pattern 
fills, shadows, glow, soft edges, and other formatting.

➤	 Don’t try to enhance your dashboard with clip art or pictures. They do nothing to further 
data presentation, and they often just look tacky.

Skip the unnecessary chart junk
Data visualization pioneer Edward Tufte introduced the notion of data-to-ink ratio. Tufte’s basic idea 
is that a large percentage of the ink on your chart (or on your dashboard) should be dedicated to 
data. Very little ink should represent what he calls chart junk: borders, gridlines, trend lines, labels, 
backgrounds, and so on.
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Figure 1-6 illustrates the impact that chart junk can have on the ability to effectively communicate 
your data. Notice how convoluted and cramped the data looks in the top chart.

The bottom chart actually contains the same data. Yet, it more effectively presents the core message 
that driver registrations in Texas rose from approximately 10.5 million to almost 17 million. This mes-
sage was diluted in the top chart by excess clutter. So you can see from this simple example how 
your chart dramatically improves by simply removing elements that don’t directly contribute to the 
core message.

Figure 1-6: Charts with too many chart elements can become convoluted and hard to read. Removing the 
unnecessary elements clarifies the message.

Here are a few ways to avoid chart junk and ensure that your charts clearly present your data.

➤	 Remove gridlines: Gridlines (both vertical and horizontal) are almost always unnecessary. 
The implied reason for gridlines is that they help to visually gauge the value represented by 
each data point. The truth is, however, people typically gauge the value of a data point by 
comparing its position to the other data points in the chart. So gridlines become secondary 
reference points that simply take up ink.

➤	 Remove borders: You’ll find that eliminating borders and frames gives your charts a cleaner 
look and helps you avoid the dizzying lines you get when placing multiple charts with bor-
ders on a single dashboard. Instead of borders, make use of the white space between the 
charts as implied borders.
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➤	 Skip the trend lines: Seldom does a trend line provide insight that can’t be gained with the 
already plotted data or a simple label. In fact, trend lines often state the obvious and some-
times confuse readers into thinking they are part of another data series. Why place a trend 
line on a line chart when the line chart is in and of itself a trend line of sorts? Why place a 
trend line on a bar chart when it’s just as easy to look at the tops of the bars? In lieu of  
trend lines, add a simple label that states what you’re trying to say about the overall trend  
of the data.

➤	 Avoid unnecessary data labels: Nothing states that you need to show the data label for every 
value on your chart. It’s okay to plot a data point and not display its value. You’ll find that your 
charts have more impact when you show only numbers that are relevant to your message.

➤	 Don’t show a legend if you don’t have to: When you’re plotting one data series, you don’t 
need to display a space-taking chart legend. Allow your chart title to identify the data that 
your chart represents.

➤	 Remove any axis that doesn’t add value: The purpose of the X and Y axes are to help a user 
visually gauge and position the values represented by each data point. However, if the 
nature and utility of the chart doesn’t require a particular axis, remove it. Again, the goal here 
is not to hack away at your chart. The goal is to include only those chart elements that 
directly contribute to the core message of your chart.

Limit each dashboard to one viewable page or screen
A dashboard should provide an at-a-glance view into key measures relevant to a particular objective 
or business process. This implies that all the data is immediately viewable at one time. Although this 
isn’t always the easiest thing to do, it’s best to see all the data on one page or screen. You can com-
pare sections more easily, you can process cause and effect relationships more effectively, and you 
rely less on short-term memory. When a user has to scroll left, right, or down, these benefits are 
diminished. Furthermore, users tend to believe that when information is placed out of normal view 
(areas that require scrolling), it is somehow less important.

But what if you can’t fit all the data in one viewable area (one page or one screen)? First, review the 
measures on your dashboard and determine if they really need to be there. Next, format your dash-
board to use less space (format fonts, reduce white space, adjust column and row widths). Finally, try 
adding interactivity to your dashboard, allowing users to dynamically change views to show only 
those measures that are relevant to them.

Cross-Ref	

We discuss how to add interactive features in Chapter 12.
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Use layout and placement to draw focus
As discussed earlier in this chapter, only include measures that support your dashboard’s goal. 
However, just because all measures on your dashboard are significant, they may not always have the 
same level of importance. In other words, you will frequently want one component of your dash-
board to stand out from the others. 

Instead of using bright colors or exaggerated sizing differences, you can leverage location and place-
ment to draw focus to the most important components on your dashboard.

Various studies have shown that readers have a natural tendency to focus on particular regions of a 
document. For example, researchers at the Poynter Institute’s Eyetracker III project have found that 
readers view various regions on a screen in a certain order, paying particular attention to specific 
regions on the screen. They use the diagram in Figure 1-7 to illustrate what they call priority zones. 
Regions with the number 1 in the diagram seem to have high prominence, attracting the most atten-
tion for longer periods of time. Meanwhile number 3 regions seem to have low prominence.

Figure 1-7: Studies show that users pay particular attention to the upper left and middle left of a document.

You can leverage these priority zones to promote or demote certain components based on signifi-
cance. If one of the charts on your dashboard warrants special focus, you can simply place that chart 
in a region of prominence. 

Tip 	

Surrounding colors, borders, fonts, and other formatting can affect the viewing patterns 
of your readers, de-emphasizing a previously high-prominence region.

Format numbers effectively
Undoubtedly, you will use lots of numbers in your dashboards. Some of them will be in charts, 
whereas others will be in tables. Remember that every piece of information on your dashboard 
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should have a purpose. It’s important that you format your numbers effectively so your users can 
understand the information they represent without confusion or hindrance. 

Here are some guidelines to keep in mind when formatting the numbers in your dashboards  
and reports.

➤	 Always use commas to make numbers easier to read. For example, instead of 2345,  
show 2,345.

➤	 Only use decimal places if that level of precision is required. For instance, there is rarely a 
benefit for showing the decimal places in a dollar amount such as $123.45. Likewise in per-
centages, use only the minimum number of decimals required to represent the data effec-
tively. For example instead of 43.21%, you may be able to get away with 43%.

➤	 Only use the dollar symbol when you need to clarify that you’re referring to monetary values. 
If you have a chart or table that contains all revenue values, and there is a label clearly stating 
this, you can save room and pixels by leaving out the dollar symbol.

➤	 Format very large numbers to thousands or millions place. For instance, instead of displaying 
16,906,714, you can format the number to read 17M.

In Chapter 2, you explore how to leverage number formatting tricks to enhance the readability of 
your dashboards and reports.

Use titles and labels effectively
It’s common sense, but people often fail to label items on dashboards effectively. If your customer 
looks at your dashboard and asks, “What is this telling me?” you likely have labeling issues. Here are a 
few guidelines for effective labeling in your dashboards and reports.

➤	 Always include a timestamp on your dashboard or report. This minimizes confusion when 
distributing the same dashboard or report in monthly or weekly installments.

➤	 Always include some text indicating when the data for the measures was retrieved. In many 
cases, timing of the data is a critical piece of information for analyzing a measure.

➤	 Use descriptive titles for each component. This allows users to clearly identify what they’re 
looking at. Be sure to avoid cryptic titles with lots of acronyms and symbols.

➤	 Although it may seem counterintuitive, it’s generally good practice to de-emphasize labels 
by formatting them to lighter hues than your data. Lightly colored labels give your users the 
information they need without distracting them from the information that’s displayed. Ideal 
colors to use for labels are colors that are commonly found in nature: soft grays, browns, 
blues, and greens.
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Key Questions to Ask Before  
Distributing Your Dashboard
Before you send out your finished dashboard, it’s worth your time to step back and measure it 
against some of the design principles we discuss in this chapter. Here are some key questions you 
can use as a checklist before distributing your dashboard.

Does my dashboard present the right information?
Look at the information you’re presenting and determine whether it meets the purpose of the dash-
board identified during requirements gathering. Don’t be timid about clarifying the purpose of the 
dashboard again with your core users. You want to avoid building the dashboard in a vacuum. Allow 
a few test users to see iterations as you develop it. This way, communication remains open, and you 
won’t go too far in the wrong direction.

Does everything on my dashboard have a purpose?
Take an honest look at how much information on your dashboard doesn’t support its main purpose. 
In order to keep your dashboard as valuable as possible, you don’t want to dilute it with nice- 
to-know data that’s interesting, but not actionable. Remember, if the data doesn’t support the  
core purpose of the dashboard, leave it out. Nothing says you have to fill every bit of white space  
on the page.

Does my dashboard prominently display the key message?
Every dashboard has one or more key messages. You want to ensure that these messages are promi-
nently displayed. To test whether the key messages in a dashboard are prominent, stand back and 
squint your eyes while you look at the dashboard. Look away and then look at the dashboard several 
times. What jumps out at you first? If it’s not the key components you want to display, then you’ll 
have to change something. Here are a few actions you can take to ensure that your key components 
have prominence.

➤	 Place the key components of your dashboard in the upper-left or middle-left of the page.  
As I noted earlier, studies show that these areas attract the most attention for longer periods 
of time.

➤	 De-emphasize borders, backgrounds, and other elements that define dashboard areas. Try to 
use the natural white space between your components to partition your dashboard. If bor-
ders are necessary, format them to lighter hues than your data.

➤	 Format labels and other text to lighter hues than your data. Lightly colored labels give your 
users the information they need without distracting them from the information displayed.
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Can I maintain this dashboard?
There’s a big difference between updating a dashboard and rebuilding a dashboard. Before you 
excitedly send out the sweet-looking dashboard you just built, take a moment to think about the 
maintenance of such a dashboard. You want to think about the frequency of updates and what pro-
cesses you need to go through each time you update the data. If it’s a one-time reporting event, then 
set that expectation with your users. If you know it will become a recurring report, you’ll want to 
really negotiate development time, refresh intervals, and phasing before agreeing to a time table.

Does my dashboard clearly display its scope and shelf life?
A dashboard should clearly specify its scope and shelf life. That is to say, anyone should be able to 
look at your dashboard and know the time period it’s relevant to and the scope of the information on 
the dashboard. This comes down to a few simple things you can do to effectively label your dash-
boards and reports.

➤	 Always include a timestamp on your dashboard. This minimizes confusion when distributing 
the same dashboard or report in monthly or weekly installments.

➤	 Always include some text indicating when the data for the measures was retrieved. In many 
cases, timing of the data is a critical piece of information when analyzing a measure.

➤	 Use descriptive titles for each component in your dashboard. Be sure to avoid cryptic titles 
with lots of acronyms and symbols.

Is my dashboard well documented?
It’s important to document your dashboard and the data model behind it. Anyone who has ever 
inherited an Excel worksheet knows how difficult it can be to translate the various analytical gyra-
tions that go into a report. If you’re lucky, the data model will be small enough to piece together in a 
week or so. If you’re not so lucky, you’ll have to ditch the entire model and start from scratch. By the 
way, the Excel data model doesn’t even have to be someone else’s. I actually went back to a model 
that I’d built six or so months earlier, only to find that I’d forgotten what I had done. Without docu-
mentation, it took me a few days to remember and decipher my own work. 

The documentation doesn’t even have to be highfalutin’ fancy stuff. A few simple things can help in 
documenting your dashboard. 

➤	 Add a Model Map tab to your data model. The Model Map tab is a separate sheet you can 
use to summarize the key ranges in the data model and how each range interacts with the 
reporting components in the final presentation layer.

➤	 Use comments and labels liberally. It’s amazing how a few explanatory comments and 
labels can help clarify your model even after you’ve been away from your data model for a 
long period of time.
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➤	 Use colors to identify the ranges in your data model. Using colors in your data model 
enables you to quickly look at a range of cells and get a basic indication of what that range 
does. Each color can represent a range type. For example, yellow could represent staging 
tables, gray could represent formulas, and purple could represent reference tables.

Cross-Ref	

In Chapter 2, we introduce you to data models and building a data model map.

Is my dashboard user-friendly?
Before you distribute your dashboard, you want to ensure that it’s user-friendly. It’s not difficult to 
guess what user-friendly means.

➤	 Intuitive: Your dashboard should be intuitive to someone who has never seen it. Test it out 
on someone and ask her if it makes sense. If you have to start explaining what the dashboard 
says, something is wrong. Does the dashboard need more labels, less-complicated charts, a 
better layout, more data, less data? It’s a good idea to get feedback from several users.

➤	 Easy to navigate: If your dashboard is dynamic, allowing for interactivity with macros or 
pivot tables, then you want to make sure that the navigation works well. Do users have to 
click several places to get to their data? Is the number of drill-downs appropriate? Does it 
take too long to switch from one view to another? Again, you’ll want to test your dashboard 
on several users. And be sure to test any interactive dashboard features on several comput-
ers other than yours.

➤	 Prints properly: Nothing is more annoying than printing a dashboard only to find that the 
person who created the dashboard didn’t take the time to ensure that it prints correctly. Be 
sure you set the print options on your Excel files so that your dashboards print properly.

Is my dashboard accurate?
Nothing kills a dashboard or report faster than the perception that the data in it is inaccurate. It’s not 
within my capabilities to tell you how to determine whether your data is accurate. I can, however, 
highlight three factors that establish the perception that a dashboard is accurate.

➤	 Consistency with authoritative sources: It’s obvious that if your data doesn’t match other 
reporting sources, you’ll have a data credibility issue — especially if those other sources  
are deemed to be the authoritative sources. Be sure you are aware of the data sources  
that are considered to be gospel in your organization. If your dashboard contains data  
associated with an authoritative source, compare your data with that source to ensure  
consistency.
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➤	 Internal consistency: It’s never fun to explain why one part of your dashboard doesn’t jibe 
with other parts of the same dashboard. You want to ensure some level of internal consis-
tency within your dashboard. Be sure comparable components in different areas of your 
dashboard are consistent with each other. If there is a reason for inconsistency, be sure to 
clearly notate those reasons. It’s amazing how well a simple notation clears up questions 
about the data.

➤	 Personal experience: Have you ever seen someone look at a report and say, “That doesn’t 
look right?” They are using what some people call “gut feel” to evaluate the soundness of the 
data. None of us looks at numbers in a vacuum. When we look at any analysis, we bring with 
us years of personal knowledge, interaction, and experience. We subconsciously use these 
experiences in our evaluation of information. When determining the accuracy of your dash-
board, take into consideration organizational anecdotal knowledge. If possible, show your 
dashboard to a few content experts in your company.
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2
Table Design  
Best Practices
In This Chapter

●	 Table design principles

●	 Custom number formatting

●	 Applying custom format colors

●	 Applying custom format conditions

The Excel table is the number one way information is consolidated and relayed. Look in any Excel 
report, and you’ll find a table of data. Yet the concept of making tables easier to read and more visu-
ally appealing escapes most of us.

Even on many highly graphical dashboards, you find key pieces of information (like the top ten sales 
reps) presented in a table format. But while the visual components of dashboards are treated with 
overwhelming care and attention, table design rarely goes beyond matching the color scheme of the 
other visual components of the dashboard.

Maybe the nicely structured rows and columns of a table lull people into believing that the data is 
presented in the best way possible. Maybe the options of adding color and borders make the table 
seem nicely packaged. In any case, you can use several design principles to make your Excel table a 
more effective platform for conveying data points.

In this chapter, you explore how easy it is to apply a handful of table-design best practices. The tips 
found here will ultimately help you create visually appealing tables that make the data within them 
easier to consume and comprehend.

On the Web	

All workbook examples in this book are available on the companion website for this 
book at www.wiley.com/go/exceldr.
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Table Design Principles
Table design is one of the most underestimated endeavors in Excel reporting. How a table is 
designed has a direct effect on how well an audience absorbs and interprets the data in that table. 
Unfortunately, the act of putting a table of data together for consumption is treated trivially by most.

Take, for example, the table illustrated in Figure 2-1. This table is similar to many found in Excel 
reports. The thick borders, the different colors, and the poorly formatted numbers are all unfortunate 
trademarks of most tables that come from the average Excel analyst.

Figure 2-1: A poorly designed table.

Throughout this chapter, you’ll improve upon this table, applying these four basic design principles.

➤	 Use colors sparingly, reserving them only for information about key data points.

➤	 De-emphasize borders by using the natural white space between your components to parti-
tion your dashboard.

➤	 Use effective number formatting to avoid inundating your table with too much ink.

➤	 Subdue your labels and headers.

Use colors sparingly
Color is most often used to separate the various sections of a table. The basic idea is that the colors 
applied to a table suggest the relationships among the rows and columns. The problem is that colors 
often distract and draw attention away from the important data. In addition, printed tables with 
dark-colored cells are notoriously difficult to read (especially when printed on black and white print-
ers). They’re also hard on the toner budget, if that holds any importance to you.

In general, you should use colors sparingly; reserve them for providing information about key data 
points. The headers, labels, and natural structure of your table are more than enough to guide your 
audience. There’s no real need to add a layer of color to demark rows and columns.
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Figure 2-2 shows a table with the colors removed. As you can see, it’s already easier to read.

Figure 2-2: Remove unnecessary cell coloring.

To remove color from cells in a table, first highlight the cells, and then go to the Ribbon and select 
Home➜Theme Colors. From the Theme Colors drop-down menu, select No Fill (see Figure 2-3).

Figure 2-3: Use the No Fill option to clear cell colors.

De-emphasize borders
Believe it or not, borders get in the way of quickly reading the data in a table. This is counterintuitive 
to the thought that borders help separate data into nicely partitioned sections. The reality is that the 
borders of a table are the first thing your eyes see when looking at a table. Don’t believe it? Try stand-
ing back a bit from an Excel table and squint. The borders will pop out at you.

De-emphasize borders and gridlines wherever you can:

➤	 Try to use the natural white space between the columns to partition sections.

➤	 If borders are necessary, format them to lighter hues than your data.

➤	 Light grays are typically ideal for borders. The idea is to indicate sections without distracting 
from the information displayed.
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Figure 2-4 demonstrates these concepts. Notice how the numbers are no longer caged in gridlines. 
Also, headings now jump out at you with the addition of Single Accounting underlines.

Figure 2-4: Minimize the use of borders and use the Single Accounting underlines to accent the column  
headers.

Tip 	

Single Accounting underlines are different from the standard underlines you typically 
apply by pressing Ctrl+U on the keyboard. Standard underlining draws a line only as far 
as the text goes. That is to say, if you underline the word YES, you get a line under the 
three letters. Single Accounting, on the other hand, draws a line across the entire col-
umn, regardless of how big or small the word is. This makes for a minimal but apparent 
visual demarcation that calls out your column headers nicely.

To format your borders, follow these steps:

	 1.	 Highlight the cells you’re working with, right-click, and select Format Cells.

		  The Format Cells dialog box appears.

	 2.	 Click the Border tab, shown in Figure 2-5.

	 3.	 Select an appropriate line thickness.

		  You typically want to select the line with the lightest weight.

	 4.	 Select an appropriate color.

		  Again, lighter hues are the best option.

	 5.	 Use the border buttons to control where your borders are placed.

www.it-ebooks.info

http://www.it-ebooks.info/


Chapter 2: Table Design Best Practices 33

1

2

3

Figure 2-5: Use the Border tab of the Format Cells dialog box to customize your borders.

To apply the Single Accounting underline, follow these steps:

	 1.	 Right-click your column headings and select Format Cells.

		  The Format Cells dialog box appears.

	 2.	 Click the Font tab.

	 3.	 Choose the Single Accounting underline, as shown in Figure 2-6.

Figure 2-6: Single Accounting underlines effectively call out your column headers.
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Use effective number formatting
Every piece of information in your table should have a reason for being there. To clarify, tables often 
inundate the audience with superfluous ink that doesn’t add value to the information. For example, 
you’ll often see tables that show a number like $145.57 when a simple 145 would be relay the data 
just fine. Why include the extra decimal places that serve only to add to the mass of numbers that 
your audience will need to plow through?

Here are some guidelines to keep in mind when applying formats to the numbers in your table.

➤	 Only use decimal places if that level of precision is required.

➤	 In percentages, use only the minimum number of decimals required to represent the data 
effectively.

➤	 Instead of using currency symbols (like $ or £), let your labels clarify that you’re referring to 
monetary values.

➤	 Format very large numbers to thousands or millions place.

➤	 Right-align numbers so that they’re easier to read and compare.

Figure 2-7 shows the table with appropriate number formatting applied. Note the following:

➤	 The large revenue and margin dollar amounts are converted to thousands place.

➤	 The labels above the numbers now clearly indicate that the numbers are represented in 
thousands place.

➤	 The percentages are truncated to show no decimal places.

➤	 The key metric, the Margin % column, is emphasized by color coding.

Figure 2-7: Use number formatting to eliminate clutter in your table and draw attention to key metrics.

Amazingly, all of these improvements were made with simple number formatting. That’s right; no 
formulas were used to convert large numbers to thousands place, no conditional formatting was 
used to color code the Margin % field, no other peripheral tricks of any kind were used.
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Later in this chapter, in the section “Enhancing Reporting with Custom Number Formatting,” you 
explore how to leverage the number-formatting feature to accomplish these improvements.

Subdue your labels and headers
No one will argue that the labels and headers of a table aren’t important. On the contrary, they pro-
vide your audience with the guidance and structure needed to make sense of the data in a table. 
However, labels and headers sometimes are overemphasized to the point that they overshadow the 
data. How many times have you seen bold or oversized font applied to headers? The reality is that 
your audience will benefit more with the use of subdued labels.

De-emphasizing labels by using lighter hues will actually make a table easier to read and will draw 
more attention to the data in the table. Lightly colored labels give users the information they need 
without distracting them from the information being presented.

Tip 	

Ideal colors for labels are soft grays, light browns, soft blues, and greens.

Font size and alignment also factor into the effective display of tables. Aligning column headers to 
the same alignment as the numbers beneath them helps reinforce the column structures in your 
table. Keeping the font size of your labels close to that of the data within the table will help keep eyes 
focused on the data — not the labels.

Figure 2-8 illustrates how the table looks with subdued headers and labels. Note how the data now 
becomes the focus of attention, whereas the muted labels work in the background.

Figure 2-8: Send your labels and headers to the background by subduing their colors and keeping their font 
sizes in line with the data.

Tip 	

Sorting is another key factor in the readability of data. Many tables sort based on labels 
(alphabetical by route, for example). Sorting the table based on a key data point within 
the data establishes a pattern that your audience can use to quickly analyze the top and 
bottom values. In Figure 2-8, note that the data is sorted by the Revenue dollars. This again 
adds a layer of analysis and provides a quick look at the top and bottom generating routes.

Figure 2-9 shows the table before and after all the improvements are made. It’s easy to see how a few 
design principles can greatly enhance your ability to present table-driven data.
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Figure 2-9: Before and after applying table design principles.

Tip 	

Although it may seem like a mere matter of taste, font type has a subtle but tangible 
impact on your tables. Outdated or inappropriate fonts will cause your audience to 
focus on the fonts rather than the data in your table. Using fonts like Comic Sans may 
seem cute, but they’re rarely appropriate for a report. Older fonts like Times New Roman 
or Arial can make your reports look old. It may seem strange, but fonts with straight 
edges and fancy strokes now look old compared to the rounded edges of the more pop-
ular fonts being used. This change in font perception is primarily driven by popular 
online sites, which often use fonts with rounded edges. If possible, consider using  
modern-looking fonts like Calibri and Segoe UI in your reports and dashboard.

Enhancing Reporting with Custom  
Number Formatting
You can apply number formatting to cells several ways. Most people utilize the convenient Number 
commands found on the Home tab. Using these commands, you can quickly apply some default for-
matting (such as number, percent, and currency) and just be done with it. But a better way is to uti-
lize the Format Cells dialog box, where you can create your own custom number formatting.
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Number formatting basics
To apply a custom number format, follow these steps:

	 1.	 Right-click on a range of cells and select Format Cells.

		  The Format Cells dialog box opens.

	 2.	 Go to the Number tab and apply some basic formatting.

		  To start, choose a format that makes the most sense for your purposes. In Figure 2-10, the 
Number format is chosen, with comma separator, no decimal places, and negative numbers 
wrapped in parentheses.

Figure 2-10: Choose a basic format.

	 3.	 Click the Custom option, as shown in Figure 2-11.

		  Excel takes you to a screen that shows the syntax that makes up the format you selected. The 
syntax is shown in the Type input box. Here you can edit the syntax to customize the number 
format.

Figure 2-11: The Type input box allows you to customize the syntax for the number format.

		  In this case, you see

#,##0_);(#,##0)
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		  The number formatting syntax tells Excel how a number will look in various scenarios. 
Number formatting syntax consists of different individual number formats separated by 
semicolons. In this example, you see two different formats:

●	 The format to the left of the semicolon. By default, any formatting to the left of the first 
semicolon is applied to positive numbers.

●	 The format to the right of the semicolon. Any formatting to the right of the first semico-
lon is applied to negative numbers.

		  So in this scenario, negative numbers are formatted with parentheses, whereas positive 
numbers are formatted as a simple number.

(1,890)
 1,982

Note 	

Notice that the syntax for the positive formatting in the previous example ends with _). 
This tells Excel to leave a space the width of a parenthesis character at the end of posi-
tive numbers. This syntax ensures that positive and negative numbers align nicely when 
negative numbers are wrapped within parentheses.

You can edit the syntax in the Type input box so that the numbers are formatted differently. For 
example, try changing the syntax to:

+#,##0;-#,##0

When applied, positive numbers will start with the + symbol, and negative numbers will start with a – 
symbol, like so:

+1,200
-15,000

This comes in quite handy when formatting percentages. For instance, you can apply a custom per-
cent format by entering the following syntax into the Type input box:

+0%;-0%

This syntax gives you percentages that look like this:

+43%
-54%
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You can get fancy and wrap your negative percentages with parentheses with this syntax:

0%_);(0%)

This syntax gives you percentages that look like this:

 43%
(54%)

Note 	

If you include only one format syntax, meaning you don’t add a second formatting 
option with the use of a semicolon separator, that one format will be applied to all  
numbers—negative or positive.

Formatting numbers in thousands and millions
Earlier in this chapter, you formatted your revenue numbers to show in thousands. This allowed you 
to present cleaner numbers and avoid inundating your audience with too much ink. To show your 
numbers in thousands, follow these steps:

	 1.	 Highlight the cells containing your numbers, right-click, and select Format Cells.

		  The Format Cells dialog box appears.

	 2.	 Click the Custom option.

		  The screen shown in Figure 2-12 appears.

Figure 2-12: Go to the Custom screen of the Format Cells dialog box.
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	 3.	 In the Type input box, add a comma after the format syntax.

		  This syntax cosmetically changes your number to thousands place:

#,##0,

		  After confirming your changes, your numbers will automatically show in thousands place.

Here’s the beauty of this technique: It doesn’t change or truncate your numbers in any way. Excel is 
simply applying a cosmetic effect to the number. To see what this means, take a look at Figure 2-13.

The selected cell is formatted to show in thousands: You see 118. But when you look in the formula 
bar, you see the real unformatted number (117943). The 118 you see in the cell is a cosmetically for-
matted version of the real number shown in the formula bar.

Figure 2-13: Formatting numbers applies only a cosmetic look. Look in the formula bar to see the real unformat-
ted number.

Note 	

Custom number formatting has obvious advantages over using other techniques to for-
mat numbers to thousands. For instance, many beginning analysts convert numbers to 
thousands by dividing them by 1,000 in a formula. But that changes the integrity of the 
number dramatically, and it forces you to keep track of and maintain formulas that 
could cause calculation errors later. Using custom number formatting avoids that by 
changing only how the number looks, keeping the actual number intact.

If needed, you can even indicate that the number is in thousands by adding a “k” to the number syntax.

#,##0,”k”

This syntax shows your numbers like this:

118k
318k

You can use this technique on both positive and negative numbers.

#,##0,”k”; (#,##0,”k”)
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After you apply this syntax, your negative numbers will also show in thousands.

118k
(318k)

Need to show numbers in millions? Easy. Simply edit the Type input box to add two commas to your 
number format syntax.

#,##0.00,, “m”

Note the extra decimal places (.00). When converting numbers to millions, it’s often useful to show 
additional precision points, as in:

24.65 m

Hiding and suppressing zeros
In addition to positive and negative numbers, Excel allows you to provide a format for zeros. You do 
so by adding another semicolon to your custom number syntax. By default, any format syntax placed 
after the second semicolon is applied to any number that evaluates to zero.

For example, the following syntax applies a format that shows “n/a” for cells that contain zeros.

#,##0_);(#,##0);”n/a”

You can also use this syntax to suppress zeros entirely. If you add the second semicolon but don’t fol-
low it with any syntax, cells containing zeros will show blank.

#,##0_);(#,##0);

Again, custom number formatting affects only the cosmetics of the cell. The actual data in the cell is 
not affected, as demonstrated in Figure 2-14. The selected cell is formatted so that zeros show as n/a, 
but if you look at the formula bar, you can see the actual unformatted cell contents.

Figure 2-14: Custom number formatting that shows zeros as n/a.
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Applying custom format colors
Have you ever set the formatting on a cell so that negative numbers show up red? If so, you essen-
tially applied a custom format color. In addition to controlling the look of your numbers with custom 
number formatting, you can control their color.

In this example, you format the percentages so that positive percentages show blue with a + symbol, 
whereas negative percentages show red with a – symbol. Again, you enter this syntax in the Type 
input box shown earlier in Figure 2-12.

[Blue]+0%;[Red]-0%

To apply a color, just enter the color name wrapped in square brackets [ ].

Now, there are only certain colors you can call out by name. You can call out the eight VB colors by 
name. These colors make up the first eight colors of the default Excel color palette.

[Black]

[Blue]

[Cyan]

[Green]

[Magenta]

[Red]

[White]

[Yellow]

Caution	

Blue and Red are the only colors from the 8 VB colors that are viable in a report or dash-
board. The rest of the colors listed are virtually unusable, as they are very unattractive.

Fortunately, the Excel palette comes with 56 colors that you can call up using a color code. Every 
color has a code: The color code for black is 1, the color code for white is 2, and so on.

You can use color codes in your custom number syntax by replacing the named color with the word 
COLOR followed by the code.

For example, this syntax formats the percentages so that positive percentages show green with a + 
symbol, whereas negative percentages show red with a – symbol.

[COLOR10]+0%;[COLOR3]-0%
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So how do you know which color code to use? Well, in the Chapter 2 sample file, you will find a tab 
called Get Color Codes (see Figure 2-15). The button found on that tab runs a small bit of VBA that 
extracts the color and color code for you. Simply find the color you deem most appropriate and use 
the associated code.

Figure 2-15: Use the Get Color Codes tab in the Chapter 2 Sample file to extract the Excel palette colors and 
their associated codes.

You may be wondering how using custom number coloring is different from Excel’s built-in conditional-
formatting feature. In many ways, they’re the same. However, you do get a couple of benefits from 
using custom number coloring rather than conditional formatting.

➤	 You don’t have to manage separate conditional formatting rules. All the formatting needed 
is built into the cell. 

➤	 Every object that uses your custom formatted cell adopts the format automatically. This 
means your custom formatting can be applied where conditional formatting can’t. For exam-
ple, the chart in Figure 2-16 plots cells that have custom number formatting. Notice how the 
y axis of the chart faithfully displays the custom number formatting. You couldn’t do this 
with conditional formatting.

Figure 2-16: Custom number formatting is automatically adopted in charts.
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Formatting dates and times
Custom number formatting isn’t just for numbers. You can also format dates and times. As you can 
see in Figure 2-17, you use the same dialog box to apply date and time formats using the Type input.

Figure 2-17: You can also format dates and times using the Format Cells dialog box.

Figure 2-17 demonstrates that date and time formatting involves little more than stringing date- 
specific or time-specific syntax together. The syntax used is fairly intuitive. For example, DDD is the 
syntax for the three-letter day, mmm is the syntax for the three-letter Month, and yyyy is the syntax 
for the four-digit year.

There are several variations on the format for days, months, years, hours, and minutes. Take some 
time and experiment with different combinations of syntax strings.

Table 2-1 lists some common date and time format codes you can use as starter syntax for your 
reports and dashboards.

Table 2-1: Common Date and Time Format Codes
Format Code 1/31/2013 7:42:53 PM Displays As

m 1

mm 01

mmm Jan

mmmmm January

mmmmm J

dd 31

ddd Thu

dddd Thursday

yy 13

yyyy 2013

mmm-yy Jan-13

dd/mm/yyyy 31/01/2013

dddd mmm yyyy Thursday Jan 2013
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Format Code 1/31/2013 7:42:53 PM Displays As

mm-dd-yyyy h:mm AM/PM 01-31-2013 7:42 PM

h AM/PM 7 PM

h:mm AM/PM 7:42 PM

h:mm:ss AM/PM 7:42:53 PM

Adding conditions to customer number formatting
At this point, you know that Excel’s number formatting syntax consists of different individual number 
formats separated by semicolons. By default, the syntax to the left of the first semicolon is applied to 
positive numbers, the syntax to the right of the first semicolon is applied to negative numbers, and 
the syntax to the right of the second semicolon is applied to zeros.

Positive Number Format; Negative Number Format; Format for Zeros

Interestingly, Excel allows you override this default behavior and repurpose the syntax sections using 
your own conditions. Conditions are entered in square brackets.

In this syntax example, you apply a blue color to cells containing a number over 500, a red color to 
cells containing a number less than 500, and n/a to cells containing a number equal to 500.

[Blue][>500]#,##0;[Red][<500]#,##0;”n/a”

One of the more useful ways to use conditions is to convert numbers to thousands or millions, 
depending on how big the number is. In this example, numbers equal to or greater than 1,000,000 
are formatted as millions, whereas numbers equal to or greater than 1,000 are formatted as  
thousands.

[>=1000000]#,##0.00,,”m”;[>=1000]#,##0,”k”

Again, the conditions you use must be relatively basic. Even so, conditions give you another avenue 
to gaining control over the display of the numbers in your dashboards and reports.
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3
Using Excel  
Sparklines
In This Chapter

●	 Understanding the Excel 2013 Sparkline feature

●	 Adding sparklines to a worksheet

●	 Working with groups of sparklines

●	 Modifying your sparkline graphics

Sparklines were developed by visualization guru Edward Tufte. Tufte envisioned mini word-sized 
charts placed in and among the data that they represent. Sparklines enable you to see trends and 
patterns within your data at a glance using minimal space. Following the sparkline concept, 
Microsoft then implemented sparklines in Excel worksheets so that you can get visual context for 
data that doesn’t take up a lot of real estate on your dashboard.

This chapter introduces you to sparklines and demonstrates how you can use them to add visualiza-
tions to your dashboards and reports.

Note 	

Sparklines are available only with Excel 2010 and Excel 2013. If you create a workbook 
that uses sparklines, and that workbook is opened using a previous version of Excel, the 
sparkline cells will be empty. If your organization is not fully using Excel 2010 or 2013, 
you may want to search for alternatives to the built-in Excel sparklines. There are many 
third-party add-ons that bring sparkline features to earlier versions of Excel. Some of 
these products support additional sparkline types, and most have many additional cus-
tomization options. Search the web for sparklines excel, and you’ll find several add-ons 
to choose from.
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Understanding Sparklines
It’s important to understand just how sparklines can enhance your reporting. As I mention in  
Chapter 2, much of the reporting done in Excel is table-based, where precise numbers are more 
important than pretty charts. However, in table-based reporting, you often lose the ability to show 
important aspects of the data such as trends. The number of columns needed to show adequate 
trend data in a table makes it impractical to do so, and often will do nothing more than render your 
report unreadable. Sparklines allow you to add extra analysis, such as trends, in a concise visualiza-
tion within your table without inundating your customers with superfluous numbers.

Take the example in Figure 3-1. The data represents a compact KPI summary designed to be an  
at-a-glance view of key metrics. Although there is some effort given to comparing various time  
periods (in columns D, E, and F), the ability to see a full-year trend would be helpful.

Figure 3-1: Although this KPI Summary is useful, it lacks the ability to show a full-year trend.

Figure 3-2 illustrates the same KPI Summary with Excel sparklines added to visually show the 
12-month trend. With the sparklines added, you can see the broader story behind each metric. For 
example, if you were to look at the Passengers metric based solely on the numbers, it would look like 
it is merely slightly up from the average. But look at the sparkline, and you see a story of a heroic 
comeback from a huge hit at the beginning of the year.

It’s not about adding flash and pizzazz to your tables. It’s about building the most effective message 
you can in the limited you space you have. Sparklines are another tool you can use to add another 
dimension to your table-based reports.
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Figure 3-2: Sparklines allow you to add trending in a compact space, enabling you to see a broader picture for 
each metric.

Applying Sparklines
Although sparklines look like miniature charts (and can sometimes take the place of a chart), this fea-
ture is completely separate from the Excel chart feature (covered in Part II of this book). For example, 
charts are placed on a worksheet’s drawing layer, and a single chart can display several series of data. 
In contrast, a sparkline is displayed inside a worksheet cell and displays only one series of data.

Excel 2013 supports three types of sparklines: Line, Column, and Win/Loss. Figure 3-3 shows exam-
ples of each type of sparkline graphics, displayed in column H. Each sparkline depicts the six data 
points to the left.

➤	 Line: Similar to a line chart, the line can display with a marker for each data point. The first 
group in Figure 3-3 shows Line sparklines with markers. A quick glance reveals that with the 
exception of Fund Number W-91, the funds have been losing value over the six-month 
period.

➤	 Column: Similar to a column chart, the second group shows the same data with Column 
sparklines.

➤	 Win/Loss: A binary type chart that displays each data point as a high block or a low block. 
The third group shows Win/Loss sparklines. Notice that the data is different. Each cell dis-
plays the change from the previous month. In the sparkline, each data point is depicted as a 
high block (win) or a low block (loss). In this example, a positive change from the previous 
month is a win, and a negative change from the previous month is a loss.
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Figure 3-3: Three types of sparklines.

Creating Sparklines
Figure 3-4 shows some weather data that you can summarize with sparklines. To create sparkline 
graphics for the values in these nine rows, follow these steps:

	 1.	 Select the data range that you want to summarize. In this example, select B4:M12.

		  If you’re creating multiple sparklines, select all the data.

Figure 3-4: Data that you want to summarize with sparkline graphics.

	 2.	 With the data selected, click the Insert tab on the Ribbon and find the Sparklines group. 
There you can select any one of the three sparkline types: Line, Column, or Win/Loss. In this 
case, select the Column option.

		  Excel displays the Create Sparklines dialog box, as shown in Figure 3-5.
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Figure 3-5: Use the Create Sparklines dialog box to specify the data range and the location for the 
sparkline graphics.

	 3.	 Specify the data range and the location for the sparklines. For this example, specify N4:N12 
as the Location Range.

		  Typically, you put the sparklines next to the data, but that’s not required. Most of the time, 
you’ll use an empty range to hold the sparklines. However, Excel doesn’t prevent you from 
inserting sparklines into nonempty cells. The sparkline location that you specify must match 
the source data in terms of number of rows or number of columns.

	 4.	 Click OK.

		  Excel creates the sparklines graphics of the type you specified (see Figure 3-6).

Figure 3-6: Column sparklines summarize the precipitation data for nine cities.

The sparklines are linked to the data, so if you change any of the values in the data range, the  
sparkline graphic updates.

Tip 	

Generally, you’ll create sparklines on the same sheet that contains the data. If you want 
to create sparklines on a different sheet, start by activating the sheet where the spark
lines will be displayed. Then, in the Create Sparklines dialog box, specify the source data 
either by pointing or by typing the complete sheet reference (for example, type 
Sheet1A1:C12). The Create Sparklines dialog box lets you specify a different sheet for 
the Data Range, but not for the Location Range.
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Customizing Sparklines
When you activate a cell that contains a sparkline, Excel displays an outline around all the sparklines 
in its group. You can then use the commands on the Design tab (select Sparkline Tools➜Design tab) 
to customize the group of sparklines.

Sizing and merging sparkline cells
When you change the width or height of a cell that contains a sparkline, the sparkline adjusts to fill 
the new cell size. In addition, you can put a sparkline into merged cells. To merge cells, select at least 
two cells and choose Home➜Alignment➜Merge & Center.

Figure 3-7 shows the same sparkline, displayed at four sizes resulting from column width, row height, 
and merged cells.

Understanding Sparkline Groups
Most of the time, you’ll probably create a group of sparklines — one for each row or column of data. 
A worksheet can hold any number of sparkline groups. Excel remembers each group, and you can 
work with the group as a single unit. For example, you can select one sparkline in a group and then 
modify the formatting of all sparklines in the group. When you select one sparkline cell, Excel dis-
plays an outline of all the other sparklines in the group.

You can, however, perform some operations on an individual sparkline in a group:

●	 Change the sparkline’s data source. Click the sparkline cell and go to the Sparkline Tools tab 
on the Ribbon. There you can choose Design➜Sparkline➜Edit Data➜Edit Single Sparkline’s 
Data. Excel displays a dialog box that lets you change the data source for the selected  
sparkline.

●	 Delete the sparkline. Click the sparkline, click the Sparkline Tools tab on the Ribbon, and then 
select Design➜Group➜Clear➜Clear Selected Sparklines.

Both operations are available from the shortcut menu that appears when you right-click a  
sparkline cell.

You can also ungroup a set of sparklines. Select any sparkline in the group and then, from the 
Sparkline Tools tab, select Design➜Group➜Ungroup. After you ungroup a set of sparklines, you  
can work with each sparkline individually.

Ungrouping sparklines gives you the ability to move, size, and format them separately on your  
dashboard.
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Figure 3-7: A sparkline at various sizes.

Note 	

Generally, the most appropriate aspect ratio for a chart is 2:1, where the chart is about 
twice as wide as it is tall. Other aspect ratios can distort your visualizations, exaggerat-
ing the trend in sparklines that are too tall, and flattening the trend in sparklines that 
are too wide.

Note 	

If you merge cells, and the merged cells occupy more than one row or one column, Excel 
won’t let you insert a group of sparklines into those merged cells. Rather, you need to 
insert the sparklines into a normal range (with no merged cells) and then merge the cells.

You can also put a sparkline in nonempty cells, including merged cells. Figure 3-8 shows two spark
lines merged with cells containing some text. This gives the appearance of two single cells with both 
text and graphics.

Figure 3-8: Sparklines in merged cells (E2:I7 and E9:I14).

Handling hidden or missing data
In some cases, you just want to present the sparkline visualization, without the numbers. One way to 
do so is to hide the rows or columns that contain the data. Figure 3-9 shows a table with the values 
displayed, and the same table with the values hidden (by hiding the columns).
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By default, if you hide rows or columns that contain data used in a sparkline graphic, the hidden data 
doesn’t appear in the sparkline. In addition, blank cells are displayed as a gap in the graphic.

To change these default settings, go to the Sparkline Tools tab on the Ribbon and select Design➜ 

Sparkline➜Edit Data➜Hidden & Empty Cells. In the Hidden and Empty Cell Settings dialog box, spec-
ify how to handle hidden data and empty cells.

Figure 3-9: Sparklines can use data in hidden rows or columns.

Changing the sparkline type
As mentioned earlier in this chapter, Excel supports three sparkline types: Line, Column, and Win/
Loss. After you create a sparkline or group of sparklines, you can easily change the type by clicking 
the sparkline and selecting one of the three icons located under Sparkline Tools➜Design➜Type. If 
the selected sparkline is part of a group, all sparklines in the group are changed to the new type.

Tip 	

If you’ve customized the appearance, when you switch among different sparkline types, 
Excel remembers your customization settings for each sparkline type.

Changing sparkline colors and line width
After you create a sparkline, changing the color is easy. Simply click the sparkline, go up to the 
Sparkline Tools tab in the Ribbon, and select Design➜Style. There you will find various options to 
change the color and style of your sparkline.

For Line sparklines, you can also specify the line width. Choose Sparkline Tools➜Design➜Style➜ 

Sparkline Color➜Weight.
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Colors used in sparkline graphics are tied to the document theme. If you change the 
theme (by choosing Page Layout➜Themes➜Themes), the sparkline colors then change 
to the new theme colors. Be aware that any manual changes you make to color are lost if 
you change the theme.

Using color to emphasize key data points
Use the commands under Sparkline Tools➜Design➜Show to customize the sparklines to emphasize 
key aspects of the data. The options in the Show group are as follows:

➤	 High Point: Apply a different color to the highest data point in the sparkline.

➤	 Low Point: Apply a different color to the lowest data point in the sparkline.

➤	 Negative Points: Apply a different color to negative values in the sparkline.

➤	 First Point: Apply a different color to the first data point in the sparkline.

➤	 Last Point: Apply a different color to the last data point in the sparkline.

➤	 Markers: Show data markers in the sparkline. This option is available only for Line sparklines.

You can control the color of the sparkline by using the Marker Color control in the Sparkline 
Tools➜Design➜Style group. Unfortunately, you cannot change the size of the markers in Line  
sparklines.

Figure 3-10 shows some Line sparklines with various types of colors added.

Figure 3-10: Using color to emphasize key data points for Line sparklines.

Adjusting sparkline axis scaling
When you create one or more sparklines, they all use (by default) automatic axis scaling. In other 
words, Excel determines the minimum and maximum vertical axis values for each sparkline in the 
group, based on the numeric range of the sparkline data.

Note
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The Sparkline Tools➜Design➜Group➜Axis command lets you override this automatic behavior and 
control the minimum and maximum value for each sparkline, or for a group of sparklines. For even 
more control, you can use the Custom Value option and specify the minimum and maximum for the 
sparkline group.

Axis scaling can make a huge difference in the sparklines. Figure 3-11 shows two groups of spark
lines. The group at the top uses the default axis settings (Automatic for Each Sparkline). Each spark
line in this group shows the six-month trend for the product, but there is no indication of the 
magnitude of the values.

The sparkline group at the bottom (which uses the same data), uses the Same for All Sparklines set-
ting for the minimum and maximum axis values. With these settings in effect, the magnitude of the 
values across the products is apparent — but the trend across the months within a product is not 
apparent.

The axis scaling option you choose depends on what aspect of the data you want to emphasize.

Figure 3-11: The bottom group of sparklines shows the effect of using the same axis minimum and maximum 
values for all sparklines in a group.

Faking a reference line
One useful feature that’s missing in the Excel 2013 implementation of sparklines is a reference line. 
For example, it might be useful to show performance relative to a goal. If the goal is displayed as a 
reference line in a sparkline, the viewer can quickly see whether the performance for a period 
exceeded the goal.

One approach is to write formulas that transform the data and then use a sparkline axis as a fake ref-
erence line. Figure 3-12 shows an example. Students have a monthly reading goal of 500 pages. The 
range of data shows the actual pages read, with sparklines in column H. The sparklines show the six-
month page data, but it’s impossible to tell who exceeded the goal and when they did it.
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Figure 3-12: Sparklines display the number of pages read per month.

The lower set of sparklines in Figure 3-13 shows another approach: Transforming the data so that 
meeting the goal is expressed as a 1 and failing to meet the goal is expressed as a –1. The following 
formula (in cell B18) transforms the original data:

=IF(B6>$C$2,1,-1)

This formula was copied to the other cells in the B18:G25 range.

Using the transformed data, Win/Loss sparklines are used to visualize the results. This approach is 
better than the original, but it doesn’t convey any magnitude differences. For example, you cannot 
tell whether the student missed the goal by 1 page or by 500 pages.

Figure 3-13: Using Win/Loss sparklines to display goal status.
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Figure 3-14 shows a better approach. Here the original data is transformed by subtracting the goal 
from the pages read. The formula in cell B31 is

=B6-C$2

This formula was copied to the other cells in the B31:G38 range, and a group of Line sparklines dis-
play the resulting values. This group has the Show Axis setting enabled and also uses Negative Point 
markers so the negative values (failure to meet the goal) clearly stand out.

Figure 3-14: The axis in the sparklines represents the goal.

Specifying a date axis
By default, data displayed in a sparkline is assumed to be at equal intervals. For example, a sparkline 
may display a daily account balance, sales by month, or profits by year. But what if the data isn’t at 
equal intervals?

Figure 3-15 shows data, by date, along with a sparklines graphic created from column B. Notice that 
some dates are missing, but the sparkline shows the columns as though the values were spaced at 
equal intervals.

Figure 3-15: The sparkline displays the values as though they’re at equal time intervals.
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To better depict this type of time-based data, the solution is to specify a date axis. Select the spark
line and choose Sparkline Tools➜Design➜Group➜Axis➜Date Axis Type.

Excel displays a dialog box, asking for the range that contains the corresponding dates. In this exam-
ple, specify range A2:A11.

Click OK, and the sparkline displays gaps for the missing dates (see Figure 3-16).

Figure 3-16: After specifying a date axis, the sparkline shows the values accurately.

Auto-updating sparkline ranges
If a sparkline uses data in a normal range of cells, adding new data to the beginning or end of the 
range does not force the sparkline to use the new data. You need to use the Edit Sparklines dialog 
box to update the data range (choose Sparkline Tools➜Design➜Sparkline➜Edit Data).

But if the sparkline data is in a column within a Table object (created using Insert➜Tables➜Table as 
described in Chapter 11), the sparkline uses new data that’s added to the end of the table.

Figure 3-17 shows an example. The sparkline was created using the data in the Rate column of the table. 
When you add the new rate for September, the sparkline will automatically update its Data Range.

Figure 3-17: Creating a sparkline from data in a table.
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4
Chartless  
Visualization  
Techniques
In This Chapter

●	 Using conditional formatting

●	 Leveraging symbols in formulas

●	 Using the Camera tool

Chartless visualization is less a feature specific to Excel than it is a concept that you can apply to your 
dashboard presentation. With these types of visualization, you can easily add layers of visualization 
to your dashboard and take advantage of some common worksheet features that can turn your data 
into meaningful views.

Enhancing Reports with  
Conditional Formatting
Conditional formatting applies to the Excel functionality used that dynamically changes the format-
ting of a value, cell, or range of cells based on a set of conditions you define. Conditional formatting 
allows you to look at your Excel reports and make split-second determinations on which values are 
“good” and which are “bad,” all based on formatting.

In this section, you discover the world of conditional formatting and find out how to leverage this 
functionality to enhance your reports and dashboards.
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Applying basic conditional formatting
Thanks to the many predefined options offered with Excel 2013, you can apply some basic condi-
tional formatting with a few clicks of the mouse. To get a first taste of what you can do, go the 
Ribbon, click the Home tab, and choose the Conditional Formatting icon (see Figure 4-1).

Figure 4-1: Click the Conditional Formatting icon to reveal the predefined options available in Excel 2013.

As you can see, five categories of predefined options are available:

Highlight Cells Rules

Top/Bottom Rules

Data Bars

Color Scales

Icon Sets

Take a moment now to review what each category enables you to do.

Using Highlight Cells Rules
The formatting options in the Highlight Cells Rules category, shown in Figure 4-2, allow you to high-
light those cells whose values meet a specific condition.

Note 	

These options work very much like an If…Then…Else… statement. That is, if the condi-
tion is met, the cell is formatted; if the condition isn’t met, the cell isn’t touched.
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Figure 4-2: The Highlight Cells Rules options apply formats if specific conditions are met.

The options in the Highlight Cells Rules category are pretty self-explanatory:

➤	 Greater Than: Allows you to conditionally format a cell whose value is greater than a speci-
fied amount.

	 For instance, you can tell Excel to format those cells that contain a value greater than 50.

➤	 Less Than: Allows you to conditionally format a cell whose value is less than a specified 
amount.

	 For instance, you can tell Excel to format those cells that contain a value less than 100.

➤	 Between: Allows you to conditionally format a cell whose value is between two given 
amounts.

	 For example, you can tell Excel to format those cells that contain a value between 50  
and 100.

➤	 Text That Contains: Allows you to conditionally format a cell whose contents contain any 
form of a given text you specify as a criterion.

	 For example, you can tell Excel to format the cells that contain the text North.

➤	 A Date Occurring: Allows you to conditionally format a cell whose contents contain a date 
occurring in a specified period relative to today’s date.

	 For example, Yesterday, Last Week, Last Month, Next Month, Next Week, and so on.

➤	 Duplicate Values: Allows you to conditionally format both duplicate values and unique val-
ues in a given range of cells.
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This rule was designed more for data cleanup than for dashboarding, enabling you to 
quickly identify duplicates and unique values in your dataset.

Here’s a simple example of how to apply one of these options. To highlight all values greater than a 
certain amount, follow these steps:

	 1.	 Select the range of cells to which you need to apply the conditional formatting.

	 2.	 In the Highlight Cells Rules category, choose the Greater Than option (see Figure 4-2).

		  The Greater Than dialog box opens, as shown in Figure 4-3. The idea here is to define a value 
that will trigger the conditional formatting. You can either

	 ●	 Type the value (400 in this example).

	 ●	 Reference a cell that contains the trigger value.

		  Also in this dialog box, you can use the drop-down menu to specify the format you want 
applied.

Figure 4-3: Each option has its own dialog box that you can use to define the trigger values and the 
format for each rule.

	 3.	 Click OK.

		  You immediately see the formatting rule applied to the selected cells (see Figure 4-4).

Figure 4-4: Cells greater than 400 are formatted.

Tip
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The benefit of a conditional formatting rule is that Excel automatically reevaluates the rule each time 
a cell is changed (provided that cell has a conditional formatting rule applied to it). For instance, if 
you were to change any of the low values to 450, the formatting would automatically change 
because all of the cells in the dataset have the formatting applied to it.

Applying Top/Bottom Rules
The formatting options in the Top/Bottom Rules category, shown in Figure 4-5, allow you to high-
light those cells whose values meet a given threshold.

Figure 4-5: The Top/Bottom Rules options apply formats if specific thresholds are met.

As with the Highlight Cells Rules, these options work like If…Then…Else… statements:

➤	 If the condition is met, the cell is formatted.

➤	 If the condition isn’t met, the cell isn’t touched.

In the Top/Bottom Options category, you can select a percentage or number of cells.

Tip 	

Some of the names of the options are misleading. Options that are named with 10 Items 
can select any number of cells, and options that are named with 10% can select any  
percentage.

You can select from these options:

➤	 Top 10 Items: Allows you to specify any number of cells to highlight based on individual cell 
values (not just 10 cells).

	 For example, you can highlight the cells whose values are the 5 largest numbers of all the 
cells selected.

➤	 Top 10%: Allows you to specify any percentage of cells to highlight based on individual cell 
values (not just 10 percent) option.
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	 For instance, you can highlight the cells whose values make up the top 20 percent of the 
total values of all the selected cells.

➤	 Bottom 10 Items: Allows you to specify the number of cells to highlight based on the lowest 
individual cell values (not just 10 cells).

	 For example, you can highlight the cells whose values are within the 15 smallest numbers 
among all the cells selected.

➤	 Bottom 10%: Allows you to specify any percentage of cells to highlight based on individual 
cell values (not just 10 percent).

	 For instance, you can highlight the cells whose values make up the bottom 15 percent of the 
total values of all the selected cells.

➤	 Above Average: Allows you to conditionally format each cell whose value is above the aver-
age of all cells selected.

➤	 Below Average: Allows you to conditionally format each cell whose value is below the aver-
age of all cells selected.

In this example, you conditionally format all cells whose values are within the top 40 percent of the 
total values of all cells.

Note 	

To avoid overlapping different conditional formatting options, before applying a new 
option, you may want to delete any conditional formatting you’ve previously applied. 
To clear the conditional formatting for a given range of cells, select the cells, go to 
Ribbon, and select Home➜Conditional Formatting. Here you find the Clear Rules selec-
tion. Click Clear Rules and select whether you want to clear conditional formatting for 
the entire sheet or only the selected workbook.

	 1.	 Select the range of cells to which you need to apply the conditional formatting.

	 2.	 In the Top/Bottom Options category, choose Top 10% (see Figure 4-5).

		  The Top 10% dialog box opens, as illustrated in Figure 4-6. Here you define the threshold 
that that will trigger the conditional formatting.

	 3.	 In this example, enter 40.

		  Here you can also use the drop-down menu to specify the format you want to apply.

Figure 4-6: Each option has its own dialog box where you can define its trigger values and format.
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	 4.	 Click OK.

		  You immediately see the formatting option applied to the selected cells (see Figure 4-7).

Figure 4-7: With conditional formatting, you can easily see that September through December makes 
up 40 percent of the total value in this dataset.

Creating Data Bars
Data Bars fill each cell you’re formatting with mini-bars in varying length, indicating the value in each 
cell relative to other formatted cells. Excel essentially takes the largest and smallest values in the 
selected range and calculates the length for each bar.

To apply Data Bars to a range, do the following:

	 1.	 Select the target range of cells to which you need to apply the conditional formatting.

	 2.	 Click the Home tab and choose Conditional Formatting➜Data Bars.

As you can see in Figure 4-8, you can choose from a menu of Data Bars varying in gradient and color.

Figure 4-8: Applying Data Bars.
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As shown in Figure 4-9, the result is essentially a mini-chart within the cells you selected. Also note 
that the Data Bars category, by default, accounts for negative numbers nicely by changing the direc-
tion of the bar and inverting the color to red.

Figure 4-9: Conditional formatting with Data Bars.

Note 	

After you create your Data Bars, it’s easy to go back and change their colors. Highlight 
the range of cells that contain the Data Bars, and then go up to the Home tab and select 
Conditional Formatting➜Manage Rules. This opens the Rules Manager dialog box that 
lists all the conditional formatting rules applied to the highlighted range. Here, select 
your Data Bar rule and click the Edit Rule button. The Edit Formatting Rule dialog box 
appears, allowing you to change the colors for both positive and negative Data Bars.

Applying Color Scales
Color Scales fill each cell you’re formatting with a color, varying in scale based on the value in each 
cell relative to other formatted cells. Excel essentially takes the largest and smallest values in the 
selected range and determines the color for each cell.

To apply Color Scales to a range, do the following:

	 1.	 Select the target range of cells to which you need to apply the conditional formatting.

	 2.	 Click the Home tab and choose Conditional Formatting➜Color Scales.

As you can see in Figure 4-10, you can choose from a menu of Color Scales varying in color.

Figure 4-10: Applying Color Scales.
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As you can see in Figure 4-11, the result is a kind of heat-map within the cells you selected.

Figure 4-11: Conditional formatting with Color Scales.

Using icon sets
Icon sets are sets of symbols that are inserted in each cell you’re formatting. Excel determines which 
symbol to use based on the value in each cell relative to other formatted cells.

To apply an icon set to a range, do the following:

	 1.	 Select the target range of cells to which you need to apply the conditional formatting.

	 2.	 Click the Home tab and choose Conditional Formatting➜Icon Sets.

		  As you can see in Figure 4-12, you can choose from a menu of icon sets varying in shape and 
colors.

Figure 4-12: Applying icon sets.
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Figure 4-13 illustrates how each cell is formatted with a symbol indicating each cell’s value based on 
the other cells.

Figure 4-13: Conditional formatting with icon sets.

Adding your own formatting rules manually
You don’t have to use one of the predefined options offered by Excel. Excel gives you the flexibility to 
create your own formatting rules manually. Creating your own formatting rule helps you better con-
trol how cells are formatted and allows you to do things you can’t do with the predefined options.

For example, a useful conditional formatting rule is to tag all above-average values with a Check icon, 
whereas all below-average values get an X icon, as shown in Figure 4-14.

Figure 4-14: With a custom formatting rule, you can tag the above-average values with a check and the below-
average values with an X.

Note 	

Although the above average and below average options built into Excel allow you to 
format cell and font attributes, they don’t enable the use of icon sets. You can imagine 
why icon sets will be better on a dashboard than just color variances. Icons and shapes 
do a much better job at conveying your message, especially when your dashboard is 
printed in black and white.
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To start creating your first custom formatting rule, open the Chapter 4 Samples.xlsx file found in the 
sample files for this book. With the file open, go to the Create Rule by Hand tab.

	 1.	 Select the target range of cells to which you need to apply the conditional formatting and 
select New Rule as, shown in Figure 4-15.

Figure 4-15: Select the target range; then select New Rule.

		  The New Formatting Rule dialog box opens, as shown in Figure 4-16.

		  As you can see, some of the rule types at the top of the dialog box are predefined option 
choices discussed earlier in this chapter:

●	 Format All Cells Based on Their Values: Measures the values in the selected range 
against each other.

	 This selection is handy for finding general anomalies in your dataset.

●	 Format Only Cells That Contain: Applies conditional formatting to those cells that meet 
specific criteria you define.

	 This selection is perfect for comparing values against a defined benchmark.

●	 Format Only Top or Bottom Ranked Values: Applies conditional formatting to those 
cells that are ranked in the top or bottom nth number or percent of all the values in the 
range.

●	 Format Only Values That Are Above or Below the Average: Applies conditional for-
matting to those values that are mathematically above or below the average of all values 
in the selected range.

●	 Format Only Unique or Duplicate Values: Applies conditional formatting to cells that 
either contain values that are duplicated within the selected range or contain values are 
unique (not duplicated) within the selected range.
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●	 Use a Formula to Determine Which Cells to Format: Evaluates values based on a for-
mula you specify. If a particular value evaluates to true, then the conditional formatting is 
applied to that cell.

	 This selection is typically used when applying conditions based the results of an 
advanced formula or mathematical operation.

Tip 	

You can use Data Bars, Color Scales, and icon sets only with the Format All Cells Based 
on Their Values rule.

	 2.	 Ensure that the Format All Cells Based on Their Values rule is selected; then use the Format 
Style drop-down menu to switch to icon sets.

	 3.	 Click the Icon Style drop-down menu to select your desired icon set.

Figure 4-16: Select the Format All Cells Based on Their Values rule; then use the Format Style drop-
down menu to switch to icon sets.

	 4.	 In the Type drop-down boxes, change both types to Formula.

	 5.	 In each Value box, enter =Average($C$2:$C$22).

		  This tells Excel that the value in each cell must be greater than the average of the entire data-
set in order to get the Check icon.

		  At this point, your dialog box will look similar to the one in Figure 4-17.

	 6.	 Click OK to apply your conditional formatting.

It’s worth taking some time to understand how this conditional formatting rule works. Excel will 
assess every cell in your target range to see if its contents match the logic in each Value box in order 
(top box first):

➤	 If a cell contains a number or text that evaluates true to the first Value box, the first icon is 
applied, and Excel moves on to the next cell in your range.

➤	 If not, Excel continues down each Value box until one of them evaluates to true.

➤	 If the cell being assessed doesn’t fit any of the logic placed in the Value boxes, Excel auto-
matically tags that cell with the last icon.
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Figure 4-17: Change the Type drop-down box to Formula and enter the appropriate formulas in the  
Value boxes.

In this example, you want your cells to get a Check icon only if the value of that cell is greater than  
(or equal to) the average of the total values. Otherwise, you want Excel to skip right to the X icon  
and apply the X.

Show only one icon
In many cases, you may not need to show all icons when applying the icon set. In fact, showing  
too many icons at one time may only serve to obstruct the data you’re trying to convey in your  
dashboard.

In the last example, you applied Check icons to values above the average for the range, whereas all 
below-average values were formatted with the X icon (see Figure 4-18). However, in the real world, 
you often need to bring attention only to the below-average values. This way, your eyes aren’t inun-
dated with superfluous icons.

Figure 4-18: Too many icons can hide the items you want to draw attention to.
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Excel provides a clever mechanism to allow you to stop evaluating and formatting values if a condi-
tion is true.

In this example, you remove the Check icons. The cells that contain those icons all have values above 
the average for the range. Therefore, you first need to add a condition for all cells whose values are 
above average.

	 1.	 Select the target range of cells; then click the Home tab and select Conditional 
Formatting➜Manage Rules.

		  The Conditional Formatting Rules Manager dialog box opens, as shown in Figure 4-19.

	 2.	 Click the New Rule button to start a new rule.

Figure 4-19: Open the Conditional Formatting Rules Manager and select New Rule.

	 3.	 Click the rule type Format Only Cells That Contain. Then configure the rule so that the format 
applies to cell values greater than the average (see Figure 4-20).

	 4.	 Click OK without changing any of the formatting options.

Figure 4-20: This new rule applies to any cell value that you don’t want formatted.
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	 5.	 Back in the Conditional Formatting Rules Manager, place a check in the Stop If True check 
box, as demonstrated in Figure 4-21.

Figure 4-21: Click Stop If True to tell Excel to stop evaluating those cells that meet the first condition.

	 6.	 Click OK to apply your changes.

As you can see in Figure 4-22, only the X icons are now shown. Again, this allows your audience to 
focus on the exceptions, rather than determining which icons are good and bad.

Figure 4-22: This table is now formatted to show only one icon.

Show Data Bars and icons outside of cells
Although Data Bars and icon sets give you a snazzy way of adding visualizations to your dashboards, 
you don’t have a lot of say in where they appear within your cell. Take a look at Figure 4-23 to see 
what I mean.
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The Data Bars are, by default, placed directly inside each cell, almost obfuscating the data. From a 
dashboarding perspective, this is less than ideal for two reasons:

➤	 The numbers can get lost in the colors of the Data Bars, making them difficult to read — 
especially when printed in black and white.

➤	 It’s difficult to see the ends of each bar.

Figure 4-23: Showing Data Bars inside the same cell as your values can make it difficult to analyze the data.

The answer to this issue is to show the Data Bars outside the cell that contains the value. Here’s how:

	 1.	 To the right of each cell, enter a formula that references the cell that contains your data 
value.

		  For example, if your data is in B2, go to cell C2 and enter =B2.

	 2.	 Apply the Data Bar conditional formatting to the formulas you just created.

	 3.	 Select the formatted range of cells; then click the Home tab and select Conditional 
Formatting➜Manage Rules.

		  The Conditional Formatting Rules Manager dialog box opens.

	 4.	 Click the Edit Rule button.

	 5.	 Place a check in the Show Bar Only option, as demonstrated in Figure 4-24.

	 6.	 Click OK to apply your change.

Figure 4-24: Edit the formatting rule to show only the Data Bars, not the data.
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The reward for your efforts is a view that is cleaner and much better suited for reporting in a dash-
board environment. Figure 4-25 illustrates the improvement gained with this technique.

Figure 4-25: Data Bars cleanly placed next to the data values.

Using the same technique, you can separate icon sets from the data, allowing you to position the 
icons where they best suit your dashboard.

Representing trends with icon sets
In a dashboard environment, there may not always be enough space available to add a chart that 
shows trending. In these cases, icon sets are an ideal replacement, enabling you to visually represent 
the overall trending without taking up a lot of space. Figure 4-26 illustrates this with a table that pro-
vides a nice visual element, allowing for an at-a-glance view of which markets are up, down, and flat 
over the previous month.

In your situations, you will want to do the same type of thing. The key is to create a formula that gives 
you a variance or trending of some sort.

Figure 4-26: Conditional Formatting icon sets enable trending visualizations.

To achieve this type of view, follow these steps:

	 1.	 Select the target range of cells to which you need to apply the conditional formatting.

		  In this case, the target range will be the cells that hold your variance formulas.
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	 2.	 Click the Home tab and choose Conditional Formatting➜Icon Set; then choose the most 
appropriate icons for your situation.

		  In this example, the set with three arrows works (see Figure 4-27).

	 ●	 The up arrow indicates an upward trend.

	 ●	 A down arrow indicates a downward trend.

	 ●	 A right-pointing arrow indicates a flat trend.

Figure 4-27: Your newly applied conditional formatting allows for a quick view of performance.

		  In most cases, you will want to adjust the thresholds that define what up, down, and flat 
mean. Imagine that you need any variance above 3% to be tagged with an up arrow, any 
variance below –3% to be tagged with a down arrow and all others to show flat.

	 3.	 Select the target range of cells; then click the Home tab and select Conditional 
Formatting➜Manage Rules.

		  The Conditional Formatting Rules Manager dialog box opens.

	 4.	 Click the Edit Rule button.

		  The Edit Formatting Rule dialog box opens.

	 5.	 Adjust the properties, as shown in Figure 4-28.

	 6.	 Click OK to apply your changes.

Tip 	

In Figure 4-28, notice that the Type property for the formatting rule is set to Number 
even though the data you’re working with (the variance) is in percentages. You’ll find 
that working with the Number setting gives you more control and predictability when 
setting thresholds.
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Figure 4-28: You can adjust the thresholds that define what up, down, and flat mean.

Using Symbols to Enhance Reporting
Symbols are essentially tiny graphics, not unlike those you see when you use the Wingdings, 
Webdings, or the other fancy fonts. However, symbols are not really fonts. They’re Unicode charac-
ters. Unicode characters are a set of industry-standard text elements designed to provide a reliable 
character set that remains viable on any platform regardless of international font differences.

One example of a commonly used symbol is the Copyright symbol (©). This symbol is a Unicode char-
acter. You can use this symbol on a Chinese, Turkish, French, and American PC, and it will be available 
reliably with no international differences.

In terms of Excel presentations, Unicode characters (or symbols) can be used in places where condi-
tional formatting cannot. For instance, in the chart labels that you see in Figure 4-29, notice that the 
x-axis shows some trending arrows that allow an extra layer of analysis. This couldn’t be done with 
conditional formatting.

Figure 4-29: Use symbols to add an extra layer of analysis to charts.
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Now, take some time to review the steps that led to the chart in Figure 4-29.

Start with the data shown in Figure 4-30. Note a cell (C1 in this case) is designated to hold any sym-
bols you’re going to use. This cell isn’t really all that important. It’s just a holding cell for the symbols 
you will insert.

Figure 4-30: The starting data with a holding cell for your symbols.

Follow these steps to integrate symbols into your visualization:

	 1.	 Click in C1 and then select the Symbol command on the Insert tab.

		  The Symbol dialog box opens, as shown in Figure 4-31.

	 2.	 Find and select your desired symbols, clicking the Insert button for each symbol.

		  Then follow these steps:

	 a.	 Select the DOWN symbol; then click Insert.

	 b.	 Click the UP symbol; then click insert.

	 3.	 Close the dialog box when you’re done.

Figure 4-31: Use the Symbol dialog box to insert the desired symbols into your holding cell.

		  At this point, you have the UP and DOWN symbols in cell C1 (see Figure 4-32).
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	 4.	 Click in the cell, go to the Formula bar, and copy the two symbols (highlight them and press 
Ctrl+C on your keyboard).

Figure 4-32: Copy the newly inserted symbols to the Clipboard.

	 5.	 Go to your data table, right-click on the percentages and then select Format Cells.

		  The Format Cells dialog box appears.

	 6.	 Create a new custom format by pasting the UP and DOWN symbols into the appropriate syn-
tax parts (see Figure 4-33).

		  In this case, any positive percent will be preceded with the UP symbol, whereas any negative 
percent will be preceded with the DOWN symbol.

Figure 4-33: Create a custom number format using the symbols.

Cross-Ref	

Not familiar with custom number formatting? Feel free to visit Chapter 2 where we 
cover the ins and outs of custom number formatting in detail.

	 7.	 Click OK, and you will see that the symbols are now a part of your number formatting.

		  Figure 4-34 illustrates what your percentages will look like. Changing any number from posi-
tive to negative (or vice versa) will automatically apply the appropriate symbol.
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Figure 4-34: Your symbols are now part of your number formatting.

Because charts automatically adopt number formatting, a chart created from this data will show the 
symbols as part of the labels. Simply use this data as the source for the chart.

This is just one way to use symbols in your reporting. Using this basic technique, you can use inserted 
symbols to add visual appeal to tables, pivot tables, formulas, or other objects you can think of.

Using Excel’s Camera Tool
Excel’s Camera tool enables you to take a live picture of a range of cells that updates dynamically 
while the data in that range updates. If you haven’t heard of this tool, don’t feel too badly. Microsoft 
has hidden this nifty tool in the last few versions of Excel by not including it on the Ribbon. However, 
it’s actually quite useful for those of us building dashboards and reports.

Finding the Camera tool
Before you can use the Camera tool, you have to find it and add it to your Quick Access toolbar.

Tip 	

The Quick Access toolbar is a customizable toolbar on which you can store frequently 
used commands so that they’re always accessible with just one click. You can add com-
mands to the Quick Access toolbar by dragging them directly from the Ribbon or by 
going through the Customize menu.

Follow these steps to add the Camera tool to the Quick Access toolbar:

	 1.	 Click the File tab and then click the Options button.

		  The Excel Options dialog box opens.

	 2.	 Click the Quick Access Toolbar button.

	 3.	 In the Choose Commands From drop-down menu, select Commands Not in the Ribbon.

	 4.	 Scroll down the alphabetical list of commands (see Figure 4-35) and find Camera; double-
click to add it to the Quick Access toolbar.

	 5.	 Click OK.
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Figure 4-35: Add the Camera tool to the Quick Access toolbar.

After you take these steps, you see the Camera tool in your Quick Access toolbar, as shown in  
Figure 4-36.

Figure 4-36: Not surprisingly, the icon for the Camera tool looks like a camera.

Using the Camera tool
To use the Camera tool, you simply highlight a range of cells to capture everything in that range in a 
live picture. The cool thing about the Camera tool is that you’re not limited to showing a single cell’s 
value like you are with a linked text box. Also, because the picture is live, all updates made to the 
source range automatically change the picture.

In Figure 4-37, you see some simple numbers and a chart based on those numbers. The goal here is 
to create a live picture of the range that holds both the numbers and the chart.

Figure 4-37: Enter some simple numbers in a range and create a basic chart from those numbers.
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Take a moment to walk through this basic demonstration of the Camera tool.

	 1.	 Highlight the range that contains the information you want to capture.

		  In this scenario, B3:F13 is selected to capture the area with the chart.

	 2.	 Select the Camera tool icon in the Quick Access toolbar.

		  You added the Camera tool to the Quick Access toolbar in the preceding section.

	 3.	 Click the worksheet in the location where you want to place the picture.

		  Excel immediately creates a live picture of the entire range, as shown in Figure 4-38.

Figure 4-38: A live picture is created via the Camera tool.

Changing any number in the original range automatically causes the picture to update.

Tip 	

By default, the picture that’s created has a border around it. To remove the border, 
right-click the picture and select Format Picture. This opens the Format Picture dialog 
box. On the Colors and Lines tab, you see a Line Color drop-down menu. Here you can 
select No Color, thereby removing the border. On a similar note, to get a picture without 
gridlines, simply remove the gridlines from the source range.

Creating a live picture without the Camera tool
Did you know you can create a live picture without actually using the Camera tool? That’s right. 
Excel 2013 made it relatively easy to manually mimic the Camera tool’s functionality.

	 1.	 Select the target range and copy it.

	 2.	 On the Ribbon, click the Home tab and then click the drop-down control under the Paste  
command.

	 3.	 In the Other Paste Options group, select the Linked Picture icon.

Of course, the advantage of using the Camera tool is that you can do the same thing with two clicks.
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Enhancing a dashboard with the Camera tool
Here are a few ways to go beyond the basics and use the Camera tool to enhance your dashboards 
and reports.

➤	 Consolidate varied ranges from different sources into one print area.

➤	 Rotate objects to simplify your work.

➤	 Create small charts.

Consolidating disparate ranges into one print area
Sometimes a data model gets so complex that it’s difficult to keep all the final data in one printable 
area. This often forces the printing of multiple pages that are inconsistent in layout and size. Given 
that dashboards are most effective when contained in a compact area that can be printed in a page 
or two, complex data models prove to be problematic when it comes to layout and design.

When you create pictures with the Camera tool, you can resize and move the pictures around freely. 
This gives you the freedom to test different layouts without needing to work on column widths, hid-
den rows, or other such nonsense. In short, you can create and manage multiple analyses on differ-
ent tabs and then bring all your presentation pieces together in a nicely formatted presentation 
layer; see Figure 4-39.

Figure 4-39: Use the Camera tool to get multiple source ranges into a compact area.

Rotating objects to save time
Again, because the Camera tool outputs pictures, you can rotate the pictures in situations where 
placing the copied range on its side can help save time. A great example is a chart. Certain charts  
are relatively easy to create in a vertical orientation but extremely difficult to create in a horizontal 
orientation.
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Figure 4-40 shows a vertical bullet graph (on the left). Whereas creating a horizontal bullet graph 
involves lots of intricate steps with multiple chart types, this graph is relatively easy to create in this 
vertical format.

Figure 4-40: Use the rotation handle to rotate your live pictures to a horizontal orientation, as seen here on  
the right.

The Camera tool to the rescue! When the live picture of the chart is created, all you have to do is 
change the alignment of the chart labels and then rotate the picture using the rotate handle to cre-
ate a horizontal version.
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5
Excel Charting for  
the Uninitiated
In This Chapter

●	 What is a chart?

●	 How Excel handles charts

●	 Embedded charts versus chart sheets

●	 The parts of a chart

●	 The basic steps for creating a chart

●	 Working with charts

No other tool is more synonymous with dashboards and reports than the chart. Charts offer a visual 
representation of numeric values and at-a-glance views that allow you to specify relationships 
between data values, point out differences, and observe business trends. Few mechanisms allow you 
to absorb data faster than a chart, which can be a key component in your dashboard.

When most people think of a spreadsheet product such as Excel, they think of crunching rows and 
columns of numbers. However, Excel is no slouch when it comes to presenting data visually, in the 
form of a chart. In this chapter, we present an overview of Excel’s charting ability and show you how 
to create and customize your own charts using Excel.

What Is a Chart?
We start with the basics. A chart is a visual representation of numeric values. Charts (also known as 
graphs) have been an integral part of spreadsheets since the early days of Lotus 1-2-3. Charts  
generated by early spreadsheet products were extremely crude by today’s standards, but over the 
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years, their quality and flexibility improved significantly. You’ll find that Excel provides you with the 
tools to create a wide variety of highly customizable charts that can help you effectively communicate 
your message.

Displaying data in a well-conceived chart can make your numbers more understandable. Because a 
chart presents a picture, charts are particularly useful for summarizing a series of numbers and their 
interrelationships. Making a chart can often help you spot trends and patterns that might otherwise 
go unnoticed.

Figure 5-1 shows a worksheet that contains a simple column chart that depicts a company’s sales vol-
ume by month. Viewing the chart makes it very apparent that sales were off in the summer months 
(June through August), but they increased steadily during the final four months of the year. You 
could, of course, arrive at this same conclusion simply by studying the numbers. But viewing the 
chart makes the point much more quickly.

Figure 5-1: A simple column chart depicts the sales volume for each month.

A column chart is just one of many different types of charts that you can create with Excel. By the 
way, creating this chart is simple: Select the data in A1:B13 and press Alt+F1.

On the Web	

All the charts pictured in this chapter are available at www.wiley.com/go/exceldr 
in a workbook file named Chapter 5 Samples.xlsx.

How Excel Handles Charts
Before you can create a chart, you must have some numbers — sometimes known as data. The data, 
of course, is stored in the cells in a worksheet. Normally, the data that is used by a chart resides in a 
single worksheet, but that’s not a strict requirement. A chart can use data that’s stored in any number 
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of worksheets, and the worksheets can even be in different workbooks. The decision to use data from 
one sheet or multiple sheets really depends on your data model, the nature of your data sources, and 
the interactivity you want to give your dashboard.

A chart is essentially an “object” that Excel creates upon request. This object consists of one or more 
data series, displayed graphically. The appearance of the data series depends on the selected chart 
type. For example, if you create a line chart that uses two data series, the chart contains two lines, and 
each line represents one data series.

➤	 The data for each series is stored in a separate row or column.

➤	 Each point on the line is determined by the value in a single cell and is represented by a 
marker.

	 You can distinguish the lines by their thickness, line style, color, and data markers.

Figure 5-2 shows a line chart that plots two data series across a nine-year period. The series are iden-
tified by using different data markers (squares versus circles), shown in the legend at the bottom of 
the chart. The lines also use different colors, which is not apparent in the grayscale figure.

Figure 5-2: This line chart displays two data series.

A key point to keep in mind is that charts are dynamic. In other words, a chart series is linked to the 
data in your worksheet. If the data changes, the chart is updated automatically to reflect those 
changes so your dashboard can show the most current information.

After you create a chart, you can always change its type and formatting, add new data series to it, or 
change an existing data series so that it uses data in a different range.

Charts can reside in either of two locations in a workbook:

➤	 On a worksheet (an embedded chart)

➤	 On a separate chart sheet
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Embedded charts
An embedded chart basically floats on top of a worksheet, on the worksheet’s drawing layer. The 
charts shown previously in this chapter are both embedded charts.

As with other drawing objects (such as a text box or a shape), you can move an embedded chart, 
resize it, change its proportions, adjust its borders, and add effects such as a shadow. Using embed-
ded charts enables you to view the chart next to the data that it uses. Or you can place several 
embedded charts together so that they print on a single page.

As we discuss in Chapter 11, you ideally place your charts in the presentation layer, presenting the 
relevant charts in a single viewable area that fit on one page or a single screen.

When you create a chart, it always starts off as an embedded chart. The exception to this rule is when 
you select a range of data and press F11 to create a default chart. Such a chart is created on a chart 
sheet.

To make changes to the actual chart in an embedded chart object, you must click the chart to acti-
vate it. When a chart is activated, Excel displays the two Chart Tools context tabs, Design and Format, 
as shown in Figure 5-3. To access these commands, choose Chart Tools➜Design and Chart Tools➜ 

Format, respectively.

In addition, when clicking a chart, you’ll see several buttons next to the chart. These are helper but-
tons that provide an easy way to customize the various properties of the chart. These include

Chart Elements

Chart Style

Chart Filter

Figure 5-3: Activating a chart displays additional tabs on the Excel Ribbon and helper buttons next to the chart.
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Chart sheets
You can move an embedded chart to its own chart sheet so that you can view it by clicking a sheet 
tab (covered later in this chapter in the “Moving and resizing a chart” section). When you move a 
chart to a chart sheet, the chart occupies the entire sheet. If you plan to print a chart on a page by 
itself, using a chart sheet is often your better choice. If you have many charts to create, you may want 
to put each one on a separate chart sheet to avoid cluttering your worksheet. This technique also 
makes locating a particular chart easier because you can change the names of the chart sheets’ tabs 
to provide a description of the chart that it contains. Although chart sheets are not typically used in 
traditional dashboards, they can come in handy when producing reports that will be viewed in a 
multi-tab workbook.

Figure 5-4 shows a chart on a chart sheet. When a chart sheet is activated, Excel displays the Chart 
Tools context tabs, as described in the previous section.

Figure 5-4: A chart on a chart sheet.

Parts of a Chart
A chart is made up of many different elements, and all of these elements are optional. Yes, you  
can create a chart that contains no chart elements — an empty chart. It’s not very useful, but Excel 
allows it.
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Refer to the chart in Figure 5-5 as you read the following description of the chart’s elements.

Figure 5-5: Parts of a chart.

This particular chart is a combination chart that displays both columns and a line. The chart has two 
data series: Income and Profit Margin. Income is plotted as vertical columns, and the Profit Margin is 
plotted as a line with square markers. Each bar (or marker on the line) represents a single data point 
(the value in a cell).

The chart has a horizontal axis, known as the category axis. This axis represents the category for each 
data point (January, February, and so on). This axis doesn’t have a label because the category units 
are obvious.

Notice that this chart has two vertical axes. These are known as value axes, and each one has a differ-
ent scale. The axis on the left is for the column series (Income), and the axis on the right is for the line 
series (Profit Margin).

The value axes also display scale values. The axis on the left displays scale values from 0 to 250,000, in 
major unit increments of 50,000. The value axis on the right uses a different scale: 0 percent to 14 
percent, in increments of 2 percent. For a value axis, you can command the minimum and maximum 
values, as well as the increment value.

A chart with two value axes is appropriate because the two data series vary dramatically in scale. If 
the Profit Margin data were to be plotted using the left axis, the line would not even be visible.
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If a chart has more than one data series, you’ll usually need a way to identify the data series or data 
points. A legend, for example, is often used to identify the various series in a chart. In this example, 
the legend appears at the bottom of the chart. Some charts also display data labels to identify spe-
cific data points. The example chart displays data labels for the Profit Margin series, but not for the 
Income series. In addition, most charts (including the example chart) contain a chart title and addi-
tional labels to identify the axes or categories.

The example chart also contains horizontal gridlines (which correspond to the values on the left axis). 
Gridlines are basically extensions of the value axis scale, which makes it easier for the viewer to deter-
mine the magnitude of the data points.

In addition, all charts have a chart area (the entire background area of the chart) and a plot area (the 
part that shows the actual chart, including the plotted data, the axes, and the axis labels).

Charts can have additional parts or fewer parts, depending on the chart type. For example, a pie 
chart (see Figure 5-6) has “slices” and no axes. A 5-D chart may have walls and a floor (see Figure 5-7).

Figure 5-6: A pie chart.

Figure 5-7: A 3-D column chart.

Several other types of items can be added to a chart. For example, you can add a trend line or display 
error bars.
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Like everything else in Excel, charts do have limitations. Table 5-1 lists the limitations of Excel charts.

Table 5-1: Chart Limitations
Item Limitation

Charts in a worksheet Limited by available memory

Worksheets referred to by a chart 255

Data series in a chart 255

Data points in a data series 32,000

Data points in a data series (3D charts) 4,000

Total data points in a chart 256,000

Most users never find these limitations to be a problem. However, one item that frequently does 
cause problems is the limit on the length of the SERIES formula. Each argument is limited to 255 char-
acters, and in some situations, that’s simply not enough characters. See Chapter 6 for more informa-
tion about SERIES formulas.

Basic Steps for Creating a Chart
Creating a chart is relatively easy. The following sections describe how to create and then customize 
a basic chart in Excel 2013 to best communicate your business goals.

Creating the chart
Follow these steps to create a chart using the data in Figure 5-8:

	 1.	 Select the data that you want to use in the chart.

		  Make sure that you select the column headers, if the data has them.

Tip 	

If you select a single cell within a range of data, Excel uses the entire data range for  
the chart.

Figure 5-8: This data would make a good chart.
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	 2.	 Click the Insert tab and then in the Charts group, click a Chart icon.

		  The icon expands into a gallery list that shows subtypes (see Figure 5-9).

Figure 5-9: The icons in the Insert➜Charts group expand to show a gallery of chart subtypes.

	 3.	 Click a Chart subtype, and Excel creates the chart of the specified type.

		  Figure 5-10 shows a column chart created from the data.

Figure 5-10: A column chart with two data series.

Tip 	

To quickly create a default chart, select the data and press Alt+F1 to create an embed-
ded chart, or press F11 to create a chart on a chart sheet.
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Switching the row and column orientation
When Excel creates a chart, it uses an algorithm to determine whether the data is arranged in col-
umns or in rows. Most of the time, Excel guesses correctly, but if it creates the chart using the wrong 
orientation, you can quickly change the orientation by selecting the chart and choosing Chart Tools➜ 

Design➜Data➜Switch Row/Column. This command is a toggle, so if changing the data orientation 
doesn’t improve the chart, just choose the command again (or click the Undo button found on the 
Quick Access toolbar).

The orientation of the data has a drastic effect on the look (and, perhaps, understandability) of your 
chart. Figure 5-11 shows the column chart in Figure 5-10 after changing the orientation. Notice that 
the chart now has three data series, one for each month. If the goal of your dashboard is to compare 
actual values to projected values for each month, this version of the chart is much more difficult to 
interpret because the relevant columns are not adjacent.

Figure 5-11: The column chart, after swapping the row/column orientation.

Changing the chart type
After you create a chart, you can easily change the chart type. Although a column chart may work 
well for a particular data set, there’s no harm in checking out other chart types. You can choose Chart 
Tools➜Design➜Type➜Change Chart Type to display the Change Chart Type dialog box and experi-
ment with other chart types. Figure 5-12 shows the Change Chart Type dialog box.

In the Change Chart Type dialog box, the main categories are listed on the left, and the subtypes are 
shown as icons. Select an icon and click OK, and Excel displays the chart using the new chart type. If 
you don’t like the result, click the Undo button.

	

If the chart is an embedded chart, you can also change a chart’s type by using the icons 
in the Insert➜Charts group. In fact, this method is more efficient because it doesn’t 
involve a dialog box.Tip
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Figure 5-12: The Change Chart Type dialog box.

Applying chart styles
Each chart type has a number of prebuilt styles that you can apply with a single mouse click. A style 
contains additional chart elements, such as a title, data labels, and axes. This step is optional, but one 
of the prebuilt designs might be just what you’re looking for. Even if the style isn’t exactly what you 
want, it may be close enough that you need to make only a few adjustments.

To apply a style, select the chart and use the Chart Tools➜Design➜Chart Styles gallery. Figure 5-13 
shows how a column chart looks using various styles.

Applying a chart style
The Chart Tools➜Design➜Chart Styles gallery contains quite a few styles that you can apply to your 
chart. The styles consist of various color choices and some special effects. Again, this step is optional.

Tip 	

The styles displayed in the gallery depend on the workbook’s theme. When you choose 
Page Layout➜Themes to apply a different theme, you see a new selection of chart styles 
designed for the selected theme.
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Figure 5-13: One-click design variations of a column chart.

Adding and deleting chart elements
In some cases, applying a chart layout (as described previously) gives you a chart with all the ele-
ments you need. Most of the time, however, you need to add or remove some chart elements and 
fine-tune the layout. You do so using the Chart Elements button next to the chart command.

For example, to give a chart a title, choose the Chart Elements button and place a check next to Chart 
Title (see Figure 5-14).

As you can see in Figure 5-14, you add all kinds of chart elements, such as axis titles, data labels, grid-
lines, and trend lines.

Figure 5-14: Use the Chart Elements button to add or remove various chart elements.
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Moving and deleting chart elements
Some of the elements within a chart can be moved. The movable chart elements include the plot area, 
titles, the legend, and data labels. To move a chart element, click it to select it. Then drag its border.

The easiest way to delete a chart element is to select it and then press Delete. Note that if you delete 
a chart element and later decide that you want to add it back, all previous formatting will be lost, and 
you’ll need to reapply the formatting.

A few chart elements consist of multiple objects. For example, the data labels element consists of 
one label for each data point. To move or delete one data label, click once to select the entire ele-
ment and then click a second time to select the specific data label. You can then move or delete the 
single data label.

Formatting chart elements
Many users are content to stick with the predefined chart layouts and chart styles. For more precise cus-
tomizations, Excel allows you to work with individual chart elements and apply additional formatting.

Every element in a chart can be formatted and customized in many ways. Many users are content 
with charts that are created using the steps described earlier in this chapter. But because you’re read-
ing this book, you probably want to find out how to customize charts for maximum impact.

	

For more detailed information about formatting and customizing your chart, see 
Chapter 6.

Excel provides two ways to format and customize individual chart elements. Both of the following 
methods require that you select the chart element first:

➤	 Use the Ribbon commands on the Chart Tools➜Format tab.

➤	 Press Ctrl+1 to display the Format dialog box that’s specific to the selected chart element.

If you use Excel 2013, you can also double-click a chart element to display the Format dialog box for 
the element.

Note 	

The Ribbon commands contain only a subset of the formatting options. For maximum 
command, use the Format dialog box.

For example, assume that you want to change the color of the columns for one of the series in the 
chart. Click any column in the series (which selects the entire series). Then choose Chart Tools➜ 

Format➜Shape Styles➜Shape Fill and select a color from the list that appears. To change the proper-
ties of the outline around the columns, use the Chart Tools➜Format➜Shape Styles➜Shape Outline 
command. To change the effects used in the columns (for example, add a shadow), use the Chart 
Tools➜Format➜Shape Styles➜Shape Effects command.

Cross-Ref
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Alternatively, you can select a series in the chart, press Ctrl+1, and use the Format Data Series dialog 
box shown in Figure 5-15. Note that this is a tabbed dialog box. Click the icons along the top of the 
dialog box to view additional commands. It’s also a persistent dialog box, so you can click another 
element in the chart. In other words, you don’t have to close the dialog box to see the changes you 
specify.

Figure 5-15: Using the Format Data Series dialog box.

Working with Charts
As you develop your charts in Excel, you will find the need to move your charts around, resize your 
charts, duplicate your charts, etc. The following section covers some of the common actions you will 
inevitably have to perform when working with charts.

Note 	

Before you can work with a chart, you must activate it. To activate an embedded chart, 
click an element in the chart. Doing so activates the chart and also selects the element 
that you click. To activate a chart on a chart sheet, just click its sheet tab.

Moving and resizing a chart
If your chart is an embedded chart, you can freely move and resize it with your mouse. Click the 
chart’s border and then drag the border to move the chart. Drag any of the handles to resize  
the chart. The handles consist of dots that appear on the chart’s corners and edges when you  
click the chart’s border. When the mouse pointer turns into a double arrow, click and drag to resize 
the chart.

When a chart is selected, you can use the Chart Tools➜Format➜Size commands to adjust the height 
and width of the chart. Use the spinners or type the dimensions directly into the Height and Width 
commands. Oddly, Excel doesn’t provide similar commands to specify the top and left positions of 
the chart.
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To move an embedded chart, just click its border at any location except one of the eight resizing 
handles. Then drag the chart to its new location. You also can use standard cut-and-paste techniques 
to move an embedded chart. Select the chart and choose Home➜Clipboard➜Cut (or press Ctrl+X). 
Then activate a cell near the desired location and choose Home➜Clipboard➜Paste (or press Ctrl+V). 
The new location can be in a different worksheet or even in a different workbook. If you paste the 
chart to a different workbook, it will be linked to the data in the original workbook. Another way to 
move a chart to a different location is to choose Chart Tools➜Design➜Location➜Move Chart. This 
command displays the Move Chart dialog box, which lets you specify a new sheet for the chart 
(either a chart sheet or a worksheet).

Converting an embedded chart to a chart sheet
When you create a chart using the icons in the Insert➜Charts group, the result is always an embed-
ded chart. If you prefer that your chart be located on a chart sheet, you can easily move it.

To convert an embedded chart to a chart on a chart sheet, select the chart and choose Chart➜Tools➜ 

Design➜Location➜Move Chart to display the Move Chart dialog box shown in Figure 5-16. Select 
the New Sheet option and (optionally) provide a different name for the chart sheet.

Figure 5-16: Use the Move Chart dialog box to move an embedded chart to a chart sheet (or vice versa).

To convert a chart on a chart sheet to an embedded chart, activate the chart sheet and then choose 
Chart➜Tools➜Design➜Location➜Move Chart to display the Move Chart dialog box. Select the 
Object In option and specify the sheet by using the drop-down command.

Copying a chart
To make an exact copy of an embedded chart, select the chart and choose Home➜Clipboard➜Copy 
(or press Ctrl+C). Then activate a cell near the desired location and choose Home➜Clipboard➜Paste 
(or press Ctrl+V). The new location can be in a different worksheet or even in a different workbook. If 
you paste the chart to a different workbook, it will be linked to the data in the original workbook.

To copy a chart on a chart sheet, press Ctrl while you click and drag the sheet tab to the left or right. 
After you let go of the mouse, you will have a copy of the chart sheet.
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Deleting a chart
To delete an embedded chart, click the chart (this selects the chart as an object). Then press Delete. 
With the Ctrl key pressed, you can select multiple charts and then delete them all with a single press 
of the Delete key.

To delete a chart sheet, right-click its sheet tab and choose Delete from the shortcut menu. To delete 
multiple chart sheets, select them by pressing Ctrl while you click the sheet tabs.

Copying a chart’s formatting
If you create a nicely formatted chart and realize that you need to create several more charts that 
have the same formatting, you have these three choices:

➤	 Make a copy of the original chart and then change the data used in the copied chart. One 
way to change the data used in a chart is to choose the Chart Tools➜Design➜Data➜Select 
Data command and make the changes in the Select Data Source dialog box.

➤	 Create the other charts, but don’t apply any formatting. Then activate the original chart and 
press Ctrl+C. Select one of the other charts and choose Home➜Clipboard➜Paste➜Paste 
Special. In the Paste Special dialog box, click the Formats option and then click OK. Repeat 
for each additional chart.

➤	 Create a chart template and then use the template as the basis for the new charts. Or you 
can apply the new template to existing charts. 

Renaming a chart
When you activate an embedded chart, its name appears in the Name box (located to the left of the 
Formula bar). To change the name of an embedded chart, just type the new name into the Name box 
and press Enter.

Why rename a chart? If a worksheet has many charts, you may prefer to activate a particular chart by 
name. Just type the chart’s name in the Name box and press Enter. It’s much easier to remember a 
chart named Monthly Sales as opposed to a chart named Chart 9.

Note 	

When you rename a chart, Excel allows you to use a name that already exists for another 
chart. Normally, it doesn’t matter if multiple charts have the same name, but it can 
cause problems if you use VBA macros that select a chart by name.
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Printing charts
Printing embedded charts is nothing special; you print them the same way that you print a work-
sheet. As long as you include the embedded chart in the range that you want to print, Excel prints 
the chart as it appears on-screen. When printing a sheet that contains embedded charts, it’s a good 
idea to preview first (or use Page Layout view) to ensure that your charts don’t span multiple pages. If 
you create the chart on a chart sheet, Excel always prints the chart on a page by itself.

Tip 	

If you select an embedded chart and choose File➜Print, Excel prints the chart on a page 
by itself (as though it were a chart sheet) and does not print the worksheet.

If you don’t want a particular embedded chart to appear on your printout, select the background 
area of the chart (the chart area), right-click, and choose Format. In the Format Chart Area dialog box, 
click the Properties tab and deselect the Print Object check box (see Figure 5-17).

Figure 5-17: Specifying that a chart should not be printed with the worksheet.
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6
Working with  
Chart Series
In This Chapter

●	 Adding and removing series from a chart

●	 Finding various ways to change the data used in a chart

●	 Using noncontiguous ranges for a chart

●	 Charting data from different worksheets or workbooks

●	 Dealing with missing data

●	 Controlling a data series by hiding data

●	 Unlinking a chart from its data

●	 Using secondary axes

Every chart consists of at least one series, and the data used in that series is (normally) stored in a 
worksheet. This chapter provides an in-depth discussion of data series for charts and presents lots of 
tips to help you select and modify the data used in your charts.

On the Web	

All workbook examples in this book are available on the companion website for this 
book at www.wiley.com/go/exceldr.

Specifying the Data for Your Chart
When you create a chart, you almost always start by selecting the worksheet data to be plotted. 
Normally, you select the numeric data as well as the category labels and series names, if they exist.
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When creating a chart, a key consideration is the orientation of your data: by rows or by columns. In 
other words, is the data for each series in a single row or in a single column?

Excel attempts to guess the data orientation by applying a simple rule: If the data rows outnumber 
the data columns, each series is assumed to occupy a column. If the number of data columns is 
greater than or equal to the number of data rows, each series is assumed to occupy a row. In other 
words, Excel always defaults to a chart that has more category labels than series.

After you create the chart, it’s a simple matter to override Excel’s orientation guess. Just activate the 
chart and choose Chart Tools➜Design➜Data➜Switch Row/Column.

Your choice of orientation determines how many series the chart has, and it affects the appearance 
and (possibly) the legibility of your chart. Figure 6-1 shows two charts that use the same data. The 
chart on the left displays three series, arranged in columns. The chart on the right shows four series, 
arranged in rows.

Figure 6-1: Your choice of data orientation (by row or by column) determines the number of series in the chart.

In many situations, you may find it necessary to modify the ranges used by a chart. Specifically, you 
may want to do the following:

➤	 Add a new series to the chart.

➤	 Delete a series from the chart.

➤	 Extend the range used by a series (show more data).

➤	 Contract the range used by a series (show less data).

➤	 Add or modify the series names.

All these topics are covered in the following sections.

Note 	

Chart types vary in the number of series that they can use. All charts are limited to a 
maximum of 255 series. Other charts require a minimum number of series. For example, 
a high-low-close stock chart requires three series. A pie chart can use only one series.
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Adding a New Series to a Chart
Excel provides four ways to add a new series to an existing chart:

➤	 Copy the range and then paste the data into the chart.

➤	 Use the Select Data Source dialog box.

➤	 Select the chart and extend the blue highlighting rectangle to include the new series.

➤	 Activate the chart, click in the Formula bar, and manually type a SERIES formula.

Dealing with numeric category labels
It’s not uncommon to have category labels that consist of numbers. For example, you may create a 
chart that shows sales by year, and the years are numeric values. If your category labels include a 
heading, Excel will (incorrectly) interpret the category labels as a data series and use generic cate-
gory labels that consist of integers (1, 2, 3, and so on). The following figure shows an example.

You can, of course, choose Chart Tools➜Design➜Data➜Select Data and use the Select Data Source 
dialog box to fix the chart. But a more efficient solution is to make a simple change before you cre-
ate the chart: Remove the header text above the category labels! The following figure shows the 
chart that was created when the heading was removed from the category label column.

www.it-ebooks.info

http://www.it-ebooks.info/


Part II: Introducing Charts into Your Dashboards110

These techniques are described in the following sections.

Note 	

Attempting to add a new series to a pie chart has no apparent effect because a pie chart 
can have only one series. The series, however, is added to the chart but isn’t displayed. If 
you select a different chart type for the chart, the added series is then visible.

Adding a new series by copying a range
One way to add a new series to a chart is to perform a standard copy/paste operation. Follow these 
steps:

	 1.	 Select the range that contains the data to be added (including the series name).

	 2.	 Choose Home➜Clipboard➜Copy (or press Ctrl+C).

	 3.	 Click the chart to activate it.

	 4.	 Choose Home➜Clipboard➜Paste (or press Ctrl+V).

	

If the series you are trying to copy and paste into your chart has a series name that is a 
number (for example, a year like 2009) Excel will try to plot that series name as an actual 
value to the chart. In these cases, you can use the Paste Special feature to avoid this 
problem. Read on to find out how. 

For more control when adding data to a chart, choose Home➜Clipboard➜Paste➜Paste Special in 
Step 4. This command displays the Paste Special dialog box. Figure 6-2 shows a new series (using 
data in row 5) being added to a line chart.

Figure 6-2: Using the Paste Special dialog box to add a series to a chart.

Note
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Following are some pointers to keep in mind when you add a new series using the Paste Special  
dialog box:

➤	 Make sure that the New Series option is selected.

➤	 Excel will guess at the data orientation, but you should verify that the Rows or Columns 
option is guessed correctly.

➤	 If the range you copied included a cell with the series name, ensure that the Series Names in 
First Row/Column option is selected.

➤	 If the first column of your range selection included category labels, make sure that the 
Categories (X Labels) in First Column/Row check box is selected.

➤	 If you want to replace the existing category labels, select the Replace Existing Categories 
check box.

Adding a new series by extending the range highlight
When you select a series in a chart, Excel displays an outline around the data used by that series. 
When you select something other than a series in a chart, Excel displays an outline around the entire 
data range used by the chart — but only if the data is in a contiguous range of cells.

If you need to add a new series to a chart (and the new series is contiguous with the existing chart’s 
data), you can just drag the blue range highlight to add the new series. Start by selecting any chart 
element except a series. Excel highlights the range with a blue outline. Drag a corner of the blue out-
line to include the new data, and Excel creates a new series in the chart.

Adding a new series using the Select Data Source dialog box
The Select Data Source dialog box provides another way to add a new series to a chart, as follows:

	 1.	 Click the chart to activate it.

	 2.	 Choose Chart Tools➜Design➜Data➜Select Data to display the Select Data Source  
dialog box.

	 3.	 Click the Add button to display the Edit Series dialog box.

	 4.	 Use the range selector controls to specify the cell for the Series Name (optional) and Series 
Values (see Figure 6-3).
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	 5.	 Click OK to close the Edit Series dialog box and return to the Select Data Source dialog box.

	 6.	 Click OK to close the Select Data Source dialog box or click the Add button to add another 
series to the chart.

Figure 6-3: Using the Edit Series dialog box to add a series to a chart.

Note 	

The configuration of the Edit Series dialog box varies, depending on the chart type. For 
example, if the chart is a scatter chart, the Edit Series dialog box displays range selectors 
for the Series Name, the Series X Values, and the Series Y Values. If the chart is a bubble 
chart, the dialog box displays an additional range selector for the Series Bubble Size.

Adding a new series by typing a new SERIES formula
Excel provides yet another way to add a new series: Type a new SERIES formula. Follow these steps:

	 1.	 Click the chart to activate it.

	 2.	 Click the Formula bar.

	 3.	 Type the new SERIES formula and press Enter.

This method is certainly not the most efficient way to add a new series to a chart. It requires that  
you understand how the SERIES formula works, and (as you might expect) it can be rather error-
prone. Note, however, that you don’t need to type the SERIES formula from scratch. You can copy  
an existing SERIES formula, paste it into the Formula bar, and then edit the SERIES formula to create  
a new series.

Cross-Ref	

For more information about the SERIES formula, see the “SERIES formula syntax”  
sidebar, later in this chapter.
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Deleting a Chart Series
The easiest way to delete a series from a chart is to select the series and press Delete.

Note 	

Deleting the only series in a chart does not delete the chart. Rather, it gives you an 
empty chart. If you’d like to delete this empty chart, just press Delete a second time.

You can also use the Select Data Source dialog box to delete a series. Choose Chart Tools➜Design➜ 

Data➜Select Data to display this dialog box. Then select the series from the list and click the Remove 
button.

Modifying the Data Range  
for a Chart Series
After you’ve created a chart, you may want to modify the data ranges used by the chart. For example, 
you may need to expand the range to include new data. Or you might need to substitute an entirely 
different range. Excel offers a number of ways to perform these operations:

➤	 Drag the range highlights.

➤	 Use the Select Data Source dialog box.

➤	 Edit the SERIES formula.

Each of these techniques is described in the following sections.

Tip 	

If you create your chart from data in a table (created by choosing Insert➜Tables➜ 

Table), the chart will adjust automatically if you add new data to the table.

Using range highlighting to change series data
When you select a series in a chart, Excel highlights the worksheet ranges used in that series. This 
range highlighting consists of a colored outline around each range used by the series. Figure 6-4 
shows an example in which the chart series (Region 1) is selected. Excel highlights the following 
ranges:

➤	 C2 (the series name)

➤	 B3:B8 (the category labels)

➤	 C3:C8 (the values)
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Figure 6-4: Selecting a chart series highlights the data used by the series.

Each of the highlighted ranges contains a small handle at each corner. You can perform two opera-
tions with the highlighted data:

➤	 Expand or contract the data range. Click one of the handles and drag it to expand the out-
lined range (specify more data) or contract the data range (specify less data). When you 
move your cursor over a handle, the mouse pointer changes to a double arrow.

➤	 Specify an entirely different data range. Click one of the borders of the highlight and then 
drag it to highlight a different range. When you move the cursor over a border, the mouse 
pointer changes to a four-way arrow.

Figure 6-5 shows the chart after the data range has been changed. In this case, the highlight around cell 
C2 was dragged to cell D2, and the highlight around C3:C8 was dragged to D3:D8 and then expanded 
to include D3:D14. Notice that the range for the category labels (B3:B8) wasn’t modified — and the 
missing labels aren’t shown in the chart. To finish the job, that range needs to be expanded to B3:B14.

Figure 6-5: The chart’s data range has been modified.
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Modifying chart source data by using the range highlights is probably the simplest method. Note, 
however, that this technique works only with embedded charts (not with chart sheets). In addition, it 
doesn’t work when the chart’s data is in a worksheet other than the sheet that contains the embed-
ded chart.

Note 	

A surface chart is a special case. You cannot select an individual series in a surface chart. 
But when you select the plot area of a surface chart, Excel highlights all the data used in 
the chart. You can then use the range highlighting to change the ranges used in the chart.

Using the Select Data Source dialog  
box to change series data
Another method of modifying a series data range is to use the Select Data Source dialog box. Select 
your chart and then choose Chart Tools➜Design➜Data@>Select Data. Figure 6-6 shows the Select 
Data Source dialog box.

Figure 6-6: The Select Data Source dialog box.

Notice that the Select Data Source dialog box has three parts:

➤	 The top part of the dialog box shows the entire data range used by the chart. You can 
change this range by selecting new data.

➤	 The lower-left part displays a list of each series. Select a series and click the Edit button to dis-
play the Edit Series dialog box to change the data used by a single series.

➤	 The lower-right part displays the category axis labels. Click the Edit button to display the Axis 
Labels dialog box to change the range used as the axis labels.

Note 	

The Edit Series dialog box can vary somewhat, depending on the chart type. The Edit 
Series dialog box for a bubble chart, for example, has four range selector controls: Series 
Name, Series X Values, Series Y Values, and Series Bubble Size.
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Editing the SERIES formula to change series data
Every chart series has its own SERIES formula. When you select a data series in a chart, its SERIES for-
mula appears in the Formula bar. In Figure 6-7, for example, you can see one of two SERIES formulas 
in the Formula bar for a chart that displays two data series.

Figure 6-7: The SERIES formula for the selected data series appears in the Formula bar.

Although a SERIES formula is displayed in the Formula bar, it isn’t a “real” formula. In other words, you 
can’t put this formula into a cell, and you can’t use worksheet functions within the SERIES formula. You 
can, however, edit the arguments in the SERIES formula to change the ranges used by the series. To edit 
the SERIES formula, just click in the Formula bar and use standard editing techniques. Refer to the side-
bar, “SERIES formula syntax,” to find out about the various arguments for a SERIES formula.

Note 	

When you modify a series data range using either of the techniques discussed previ-
ously in this section, the SERIES formula is also modified. In fact, those techniques are 
simply easy ways of editing the SERIES formula.

Following is an example of a SERIES formula:

=SERIES(Sheet4!$D$2,Sheet4!$B$3:$B$8,Sheet4!$D$3:$D$8,2)

This SERIES formula does the following:

➤	 Specifies that cell D2 (on Sheet4) contains the series name.

➤	 Specifies that the category labels are in B3:B8 on Sheet4.

➤	 Specifies that the data values are in D3:D8, also on Sheet4.

➤	 Specifies that the series will be plotted second on the chart (the final argument is 2).
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Notice that range references in a SERIES formula always include the worksheet name, and the range 
references are always absolute references. An absolute reference, as you may know, uses a dollar sign 
before the row and column part of the reference. If you edit a SERIES formula and remove the sheet 
name or make the cell references relative, Excel will override these changes.

Understanding Series Names
Every chart series has a name, which is displayed in the chart’s legend. If you don’t explicitly provide 
a name for a series, it will have a default name, such as Series1, Series2, and so on.

The easiest way to name a series is to do so when you create the chart. Typically, a series name is con-
tained in a cell adjacent to the series data. For example, if your data is arranged in columns, the col-
umn headers usually contain the series names. If you select the series names along with the chart 
data, those names will be applied automatically.

SERIES formula syntax
A SERIES formula has the following syntax:

=SERIES(series_name, category_labels, values, order, sizes)

The arguments you can use in the SERIES formula include the following:

●	 series_name: (Optional) A reference to the cell that contains the series name used in the leg-
end. If the chart has only one series, the name argument is used as the title. This argument can 
also consist of text in quotation marks. If omitted, Excel creates a default series name (for 
example, Series 1).

●	 category_labels: (Optional) A reference to the range that contains the labels for the category 
axis. If omitted, Excel uses consecutive integers beginning with 1. For scatter charts, this argu-
ment specifies the x values. A noncontiguous range reference is also valid. (The ranges’ 
addresses are separated by a comma and enclosed in parentheses.) The argument may also 
consist of an array of comma-separated values (or text in quotation marks) enclosed in braces.

●	 values: (Required) A reference to the range that contains the values for the series. For scatter 
charts, this argument specifies the y values. A noncontiguous range reference is also valid. 
(The ranges’ addresses are separated by a comma and enclosed in parentheses.) The argu-
ment may also consist of an array of comma-separated values enclosed in braces.

●	 order: (Required) An integer that specifies the plotting order of the series. This argument is 
relevant only if the chart has more than one series. Using a reference to a cell is not allowed.

●	 sizes: (Only for bubble charts) A reference to the range that contains the values for the size of 
the bubbles in a bubble chart. A noncontiguous range reference is also valid. (The ranges’ 
addresses are separated by a comma and enclosed in parentheses.) The argument may also 
consist of an array of values enclosed in braces.
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Figure 6-8 shows a chart with three series. The series names, which are stored in B3:D3, are Main, N. 
County, and Westside. The SERIES formula for the first data series is as follows:

=SERIES(Sheet1!$B$3,Sheet1!$A$4:$A$9,Sheet1!$B$4:$B$9,1)

Figure 6-8: The series names are picked up from the worksheet.

Note that the first argument for this SERIES formula is a reference to the cell that contains the  
series name.

Changing a series name
The series name is the text that appears in a chart’s legend. In some cases, you may prefer the chart 
to display a name other than the text that’s in the worksheet. To change the name of a series, follow 
these steps:

	 1.	 Activate the chart.

	 2.	 Choose Chart Tools➜Design➜Data➜Select Data to display the Select Data Source  
dialog box.

	 3.	 In the Select Data Source dialog box, select the series that you want to modify, and click the 
Edit button to display the Edit Series dialog box.

	 4.	 Type the new name in the Series Name box.

Normally, the Series Name box contains a cell reference. But you can override this and enter any text.

Note 	

If you go back to a series that you’ve already renamed, you’ll find that Excel has con-
verted your text into a formula — an equal sign, followed by the text you entered (the 
new series name), within quotation marks.

www.it-ebooks.info

http://www.it-ebooks.info/


Chapter 6: Working with Chart Series 119

Figure 6-9 shows the previous chart, after changing the series names. The first argument in each of 
the SERIES formulas no longer displays a cell reference. It now contains the literal text. For example, 
the SERIES formula for the first series is as follows:

=SERIES(“Branch 1”,’Figure 6-9’!$A$4:$A$9,’Figure 6-9’!$B$4:$B$9,1)

Figure 6-9: The series names have been changed; the new names are shown in the legend.

You can also change the name of a series by editing the SERIES formula directly. Select the series, 
click inside the Formula bar, and replace the first argument with your text (make sure that the text is 
enclosed within quotation marks).

Deleting a series name
To delete a series name, use the Edit Series dialog box as described previously. Highlight the range 
reference (or text) in the Series Name box and press Delete.

Alternatively, you can edit the SERIES formula and remove the first argument. Here’s an example of a 
SERIES formula for a series with no specified name (it will use the default name):

=SERIES(,Sheet2!$A$2:$A$6,Sheet2!$B$2:$B$6,1)

	

When you remove the first argument in a SERIES formula, make sure that you do not 
delete the comma that follows the first argument. The comma is required as a place-
holder to indicate the missing argument.

To create a series with no name, use a set of empty quotation marks for the first argument in the 
SERIES formula. A series with no name still appears in the chart’s legend, but no text is displayed.

Note
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Adjusting the Series Plot Order
Every chart series has a plot order parameter. A chart’s legend usually displays the series’ names in 
the order in which they’re plotted. I say usually, because you do find exceptions. For example, con-
sider a combination chart that displays a column series and a line series. Changing the series order 
doesn’t change the order in which the series are listed in the legend.

To change the plot order of a chart’s data series, use the Select Data Source dialog box. In the lower-
left list, the series are listed in the order in which they’re plotted. Select a series and then use the  
up- or down-arrow buttons to adjust its position in the list — which also changes the plot order of 
the series.

Alternatively, you can edit the SERIES formulas — specifically, the fourth parameter in the SERIES for-
mulas. See the “SERIES formula syntax” sidebar, earlier in this chapter, for more information about 
SERIES formulas.

For some charts, the plot order is not important. For others, however, you may want to change the 
order in which the series are plotted. Figure 6-10 shows a stacked column chart generated from the 
data in A2:E6. Notice that the columns are stacked, beginning with the first data series (Region 1) on 
the bottom. You may prefer to stack the columns in the order in which the data appears. To do so, 
you need to change the plot order.

Figure 6-10: The plot order of this chart doesn’t correspond to the order of the data.

After changing the plot order of the series, the chart now appears as in Figure 6-11.

www.it-ebooks.info

http://www.it-ebooks.info/


Chapter 6: Working with Chart Series 121

Figure 6-11: After changing the plot order, the stacked columns correspond to the order of the data.

Charting a Noncontiguous Range
Most of the time, a chart series consists of a contiguous range of cells. But Excel does allow you to 
plot data that isn’t in a contiguous range. Figure 6-12 shows an example of a noncontiguous series. 
This chart displays monthly data for the first and fourth quarters. The data in this single series is con-
tained in rows 2:4 and 11:13. Notice that the category labels display Jan, Feb, Mar, Oct, Nov, and Dec.

Figure 6-12: This chart uses data in a noncontiguous range.

The SERIES formula for this series is as follows:

=SERIES(‘Figure 6-12’!$B$1,(‘Figure 6-12’!$A$2:$A$4,’Figure 

6-12’!$A$11:$A$13),(‘Figure 6-12’!$B$2:$B$4,’Figure 6-12’!$B$11:$B$13),1)
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The first argument is omitted, so Excel uses the default series name. The second argument specifies 
six cells in column A as the category labels. The third argument specifies six corresponding cells in 
column B as the data values. Note that the range arguments for the noncontiguous ranges are dis-
played in parentheses, and each subrange is separated by a comma.

Note 	

When a series uses a noncontiguous range of cells, Excel doesn’t display the range high-
lights when the series is selected. Therefore, the only way to modify the series is to use 
the Select Data Source dialog box or to edit the SERIES formula manually.

Using Series on Different Sheets
Typically, data to be used on a chart resides on a single sheet. Excel, however, does allow a chart  
to use data from any number of worksheets, and the worksheets don’t need to be in the same  
workbook.

Normally, you select all the data for a chart before you create the chart. But if your chart uses data 
from different worksheets, you need to create an empty chart and then add the series (see the sec-
tion “Adding a New Series to a Chart,” earlier in this chapter).

Figure 6-13 shows a chart that uses data from two other worksheets. Each of the three worksheets is 
shown in a separate window.

Figure 6-13: This chart uses data from different worksheets.

The SERIES formulas for this chart are as follows:

=SERIES(Region1!$B$1,Region1!$A$2:$A$7,Region1!$B$2:$B$7,1)
=SERIES(Region2!$B$1,Region1!$A$2:$A$7,Region2!$B$2:$B$7,2)
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Another way to handle data in different worksheets is to create a summary range in a 
single worksheet. This summary range consists of simple formulas that refer to the data 
in other sheets. Then you can create a chart from the summary range.

Handling Missing Data
Sometimes, data that you use in a chart may lack one or more data points. Excel offers the following 
ways to handle the missing data:

➤	 Ignore the missing data. Plotted data series will have a gap.

➤	 Treat the missing data as zero values.

➤	 Interpolate the missing data (for line and scatter charts only).

For some reason, Excel makes these options rather difficult to locate. The Ribbon doesn’t contain 
these options, and you don’t specify these options in the Format Data Series dialog box. Rather, you 
must follow these steps:

	 1.	 Select your chart.

	 2.	 Choose Chart Tools➜Design➜Data➜Select Data to display the Select Data Source  
dialog box.

	 3.	 In the Select Data Source dialog box, click the Hidden and Empty Cells button. Excel displays 
the dialog box shown in Figure 6-14.

	 4.	 Choose the appropriate option and click OK.

Figure 6-14: Use the Hidden and Empty Cell Settings dialog box to specify how to handle missing data.

The setting that you choose applies only to the active chart and applies to all series in the chart. In 
other words, you can’t specify a different missing data option for different series in the same chart. In 
addition, not all chart types support all missing data options.

Figure 6-15 shows three charts that depict the three missing data options. The chart shows tempera-
ture readings at one-hour intervals, and four data points are missing. The “correct” missing data 
option depends on the message that you want to convey. In the top chart, the missing data is obvi-
ous because of the gaps in the line. In the middle chart, the missing data is shown as zero — which is 

Tip
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clearly misleading. In the bottom chart, the missing data is interpolated. Because of the time-based 
and relatively smooth nature of the data, interpolating the missing data may be an appropriate 
choice.

Figure 6-15: These three charts depict the three ways to present missing data in a chart.

Tip 	

For line charts, you can force Excel to interpolate missing values by placing =NA() in the 
empty cells. Those cell values will be interpolated, regardless of the missing data option 
that is in effect for the chart. For other charts, =NA() is interpreted as zero.

Controlling a Data Series by Hiding Data
By default, Excel doesn’t plot data that is in a hidden row or column. You can sometimes use this to 
your advantage because it’s an easy way to control what data appears in the chart.

Figure 6-16 shows a line chart that plots 365 days of data stored in a table (created by choosing 
Insert➜Tables➜Table). Figure 6-17 shows the same chart after I applied a filter to the table. The filter 
hides all rows except those in which the month is September.

In some cases, when you’re working with outlines or filtered tables (both of which use hidden rows), 
you may not like the idea that hidden data is removed from your chart. To override this, activate the 
chart and choose Chart Tools➜Design➜Data➜Select Data to display the Select Data Source dialog 
box. Click the Hidden and Empty Cells button and select the Show Data in Hidden Rows and Columns 
check box.
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Figure 6-16: A line chart that uses data in a table.

Figure 6-17: After filtering the table, the chart shows only data for September.

Unlinking a Chart Series  
from Its Data Range
Typically, an Excel chart uses data stored in a range. Change the data in the range, and the chart 
updates automatically. In some cases, you may want to “unlink” the chart from its data ranges and 
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produce a static chart — a chart that never changes. For example, if you plot data generated by vari-
ous what-if scenarios, you may want to save a chart that represents some baseline so that you can 
compare it to other scenarios. You can create such a chart in the following ways:

➤	 Convert the chart to a picture.

➤	 Convert the range references to arrays.

Converting a chart to a picture
To convert a chart to a static picture, follow these steps:

	 1.	 Create the chart as usual and make any necessary modifications.

	 2.	 Click the chart to activate it.

	 3.	 Choose Home➜Clipboard➜Copy (or press Ctrl+C).

	 4.	 Click in any cell to deselect the chart.

	 5.	 Choose Home➜Clipboard➜Paste➜Picture.

The result is a picture of the original chart. This picture can be edited as a picture, but not as a chart. 
In other words, you can no longer modify properties such as chart type, data labels, and so on.

When you select such a picture, you see Excel’s Picture Tools➜Format tab. Figure 6-18 shows a few 
examples of built-in formatting options applied to a picture of a chart.

Figure 6-18: After converting a chart to a picture, you can apply various types of formatting to the picture.
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Converting a range reference to arrays
The other way to unlink a chart from its data is to convert the SERIES formula range references to 
arrays. Figure 6-19 shows an example of a pie chart that doesn’t use data stored in a worksheet. 
Rather, the chart’s data is stored directly in the SERIES formula, which is as follows:

=SERIES(,{“Work”,”Sleep”,”Drive”,”Eat”,”Other”},{9,7,2.5,3,2.5},1)

Figure 6-19: This chart is not linked to a data range.

The first argument, the series name, is omitted. The second argument consists of an array of five text 
strings. Notice that each array element appears within quotation marks and is separated by a comma. 
The array is enclosed in braces. The chart’s data is stored as another array (the third argument).

This chart was originally created by using data stored in a range. Then the SERIES formula was 
delinked from the range, and the original data was deleted. The result is a chart that doesn’t rely on 
data stored in a range.

Follow these steps to convert the range references in a SERIES formula to arrays:

	 1.	 Create the chart as usual.

	 2.	 Click the chart series.

		  The SERIES formula appears in the Formula bar.

	 3.	 Click inside the Formula bar.

	 4.	 Press F9.

	 5.	 Press Enter, and the range references are converted to arrays.
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Repeat this procedure for each series in the chart. This method of unlinking a chart series (as 
opposed to creating a picture) enables you to continue to edit the chart and apply formatting. Note 
that you can also convert just a single argument to an array. Highlight the argument in the SERIES 
formula and press F9.

Note 	

Excel imposes a 1,024-character limit to the length of a SERIES formula, so this tech-
nique doesn’t work if a chart series contains a large number of values or category labels.

Working with Multiple Axes
An axis is a chart element that contains category or value information for a series. A chart can use 
zero, two, three, or four axes, and any or all of them can be hidden if desired.

Pie charts and doughnut charts have no axes. Common chart types, such as a standard column or 
line chart, use a single category axis and a single value axis. If your chart has at least two series — and 
it’s not a 3-D chart — you can create a secondary value axis. Each series is associated with either the 
primary or the secondary value axis. Why use two value axes? Two value axes are most often used 
when the data being plotted in a series varies drastically in scale from the data in another series.

Creating a secondary value axis
Figure 6-20 shows a line chart with two data series: Income and Profit Margin. Compared to the 
Income values, the Profit Margin numbers (represented by squares) are so small that they barely 
show up on the chart. This is a good candidate for a secondary value axis.

Figure 6-20: The values in the Profit Margin series are so small that they aren’t visible in the chart.
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To add a secondary value axis, follow these steps:

	 1.	 Select the Profit Margin series on the chart.

	 2.	 Press Ctrl+1 to display the Format Data Series dialog box.

	 3.	 In the Format Data Series dialog box, click the Series Options tab.

	 4.	 Choose the Secondary Axis option.

A new value axis is added to the right side of the chart, and the Profit Margin series uses that value 
axis. Figure 6-21 shows the dual-axis chart.

Figure 6-21: Using a secondary value axis for the Profit Margin series.

Creating a chart with four axes
Very few situations warrant a chart with four axes. The problem, of course, is that using four axes 
almost always causes the chart to be difficult to understand. An exception is scatter charts. Figure 
6-22 shows a scatter chart that has two series, and the series vary quite a bit in magnitude on both 
dimensions. If the objective is to compare the shape of the lines, this chart doesn’t do a very good job 
because most of the chart consists of white space. Using four axes might solve the problem.

Figure 6-22: The two series vary in magnitude.
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Follow these steps to add two new value axes for this scatter chart:

	 1.	 Select the Group B series.

	 2.	 Press Ctrl+1 to display the Format Data Series dialog box.

	 3.	 In the Format Data Series dialog box, click the Series Options tab.

	 4.	 Choose the Secondary Axis option.

		  At this point, each of the series has its own y-value axis (one on the left, one on the right), but 
they share a common x-value axis.

	 5.	 Choose Chart Tools➜Layout➜Axes➜Secondary Horizontal Axis➜Show Default Axis.

		  Note that this Ribbon command is available only if you’ve assigned a series to the  
secondary axis.

Figure 6-23 shows the result. The Group B series uses the left and bottom axes, and the Group A 
series uses the right and top axes. The chart also has four axis titles to clarify the axes for each group. 
If necessary, the scales for each axis can be adjusted separately.

Figure 6-23: This chart uses four value axes.
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7
Formatting and 
Customizing Charts
In This Chapter

●	 Getting an overview of chart formatting

●	 Formatting fill and borders

●	 Formatting chart background elements

●	 Working with chart titles

●	 Working with legends, data labels, gridlines, and data tables

●	 Understanding chart axes

●	 Formatting 3-D charts

If you create a chart for your own use, spending a lot of time on formatting and customizing the 
chart may not be worth the effort. But if you want to create the most effective chart possible, or if you 
need to create a chart for presentation purposes, you will want to take advantage of the additional 
customization techniques available in Excel.

This chapter discusses the ins and outs of formatting and customizing your charts. It’s easy to 
become overwhelmed with all the chart customization options. However, the more you work with 
charts, the easier it becomes. Even advanced users tend to experiment a great deal with chart cus-
tomization, and they rely heavily on trial and error — a technique that’s highly recommend.

Chart Formatting Overview
Customizing a chart involves changing the appearance of its elements, as well as possibly adding 
new elements to it or removing elements from it. These changes can be purely cosmetic (such as 
changing colors or modifying line widths) or quite substantial (such as changing the axis scales).
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Before you can customize a chart, you must activate it. To activate an embedded chart, click any-
where within the chart. To deactivate an embedded chart, just click anywhere in the worksheet or 
press Esc (once or twice, depending on which chart element is currently selected). To activate a chart 
on a chart sheet, click its sheet tab.

Tip 	

If you press Ctrl while you activate an embedded chart, the chart is selected as an object. 
In fact, you can select multiple charts using this technique. When a group of charts is 
selected, you can move and resize them all at once. In addition, the tools in the Drawing 
Tools➜Format➜Arrange group are available. For example, you can align the selected 
charts vertically or horizontally.

Selecting chart elements
Modifying a chart is similar to everything else you do in Excel: First you make a selection (in this case, 
select a chart element); then you issue a command to do something with the selection.

You can select only one chart element at a time. For example, if you want to change the font for  
two axis labels, you must work on each label separately. The exceptions to the single-selection  
rule are elements that consist of multiple parts, such as gridlines. Selecting one gridline selects  
them all.

Excel provides three ways to select a particular chart element:

➤	 Use the mouse

➤	 Use the keyboard

➤	 Use the Chart Elements drop-down list

These selection methods are described in the following sections.

Selecting with the mouse
To select a chart element with your mouse, just click the element.

Tip 	

To ensure that you’ve selected the chart element that you intended to select, check  
the name that’s displayed in the Chart Elements dropdown found on the far left of the 
Chart Tools➜Format tab. The Chart Elements dropdown displays the name of the 
selected chart element, and you can also use this control to select a particular  
element. See the “Selecting with the Chart Elements dropdown” section later in this  
chapter.
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When you move the cursor over a selected chart, a small “chart tip” displays the name of the chart 
element under the mouse pointer. When the mouse pointer is over a data point, the chart tip also 
displays the series, category, and value of the data point. If you find these chart tips annoying,  
you can turn them off in the Advanced tab in the Excel Options dialog box. In the Chart section,  
you’ll find two check boxes: Show Chart Element Names on Hover, and Show Data Point Values on 
Hover.

Some chart elements (such as a chart series, a legend, and data labels) consist of multiple items. For 
example, a chart series is made up of individual data points. To select a single data point, you need to 
click twice: First click the series to select it; then click the specific element within the series (for exam-
ple, a column or a line chart marker). Selecting an individual element enables you to apply formatting 
only to a particular data point in a series. This might be useful if you’d like one marker in a line chart 
to stand out from the others.

Note 	

If you find that some chart elements are difficult to select with the mouse, you’re  
not alone. If you rely on the mouse for selecting a chart element, it may take several 
clicks before the desired element is actually selected. And in some cases, selecting  
a particular element with the mouse is almost impossible. Fortunately, Excel provides 
other ways to select a chart element, and it’s worth your while to be familiar with  
them.

Selecting with the keyboard
When a chart is active, you can use the up- and down-arrow keys on your keyboard to cycle among 
the chart’s elements. Again, keep your eye on the Chart Elements control to verify which element is 
selected.

When a chart series is selected, use the left- and right-arrow keys to select an individual data point 
within the series. Similarly, when a set of data labels is selected, you can select a specific data label by 
using the left- or right-arrow key. And when a legend is selected, you can select individual elements 
within the legend by using the left- or right-arrow keys.

Selecting with the Chart Elements dropdown
As noted earlier, the Chart Elements drop-down list (found on the far left of the Chart Tools➜Format 
tab) displays the name of the selected chart element. This control contains a drop-down list of all 
chart elements (excluding shapes and text boxes), so you can also use it to select a particular chart 
element.

The Chart Elements drop-down list lets you select a particular chart element from the active chart 
(see Figure 7-1). This drop-down list lists only the top-level elements in the chart. To select an individ-
ual data point within a series, for example, you need to select the series and then use one of the 
other techniques to select the desired data point.
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Figure 7-1: Use the Chart Elements drop-down list to select an element on a chart.

Note 	

When a single data point is selected, the Chart Elements control will display the name of 
the selected element, even though it’s not actually available for selection in the drop-
down list.

Common chart elements
Table 4-1 contains a list of the various chart elements that you may encounter. Note that the actual 
chart elements that are present in a particular chart depend on the chart type and on the customiza-
tions that you’ve performed on the chart.

Table 4-1 Chart Elements
Part Description

Category Axis The axis that represents the chart’s categories.

Category Axis Title The title for the category axis.

Chart Area The chart’s background.

Chart Title The chart’s title.

Data Label A data label for a point in a series. The name is preceded by the series and the 
point. Example: Series 1 Point 1 Data Label.

Data Labels Data labels for a series. The name is preceded by the series. Example: Series 1 
Data Labels.

Data Table The chart’s data table.

Display Units Label The units label for an axis.

Up/Down Bars Vertical bars in a line chart or stock market chart.

Drop Lines Lines that extend from each data point downward to the axis (line and area 
charts only).

Error Bars Error bars for a series. The name is preceded by the series. Example: Series 1 
Error Bars.
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Part Description

Floor The floor of a 3-D chart.

Gridlines A chart can have major and minor gridlines for each axis. The element is named 
using the axis and the type of gridlines. Example: Primary Vertical Axis Major 
Gridlines.

High-Low Lines Vertical lines in a line chart or stock market chart.

Legend The chart’s legend.

Legend Entry One of the text entries inside a legend.

Plot Area The chart’s plot area — the actual chart, without the legend.

Point A point in a data series. The name is preceded by the series name. Example: 
Series 1 Point 2.

Secondary Category Axis The second axis that represents the chart’s categories.

Secondary Category Axis 
Title

The title for the secondary category axis.

Secondary Value Axis The second axis that represents the chart’s values.

Secondary Value Axis Title The title for the secondary value axis.

Series A data series.

Series Axis The axis that represents the chart’s series (3-D charts only).

Series Lines A line that connects a series in a stacked column or stacked bar chart.

Trendline A trend line for a data series.

Trendline Equation The equation for a trend line.

Value Axis The axis that represents the chart’s values. There also may be a Secondary 
Value Axis.

Value Axis Title The title for the value axis.

Walls The walls of a 3-D chart only (except 3-D pie charts).

UI choices for formatting
When a chart element is selected, you have some choices as to which UI method you can use to  
format the element:

➤	 The Ribbon

➤	 The mini toolbar

➤	 The Format dialog box

Formatting by using the Ribbon
The controls in the Chart Tools➜Format tab are used to change the appearance of the selected  
chart element. For example, if you would like to change the color of a series in a column chart, one 
approach is to use one of the predefined styles in the Chart➜Tools➜Format➜Shape Styles group.
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For a bit more control, follow these steps:

	 1.	 Click the series to select it.

	 2.	 Choose Chart Tools➜Format➜Shape Styles➜Shape Fill, and select a color.

	 3.	 Choose Chart Tools➜Format➜Shape Styles➜Shape Outline, and select a color for the out-
line of the columns. 

		  You can also modify the outline width and the type of dashes (if any).

	 4.	 Choose Chart Tools➜Format➜Shape Styles➜Shape Effects, and add one or more effects to 
the series.

Note that you can modify the Shape Fill, Shape Outline, and Shape Effects for almost every element 
in a chart.

Here’s one way to change the formatting of a chart’s title so that the text is white on a black background:

	 1.	 Click the chart title to select it.

	 2.	 Choose Chart Tools➜Format➜Shape Styles➜Shape Fill, and select black.

	 3.	 Choose Chart Tools➜Format➜WordArt Styles➜Text Fill, and select white.

Notice that some of the controls in the Home➜Font and Home➜Alignment groups are also available 
when a chart element is selected. An alternate way of changing a chart’s title to white on black is as 
follows:

	 1.	 Click the chart title to select it.

	 2.	 Choose Home➜Font➜Fill Color, and select black.

	 3.	 Choose Home➜Font➜Font Color, and select white.

Note 	

The Ribbon commands do not contain all possible formatting options for chart ele-
ments. In fact, the Ribbon controls contain only a small subset of the chart formatting 
commands. For optimal control, you need to use the Format dialog box (discussed later 
in this chapter).

Formatting by using the Mini Toolbar
When you right-click a chart element, Excel displays its shortcut menu, with the Mini Toolbar on top. 
Figure 7-2 shows the Mini Toolbar that appears when you right-click a chart title. Use the Mini 
Toolbar to make formatting changes to the selected element. Note that the Mini Toolbar also works if 
you’ve selected only some of the characters in the chart element. In such a case, the text formatting 
applies only to the selected characters.
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Figure 7-2: You can use the Mini Toolbar to format chart elements.

A few of the common keystroke combinations also work when a chart element that contains text is 
selected — specifically: Ctrl+B (bold), Ctrl+I (italic), and Ctrl+U (underline).

Formatting by using the Format dialog box
For complete control over text element formatting, use the Format dialog box. Each chart element 
has a unique Format dialog box, and the dialog box has several tabs.

You can access the Format dialog box by using either of the following methods:

➤	 Select the chart element and press Ctrl+1.

➤	 Right-click the chart element and choose Format xxxx from the shortcut menu (where xxxx is 
the chart element’s name).

In addition, some of the Ribbon controls contain a menu item that, when clicked, opens the Format 
dialog box and displays a specific tab. For example, when you choose Chart Tools➜Format➜Shape 
Outline➜Weight, one of the options is More Lines. Click this option, and Excel displays the Format 
dialog box with the Border Styles tab selected. This tab enables you to specify formatting that’s not 
available on the Ribbon.

Figure 7-3 shows an example of a Format dialog box. Specifically, the figure shows the Legend 
Options tab of the Format Legend dialog box. As noted, each chart element has a different Format 
dialog box, which shows options that are relevant to the chart element.

Note 	

The Format dialog box is a stay-on-top dialog box. In other words, you can keep this dia-
log box open while you’re working on a chart. It’s not necessary to close the dialog box 
to see the changes on the chart. In some cases, however, you need to activate a different 
control in the dialog box to see the changes you’ve specified. Usually, pressing Tab will 
move to the next control in the dialog box and force Excel to update the chart.

www.it-ebooks.info

http://www.it-ebooks.info/


Part II: Introducing Charts into Your Dashboards138

Figure 7-3: Each chart element has its own Format dialog box. This dialog box controls formatting  
for the chart’s legend.

Adjusting Fills and Borders:  
General Procedures
Many of the Format dialog boxes for chart elements include a tab named Fill as well as other tabs that deal 
with border formatting. These tabs are used to change the interior and border of the selected element.

About the Fill tab
Figure 7-4 shows the Fill tab in the Format Chart Area dialog box when the Solid Fill option is 
selected. The controls on this tab change, depending on which option is selected.

Figure 7-4: The Fill tab of the Format Chart Area dialog box.

Although the Fill tabs of the various Format dialog boxes are similar, they are not identical. 
Depending on the chart element, the dialog box may have additional options that are relevant for 
the selected item. 
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Not all chart elements can be filled. For example, the Format Major Gridlines dialog box does not 
have a Fill tab because filling a line makes no sense. You can, however, change the gridline format-
ting by using the tabs that are displayed.

The main Fill tab options are as follows:

➤	 No Fill: Makes the chart element transparent.

➤	 Solid Fill: Displays a color selector so that you can choose a single color. You can also specify 
the transparency level for the color.

➤	 Gradient Fill: Displays several additional controls that allow you to select a preset gradient 
or construct your own gradient. A gradient consists of from two to ten colors that are 
blended together in various ways. You have literally millions of possibilities. 

➤	 Picture or Texture Fill: Enables you to select from 24 built-in textures, choose an image file, 
or use clip art for the fill. This feature can often be useful in applying special effects to a data 
series. See the section “Formatting Chart Series,” later in this chapter.

➤	 Pattern Fill: Lets you specify a two-color pattern. This option is not available in Excel 2007.

➤	 Automatic: Sets the fill to the default color. All chart elements start out with Automatic fill.

As a general rule, it’s best to use these fill options sparingly. Using too much fill formatting can sub-
due your data, hindering the chart’s ability to communicate the data. For example, Figure 7-5 shows 
a very ugly chart with various types of fill formatting applied. The column data series uses clip art, in 
the form of stacked monkeys. The plot area uses a texture, the chart area uses a gradient fill, and the 
axis labels use a solid black fill.

Figure 7-5: Using too many fill types can quickly lead to ugly charts that are difficult to read.
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Formatting borders
A border is the line around an object. Excel offers four general choices for formatting a border:

➤	 No Line: The chart element has no line.

➤	 Solid Line: The chart element has a solid line. You can specify the color, the transparency, 
and a variety of other settings.

➤	 Gradient Line: The chart element has a line that consists of a color gradient.

➤	 Automatic: The default setting. Excel decides the border settings automatically.

Figure 7-6 shows the Border Styles tab of the Format Chart Area dialog box. If you explore this dialog 
box, you’ll soon discover that a border can have a huge number of variations. Keep in mind that all 
settings are not available for all chart elements. For example, the Arrow Settings are disabled when a 
chart element that can’t display an arrow is selected.

Figure 7-6: Some of the settings available for a chart element border.

Formatting Chart Background Elements
Every chart has two key components that play a role in the chart’s overall appearance:

➤	 The chart area: The background area of the chart object

➤	 The plot area: The area (within the chart area) that contains the actual chart

The default colors of the chart area and the plot area depend on which chart style you choose from 
the Chart Tools➜Design➜Chart Styles gallery.
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Working with the chart area
The chart area is an object that contains all other elements on the chart. You can think of it as a 
chart’s master background. The chart area is always the same size as the chart object (the chart’s  
container).

Tip 	

When the chart area is selected, you can adjust the font for all the chart elements that 
display text. In other words, if you want to make all text in a chart 12 point, select the 
chart area and then apply the font formatting.

In some cases, you may want to make the chart area transparent so that the underlying worksheet 
shows through. Figure 7-7 shows a column chart with a transparent chart area. You can accomplish 
this by setting the chart area’s fill to No Fill, or set it to a Solid Fill and make it 100% transparent.

Figure 7-7: The chart area for this chart is transparent. The plot area, however, contains a fill color.

Working with the plot area
The plot area is the part of the chart that contains the actual chart. The plot area contains all chart 
elements except the chart title and the legend.

Although the plot area consists of elements such as axes and axis labels, when you change the fill of 
the plot area, these “outside” elements are not affected.

Tip 	

If you set the Fill option to No Fill, the plot area will be transparent. Therefore, the color 
and patterns applied to the chart area will show through. You can also set the plot area 
to a solid color and adjust the Transparency setting so that the chart area shows 
through partially.

In some situations, you may want to insert an image into the plot area. To do so, use the Fill tab of 
the Format Plot Area dialog box, and choose the Picture or Texture Fill option. The image can come 
from a file, the Clipboard, or clip art. Figure 7-8 shows a column chart that uses a graphic in the plot 
area. In addition, the column series is partially transparent.
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Figure 7-8: The plot area for this chart uses a graphic image.

To reposition the plot area within the chart area, select the plot area and then drag a border to move 
it. To change the size of the plot area, drag one of the corner “handles.” If you like, you can expand 
the plot area so that it fills the entire chart area.

You’ll find that different chart types vary in how they respond to changes in the plot area dimen-
sions. For example, you cannot change the relative dimensions of the plot area of a pie chart or a 
radar chart (it’s always square). But with other chart types, you can change the aspect ratio of the plot 
area by changing either the height or the width.

Copying chart formatting
You created a killer chart and spent hours customizing it. Now you need to create another one just 
like it. What are your options? You have several choices:

●	 Copy the formatting. Create a standard chart with the default formatting. Then select your 
original chart and press Ctrl+C. Click your new chart and choose Home➜Clipboard➜ 

Paste➜Paste Special. In the Paste Special dialog box, select Formats. 
●	 Copy the chart; change the data sources. Select the original chart and press Ctrl+C. Then, 

activate any cell and press Ctrl+V. This creates an exact copy of your chart. Activate a series in 
the new chart and drag the range highlights to the new ranges (and repeat for each series). 
Or, you can choose Chart Tools➜Design➜Data➜Select Data to display the Select Data Source 
dialog box.

●	 Create a chart template. Select your chart and then choose Chart Tools➜Design➜Type➜ 

Save as Template. In the Save Chart Template dialog box, provide a descriptive filename. 
When you create your next chart, choose Insert➜Charts➜Other Charts➜All Chart Types, and 
select the Templates tab. Then, specify the template you created.
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Also, be aware that the size of the plot area can be changed automatically when you adjust other  
elements of your chart. For example, if you add a legend or title to a chart, the size of the plot area 
may be reduced to accommodate the legend.

Tip 	

Remember to think of the purpose and utility of your chart before adding images to  
the plot area. Images may be appropriate for charts used as marketing or sales tools 
where visual components and eye candy help attract attention. Although in an analytical 
environment where the data is the primary product of your chart, there is no be a need to 
dress up your data with superfluous images.

Formatting Chart Series
Making a few simple formatting changes to a chart series can make a huge difference in the readabil-
ity of your chart. When you create a chart, Excel uses its default colors and marker styles for the series. 
In many cases, you’ll want to modify these colors or marker styles for clarity (basic formatting). In 
other cases, you may want to make some drastic changes for impact.

You can apply formatting to the entire series or to a single data point within the series — for exam-
ple, make one column a different color to draw attention to it.

On the Web	

This workbook, named Chapter 7 Samples.xlsx, is available at www.wiley.com/
go/exceldr with the other example files for this book. 

Basic series formatting
Basic series formatting is very straightforward: Just select the data series on your chart and use the 
tools in the Chart Tools➜Format➜Shape Styles group to make changes. For more control, press 
Ctrl+1 and use the Format Data Series dialog box.

Using pictures and graphics for series formatting
You can add a picture to several chart elements, including data markers on line charts and series  
fills for column, bar, area, bubble, and filled radar charts. Figure 7-9 shows a column chart that uses  
a clip art image of a car. The picture was added using the Fill tab of the Format Data Series dialog  
box (select the Picture or Texture Fill option; then click the Clip Art button to select the image). In 
addition, the original image is sized so that each car represents approximately 20 units.

Figure 7-10 shows another example. The data markers in this line chart display a shape that was 
inserted in the worksheet and then copied to the Clipboard. Select the line series and press Ctrl+V  
to paste the shape.
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Figure 7-9: This column chart uses a clip art image.

You can also use the Marker Fill tab of the Format Data Series dialog box to specify Picture or Texture 
Fill. However, the result is very different. If you use the Clipboard button to paste the copied shape, 
the pasted image will fill the existing marker (not replace it). You’ll probably need to increase the 
marker size, and also hide the marker borders.

Figure 7-10: The data markers use a shape that was copied to the Clipboard.

Tip 	

Again, the purpose and utility of your chart should dictate whether pictures and graphics 
are appropriate. Charts for sales presentations, for example, can benefit from pictures and 
graphics given that visual enhancements can increase the possibility of prospective buy-
ers paying attention to you. But in boardroom presentations where data is king, images 
will just get in the way. Think of it as selecting the right outfit for the right occasion. You 
wouldn’t give a serious a speech in a Roman general’s uniform. How well will you get your 
point across when your audience is thinking, “What’s the deal with Tiberius”?
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Additional series options
Chart series offer a number of additional options. These options are located in the Series Options tab 
of the Format Data Series dialog box. The set of options varies, depending on the chart type of the 
series. In most cases, the options are self-explanatory. But, if you are unsure about a particular series 
option, try it! If the result isn’t satisfactory, change the setting to its original value or press Ctrl+Z to 
undo the change.

Figure 7-11 shows an example of modifying series settings. The chart uses a Series Overlap of 50% 
and a Gap Width of 28%.

Figure 7-11: A column chart, after adjusting the Series Overlap and Gap Width settings

About those fancy effects
Excel 2007 introduced several new formatting options, which are known as effects. Access these 
effects by choosing Chart Tools➜Format➜Shape Styles➜Shape Effects. For more options, use the 
Format dialog box. Note that not all effects work with all chart elements.

Following is a general description of the effect types:

●	 Shadow: Adds a highly customizable shadow to the selected chart element. Choose from a 
number of preset shadows, or create your own using the Shadow tab of the Format dialog 
box. Shadows, when used tastefully, can improve the appearance of a chart by adding depth.

●	 Glow: Adds a color glow around the element. Charts are rarely improved by adding a glow to 
any element.

●	 Soft Edges: Makes the edges of the element softer. Extreme settings make the element 
appear to be out of focus, become smaller, or even disappear.

●	 Bevel: Adds a 3-D bevel look to the element. This effect is highly customizable, and you can 
use it to create a frame for your chart (see the accompanying figure).

●	 3-D Rotation: This effect does not work with any chart elements.

continued

www.it-ebooks.info

http://www.it-ebooks.info/


Part II: Introducing Charts into Your Dashboards146

Working with Chart Titles
A chart can have as many as five different titles:

➤	 Chart title

➤	 Category axis title

➤	 Value axis title

➤	 Secondary category axis title

➤	 Secondary value axis title

The number of titles depends on the chart type. For example, a pie chart supports only a chart title 
because it has no axes. Figure 7-12 shows a chart that contains four titles: the chart title, the horizon-
tal category axis title, the vertical value axis title, and the secondary vertical axis title.

Figure 7-12: This chart has four titles.

continued

The best advice regarding these effects is to use them sparingly with charts. Generally, a chart’s for-
matting shouldn’t draw attention away from the point you’re trying to make with the chart.
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Adding titles to a chart
To add a chart title to a chart, activate the chart and click the Chart Elements button next to the chart. 
This will expand a menu of chart elements you can add to your chart. Place a check next to Chart 
Title.

To add axis titles to a chart, simply place a check next to the Axis Titles option. Keep in mind that the 
options include only those that are appropriate for the chart. For example, if the chart doesn’t have a 
secondary value axis, you don’t have an option to add a title to the nonexistent axis.

Note 	

Contrary to what you might expect, you cannot resize a chart title. When you select a 
title, it displays the characteristic border and handles — but the handles cannot be 
dragged to change the size of the object. The only way to change the size is to change 
the size of the font used in the title. For more control over a chart’s title, you can use a 
text box instead of an official title.

Changing title text
When you add a title to a chart, Excel inserts generic text to help you identify the title. To edit the text 
used in a chart title, click the title once to select it; then click a second time inside the text area. If the 
title has a vertical orientation, things get a bit tricky because you need to use the up- and down-
arrow keys rather than the left- and right- arrow keys.

Tip
	

For lengthy titles, Excel handles the line breaks automatically. To force a line break in 
the title, press Enter. To add a line break within existing title text, press Ctrl+Shift+Enter.

Formatting title text
Unfortunately, Excel does not provide a “one-stop” place to change all aspects of a chart title. The 
Format Chart Title dialog box provides options for changing the fill, border, shadows, 3-D format,  
and alignment. If you want to change anything related to the font, you need to use the Ribbon (or 
right-click and use the mini toolbar). Yet another option is to right-click the chart element and 
choose Font from the shortcut menu. This displays the Font dialog box, with options that aren’t  
available elsewhere. For example, the Font dialog box lets you control the character spacing of the 
text.

Most of the font changes you make will use the tools in the Home➜Font group. You may be tempted 
to use the controls in the Chart Tools➜Format➜WordArt Styles group, but these controls are  
primarily for special effects.

Tip 	

You can easily modify the formatting for individual characters within a title. Select the 
title, highlight the characters that you want to modify, and apply the formatting. The 
formatting changes you make will affect only the selected characters.
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Linking title text to a cell
When you create a chart, you might like to have some of the chart’s text elements linked to cells. That 
way, when you change the text in the cell, the corresponding chart element updates. And, of course, 
you can even link chart text elements to cells that contain a formula. For example, you might link the 
chart title to a cell that contains a formula that returns the current date.

You can create a link to a cell for the chart title or any of the axis titles. Follow these steps:

	 1.	 Select the chart element that will contain the cell link. Make sure that the text element itself 
is selected (don’t select text within the element). 

	 2.	 Click the Formula bar.

	 3.	 Type an equal sign (=).

	 4.	 Click the cell that will be linked to the chart element.

	 5.	 Press Enter.

Figure 7-13 shows a chart that has links for the following elements: chart title, the vertical axis title, 
and the horizontal axis title.

Figure 7-13: The titles in this chart are linked to cells.

Adding free-floating text to a chart
Text in a chart is not limited to titles. In fact, you can add free-floating text anywhere you want by 
inserting a text box into the chart. To do so, follow these steps:

	 1.	 Select the chart.

	 2.	 Choose Insert➜Text Box.
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Working with a Chart’s Legend
A chart legend identifies the series in the chart and consists of text and keys. A key is a small graphic 
image that corresponds to the appearance of the corresponding chart series. The text displayed in a 
legend corresponds to the series names. The order of the items within a legend varies, depending on 
the chart type.

	 3.	 Click and drag within the chart to create the text box.

	 4.	 Start typing the text.

You can click and drag the text box to change its size or location. And when the text box is selected, 
you can access the formatting tools using the controls on the Drawing Tools➜Format tab.

The accompanying figure shows a chart with a text box that contains quite a bit of formatted text. 
The chart’s plot area was reduced in size to accommodate the text box.

There’s nothing special about a text box. A text box is actually a rectangular shape object that  
contains text. You can change it to a different shape, if you like. Select the text box and choose 
Drawing Tools➜ Format➜ Insert Shapes➜ Edit Shape ➜Change Shape, and select a shape from the 
list. The Format Shape dialog box gives you lots of options for changing the look of the text box.

If you would like to link the text box to a cell, follow these steps:

	 1.	 Select the text box.

	 2.	 Click the Formula bar.

	 3.	 Type an equal sign (=).

	 4.	 Click the cell that will be linked to the chart element.

After you create the link, the text box will always display the contents of the cell it’s linked to.

Some people prefer to use a text box in place of a chart’s title because a text box provides much 
more control over formatting. When a text box is selected, its Format Shape dialog box provides 
several additional options, compared to the Format Chart Title dialog box.
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Adding or removing a legend
To add a legend to a chart, activate the chart and click the Chart Elements button next the chart. This 
will expand a menu of chart elements you can add to your chart. Place a check next to Legend.

The quickest way to remove a legend is to select it and press Delete.

Moving or resizing a legend
To move a legend, click it and drag it to the desired location. Alternatively, you can activate the chart, 
click the Chart Elements button next the chart, and then click the arrow next to the Legend option to 
choose any one of the predefined positions listed (Right, Top, Left, or Bottom). If you move a legend 
from its default position, you may want to change the size of the plot area to fill in the gap left by the 
legend. Just select the plot area and drag a border to make it the desired size.

To change the size of a legend, select it and drag any of its corners. Excel will adjust the legend  
automatically and may display it in multiple columns.

Formatting a legend
You can select an individual legend entry within a legend and format it separately. For example, you 
may want to make the text bold to draw attention to a particular data series. To select an element in 
the legend, first select the legend and then click the desired entry.

You can’t change the formatting of individual characters in a legend entry. For example, if you’d like 
the legend to display a superscript or subscript character, you’re out of luck.

When a single legend entry is selected, you can use the Format Legend Entry dialog box to format 
the entry. When a legend entry is selected, and you apply any type of formatting except text  
formatting, the formatting affects the legend key and the corresponding series. In other words, the 
appearance of the legend key will always correspond to the data series.

Note 	

You can’t use the Chart Elements drop-down list to select a legend entry. You must 
either click the item or select the legend itself, and then press the right-arrow key until 
the desired element is selected.

Changing the legend text
The legend text corresponds to the names of the series on the chart. If you didn’t include series 
names when you originally selected the cells to create the chart, Excel displays a default series name 
(Series 1, Series 2, and so on) in the legend.

To add series names, choose Chart Tools➜Design➜Select Data to display the Select Data Source  
dialog box. Select the series name and click the Edit button. In the Edit Series dialog box, type the 
series name or enter a cell reference that contains the series name. Repeat for each series that needs 
naming. Alternatively, you can edit the SERIES formula, as described in Chapter 5.
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Deleting a legend entry
For some charts, you may prefer that one or more of the data series not appear in the legend. To 
delete a legend entry, just select it and press Delete. The legend entry will be deleted, but the data 
series will remain intact.

If you’ve deleted one or more legend entries, you can restore the legend to its original state by delet-
ing the entire legend and then adding it back.

Identifying series without using a legend
Legends are appropriate for charts that have at least two series. But even then, all charts do not 
require a legend. You may prefer to identify relevant data using other methods, such as a data label, 
a text box, or a shape with text. Figure 7-14 shows a chart in which the data series are identified by 
using text in shapes, which were added to the chart using Insert➜Illustrations➜Shapes.

Figure 7-14: This chart uses shapes as an alternative to a legend.

Working with Chart Axes
As you know, charts vary in the number of axes that they use. Pie and doughnut charts have no axes. 
All 2-D charts have at least two axes, and they can have three (if you use a secondary value or cate-
gory axis) or four (if you use a secondary category axis and a secondary value axis). Three-
dimensional charts have three axes — the “depth” axis is known as the series axis.

Excel provides you with a great deal of control over the look of chart axes. To modify any aspect of an 
axis, access its Format Axis dialog box. The dialog box varies, depending on which type of axis is 
selected.

On the Web
	

This workbook, named axes.xlsx, is available at www.wiley.com/go/exceldr with 
the other example files for this book.

www.it-ebooks.info

http://www.it-ebooks.info/


Part II: Introducing Charts into Your Dashboards152

All aspects of axis formatting are covered in the sections that follow.

Value axis versus category axis
Before getting into the details of formatting, it’s important to understand the difference between a 
category axis and a value axis. A category axis displays arbitrary text, whereas a value axis displays 
numerical intervals. Figure 7-15 shows a simple column chart with two series. The horizontal cate-
gory axis displays labels that represent the categories. The vertical value axis, on the other hand, is a 
value axis which has a numerical scale.

Figure 7-15: The category axis displays arbitrary labels, whereas the value axis displays a numerical scale.

In this example, the category labels happen to be text. Alternatively, the categories could be num-
bers. Figure 7-16 shows the same chart after replacing the category labels with numbers. Even 
though the chart becomes meaningless, it should be clear that the category axis does not display a 
true numeric scale. The numbers displayed are completely arbitrary, and the chart itself was not 
affected by changing these labels.

Figure 7-16: The category labels have been replaced with numbers — but the numbers do not function as 
numbers.
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Two of Excel’s chart types are different from the other chart types in one important respect. Scatter 
charts and bubble charts use two value axes. For these chart types, both axes represent numeric 
scales.

Figure 7-17 shows two charts (a scatter chart and a line chart) that use the same data. The data shows 
world population estimates for various years. Note that the interval between the years in column A is 
not consistent.

Figure 7-17: These charts plot the same data but present very different pictures.

The scatter chart, which uses two value axes, plots the years as numeric values. The line chart, on the 
other hand, uses a (non-numeric) category axis, and it assumes that the categories (the years) are 
equally spaced. This, of course, is not a valid assumption, and the line chart presents a very inaccu-
rate picture of the population growth: It appears to be linear, but it’s definitely not.

Cross-Ref
	

For more information about time-based axes, refer to the “Using time-scale axes” sec-
tion later in this chapter.

Value axis scales
The numerical range of a value axis represents the axis’s scale. By default, Excel automatically scales 
each value axis. It determines the minimum and maximum scale values for the axis, based on the 
numeric range of the data. Excel also automatically calculates a major unit and a minor unit for each 
axis scale. These settings determine how many intervals (or tick marks) are displayed on the axis and 
determine how many gridlines are displayed. In addition, the value at which the axis crosses the cate-
gory axis is also calculated automatically.
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You can, of course, override this automatic behavior and specify your own minimum, maximum, 
major unit, minor unit, and cross-over for any value axis. You set these specifications by right-clicking 
on the axis and selecting Format Axis. This will activate the Format Axis dialog box shown in  
Figure 7-18. Use the settings under Axis Options to customize the axis as needed.

Figure 7-18: The Axis Options tab of the Format Axis dialog box.

Note 	

A category axis does not have a scale because it displays arbitrary category names. For a 
category axis, the Axis Options tab of the Format Axis dialog box displays a number of 
other options that determine the appearance and layout of the axis.

Adjusting the scale of a value axis can dramatically affect the chart’s appearance. Manipulating the 
scale, in some cases, can present a false picture of the data. Figure 7-19 shows two line charts that 
depict the same data. The top chart uses Excel’s default axis scale values, which extend from 8,000 to 
9,200. In the bottom chart, the Minimum scale value was set to 0, and the Maximum scale value was 
set to 10,000. A casual viewer might draw two very different conclusions from these charts. The top 
chart makes the differences in the data seem more prominent. The lower chart gives the impression 
that not much change has occurred over time.

The actual scale that you use depends on the situation. There are no hard-and-fast rules regarding 
setting scale values, except that you shouldn’t misrepresent data by manipulating the chart to prove 
a point that doesn’t exist. In addition, most agree that the value axis of a bar or column chart should 
always start at zero (and even Excel follows that rule).
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Figure 7-19: These two charts show the same data, but they use different value axis scales.

If you’re preparing several charts that use similarly scaled data, keeping the scales constant across all 
charts facilitates comparisons across charts. The charts in Figure 7-20 show the distribution of 
responses for two survey questions. For the top chart, the value axis scale ranges from 0% to 50%. 
For the bottom chart, the value axis scale extends from 0% to 35%. Because the same scale was not 
used on the value axes, however, comparing the responses across survey items is difficult.

Figure 7-20: These charts use different scales on the value axis, making a comparison between the two difficult.
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Another option in the Format Axis dialog box is Values in Reverse Order. The top chart in Figure 7-21 
uses default axis settings. The bottom chart uses the Values in Reverse Order option, which reverses 
the scale’s direction. Notice that the category axis is at the top. If you would prefer that it remain at 
the bottom of the chart, select the Maximum Axis Value option for the Horizontal Axis Crosses setting.

Figure 7-21: The bottom chart uses the Values in Reverse Order option.

If the values to be plotted cover a very large range, you may want to use a logarithmic scale for the 
value axis. A log scale is most often used for scientific applications. Figure 7-22 shows two charts. The 
top chart uses a standard scale, and the bottom chart uses a logarithmic scale. Note that the base is 
10, so each scale value in the chart is 10 times greater than the one below it. Increasing the base unit 
to 100 would result in a scale in which each tick mark value is 100 times greater than the one below.

If your chart uses very large numbers, you may want to change the Display Units settings. Figure 7-23 
shows a chart that uses very large numbers. The lower chart uses the Display Units as Millions setting, 
with the option to Show Display Units Label on Chart. Excel inserted the label “Millions,” which was 
edited to display as “Millions of Miles.”
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Figure 7-22: These charts display the same data, but the lower chart uses a logarithmic scale.

Tip 	

Another way to change the number display is to use a custom number format for the 
axis values. For example, to display the values in millions, click the Number tab of the 
Format Axis dialog box, select the Custom category, and then enter this format code:

#,##0,,
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Figure 7-23: The lower chart uses display units of millions.

An axis also has tick marks — the short lines that depict the scale units and are perpendicular to the 
axis. In the Axis Options dialog box, you can select the type of tick mark for the major units and the 
minor units. The options are as follows:

➤	 None: No tick marks

➤	 Inside: Tick marks on the inside of the axis only

➤	 Outside: Tick marks on the outside of the axis only

➤	 Cross: Tick marks on both sides of the axis

You can also control the position of the tick mark labels. The options are as follows:

➤	 None: No labels.

➤	 Low: For a horizontal axis, labels appear at the bottom of the plot area; for a vertical axis, 
labels appear to the left of the plot area.

➤	 High: For a horizontal axis, labels appear at the top of the plot area; for a vertical axis, labels 
appear to the right of the plot area.

➤	 Next to axis: Labels appear next to the axis (the default setting).
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Major tick marks are the axis tick marks that normally have labels next to them. Minor 
tick marks are between the major tick marks.

When you combine these settings with the Axis Crosses At option, you have a great deal of  
flexibility, as shown in Figure 7-24. These charts all display the same data, but the axes are formatted 
differently.

Figure 7-24: Various ways to display axis labels and crossing points.

Using time-scale axes
When you create a chart, Excel attempts to determine whether your category axis contains date or 
time values. If so, it creates a time-series chart. Figure 7-25 shows a simple example. Column A  
contains dates, and column B contains the values plotted on the column chart. The data consists  
of values for only ten dates, yet Excel created the chart with 31 intervals on the category axis. It  
recognized that the category axis values were dates, and created an equal-interval scale.

If you would like to override Excel’s decision to use a time-based category axis, you need to access 
the Axis Options tab of the Format Axis dialog box. There, you’ll discover that the default category 
axis option is Automatically Select Based on Data. Change this option to Text Axis, and the chart will 
resemble Figure 7-26. On this chart, the dates are treated as arbitrary text labels.

Note
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Figure 7-25: Excel recognizes the dates and creates a time-based category axis.

Figure 7-26: The previous chart, using a standard category axis.

Note

	

A time-scale axis option is available only for the category axis (not the value axis).

When a category axis uses dates, the Axis Options tab of the Format Axis dialog box lets you specify 
the Base Unit, the Major Unit, and the Minor Unit — each in terms of days, months, or years.

If you need a time-scale axis for smaller units (such as hours), you need to use a scatter chart. That’s 
because a date-scale axis treats all values as integers. Therefore, every time value is plotted as mid-
night of that day. Figure 7-27 shows a scatter chart that plots scheduled versus actual arrival times for 
flights. Note that both of the value axes display times, in one-hour increments.

www.it-ebooks.info

http://www.it-ebooks.info/


Chapter 7: Formatting and Customizing Charts 161

Figure 7-27: This scatter chart displays times on both value axes.

Unfortunately, Excel does not allow you to specify time values on the Axis Options tab of the Format 
Axis dialog box. If you want to override the default minimum, maximum, or major unit values, you 
must manually convert the time value to a decimal value. 

This chart uses the following scale values:

➤	 Minimum axis scale value: .25 (6:00 am)

➤	 Maximum axis scale value: .58333 (2:00 pm)

➤	 Major unit: .041666 (1:00:00)

To convert a time value to a decimal number, enter the time value into a cell. Then apply General 
number formatting to the cell. Time values are expressed as a percentage of a 24-hour day. For 
example, 12:00 noon is 0.50. 

Creating a multiline category axis
Most of the time, the labels on a category axis consist of data from a single column or row. You can, 
however, create multiline category labels, as shown in Figure 7-28. This chart uses the text in  
columns A:C for the category axis labels.
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Figure 7-28: The category axis contains labels from three columns.

When this chart was created, range A1:E10 was selected. Excel determined automatically that the first 
three columns would be used for the category axis labels.

Note
	

This type of data layout is common when you work with pivot table, and pivot charts 
often use multiline category axes. 

Removing axes
To remove an axis is to select it and then press Delete.

Figure 7-29 shows three charts with no axes displayed. Using data labels makes the value axis  
superfluous, and it is assumed that the reader understands what the horizontal axis represents.

Figure 7-29: Three line charts with no axes.
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Axis number formats
A value axis, by default, displays its values using the same number format that’s used by the chart’s 
data. You can provide a different number format, if you like, by using the Number tab of the Format 
Axis dialog box. Changing the number format for a category axis that displays text will have no 
effect.

Don’t forget about custom number formats. Figure 7-30 shows a chart that uses the following  
custom number format for the value axis:

General “ mph” 

This number format causes the text mph to be appended to each value.

Figure 7-30: The value axis uses a custom number format to provide units for the values.

Working with Gridlines
Gridlines can help the viewer determine the values represented by the series on the chart. Gridlines 
are optional, and you have quite a bit of control over the appearance of gridlines. Gridlines simply 
extend the tick marks on the axes. The tick marks are determined by the major unit and minor unit 
specified for the axis.

Note

	

Gridlines are applicable to all chart types except pie charts and doughnut charts.

Some charts look better with gridlines; others appear more cluttered. It’s up to you to decide 
whether gridlines can enhance your chart. Sometimes, horizontal gridlines alone are enough, 
although scatter charts often benefit from both horizontal and vertical gridlines. In many cases,  
gridlines will be less overpowering if you make them dashed lines with a gray color.
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Adding or removing gridlines
To add or remove gridlines, activate the chart and click the Chart Elements button next the chart. 
This will expand a menu of chart elements you can add to your chart. Place a check next to Gridlines 
to add gridlines. Remove the check to remove gridlines.

Each axis has two sets of gridlines: major and minor. Major units are the ones that display a label. 
Minor units are those in between the labels. If you’re working with a chart that has a secondary  
category axis, a secondary value axis, or a series axis (for a 3-D chart), the dialog box has additional 
options for three sets of gridlines.

A more direct way to remove a set of gridlines is to select the gridlines and press Delete.

Note 	

If a chart uses a secondary axis, you can specify either or both value axes to display  
gridlines. As you might expect, displaying two sets of gridlines in the same direction can 
be confusing and result in additional clutter. 

To modify the properties of a set of gridlines, select one gridline in the set (which selects all in the 
set) and access the Format Gridlines dialog box. Or, use the controls in the Chart Tools➜Format➜ 

Shape Styles group.

Note
	

You can’t apply different formatting to individual gridlines within a set of gridlines. All 
gridlines in a set are always formatted identically.

Working with Data Labels
For some charts, you may want to identify the individual data points in a series by displaying data 
labels.

Adding or removing data labels
To add data labels, activate the chart and click the Chart Elements button next the chart. This will 
expand a menu of chart elements you can add to your chart. Place a check next to Data Labels. 

To remove data labels from a particular series, select the data labels and press Delete. To remove a 
single data label, click the individual label once to select the series data labels; then click the  
individual label again. This will ensure that only the targeted label is selected. At this point, you can 
press Delete. 

Note 	

If an entire chart series is selected, data labels will be added to the selected series. If a 
single point is selected, a data label will be applied to only to the selected point. If a 
chart element other than a series (or single point) is selected, Excel adds data labels to 
all series in the chart.
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Editing data labels
After adding data labels to a series, you can apply formatting to the labels by right-clicking on the 
labels and selecting Format Data Labels. This will activate the Format Data Labels dialog box. To 
specify the contents of the data labels, use the Label Options tab of the Format Data Labels dialog 
box. Figure 7-31 shows this dialog box for a pie chart.

Note 	

When you click a data label, the labels for the entire series are selected. If you click a  
second time (on a single label), only that data label is selected. In other words, Excel lets 
you format all data labels at once or format just a single data label.

Figure 7-31: Options for displaying data labels.

The types of information that can be displayed in data labels are as follows:

➤	 The series name

➤	 The category name

➤	 The numeric value

➤	 The value as a percentage of the sum of the values in the series (for pie charts and doughnut 
charts only)

➤	 The bubble size (for bubble charts only)

Other options are as follows. Keep in mind that not all options are available for all chart types.

➤	 Show Leader Lines: If selected, Excel displays a line that connects the data label with the 
chart series data point.

➤	 Label Position: Specifies the location of the data labels, relative to each data point.
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➤	 Include Legend Key in Label: If selected, each data label displays its legend key image next  
to it.

➤	 Separator: If you specify multiple contents for the data labels, this control enables you to 
specify the character that separates the elements (a comma, a semicolon, a period, a space, 
or a line break).

The Format Data Labels dialog box also lets you specify a variety of other formatting options for your 
data labels.

The column chart in Figure 7-32 contains data labels that display category names and their values. 
These labels are positioned to appear on the Outside End. These data labels use the New Line  
separator option, so the value appears on a separate line. Because the category name is included in 
the data labels, the horizontal category axis labels aren’t necessary.

Figure 7-32: Data labels in a column chart.

Note 	

The data labels display the values for each data point. For this particular chart, it would 
be preferable to display the value as a percentage of the total. Unfortunately, the 
Percent option is available only for a pie or doughnut chart. The alternative is to  
calculate the percentages using formulas and then plot the percentage data rather than 
the actual value data.

Figure 7-33 shows a line chart in which the data labels are positioned on top of the (large) markers. 
The data labels were positioned using the Center option. 
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Figure 7-33: Positioning data labels on series markers.

Note 	

To make your markers large, right-click on any of the markers in your series and select 
Format Data Series. This will activate the Format Data Series dialog box. Click on the Fill 
& Line icon (the paint bucket) and choose Marker➜Maker Options. Adjust the Size  
property to make your markers as big as you need them to be. 

To override a particular data label with other text, select the label and enter the new text. To select an 
individual data label, click once to select all the data labels; then click the specific data label to select it.

To link a selected data label to a cell, follow these steps:

	 1.	 Click in the Formula bar.

	 2.	 Type an equal sign (=).

	 3.	 Click the cell that contains the text.

	 4.	 Press Enter.

After adding data labels, you’ll often find that the data labels aren’t positioned optimally. For  
example, one or more of the labels may be obscured by another data point or a gridline. If you select 
an individual label, you can drag the label to a better location.

Problems and limitations with data labels
As you work with data labels, you will probably discover that Excel’s Data Labels feature leaves a bit 
to be desired. For example, it would be nice to be able to specify a range of text to be used for the 
data labels. This would be particularly useful in scatter charts in which you want to identify each data 
point with a particular text item. Figure 7-34 shows a scatter chart. If you would like to apply data 
labels to identify the student for each data point, you’re out of luck.
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Figure 7-34: Excel provides no direct way to add descriptive data labels to the data points.

Despite what must amount to thousands of requests, Microsoft still has not added this feature to 
Excel! You need to add data labels and then manually edit each label.

Note 	

A few utility add-ins are available, which allow you to specify an arbitrary range of text 
to be used for data labels. One such product is Power Utility Pak, available from John 
Walkenbach’s website (http://spreadsheetpage.com).

As you work with data labels, you’ll find that this feature works best for series that contain a relatively 
small number of data points. The chart in Figure 7-35, for example, contains 24 data points. You can’t 
display all the data labels on this chart and keep the chart legible.

Figure 7-35: Data labels don’t work well for this chart.

One option is to delete some of the individual data labels. For example, you might want to delete all 
the data labels except those at the high and low points of the series. Deleting only certain data labels 
is, however, a manual process. To delete an individual data label, select it and press Delete. Using 
gridlines provides another way to let the reader discern the values for the data points. Yet another 
alternative is to use a data table, which is described in the next section.
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Working with a Chart Data Table
There may be situations where it’s valuable to show all the data values along with the plotted data 
points. However, you’ve adding data labels can inundate your audience with a bevy of numbers that 
muddle the chart.

Instead of using data labels, you can attach a Data Table to your Excel chart. A data table allows you 
to see the data values for each plotted data point, beneath the chart, showing the data without  
overcrowding the chart itself. Figure 7-36 shows a chart that includes a data table.

Figure 7-36: This chart includes a data table.

Note
	

This workbook, named data table.xlsx, is available at www.wiley.com/go/
exceldr with the example files for this book.

Adding and removing a data table
To add or remove data tables, activate the chart and click the Chart Elements button next the chart. 
This will expand a menu of chart elements you can add to your chart. Place a check next to Data 
Table to add a data table. Remove the check to remove the data table.

Problems and limitations with data tables
One problem with data tables, as noted previously, is that this feature is available for only a few chart 
types. Formatting options for a data table are relatively limited. Data table formatting changes are 
made in the Format Data Table dialog box.

The Fill tab is a bit misleading because it does not actually allow you to change the fill color for the 
data table. Rather, you are limited to formatting the background of the text and numbers in the data 
table.
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Unfortunately, you cannot apply different font formatting to individual cells or rows within the data 
table. You also can’t change the number formatting. The numbers displayed in a data table always 
use the same number formatting as the source data.

When you add a data table to a chart, the data table essentially replaces the axis labels on the  
horizontal axis. The first row of the data table contains these labels, so losing them isn’t a major  
problem. However, you will not be able to apply separate formatting to the axis labels — they will 
have the same formatting as the other parts of the data table.

Note 	

An exception to the behavior described in the preceding paragraph occurs with bar 
charts and charts with a time-scale category axis. For these types of charts, the data 
table is positioned below the chart and does not replace any axis labels.

Another potential problem with data tables occurs when they are used with embedded charts. If you 
resize the chart to make it smaller, the data table may not show all the data.

Using a data table is probably best suited for charts on chart sheets. If you need to show the data 
used in an embedded chart, you can do so using data in cells, which provides you with much more 
flexibility in terms of formatting.
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8
Components That  
Show Trending
In This Chapter

●	 Understanding basic dashboard trending concepts

●	 Comparing trends across multiple series

●	 Emphasizing distinct periods of time in your trends

●	 Working past other anomalies in trending data

One of the most common concepts used in dashboards and reports is the concept of trending. A trend is a 
measure of variance over some defined interval — typically time periods, like days, months, or years.

The reason trending is so popular is that it provides a rational expectation of what might happen in 
the future. If we know this book has sold 5,000 copies a month over the last 12 months, we have rea-
son to believe that sales next month will be around 5,000 copies. In short, trending tells you where 
you’ve been and where you might be going.

In this chapter, you explore basic trending concepts and some of the advanced dashboard tech-
niques you can use to take your trending components beyond simple line charts.

Trending Dos and Don’ts
Building trending components for your dashboards has some dos and don’ts. This section helps you 
avoid some common trending faux pas.
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Using chart types appropriate for trending
It would be nice if you could definitively say which chart type you should use when building  
trending components. But the truth is that no chart type is the silver bullet for all situations. For  
effective trending, you need to understand which chart types are most effective in different  
trending scenarios.

Using line charts
Line charts are the kings of trending. In business presentations, a line chart almost always indicates move-
ment across time. Even in areas not related to business, the concept of lines is used to indicate time — 
consider timelines, family lines, bloodlines, and so on. The benefit of using a line chart for trending is that 
it’s instantly recognized as a trending component, avoiding any delay in information processing.

Line charts are especially effective in presenting trends with many data points — as the top chart in 
the Figure 8-1 shows. You can also use a line chart to present trends for more than one time period, 
as shown in the bottom chart in Figure 8-1.

Figure 8-1: Line charts are the chart of choice when you need to show trending over time.

Using area charts
An area chart is essentially a line chart that’s been filled in. So, technically, area charts are appropriate 
for trending. They’re particularly good at highlighting trends over a long time span. For example, the 
chart in Figure 8-2 spans more than 120 days of data.

Using combination charts
If you’re trending one series of time, a line chart is absolutely the way to go. However, if you’re com-
paring two or more time periods on the same chart, combination charts may bring out the compari-
sons better.
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Figure 8-2: You can use area charts to trend over a long time span.

Figure 8-3 demonstrates how a combination chart can more easily call attention to the exact months 
when 2010 sales fell below 2009. A combination of line and column charts is a very effective way to 
show the difference in units sold between two time periods. We show you how to create this type of 
chart later in this chapter.

Figure 8-3: Using columns and lines emphasizes the trending differences between two time periods.

Starting the vertical scale at zero
The vertical axis on trending charts should almost always start at zero. The reason we say almost is 
because you may have trending data that contains negative values or fractions. In those situations, 
it’s generally best to keep Excel’s default scaling. However, in situations where there are only non-
negative integers, ensure that your vertical axis starts at zero.

The reason is that the vertical scale of a chart can have a significant impact on the representation of a 
trend. For instance, the two charts shown in Figure 8-4 contain the same data. The only difference is 
that in the top chart, we did nothing to fix the vertical scale assigned by Excel (it starts at 96), but in 
the bottom chart, we fixed the scale to start at zero.

Now, you may think the top chart is more accurate because it shows the ups and downs of the trend. 
However, if you look at the numbers closely, you see that the units represented went from 100 to  
107 in 12 months. That’s not exactly a material change, and it certainly doesn’t warrant such a  
dramatic chart. Actually, the trend is relatively flat, yet the top chart makes it look as though the 
trend is way up.

The bottom chart more accurately reflects the true nature of the trend. We achieved this effect by 
locking the Minimum value on the vertical axis to zero.

www.it-ebooks.info

http://www.it-ebooks.info/


Part II: Introducing Charts into Your Dashboards174

Figure 8-4: Vertical scales should always start at zero.

To adjust the scale of your vertical axis, follow these simple steps:

	 1.	 Right-click the vertical axis and choose Format Axis.

		  The Format Axis dialog box appears. (See Figure 8-5.)

	 2.	 In the Format Axis dialog box, expand the Axis Options section and set the Minimum value 
to 0.

	 3.	 (Optional) You can set the Major Unit value to half the Maximum value in your data.

		  This ensures that your trend line is placed in the middle of your chart.

	 4.	 Click the Close button (the x) to apply your changes.

Figure 8-5: Always set the Minimum value of your vertical axis to zero.
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Some of you would argue that the bottom chart shown in Figure 8-4 hides the small-
scale trending that may be important. That is, a seven unit difference may be very signif-
icant in some businesses. Well, if that’s true, why use a chart at all? If each unit has such 
an impact on the analysis, why use a broad-sweep representation like a chart? A table 
with conditional formatting will do a better job at highlighting small-scale changes than 
any chart can.

Leveraging Excel’s logarithmic scale
In some situations, your trending may start with very small numbers and end with very large num-
bers. In these cases, you end up with charts that don’t accurately represent the true trend. Take 
Figure 8-6, for instance. In this figure, you see the unit trending for both 2009 and 2010. As you can 
see in the source data, 2009 started with a modest 50 units. As the months progressed, the monthly 
unit count increased to 11,100 units through December 2010. Because the two years are on such dif-
ferent scales, it’s difficult to discern a comparative trending for the two years together.

Figure 8-6: A standard linear scale doesn’t allow for accurate trending in this chart.

The solution is to use a logarithmic scale instead of a standard linear scale.

Without going into high school math, a logarithmic scale allows your axis to jump from 1 to 10, to 
100 to 1,000, and so on without changing the spacing between axis points. In other words, the dis-
tance between 1 and 10 is the same as the distance between 100 and 1,000.

Figure 8-7 shows the same chart as the one in Figure 8-6, but in a logarithmic scale. Notice that the 
trending for both years is now clear and accurately represented.

Figure 8-7: Using the logarithmic scale helps bring out trending in charts that contain very small  
and very large values.

Tip
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To change the vertical axis of a chart to logarithmic scaling, follow these steps:

	 1.	 Right-click the vertical axis and choose Format Axis. The Format Axis dialog box appears.

	 2.	 Expand the Axis Options section and place a check next to Logarithmic scale, as shown in 
Figure 8-8.

Figure 8-8: Setting the vertical axis to Logarithmic scale.

Note 	

Logarithmic scales work only with positive numbers. 
 

Applying creative label management
As trivial as it may sound, labeling can be one of the sticking points to creating effective trending com-
ponents. Trending charts tend to hold lots of data points, whose category axis labels take up lots of 
room. Inundating users with a gaggle of data labels can definitely distract from the main message of 
the chart. In this section, you find a few tips to help manage the labels in your trending components. 

Abbreviating instead of changing alignment
Month names look and feel very long when you have to place them in a chart — especially when that 
chart must fit on a dashboard. However, the solution isn’t to change their alignment, as shown in 
Figure 8-9. Words that are placed on their sides inherently cause a reader to stop for a moment and 
read the labels. This isn’t ideal when you want them to think about your data and not spend time 
reading with their heads tilted.

Although it’s not always possible, the first option is always to keep your labels normally aligned. So 
instead of jumping right to the alignment option to squeeze them in, try abbreviating the month 
names. As you can see in Figure 8-9, even using the first letter of the month name is appropriate.
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Figure 8-9: Choose to abbreviate category names instead of changing alignment.

Implying labels to reduce clutter
When you’re listing the same months over the course of multiple years, you may be able to imply the 
labels for months instead of labeling each and every one of them.

Take Figure 8-10, for example. In this figure, you see a chart that shows trending through two years. There 
are so many data points that the labels are forced to be vertically aligned. To reduce clutter, as you can 
see, only certain months are explicitly labeled. The others are implied by a dot. To achieve this effect, you 
can simply replace the label in the original source data with a dot (or whatever character you like).

Figure 8-10: To save real estate on your dashboard, try labeling only certain data points.

Going vertical when you have too many data points for horizontal
Trending data by day is common, but it does prove to be painful if the trending extends to 30 days or 
more. In these scenarios, it becomes difficult to keep the chart to a reasonable size and even more 
difficult to effectively label it.
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One solution is to show the trending vertically using a bar chart. (See Figure 8-11.) With a bar chart, 
you have room to label the data points and keep the chart to a reasonable size. This isn’t something 
to aspire to, however. Trending vertically isn’t as intuitive and may not convey your information in a 
very readable form. Nevertheless, this solution can prove to be just the workaround you need when 
the horizontal view proves to be impractical.

Figure 8-11: A bar chart can prove to be effective when trending days extending to 30 or more data points.

Nesting labels for clarity
Often, the data you’re trying to chart has multiple time dimensions. In these cases, you can call out 
these dimensions by nesting your labels. Figure 8-12 demonstrates how including a year column 
next to the month labels clearly partitions each year’s data. You simply include the year column 
when identifying the data source for your chart.

Figure 8-12: Excel is smart enough to recognize and plot multiple layers of labels.
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Comparative Trending
Although the name is fancy, comparative trending is a simple concept. You chart two or more data 
series on the same chart so that the trends from those series can be visually compared. In this section, 
you walk through a few techniques that allow you to build components that present comparative 
trending.

Creating side-by-side time comparisons
Figure 8-13 shows a chart that presents a side-by-side time comparison of three time periods. With this 
technique, you can show different time periods in different colors without breaking the continuity of 
the overall trending.

Figure 8-13: You can show trends for different time periods side by side.

	 1.	 To create this type of chart, structure your source data similar to the structure shown in 
Figure 8-14.

		  Note that instead of placing all the data into one column, you’re staggering the data into 
respective years. This tells the chart to create three separate lines (allowing for the three  
colors).

	 2.	 Select the entire table and create a line chart.

		  This creates the chart shown in Figure 8-13.

	 3.	 If you want to get a bit fancy, click the chart to select it and then right-click. Select Change 
Chart Type from the context menu that opens.

	 4.	 When the Change Chart Type dialog box opens, select Stacked Column Chart.

		  As you can see in Figure 8-15, your chart now shows the trending for each year in columns.
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Figure 8-14: The source data needed to display side-by-side trends.

Figure 8-15: Change the chart type to Stacked Column Chart to present columns instead of lines.

Would you like a space in between the years? Adding a space in the source data (between each 
12-month sequence) adds a space in the chart. (See Figure 8-16.)

Figure 8-16: If you want to separate each year with a space, simply add a space into the source data.
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Creating stacked time comparisons
The stacked time comparison places two series on top of each other instead of side-by-side. 
Although this approach removes the benefit of having an unbroken overall trending, you get the 
benefit of an at-a-glance comparison within a compact space. Figure 8-17 illustrates a common 
stacked time comparison.

Figure 8-17: A stacked time comparison allows you to view and compare two years of data in a compact space.

	 1.	 Create a new structure and add data to it like the one shown in Figure 8-18.

Figure 8-18: Start with a structure containing the data for two time periods.

	 2.	 Highlight the entire structure and create a column chart.

	 3.	 Select and right-click any of the bars for the 2010 data series and then choose Change Series 
Chart Type.

	 4.	 When the Change Chart Type dialog box opens, select the Line type.

Tip 	

This technique works well with two time series. You generally want to avoid stacking 
any more than that. Stacking more than two series often muddies the view and  
causes users to constantly reference the legend to keep track of the series they’re  
evaluating.
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Trending with a secondary axis
In some trending components, you’ll have series that trend two very different units of measure. For 
instance, in Figure 8-19, you have a table that shows a trend for People Count and a trend for % of 
Labor Cost.

Figure 8-19: You often need to trend two very different units of measure, such as counts and percentages.

These are two very different units of measure that, when charted, produce the unimpressive chart 
you see in Figure 8-20. Because Excel builds the vertical axis to accommodate the largest number, 
the percentage of labor cost trending gets lost at the bottom of the chart. Even a logarithmic scale 
doesn’t help in this scenario.

Figure 8-20: The trending for percentage of labor cost gets lost at the bottom of the chart.

Because the default vertical axis (or primary axis) doesn’t work for both series, the solution is to create 
another axis to accommodate the series that doesn’t fit into the primary axis. This other axis is the 
secondary axis.

To place a data series on the secondary axis, follow these steps:

	 1.	 Right-click the data series and select Format Data Series.

		  The Format Data Series dialog box appears (see Figure 8-21).

	 2.	 In the Format Data Series dialog box, expand the Series Options section and then select the 
Secondary Axis radio button.
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Figure 8-21: Placing a data series on the secondary axis.

Figure 8-22 illustrates the newly added axis to the right of the chart. Any data series on the secondary 
axis has its vertical axis labels shown on the right.

Figure 8-22: Thanks to the secondary axis, both trends are clearly defined.

Again, changing the chart type of any one of the data series can help in comparing the two trends. In 
Figure 8-23, the chart type for the People Count trend has been changed to a column. Now you can 
easily see that although the number of people went down in November and December, the percent-
age of labor cost continues to rise.

Figure 8-23: Changing the chart type of one data series can underscore comparisons.

Tip 	

Technically, it doesn’t matter which data series you place on the secondary axis.  
A general rule is to place the problem data series on the secondary axis. In this scenario, 
because the data series for percentage of labor cost seems to be the problem, we place 
that series on the secondary axis.
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Emphasizing Periods of Time
Some of your trending components may contain certain periods where a special event occurred, 
causing an anomaly in the trending pattern. For instance, you may have an unusually large spike  
or dip in the trend caused by some occurrence in your organization. Or maybe you need to mix 
actual data with forecasts in your charting component. In such cases, it could be helpful to empha-
size specific periods in your trending with special formatting.

Formatting specific periods
Imagine you just created the chart component illustrated in Figure 8-24, and you want to explain the 
spike in October. You could, of course, use a footnote somewhere, but that would force your audience 
to look for an explanation elsewhere on your dashboard. Calling attention to an anomaly directly on 
the chart helps give your audience context without the need to look away from the chart.

Figure 8-24: The spike in October warrants emphasis.

A simple solution is to format the data point for October to display in a different color and then add a 
simple text box that explains the spike.

To format a single data point:

	 1.	 Click the data point once. 

		  This places dots on all the data points in the series.

	 2.	 Click the data point again to ensure Excel knows you’re formatting only that one data point.

		  The dots disappear from all but the target data point.

	 3.	 Right-click and select Format Data Point. 

		  The Format Data Point dialog box opens, as shown in Figure 8-25. The idea is to adjust the 
formatting properties of the data point as you see fit.

Note 	

The dialog box shown in Figure 8-25 is for a column chart. Different chart types have  
different options in the Format Data Point dialog box. Nevertheless, the idea remains 
the same in that you can adjust the properties in the Format Data Point dialog box to 
change the formatting of a single data point.
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Figure 8-25: The Format Data Point dialog box gives you formatting options for a single data point.

After changing the fill color of the October data point and adding a text box with some context, the 
chart nicely explains the spike. (See Figure 8-26.)

Figure 8-26: The chart now draws attention to the spike in October and provides instant context via a text box.

Note 	

To add a text box to a chart, click the Insert tab on the Ribbon and select the Text Box 
icon. Then click inside the chart to create an empty text box, which you can fill with your 
words.

Using dividers to mark significant events
Every now and then a particular event shifts the entire paradigm of your data permanently. A good 
example is a price increase. The trend shown in Figure 8-27 has been permanently affected by a price 
increase implemented in October. As you can see, a dividing line (along with some labeling) provides 
a distinct marker for the price increase, effectively separating the old trend from the new.
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Figure 8-27: Use a simple line to mark particular events along a trend.

Although there are lots of fancy ways to create this effect, you will rarely need to get any fancier than 
manually drawing a line yourself. To draw a dividing line inside a chart, take the following steps:

	 1.	 Click the chart to select it.

	 2.	 Select the Insert tab on the Ribbon and click the Shapes drop-down command.

	 3.	 Select the line shape, go to your chart, and draw the line where you want it.

	 4.	 Right-click your newly drawn line and select Format Shape.

	 5.	 Use the Format Shape dialog box to format your line’s color, thickness, and style.

Representing forecasts in your trending components
It’s common to be asked to show both actual data and forecast as a single trending component. 
When you do show the two together, you want to ensure that your audience can clearly distinguish 
where actual data ends and where forecasting begins. Take a look at Figure 8-28.

Figure 8-28: You can easily see where sales trending ends and forecast trending begins.

The best way to achieve this effect is to start with a data structure similar to the one shown in  
Figure 8-29. As you can see, sales and forecasts are in separate columns so that when charted,  
you get two distinct data series. Also note that the value in cell B14 is actually a formula referencing 
C14. This value serves to ensure a continuous trend line (with no gaps) when the two data series  
are charted together.
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Figure 8-29: Start with a table that places your actual data and your forecasts in separate columns.

When you have the appropriately structured dataset, you can create a line chart. At this point, you 
can apply special formatting to the 2013 forecast data series. Follow these steps:

	 1.	 Click the data series that represents the 2013 forecast.

		  This places dots on all the data points in the series.

	 2.	 Right-click and select Format Data Series.

		  This opens the Format Data Series dialog box. When the Format Data Series dialog box 
opens, you can adjust the properties to format the series color, thickness, and style.

Other Trending Techniques
In this section, you explore a few techniques that go beyond the basic concepts covered so far.

Avoiding overload with directional trending
Do you work with a manager who is crazy for data? Are you getting headaches from trying to 
squeeze three years of monthly data into a single chart? Although it’s understandable to want to see 
a three-year trend, placing too much information on a single chart can make for a convoluted trend-
ing component that tells you almost nothing.

When you’re faced with the need to display impossible amounts of data, step back and think about 
the true purpose of the analysis. When your manager asks for a three-year sales trend by month, 
what’s he really looking for? It could be that he’s really asking whether current monthly sales are 
declining when compared to historical data. Do you really need to show each and every month or 
can you show the directional trend?

A directional trend is one that uses simple analysis to imply a relative direction of performance. The 
key attribute of a directional trend is that the data used is often a set of calculated values as opposed 
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to actual data values. For instance, instead of charting each month’s sales for a single year, you could 
chart the average sales for Q1, Q2, Q3, and Q4. With such a chart, you get a directional idea of 
monthly sales, without the need to look into detailed data.

Take a look at Figure 8-30, which shows two charts. The bottom chart trends each year’s monthly 
data in a single trending component. You can see how difficult it is to discern much from this chart. It 
looks like monthly sales are dropping in all three years. The top chart shows the same data in a direc-
tional trend, showing average sales for key time periods. The trend really jumps at you, showing that 
sales have flattened out after healthy growth in 2011 and 2012.

Figure 8-30: Directional trending (bottom) can help you reveal trends that may be hidden  
in more complex charts.

Smoothing data
Certain lines of business lend themselves to wide fluctuations in data from month to month. For instance, 
a consulting practice may go months without a steady revenue stream before a big contract comes along 
and spikes the sales figures for a few months. Some call these ups and downs seasonality or business 
cycles.

Whatever you call them, wild fluctuations in data can prevent you from effectively analyzing and pre-
senting trends. Figure 8-31 demonstrates how highly volatile data can conceal underlying trends.

This is where the concept of smoothing comes in. Smoothing does just what it sounds like — it forces 
the range between the highest and lowest values in a dataset to smooth to a predictable range with-
out disturbing the proportions of the dataset.
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Figure 8-31: The volatile nature of this data makes it difficult to seek the underlying trend.

You can use lots of different techniques to smooth a dataset. Take a moment to walk through two of 
the easier ways to apply smoothing.

Smoothing with Excel’s moving average functionality
Excel has a built-in smoothing mechanism in the form of a moving average trend line. That is, a trend 
line that calculates and plots the moving average at each data point. A moving average is a statistical 
operation that is used to track daily, weekly, or monthly patterns. A typical moving average starts  
calculating the average of a fixed number of data points; then with each new day’s (or week’s or 
month’s) numbers, the oldest number is dropped, and the newest number is included in the average. 
This calculation is repeated over the entire dataset, creating a trend that represents the average at 
specific points in time.

Figure 8-32 illustrates how Excel’s moving average trend line can help smooth volatile data, high-
lighting a predictable range.

In this example, a four-month moving average is applied.

Figure 8-32: A four–month moving average trend line is added to smooth the volatile nature  
of the original data.
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To add a moving average trend line, follow these steps:

	 1.	 Right-click the data series that represents the volatile data and then select Add Trendline.

	 2.	 In the Format Trendline dialog box that opens (see Figure 8-33), select Moving Average and 
then specify the number of periods.

		  In this case, Excel will average a four–month moving trend line.

Figure 8-33: Applying a four–month moving average trend line.

Creating your own smoothing calculation
As an alternative to Excel’s built-in trend lines, you can create your own smoothing calculation and 
simply include it as a data series in your chart. In Figure 8-34, a calculated column (appropriately 
called smoothing) provides the data points needed to create a smoothed data series. 

Figure 8-34: A calculated smoothing column feeds a new series to your chart.
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In this example, the second row of the smoothing column contains a simple average formula that 
averages the first data point and the second data point. Note that the reference to the first data point 
(cell D2) is locked as an absolute value with dollar ($) signs. This ensures that when this formula is 
copied down, the range grows to include all previous data points.

Once the formula is copied down to fill the entire smoothing column, it can simply be included in the 
data source for the chart. Figure 8-35 illustrates the smoothed data plotted as a line chart.

Figure 8-35: Plotting the smoothed data reveals the underlying trend.

www.it-ebooks.info

http://www.it-ebooks.info/


Part II: Introducing Charts into Your Dashboards192

www.it-ebooks.info

http://www.it-ebooks.info/


193

9
Components That  
Group Data
In This Chapter

●	 Showing top and bottom views

●	 Tracking progress using histograms

●	 Emphasizing top values in charts

It’s often helpful to organize your data into logical groups. Grouping allows you to focus on manage-
able sets of information that have key attributes. For example, instead of looking at all customers in 
one giant view, you can analyze customers who buy only one product. This allows you to focus atten-
tion and resources on those customers who have the potential to buy more products. The benefit is 
that you can more easily pick out groups that fall outside the norm for your business.

In this chapter, you focus on how you can organize groups of data using dashboard components.

Listing Top and Bottom Values
When you look at the list of Fortune 500 companies, you often look for the top 20 companies. Then 
perhaps you look at who eked out at the bottom 20 slots. It’s unlikely that you check to see which 
company came in at number 251. It’s not necessarily because you don’t care about number 251; it’s 
just that you can’t spend the time or energy to process all 500 companies. So you process the top 
and bottom of the list.

This is the same concept behind creating top and bottom displays. Your audience has only a certain 
amount of time and resources to dedicate to solving any issues you can emphasize in your dash-
board. Showing them the top and bottom values in your data can help them pinpoint where and 
how they can have the most impact with the time and resources they do have.
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Organizing source data
The top and bottom displays you create can be as simple as source data that you incorporate into 
your dashboard. Typically placed to the right of a dashboard, this data can emphasize details a man-
ager may use to take action on a metric. For example, the simple dashboard in Figure 9-1 shows sales 
information with top and bottom sales reps.

Figure 9-1: Top and bottom displays that emphasize certain metrics.

To get a little fancier, you can supplement your top and bottom displays with some ranking informa-
tion, some in-cell bar charts, or some conditional formatting (see Figure 9-2).

You can create the in-cell bar charts with the Data Bars conditional formatting function, covered in 
Chapter 4. The arrows are also simple conditional formatting rules that are evaluated against the vari-
ance in current and last months’ ranks.

Figure 9-2: You can use some conditional formatting to add visual components to your top and bottom displays.
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Using pivot tables to get top and bottom views
A pivot table is an amazing tool that can help you create interactive reporting. If you’re new to  
pivot tables, fear not. You learn about them in detail in Part IV of this book. For now, take a moment  
to go through an example of how pivot tables can help you build interactive top and bottom  
displays.

On the Web	

You can open the Chapter 9 Samples.xlsx file, found on this book’s companion 
website at www.wiley.com/go/exceldr to follow along. 

Follow these steps to display a Top filter with a pivot table:

	 1.	 Start with a pivot table that shows the data you want to display with your top and bottom 
views.

		  In this case, the pivot table shows Sales Rep and Sales_Amount (see Figure 9-3).

Figure 9-3: Start with a pivot table that contains the data you want to filter.

	 2.	 Right-click on the field you want to use to determine the top values. In this example, you use 
the Sales Rep field. Choose Filter➜Top 10 (see Figure 9-4).

Figure 9-4: Select the Top 10 filter option.
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		  The Top 10 Filter (Sales Rep) dialog box appears (see Figure 9-5).

Figure 9-5: Specify the filter you want to apply.

	 3.	 In the Top 10 Filter (Sales Rep) dialog box, define the view you’re looking for. In this example, 
you want the Top 10 Items (Sales Reps) as defined by the Sales_Amount field. 

	 4.	 Click OK to apply the filter.

		  At this point, your pivot table is filtered to show you the top ten sales reps for the selected 
Region and Market. You can change the Market filter to Charlotte and get the top ten sales 
reps for Charlotte only (see Figure 9-6).

	 5.	 To view the bottom ten Sales Rep list, copy the entire pivot table and paste it next to the 
existing one.

	 6.	 Repeat Steps 2–4 in the newly copied pivot table, except this time choose to filter on the  
bottom ten items as defined by the Sales_Amount field.

If all went well, you now have two pivot tables similar to Figure 9-7: one that shows the top ten sales 
reps and one that shows the bottom ten. You can link back to these two pivot tables in the analysis 
layer of your data model using formulas. This way, when you update the data, your top and bottom 
values display the new information.

Figure 9-6: You can interactively filter your pivot table report to instantly show the top ten sales reps  
for any Region and Market.
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Figure 9-7: You now have two pivot tables that show top and bottom displays.

Note 	

If there’s a tie for any rank in the top or bottom values, Excel shows you all the tied 
records. This means that you may get more than the number you filtered for. If you fil-
tered for the top 10 sales reps and there’s a tie for the number 5 rank, Excel shows you 
11 sales reps (both reps ranked at number 5 will be shown).

Using Histograms to Track Relationships 
and Frequency
A histogram is essentially a graph that plots frequency distribution. A frequency distribution shows 
how often an event or category of data occurs. With a histogram, you can visually see the general  
distribution of a certain attribute.

Take a look at the histogram shown in Figure 9-8. This histogram represents the distribution of units 
sold in one month among your sales reps. As you can see, most reps sell somewhere between 5 and  
25 units per month. As a manager, you want the hump in the chart to move to the right — more people 
selling a higher number of units per month. So you set a goal to have a majority of your sales reps sell 
between 15 and 25 units within the next 3 months. With this histogram, you can visually track the  
progress toward that goal.

Figure 9-8: A histogram showing the distribution of units sold per month among your sales force.
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This chapter discusses how to create a histogram using formulas and pivot tables. The techniques 
covered here fit nicely in data models where you separate data, analysis, and presentation informa-
tion. In addition, these techniques allow for a level of automation and interactivity that comes in 
handy when updating dashboards each month.

Cross-Ref

	

We discuss how to develop a data model in Chapter 11.

Adding formulas to group data
First, you need a table that contains your raw data. The raw data ideally consists of records that rep-
resent unique counts for the data you want to group. For instance, the raw data table in Figure 9-9 
contains unique sales reps and the number of units each has sold. Follow these steps to create a for-
mula-driven histogram:

	 1.	 Before you create your histogram, you need to create a bin table (see Figure 9-9).

		  The bin table dictates the grouping parameters that are used to break your raw data into the 
frequency groups. The bin table tells Excel to cluster all sales reps selling fewer than 5 units 
into the first frequency group, any sales reps selling 5 to 14 units in the second frequency 
group, and so on.

Figure 9-9: Start with your raw data table and a bin table.

Tip 	

You can freely set your own grouping parameters when you build your bin table. 
However, it’s generally a good idea to keep your parameters as equally spaced as possi-
ble. We typically end our bin tables with the largest number in our dataset. This allows 
us to have clean groupings that end in a finite number — not in an open-ended greater 
than designation.
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	 2.	 Create a new column that holds the FREQUENCY formulas. Name the new column Frequency 
Formulas, as seen in Figure 9-10.

		  Excel’s FREQUENCY function counts how often values occur within the ranges you specify in 
a bin table.

	 3.	 Select a number of cells equal to the cells in your bin table.

	 4.	 Type the FREQUENCY formula you see in Figure 9-10 and then press Ctrl+Shift+Enter on your 
keyboard.

Note 	

The FREQUENCY function does have a quirk that often confuses first-time users. The 
FREQUENCY function is an array formula — that is, it’s a formula that returns many val-
ues at one time. In order for this formula to work properly, you have to press 
Ctrl+Shift+Enter after typing the formula. If you just press the Enter key, you won’t get 
the results you need.

Figure 9-10: Type the FREQUENCY formula you see here; be sure to hold down the Ctrl+Shift+Enter 
keys on your keyboard.

At this point, you should have a table that shows the number of sales reps that fall into each of your 
bins. You could chart this table, but the data labels would come out wonky. For the best results, build 
a simple chart feeder table that creates appropriate labels for each bin, which you do as follows:

	 1.	 Create a new table that feeds the charts a bit more cleanly (see Figure 9-11). Use a simple for-
mula that concatenates Bins into appropriate labels. Use another formula to bring in the 
results of your FREQUENCY calculations.

		  In Figure 9-11, we made the formulas in the first record of the chart feeder table visible. 
These formulas are essentially copied down to create a table appropriate for charting.

	 2.	 Use your newly created chart feeder table to plot the data into a column chart.

		  Figure 9-12 illustrates the resulting chart. You can certainly use the initial column chart as 
your histogram.

		  If you like your histograms to have spaces between the data points, you’re done. If you like 
the continuous blocked look you get with no gaps between the data points, follow the next 
few steps.
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	 3.	 Right-click any of the columns in the chart and choose Format Data Series.

		  The Format Data Series dialog box appears.

	 4.	 Adjust the Gap Width property to 0% (see Figure 9-13).

Figure 9-11: Build a simple chart feeder table that creates appropriate labels for each bin.

Figure 9-12: Plot your histogram data into a column chart.

Figure 9-13: To eliminate the spaces between columns, set the Gap Width to 0%.
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Adding a cumulative percent
A nice feature to add to your histograms is a cumulative percent series. With a cumulative percent 
series, you can show the percent distribution of the data points to the left of the point of interest.

Figure 9-14 shows an example of a cumulative percent series. At each data point in the histogram, 
the cumulative percent series tells you the percent of the population that fills all the bins up to that 
point. For instance, you can see that 25% of the sales reps denoted sold 15 units or fewer. In other 
words, 75% of the sales reps sold more than 15 units.

Take another look at the chart in Figure 9-14 and find the point where you see 75% on the cumula-
tive series. At 75%, look at the label for that Bin range (you see 35–45). The 75% mark tells you that 
75% of sales reps sold between 0 and 45 units. This means that only 25% of sales reps sold more than 
45 units.

Figure 9-14: The cumulative percent series shows the percent of the population that fills all the bins up to each 
point in the histogram.

To create a cumulative percent series for your histogram, follow these steps:

	 1.	 After you perform Steps 1 through 5 to create a histogram (outlined earlier in this chapter), 
add a column to your chart feeder that calculates the percent of total sales reps for the first 
bin (see Figure 9-15).

		  Note the dollar symbols ($) used in the formula to lock the references while you copy the  
formula down.

Figure 9-15: In a new column, create a formula that calculates the percent of total sales reps for the 
first bin.
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	 2.	 Copy the formula down for all the bins in the table.

	 3.	 Use the chart feeder table to plot the data into a line chart.

		  As you can see in Figure 9-16, the resulting chart needs some additional formatting.

Figure 9-16: Your initial chart will need some formatting to make it look like a histogram.

	 4.	 Right-click the series that makes up your histogram (Count of Sales Rep), select Change Chart 
Type, and then change the chart type to a column chart.

	 5.	 Right-click any of the columns in the chart and choose Format Data Series.

	 6.	 Adjust the Gap Width property to 0% (refer to Figure 9-13).

	 7.	 Right-click Cumulative Percent series and choose Format Data Series.

	 8.	 In the Format Data Series dialog box, change the Plot Series On option to Secondary Axis.

	 9.	 Right-click Cumulative Percent series and choose Add Data Labels.

At this point, your base chart is complete. It should look similar to the one shown at the beginning of 
this section in Figure 9-14. When you get to this point, you can adjust the colors, labels, and other 
formatting.

Using a pivot table to create a histogram
Did you know you can use a pivot table as the source for a histogram? That’s right. With a little-
known trick, you can create a histogram that is as interactive as a pivot chart!
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As in the formula-driven histogram, the first step in creating a histogram with a pivot table is to cre-
ate a frequency distribution. 

Cross-Ref	

If you’re new to pivot tables, rest easy. In Part IV of this book, we cover the ins and outs 
of pivot tables. This section allows you to get a preview of the types of advanced analy-
sis you can accomplish with pivot tables.

	 1.	 Create a pivot table and plot the data values in the row area (not the data area). As you can 
see in Figure 9-17, the SumOfSales Amount field is placed in the ROWS area. Place the Sales 
Rep field in the VALUES area as a Count.

Figure 9-17: Place your data values in the ROWS area and the Sales Rep field in the VALUES area as a Count.

	 2.	 Right-click any value in the ROWS area and choose Group.

		  The Grouping dialog box appears (see Figure 9-18).

Figure 9-18: The Grouping dialog box.

	 3.	 In the dialog box, set the start and end values and then set the intervals.

		  This essentially creates your frequency distribution. In Figure 9-18, the distribution is set to 
start at 5,000 and to create groups in increments of 1,000 until it ends at 100,000.
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	 4.	 Click OK to confirm your settings.

		  The pivot table calculates the number of sales reps for each defined increment, just as in a fre-
quency distribution. (See Figure 9-19.) You can now leverage this result to create a histogram!

Figure 9-19: The result of grouping the values in the Row area is a frequency distribution that can be 
charted into a histogram.

The obvious benefit to this technique is that after you have a frequency distribution and a histogram, 
you can interactively filter the data based on other dimensions, like Region and Market. For instance, 
you can see the histogram for the Canada market and then quickly switch to see the histogram for 
the California market.

Tip

	

Note that you can’t add cumulative percentages to a histogram based on a pivot table. 

Emphasizing Top Values in Charts
Sometimes a chart is indeed the best way to display a set of data, but you still want to call attention 
to the top values in that chart. In these cases, you can use a technique that actually highlights the top 
values in your charts. That is to say, you can use Excel to figure out which values in your data series 
are in the top nth value and then apply special formatting to them. Figure 9-20 illustrates an example 
where the top five quarters are highlighted and given a label.

The secret to this technique lies in Excel’s obscure LARGE function. The LARGE function returns the nth 
largest number from a dataset. In other words, you tell it where to look and the number rank you want.

To find the largest number in the dataset, you enter the formula LARGE(Data_Range, 1). To find the 
fifth largest number in the dataset, you use LARGE(Data_Range, 5). Figure 9-21 illustrates how the 
LARGE function works.
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Figure 9-20: This chart highlights the top five quarters with different font and labeling.

Figure 9-21: Using the LARGE function returns the nth largest number from a dataset.

The idea is fairly simple. In order to identify the top five values in a dataset, you first need to identify 
the fifth largest number (LARGE function to the rescue) and then test each value in the dataset to see 
if it’s bigger than the fifth largest number. Here’s what you do:

	 1.	 Build a chart feeder that consists of formulas that link back to your raw data. The feeder 
should have two columns: one to hold data that isn’t in the top five and one to hold data 
that is in the top five (see Figure 9-22).

	 2.	 In the first row of the chart feeder, enter the formulas shown in Figure 9-22.

		  The formula for the first column (F4) checks to see if the value in cell C4 is less than the num-
ber returned by the LARGE formula (the fifth largest value). If it is, the value in cell C4 is 
returned. Otherwise, NA is used. The formula for the second column works in the same way, 
except the IF statement is reversed: If the value in cell C4 is greater than or equal to the num-
ber returned by the LARGE formula, then the value is returned; otherwise NA is used. 

	 3.	 Copy the formulas down to fill the table.
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	 4.	 Use the chart feeder table to plot the data into a stacked column chart.

		  You immediately see a chart that displays two data series: one for data points not in the top 
five and one for data points in the top five (see Figure 9-23).

Figure 9-22: Build a new chart feeder that consists of formulas that plot values into one of two columns.

Figure 9-23: After adding data labels to the top five data series and doing a bit of formatting, your 
chart should look similar to the one shown here.

		  Notice in Figure 9-23 that the chart shows some rogue zeros. You can fix the chart so that the 
zeros don’t display by performing the next few steps.

	 5.	 Right-click any of the data labels for the top five series and choose Format Data Labels.

	 6.	 In the Format Data Labels dialog box, expand the Numbers section and select Custom in the 
Category list.

	 7.	 Enter #,##0;; as the custom number format, as shown in Figure 9-24.

	 8.	 Click the Add button and then click Close.
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Figure 9-24: Entering #,##0;; as the custom format for a data label renders all zeros in that data series hidden.

When you go back to your chart, you see that the rogue zeros are now hidden and your chart is ready 
for colors, labels, and other formatting you want to apply.

You can apply the same technique to highlight the bottom five values in your data set. The only differ-
ence is that instead of using the LARGE function, you use the SMALL function. Whereas the LARGE func-
tion returns the largest nth value from a range, the SMALL function returns the smallest nth value.

Figure 9-25 illustrates the formulas you use to apply the same technique outlined here for the bot-
tom five values.

Figure 9-25: Use the SMALL function to highlight the bottom values in a chart.

The formula for the first column (F4) checks to see if the value in cell C22 is greater than the number 
returned by the SMALL formula (the fifth smallest value). If it is, the value in cell C22 is returned. 
Otherwise, NA is used. The formula for the second column works in the same way, except the IF state-
ment is reversed: If the value in cell C22 is greater than the number returned by the SMALL formula, 
then NA is used; otherwise, the value is returned.
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10
Components That  
Show Performance 
Against a Target
In This Chapter

●	 Using variance to compare performance with a target

●	 Displaying performance against organizational trends

●	 Creating a thermometer-style chart

●	 Creating a bullet graph

●	 Showing performance against a target range

No matter what business or industry you talk about, you can always point to some sort of target to 
measure data against. That target could be anything from a certain amount of revenue to the num-
ber of boxes shipped or phone calls made. The business world is full of targets and goals. Your job is 
to find effective ways to represent performance against those targets.

What is performance against a target? Imagine that your goal is to break the land speed record (cur-
rently 763 miles per hour). Your target speed is 771 miles per hour. After you jump into your car and 
go as fast as you can, you will have a final speed of some number. That number is considered to be 
your performance against the target.

In this chapter, we discuss some new and interesting ways to create components that show perfor-
mance against a target.
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Showing Performance with Variances
The standard way of displaying performance against a target is to plot the target and then plot the perfor-
mance. This is usually done with a line chart or a combination chart, such as the one shown in Figure 10-1.

Figure 10-1: A typical chart showing performance against a target.

Although this chart allows you to visually pick the points where performance exceeded or fell below 
targets, it gives you a rather one-dimensional view and provides minimal information. Even if this 
chart offered labels that showed the actual percent of sales revenue versus target, you’d still get only 
a mildly informative view.

A more impactful and informative way of displaying performance against a target is to plot the vari-
ances between the target and the performance. Figure 10-2 shows the same performance data you 
see in Figure 10-1, but includes the variances (sales revenue minus target). This way, you not only see 
where performance exceeded or fell below targets but also you get an extra layer of information 
showing the dollar impact of each rise and fall.

Figure 10-2: Consider using variances to plot performance against a target.

Showing Performance Against 
Organizational Trends
The target you use to measure performance doesn’t necessarily have to be set by management or 
organizational policy. In fact, some of the things you measure may never have a target or goal set for 
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them. In situations where you don’t have a target to measure against, it’s often helpful to measure 
performance against some organizational statistic.

For example, the component in Figure 10-3 measures the sales performance for each division against 
the median sales for all the divisions. You can see that divisions 1, 3, and 6 fall well below the median 
for the group.

Figure 10-3: Measuring data when there’s no target for a measure.

Here’s how you create a median line similar to the one you see in Figure 10-3:

	 1.	 Start a new column next to your data and type the simple MEDIAN formula, as shown in 
Figure 10-4.

		  Note that this formula can be any mathematical or statistical operation that works for the 
data you’re representing. Just ensure that the values returned are the same for the entire col-
umn. This gives you a straight line.

Figure 10-4: Start a new column and enter a formula.

	 2.	 Copy the formula down to fill the table.

		  Again, all the numbers in the newly created column should be the same.

	 3.	 Plot the table into a column chart.

	 4.	 Right-click the Median data series and choose Change Series Chart Type.

	 5.	 Change the chart type to a line chart.
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Using a Thermometer-Style Chart
A thermometer-style chart offers a unique way to view performance against a goal. As the name 
implies, the data points shown in this type of chart resemble a thermometer. Each performance  
value and its corresponding target are stacked on top of one another, giving an appearance similar 
to that of mercury rising in a thermometer. In Figure 10-5, you see an example of a thermometer-
style chart.

Figure 10-5: Thermometer-style charts offer a unique way to show performance against a goal.

To create this type of chart, follow these steps:

	 1.	 Starting with a table that contains revenue and target data, plot the data into a new column 
chart.

	 2.	 Right-click the Revenue data series and choose Format Data Series.

	 3.	 In the Format Data Series dialog box, select the Secondary Axis.

	 4.	 Go back to your chart and delete the new vertical axis that was added; it’s the vertical axis to 
the right of the chart.

	 5.	 Right-click the Target series and choose Format Data Series.

	 6.	 In the dialog box, adjust the Gap Width property so that the Target series is slightly wider 
than the Revenue series — between 45% and 55% is typically fine.

Using a Bullet Graph
A bullet graph is a type of column/bar graph developed by visualization expert Stephen Few to serve 
as a replacement for dashboard gauges and meters. He developed bullet graphs to allow for the 
clear display of multiple layers of information without occupying a lot of space on a dashboard. A 
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bullet graph, as seen in Figure 10-6, contains a single performance measure (such as YTD [year-to-
date] revenue); compares that measure to a target; and displays it in the context of qualitative 
ranges, such as Poor, Fair, Good, and Very Good.

Figure 10-6: Bullet graphs display multiple perspectives in an incredibly compact space.

Figure 10-7 breaks down the three main parts of a bullet graph. The performance bar represents the 
performance measure. The target marker represents the comparative measure. And the background 
fills represent the qualitative range.

Figure 10-7: The parts of a bullet graph.

Creating a bullet graph
Creating a bullet graph in Excel involves quite a few steps, but it isn’t necessarily difficult. Follow 
these steps to create your first bullet graph:

	 1.	 Start with a data table that gives you all the data points you need to create the three main 
parts of the bullet graph.

		  Figure 10-8 illustrates what that data table looks like. The first four values in the data set 
(Poor, Fair, Good, and Very Good) make up the qualitative range. You don’t have to have  
four values — you can have as many or as few as you need. In this scenario, you want the 
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qualitative range to span from 0 to 100%. Therefore, the percentages (75%, 15%, 10%, and 
5%) must add up to 100%. Again, this can be adjusted to suit your needs. The fifth value in 
Figure 10-8 (Value) creates the performance bar. The sixth value (Target) makes the target 
marker.

Figure 10-8: Start with data that contains the main data points of the bullet graph.

	 2.	 Select the entire table and plot the data on a stacked column chart.

		  The chart that’s created is initially plotted in the wrong direction.

	 3.	 To fix the direction, click the chart and select the Switch Row/Column button, as shown in 
Figure 10-9.

Figure 10-9: Switch the orientation of the chart to read from columns.

	 4.	 Right-click the Target series and choose Change Series Chart Type. Use the Change Chart 
Type dialog box to change the Target series to a Stacked Line with Markers and to place it on 
the secondary axis (see Figure 10-10). After you confirm your change, the Target series will 
show on the chart as a single dot.
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Figure 10-10: Use the Change Chart Type dialog box to change the Target series to a Stacked Line with 
Markers and place it on the secondary axis.

	 5.	 Right-click the Target series again and choose Format Data Series to open that dialog box. 
Click the Marker option and adjust the marker to look like a dash, as shown in Figure 10-11.

Figure 10-11: Adjust the marker to a dash.

	 6.	 Still in the Format Data Series dialog box, click the Fill & Line icon (the paint bucket). Expand 
the Fill section and Solid Fill property to set the color of the marker to a noticeable color  
like red.

	 7.	 Still in the Format Data Series dialog box, expand the Border section and set the Border to  
No Line.

	 8.	 Go back to your chart and delete the new secondary axis that was added to the right of your 
chart (see Figure 10-12).

		  This is an important step to ensure that the scale of the chart is correct for all data points.

www.it-ebooks.info

http://www.it-ebooks.info/


Part II: Introducing Charts into Your Dashboards216

Figure 10-12: Be sure to delete the newly created secondary vertical axis.

	 9.	 Right-click the Value series and choose Format Data Series.

	 10.	 In the Format Data Series dialog box, click Secondary Axis.

	 11.	 Still in the Format Data Series dialog box under Series Options, adjust the Gap Width prop-
erty so that the Value series is slightly narrower than the other columns in the chart — 
between 205% and 225% is typically okay.

	 12.	 Still in the Format Data Series dialog box, click the Fill icon (the paint bucket), expand the Fill 
section, and then select the Solid fill option to set the color of the Value series to black.

	 13.	 All that’s left to do is change the color for each qualitative range to incrementally lighter 
hues.

At this point, your bullet graph is essentially done! You can apply whatever minor formatting adjust-
ments to size and shape the chart to make it look the way you want. Figure 10-13 shows the newly 
created bullet graph formatted with a legend and horizontal labels.

Figure 10-13: Your formatted bullet graph.

Adding data to your bullet graph
After you’ve built your chart for the first performance measure, you can use the same chart for any 
additional measures. Take a look at Figure 10-14.
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Figure 10-14: To add more data to your chart, manually expand the chart’s data source range.

As you can see in Figure 10-14, you’ve already created this bullet graph with the first performance 
measure. Imagine that you add two more measures and want to graph those. Here’s how to do so:

	 1.	 Click the chart so that the blue outline appears around the original source data.

	 2.	 Hover your mouse over the blue dot in the lower-right corner of the blue box.

		  Your cursor turns into an arrow, as seen in Figure 10-14.

	 3.	 Click and drag the blue dot to the last column in your expanded data set.

Figure 10-15 illustrates how the new data points are added without one ounce of extra work!

Figure 10-15: Expanding the data source automatically creates new bullet graphs.

Final thoughts on formatting bullet graphs
Before wrapping up this introduction to bullet graphs, we discuss two final thoughts on formatting:

➤	 Creating qualitative bands

➤	 Creating horizontal bullet graphs
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Creating qualitative bands
First, if the qualitative ranges are the same for all the performance measures in your bullet graphs, 
you can format the qualitative range series to have no gaps between them. For instance, Figure 
10-16 shows a set of bullet graphs where the qualitative ranges have been set to 0 Gap Width. This 
creates the clever effect of qualitative bands.

Figure 10-16: Try setting gap widths to zero to create clean-looking qualitative bands.

	 1.	 Right-click any one of the qualitative series and choose Format Data Series.

	 2.	 In the Format Series dialog box, adjust the Gap Width property to 0%.

Creating horizontal bullet graphs
If you’re waiting for the section about horizontal bullet graphs, there’s good and bad news. The bad 
news is that creating a horizontal bullet graph from scratch in Excel is a much more complex 
endeavor than creating a vertical bullet graph — one that doesn’t warrant the time and effort it takes 
to create it.

The good news is that there is a clever way to get a horizontal bullet graph from a vertical one — and 
in three steps, no less. Here’s how you do it:

	 1.	 Create a vertical bullet graph.

		  Refer to the earlier section “Creating a bullet graph” for more on that topic.

	 2.	 Change the alignment for the axis and other labels on the bullet graph so that they’re 
rotated 270 degrees (see Figure 10-17).

	 3.	 Use Excel’s Camera tool to take a picture of the bullet graph.

		  After you have a picture, you can rotate it to be horizontal. Figure 10-18 illustrates a horizon-
tal bullet graph.
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Figure 10-17: Rotate all labels so that they’re on their sides.

Figure 10-18: A horizontal bullet graph.

The nifty thing about this trick is that because the picture is taken with the Camera tool, the picture 
automatically updates when the source table changes.

Tip 	

Never heard of the Camera tool? Check out Chapter 4 for a detailed look at benefits of 
the Camera tool. 

Showing Performance Against  
a Target Range
In some businesses, a target isn’t one value — it’s a range of values. That is to say, the goal is to stay 
within a defined target range. Imagine you manage a small business selling boxes of meat. Part of 
your job is to keep your inventory stocked between 25 and 35 boxes in a month. If you have too 
many boxes of meat, the meat will go bad. If you have too few boxes, you’ll lose money.

To track how well you do at keeping your inventory of meat between 25 and 35 boxes, you need a 
performance component that displays on-hand boxes against a target range. Figure 10-19 illustrates 
a component you can build to track performance against a target range. The gray band represents 
the target range you must stay within each month. The line represents the trend of on-hand meat.
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Figure 10-19: You can create a component that plots performance against a target range.

Obviously, the trick to this type of component is to set up the band that represents the target range. 
Here’s how you do it:

	 1.	 Set up a limit table where you can define and adjust the upper and lower limits of your target 
range.

		  Cells B2 and B3 in Figure 10-20 serve as the place to define the limits for the range.

	 2.	 Build a chart feeder that’s used to plot the data points for the target range.

		  This feeder consists of the formulas revealed in cells B8 and B9 in Figure 10-20.

		  The idea is to copy these formulas across all the data.

		  The values you see for Feb, Mar, and Apr are the results of these formulas.

	 3.	 Add a row for the actual performance values (see Figure 10-21).

		  These data points create the performance trend line.

Figure 10-20: Create a chart feeder that contains formulas that define the data points  
for the target range.

Figure 10-21: Add a row for the performance values.
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	 4.	 Select the entire chart feeder table and plot the data on a stacked column chart.

	 5.	 Right-click the Values series and choose Change Series Chart Type. Use the Change Chart Type 
dialog box to change the Values series to a Line and to place it on the secondary axis (see 
Figure 10-22). After confirming your change, the Values series will show on the chart as a line.

Figure 10-22: Use the Change Chart Type dialog box to change the Values series to a Line chart and 
place it on the secondary axis.

	 6.	 Go back to your chart and delete the new vertical axis that was added; it’s the vertical axis to 
the right of the chart.

	 7.	 Right-click the Lower Limit data series and choose Format Data Series.

	 8.	 In the Format Data Series dialog box, click the Fill icon. Choose the No Fill option under Fill 
and the No Line option under Border (see Figure 10-23).

Figure 10-23: Format the Lower Limit series so that it’s hidden.

	 9.	 Right-click the Upper Limit series and select Format Data Series.

	 10.	 In the Format Series dialog box, adjust the Gap Width property to 0%.

That’s it. All that’s left to do is apply the minor adjustments to colors, labels, and other formatting.
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